Subject: xml2rfc.ietf.org dead ?

From: Toerless Eckert <[email-masked]>
Date: Sun, 20 Mar 2016 18:40:46 -0700

Just for me ?  For quite a while now.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 20 Mar 2016 23:07:28 -0400

When I used XML2RFC, I always used http://xml.resource.org/

That also seems to be down...

If you are on Windows, you can download my RFC converter tool which
converts from HTML, XML, Word or Markdown to any of the former plus
plaintext format.

---

From: Randy Bush <[email-masked]>
Date: Mon, 21 Mar 2016 12:19:09 +0900

ryuu.psg.com:/Users/randy> doc -p -w resource.org
Doc-2.2.3: doc -p -w resource.org
Doc-2.2.3: Starting test of resource.org.   parent is org.
Doc-2.2.3: Test date - Mon Mar 21 12:18:29 JST 2016
ERROR: NS list from resource.org. authoritative servers does not
  === match NS list from parent (org.) servers
ERROR: ns1.media.org. claims to be authoritative, but does not appear in
NS list from authoritative servers
Summary:
   ERRORS found for resource.org. (count: 2)
Done testing resource.org.  Mon Mar 21 12:18:30 JST 2016

---

From: <[email-masked]>
Date: Mon, 21 Mar 2016 05:33:07 +0000 (UTC)

https://pypi.python.org/pypi/xml2rfc/

pip install xml2rfc

dependence on ietf infrastructure probably not a good idea...
but outsourced to xml.resource.org anyway.

 Lloyd Wood [email-masked] http://about.me/lloydwood

---

From: Jari Arkko <[email-masked]>
Date: Mon, 21 Mar 2016 14:41:11 +0200

Works for me at least, right now.

Jari

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Mon, 21 Mar 2016 13:38:58 +0000

Xml.resource.org is a CNAME for xml2rfc.ietf.org
Which in turn is a CNAME for zinfandel.tools.ietf.org
Which is one of the tools.ietf.org machines.

There evidently was a bad robot out there. Henrik posted this elsewhere this morning:

	On Monday, March 21, 2016 at 6:35 AM, Henrik Levkowetz wrote:
	On 2016-03-21 08:58, Randy Bush wrote:
	>http://tools.ietf.org/ seems not to respond usefully.  both addresses

	A bot (at 183.53.230.35) which didn't honour robots.txt had managed to get
	almost all apache threads bound up in returning wiki diffs and change
	lists, which are rather slow and resource-intensive pages.  I flushed
	those connections at 2016-03-21_10:25:38Z, and things look better after
	that.

	(An email directly to [email-masked] will get a faster response
	than one to [email-masked], though ,:-)

Bad bot. Bad bot. Shame on you. Go sit in your corner.

	Tony Hansen