Subject: 6lowpan over wire, specifically over powerline?

From: "Patrik Fältström" <[email-masked]>
Date: Mon, 28 Mar 2016 14:31:53 +0200

Hi,

This is a shot in the dark, but has anyone been looking at implementing things like 6lowpan on wire protocols, specifically over power lines? In a standardized way? There seems to be hundreds (well...) of proprietary solutions, but what about interoperable gear?

   Patrik

---

From: Ralph Droms <[email-masked]>
Date: Mon, 28 Mar 2016 08:38:59 -0400

Patrik - are you asking about 6lowpan as a way of reducing the overhead of IPv6?

Wi-SUN Alliance has been working on 6lowpan-over-ethernet, but mostly (as I understand it) for interconnecting IEEE802.15.4 networks for testing.

There is still, of course, the requirement for application protocols to replace all those proprietary protocols.

- Ralph

> On Mar 28, 2016, at 8:31 AM 3/28/16, Patrik Fältström <[email-masked]> wrote:
> 
> Hi,
>

---

From: "Patrik Fältström" <[email-masked]>
Date: Mon, 28 Mar 2016 15:20:22 +0200

> There is still, of course, the requirement for application protocols to replace all those proprietary protocols.

Yes, exactly, 6lowpan for talking to small 8-32 bit micro controllers which are on power lines or in small control equipment. Today they talk either modbus or canbus mostly.

   Patrik

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 28 Mar 2016 15:26:00 +0200

Patrik Fältström wrote:
> Hi,
> 
> This is a shot in the dark, but has anyone been looking at implementing things like 6lowpan on wire protocols, 

Yes.

https://tools.ietf.org/html/draft-ietf-6lo-6lobac

> specifically over power lines? 

Which PLC spec specifically are you thinking about?

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Mon, 28 Mar 2016 10:47:19 -0400

Patrik Fältström <[email-masked]> wrote:
    > This is a shot in the dark, but has anyone been looking at implementing
    > things like 6lowpan on wire protocols, specifically over power lines?
    > In a standardized way? There seems to be hundreds (well...) of
    > proprietary solutions, but what about interoperable gear?

My understanding is that a quite a number of Powerline protocols are
essentially 802.15.4 with a AC-transformer rather than an antenna, and so
there is really nothing to do.   The other ones which exist (going back to
X.10...) have monolithic protocol stacks, and few can run IP at all.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 28 Mar 2016 17:05:55 +0200

We worked in a project “6POWER” to implement IPv6, including QoS and multicast a few years ago, including the main chip set vendor for PLC, DS2, a Spanish company, leading in this field, which was later on acquired by Marvell.

At that time, the chip sets support 802.3 by default, 

All the documents are still available at:

http://www.6power.org/

I guess it will be interesting to apply 6lowpan here as well, but usually the scope of those networks and the bandwidth available in very low cost chip sets (clready up to 600 Mbits at that time), wat not a problem, bay be now there are other considerations that are relevant.

Regards,
Jordi

---

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 28 Mar 2016 18:09:05 +0000

Sometime ago there was a draft on 6lowpan-over-powerline and it was presented at IETF 6lo WG. However there was  no follow-up after that:

https://tools.ietf.org/html/draft-popa-6lo-6loplc-ipv6-over-ieee19012-networks-00

In addition, G3-PLC uses  6loWPAN adaptation over power-line (using mesh headers). http://www.g3-plc.com/content/g3-plc-benefits

Other efforts:
http://ieeexplore.ieee.org/xpl/login.jsp?tp=&arnumber=6525839&url=http%3A%2F%2Fieeexplore.ieee.org%2Fiel7%2F6520967%2F6525799%2F06525839.pdf%3Farnumber%3D6525839

https://hal.inria.fr/inria-00563226/document

Thanks,
-Samita 

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Carsten Bormann
Sent: Monday, March 28, 2016 6:26 AM
To: Patrik Fältström
Cc: IETF discussion list
Subject: Re: 6lowpan over wire, specifically over powerline?

Yes.

Grüße, Carsten

---

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 28 Mar 2016 18:20:05 +0000

BTW Patrik , [email-masked]  would be the WG which should be able to discuss more on 6lowpan-over-foo, if you have further interest to follow up.

https://datatracker.ietf.org/wg/6lo/charter/

6lo archive subscription information:
https://www.ietf.org/mailman/listinfo/6lo

Thanks,
-Samita
[6lo co-chair]

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Patrik Fältström
Sent: Monday, March 28, 2016 5:32 AM
To: IETF discussion list
Subject: 6lowpan over wire, specifically over powerline?

Hi,

   Patrik

---

From: Thomas Clausen <[email-masked]>
Date: Tue, 29 Mar 2016 11:17:56 +0200

Hi,

I reached out to Thierry Lys, from ERDF (French utility company), who replied:

> Hi Thomas,
>  
> Thank you for your email.
> As far as I know G3 is the only protocol to use 6loWPAN.
> These are the latest news on G3:
> 1)      We are pleased that IETF will « recognize » G3-PLC in including it in the IANA registry. The corresponding RFC is about to be release (see draft-ietf-6lo-dispatch-iana-registry-02.txt)
> 2)      We have already 30 000 G3 meters in the field now and 500 000 G3 meters by end of June (with 4000 meters installed / day)
> 3)      Other countries as well has started with G3 : Japan (roll out in progress), Belgium, Luxemburg, Austria, …(tender in progress)
> 4)      We have up to 73 platforms and products already certified (with interoperability proven)
>  
> Do not hesitate to copy and paste my email on IETF mailing list if needed !
>  
> Cheers, Thierry

Best,

Thomas

> On 28 Mar 2016, at 20:20, Samita Chakrabarti <[email-masked]> wrote:
>