Subject: Re: I-D Action: draft-arkko-ietf-trends-and-observations-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 2 Mar 2016 15:11:38 +1300

Thanks for this draft. It's helpful, but some other issues come to mind:

Crypto-wars redux, including the privacy wars, and are they affecting
general progress in the IETF?

Are any of the problems in RFC 3774 still open?

Is IASA as good as it could be? Time for a 10-year review?

Is the IETF Trust as good as it could be? Time for a review?

Is the EDU effort as good as it could be? Time for a review?

ISDs*. The mess of RFCs updating & depending on other RFCs only gets worse.

IETF process rules. The mess of RFCs and IESG statements updating & depending
on others only gets worse. I do my best at http://www.ietf.org/about/process-docs.html
but it's spaghetti.

Regards
   Brian Carpenter

*https://tools.ietf.org/html/draft-klensin-isdbis

---

From: Jari Arkko <[email-masked]>
Date: Fri, 4 Mar 2016 14:35:01 +0200

Brian,

Thanks for your helpful comments!

> Thanks for this draft. It's helpful, but some other issues come to mind:

The reason we put it out for your review, I guess :-)

> general progress in the IETF?

Good points. Indeed there are non-technical components that may affect our work. It hasn’t, to the best of my knowledge, so far. But it could. And this is just the current instance of the debate, there will be future debates on this as well.

There might be other similar policy-level effects that affect our work.

> on others only gets worse. I do my best at http://www.ietf.org/about/process-docs.html

All good questions and points. And now noted.

(But I do want to draw a distinction between external “forces of nature” and internal arrangements and processes. We certainly have a ton to do in the latter area, and as a whole, noting that process rules needs un-spaghetting is for instance a worthwhile thing to note in the draft. But at the same time, we wanted to focus on the external and large scale shifts. Btw, IASA/Trust review has been a topic that the IESG has discussed and is something we would like to do.)

Jari