Subject: Re: Remote Participation for IETF 95: Meetecho Details

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 31 Mar 2016 08:12:35 +0200

Dear IETF Secretariat,

Tools for remote participation are very necessary - thank you.

But I have one comment:

Le 30/03/2016 22:22, IETF Secretariat a écrit :
> You may use Meetecho to participate in or just observe any session
> being held in Buenos Aires. Here are the requirements and details.
>
> 1. Individuals are required to register for the meeting to observe or
> participate via Meetecho. - Individuals are required to enter
> registration I.D and name when logging into a session via Meetecho -
> The name must match that used to register for the meeting - Please
> register even if you are participating as part of remote hub - There
> is no cost to register as a remote attendee. Register
> here:http://ietf.org/meeting/register.html.
>
> 2. Participation includes the ability to transmit audio and video via
> the Meetecho virtual queue. - The virtual queue permits remote
> attendees to share audio and video if they choose, see here for more
> information:
> https://ietf95.conf.meetecho.com/index.php/UMPIRE_Project

thanks, this is new and specific to IETF.

> - Anyone who thinks they may want to participate by transmitting
> audio / video should perform the Meetecho self-test prior to the
> start of the session:
> http://ietf95.conf.meetecho.com/index.php/Self_Test

That URL seems to be working only starting Saturday, it does not work 
now.  This self-test should not be announced now, unless it works now.

Second, the remote attendees should have a means to self-test even if
they just want to listen (not necessarily transmit audio/video).
Because, even if the in-browser webrtc tools claim there is nothing to 
install sometimes there is the browser itself, or the java to install or 
some plugins to approve.  In enterprise environments often these actions 
are blocked by security policy.  Because of that one needs time in 
advance to test and obtain derrogation.  Especially for session of 
Monday morning 9am.  Not everybody works during weekends, especially if 
remote (not at IETF).

Meetecho is a new tool for many non-IETFers and one doesnt want them go
to their other preferred tools just because of this simple self-test matter.

Alex

>
> 3. WG Chairs will control the virtual queue, unmuting and muting of
> remote participants
>
> 4. The agenda for the WG sessions, as well as more detail on how to
> use Meetecho to participate, can be found here:
> https://ietf95.conf.meetecho.com/index.php/.
>
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 31 Mar 2016 08:19:03 +0200

Le 30/03/2016 22:22, IETF Secretariat a écrit :
> You may use Meetecho to participate in or just observe any session being held in Buenos Aires. Here are the requirements and details.
>
> 1. Individuals are required to register for the meeting to observe or participate via Meetecho.
> - Individuals are required to enter registration I.D and name when logging into a session via Meetecho
> - The name must match that used to register for the meeting
> - Please register even if you are participating as part of remote hub
> - There is no cost to register as a remote attendee. Register here:http://ietf.org/meeting/register.html.
>
> 2. Participation includes the ability to transmit audio and video via the Meetecho virtual queue.
> - The virtual queue permits remote attendees to share audio and video if they choose, see here for more information: https://ietf95.conf.meetecho.com/index.php/UMPIRE_Project
> - Anyone who thinks they may want to participate by transmitting audio / video should perform the Meetecho self-test prior to the start of the session: http://ietf95.conf.meetecho.com/index.php/Self_Test
>
> 3. WG Chairs will control the virtual queue, unmuting and muting of remote participants

Once one gets unmuted and comment given, is the Chair muting back the 
commenter?  Or is the commenter muting herself?

Or is it that once commenter gets unmuted one keeps that unmute forever?

This is important to know for the remote commenter to avoid create echo.

(in typical audioconf it is the commenter who mutes self, so once she 
learns that the Chair takes care of it s/he must be sure s/he has 
nothing to do to avoid echo).

If it is the Chair who controls all mute/unmute then how does the 
commenter request to talk?  Is it it a "raise hand" button?  Is the 
Chair's "mute commenter" button cancel a "raise hand"?  Must the 
commenter "low hand"?  Or is the Chair's "mute" automatically "low 
hand"?  Can a commenter keep a "raise hand" permanently?

Alex

>
> 4. The agenda for the WG sessions, as well as more detail on how to use Meetecho to participate, can be found here: https://ietf95.conf.meetecho.com/index.php/.
>
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 31 Mar 2016 08:28:56 +0200

> - There is no cost to register as a remote attendee. Register here:http://ietf.org/meeting/register.html.

Can one register a, say, "mickey mouse", account and then share to many 
other interested remote people to "tune in" without registering?

Because in some cases of extreme hurry the form-filling part of 
registration can be long.

Alex

---

From: Mauricio Esteban <[email-masked]>
Date: Wed, 30 Mar 2016 17:38:01 -0300

[email-masked]
El 30 mar. 2016 5:25 PM, "IETF Secretariat" <[email-masked]>
escribió:

> You may use Meetecho to participate in or just observe any session being
> held in Buenos Aires. Here are the requirements and details.
>
> participate via Meetecho.
> - The virtual queue permits remote attendees to share audio and video if
> they choose, see here for more information:
> - Anyone who thinks they may want to participate by transmitting audio /
> video should perform the Meetecho self-test prior to the start of the
> session: http://ietf95.conf.meetecho.com/index.php/Self_Test
>
> 4. The agenda for the WG sessions, as well as more detail on how to use
> Meetecho to participate, can be found here:
> _______________________________________________
> 95all mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/95all
>

---

From: Melinda Shore <[email-masked]>
Date: Wed, 30 Mar 2016 16:37:59 -0800

> participate via Meetecho.

I'm not sure I understand this correctly.  Does this mean
that somebody is going to have to register after the meeting
to be able to watch archived recordings?  That doesn't
seem correct.  If it's not correct, why does someone have
to register to passively watch a session?  Will the standalone
audio streams still be available during sessions?

Melinda

---

From: John C Klensin <[email-masked]>
Date: Thu, 31 Mar 2016 14:15:02 -0400

Thanks, but this is really not the solution.

I notice that the placeholder for IETF 95 "Remote Participation"
at http://www.ietf.org/ still is not associated with a link.  On
the meeting page (http://www.ietf.org/meeting/95/index.html),
there is no information under "At a Glance", one has to figure
out to look further, near the lower right corner of the top part
of the page above all the impressive logos, to find a "Remote
Participation"  entry.  There is an "info" link there that
points to
http://www.ietf.org/meeting/95/remote-participation.html, a page
that probably contains all the relevant information or pointers
to it if one is sufficiently experienced with  the IETF to know
how to read and interpret it, but I think it would be quite
difficult for a newcomer.  It points back to the Meetecho page,
as does the Meetecho link from the meeting page, but one needs
to know enough about Meetecho to know to go there.

Similarly, under that slightly-hard-to-find "Remote
Participation" heading, there is an entry for "Remote
Participant List" but no hint of the new Remote Participant
registration policy, much less a link to that page, which I'd
expect to find either next to the "General" Registration entry
or prominently featured under "Remote Participation", or, since
it seems to be the standard registration page and this is a
change from long-standing policy (see below) an indication on
the IETF main and meetings pages that remote participants are
expected to register.  I note that the explanatory material at
the top of the registration page
(https://www.ietf.org/registration/ietf95/ietfreg.py) doesn't
give a hint about no-fee remote participant registrations either
-- the only hint is a "Registration Type" checkbox in the
registration form itself.

While I've been advocating for years that we establish a
procedure for registering remote participants, at least those
who expect to interact with the meeting rather than lurk on
audio, this is a major policy change that I don't recall being
discussed with the community to see if there is really consensus
for it or at least to be sure that everyone is informed.  If
that discussion has occurred, could someone point me at it?   If
it has not, I hope to hear an adequate explanation from the IAOC
and/or IESG about the new policy-making process that does not
require community review.

If we really want remote participants, especially those who are
relatively new to the IETF, we really can, and should, do better
than this.  At least the "information hidden, need to be either
an old hand or very persistent to find it" problem has come up
many times before.

best,
    john

--On Wednesday, March 30, 2016 13:22 -0700 IETF Secretariat
<[email-masked]> wrote:

> You may use Meetecho to participate in or just observe any
> session being held in Buenos Aires. Here are the requirements
> and details. 
> 
> 1. Individuals are required to register for the meeting to
> observe or participate via Meetecho. - Individuals are
> required to enter registration I.D and name when logging into
> a session via Meetecho - The name must match that used to
> register for the meeting - Please register even if you are
> participating as part of remote hub - There is no cost to
> register as a remote attendee. Register
> 2. Participation includes the ability to transmit audio and
> video via the Meetecho virtual queue. - The virtual queue
> permits remote attendees to share audio and video if they
> choose, see here for more information:
> https://ietf95.conf.meetecho.com/index.php/UMPIRE_Project -
> Anyone who thinks they may want to participate by transmitting
> audio / video should perform the Meetecho self-test prior to
> the start of the session:
> 4. The agenda for the WG sessions, as well as more detail on
> how to use Meetecho to participate, can be found here:
> Recentattendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/recentattendees

---

From: Ray Pelletier <[email-masked]>
Date: Thu, 31 Mar 2016 14:17:36 -0400

Melinda

> On Mar 30, 2016, at 8:37 PM, Melinda Shore <[email-masked]> wrote:
> 
> to be able to watch archived recordings?

No. All sessions will be available on YouTube, likely within a day or so after the session. 

>  That doesn't
> to register to passively watch a session?

All onsite attendees register, even those who passively watching a session.  It will also provide an opportunity to survey remote attendees to improve the service. 

>  Will the standalone

Yes, no changes there. 

Ray

---

From: Dave Crocker <[email-masked]>
Date: Thu, 31 Mar 2016 11:23:12 -0700

On 3/31/2016 11:15 AM, John C Klensin wrote:
> athttp://www.ietf.org/  still is not associated with a link.  On
...

Yes, there are some hiccups in some of the pages.

However I latched onto the directive that remote participants need to 
register and, after searching and finding the problems you cited, 
decided to try to register.  There I found that I could choose 'remote 
participation' as a class of registration and everything else was 
normal, except that it didn't charge me.

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Lucy Lynch <[email-masked]>
Date: Thu, 31 Mar 2016 18:28:03 +0000 (UTC)

On Thu, 31 Mar 2016, Dave Crocker wrote:

> register and, after searching and finding the problems you cited, decided to 
> try to register.  There I found that I could choose 'remote participation' as 
> a class of registration and everything else was normal, except that it didn't 
> charge me.

... but the "everything else was normal" actually includes a number of 
options that are not relevant to remote participation and the form is long 
and confusing. How hard would it be to make a separate form for remote 
users with fewer steps and fewer options? Linking directly from the 
meetecho pages to a short form would be peachy.

- Lucy

---

From: John C Klensin <[email-masked]>
Date: Thu, 31 Mar 2016 14:29:15 -0400

--On Wednesday, March 30, 2016 16:37 -0800 Melinda Shore
<[email-masked]> wrote:

>> observe or participate via Meetecho.
> 

See separate, related, note, but add to Melinda's questions:

A registration requirement for remote participants is a major
policy change and one for people who merely want to passively
observe is something I believe the community has several times
concluded is inappropriate given privacy, etc., concerns.  So,
who made this decision and how?  Unless the answer involves a
community discussion and Last Call or equivalent process that I
missed (and apparently Melinda did too), if the answer to "who
decided" involves anyone in the IETF Leadership, would they
please offer to resign?

If it isn't clear, despite advocating for remote participant
registration for years (and being clearly in the rough), I think
this way of handling and announcing the decision is outrageous.

    john

---

From: John C Klensin <[email-masked]>
Date: Thu, 31 Mar 2016 14:39:45 -0400

--On Thursday, March 31, 2016 11:23 -0700 Dave Crocker
<[email-masked]> wrote:

>> I notice that the placeholder for IETF 95 "Remote
>> Participation" athttp://www.ietf.org/  still is not
>> associated with a link.  On the meeting page
>> (http://www.ietf.org/meeting/95/index.html),
> ...
> 
> 
> However I latched onto the directive that remote participants
> need to register and, after searching and finding the problems
> you cited, decided to try to register.  There I found that I
> could choose 'remote participation' as a class of registration
> and everything else was normal, except that it didn't charge
> me.

Yes, I found that too (and mentioned it in my note).   My
concern (independent of concerns about how the decisions were
made) is that you and I are about as experienced IETF old hands
(complete with appropriately-colored beards) as members of any
group of people around here.   A newcomer who can be easily
discouraged (rather than one who is exceptionally persistent and
determined) might well just give up instead.   I presume (and
hope) that is not the behavior we want to encourage.  

It really wouldn't take much effort to put a few sentences on
the meeting page (and either on the IETF home page or at the top
of the registration one) to say something like 'The IETF is now
requiring that remote participants register for the meeting
using the normal registration process but checking the new
"Remote Participant" category.  Doing so will give such
participants access to various capabilities including the
Meetecho remote conferencing system.'.   I'm just having trouble
understanding why it apparently didn't occur to anyone to do
that whether you and I can figure out how to navigate the system
or not.

   john

---

From: Melinda Shore <[email-masked]>
Date: Thu, 31 Mar 2016 10:55:56 -0800

On 3/31/16 10:29 AM, John C Klensin wrote:
> concluded is inappropriate given privacy, etc., concerns.

Yes, and inconsistent with the recent apparent consensus that
someone will be whitelisted for all IETF mailing lists if they're
signed up for any.

I do think there ought to be registration for people who are
active participants and who may influence outcomes - there are
tradeoffs around accountability and privacy that kick in in
that circumstance.  I don't think those tradeoffs apply to
merely consuming information.

In particular, I think it's weird and represents somewhat
incoherent engineering decisions to require registration to
passively monitor a session via Meetecho but not the raw
audio feed, and that no registration is required to watch
a recording.  Note that this is *not* an argument in favor of
requiring registration for access to archived material, but
that the registration requirement should be restricted to the
mike queue (although that raises the question of what to do
about questions relayed via Jabber).

As a frequent remote participant I'm very, very happy to see
that there's been progress on improving tools for allowing
remote participants to be more active during a session, but
as always seems to happen, the details are messy.

Melinda

---

From: joel jaeggli <[email-masked]>
Date: Thu, 31 Mar 2016 12:00:52 -0700

> someone will be whitelisted for all IETF mailing lists if they're

in my decade or so of moderating  ietf mailing lists... The overwhelming
source of whitelist additions was people using multiple accounts. and or
people sending stuff to lists to which they aren't subscribed e.g. the iesg.

neither case leaves much to the imagination

---

From: Melinda Shore <[email-masked]>
Date: Thu, 31 Mar 2016 11:09:49 -0800

> people sending stuff to lists to which they aren't subscribed e.g. the iesg.

To be clear, I don't have a problem with this.  I do have
a problem with the inconsistencies.

Melinda

---

From: SM <[email-masked]>
Date: Thu, 31 Mar 2016 12:11:33 -0700

Hi Alex,
At 23:28 30-03-2016, Alexandre Petrescu wrote:
>Can one register a, say, "mickey mouse", account and then share to 
>many other interested remote people to "tune in" without registering?

:-)

>registration can be long.

The form requires six fields to be filled in to register as a remote 
participant.  A remote person who is interested in listening to a 
working group session would either not bother signing up or put in 
"privacy-friendly" data.  I'll use the usual way to "tune in".

Regards,
-sm

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 1 Apr 2016 08:35:21 +1300

Thanks to John et al for complaining, because otherwise I wouldn't
have known until I tried to connect to Meetecho that remote registration
was needed. I mean, why would I bother to read a routine message about
remote participation details more than half an hour in advance?

Also, when you do register, why does it *require* your postal address and
telephone number, which have no relevance or value? (I can see why they
are needed for physical attendees.)

And why does the confirmation email have a bunch of text starting thus:
"You can pay the registration fee on site..."?

Regards
   Brian

On 01/04/2016 07:29, John C Klensin wrote:
> .

---

From: joel jaeggli <[email-masked]>
Date: Thu, 31 Mar 2016 16:20:25 -0700

> decided" involves anyone in the IETF Leadership, would they

I think you are accusing the community selected committee members of
malfeasance. At least now we are clear on where we stand.

We have advanced No BCP or standards track document to describe
requirements or procedures for the operation of remote participation nor
should we IMHO unless:

We view it as a core function of the IETF activiity.

It is mature enough that the thing we describe is neither obsoleted or
overtaken by events or at least is not focused on the technology and
method of delivery before the document is published.

---

From: John C Klensin <[email-masked]>
Date: Thu, 31 Mar 2016 20:28:08 -0400

--On Thursday, March 31, 2016 16:20 -0700 joel jaeggli
<[email-masked]> wrote:

>> community discussion and Last Call or equivalent process that
>> I missed (and apparently Melinda did too), if the answer to
>> "who decided" involves anyone in the IETF Leadership, would
>> they please offer to resign?
> 
> I think you are accusing the community selected committee
> members of malfeasance. At least now we are clear on where we
> stand.
> 
> requirements or procedures for the operation of remote
> participation nor should we IMHO unless:
> 
> It is mature enough that the thing we describe is neither
> obsoleted or overtaken by events or at least is not focused on
> the technology and method of delivery before the document is
> published.

Joel,

We aren't talking about the "technology or method of delivery"
for remote participation.  AFAICT, I raised two issues, neither
of which was about that.  The issues were:

(1) The unexpected decision to impose a registration requirement
on remote participants.  

I would believe there should have been at least an announcement
but otherwise that it was not a big deal had there not been
extensive discussion in the community about the possibility of
asking some or all remote attendees to register.  I think the
clear conclusion from those discussions was "no" (and I was on
the losing side, so I'm not trying to back anyone into or out of
a policy I like here).  That was "no, it is not a core
function", "no, it raises too many privacy issues", and "no,
there is no need to do it".  

In general, if the community has a discussion that concludes
with either "don't do that" or "needs more thought", there is an
expectation that it won't be done without reopening the
discussion or making a clear statement as to why the change was
needed.  Neither of those occurred, at least as far as I can
tell.  I've said nothing about malfeasance, nor do I believe
there is any evidence of evil intentions.  However, I think
there has been a significant breach of community norms and
expectations about openness, consultation, and transparence.   I
also don't know if that failure was by "the community selected
committee members" or if some staff member is making decisions
without adequate supervision, but it is a problem either way and
I hope that whomever is involved will take the situation
seriously, explain the source or reason for the disconnect to
the community, and evaluate (along with the community) whether
they really want to do whatever job they are doing.

(2) There are some almost-unrelated issues about how remote
participation information is presented and made available and
about remote access to, e.g., Sunday tutorials.  Those topics
are old news but there is some question about why we are having
to discuss them, or scrambling around to fix them, a few days
before IETF sessions begin.  That seems important to me not only
because we've had these discussions fairy regularly but also
because, IMO, things were getting steadily better for some time
but we now seem to have reversed course and gotten a little too
relaxed again.  Again, I think the community is entitled to know
who bears the responsibility for having such things under
control and how the apparent lapses this time occurred.  That
isn't a claim of malfeasance either, although it is possible
that there are some issues of non-feasance.

best
    john