Subject: RE: I-D Action: draft-bradner-rfc3979bis-08.txt

From: Michael Cameron <[email-masked]>
Date: Wed, 30 Mar 2016 17:01:21 +0000

After reviewing draft-bradner-rfc3979bis-08.txt, I would propose the following in order to bring additional clarity and certainty to the obligations imposed on Area Directors and WG chairs.  This proposal relates to the definitions of "Participating in an IETF discussion or activity", and "Participating" and Section 5.1.2. 

There are two actors in Section 5.1.2: "Contributors" and "Participants".  Contributors are a subset of Participants. While there is an obligation on Contributors to disclose IPR of which they are aware which relates to their Contribution, there is also an IPR disclosure obligation on non-Contributor Participants, that is, those who have Participated in an IETF discussion or activity.  In this draft, "Participating" is defined to mean "acting in order to influence the outcome of a discussion relating to the IETF Standards Process.  Without limiting the generality of the foregoing, acting as a working group chair or Area Director constitutes "Participating" in all activities of the relevant working group or area."  

For non-Contributing Participants who are WG chairs or Area Directors, personal knowledge of IPR should be contemporaneous with action taken on the Contribution. Such actions could be the original submission of the Contribution, submission of updated drafts thereof or last call.  For example, a WG chair or Area Director serving in 2016 who assisted in the review of an Invention Disclosure (IVD) for their company in 2012 and has since forgotten about this IVD, does not "reasonably and personally" know of IPR meeting the conditions of Section 5.6 if the Contribution by another in their domain is made in 2016. In other words, there is no affirmative obligation on a WG chair or Area Director, for a Contribution within the Area Director's or WG chairs' domain, to go back and review company IP activities in which they were or might have been exposed to refresh recollection.  To clarify this, I would propose deleting the phrase "reasonably and" in Section 5.1.2.

Further, because WG chairs and Area Directors should not be expected to predict the outcome of the uncertain patent prosecution process, the phrase "may ultimately Cover that Contribution" should be deleted in Section 5.1.2. Even assuming a WG chair or Area Director has personal knowledge of a pending patent application, it is very difficult, if not impossible, to predict the outcome of patent prosecution and ultimate claim scope. Notwithstanding the definition of "Covers" or "Covered", there is no such thing as a "valid" claim of a patent application (including a provisional patent application).  To be exactly precise, "Covers" or "Covered" should only refer to claims of issued patents, but that discussion is for another time. For now, to bring certainty to the process, WG chairs and Area Directors should only be required to take a snapshot of the situation as it exists at the time of the Contribution related event (original submission, update, last call) of which they are participating to determine whether they then have personal knowledge of IPR related thereto.  

Thus, I would propose Section 5.1.2 be amended as follows:

If an individual Participates relative to a written Contribution (other than a Contribution that is not intended to be used as an input into the IETF Standards Process) made by another person and such Participant    personally knows of IPR meeting the conditions of Section 5.6 which the Participant believes Covers, or which the Participant personally knows his or her employer or sponsor may assert against Implementing Technologies based on such written Contribution, then such Participant must make a disclosure in accordance with this Section 5.

Also, the definition of "Participating in an IETF discussion or activity" and "Participating" should be amended as follows:

"Participating in an IETF discussion or activity": means making a Contribution, as described above, or in any other way acting in order to influence the outcome of a discussion relating to the IETF Standards
Process.  Without limiting the generality of the foregoing, acting as a working group chair or Area Director shall constitute "Participating" to the extent such person engages in discussions or review of a Contribution as part of the activities of their relevant working group or area.  "Participant" and "IETF Participant" mean  any individual Participating in an IETF discussion or activity.

Respectfully, Mike Cameron

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 31 Mar 2016 09:12:41 +1300

On 31/03/2016 06:01, Michael Cameron wrote:
...
> To clarify this, I would propose deleting the phrase "reasonably and" in Section 5.1.2.

I would object very strongly to this deletion. We have always said "reasonably and
personally known" to make it clear that nobody is expected to go to unreasonable
lengths to discover the existence of IPR. For anyone who works for a large company,
it is clearly unreasonable for them to be aware of all IPR owned by that company,
and this phrase covers that case nicely, especially given that we all participate
and contribute here as individuals, even if we happen to use a corporate email
address. This phrase has stood the test of time and should not be changed.

...
> ...  Without limiting the generality of the foregoing, acting as a working group chair or Area Director shall constitute "Participating" to the extent such person engages in discussions or review of a Contribution as part of the activities of their relevant working group or area. 

That seems 100% redundant to me. How could anybody possibly interpret the roles
of WG Chair or AD as anything other than participating, at moments when they
are not contributing (which they often do)?

Regards
   Brian

---

From: Michael Cameron <[email-masked]>
Date: Wed, 30 Mar 2016 20:20:46 +0000

Hello Brian.  I respectfully disagree.  If the meaning of the phrase has not been litigated, it has not been tested. Regarding your second point, please refer to Gonzalo's earlier comment. For those and other reasons, I continue to believe that these amendments add certainty and clarity to the policy.

Best, Mike

> On Mar 30, 2016, at 1:12 PM, Brian E Carpenter <[email-masked]> wrote:
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Wed, 30 Mar 2016 16:32:15 -0400

this is a legal issue - the language comes from a long ago US court case

in addition to what Brian brings out 

“reasonably’ also refers to what someone should, by their job, know - i.e. a company
can not purposely keep someone in the dark to avoid disclosure requirements

Scott

> On Mar 30, 2016, at 4:12 PM, Brian E Carpenter <[email-masked]> wrote:
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Wed, 30 Mar 2016 16:33:18 -0400

actually - when 2026 was written that language was recommended by the (many) lawyers who advised us
specifically because it had been tested

Scott

> On Mar 30, 2016, at 4:20 PM, Michael Cameron <[email-masked]> wrote:
>

---

From: Michael Cameron <[email-masked]>
Date: Wed, 30 Mar 2016 21:04:50 +0000

Hi Scott, please provide a cite to the case interpreting that phrase-depending on the context and court, this may not be as significant an issue.   Your second point about what someone "should" know is the concern.   If a Company X engineer is a co-author with 3 others on a number of drafts, and it is in one of a number of WGs that are overseen by a Company X AD, and this draft is overlooked by the Company X AD, "should" that Company X AD nevertheless have to redouble their efforts, ensure that they are aware of all the Company X drafts of all the workgroups under their area, then at least cursorily canvas the Company X IP portfolio? My experience is that a hostile trial lawyer will argue that the AD "should" have performed this at least cursory analysis. In fact, a trial lawyer will go further and torch an AD for not doing much, much more.  All because of the word "should".  Let's stay away from what someone "should" know and stick with what they do know.

Best, Mike

> On Mar 30, 2016, at 1:32 PM, Scott O. Bradner <[email-masked]> wrote:
>