Subject: amount of time for WG meetings, starting times, unstructured time, etc for Seoul

From: IETF Chair <[email-masked]>
Date: Thu, 15 Sep 2016 14:58:38 +0300

At IETF-96, we had a discussion about both the chosen starting time but also other issues in the way that we set up the schedule, and provide time for either WG or other discussions.

This email provides some information about the options the IESG has in setting the schedule and related tradeoffs.

In general, barring any specific venue limitations, the IESG can independently adjust a number of different variables in the schedule, while assuming the same overall meeting week length. We can adjust the length of the day and overall number of hours in the schedule.  The IESG sets only the formal meeting schedules, so the tradeoff here is what fraction of the days are spent in formal meetings vs. unscheduled time that might be used for design team meetings and other more unstructured collaboration.

We can also adjust the specific timing, subject to local food availability and other conditions. And we can adjust the parallelism, i.e., number of tracks. This will impact conflicts but also our capacity to host meetings that the WGs have requested. Finally, we can adjust the number of plenaries, with the recent trend being holding exactly one plenary during the week.

Overall, our perception at the IESG is the following:

o  The start time provokes some opinions. For IETF-97 we plan to set this so that lunch and dinner times in the local situation are convenient. It might be useful to poll the community about this as well, but we'd like to suggest that it may be more important to focus on the bigger issues such as unstructured/structured time. At this time, what we know is that we will have plenty of restaurants around us, that there may be some lines at 11:30, some restaurants close at 21:30 while others stay open 24 hours. We are still deciding what to do about the start time, though one possibility is to start at 9:30. A lot depends also on how many sessions WGs request, or how many official total meeting hours we want to have.

o  Knowing the ending time on Friday is important for your flight arrangements. We do plan to start early on Friday, have three hours of sessions and one small room changeover break. As a result Friday schedule will end at 12:20.

o  We believe the community has told us to not increase the plenary time. The existing plenary time should be used primarily for technical topic (when available) or community discussion. There will be some amount of program in all of our plenaries, but the substantial reports have largely been moved to online consumption.

o  We also believe the community has told that arranging more unstructured time for work to happen would be useful. Is this a correct conclusion? The exact forms of how we might go about this are subject to furher discussion, see below. One of the big question marks here is the effect of any unstructured time to remote or English-as-foreign-language participants.

o  We have also heard repeated calls for stricter time allocation control by the IESG, in that only some working groups or maybe no working groups should be allowed extensive use of meeting hours (2x3hrs etc). We're not quite sure where the community is on this though, and it is also important that we get to do work when we do meet face to face. Our current belief is that it is better to deal with this question as part of the overall time allocation question, i.e., how much time gets allocated. The IESG is in charge of ensuring that within the time reserved for WGs, the allocation is fair in the sense of giving the time where it is needed and demonstrably useful. Including, for instance, the WG's track record from the time since the previous IETF meeting.

With regards to the possible increase of unstructured time in the meetings, we would like to do some experimentation, as we do not yet have experience of how time might get used.

The possible experiments that we've identified are:

1. The total number of hours available for WG meetings during the week. We could either keep this capped at what we had in Berlin. Alternatively, we can reduce the overall number of hours so that we can have, for instance, more design team meetings. We can start later or finish earlier one day, as an example.

2. Encouraging working groups try unstructured meeting time in one of their slots. This time could be used for free-form discussion in the whole group, an “unconference" style idea session in the different corners of the room, or a hacking session devoted to the WG's technology. All up to the WG chairs to decide. We’ve reached out to the working group chairs for their ideas in this space.

Note: Seoul we will have tighter than usual space constraint. We can unfortunately not devote additional rooms, so anything we do needs to run under the usual room allocations. However, we will have more space in Chicago, so some bigger experiments or changes could be considered there.

We would like to solicit some feedback:

Q1. Please confirm that the community wishes that we arrange more unstructured time for work to happen.

Q2. Would you like to either keep the amount of meeting time from Berlin, or reduce it so that an additional hour(s) can be used for design team meetings and other unofficial interaction?

Q3. Any other feedback? Other suggestions?

The IESG is looking to make a decision of the IETF-97 schedule by September 30, so input before that is most useful,

Jari (for the IESG)

---

From: "Paul Hoffman" <[email-masked]>
Date: Thu, 15 Sep 2016 07:50:51 -0700

> unstructured time for work to happen.

Yes, if this does not force cancellation of needed WG meetings. It is OK 
if it forces shortening of some meetings by 30 mins, for example.

> Q2. Would you like to either keep the amount of meeting time from 
> Berlin, or reduce it so that an additional hour(s) can be used for 
> design team meetings and other unofficial interaction?

Reduce by a bit seems OK.

> Q3. Any other feedback? Other suggestions?

The ability to have grab-and-go lunches, either in the venue or within a 
block or so, *greatly* increases the ability to make the 90 minutes of 
lunch be useful work/social time. Even the typically over-priced hotel 
fare is useful if some of us want to eat quickly so that we have an hour 
or even a half-hour of coordination on some work topic, particularly 
something that came up earlier in the week. (This is probably not an 
issue for Seoul, but should be kept in mind for all meetings under this 
topic.)

--Paul Hoffman

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 16 Sep 2016 08:32:01 +1200

Hi Jari,

Thanks for asking! Here are some quick thoughts (although I will not be in Seoul):

> o  We have also heard repeated calls for stricter time allocation control by the IESG, in that only some working groups or maybe no working groups should be allowed extensive use of meeting hours (2x3hrs etc).

I don't think there should be a strict rule about this. It all depends on where
a WG is in its life cycle. Sometimes there is a real need for in-depth face2face
discussion, but not quite enough to merit a full interim meeting. Sometimes a
long interim meeting is essential. Sometimes the mailing list is working well
and there are few issues that deserve f2f time.

A WG that *consistently* claims that it needs 6 hours of f2f time is clearly
in trouble and probably deserves drastic action by the AD.

So I think this is a matter of AD judgment - with a clear preference for short,
efficient sessions, but the option of longer sessions when well justified.

> Q1. Please confirm that the community wishes that we arrange more unstructured time for work to happen.

Up to a point. I used the 9-10 a.m. time in Berlin, but I didn't like the later lunch
and dinner times that resulted. And I saw fewer people having organised breakfast
meetings than normal, so the time between 7 and 9 a.m. was probably less well used.

> Q2. Would you like to either keep the amount of meeting time from Berlin, or reduce it so that an additional hour(s) can be used for design team meetings and other unofficial interaction?

Definitely don't reduce it. The main reason Berlin worked well for me was the large amount
of *space* for informal meetings, not the schedule.

Regards,
      Brian