Subject: Old Errata

From: Yoav Nir <[email-masked]>
Date: Mon, 12 Sep 2016 11:29:16 +0300

Hi

I’ve just noticed that there are a lot (224 at this point in time) or reported errata that have not yet been handled ([1]).  Some of these are fairly recent, but a lot are from months or years ago, including 5 from 2010, 1 from 2005 (for RFC 3970 - “A Traffic Engineering (TE) MIB”)

Is there some process for getting all these errata handled?  I know the usual process is that someone submits a report, ADs or WG chairs notice, and after a brief discussion the report is classified as Verified, Held for Document Update, or Rejected. But ISTM that some reports fall through the cracks. 

And sure, I only noticed because one of those 224 is mine...

Yoav

[1] https://www.rfc-editor.org/errata_search.php?rec_status=2&presentation=table

---

From: Loa Andersson <[email-masked]>
Date: Mon, 12 Sep 2016 11:56:18 +0200

Yoar,

I looked at this - to see if I missed something - and the picture that
comes over is

Year    number of errata   working group
2005    1                  tewg
2010    5                  nsfv4
2011    1                  nsfv4
2012    1                  nsfv4
2013    11                 Legacy (gen), Poisson (gen), krb-wg (sec),
                            mext (int), nsfv4, non-wg (sec) x 2,
                            keyprov(sec) behave (tsv), non-wg (gen),
                            dane (sec)
2014     35                many wg's
2015     57                many wg's
2016    114                many wg's

I think there are one problem here that need to have some type of
management action. The tewg, nsfv4 and of the wg's with errata from
2013 only dane is still active.

The ADs might have to point to someone to resolve the (oldest) errata.
Or errata that belong to closed wg's.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 12 Sep 2016 11:15:31 +0100

> Or errata that belong to closed wg's.

FWIW, for my WGs, I follow the practice of handling any
errata for which someone shows interest. So if there're
any that need to be processed, then please ping me, and/or
a relevant mailing list and I'll take action. If, OTOH,
nobody is interested, then that is also true of me:-)

While other ADs may be more proactive than me, I think
it's true that if pinged, ADs will generally take action.

Cheers,
S.

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 12 Sep 2016 12:40:11 +0100

On 12/09/16 12:23, Loa Andersson wrote:
> Stephen,
> 
> Errata that does not attract interest could do so for many reasons. I
> think we at least should make up our mind if they should be rejected.
> If they are not they at least should be held for a future bis.

That is reasonable, assuming "we" is the set of folks reading this
thread.

S.

> 
> /Loa
> 
> Sent from my iPhone
> 
>> On 12 sep. 2016, at 12:15, Stephen Farrell
>> <[email-masked]> wrote:
>> 
>> 
>> 
>>> The ADs might have to point to someone to resolve the (oldest)
>>> errata. Or errata that belong to closed wg's.
>> 
>> FWIW, for my WGs, I follow the practice of handling any errata for
>> which someone shows interest. So if there're any that need to be
>> processed, then please ping me, and/or a relevant mailing list and
>> I'll take action. If, OTOH, nobody is interested, then that is also
>> true of me:-)
>> 
>> While other ADs may be more proactive than me, I think it's true
>> that if pinged, ADs will generally take action.
>> 
>> Cheers, S.
>> 
>

---

From: John C Klensin <[email-masked]>
Date: Mon, 12 Sep 2016 13:35:49 -0400

--On Monday, September 12, 2016 11:56 +0200 Loa Andersson
<[email-masked]> wrote:

> I think there are one problem here that need to have some type
> of management action. The tewg, nsfv4 and of the wg's with
> errata from 2013 only dane is still active.

> errata. Or errata that belong to closed wg's.

As former co-chair of one of the WGs listed, I don't remember
ever having been told about this
(https://www.rfc-editor.org/errata_search.php?eid=3752).  If I
had been, or were able to comment on the erratum now (there does
not appear to be any way in the system for me to do that), I
would have said that using an erratum to change (not actually
correct, because it was correct when the RFC was published) an
email address would rank fairly high on the "pointless" scale...
at least until we turn RFCs from archival to living documents or
invent a magical mechanism that warns anyone opening an RFC that
there are relevant errata.... even if the copy of the RFC they
open was copied from the archive years ago onto a machine that
is not connected to the Internet.

Part of the point is that our Status and Type categories are
really not up to the job (something that has been discussed
extensively in the past with, AFAIK, no resolution).   Given the
current categories, just leaving some documents in "Reported"
forever might be the right disposition.  If we are going to use
errata to make minor technical changes, then we probably should
have a Status of "Sure, but there needs to be another way to
notify people about this issue", maybe with an appropriate
Action number in that tracker.  It is also tempting to suggest
that the "Type" for this kind of erratum should be "smells of
dead fish": certainly it is not "Editorial" because the RFC was
absolutely correct --technically, operationally, and
editorially-- when written.

Seems to me that just keeping an alias or link until a few years
after the relevant RFC becomes obsolete would be a lot less
trouble.

I doubt this is the only case -- the errata filing system
doesn't have a great track record for S/N ratio and I, at least,
would much prefer to have ADs paying attention to WGs and
processing of current documents rather than studying the errata
files looking for loose ends.

    john

---

From: Loa Andersson <[email-masked]>
Date: Tue, 13 Sep 2016 11:56:34 +0200

Stephen,

> That is reasonable, assuming "we" is the set of folks reading this

Well - yes. But also if you are (the former) wg chair or the shepherd
for a document that have an errata listed I think that it is in your
own interest to have that errata responded to.

/Loa

--