Subject: Re: Review of draft-ietf-dime-load-07

From: Steve Donovan <[email-masked]>
Date: Tue, 7 Mar 2017 09:44:57 -0600

Roni,

Thank you for your review.  Please see my comments inline.

Steve

On 2/23/17 3:01 AM, Roni Even wrote:
> Reviewer: Roni Even
> Review result: Ready with Nits
>
> I am the assigned Gen-ART reviewer for this draft. The General Area
> Review Team (Gen-ART) reviews all IETF documents being processed
> by the IESG for the IETF Chair.  Please treat these comments just
> like any other last call comments.
>
> For more information, please see the FAQ at
>
> <https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.
>
> Document: draft-ietf-dime-load-07
> Reviewer: Roni Even
> Review Date: 2017-02-23
> IETF LC End Date: 2017-02-27
> IESG Telechat date: 2017-03-16
>
> Summary: This draft is almost ready for publication as a standard
> track RFC
>
> Major issues:
>
> Minor issues:
>
> I understand that each node can calculate the load differently , the
> example in figure 8 demonstrate that the agent selection may be
> different if the agent aggregates load from the servers to calculate
> its load or just conveys his load, possibly even that each one of the
> agents will use different method. Why not mandate load calculation
> using aggregated weighted loads?
SRD> The working group thought it was best to leave this as an 
implementation decision.
>
> Nits/editorial comments:
> 1. In section 5 paragraph 9 "The load report includes a value
> indicating the load of the sending
>     node relative load of the sending node, " should be just "The load
> report includes a value indicating the relative load of the sending
> node,"
SRD> Yes, change made.
> 2. In section 6.2 "weigth "
SRD> Change made.
> 3. in the security consideration what about an endpoint in the middle
> changing the host load value causing a change in the routing
> decisions.
SRD> I'm assuming that you mean an agent in the middle changing the host 
value.  I've added the following to the security considerations section 
-- "Given that routing decisions are impacted by load information, there 
is potential for negative impacts on a Diameter network caused by 
erroneous or malicious load reports. This includes the malicious 
changing of load values by Diameter Agents."

---

From: Roni Even <[email-masked]>
Date: Wed, 8 Mar 2017 06:39:46 +0000

Hi Steve,
Thanks, I have no more comments
Roni

> -----Original Message-----
> From: ietf [mailto:[email-masked]] On Behalf Of Steve Donovan
> Sent: יום ג 07 מרץ 2017 17:45
> To: [email-masked]
> Subject: Re: Review of draft-ietf-dime-load-07
> 
> Roni,
> 
> > Review Team (Gen-ART) reviews all IETF documents being processed by
> > the IESG for the IETF Chair.  Please treat these comments just like
> > any other last call comments.
> >
> -- "Given that routing decisions are impacted by load information, there is
> potential for negative impacts on a Diameter network caused by erroneous
> or malicious load reports. This includes the malicious changing of load values
> by Diameter Agents."
> >
> >
> >
> >