Subject: Re: Last Call: <draft-ietf-lamps-eai-addresses-05.txt> (Internationalized Email Addresses in X.509 certificates) to Proposed Standard

From: Stephen Farrell <[email-masked]>
Date: Wed, 8 Mar 2017 16:22:25 +0000

Hiya,

So I don't think we've yet resolved the issues raised
with this. And since the March 16th telechat will be my
last one I figure that the best thing to do is to ask
that this go back to the working group for resolution.

Once that's sorted out, then the WG can kick it over
to their new AD. Note that this need not add any major
delay - it'd be entirely possible to have it back on a
telechat agenda shortly after IETF98, all going well.

If nobody yells, I'll do that tomorrow.

If someone does yell, please do that now and accompany
your yell with the OLD/NEW changes that you claim resolve
the issues raised. (To be honest though, I think this
would benefit from more WG discussion so I'll not be so
easy to convince if someone does yell thusly;-)

Cheers,
S.

On 23/02/17 20:16, Stephen Farrell wrote:
> 
> Folks,
> 
> I've just reviewed the IETF LC for this draft. Thanks all for
> the comments and discussion which I think have thrown up some
> real issues.
> 
> As of now, it is not clear to me that we have finished the
> work with this one, at least the issues to do with name
> constraints seem to me to call for some more WG consideration.
> 
> I think Russ (as lamps WG chair) has a similar opinion
> that we're not done yet.
> 
> That said, I had put this on the March 16th IESG telechat
> for consideration. If we do manage to reach a clear enough
> consensus on a published revision to the draft in say the
> next week then that schedule should still be fine. So I'd
> encourage the authors and others who've commented to try
> again and see if, in that timeframe, we can get to where
> we're happy that the issues raised have been handled well
> enough.
> 
> But, if it looks (as it does to me today) as if this'll take
> a bit longer to figure out, then I figure the right thing to
> do will be to let the lamps WG figure out how to proceed.
> (And that'll mean that my successor as the responsible AD
> for the lamps WG will handle further actions with the doc.)
> 
> Bottom line: if this isn't settled in the next week or so,
> I'll take it off the March 16th IESG telechat and let the WG
> continue the discussion.
> 
> Cheers,
> S.
> 
> PS: To add to the name constraints discussion, I did wonder
> if anyone really wants to use those. So for example, if we
> defined the new name form so that certificate chains with
> any name constraints at all and one of those names anywhere
> are always treated as invalid, then would that cause any
> real breakage? (It certainly would cause theoretical breakage,
> but if that's all then I'd be ok with that:-)
> 
> 
>

---

From: Wei Chuang <[email-masked]>
Date: Wed, 8 Mar 2017 15:07:15 -0800

Hi Stephen,

Let me provide that yell to see if this draft resolves the last set of
concerns.
https://tools.ietf.org/html/draft-ietf-lamps-eai-addresses-07

The diff is here:
https://tools.ietf.org/rfcdiff?url2=draft-ietf-lamps-eai-addresses-07.txt

-Wei

On Wed, Mar 8, 2017 at 8:22 AM, Stephen Farrell <[email-masked]>
wrote:

> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm
>
>

---

From: Viktor Dukhovni <[email-masked]>
Date: Wed, 8 Mar 2017 18:27:55 -0500

> On Mar 8, 2017, at 6:07 PM, Wei Chuang <[email-masked]> wrote:
> 

This diff covers a lot more than just name constraints.  One oddity that
stands out is in section 5:

	3.  Ensure local-part is UTF-8.

I don't see how one would "ensure" such a thing, since no encoding
information is available for the localpart, is I would expect that
is always presumptively UTF-8 (if not us-ascii).

More importantly I don't believe that the name constraint issues are
adequately or correctly addressed in this revision.

Instead of prohibiting issuance of EE certs that HAVE SmtpUTF8Name SAN
elements via a cert chain that has a certificate with *just* rfc822Name
constraints, it attempts to require an unnecessary (and I think not
entirely robust) correspondence between the two types constraint, and
needlessly bans EE certs whose chains include just rfc822Name constraints
even in the absence of SmtpUTF8Name SAN elements.

The changes in this revision seem to me to be too extensive, and not
yet finished. :-(

-- 
	Viktor.

---

From: Wei Chuang <[email-masked]>
Date: Wed, 8 Mar 2017 17:17:15 -0800

Okay.  I think the direction then is to have SmtpUTF8Name respect
rfc822Name name constraints and vice versa.

-Wei

---

From: Viktor Dukhovni <[email-masked]>
Date: Wed, 8 Mar 2017 22:19:20 -0500

> On Mar 8, 2017, at 8:17 PM, Wei Chuang <[email-masked]> wrote:
> 
> Okay.  I think the direction then is to have SmtpUTF8Name respect rfc822Name name constraints and vice versa.

Well, no, the simplest proposal on the table is for SmtpUTF8Name to
be *prohibited* when rfc822Name constraints are present and SmtpUTF8Name
constraints are not.  When both present, they can operate independently.

The verifier logic is then:

	1. If neither rfc822Name constraints nor SmtpUTF8Name constraints
           are present in any CA certificate in the chain, any mixture of
           rfc822Name and SmtpUTF8Name SAN elements is valid.

	2. If some certificate in the chain contains *only* rfc822Name
	   constraints, then these apply to rfc822Name SAN elements, but
	   all SmtpUTF8Names are prohibited.

	3. When both types of constraints are present in all CA certificates
           that have either type, then constraints for each SAN type are
	   exclusively based on just the corresponding constraint type.

	4. If some certificate in the chain contains only SmtpUTF8Name
 	   constraints then those are unavoidably at risk of bypass via
           rfc822Name SAN elements when processed by legacy verifiers.
	   Therefore, this should be avoided, and the CA needs to
 	   publish rfc822Name constraints that prevent bypass.  Such
	   constraints *need not* be equivalent (not always possible)
	   to the desired SmtpUTF8Name constraints.  Rather, it suffices
	   to not permit rfc822Name elements that would be prohibited
	   if they were simply cut/pasted (with no A-label to U-label
           conversions) as SmtpUTF8Name elements.  It is not necessary
	   for these to permit everything that SmtpUTF8Name permits.

Thus for example, if SmtpUtf8Name only permits addresses in the non NR-LDH
domain "духовный.org" (or a specific set of addresses in such a domain),
then the corresponding rfc822Name constraint could just permit "." (or the
reserved "invalid" TLD if that's preferable) which is not a usable email
domain.  This ensures that only the permitted SmtpUTF8Name SANs are used
and no rfc822Name SANs are used.

If, instead the Smtp8Name constraints are excluded non-ASCII address forms,
then since these have no literal rfc822Name equivalents, the rfc822Name
constraints can be omitted with the same effect.

Only when the intention is to permit NR-LDH domains with either ASCII or
UTF-8 localparts (or an all-ASCII full address) do the rfc822Name and
SmtpUTF8Name constraints need to be fully equivalent.  This is of course
trivial to do.  Just cut/paste the same string into both types of
constraint.

-- 
	Viktor.

---

From: tom p. <[email-masked]>
Date: Thu, 9 Mar 2017 09:34:35 +0000

----- Original Message -----
From: "Viktor Dukhovni" <[email-masked]>
To: <[email-masked]>; "IETF general list" <[email-masked]>
Sent: Thursday, March 09, 2017 3:19 AM

<tp>

Getting security right can be tricky as the legion of failed attempts
that make it to RFC testify but what you are proposing here seems so
simple, so obviously the right thing to do that I am puzzled, bewildered
even, that anyone can disagree with you.

Tom Petch

1. If neither rfc822Name constraints nor SmtpUTF8Name constraints
           are present in any CA certificate in the chain, any mixture
of
           rfc822Name and SmtpUTF8Name SAN elements is valid.

Thus for example, if SmtpUtf8Name only permits addresses in the non
NR-LDH
domain "духовный.org" (or a specific set of addresses in such a domain),
then the corresponding rfc822Name constraint could just permit "." (or
the
reserved "invalid" TLD if that's preferable) which is not a usable email
domain.  This ensures that only the permitted SmtpUTF8Name SANs are used
and no rfc822Name SANs are used.

If, instead the Smtp8Name constraints are excluded non-ASCII address
forms,
then since these have no literal rfc822Name equivalents, the rfc822Name
constraints can be omitted with the same effect.

--
Viktor.

---

From: Wei Chuang <[email-masked]>
Date: Thu, 9 Mar 2017 10:22:26 -0800

There seems to be a consensus here and internally to the changes that
Viktor proposes.  We can put that in the next draft update.

-Wei

On Thu, Mar 9, 2017 at 1:34 AM, tom p. <[email-masked]> wrote:

> domain "духовный.org <http://xn--b1adqpd3ao5c.org>" (or a specific set of
> addresses in such a domain),

---

From: Wei Chuang <[email-masked]>
Date: Sun, 12 Mar 2017 14:40:45 -0700

The latest draft 08 is up:
https://tools.ietf.org/html/draft-ietf-lamps-eai-addresses-08

The diff is:
https://tools.ietf.org/rfcdiff?url2=draft-ietf-lamps-eai-addresses-08.txt

This draft attempts to capture Viktor's name constraint verifier logic, and
illustrate the examples in the diagrams.

-Wei

On Thu, Mar 9, 2017 at 10:22 AM, Wei Chuang <[email-masked]> wrote:

>> domain "духовный.org <http://xn--b1adqpd3ao5c.org>" (or a specific set
>> of addresses in such a domain),