Subject: FW: Video Streaming Bar BoF @ IETF98

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Wed, 22 Mar 2017 18:37:16 +0000

I want to invite anyone who is interested in Internet Video Streaming to a Bar BoF on Internet Video Streaming to be held at IETF98.

Time:     Monday Oct 27th  at 6:30-7:30pm CDT
Where:  Columbus Tap at the Fairmont (this is the overflow hotel and is connected to the venue via the underground mall).

This is open to anyone interested so please feel free to pass this invite along.  I'm told that the Columbus Tap also has a fine selection of beer!

This is a non-hosted event, meaning no free beer, but there will be great discussion of Internet video!

regards
Glenn Deen

------

Topic: Video Streaming eXtensions (V-SX)

Description:

Due to its size and sensitivity to network conditions, the transport of video over the Internet has highlighted a significant scalability problem for the Internet.  On the belief that addressing this scalability problem requires better integration between application transport and networking technologies and leveraging IPv6, this Bar BOF will solicit experiences of the scaling problem as perceived from different parts of the industry (network, producer, vendors).

Video is without rival the top use of Internet bandwidth, and its ever growing demand for more bandwidth easily out paces the new capacity being added both globally and regionally with no let up in sight.   Users are frustrated by quality, buffering, and stuttering problems. Video providers and access networks are investing heavily to keep up with demand.  Significant work has be done at the application layer producing more efficient codecs and innovative adaptive bitrate transports like MPEG-DASH.  These access investments and application layer work have helped but they alone have not been enough.

A target of any eventual work and product is to enable video and network routing / management to work more cooperatively and efficiently to transport video.  Successful approaches will need to do so in a backward compatible ways to permit exiting devices and players to take advantage of the improved network efficiencies.

One proposed approach to dealing with issues was outlined in the Glass to Glass Internet Ecosystem BoF proposal — related drafts and mailing list information is provided below.  A demonstration of GGIE will be provided during the BoF, for illustration purposes.  Discussion is expected and encouraged to range further than the specific GGIE proposal.

This will be an interactive discussion and we encourage anyone with an interest in this topic to come and share their ideas.

    Agenda
Introduction
Context setting [5min]

Roundtable discussion of the issue(s) [30min]

Demo of GGIE prototype [10min]

Where from here? [15min]
Potential for IETF work — is there interest to pursue?
Work for other groups?

        Mailing List: ​https://www.ietf.org/mailman/listinfo/ggie

        Relevant drafts:
            draft-deen-daigle-ggie-02 :  Glass to Glass Internet Ecosystem Introduction
   draft-rose-deen-ggie-use-cases-00 : GGIE Internet Video Use Cases
   draft-daigle-deen-ggie-uri-snaptr-00 :  Glass to Glass Internet Ecosystem URI and S-NAPTR Use
   draft-deen-naik-ggie-men-mpeg-dash-00 : Using Media Encoding Networks to address MPEG-DASH video

Time:     Monday Oct 27th  at 6:30-7:30pm CDT
Where:  Columbus Tap at the Fairmont (this is the overflow hotel and is connected to the venue via the underground mall).

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Wed, 22 Mar 2017 18:50:13 +0000

Oops very wrong date (credit to Phil for catching it!)

Correct Date is Monday March 27 @6:30 CDT!

My bad,
Glenn

Sent from my iPhone

On Mar 22, 2017, at 7:38 PM, Deen, Glenn (NBCUniversal) <[email-masked]<mailto:[email-masked]>> wrote:

regards
Glenn Deen

------

Description:

    Agenda
Introduction
Context setting [5min]

Where from here? [15min]

        Relevant drafts:

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 26 Mar 2017 19:07:13 +0000

Hi Glenn, all,

Thank you for arranging this.

At the BBC we are very interesting in solving some of the challenges for streaming at scale. Some of our recent research has focused on the transport of MPEG-DASH over multicast, in particular addressing some of the issues around clients' ability to discover such services and reuse of existing technologies.

To this end, we have published an I-D that describes a generic bulk transport using HTTP over multicast QUIC (draft-pardue-quic-http-mcast<https://tools.ietf.org/html/draft-pardue-quic-http-mcast-00>). We also have a prototype of this, specialised for a live MPEG-DASH stream, which we have demonstrated with Automatic Multicast Tunnelling (AMT) at the Hackathon.

We'll be at the Bar boF and hope to meet like minded souls.

Regards
Lucas Pardue
BBC R&D
________________________________
From: 98attendees [[email-masked]] on behalf of Deen, Glenn (NBCUniversal) [[email-masked]]
Sent: 22 March 2017 18:37
To: [email-masked]; [email-masked]
Subject: [98attendees] FW: Video Streaming Bar BoF @ IETF98

regards
Glenn Deen

------

Description:

    Agenda
Introduction
Context setting [5min]

Where from here? [15min]

        Relevant drafts: