Subject: Report out from the NomCom 2016-2017

From: NomCom Chair 2016 <[email-masked]>
Date: Mon, 27 Mar 2017 13:24:17 -0700

All -

Please find below some high level outcomes and observations from this years 
NomCom. Issues of particular interest to the community include both the
issues related to recruiting and supporting nominees and the corner cases we 
encountered that which may require updates to our current guiding documents. 
The list closes with a few action steps that everyone can take to help improve 
next years process.

We will be happy to take questions and community feedback either in Plenary
or via email: [email-masked]

Details on this years membership and the outcomes of our selection processes
can be found here: https://datatracker.ietf.org/nomcom/2016/

I want to thank everyone who participated this cycle. The inputs, the
willingness to serve, and the willingness to support nominee participation all
contributed to our results. Special thanks to Peter Yee for stepping up as
the in-coming NomCom Chair.

Lucy Lynch
NomCom Chair 2016-2017

NomCom 2016-2017

The Three Stages of the NomCom Process

- Recruit and Select NomCom Members  (March -> July)
  -- Calls for Volunteers
  -- Direct email/Registration tick box volunteers
  -- Random Selection Process
  --- 10 voting members drawn from a pool of 128 volunteers
- Recruit Nominees and Gather Data (July -> November)
  -- Position Descriptions
  -- Call for Nominations
  --- Out of 97 nominations 39 were accepted.
  -- Questionnaires
  -- Community Feedback
  -- Interviews with IAB/IESG/IAOC Chairs
  -- Interviews with exiting IAB/IESG Members
  -- Nominee Interviews (38 on-site in Seoul, 1 by phone)
- Select for Open Positions (November -> March)
  -- NomCom review of all inputs
  -- First order sorting
  -- Discussion of top ranked nominees
  -- Straw Polls/Condorcet ranking/etc.
  -- Up/Down E-Vote to confirm top choices
  -- Submit for approval (IAB/ISOC/IESG)
  -- Announce slates when approved.
  -- Feedback provided to nominees who accepted a nomination on request.

Bonus Round Nominee Process (2016-2017) 

- Recruit/Select/Submit/Announce for short term ART AD vacancy
  -- mandated 6 week time-line start to finish
  -- appointment must run a full year
  -- had to complete before IETF 98
  -- There were 14 nominations and 4 people accepted
  -- Interviews were conducted via WebEX
  -- Selection and Approval process was successful

Areas of Weakness:

- Some Areas have very small leadership pools
  -- OPS/INT/TSV
  --- persistent issue over several NomCom cycles
- Employer support for participation
  -- we are losing good candidates due to lack of support
  -- the value to the IETF and the nominee may be well understood
  -- the value proposition for the employer needs work/promotion
- Clear and distinct position descriptions
  -- The IAOC and IAB material may be too generic for the *randomly selected*
     NomCom members who don't track these bodies closely.
  -- The Operations and Management distinction not always reflected
     in community nominations so may need additional flagging.

IETF Internal Data and Tools:

- Validating status for NomCom volunteers
  -- existing data has some gaps
  -- but this is improving with each round of registrations
- Validating primary email addresses in the data-tracker
  -- some folk don't see their nomination due to stale email in profiles
- Tools and AMS folk provide great support to the NomCom 
  -- The tools depend on good data to function
  -- Tools team was quick to fix issues and small requests
  -- There is a wish list for future features
  -- Still a lot of hand crafted tasks outside the existing tool set

NomCom Lessons Learned (Re-learned):

- We needed a Questionnaire for the IETF Chair position
  -- we used the IESG form but had additional questions
- All of the questionnaires are long but... hard to cut down.
- There is a strong bias toward Two Term appointments
  -- one and three term appointment options engender a lot of discussion
- Nominations and feedback both come from a small sub-set of the community
  -- less then 100 individuals overall
- A "living" NomCom Chairs Best Practices document would be useful

RFC Updates Needed:

- The composition of the IESG has changed (and may again)
  -- document the 3 AD pattern
  -- document the 2 AD (not alike) pattern
- We need to document the process for filling an IESG to IESG move
  --- current text addresses IAB to IESG
  --- additional patterns may also occur

and...

The Elephant in the Room:

- Remote Participation
  -- The NomCom has a 3 of 5 meeting requirement for both
     the Chair and the membership
  -- We had one nominee who has been primarily remote
  -- Visa and meeting location issues  

Three things every IETFer can do

- Check your status to volunteer for the NomCom
  -- https://www.ietf.org/registration/nomcom.py
  -- and work with AMS to update your records as needed
  -- if you qualify, check the NomCom Volunteer box when your register
- Check your profile in the data-tracker
  -- https://datatracker.ietf.org/accounts/profile/
  -- are your Primary and Active email details correct?
- Provide feedback on the Nominees!
  -- consider providing area and issue feedback as well

---

From: Michael Richardson <[email-masked]>
Date: Mon, 27 Mar 2017 17:17:06 -0400

NomCom Chair 2016 <[email-masked]> wrote:
    > - Check your status to volunteer for the NomCom --
    > https://www.ietf.org/registration/nomcom.py -- and work with AMS to
    > update your records as needed -- if you qualify, check the NomCom
    > Volunteer box when your register

Maybe these two steps could be combined, and one's nomcom eligility placed
on your registration receipt...

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: George Michaelson <[email-masked]>
Date: Mon, 27 Mar 2017 16:27:36 -0500

I'd like to thank Lucy and all the nomcom team I interacted with, for
a positive, affirming and above-all human(e) process.

I found the entire conversation very profitable. I understand
expectations better, and I was able to "escape the room" with my
dignity and a sense of purpose intact.

Considering the modern focus on 3h and 3day whiteboard tests of
terror, what we did, is have a conversation of equals.

which, I like.

so, thanks.

-George

---

From: Barry Leiba <[email-masked]>
Date: Mon, 27 Mar 2017 17:43:05 -0500

>   -- Feedback provided to nominees who accepted a nomination on request.

I've thanked the NomCom for this last item, and I want to repeat that
thanks publicly: I'm *so* glad that this NomCom has agreed to provide
feedback, I've found their feedback to be excellent and valuable to
me, and I very much hope that future NomComs continue this new
practice.

Barry

---

From: Alia Atlas <[email-masked]>
Date: Mon, 27 Mar 2017 18:45:27 -0400

> me, and I very much hope that future NomComs continue this new

I strongly agree.  It is extremely helpful to have feedback.

Regards,
Alia

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 27 Mar 2017 23:48:09 +0100

Echo what Barry said.
IMHO, giving feedback was a very brave thing to do. 
Previous NomComs have shied away from this for fear of confidentiality and the additional thought and hard work needed to keep community feedback anonymous. 
Also NomComs have been worried about opening discussions about their decisions.
I think this year's NomCom handled this very well, and I hope they leave a sound trail of breadcrumbs for future NomComs to follow.

Adrian

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 27 Mar 2017 19:00:48 -0400

Dear colleagues,

I've now had more than one person ask me about this, and since the
NomCom report raises the issue of employer support I think
transparency requires that I say something.

While I never planned to stand for IAB chair again this year, I did
submit my candidacy for reappointment to the IAB.  Unfortunately, due
to some uncertaintly in my personal circumstances before the NomCom
rendered its decision, I had to withdraw my name from consideration at
the last minute.  To be clear, my current employer did not withdraw
support for my activities in the IETF.  I apologise to those who spent
their time sending comments assuming my commitment to stand, when it
turned out I could not follow through on that commitment.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]