Subject: Proposal to revise ISOC's mission statement

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 26 Oct 2017 11:18:08 +0300

Hi,

the board of trustees of the Internet Society (ISOC) plans to revise
ISOC's mission statement. We would like to get your comments on the
proposal we include below. This email discusses the reasons for the
proposed change, the process we have followed so far to put together
the current proposal, and the next steps in the process.

ISOC's current vision and mission statements were developed around
2005 and are available at ISOC's web page:

https://www.internetsociety.org/mission/

These statements have provided ISOC with a clear direction for many
years and have been a useful tool for the community.

What ISOC does in practice to fulfill its vision has evolved over
time.  Looking at the environment in which ISOC operates, there have
been important changes (some external and some internal to ISOC) that
make it desirable to revise those statements at this point.

Externally, the current Internet environment is different from what it
was when the current statements were developed: regional needs are
different, communication patterns are different, and the
standardization landscape is different. Internet users and, thus, also
ISOC's chapters and members are more international and many of them
come from developing countries.

Internally, ISOC's revenue sources have increased significantly from
2005 until present. This means that ISOC's potential to realize its
vision through activities has increased substantially and may still
continue to increase in the near term. The board considers that simply
increasing linearly everything ISOC does today would not be a viable
or desirable approach. Building a large reserve without further
advancing ISOC's social goals is not a good option either. Instead,
ISOC will strengthen some of its current areas of engagement and, when
appropriate, engage in new impactful activities in new areas.

Our goal is to bring more focus into the organization. The idea is to
avoid spreading ourselves too thin and, instead, increase ISOC's focus
on activities that make a difference.

In order to make those key decisions, staff, the board, and the
community need to be on the same page regarding ISOC's vision and
mission, and their underlying meaning. Given that many members of
staff, the board, and the community were not around when the current
statements were developed back in 2005, revising them with their
involvement was considered to be a necessary exercise so that
everybody feels them as their own. Getting a common sense of ownership
is one of our main goals.

In order to have a fresh look at our vision and mission, a set of
workshops involving the whole staff were organized.  Using an
iterative process and taking the input from those workshops into
consideration, further workshops involving the board and ISOC's senior
management were organized with the help of a facilitator. Some of the
workshops were virtual and some of them were face-to-face.

The board had a face-to-face retreat where, based on all the work
above, revised draft statements were generated. Those draft statements
were sent to parts of the community (including IETF leadership, ISOC's
emeriti trustees, and chapter and org members) to get initial
comments. After gathering a good amount of initial community feedback,
the board generated new proposed statements addressing the comments
received. With the process above the board aimed to ensure that the
revised statements take into account the perspectives of staff as well
as our wider community.

The resulting proposed statements (included below) are now ready to be
sent to our whole community.

During the process above, we agreed that ISOC's current vision and
mission are still as valid as ever. With respect to the *statements*
that capture the spirit of the vision and mission, we do not propose
any changes to the vision statement.

With respect to the mission statement, we propose to update it.  One
of the goals with the new statement is that it is both concise and
memorable.  Consequently, the mission is stated at a higher
abstraction level and contains fewer points.

The current mission statement included a list of activities ISOC
performs to help achieve our mission. While it seems that list was not
approved as part of the mission statement back in the day, the initial
feedback we have gotten from the community clearly indicates that many
consider capturing the list in an official way important. Therefore,
we propose to keep those bullets as highlights of activities.

It is worthwhile noting that, regardless of the outcome in the form of
a revised mission statement, this process is being very useful in
itself. It has clearly helped getting a better understanding about
ISOC's purpose among everybody involved.

Please, find the proposed statements below and share your comments
with us on this list. Thanks!

Cheers,

Gonzalo Camarillo (for the board)
Chair - ISOC Board of Trustees

--- Proposal ---

Vision:
-------

  The Internet is for everyone.

Mission:
--------

  The Internet Society champions the development of the Internet as a
  global technical infrastructure, a resource to enrich people's
  lives, and a force for good in society.

  We work with the worldwide Internet community for an Internet that
  is open, globally-connected, and secure.

  Together, we focus on:

  - Building and supporting the communities that make the Internet work;

  - Advancing the development of Internet infrastructure,
    technologies, and open standards; and

  - Advocating for sound Internet policy around the world.

Highlights of Activities:
-------------------------

  To help achieve our mission, the Internet Society:

  - Facilitates open development of standards, protocols,
    administration, and the technical infrastructure of the Internet.

  - Supports education in developing countries specifically, and
    wherever the need exists.

  - Promotes professional development and builds community to foster
    participation and leadership in areas important to the evolution
    of the Internet.

  - Provides reliable information about the Internet.

  - Provides forums for discussion of issues that affect Internet
    evolution, development and use in technical, commercial, societal,
    and other contexts.

  - Fosters an environment for international cooperation, community,
    and a culture that enables self-governance to work.

  - Serves as a focal point for cooperative efforts to promote the
    Internet as a positive tool to benefit all people throughout the
    world.

  - Provides management and coordination for on-strategy initiatives
    and outreach efforts in humanitarian, educational, societal, and
    other contexts.

--- End of Proposal ---

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 26 Oct 2017 16:30:51 +0300

Hi Gonzalo,

I will suggest that we have a clear text (may be in the mission statement) that avoids ISOC (and staff) to get involved into courts decisions in democratic countries and even comment them unless they have documents that demonstrate what they are saying. The recent happenings in Catalonia and the lies that ISOC staff has communicated, are not only illegal but also lies, and can bring legal consequences to ISOC & staff as a Spanish prosecutor is already looking into that. I’m not going to repeat myself on this, this is explained at:

http://www.circleid.com/posts/20170926_catalonian_matter_law_order_democracy_freedom_of_speech_censorship/
and the continuation at:
https://jordipalet.blogspot.co.uk/2017/09/isoc-against-its-own-principles-acting.html

Also, after reading your email, and according to the highlighted activities I will like to bring a couple of possible more concrete actions.

1) As one of the proposed activities is “Facilitates open development of standards, protocols, administration, and the technical infrastructure of the Internet”, and this is clearly referring, at least in part, to IETF, considering increase in the revenue that you mention, I think it will be very relevant to understand that many frequent and active participants are contributing from their own pockets, which our own personal time. So, I think we should consider that those not backed by big companies, could get some funding at least to cover their registration fee. I’m not sure if also traveling expenses, but I guess increasing the ISOC contribution to IETF, to make the registration fee free for those that need that support, will not mean a very high cost for ISOC and for many of us it is over 2.000 USD per year.
2) I’m missing highlighting very concrete activities regarding “globally-connected, and secure”. Let me explain what I think are relevant actions that can be taken here in the next paragraphs.

I’ve been tracking personally the problem of spam for several years, and precisely we had a discussion with some folks on this yesterday night. I’m clear that it requires some investigators, and I’m not talking only about “network” research, but also lawyers. I’m convinced that whois privacy is a big problem, as it hides criminals, and we should get involved in making sure that ICANN understands it.

My few resources to investigate this, brought me to the conviction (I’m not saying that it was not clear for me before, but now I’ve evidences) that there are some criminal organizations using spam for many other criminal actions. They create user databases (at least with emails, but possibly other personal data), and they are at the minimum, selling or hiring those databases to another kind of “legal” but in my personal view, also criminal organizations which call themselves “email marketing companies”. Nobody, in general provides his/her email for receiving spam, and in many countries, this is forbidden, and is even against the law, to have registered you email (despite what the “form” said), and use it for a different “ad campaign”. In many countries every spam sender, requires a previous and explicit acceptance from the email owner, but this is never respected.

I’ve got threatened by several of those organizations when I’ve tried to act against them, and unfortunately, I don’t see data protection agencies and governments taking a strong position/action on this, so Internet citizens are not protected.

I think ISOC could invest in doing a good investigation on this (I’m happy to help, I’ve even a law proposal for governments to be able to fine/punish organizations hiring those illegal “spam” services), bring this data to lawyers, and start a few suites against those criminal organizations, so governments actually see the problem, make strong rules and enforce them.

In summary, in my opinion “email marketing” should be only used for a company to advertise their *own* products to their *own* customers or interested ones that have explicitly agreed on that (which is what the law say in many countries, but is not getting enforced).

I’m talking about spam, but the implications of what I explained above are related to security in general in the network, intrusion in our “own” devices and apps, and all kind of related cybercrimes, and in the near future, if we don’t act now, it will also have very serious implications in IoT and new developments.

This week, during the RIPE meeting in Dubai, I learnt from ISOC staff about the OTA (https://otalliance.org/), which is now an ISOC activity. This is one of the topics I believe ISOC should invest. My view has two sides:
a) The use of clouds is good (I don’t think is technically necessary with IPv6), but it requires SDOs, governments and industry to agree in ways to protect consumers. Short explanation. You by a device, it works only (or many of the best features) thru a cloud. Vendor goes to bankrupt, you throw away the device, even if it costed several hundred dollars. Possible solution, governments have laws (as in any other field, FCC, EC, UL, etc.), that mandate that every device being imported in a territory, either is not using cloud, or it has open and standard APIs so instead of using only the vendor “free” cloud can be attached/used to other ones without losing functionalities.
b) Security of those devices. Any Internet or IoT device, must pass (the same as FCC, EC, etc.), minimum security testing to allow to be upgraded when security bugs are found, to avoid easily being hacked, etc. I recall when we had modems, that need to pass specific regulations, and you can’t bring them to your country is they don’t have got the certification number. Nothing new here, just a different way to “connect” (it was RJ45 before, now is IP).

A possible path for both areas is having the same organizations doing those FCC, EC, UL, etc., testing, increasing their test, with the support from IETF or other SDOs when applicable, and making sure that governments and industry get together in supporting it and not allowing non-compliance devices to be in the market. I believe that having the same “certification” authorities, will not increase the “testing” cost, neither the “enforcement” cost (same border controls in customs when importing products), and vendors will have an “easy” way to follow those specs if we work together.

In my opinion ISOC has the power and budget to do that, and again, I’m happy to work on this area and specially contribute to the discussion of possible paths.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Gonzalo Camarillo <[email-masked]>
Responder a: Gonzalo Camarillo <[email-masked]>
Fecha: jueves, 26 de octubre de 2017, 11:21
Para: <[email-masked]>
Asunto: Proposal to revise ISOC's mission statement

    Hi,

    

    

    

    

    

    
    Cheers,

    --- Proposal ---
    
    Vision:
    -------

    Mission:
    --------

    
      Together, we focus on:

    

    

    

    

    --- End of Proposal ---

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Randy Bush <[email-masked]>
Date: Thu, 26 Oct 2017 15:35:29 +0200

> I will suggest that we have a clear text (may be in the mission
> statement) that avoids ISOC (and staff) to get involved into courts
> decisions in democratic countries

got a list of 'democratic' countries?

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 26 Oct 2017 17:20:03 +0300

Very simple, unless is demonstrated that the country government and the courts are under the same power, which is not the case for Spain. Split power is a basic principle of democracy.

ISOC MUST respect court orders as all the citizens do, otherwise we will have no democracy, but chaos.

ISOC is doing false accusations. They have said “major telecom operators have been asked to monitor and block traffic to political websites, and following a court order, law enforcement has raided the offices of the .CAT registry in Barcelona, examining a computer and arresting staff.”

Only one person was arrested, because he was suspicions as cooperator or an unlawful act. Nobody asked operators to “monitor”. I’ve copy of the court order, and I can show you in Singapore if you want.

ISOC was warned also by other Spanish chapters that this is not true, and they didn’t correct it.

Regards,
Jordi

---

From: Michael Richardson <[email-masked]>
Date: Thu, 26 Oct 2017 11:51:56 -0400

> the current proposal, and the next steps in the process.

Thanks.

    > ISOC's current vision and mission statements were developed around 2005
    > and are available at ISOC's web page:

    > https://www.internetsociety.org/mission/

re-reading it, I find that I agree with all the ideas presented in 2005, but
I think it would be difficult for a person not intimately familiar with ISOC
to connect the points given to the specific activities.

    > come from developing countries.

Could you characterize what you think the changes in communications patterns are?

    > 2005 until present. This means that ISOC's potential to realize its

ISOC has more money, but are it's revenue sources significantly more diverse?
Or to put it another way, can ISOC do things now that might have pissed off
some of it's donors before?

    > on activities that make a difference.

Do less (or the same) things better, rather than do more things.

    > involvement was considered to be a necessary exercise so that everybody
    > feels them as their own. Getting a common sense of ownership is one of
    > our main goals.

As the new mission statement is in point form, like the previous one,
I want to suggest that each of the mission statement points be given a
name/handle (to the point of having an HTML anchor on the web page..) so that
it can easily be referred to in other documents.

While secure is mentioned, that can mean "secure for children" or "secure
against terrorists". For some governments that translates into "no privacy",
(no TLS!) which is exactly the opposite of what most of us think of when we
say "secure".

So, I'd like to see the privacy tussle mentioned more prominently if we are going to say "secure"

Somewhere, perhaps not in the normative part of the mission statement, I'd

    > administration, and the technical infrastructure of the Internet.

    ... (such as being the home for ietf.org, XXX, YYY)

Maybe a prominent link in the mission statement page that says something
like, "How ISOC implements it's mission statement"

    > global technical infrastructure, a resource to enrich people's lives,
    > and a force for good in society.

    >   We work with the worldwide Internet community for an Internet that is
    > open, globally-connected, and secure.

    >   - Advancing the development of Internet infrastructure, technologies,
    > and open standards; and

    > participation and leadership in areas important to the evolution of the
    > Internet.

    > evolution, development and use in technical, commercial, societal, and
    > other contexts.

    > Internet as a positive tool to benefit all people throughout the world.

    > and outreach efforts in humanitarian, educational, societal, and other
    > contexts.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Gonzalo Camarillo <[email-masked]>
Date: Thu, 26 Oct 2017 19:49:39 +0300

Hi Michael,

> Could you characterize what you think the changes in communications patterns are?

Back in 2005, the community was not consulted for things such as coming
up with a mission statement; that was simply the environment back then.
At present, we want to be involve the community as much as it is
feasible. That is why we are sending out requests for input such as this
one.

> ISOC has more money, but are it's revenue sources significantly more diverse?

No, they are not significantly more diverse.

> some of it's donors before?

No, we should still try not to piss off any of our donors :-)

> Do less (or the same) things better, rather than do more things.

Right, we are currently focusing on impact as opposed to activities.

> it can easily be referred to in other documents.

As you probably know, the new ISOC's web page has just been launched.
Content is still being migrated from the old page to the new one. I will
talk to the web team to make sure the statements are presented in a good
and clear way.

> So, I'd like to see the privacy tussle mentioned more prominently if we are going to say "secure"

ISOC has been using the "open, globally-connected, and secure"
adjectives for a while, AFAICT. Secure here is to be understood as in
the "trust" initiative ISOC has been driving. It is definitively not to
be understood as not using TLS. Do you have in mind any other adjective
that reflects better the intent?

> like, "How ISOC implements it's mission statement"

Yes, we intend to have text explaining all that on the new web page.
When we gather enough input we will work on finalizing the migration
from the old web page and generating any new material needed.

Thanks for the comments!

Cheers,

Gonzalo

---

From: Paul Wouters <[email-masked]>
Date: Thu, 26 Oct 2017 13:07:54 -0400 (EDT)

On Thu, 26 Oct 2017, JORDI PALET MARTINEZ wrote:

This is a very political message saying not to do politics.

I'm sure there are more appropriate lists for this than the IETF list?

Paul

> Date: Thu, 26 Oct 2017 10:20:03
> From: JORDI PALET MARTINEZ <[email-masked]>
> To: [email-masked]
> Subject: Re: Proposal to revise ISOC's mission statement
>

---

From: Doug Royer <[email-masked]>
Date: Thu, 26 Oct 2017 12:29:15 -0600

> the current proposal, and the next steps in the process.

It looks fantastic. It looks sufficiently  general to be able to adapt 
for the next decade.

-- 

Doug Royer - (http://DougRoyer.US  http://goo.gl/yrxJTu )
[email-masked]
714-989-6135

---

From: Alia Atlas <[email-masked]>
Date: Thu, 26 Oct 2017 16:49:23 -0400

On Thu, Oct 26, 2017 at 2:29 PM, Doug Royer <[email-masked]> wrote:

> It looks fantastic. It looks sufficiently  general to be able to adapt for
> the next decade.

+1  (which is it looks good, covers what I'd expect, and I don't have
detailed comments)

---

From: Miles Fidelman <[email-masked]>
Date: Thu, 26 Oct 2017 23:27:28 -0400

Personal opinion:  The current mission statement is way too long. John 
Kennedy penned the prototypical mission statement "Land a man on the 
moon, before this decade is out, and return him safely to Earth."  The 
military is pretty good at mission statements, too: Short, sweet, too 
the point - who, what, where, when (how is for more detailed plans).

And, just to be clear, the true mission of ISOC has long been to provide 
a non-governmental, stakeholder controlled home for Internet Standards 
(i.e., IETF).  Everything else is fluff.

IMHO.  We need something short & pithy, like "The Glue that Holds the 
Internet Together."  Put the laundry list of bullet points on the next 
slide.

Miles Fidelman

-- 
In theory, there is no difference between theory and practice.
In practice, there is.  .... Yogi Berra

---

From: Miles Fidelman <[email-masked]>
Date: Thu, 26 Oct 2017 23:30:53 -0400

A couple more pithy mission statements:

MIT: "The mission of MIT is to advance knowledge and educate students in 
science, technology, and other areas of scholarship that will best serve 
the nation and the world in the 21st century."

DARPA:  "For more than fifty years, DARPA has held to a singular and 
enduring mission: to make pivotal investments in breakthrough 
technologies for national security."

On 10/26/17 11:27 PM, Miles Fidelman wrote:
> And, just to be clear, the true mission of ISOC has long been to 
> provide a non-governmental, stakeholder controlled home for Internet 
> Standards (i.e., IETF).  Everything else is fluff.
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 27 Oct 2017 10:04:16 +0300

Hi Miles,

inline:

> the point - who, what, where, when (how is for more detailed plans).

That is why we have the *vision* statement, which is short and sweet,
and seems to have strong support from large parts of the community.

> (i.e., IETF).  Everything else is fluff
Per the proposal, there are three main pillars: communities, technology,
and policy. I understand *you* consider two of these pillars "fluffy",
but others would obviously not agree with that :-)

Cheers,

Gonzalo

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 27 Oct 2017 10:14:31 +0300

Doug, Alia,

thanks for the input!

Alia, now that I have you thinking of ISOC :-) and before you delete the
context from your brain, you have been reaching out to other communities
(open source communities in particular) in order to help improve the
IETF's processes and outputs.

As you know, ISOC supports the IETF in several ways (in addition to
providing funding). Please, think about how ISOC could help support the
IETF in potentially new ways or how the current programs could make an
even larger impact, and let's have a conversation in Singapore. Thanks!

Cheers,

Gonzalo

On 26/10/2017 11:49 PM, Alia Atlas wrote:
> 
> 
> On Thu, Oct 26, 2017 at 2:29 PM, Doug Royer <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     It looks fantastic. It looks sufficiently  general to be able to
>     adapt for the next decade.
> 
> 
>     [email-masked] <mailto:[email-masked]>
>     714-989-6135 <tel:714-989-6135>
> 
>

---

From: Gonzalo Camarillo <[email-masked]>
Date: Fri, 27 Oct 2017 10:32:10 +0300

Hi Jordi,

thanks for all the input!

With respect to ISOC commenting on political issues, Frederic's
clarifying statement (which was issued after the first one) said:

> There are many other stakeholders who are much better positioned
> than the Internet Society to deal with and comment on these
> political aspects.

So, yes, ISOC's role in those cases is not to take political sides but
to comment on technical issues.

With respect to your other comments, as you point out they are more
about concrete activities than mission-level comments. I will relay
them to those in ISOC dealing with those areas. In any case, you can
find my brief initial comments below:

1) ISOC has programs that bring "technical" and "policy" people to the
IETF. In addition, we have received requests from the chapters
community to have ISOC provide grants to support more-experienced IETF
participants. One example given was, indeed, to have ISOC cover the
registration fee for a few participants who meet some given criteria.

As I mentioned in a previous email, we are going to also
get the opinion of the IETF leadership about what is the best way to
help the IETF in that area. So, in short, we are currently looking
into this.

2) How to have IoT deployments with better  security and resilience
was discussed in a plenary a few IETF meetings ago, IIRC. In addition
to having governments regulate such deployments, self-regulation by
the industry is another alternative that is often discussed. ISOC's
policy people are looking into that as well.

Again, thanks for the comments, Jordi!

Cheers,

Gonzalo

---

From: Alia Atlas <[email-masked]>
Date: Fri, 27 Oct 2017 10:06:39 -0400

Hi Gonzalo,

> even larger impact, and let's have a conversation in Singapore. Thanks!

I would be delighted to.  I'm quite interested in figuring out the ways to
improve
overlap in the communities and better collaboration.  I hope others on this
list are
also encouraged to discuss and think more about what an ideal situation
would
look like.

I do have a plan for a draft clarifying that standards-track RFCs can refer
to stable (invariant)
open-source work, as was discussed and agreed to be useful during the
IESG/IAB retreat.
There are community interactions that are needed - but to me, a first step
is being clear
that - with IETF community consensus for the process and details - the IETF
can also
build on top of the excellent work from many open source projects as well.

Regards,
Alia

---

From: Michael Richardson <[email-masked]>
Date: Fri, 27 Oct 2017 11:40:32 -0400

> even larger impact, and let's have a conversation in Singapore. Thanks!

My take is (in this order);
   * longer, more involved Hackathons,
   * open source reference implementations  (%)
   * cheaply and easily reproduceable test bed/skaffolding for complex protocols
   * facilitating conformance testing, particularly for open source implementations.

(for instance, it's particularly difficult to create complex enough
infrastructures to test routing protocols such as BGP4, but this also applies
to SIDR, S/MIME, OAUTH and even some IPsec setups)

Looking up, I see a theme which is really about getting from Proposed
Standard to Internet Standard faster and in ways that engages more pieces of
the vendor and operational communities.

(%)-you may say this is self-serving, and I agree. So I'll just make my interest explicit.

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 27 Oct 2017 09:41:26 -0700

>    * facilitating conformance testing, particularly for open source implementations.

If we are going in that direction then I think it about time that the IETF starts using formal methods to verify protocols, so instead of partially checking that a protocol works (which is the best that hackathons or testing can bring to the table), we have a guarantee that they do work.  (self-serving too, as I am working since a couple years on yet another markdown language that does exactly that).

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: Alia Atlas <[email-masked]>
Date: Fri, 27 Oct 2017 12:46:14 -0400

On Fri, Oct 27, 2017 at 12:41 PM, Marc Petit-Huguenin <[email-masked]>
wrote:

> If we are going in that direction then I think it about time that the IETF
> starts using formal methods to verify protocols, so instead of partially
> checking that a protocol works (which is the best that hackathons or
> testing can bring to the table), we have a guarantee that they do work.
> (self-serving too, as I am working since a couple years on yet another
> markdown language that does exactly that).

The wonderful and frustrating thing is that there isn't a single activity
that will capture all of what would be useful.
Luckily, these can be bitten off in smaller chunks.  How would either of
you experiment with creating the efforts your are suggesting?
What support is needed?  Why would folks be motivated to help or able to
see what incremental success looks like?

Incidentally, do check out the Code Lounge at IETF 100 as an effort to
encourage Hackathon-style coding to continue...

Regards,
Alia

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 27 Oct 2017 09:59:49 -0700

On 10/27/2017 09:46 AM, Alia Atlas wrote:
> On Fri, Oct 27, 2017 at 12:41 PM, Marc Petit-Huguenin <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     > Gonzalo Camarillo <[email-masked] <mailto:[email-masked]>> wrote:
>     checking that a protocol works (which is the best that hackathons or testing
>     can bring to the table), we have a guarantee that they do work. 
> The wonderful and frustrating thing is that there isn't a single activity that 
> will capture all of what would be useful.

Sure, but it would be a good start to have something in the ISOC mission statement about promoting protocol checking (hackathon, testing) and formal verifications of the IETF standards.

> Luckily, these can be bitten off in smaller chunks.  How would either of you 
> experiment with creating the efforts your are suggesting?
> What support is needed?  Why would folks be motivated to help or able to see 
> what incremental success looks like?
> 
> Incidentally, do check out the Code Lounge at IETF 100 as an effort to encourage 
> Hackathon-style coding to continue...
> 
> Regards,
> Alia
> 
>      >
>      > Michael Richardson <[email-masked]
>     <mailto:[email-masked]>>, Sandelman Software Works
>     Email: [email-masked] <mailto:[email-masked]>
>     Blog: https://marc.petit-huguenin.org <https://marc.petit-huguenin.org>
>     <https://www.linkedin.com/in/petithug>
> 
>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 27 Oct 2017 20:40:17 +0000

Overall I think the new mission statement is quite good. One specific comment inline.

-----Original Message-----
From: ietf <[email-masked]> on behalf of Marc Petit-Huguenin <[email-masked]>
Date: Friday, October 27, 2017 at 10:00 AM
To: Alia Atlas <[email-masked]>
Cc: Doug Royer <[email-masked]>, Michael Richardson <[email-masked]>, Gonzalo Camarillo <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Proposal to revise ISOC's mission statement

Rather than add more specific examples to the existing set of highlighted activities, how about adding something in the mission statement about implementation and application in addition to the development of open standards. This would leave it to the IETF community to decide on methods to achieve this, e.g. more emphasis on running code, reference implementations, protocol validation, workshops on enabling new standards and functionality, etc.

Cheers,
Charles

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 27 Oct 2017 17:08:31 -0500

FWIW,

On Fri, Oct 27, 2017 at 3:40 PM, Charles Eckel (eckelcu) <[email-masked]>
wrote:

> Cc: Doug Royer <[email-masked]>, Michael Richardson <
> [email-masked]>, Gonzalo Camarillo <[email-masked]>,
> "[email-masked]" <[email-masked]>
>     Sure, but it would be a good start to have something in the ISOC
> mission statement about promoting protocol checking (hackathon, testing)
> and formal verifications of the IETF standards.
>
> Rather than add more specific examples to the existing set of highlighted
> activities, how about adding something in the mission statement about
> implementation and application in addition to the development of open
> standards. This would leave it to the IETF community to decide on methods
> to achieve this, e.g. more emphasis on running code, reference
> implementations, protocol validation, workshops on enabling new standards
> and functionality, etc.

I think that's just about right.

Spencer

---

From: S Moonesamy <[email-masked]>
Date: Fri, 27 Oct 2017 15:45:35 -0700

Hi Gonzalo,
>the current proposal, and the next steps in the process.

[snip]

>Highlights of Activities:

The above sounds laudable.  Could ISOC disclose the percentage of 
revenue which it has spent on the IETF yearly and on the second 
activity yearly over the last five years?

Regards,
S. Moonesamy

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 28 Oct 2017 15:00:43 +1300

Marc,
> On 10/27/2017 08:40 AM, Michael Richardson wrote:
...
> If we are going in that direction then I think it about time that the IETF starts using formal methods to verify protocols, so instead of partially checking that a protocol works (which is the best…
Some of us were very badly burned, in one way or another,
by formal conformance tests of OSI implementations the
best part of 30 years ago. So while I fully support Michael
on "facilitating conformance testing" and would even insert
the word "rigorous", I would be very cautious about "formal
methods" (except for things like MIB modules and YANG, where
clearly a formal check is required).

Interoperability remains, IMHO, much more important than
formal correctness. Implementations can be formally correct
but faulty in practice.

In any case, I don't think that distinction is relevant to the
ISOC mission, which needs to retain some level of abstraction.

Regards,
    Brian

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 28 Oct 2017 10:12:33 +0200

> On Oct 28, 2017, at 04:00, Brian E Carpenter <[email-masked]> wrote:
> 
> best part of 30 years ago. 

It can be argued that improper use of formal description techniques (FDTs) was one of the main factors that killed off OSI.

http://www.cs.columbia.edu/~hgs/papers/2011/Dagstuhl%2011042.pdf
http://boemund.dagstuhl.de/mat/index.en.phtml?11042
http://boemund.dagstuhl.de/mat/Files/11/11042/11042.PrasAiko.Slides.pdf

In the IETF, we have evolved a few FDT usage modes that do make sense (ABNF, YANG, …), and even successfully invented some rather special purpose FDTs (RFC 4997).

Research into how we can improve interoperability using FDTs without repeating the OSI mistakes should be encouraged; if something comes out of this, it also would be useful to pilot its use within IETF standardization in a way that is conscious of the pitfalls.  (FDT use is highly vulnerable to what we call “process confabulation” in software engineering; constant vigilance against that is required to come up with realistic usages.)

We do have some semiformal test descriptions that are oriented at interoperability, e.g.

https://github.com/cabo/td-coap4
or
https://www.ietf.org/mail-archive/web/6tisch/current/pdfgDMQcdCkRz.pdf

These were developed after the protocol specifications were mostly done, but did help in their finishing even if they didn’t themselves flow back into the standards.  We need to find *good* ways to do more of this.

Grüße, Carsten

---

From: Rich Kulawiec <[email-masked]>
Date: Sat, 28 Oct 2017 05:15:21 -0400

I'm only going to address one part of this.

On Thu, Oct 26, 2017 at 04:30:51PM +0300, JORDI PALET MARTINEZ wrote:
> I???ve been tracking personally the problem of spam for several years [...]

I've been studying the problem of spam for several decades, and while it's
certainly serious, certainly has numerous privacy and security implications,
certainly is extensively linked to other forms of abuse and attacks, and
certainly is contrary to some laws in some countries, I don't think
a massive litigation strategy is will be effective against it -- nor do
I think that's something the ISOC (or IETF) should pursue.

> I???m convinced that whois privacy is a big problem, as it hides criminals,
> and we should get involved in making sure that ICANN understands it.

I think they understand it just fine.

---rsk

p.s. To clarify, I'm on the record stating that there should be no
anonymity of any kind in WHOIS: those operating resources on the public
Internet need to be publicly acccessible and publicly accountable.
I've also said that all WHOIS data (and all TLD zone data) should be
completely publicly accessible -- including in bulk download format
with no registrations/restrictions/etc.  But I strongly doubt either
of these things will happen.

---

From: "John Levine" <[email-masked]>
Date: 28 Oct 2017 10:40:08 -0000

>activity yearly over the last five years?

ISOC's financial reports are public.  Recent financial reports are
here.  They're in the midst of moving stuff from the old site to the
shiny new one and some files aren't there yet, but I think the 2016
report should be added soon.

https://www.internetsociety.org/about-internet-society/financial-reports/

IETF budgets are here, including how much ISOC contributes.

https://iaoc.ietf.org/budget-and-finance.html

The IETF contribution fluctuates from year to year but is roughly 10%
of ISOC's budget.  I don't know off the top of my head what the
numbers are for capacity development.

R's,
John

---

From: Russ Housley <[email-masked]>
Date: Sat, 28 Oct 2017 07:30:14 -0400

> On Oct 27, 2017, at 10:00 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Marc,

Care must be taken that ISOC does not create an unfortunate feedback loop by sponsoring standards development and conformance testing of implementations.  Testing should provide feedback into the standards process, but testing should not drive the standards process.

Russ

---

From: Sam Hartman <[email-masked]>
Date: Sat, 28 Oct 2017 09:51:42 -0400

>>>>> "Russ" == Russ Housley <[email-masked]> writes:

    >> Some of us were very badly burned, in one way or another, by
    >> formal conformance tests of OSI implementations the best part of
    >> 30 years ago. So while I fully support Michael on "facilitating
    >> conformance testing" and would even insert the word "rigorous", I
    >> would be very cautious about "formal methods" (except for things
    >> like MIB modules and YANG, where clearly a formal check is
    >> required).
    >> 
    >> Interoperability remains, IMHO, much more important than formal
    >> correctness. Implementations can be formally correct but faulty
    >> in practice.
    >> 

    Russ> Care must be taken that ISOC does not create an unfortunate
    Russ> feedback loop by sponsoring standards development and
    Russ> conformance testing of implementations.  Testing should
    Russ> provide feedback into the standards process, but testing
    Russ> should not drive the standards process.

Russ, I suspect I probably agree with you.  However, I spent a couple of
minutes trying to understand what you wrote and realized that I was
having a hard time.  Could you give a couple of example of giving
feedback into the standards process (what you'd like to see) and testing
driving the standards process so I can see the difference?

Thanks for your consideration,

--Sam

---

From: [email-masked]
Date: Sat, 28 Oct 2017 06:48:07 -0700 (PDT)

> It can be argued that improper use of formal description techniques (FDTs)
> was one of the main factors that killed off OSI.

> http://boemund.dagstuhl.de/mat/Files/11/11042/11042.PrasAiko.Slides.pdf

You can make that argument, but in the case of email at least, you would
be incorrect. The most that can be said is that formal methods did not help.

In the case of email, the central problem was the actual protocol design was at
odds with reality.

Implementing X.400 was expensive and tedious, but we managed. Passing the
various required conformance tests was even more tedious, and occasionally
nasty because there were a number of cases where the tests were flat-out wrong,
and getting the testing folks to look at what the standards actually said was
difficult. (It was generally easier to implement options to break our
implementation.)

But real nightmware was deployment and trying to achieve interoperability. That
basically never happened.

I still remember the day I realized that the X.400 had failed. It was at a EMA
meeting discussing how to make the file transfer body part do something useful.
The chair passed around a sign-up sheet, but as he did so said something like,
"Be sure to put down your Internet address; most of X.400 addresses you folks
provided last time didn't work."

When you've botched things to the point where a room full of experts in the
field cannot even manage to write down a working address, you're toast.

				Ned

---

From: John C Klensin <[email-masked]>
Date: Sat, 28 Oct 2017 10:34:31 -0400

>> clearly a formal check is required).

As Carsten pointed out, many people have suggested that the
formal methods and the way conformance testing was carried out
where what killed OSI.   Personally, and having been involved in
the oversight process at the time, I think these were very long
list of reasons, any one or two of which might have been
sufficient.  While it has little to do with this discussion, at
least one other one may be instructive for the IETF today:
complex protocols, with many cases and options, are a bad idea,
especially when they are caused by "you can have yours if I get
mine" compromises.  Those also tend to spawn checklists and
conformity tests.

> Care must be taken that ISOC does not create an unfortunate
> feedback loop by sponsoring standards development and
> conformance testing of implementations.  Testing should
> provide feedback into the standards process, but testing
> should not drive the standards process.

I agree but would have said something a bit different.  Maybe
they are ultimately the same thing.  

First, if protocols are straightforward, with few options and
clear descriptions, conformity tests are rarely needed although
implementations (at least of proof of concept quality) and
interoperability tests clearly are and provide important
feedback (or at least sanity checks).  Conformity tests go with
complex standards, standards with many options, and those
checklists.  The difficulty is that, especially if provided by
the standards body or its oversight body, the conformity tests
tend to become, de facto, the standard.  Things that they leave
out (typically because they are hard to characterize with a
simple test) are often operationally important or critical to
interoperability while small details (often of the variety we
traditionally thought the robustness principle would take care
of) are treated as very important.  

Because I'm ranting already, it is probably also worth keeping
in mind that there is an inherent tension between standards and
one of the original motivations for Open Source software, i.e.,
that progress comes from each of us being able to modify systems
to reflect our ideas and design tastes rather than having
someone else tell us what we need and how it should be dispensed
to us.   That usually works very well for end systems and most
applications running on them but can be the enemy of
interoperability and substitution of components, which have
traditionally been the main motivations for standards (of all
types, including whether a bolt one obtains from one source fits
a nut of the same description obtained from another).

best,
    john

---

From: Ted Lemon <[email-masked]>
Date: Sat, 28 Oct 2017 12:36:24 -0400

You'd be surprised, John, at what people do that's unexpected, even with really simple protocols (DHCP being the most obvious example with which I am intimately familiar).   The most common thing they do is to consider perfectly valid responses to be errors, because they don't match the implementor's mental model of what the protocol is doing, and the implementor was very careful to ignore anything outside of his or her understanding of the protocol.   These misunderstandings often come from doing interop testing with a single server that has a particular profile of default behaviors.

So having well thought out tests that test edge cases and that send things the other side shouldn't accept are very useful.   And the process of coming up with a testing regime is actually really helpful for finding ambiguities in the specification.

I think the point you are making about OSI, which was very nicely illustrated by Ned's comment, is a valid point, but the problem wasn't that there was conformance testing, and it wasn't even that there was a need for conformance testing.   It was a problem with the process that produced the standard that was being tested.   The process had failed, and no amount of testing was going to successfully paper over that failure.

---

From: Russ Housley <[email-masked]>
Date: Sat, 28 Oct 2017 12:45:43 -0400

> On Oct 28, 2017, at 9:51 AM, Sam Hartman <[email-masked]> wrote:
> 

I am aware of a situation in another standards organization where the organization that wrote the standards also did the testing.  The testing group wanted to have some aspects of the standards changed (make it easier to conform) so that the testers could generate more revenue.  The testers we being measured on the revenue, not making the ecosystem better.

Russ

---

From: John C Klensin <[email-masked]>
Date: Sat, 28 Oct 2017 12:57:56 -0400

--On Saturday, October 28, 2017 06:48 -0700
[email-masked] wrote:

> In the case of email, the central problem was the actual
> protocol design was at odds with reality.
> 
> Implementing X.400 was expensive and tedious, but we managed.
> Passing the various required conformance tests was even more
> tedious, and occasionally nasty because there were a number of
> cases where the tests were flat-out wrong, and getting the
> testing folks to look at what the standards actually said was
> difficult. (It was generally easier to implement options to
> break our implementation.)
> 
> But real nightmware was deployment and trying to achieve
> interoperability. That basically never happened.
> 
> I still remember the day I realized that the X.400 had failed.
> It was at a EMA meeting discussing how to make the file
> transfer body part do something useful. The chair passed
> around a sign-up sheet, but as he did so said something like,
> "Be sure to put down your Internet address; most of X.400
> addresses you folks provided last time didn't work."
> 
> When you've botched things to the point where a room full of
> experts in the field cannot even manage to write down a
> working address, you're toast.

I figured it out with X.400 when I was working with a couple of
the responsible standards organizations and discovered that they
were using Internet mail, or proprietary systems that were
connected/ gatewayed to Internet mail, and not X.400.  When
asked why and what their transition plan was, they had no
answers to the second and were not even uncomfortable about the
first.  

Lots of reasons... and a sad story but one that ultimately
benefited the Internet in multiple ways.

   john

---

From: Keith Moore <[email-masked]>
Date: Sat, 28 Oct 2017 19:54:41 -0400

>    The Internet is for everyone.

These words mean something very different to me now than they did in the 
late 1990s.  In the late 1990s, I saw the Internet as entirely a force 
for good - giving people access to information, the ability to freely 
communicate among one another, making governments and businesses more 
transparent, helping to build a global community.

Twenty years later, the reality is somewhat different.   The Internet 
has become a way for the Big Brothers of the world to conduct mass 
surveillance, a way to study people's interactions in minute detail, to 
compile personal information about people and to exploit that 
information for profit.  This is not an accident; it is the business 
model of several powerful companies and the hope behind several product 
lines.  Even the "Internet of Things" is mostly about spying on people.

The Internet isn't for everyone anymore, at least not in the same 
sense.   It's for spying on everyone for the benefit of the few. It's 
also for spreading conspiracy and for dividing people politically, in 
order to give those in power more control.

So basically I think ISOC, if it really wants to continue to pursue its 
original goals and ideals, needs to find a new vision.  I suggest a 
simple change:

The Internet is for *empowering* everyone.

To this end, ISOC needs to explicitly make privacy, freedom of 
expression, and authenticity of information part of its mission.

Keith

---

From: S Moonesamy <[email-masked]>
Date: Sun, 29 Oct 2017 09:33:22 -0700

Hi John,

[snip]

>numbers are for capacity development.

Thanks. I went to read the documents to get an idea about the numbers.

The results of the second objective in the mission which was 
developed in 2005 are being experienced currently.  In my opinion, 
they are not that good.

Regards,
S. Moonesamy

---

From: Richard Shockey <[email-masked]>
Date: Sun, 29 Oct 2017 13:10:11 -0400

Two points here.  Stephen Farrell is spot on in having some skepticism about mission statements.  That said this entire thread points to a much larger and potentially fatal contagion that often infects organizations.  Its called “mission creep”.  Too often an organization wants to be all things to all people and ends up being nothing to anyone.

Testing/interoperability/conformance/compliance are a quicksand of issues. Vendors generally hate them since they typically involve large sums of money especially if the compliance testing involves branding rights (aka logos).   

My question is what is the problem/failure with protocol X that having ISOC intervene with testing/interoperability/ conformance or compliance programs would solve?  Typically, members of a specific protocol community have self-organized to look at these issues and generally have been pretty good at it.   Case in point the SIP Forum and the SIP protocol.  We’ve been around since 2000 (yep 17 years !).  We’ve always sponsored and partially funded the SIP interoperability testing programs, SIPit run for many many years by Robert Sparks.  We have always developed the implementation profiles the industry relies on for compliance, SIPConnect.  We are now working with other SDO and national regulators on the STIR/SHAKEN framework. It’s a system that seems to work well.  Sure ISOC could have been helpful but it has virtually no experience dealing with national regulators outside the context of the IANA transition.  

I’m not saying ISOC shouldn’t be involved in implementation and compliance issues. It could be very useful in kickstarting efforts by specific protocol communities in self organizing if there is sufficient consensus to do so, but acting as an overall umbrella for such efforts IMHO is not the best use of ISOC resources.

Gonzallo is perfectly right in asking the community for input on what future directions ISOC should take and this is a useful thread but I urge caution.

— 
Richard Shockey

Shockey Consulting LLC

Chairman of the Board SIP Forum

www.shockey.us

www.sipforum.org

richard<at>shockey.us

Skype-Linkedin-Facebook –Twitter  rshockey101

PSTN +1 703-593-2683

    
    
    Russ

---

From: S Moonesamy <[email-masked]>
Date: Sun, 29 Oct 2017 12:21:51 -0700

Hi Keith,
At 04:54 PM 28-10-2017, Keith Moore wrote:
>sense.   It's for spying on everyone for the benefit of the 
>few.  It's also for spreading conspiracy and for dividing people 
>politically, in order to give those in power more control.

The Internet is sometimes perceived as a communication medium to 
interfere in national affairs.

>The Internet is for empowering everyone.

What is the meaning of "empowering" in the above?

>expression, and authenticity of information part of its mission.

There are already advocacy organizations working in those areas.

As a comment about wall gardens, the topic was discussed in 2000 by 
the IAB.  I am not sure whether it would be possible to do anything about that.

Regards,
S. Moonesamy

---

From: Keith Moore <[email-masked]>
Date: Sun, 29 Oct 2017 15:44:47 -0400

On 10/29/2017 03:21 PM, S Moonesamy wrote:

>> sense.   It's for spying on everyone for the benefit of the few.  
>> It's also for spreading conspiracy and for dividing people 

Nations are sometimes perceived as interfering in ordinary people's 
ability to live and function.

> What is the meaning of "empowering" in the above?

What kind of empowerment would you like everyone to have?   I personally 
favor freedom of speech, freedom of association, freedom to expose and 
dismantle structures of oppression.

> There are already advocacy organizations working in those areas.

Do they have monopolies or something?

Keith

---

From: S Moonesamy <[email-masked]>
Date: Sun, 29 Oct 2017 13:59:44 -0700

Hi Keith,
>ability to live and function.

I unfortunately cannot do much about that.

>What kind of empowerment would you like everyone to have?  I 
>personally favor freedom of speech, freedom of association, freedom 
>to expose and dismantle structures of oppression.

I once asked a colleague whether he/she would choose to use a 
building for a church or a school; the reply was interesting [1].  I 
do not have the ability to empower anyone.  I respect your views 
(second sentence in the paragraph quoted above)

>Do they have monopolies or something?

It is a different ecosystem(s).

Regards,
S. Moonesamy

---

From: Keith Moore <[email-masked]>
Date: Sun, 29 Oct 2017 17:05:14 -0400

> It is a different ecosystem(s).

In the context of ISOC it's important to understand that the Internet 
can be used for good or ill, but it's in danger of becoming more of the 
latter.   Promoting the Internet as if it were a universal good, while 
ignoring the various ways it can be used to exploit or harm its users, 
does not seem either responsible or consistent with ISOC's history.   
There are of course limits to what ISOC can do about it, but I don't 
think ISOC should be silent and/or pretend that it's not a problem.

Keith

---

From: Andrew Sullivan <[email-masked]>
Date: Sun, 29 Oct 2017 17:34:36 -0400

On Sun, Oct 29, 2017 at 09:33:22AM -0700, S Moonesamy wrote:
> The results of the second objective in the mission which was developed in
> 2005 are being experienced currently.  In my opinion, they are not that
> good.

If we're going to have this conversation here, rather than in an
ISOC-dedicated forum (and I confess I am very much unsure why we
should do that), then perhaps saying something apart from "I don't
think that's so good," would be worth doing.  What _would_ be good,
what would meet your expectations, and so on?  That is, give the
reader some reason to think that the evaluation is anything other than
personal taste.  For example, I think bananas are not that good (they
gross me out), but that doesn't mean the banana people are doing
something wrong.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 30 Oct 2017 10:56:36 +1300

On 30/10/2017 10:34, Andrew Sullivan wrote
...> If we're going to have this conversation here, rather than in an
> should do that), 

[email-masked] seems to have gone silent a long time ago.
Maybe they use this new "Facebook" thing I keep hearing about.

    Brian

---

From: S Moonesamy <[email-masked]>
Date: Sun, 29 Oct 2017 16:03:59 -0700

Hi Keith,
At 02:05 PM 29-10-2017, Keith Moore wrote:
>In the context of ISOC it's important to understand that the 
>Internet can be used for good or ill, but it's in danger of becoming 
>more of the latter.   Promoting the

Yes.

>  Internet as if it were a universal good, while ignoring the 
> various ways it can be used to exploit or harm its users, does not 
> seem either responsible or consistent with ISOC's history.   There 
> are of course limits to what ISOC can do about it, but I don't 

I don't know about the internals which led to the revision of the 
mission statement.  I am not responsible for what other people say.

Regards,
S. Moonesamy

---

From: S Moonesamy <[email-masked]>
Date: Sun, 29 Oct 2017 18:08:24 -0700

Hi Andrew,
>should do that), then perhaps saying something apart from "I don't

Ok.

>gross me out), but that doesn't mean the banana people are doing

I do not have any expectations.  My last comment about the matter in 
an IETF venue was on 10 October 2013.  My only comment about the 
matter outside the IETF was around 11 months ago; the reason for that 
is because I was in the room where ISOC was having the 
discussion.  My opinion is based on a reading of the discussions on 
[email-masked] over an extended period of time; it is a subjective way 
to assess IETF participation.  I haven't looked at the recent 
statistics for attendance.  My guess is that it is around 1% for the 
region.  I am okay if the reader believes that the opinion is a 
matter of personal taste.

Regards,
S. Moonesamy

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 30 Oct 2017 16:38:45 +0100

On Sun, Oct 29, 2017 at 01:59:44PM -0700, S Moonesamy wrote:
> >Nations are sometimes perceived as interfering in ordinary
> >people's ability to live and function.
> 

I thought the Internet translation of
"comply with all local laws and regulations"
was "offer services from a foreign country".

As funny but true as it was in hmm... 1995 ? when i think i first
heard it, it is still the most fundamental opportunity and challenge
of the Internet. And i do not see a good reflection of that
in the mission statement. 

Overall:
I do not think the mission statement as it stands right now (and
has in the past) is very useful. Nobody who is not deeply involved
in ISOC overall would be able to translate all these bullet points
into actual facts of interest. I can maybe translate half way 3..5
bullet points but i would still prefer hard facts over uninspiring
headlines that by themselves read only like marketing.

I suggest ISOC sits down, takes those 8 bullet points and
converts them into 8 sections for the ISOC wikipedia entry, where each
section could be lets say 1/2 ... 1 page long, highlighting the 
core historic achievements, current challenges and ongoing activies
for each of these bullet points.

And then make https://www.internetsociety.org/mission/ point to
the wikipedia article.

That is how the Internet should work IMHO. 

Also: 
ISOC is not only the Internet (surprise). I am totally missing
a statement about supporting proliferation of open technologies,
development, operations and management practices of the Internet
to infinity and beyond. Is that not what IoT will be all about ?
That is not going to be the Internet. That is going to be
many internets totalling much more than the Internet will ever
be. 

Cheers
    Toerless

> >personally favor freedom of speech, freedom of association,
> >freedom to expose and dismantle structures of oppression.
> 

-- 
---
[email-masked]

---

From: Keith Moore <[email-masked]>
Date: Mon, 30 Oct 2017 12:48:42 -0400

On Oct 30, 2017, at 11:38 AM, Toerless Eckert <[email-masked]> wrote:
> 
> Is that not what IoT will be all about ?

IoT is about spying on people. [*] Don't believe me?  Do a job search for IoT and see what skills employers are looking for.

[*] and drastically increasing the network's vulnerability to attack, of course.

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 30 Oct 2017 18:40:19 +0100

> [*] and drastically increasing the network's vulnerability to attack, of course.

I was always looking for a good distinction between IoT
and how Internet companies made their money before IoT:
https://en.wikipedia.org/wiki/List_of_largest_Internet_companies

NOT!

So i continue to claim that IoT will inherit all the good and bad of the
Internet, but it is not the Internet, yet ISOC activies should and do
care about it. So, where's that in the mission statement ?

Cheers
    Toerless

P.S.: Mission stsatement since 2002:
https://www.youtube.com/watch?v=AWtCittJyr0

---

From: S Moonesamy <[email-masked]>
Date: Mon, 30 Oct 2017 13:24:06 -0700

Hi Toerless,
>in the mission statement.

There was a message from Jordi about the Catalonia affair [1].  Is 
that part of ISOC's mission?

>headlines that by themselves read only like marketing.

The draft statement has been reviewed by the "IETF 
leadership".  According to the above, it sounds like marketing.

>many internets totalling much more than the Internet will ever

According to a paper from the University of Auckland, New Zealand, 
the "Internet of Things has integrated digital services into physical goods".

Regards,
S. Moonesamy

1. https://www.ietf.org/mail-archive/web/ietf/current/msg105124.html

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 30 Oct 2017 23:39:07 +0100

Hi,

My message was precisely to make sure that somewhere we have a clear text that avoids ISOC acting with statements against law, and making themselves unlawful and unproven comments that they can’t sustain.

NEVER AGAIN ISOC/staff can repeat that problem. ISOC MUST defend freedom of expression in Internet, but not by means of untrue statements against legitimate court orders.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de S Moonesamy <[email-masked]>
Responder a: <[email-masked]>
Fecha: lunes, 30 de octubre de 2017, 21:27
Para: Toerless Eckert <[email-masked]>, <[email-masked]>
Asunto: Re: Proposal to revise ISOC's mission statement

    Hi Toerless,

    

    
    Regards,
    S. Moonesamy

---

From: Keith Moore <[email-masked]>
Date: Mon, 30 Oct 2017 18:48:26 -0400

> NEVER AGAIN ISOC/staff can repeat that problem. ISOC MUST defend freedom of expression in Internet, but not by means of untrue statements against legitimate court orders.

Who gets to decide what is untrue or legitimate?

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Mon, 30 Oct 2017 23:50:39 +0100

Either we accept that democratic countries with split power take legitimate decisions or ISOC never comments on law orders. Easy just pick one.

In any case, if ISOC want to comment a court order, they must have a copy of it so they know what they are talking about, which was not the case as I explained several times, and this is an unlawful act.

Regards,
Jordi

---

From: Ted Lemon <[email-masked]>
Date: Mon, 30 Oct 2017 20:47:30 -0400

> Either we accept that democratic countries with split power take legitimate decisions or ISOC never comments on law orders. Easy just pick one.

Jordi, the whole point of freedom of speech is to enable countries to be democratic.   You can't be a democratic country if there is no freedom of speech.   The two are simply incompatible.

So indeed our choice here is to pick zero or two.   One is not one of the possible choices.

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 31 Oct 2017 10:22:05 +0100

I disagree.

A court order that say “this web site is illegal propaganda” is democratic.

Or are you going to tell me that you agree with a web site with child pornography? If there is a law order to take it down, it should be taken down.

But the REAL problem here is that ISOC published FAKE information without verifying it. Furthermore they didn’t asked for excuses to 45 million citizens for that, once they realized the mistake … well I’m still not sure they realized it.

Do we agree with that?

Regards,
Jordi

---

From: Keith Moore <[email-masked]>
Date: Tue, 31 Oct 2017 07:49:28 -0400

I think we would agree that ISOC should not republish unverified information that originates elsewhere.

But in general, just because a court issues an order, does not mean that the court is following the law, or that the law was produced by a democratic process.   Neither ISOC nor anyone else should be compelled to pretend that court rulings are always legitimate.

Practically every country on Earth claims to be democratic.  Reality is somewhat different.  In my country there are at least a dozen ways of rigging elections that have been employed in recent history to significant effect.  The goal is to provide the appearance of democracy without the reality.

Keith

---

From: Loganaden Velvindron <[email-masked]>
Date: Tue, 31 Oct 2017 21:36:12 +0400

> Rather than add more specific examples to the existing set of highlighted activities, how about adding something in the mission statement about implementation and application in addition to the dev…

I also agree with Charles here. For many "newcomers", implementing
protocols is more "fun", and one of the reasons that they are willing
to spend their time actually reading an I-D or RFC.

---

From: Loganaden Velvindron <[email-masked]>
Date: Tue, 31 Oct 2017 21:54:34 +0400

> [*] and drastically increasing the network's vulnerability to attack, of course.

In this case, we need more educated buyers, and also more people
actually doing reviews of those products that will influence buyer's
decision. It's unlikely that people are going to avoid "IoT". One of
my friends once told me that once he bought smart light bulbs, he's
not going back. It makes his life easier. I think that what is done by
independent security researchers is a good example of vendors being
responsive to concerns : https://mjg59.dreamwidth.org/47803.html.

---

From: Keith Moore <[email-masked]>
Date: Tue, 31 Oct 2017 18:55:55 -0400

Sent from my iPhone

> On Oct 31, 2017, at 1:54 PM, Loganaden Velvindron <[email-masked]> wrote:
> 
> decision.

LOL.  Unless the device is open source, no review is likely to be at all useful.

---

From: S Moonesamy <[email-masked]>
Date: Tue, 31 Oct 2017 17:47:22 -0700

Hi Jordi,
At 03:50 PM 30-10-2017, JORDI PALET MARTINEZ wrote:
>Either we accept that democratic countries with split power take 
>legitimate decisions or ISOC never comments on law orders. Easy just pick one.

In other words, the society will only comment on law orders in 
"undemocratic countries".  Isn't it up to the society's Board of 
Trustees to decide about that?

Regards,
S. Moonesamy

---

From: Ted Lemon <[email-masked]>
Date: Tue, 31 Oct 2017 21:18:32 -0400

On Oct 31, 2017, at 8:47 PM, S Moonesamy <[email-masked]> wrote:
> In other words, the society will only comment on law orders in "undemocratic countries".  Isn't it up to the society's Board of Trustees to decide about that?

No, as I said earlier (perhaps it's futile to repeat, but wth), democracy depends on the ability of the electorate to speak about and understand the issues being decided.   So when a nominally democratic country attempts to censor the internet, it makes sense to protest.   This is the whole point of having laws, and particularly laws that protect freedom of speech.   It's quite commonplace for democratically elected leaders to attempt to suppress speech, because it is often inconvenient for them.   This is normal.   If we were to not protest when such attempts at suppression occurred, it would be normal for them to succeed.   That is why it makes sense to protest.

Protesting an attempt to suppress speech is not something that only needs to be done un non-democratic countries; indeed, in non-democratic countries, it's somewhat futile.