Subject: RE: On audio quality requirements for IETF meetings

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 22 Feb 2018 11:33:00 +0000

Hi

This one sort of lost traction. 
The issue I raised is that the audio quality at IETF meetings varies quite a lot, ranging from quite decent all the way down to pretty awful. And it also varies quite a lot between small and large rooms at the same IETF meeting.

Is there an interest to write up a set of recommendations around audio setup? 
The follow-up question is, would these recommendations be considered ?

Carsten has a few good suggestions (below).  I raised the quite obvious topic that small line array speaker controls the sound dispersion better than the commonly used point sources.  
As I see it the recommendations range from the simple and cheap (e.g. use HP filters) to more expensive gear. 
The loudspeaker recommendations that I think of, as well as microphone recommendations are not necessarily more expensive to implement than the current gear that is rented for each IETF. It is more a matter of going from "pick any gear" to "pick among gear that falls into this category"

Regards
/Ingemar

> -----Original Message-----
> From: Carsten Bormann [mailto:[email-masked]]
> Sent: den 18 november 2017 10:38
> To: Ingemar Johansson S <[email-masked]>
> Cc: <[email-masked]> <[email-masked]>
> Subject: Re: On audio quality requirements for IETF meetings
> 
> 
> >    I believe that improved acoustics would non only benefit people with bad
> hearing, it would also reduce fatigue for people with good hearing
> 
> +100.  I’ve been using English in a professional context for more than 35 years
> now, but English via bad audio really exhausts me.
> 
> I don’t think we should meddle with the actual A/V engineering (although
> the DECT microphones that Telefonica had for the STRINT workshop in 2014
> were amazing).  But we can show that we care about audio by asking for
> some simple specifications (RT60 was suggested, maybe frequency response
> if installed ceiling speakers are to be used — a high pass might help with
> some rooms).
> 
> ISTR that the microphones I looked at in Singapore said they were SM58s, so
> unless they were cheap fakes, the problems with them were mostly lack of
> training (you need to be very close to those, and unless you are an
> accomplished singer, this means you need to hold them as opposed to using
> them on a stand).  There were some microphones though that needed to be
> tapped or shaken now and then, pointing to badly maintained battery
> contacts.  And battery discipline apparently was lacking as well — batteries
> need to be replaced in a regular process and not after they finally fail.
> 
> There were some serious speaker placement problems in some rooms, with
> no direct sound at all in significant parts of the room (including the presenter
> and chair areas themselves).  Maybe we can complement the presenter TV
> with a monitor speaker (which would also help the presenter with knowing
> when they are close enough to the microphone), but the speaker placement
> for the rest of the room simply needs to be checked in place and corrections
> made where needed.
> 
> If we really want to help people who can benefit from that, there could be a
> monitor frequency per room that can be picked up by a receiver (I’ve used
> those with specific students in large-room lectures).  Those of course require
> additional planning, as they are regional and licensed; instead of doing it per
> room there could also be a set per person needing it, with a place in the
> room to plug the transmitter in.  (I have used meetecho as a cheap version of
> that when I happened to sit down in a bad area of the room, but the delay is
> generally too high compared to an analog solution.)
> 
> At least the leakage from adjacent rooms (another spec we could ask for)
> was limited this time.
> 
> Audio problems excepted, this was definitely one of the better venues we
> had.
> 
> Grüße, Carsten

> -----Original Message-----
> From: JORDI PALET MARTINEZ [mailto:[email-masked]]
> Sent: den 17 november 2017 03:43
> To: <[email-masked]> <[email-masked]>
> Cc: Ingemar Johansson S <[email-masked]>
> Subject: Re: On audio quality requirements for IETF meetings
> 
> Hi all,
> 
> I’ve got the below question from Ingemar (confirmed with him that is ok to
> respond in the list).
> 
> This document:
> 
> https://datatracker.ietf.org/doc/draft-palet-ietf-meeting-network-
> requirements/
> 
> is mainly about the network, but also “other” technical requirements, so I
> think it will be fine to include audio specs.
> 
> I’m sure we have some audio experts in the list that can figure out what will
> be the correct wording for our criteria on this?
> 
> I want to take the opportunity to ask the list for:
> 1) Please review the document, specially the NOC team and secretariat, but
> in general in case there are other technical requirements that aren’t being
> considered.
> 2) IETF chair/IESG, as the mtgvenue WG believes there is not good expertise
> there to evaluate this document, what is the path forward?
> 
> I don’t want to have the same experience as I had in 2006 with this document
> and the original draft-palet-ietf-meeting-venue-selection-criteria, which
> after hard work were silently ignored and we started the work from scratch
> in mtgvenue without even mentioning them.
> 
> This is another topic, but I want to mention it as it is a perfect example: I think
> this is a global IETF problem and we should somehow correct it. People do
> some work … is not considered by IETF, fine, but then after some time,
> somebody else take on that work and the original authors aren’t referenced.
> I think is a matter of basic politeness and acknowledgment.
> 
> Regards,
> Jordi
> 
> 
> -----Mensaje original-----
> De: Ingemar Johansson S <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: viernes, 17 de noviembre de 2017, 10:17
> Para: "[email-masked]" <[email-masked]>
> Asunto: On audio quality requirements for IETF meetings
> 
>     Hi
>     Tried to find the RFC that describes the requirements for the IETF meeting
> rooms, still not lucky in my search. I would be interested to see if there are
> any stated requirements on the audio quality.
> 
>     I personally suffer from degraded hearing since childhood and quite often
> have problems to hear what people say. The reasons are :
>     + High noise from AC and ventilation
>     + Low  audio level (sometimes close to 0dB S/N)
>     + Long reverberation times (boomy acoustics)
> 
>     Some of these issues are relatively easy to fix (requirements on audio
> levels), others can be involve more work. I don’t have all the answers right
> now but for instance.
>     + Line array loudspeakers are generally better than point sources and built
> in ceiling speakers, as the line arrays control the audio dispersion better, a
> great benefit in venues with boomy acoustics.
> 
>     + Requirements on e.g RT60 and noise levels.
>     + Audio monitors should face the WG/AD/* chairs and the presenter
> 
>     I believe that improved acoustics would non only benefit people with bad
> hearing, it would also reduce fatigue for people with good hearing
> 
>     Is there any document that can be updated with recommendations, unless
> there are any requirements/recommendations available already ?
> 
> 
>     Regards
>     Ingemar
> 
>     ==================================
>     Ingemar Johansson  M.Sc.
> 
>     Master Researcher
> 
>     Ericsson Research
>     Network Protocols & E2E Performance
>     Labratoriegränd 11
>     971 28, Luleå, Sweden
>     Phone +46-1071 43042
>     SMS/MMS +46-73 078 3289
>     [email-masked]
>     www.ericsson.com
> 
>     The world is full of magical things patiently
> 
>         waiting for our wits to grow sharper
>                    Bertrand Russell
>     ==================================
> 
> 
> 
> 
> 
> 
> **********************************************
> IPv4 is over
> Are you ready for the new Internet ?
> http://www.consulintel.es
> The IPv6 Company
> 
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the exclusive use of the
> individual(s) named above and further non-explicilty authorized disclosure,
> copying, distribution or use of the contents of this information, even if
> partially, including attached files, is strictly prohibited and will be considered a
> criminal offense. If you are not the intended recipient be aware that any
> disclosure, copying, distribution or use of the contents of this information,
> even if partially, including attached files, is strictly prohibited, will be
> considered a criminal offense, so you must reply to the original sender to
> inform about this communication and delete it.
> 
>

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 22 Feb 2018 13:04:04 +0100

I think already mention that, but just in case.

I'm working in updating
https://www.ietf.org/archive/id/draft-palet-ietf-meeting-network-requirements-01.txt

Is mainly about network requirements, but I used "and other" in the title, because I understood that we may need to consider other technical issues in the meetings.

I'm trying to figure out the best path for this document ... I hope the NOC/secretariat can review it at some point, and probably they can also provide some hints about audio details ...

Regards,
Jordi
 
-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Ingemar Johansson S <[email-masked]>
Fecha: jueves, 22 de febrero de 2018, 12:33
Para: "[email-masked]" <[email-masked]>, "<[email-masked]>" <[email-masked]>, Carsten Bormann <[email-masked]>
CC: Ingemar Johansson S <[email-masked]>
Asunto: RE: On audio quality requirements for IETF meetings

    Hi

    
    
    Regards
    /Ingemar

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Matthew Ford <[email-masked]>
Date: Thu, 22 Feb 2018 14:08:49 +0000

> On 22 Feb 2018, at 11:33, Ingemar Johansson S <[email-masked]> wrote:
> 
> The issue I raised is that the audio quality at IETF meetings varies quite a lot, ranging from quite decent all the way down to pretty awful.

I agree and it bugs me too.

If all attendees, local and remote, dialled in to Meetecho with a headset, would we even need in-room audio?

Mat

---

From: Ted Lemon <[email-masked]>
Date: Thu, 22 Feb 2018 11:14:32 -0500

> If all attendees, local and remote, dialled in to Meetecho with a headset, would we even need in-room audio?

No, but then you'd have the O(n^2) problem of debugging everybody's meetecho feed.   Also, the latency can make following difficult when you are in the room with the person who is speaking.

---

From: "John Levine" <[email-masked]>
Date: 24 Feb 2018 23:20:15 -0000

In article <[email-masked]>,
>No, but then you'd have the O(n^2) problem of debugging everybody's meetecho feed.   Also, the latency can make following difficult
>when you are in the room with the person who is speaking.

If you're feeding realtime audio to everyone at the meeting, that
could be a pretty exciting network load.

I'd rather back up a little and try to describe what kind of audio we
want and why we're not getting it, before leaping to confusions.

R's,
John
-- 
Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Ingemar Johansson S <[email-masked]>
Date: Tue, 27 Feb 2018 09:37:55 +0000

Hi
Sorry for the delay. I don't believe that meetecho+headset is a good replacement for in-room audio. It can be a useful complement  if the e2e delay (mouth to ear) can be squeezed down to some 40ms.

/Ingemar

From: Ted Lemon [mailto:[email-masked]]
Sent: den 22 februari 2018 17:15
To: Matthew Ford <[email-masked]>
Cc: Ingemar Johansson S <[email-masked]>; Carsten Bormann <[email-masked]>; [email-masked] Discussion <[email-masked]>; Jordi Palet <[email-masked]>
Subject: Re: On audio quality requirements for IETF meetings

On Feb 22, 2018, at 9:08 AM, Matthew Ford <[email-masked]<mailto:[email-masked]>> wrote:
If all attendees, local and remote, dialled in to Meetecho with a headset, would we even need in-room audio?