Subject: Re: More guidance and directions for new drafts/comers (was Re: When the IETF can discuss drafts seriously?

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 10 Feb 2018 11:18:36 +0200

Hi Keith,

For example the below messages are for an adopted work (or draft WG LC) but
no replies/guidance within the discussion list, why is that?
https://www.ietf.org/mail-archive/web/roll/current/msg10338.html
https://www.ietf.org/mail-archive/web/roll/current/msg10316.html
https://www.ietf.org/mail-archive/web/roll/current/msg10339.html

my reply below,

On Fri, Jan 26, 2018 at 1:43 PM, Keith Moore <[email-masked]>
wrote:

> IETF does try to be open to new ideas.  But people bring new ideas to IETF
> all the time, and statistically speaking, most of those new ideas are bad
> ideas because they are coming from people without enough exposure to enough
>  experience that would let them realize that they are bad ideas.   So
> experienced IETF participants tend to reject bad or dubious ideas in ways
> that may seem impolite or rude.   This is (mostly) not because they are
> rude people overall, it is simply because there are so many bad ideas
> presented here, as a consequence of IETF's openness.
>
> The people who succeed in getting IETF to adopt their ideas are those who
> are willing to listen to feedback, take it seriously, understand its
> relevance, and adapt their ideas in light of the feedback.   People who
> expect to be taken seriously without being willing to do those things tend
> to not succeed here.
>

I agree that editors need to listen and reply, but also the WG chair MUST
follow up with editor to make sure they are replying to feedback. Also the
ADs MUST follow up with IETF LC comments and they should be involved. I
think we should look at Acee as a great WG chair, and there are many other,
we may need to reward great WG chair to encourage guidance and discussions.

> Even good ideas need refinement, and IETF makes decisions by rough
> consensus.   Someone who isn't willing to listen to feedback will have a
> difficult time building consensus.   And even when a relatively good idea
> is presented, community members are less likely to try to help people
> refine their ideas, if those people seem unwilling to accept constructive
> feedback and consider compromises.
>

I agree, also our managers (ADs and WG chairs) need to follow with that,
and if that is not done I think they should do it. However, WG chair needs
to see good idea and should find a way to use it and to make the WG work
together, because some WG may be controlled by few people.

>
> Also: IETF makes it relatively easy to post an internet-draft.   But
> posting an internet-draft doesn't do anything but make the draft available
> for download and send out an announcement to a mailing list.   It doesn't
> schedule any discussion on the draft, it doesn't refer the draft to any
> working group, and it doesn't mean that anybody will take it seriously or
> even read it - whether it's good or not.
>

I discuss adopted drafts and still some times don't get reply or any
serious reaction, why is that? I some times think because I am from Africa
but I don't believe that or trying no to beleive.

>   That's just how the process works here.
>

You need to look at the other side of the process. As I see that when there
is an adopted draft and I get interested in and discuss, still managers are
not reply or they may not guide process for listening and discussions and
replies from editor,

>   It's how it has to work.  There aren't enough active participants in
> IETF for every internet-draft to be taken seriously.
>

No we have managers, and they should do their job of guidance and
directing work specially adopted ones.

>   We'd never get any work done at all if we undertook an obligation to try
> to make every proposal successful.
>

Yes I agree, but also we need to reply to the community for our adopted
work and our RFCs as well.

Overall, I think IESG needs to look into this serious issue and solve it,

Thanks

AB

>
> Keith
>
>
>
> On Jan 26, 2018, at 6:16 AM, Khaled Omar wrote:
>
> Hi Abdussalam,
>
> > The Answer to your question is: IETF is serious about adapted drafts
> only, or new drafts that have support from the internet community.
>
> I see many people in the community talking and dicussing the IPv10 I-D, I
> feel it is strange that people within the IETF do the opposite and not
> taking it seriously.
>
> Best regards,
>
> Khaled
>
>
> -------- Original Message --------
> Subject: More guidance and directions for new drafts/comers (was Re: When
> the IETF can discuss drafts seriously?
> From: Abdussalam Baryun
>
>
>
>
>
>
>
>
>
>
>
> * To: Khaled Omar CC: ietf Hello Khaled, and to all new comers, I am sorry
> I did not see your question until yesterday, but your question/draft is
> important for new comers and some times for old participants. I really feel
> that the management some times may be not serious for some slot of time and
> may have excuses because it is volunteering. If our management are paid we
> can be more guided and directed. So the new question, do we need more
> guidance or more friends? The Answer to your question is: IETF is serious
> about adapted drafts only, or new drafts that have support from the
> internet community. IMO, you need to find 4 or 5 people that are willing
> to work with you/your-draft, maybe it is easier to find them within your
> country or region. Then you contact the area director that is related to
> your draft to get feedback. The IETF provides some coaching so use that. So
> the real answer to your question: is that you need more guidance and
> directions, who doesn't. You are smart and all us in IETF are, but the
> smarter who work within the guidance of WGs and ADs. All IETF experts,
> authors and IETF WG chairs and ADs, all are getting guidance and they are
> continuously guided by asking for comments/feedback from the communities.
> So as many answered you to follow the reasonable engineering comments. The
> other issue related to your question, the problem that we all are bussy, so
> we IETF are serious but bussy. We need to be serious about our time and
> others. Finally, we in IETF must follow IETF procedures RFC2418, we always
> follow/read it and its updates available. So that is important to be
> guiding our management and our participants. We also have fun while we
> participate and we make friends, so we should not get angry being more
> serious, but we be mercy with more friends and guidance. Take care, AB *
>
>
>

---

From: Keith Moore <[email-masked]>
Date: Sat, 10 Feb 2018 05:44:42 -0500

On Feb 10, 2018, at 4:18 AM, Abdussalam Baryun wrote:

> Hi Keith,
> 
> For example the below messages are for an adopted work (or draft WG LC) but no replies/guidance within the discussion list, why is that?

I have no idea.  I'm not going to comment on the specific (lack of) actions of a WG in which I was not participating.
 
> my reply below,
> 
> On Fri, Jan 26, 2018 at 1:43 PM, Keith Moore <[email-masked]> wrote:
> IETF does try to be open to new ideas.  But people bring new ideas to IETF all the time, and statistically speaking, most of those new ideas are bad ideas because they are coming from people without enough exposure to enough  experience that would let them realize that they are bad ideas.   So experienced IETF participants tend to reject bad or dubious ideas in ways that may seem impolite or rude.   This is (mostly) not because they are rude people overall, it is simply because there are so many bad ideas presented here, as a consequence of IETF's openness.
> 
> The people who succeed in getting IETF to adopt their ideas are those who are willing to listen to feedback, take it seriously, understand its relevance, and adapt their ideas in light of the feedback.   People who expect to be taken seriously without being willing to do those things tend to not succeed here.  
> 
> I agree that editors need to listen and reply, but also the WG chair MUST follow up with editor to make sure they are replying to feedback. Also the ADs MUST follow up with IETF LC comments and they should be involved. I think we should look at Acee as a great WG chair, and there are many other, we may need to reward great WG chair to encourage guidance and discussions.

You are talking about something different here than what I was talking about.   But I emphatically disagree with your MUST assertion.   I do not believe that chairs and ADs have a duty to follow up individually on every LC comment.   LC comments that are relevant should be carefully considered, of course.  But just because a comment is made in response to LC does not mean it has sufficient merit to warrant a reply.   There is a reason IETF requires rough consensus rather than complete consensus.

>  
> Even good ideas need refinement, and IETF makes decisions by rough consensus.   Someone who isn't willing to listen to feedback will have a difficult time building consensus.   And even when a relatively good idea is presented, community members are less likely to try to help people refine their ideas, if those people seem unwilling to accept constructive feedback and consider compromises.
> 
> I agree, also our managers (ADs and WG chairs) need to follow with that, and if that is not done I think they should do it. However, WG chair needs to see good idea and should find a way to use it and to make the WG work together, because some WG may be controlled by few people.

Yes some WG can be controlled by a few people (I've seen it happen).   But a WG chair should not insist that all ideas be incorporated, not even all good ideas.  This can be inappropriate meddling on the chair's part, and there's such a thing as trying to accommodate too many good ideas.

> 
> Also: IETF makes it relatively easy to post an internet-draft.   But posting an internet-draft doesn't do anything but make the draft available for download and send out an announcement to a mailing list.   It doesn't schedule any discussion on the draft, it doesn't refer the draft to any working group, and it doesn't mean that anybody will take it seriously or even read it - whether it's good or not.
> 
> I discuss adopted drafts and still some times don't get reply or any serious reaction, why is that? I some times think because I am from Africa but I don't believe that or trying no to beleive.

I haven't read enough of your discussions to have an opinion of why you don't always get a reply.   But based on this one message alone, I'm inclined to guess that it is because you have unreasonable assumptions and people don't always feel like trying to explain this to you.   (Feel free to ignore my guess as it's based on a very small sample size.)

> You need to look at the other side of the process. As I see that when there is an adopted draft and I get interested in and discuss, still managers are not reply or they may not guide process for listening and discussions and replies from editor,

Why do you think you are in a position to tell me what I need to do?   

>  
>   It's how it has to work.  There aren't enough active participants in IETF for every internet-draft to be taken seriously.
> 
> No we have managers, and they should do their job of guidance and directing work specially adopted ones.

Sometimes a good manager knows when to ignore people.

>  
>   We'd never get any work done at all if we undertook an obligation to try to make every proposal successful.
> 
> Yes I agree, but also we need to reply to the community for our adopted work and our RFCs as well.
> 

I am unconvinced that this ranks among the very many issues warranting IESG's attention.

Keith

---

From: John C Klensin <[email-masked]>
Date: Sat, 10 Feb 2018 12:53:58 -0500

--On Saturday, February 10, 2018 05:44 -0500 Keith Moore
<[email-masked]> wrote:

>> I agree that editors need to listen and reply, but also the
>> WG chair MUST follow up with editor to make sure they are
>> replying to feedback. Also the ADs MUST follow up with IETF
>> LC comments and they should be involved. I think we should
>> look at Acee as a great WG chair, and there are many other,
> You are talking about something different here than what I was
> talking about.   But I emphatically disagree with your MUST
> assertion.   I do not believe that chairs and ADs have a duty
> to follow up individually on every LC comment.   LC comments
> that are relevant should be carefully considered, of course.
> But just because a comment is made in response to LC does not
> mean it has sufficient merit to warrant a reply.   There is a
> reason IETF requires rough consensus rather than complete
> consensus.

Keith,

Speaking generally (with no information about this particular
case at all), there is at least one more reason, one that I
consider very important.  In general there are two ways to get
to a consensus technical standard (rough or otherwise).  One is
to try to incorporate every idea, or even most ideas, and
reflect every comment.  The other is to try to end up with a
single, coherent, specification with a minimum of options.   The
first approach tends to create complex standards, sometimes with
internal inconsistencies, and often a need for profiling, but
often results in everyone who contributed to its development
feeling as if they got something.  Of the two, the second is
more likely to produce something that can actually be
implemented and deployed even if the approach runs the risk of
failing entirely.  

The IETF, as you know and I hope Abdussalam understands by now,
has historically favored the second approach and, IMO at least,
has often come to regret it when we slip over into the first.
To paraphrase a now-ancient rant, the sides of the information
superhighway are littered with the corpses of specifications
developed using the first approach, largely because technical
reality tends to get lose in the process of compromise to get a
semblance of consensus.

Taking that second approach of trying to produce a focused
standard with few options and no features added just to get
agreement requires that WGs, and WG Chairs in particular, be
given considerable discretion to evaluate, not just rough
consensus, but which way the wind is blowing.  That discretion
and authority can be abused, but the IETF's main protection
mechanism is appeals, not specific rules about procedures to be
followed.  And it is important the people remember that the main
purpose of IETF's appeals mechanism is not finding of fault but
being sure adequate consideration occurs when someone says "wait
a minute, that may need rethinking or more evaluation".

best,
    john