Subject: Re: It was started so long ago (was: Update on www.ietf.org)

From: Alissa Cooper <[email-masked]>
Date: Thu, 1 Feb 2018 09:13:35 -0500

Hi SM,

> On Jan 31, 2018, at 2:58 PM, S Moonesamy <[email-masked]> wrote:
> 
> Hello,
> At 06:52 PM 16-01-2018, Alissa Cooper wrote:
>> Now, about the lessons learned.
>> 
>> As Russ notes above, this project was started nearly four years ago. It was started so long ago that people can't remember the feedback they gave in the early rounds of community comment  or that community comment was sought at all. It was started so long ago that the entire IAOC, except the ISOC CEO, is different now than when it started. When I think about the big picture, the fact that it could take four years to re-do our web site is what really stands out. We do not have a viable structure for carrying out this sort of externally facing function, which is a necessary function for an organization that exists in the world. Within our administrative structure this function is at once many people's responsibility and nobody's responsibility.
> 
> I'll highlight the following: "many people's responsibility and nobody's responsibility".  If a person is on a committee, is he/she responsible for the decisions taken by the previous committee?  

The decision that was taken by the IAOC was to award a contract to a web design vendor. That decision doesn’t indicate who will provide project management or content management for a project like this, during the design phase or on a continuing basis. We are lucky to have had volunteers from the community and staff support from ISOC to fill in these roles, given that the IAOC is intended to be an oversight body. 

> If the project was viewed as a success, who would take credit for that?
> 
> I don't see anything in the various BCPs which says that nobody is responsible.  

Of course not, because the point is that there are a bunch of functions and responsibilities that are unspecified. It’s not as if the community took an explicit decision to make nobody responsible.

Alissa

> There are actually statements about "responsibility" in the documents.  If there is anything to learn, I'd say that what is written about the administrative structure does not work in practice.
> 
> Regards,
> S. Moonesamy

---

From: S Moonesamy <[email-masked]>
Date: Thu, 01 Feb 2018 14:32:37 -0800

Hi Alissa,
At 06:13 AM 01-02-2018, Alissa Cooper wrote:
>Of course not, because the point is that there are a bunch of 
>functions and responsibilities that are unspecified. It's not as if 
>the community took an explicit decision to make nobody responsible.

Thank you for the response.

Regards,
S. Moonesamy

---

From: [email-masked]
Date: Fri, 2 Feb 2018 10:41:03 +0000 (UTC)

>As Russ notes above, this project was started 
>nearly four years ago. 
four years ago? that's the lifetimes of seventeen differentfashionable 'full stack' javascript frameworks that have tobe learned, used, learned from, and forgotten.
it's a wonder anything shipped.

Lloyd [email-masked]
is fully angularJS react node.js ajax compliant

On Thursday, February 1, 2018, 6:58 am, S Moonesamy <[email-masked]> wrote:

Hello,
At 06:52 PM 16-01-2018, Alissa Cooper wrote:
>As Russ notes above, this project was started 
>nearly four years ago. It was started so long 
>ago that people can't remember the feedback they 
>gave in the early rounds of community comment — 
>or that community comment was sought at all. It 
>was started so long ago that the entire IAOC, 
>except the ISOC CEO, is different now than when 
>it started. When I think about the big picture, 
>the fact that it could take four years to re-do 
>our web site is what really stands out. We do 
>not have a viable structure for carrying out 
>this sort of externally facing function, which 
>is a necessary function for an organization that 
>exists in the world. Within our administrative 
>structure this function is at once many people's 
>responsibility and nobody's responsibility.

I'll highlight the following: "many people's 
responsibility and nobody's responsibility".  If 
a person is on a committee, is he/she responsible 
for the decisions taken by the previous 
committee?  If the project was viewed as a 
success, who would take credit for that?

I don't see anything in the various BCPs which 
says that nobody is responsible.  There are 
actually statements about "responsibility" in the 
documents.  If there is anything to learn, I'd 
say that what is written about the administrative 
structure does not work in practice.

Regards,
S. Moonesamy