Subject: Individual Draft Submissions.

From: Khaled Omar <[email-masked]>
Date: Wed, 7 Feb 2018 15:27:48 +0000

Hi all,

I have many questions that still without answers till now.

Does the IETF allows individual draft submissions but in fact they do not belong to the IETF work?

Does it means it is something to let people play with regardless of the ideas it contains?

When an individual draft be considered on a specific WG?

I have 3 drafts and neither has been taken forward for 1-year.

Even with having a co-author nothing have changed and I didn't get responses from the responsible AD or Chairs regarding each idea on every draft or even reserving a slot in the next IETF 101.

I got many advices from different people but nothing in the core development of each idea.

I don't want to keep working alone and making each draft takes the best shape and eventually they are not considered by the IETF and at the same time I do not want to bother people who think that this e-mail for forcing something to happen, no, it is just for understanding because when new ideas comes to the mind I feel they will face the same destiny as other ideas and the IETF will keep not caring.

Thanks,

Khaled

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 8 Feb 2018 13:56:20 +1300

> Does the IETF allows individual draft submissions but in fact they do not belong to the IETF work?

Short answer: Yes.

Long answer: Almost every RFC starts as an individual draft. If the draft arouses
interest, it may be discussed in a BOF or a WG. If it arouses a lot of interest,
it may be formally adopted by a WG. If it progresses well, it may be agreed
by the WG (following a WG Last Call). If OK with the Area Director, it may
be sent for IETF Last Call. If it passes Last Call, it will be submitted
to the IESG. If agreed by the IEAG, it will be sent to the RFC Editor for
publication.

This process can easily take two years. At every "if", the draft may fail.
I don't know the statistics; probably they could be extracted from the data
tracker, but my estimate is that at most 33% of individual drafts end up
as RFCs.

> Does it means it is something to let people play with regardless of the ideas it contains?

Short answer: Yes.

Long answer: Innovation comes from trial and error. We don't expect people
to dump every idea they have into an I-D, but having ideas available in
the I-D "sandbox" is one way that the IETF encourages innovation.
 
> When an individual draft be considered on a specific WG?

** When a significant number of people think that the idea is useful enough
to be worth considering. **

I just had a quick look at my own history... I could give you a list of
about 52 I-Ds that failed. It's normal.

> I have 3 drafts and neither has been taken forward for 1-year.

See ** above.

> Even with having a co-author nothing have changed and I didn't get responses from the responsible AD or Chairs regarding each idea on every draft or even reserving a slot in the next IETF 101.

See ** above.
 
> I got many advices from different people but nothing in the core development of each idea.

See ** above.

> I don't want to keep working alone and making each draft takes the best shape and eventually they are not considered by the IETF and at the same time I do not want to bother people who think that t…

Keep trying, but not with ideas that have already failed. See ** above.

Best regards,

    Brian

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 01:06:16 +0000

Thanks for the information Brian.

Can an I-D be discussed and updated after it is expired?

Regards,

Khaled

-------- Original Message --------
Subject: Re: Individual Draft Submissions.
From: Brian E Carpenter
To: Khaled Omar ,ietf
CC:

Short answer: Yes.

Short answer: Yes.

See ** above.

See ** above.

See ** above.

Best regards,

Brian

---

From: Jared Mauch <[email-masked]>
Date: Wed, 7 Feb 2018 20:10:35 -0500

> Can an I-D be discussed and updated after it is expired?

	Yes.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 01:47:23 +0000

Does this means that there is no interest from almost all of the IETF participants for all my drafts?

K.O

-------- Original Message --------

Short answer: Yes.

Short answer: Yes.

See ** above.

See ** above.

See ** above.

Best regards,

Brian

---

From: Mark Andrews <[email-masked]>
Date: Thu, 8 Feb 2018 13:37:23 +1100

> On 8 Feb 2018, at 12:47 pm, Khaled Omar <[email-masked]> wrote:
> 

Well draft-omar-ipv10-XX and draft-omar-ipmix-XX provide NOTHING THAT IS NEW.
You don’t even summarise the existing technology accurately.  Traffic will
switch over to IPv6.  All that is required is time.  Large amounts of traffic
already goes from IPv6 hosts at one end to IPv4 hosts at the other end.  Some
of that is initiated from IPv4, some from IPv6. Most equipment that you buy
today is IPv6 capable.

As for draft-omar-krp-XX, it is completely unrealistic.  I suggest that you
talk to network operators to understand why.

Mark

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742              INTERNET: [email-masked]

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 02:53:02 +0000

I do not understand what this means.

It requires good organizing to work perfectly.

Khaled

-------- Original Message --------
Subject: Re: Individual Draft Submissions.
From: Mark Andrews
To: Khaled Omar
CC: Brian E Carpenter ,Khaled Omar ,ietf

> On 8 Feb 2018, at 12:47 pm, Khaled Omar wrote:
>

Mark

---

From: Ted Lemon <[email-masked]>
Date: Wed, 7 Feb 2018 22:01:34 -0500

> Does this means that there is no interest from almost all of the IETF participants for all my drafts?

If there is interest, you will have heard from those who are interested.   If you haven't heard from anyone, it's safe to assume that there is no interest.

This can be really discouraging.   But it's actually good to get to the point where this happens, because then you can regroup and learn from the experience.

The first question to ask yourself is, why do you want to publish these documents?   That is, what core problem for Khaled Omar do these drafts solve?   Be brutally honest.   If the document hasn't gotten significant interest, the reason is that it's solving a problem you want to solve, not a problem that everyone wants to solve.   So where is the gap?

Write down a list of all the reasons it would be good for you if your document were published as an RFC.   Include reasons that have to do with your reputation, with your desire to be heard, etc.   Write down the technical reasons too.

But alongside the technical reasons, write down the list of documents that already attempt to solve the same problem in different ways.   Are any of them RFCs?   Have any of them seen adoption by hardware or software vendors?   How much would it cost to switch to doing what you are proposing?

Also think about how many people you want to read these documents, and how much time it will take them to read and understand them, and how much their time is worth in your favorite currency, whatever it happens to be.

This kind of thinking probably won't help you to get more interest in your current documents, but it will help you to learn from experience and produce documents that have more chance of attracting interest in the IETF.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 03:14:37 +0000

I respect this point of view.

I tried to write down what you said before and the introduction of every draft stats what it do clearly.

-------- Original Message --------
From: Ted Lemon

On Feb 7, 2018, at 8:47 PM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
Does this means that there is no interest from almost all of the IETF participants for all my drafts?

---

From: Mark Andrews <[email-masked]>
Date: Thu, 8 Feb 2018 14:20:25 +1100

> On 8 Feb 2018, at 1:53 pm, Khaled Omar <[email-masked]> wrote:
> 

Lets take this claim from your draft.

  22 years have passed since IPv6 was developed, but no full migration
  happened till now and this would cause the Internet to be divided
  into two parts, as IPv4 still dominating on the Internet traffic
  (85% as measured by Google in April, 2017) and new Internet hosts
  will be assigned IPv6-only addresses and be able to communicate with
  15% only of the Internet services and apps. 

In reality IPv6 only hosts are being deployed behind translating gateways
and can communicate with the entire IPv4 world.  For the cases where they
are servers, protocol translators with dedicated IPv4 address are deployed.
With MAP-E and MAP-T you can publish A addresses along with port information
to provide services to IPv4 clients as the those are stateless translations
mechanisms.

Anyone with a IPv4 host can bring up a tunnel with a IPv6 tunnel provider
and communicate with everyone on IPv6.

The problem you are trying to solve cannot be solved with more RFCs.  It
isn’t a technical problem.  It is at this stage a political problem.  It
is a education problem.

If you want to speed things up you need to talk to Governments and convince
them to mandate that IPv6 be provided.

Mark

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 03:37:14 +0000

This cannot be achieved, you can make for example a tunnel to allow IPv6 hosts to communicate through an IPv4 network.

> In reality IPv6 only hosts are being deployed behind translating gateways
and can communicate with the entire IPv4 world.

True, but using only hostnames, and the reverse is not applicable.

-------- Original Message --------
Subject: Re: Individual Draft Submissions.
From: Mark Andrews
To: Khaled Omar
CC: Brian E Carpenter ,ietf

> On 8 Feb 2018, at 1:53 pm, Khaled Omar wrote:
>

Mark

---

From: Mark Andrews <[email-masked]>
Date: Thu, 8 Feb 2018 15:01:58 +1100

> On 8 Feb 2018, at 2:37 pm, Khaled Omar <[email-masked]> wrote:
> 

So how does the machine I’m talking on, which is behind a IPv4 only ISP,
communicate to the IPv6 hosts that it does? 

> True, but using only hostnames,

Garbage! Do your homework! Understand ALL of what is already available.
DS-Lite, 464XLAT, MAP-E and MAP-T all allow IPv6 only hosts to communicate
to IPv4 addresses.

> and the reverse is not applicable.

Actually it is but you are not listening to people explaining how it can
be done.

Mark

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 04:18:20 +0000

Thanks for the polite way of conversation, I was talking about DNS64/NAT64.

There is no solution to allow IPv4 only hosts to communicate with IPv6 only hosts except IPv10.

Next e-mails should be unicast or I will not reply u here.

Khaled

-------- Original Message --------
CC: ietf

> On 8 Feb 2018, at 2:37 pm, Khaled Omar wrote:
>

Mark

---

From: Christopher Morrow <[email-masked]>
Date: Wed, 7 Feb 2018 23:27:20 -0500

> There is no solution to allow IPv4 only hosts to communicate with IPv6

Khaled, Many folk have tried to explain to you that in today's network:
  1) ipv4-only client + ipv6-only server == working
  2) ipv6-only client + ipv4-only server == working

you seem to believe that is not the case, and it's unclear to most readers
here (I think) why you believe that to be the case?
there are translation mechanisms in place to permit such connectivity, when
it's expected to work.

Yes, it's not possible for your ipv4 only client to talk to my ipv6-only
server if I don't put in place the correct translation techniques, but if I
want you to be able to do this I will take the time to put in place the
right bells and whistles.

Railing again and again that the world is unable to do things which it
patently can do isn't helping you out, nor this conversation out.
-chris

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 04:40:42 +0000

I meant there is no solution that allow direct connectivity without translations except IPv10.

-------- Original Message --------
From: Christopher Morrow
To: Khaled Omar
CC: Mark Andrews ,ietf

you seem to believe that is not the case, and it's unclear to most readers here (I think) why you believe that to be the case?
there are translation mechanisms in place to permit such connectivity, when it's expected to work.

Yes, it's not possible for your ipv4 only client to talk to my ipv6-only server if I don't put in place the correct translation techniques, but if I want you to be able to do this I will take the time to put in place the right bells and whistles.

Railing again and again that the world is unable to do things which it patently can do isn't helping you out, nor this conversation out.
-chris

---

From: Ted Lemon <[email-masked]>
Date: Wed, 7 Feb 2018 23:44:41 -0500

> I meant there is no solution that allow direct connectivity without translations except IPv10.

And for whom is this a problem?

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 04:51:44 +0000

For IPv4 only hosts.

-------- Original Message --------
Subject: Re: Individual Draft Submissions.
From: Ted Lemon
To: Khaled Omar
CC: Christopher Morrow ,ietf

On Feb 7, 2018, at 11:40 PM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
I meant there is no solution that allow direct connectivity without translations except IPv10.

---

From: Christopher Morrow <[email-masked]>
Date: Wed, 7 Feb 2018 23:55:21 -0500

> For IPv4 only hosts.
I think ted's earlier longer message about making lists of pros/cons and
such applies here... this generally isn't a problem, for most folks.
Generally speaking users (clients) and servers (service providers) sort out
the mix of v4/v6 and translation, if appropriate, such that connectivity is
available between the 2 parties.

If there are folk who need ipv4 to speak to ipv6 they must sort this out on
their own, but really "users" today just don't seem to notice/care, they
connect to the things they want to connect regardless of their or their
service providers' configurations. 'Monetary exchange' means connectivity
is available.

---

From: Mark Andrews <[email-masked]>
Date: Thu, 8 Feb 2018 16:00:22 +1100

> On 8 Feb 2018, at 3:51 pm, Khaled Omar <[email-masked]> wrote:
> 
> For IPv4 only hosts.

And the solution is to make the host dual stacked. That has been possible
for the last 20+ years.

---

From: Mark Andrews <[email-masked]>
Date: Thu, 8 Feb 2018 17:02:55 +1100

If one really wants IPv4 to IPv6 it would be easy enough to
do a TCP service which is registered in the DNS and is reachable
over IPv4 that takes a IPv6 address, transport and port tuple
and returns a IPv4 address and port that the client can connect
to using IPv4 over the specified transport.  Such a service would
be offered as part of a NAT64, MAP-T, MAP-E, DS-Lite and would
establish a time limited inbound mapping to the requested end
point from the IPv4 source address of the service request.

The hard part of IPv4 to IPv6 is establishing the mapping. This
would do so with a extra step performed by the IPv4 client.

example.com. AAAA 2001:0db8:85a3:0000:0000:8a2e:0370:7334
_4to6._tcp.example.com SRV 0 0 <TBD> nat64.example.net.
nat64.example.net. A 128.66.0.1

It may also pay to also return a session nonce which is added
as a IPv4 option.  Need to think about this some more.

This is similar in concept to previous work where a A record
is added to the DNS on demand but the returned address is
limited to a single client.
 
Mark

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 8 Feb 2018 10:38:10 +0000

> would do so with a extra step performed by the IPv4 client.

No, any mapping system really has to be backwards compatible with the 
client unaware this is happening.

There are lots of consumer goods out there, for example television sets, 
that expect to have a long service life and are v4 only with no chance 
or upgrade. Equally I expect that there is lots of commercial/industrial 
equipment in the same category.

- Stewart

---

From: Mark Andrews <[email-masked]>
Date: Thu, 8 Feb 2018 23:05:22 +1100

All the TV sets that are currently IPv4 only poll the vendor every night for a upgrades.  For most of them they are losing functionality without IPv6 being involved.

Additionally they basically only contact a couple of thousand addresses world wide. You only need to keep those addresses live while the rest of the world moves to IPv6.

The same applies to most of devices of this class. 

Most things that talk to all the world are already IPv6 capable and have been for a decade or more now.

Remember these IPv4 only devices live behind NATs and aren’t expecting to be contacted from the world. Connections that are made to them are local are IPv4 and local dual stack  still works behind IPv6 access networks.

People really are over worrying here. We could put all the homes on the planet behind IPv6 access networks and there would be minimal complaints because the local networks will continue to support IPv4. The routers will provide the IPv4 connectivity to the world. 

-- 
Mark Andrews

> On 8 Feb 2018, at 21:38, Stewart Bryant <[email-masked]> wrote:
> 
> 
> 
> No, any mapping system really has to be backwards compatible with the client unaware this is happening.
> 
> There are lots of consumer goods out there, for example television sets, that expect to have a long service life and are v4 only with no chance or upgrade. Equally I expect that there is lots of commercial/industrial equipment in the same category.
> 
> - Stewart
> 
> 
> 
>

---

From: Randy Bush <[email-masked]>
Date: Thu, 08 Feb 2018 21:32:37 +0900

>> The hard part of IPv4 to IPv6 is establishing the mapping. This would
>> do so with a extra step performed by the IPv4 client.
> 

luckily that was a basic principle of the upv6 design </snark>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 8 Feb 2018 08:21:38 -0500

> For IPv4 only hosts.

Not for what: for whom?   Who has this problem?   E.g., from your personal perspective, what hosts have you been unable to connect to because you only have IPv4 at home or at work?

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 13:26:04 +0000

Try to access (browse) an IPv6-only website for example and you will not be able if you have an IPv4-only address.

-------- Original Message --------

On Feb 7, 2018, at 11:51 PM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
For IPv4 only hosts.

---

From: Nick Hilliard <[email-masked]>
Date: Thu, 08 Feb 2018 13:47:16 +0000

> of that is initiated from IPv4, some from IPv6. Most equipment that you buy

More to the point, draft-omar-ipv10 requires substantial protocol
updates on not just all operating systems but also all TCP/IP APIs and
applications, and the application level support is no more backwards
compatible than native ipv6 support.

This is not viable because the amount of time and effort required to
make "omar-ipv10" work at all would be better spent on making ipv6 work
better.

In practice, it means that even if draft-omar-ipv10 worked at a
technical level (and there are no working prototypes), it would be
undeployable.

> talk to network operators to understand why.

KRP seems to require hierarchical routing, and hierarchical routing is
not how the internet works.

In other words, both draft-omar-ipv10 and draft-omar-krp are unworkable.
 This is why no-one is interested in discussing them in any of the
working groups.

Nick

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 13:59:14 +0000

IPv6 took enough time for its deployment and the result is no full migration occured anf what RIRs are trying to do now is to make IPv4 only to be dual stack, IPv10 is in the hands of technology companies.

KRP is only an organized way of the Internet routers, and routing is based on the stored information (region number and ASN) in the IP itself, there is no hierarchical routing, it is a matter of choosing the best route for every traffic class.

Khaled

-------- Original Message --------
Subject: Re: Individual Draft Submissions.
From: Nick Hilliard
To: Mark Andrews
CC: Khaled Omar ,Khaled Omar ,ietf

Nick

---

From: Warren Kumari <[email-masked]>
Date: Thu, 8 Feb 2018 09:00:02 -0500

> able if you have an IPv4-only address.

Sure, please provide a list of IPv6 only websites (not simply test
ones) and I'll be happy to give it a try from my IPv4 only hotel room.

W

> Not for what: for whom?   Who has this problem?   E.g., from your personal
> perspective, what hosts have you been unable to connect to because you only
> have IPv4 at home or at work?
>

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 14:07:21 +0000

Google IPv6 only websites and you will not be able to browse any, here is an example http://ipv6.cybernode.com/list-of-ipv6-only-sites

Khaled

-------- Original Message --------
From: Warren Kumari
To: Khaled Omar
CC: Ted Lemon ,ietf

W

> On Feb 7, 2018, at 11:51 PM, Khaled Omar
> wrote:
>
> For IPv4 only hosts.
>
>

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 8 Feb 2018 09:11:29 -0500

On Thu, Feb 8, 2018 at 9:07 AM, Khaled Omar <[email-masked]>
wrote:

> Google IPv6 only websites and you will not be able to browse any, here is
> an example http://ipv6.cybernode.com/list-of-ipv6-only-sites
>
>
maybe warren's point (and pretty much everyone else's actually)  is that
accessing a website takes more than just compatible IP protocol numbers.
ipv6.google.com has no A record, only an AAAA record in DNS... your ipv4
host will never lookup a AAAA because it's ipv4 not ipv6.

this is working as intended.

> > Try to access (browse) an IPv6-only website for example and you will not
> be
> > able if you have an IPv4-only address.
>

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 14:18:08 +0000

With IPv10 you will be able to access IPv6 only from IPv4 only hosts, and with the DNS, as described on the draft, you can have AAAA record as a reply to hostname resolution from an IPv4 only host then the communication can take place.

-------- Original Message --------
CC: Warren Kumari ,ietf

On Thu, Feb 8, 2018 at 9:07 AM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
Google IPv6 only websites and you will not be able to browse any, here is an example http://ipv6.cybernode.com/list-of-ipv6-only-sites

maybe warren's point (and pretty much everyone else's actually)  is that accessing a website takes more than just compatible IP protocol numbers.
ipv6.google.com<http://ipv6.google.com> has no A record, only an AAAA record in DNS... your ipv4 host will never lookup a AAAA because it's ipv4 not ipv6.

Khaled

-------- Original Message --------

W

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 8 Feb 2018 09:36:20 -0500

On Thu, Feb 8, 2018 at 9:18 AM, Khaled Omar <[email-masked]>
wrote:

> With IPv10 you will be able to access IPv6 only from IPv4 only hosts, and
> with the DNS, as described on the draft, you can have AAAA record as a
> reply to hostname resolution from an IPv4 only host then the communication
> can take place.
>
>
sorry, last time... this isn't a problem in the real world.

>> > Try to access (browse) an IPv6-only website for example and you will
>> not be

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 14:46:14 +0000

This is an individual decision and is respected, if someone has a different opinion, feel free to contact me for the discussion.

Khaled

-------- Original Message --------

Nick

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 14:50:11 +0000

How this is not a problem!!!

Think about newcomers to the Internet, they will be assigned IPv6 only, how other IPv4 only communicate with them?!!

Khaled

-------- Original Message --------

On Thu, Feb 8, 2018 at 9:18 AM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
With IPv10 you will be able to access IPv6 only from IPv4 only hosts, and with the DNS, as described on the draft, you can have AAAA record as a reply to hostname resolution from an IPv4 only host then the communication can take place.

-------- Original Message --------

Khaled

-------- Original Message --------

W

---

From: John C Klensin <[email-masked]>
Date: Thu, 08 Feb 2018 09:51:04 -0500

Let me add one thing to Brian's (very helpful and accurate, IMO)
comments and an additional thought along the same lines...

--On Thursday, February 8, 2018 13:56 +1300 Brian E Carpenter
<[email-masked]> wrote:

>...
> Long answer: Almost every RFC starts as an individual draft.
> If the draft arouses interest, it may be discussed in a BOF or
> a WG. If it arouses a lot of interest, it may be formally
> adopted by a WG. If it progresses well, it may be agreed by
> the WG (following a WG Last Call). If OK with the Area
> Director, it may be sent for IETF Last Call. If it passes Last
> Call, it will be submitted to the IESG. If agreed by the IEAG,
> it will be sent to the RFC Editor for publication.
> 
> This process can easily take two years. At every "if", the
> draft may fail. I don't know the statistics; probably they
> could be extracted from the data tracker, but my estimate is
> that at most 33% of individual drafts end up as RFCs.

In the hope of avoiding additional frustrated questions, I would
guess that, if those statistics were actually pulled out, they
would also show that people who had already successfully gotten
work adopted and/or edited documents that became RFCs do
somewhat better in those statistics than those who have had
neither experience.  Some of that difference is a form of
incumbent advantage -- people are somewhat more likely to read
at least the title and abstract of a document from someone whose
work they know -- but I'd guess that more of it is that those
authors have a somewhat better sense (relative to newcomers) of
what sort of ideas are likely to get traction of suggested and
how to present them.

Put differently (and I think this has been said to you before),
while there is no requirement for what y0u might think of as an
apprenticeship in the IETF, those people who come to the IETF,
try to understand what others are doing and where interests lie,
participate actively in one or more working groups that align
with their expertise, and only then start pushing their own
innovations and ideas usually have a much easier time when that
time comes.  It may well be that people have shown up without
prior involvement, experience, and visibility in the IETF;
submitted Internet Drafts containing innovative and radical
ideas; and have those drafts evolve into Internet standards, but
it has certainly not been common, at least in recent years.

In spite of that, the comments of the last 36 hours or so
indicate to me that a number of skilled people are examining
your proposals.  That is _much_ better than my guess at the
average for unsolicited ideas from people whose work is not
already known to active IETF participants.  While I agree with
some of the reasoning in those notes and not others (because
those are not areas in which I'm actively working, my technical
opinion may not be worth much), the consensus seems to be that
your ideas, as posted so far, are just not practical. While
different people have focused on assumptions that you have made
they don't believe are correct, conclusions about the problems
that need to be solved that differ from their experience,
specific technical problems, operational or economic issues, or
something else, the conclusion is the same: unless considerably
modified in both substance and explanation, those documents and
ideas are not going anywhere in the IETF (or probably anywhere
else).  

I hope your next proposal does a lot better.

best,
    john

those ideas

---

From: Nick Hilliard <[email-masked]>
Date: Thu, 08 Feb 2018 15:00:21 +0000

Khaled Omar wrote:
> IPv6 took enough time for its deployment and the result is no full
> migration occured anf what RIRs are trying to do now is to make IPv4
> only to be dual stack, IPv10 is in the hands of technology companies.

"IPv10" does not exist, so it is not "is in the hands of technology
companies".  Also, the RIRs are internet number registries, so it's not
their job to cause people to move from ipv4-only to dual stack.

The IETF works on the basis of "rough consensus and running code".
No-one has come forward to say that "ipv10" is a good idea, and there's
no running code.  Your drafts are unlikely to progress unless this changes.

> KRP is only an organized way of the Internet routers, and routing is
> based on the stored information (region number and ASN) in the IP
> itself, there is no hierarchical routing

If you are routing on the basis of "region number", then this is
hierarchical routing, by definition.

The IETF spent a good deal of time looking at hierarchical routing about
20 years ago.  At the time, it was realised that any attempt to deploy
hierarchical routing on an internet would fail.  There's probably plenty
of discussion on various ietf mailing lists from the late 1990s about
this.  You should read through the ietf mailing list archives to see why
hierarchical routing is unworkable.

Nick

---

From: Ted Lemon <[email-masked]>
Date: Thu, 8 Feb 2018 10:45:37 -0500

> Try to access (browse) an IPv6-only website for example and you will not be able if you have an IPv4-only address.

Yes, I understand that.   But who has this problem?

---

From: John C Klensin <[email-masked]>
Date: Thu, 08 Feb 2018 11:05:53 -0500

--On Thursday, February 8, 2018 14:18 +0000 Khaled Omar
<[email-masked]> wrote:

> With IPv10 you will be able to access IPv6 only from IPv4 only
> hosts, and with the DNS, as described on the draft, you can
> have AAAA record as a reply to hostname resolution from an
> IPv4 only host then the communication can take place.

Khaled,

Let me try to explain the problem a different way, noting the
response I sent a few minutes ago, and then I'm going to stop
spending time on this thread.  In retrospect, few of us are
convinced that, if we could turn the clock back to the first
half of the 1990s and start over with the knowledge we have
today, IPv6 would have come out the same way.   I can't even
guess whether there would have been consensus on a different
approach, but I think many of us would have different ideas as
to how to proceed from a protocol, deployment, or other
perspective.  

If the ideas you are now calling IPv10 had been available to us
in about 1994 (again, in combination with what we've learned
subsequently), it is an interesting question whether they would
have usefully contributed to the IPng discussions and had
significant effects on what became IPv6.  Those questions are
particularly interesting (at least to me) because some of the
assumptions we made them about what was important and what the
actual marketplace empirically finds important today are
different and it is very hard to sort out cause and effect in
those changes. 

However, today, that question is very nearly irrelevant in
practical terms and Internet design and development going
forward.   In my particular case, I cringe every time I see some
of the solutions that have been deployed to allow IPv6 hosts to
reach Ipv4 systems and vice versa.  But cringing doesn't change
anything and end users, probably unsurprisingly, don't care
about some of the issues I do and, more important, care only
about what it takes to get whatever they are trying to do (from
an applications standpoint) in a reasonably effective way.  

Maybe the world would be a better place if things were
different.  But they are not different and the net result is
that you are working very hard to solve a problem that not only
does the marketplace not care about it, but they vast majority
of users don't agree that there is a problem.

    john

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 16:09:37 +0000

Again, IPv4 only hosts.

-------- Original Message --------

On Feb 8, 2018, at 8:26 AM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
Try to access (browse) an IPv6-only website for example and you will not be able if you have an IPv4-only address.

---

From: Ted Lemon <[email-masked]>
Date: Thu, 8 Feb 2018 11:59:51 -0500

> Again, IPv4 only hosts.

What human being with a body with arms and legs has a problem?   Point to an actual person, whom you know, who has a name.   What person, that you know, has an actual problem, because their IPv4-only host can't access some resource online.   Why can't they use any of the existing solutions to this problem?   What host do they have?

Don't tell me about some theoretical host somewhere, owned by some theoretical person with a theoretical problem.   Who do you know personally who has this problem?   Why is what you are proposing the fastest way to get them a solution?   Why do none of the existing solutions satisfy their need?

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 17:14:14 +0000

Imagine a network with IPv6 only hosts, this network has many resources (web server, e-mail, etc).

Some other already existing network has IPv4 only hosts, they need to access these resources, but sorry they cannot, this is the problem.

Imagine the percentage of the IPv6 only hosts became 50% of the internet traffic, this means the 50% IPv4 only hosts will have access to only 50%, a clear division, this is the problem.

-------- Original Message --------

On Feb 8, 2018, at 11:09 AM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
Again, IPv4 only hosts.

---

From: Bernardo Soares <[email-masked]>
Date: Thu, 8 Feb 2018 15:20:14 -0200

>>  Don't tell me about some theoretical host somewhere

>>  Imagine a network

On Thu, Feb 8, 2018 at 3:14 PM, Khaled Omar <[email-masked]>
wrote:

> Some other already existing network has IPv4 only hosts, they need to
> access these resources, but sorry they cannot, this is the problem.
>
> Imagine the percentage of the IPv6 only hosts became 50% of the internet
> traffic, this means the 50% IPv4 only hosts will have access to only 50%, a
> clear division, this is the problem.
>
>
> What *human being with a body with arms and legs* has a problem?   Point
> to an actual person, whom you know, who has a name.   What person, that you
> know, has an actual problem, because their IPv4-only host can't access some
> resource online.   Why can't they use any of the existing solutions to this
> problem?   What host do they have?
>
> Don't tell me about some theoretical host somewhere, owned by some
> theoretical person with a theoretical problem.   Who do you know
> *personally* who has this problem?   Why is what you are proposing the
> fastest way to get them a solution?   Why do none of the existing solutions
> satisfy their need?
>
>

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 17:22:10 +0000

Sorry everyone, i'll not be able to reply to other e-mails today, it is more than 1 day without sleeping, remember we have different time zones, and the first reply started 2:00 AM.

Thanks for understanding, we can continue later.

Khaled

-------- Original Message --------
From: Khaled Omar
To: Ted Lemon
CC: ietf

---

From: Khaled Omar <[email-masked]>
Date: Thu, 8 Feb 2018 17:25:02 +0000

This will be a fact, look for Google IPv6 adoption, what is the recent IPv6 only hosts percentage, what is the IPv4 only hosts percentage.

I mean by imagine to think about it.

Khaled

-------- Original Message --------
From: Bernardo Soares
To: Khaled Omar
CC: Ted Lemon ,ietf

>>  Imagine a network

On Thu, Feb 8, 2018 at 3:14 PM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
Imagine a network with IPv6 only hosts, this network has many resources (web server, e-mail, etc).

---

From: "Matthew A. Miller" <[email-masked]>
Date: Thu, 8 Feb 2018 10:26:48 -0700

This Sergeant-at-Arms asks that everyone take some time away from this
thread.  The points have been well made, and are now being well made
repeatedly.

Thank you,

- m&m

Matthew A. Miller

---

From: Ted Lemon <[email-masked]>
Date: Thu, 8 Feb 2018 12:36:57 -0500

> Imagine a network with IPv6 only hosts, this network has many resources (web server, e-mail, etc).

No, please.   Don't ask me to imagine.   Tell me about a real person.

---

From: [email-masked] (Martin Rex)
Date: Thu, 8 Feb 2018 21:05:58 +0100 (CET)

Ted Lemon <[email-masked]> wrote:
> Not for what: for whom?   Who has this problem?
> E.g., from your personal perspective, what hosts have you been
> unable to connect to because you only have IPv4 at home or at work?

I have most of my PC & notebook stuff on IPv4 only, and I have my
home router on IPv4 only, and I have never met any connectivity issue
so far, that I couldn't reach a service.

But I had several severe network connectivity issues in the
not-so-distant-past with machines that had IPv6 enabled,
and those problems vanished completely when I disabled IPv6
on the machine.

No end-user needs IPv6, really.

-Martin

---

From: Mark Andrews <[email-masked]>
Date: Fri, 9 Feb 2018 07:18:18 +1100

It won’t be a IPv4 only host.  It will be a IPv10 host.

Sorry your draft doesn’t do what you think it does.

Mark

> On 9 Feb 2018, at 1:18 am, Khaled Omar <[email-masked]> wrote:
> 
> On Thu, Feb 8, 2018 at 9:07 AM, Khaled Omar <[email-masked]> wrote:
> ipv6.google.com has no A record, only an AAAA record in DNS... your ipv4 host will never lookup a AAAA because it's ipv4 not ipv6.
>

---

From: Mark Andrews <[email-masked]>
Date: Fri, 9 Feb 2018 07:22:01 +1100

> On 9 Feb 2018, at 1:50 am, Khaled Omar <[email-masked]> wrote:
> 

They will take the step required to make themselves dual stacked.
If your company doesn’t take the steps to enable IPv6 for you
complain to your management.  There is NOTHING the IETF can do that
is preventing them enabling IPv6.

> On Thu, Feb 8, 2018 at 9:18 AM, Khaled Omar <[email-masked]> wrote: