Subject: Genart last call review of draft-ietf-dime-rfc4006bis-07

From: Linda Dunbar <[email-masked]>
Date: Thu, 03 May 2018 16:10:29 -0700

Reviewer: Linda Dunbar
Review result: Almost Ready

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-dime-rfc4006bis-07
Reviewer: Linda Dunbar
Review Date: 2018-05-03
IETF LC End Date: 2018-04-12
IESG Telechat date: 2018-05-24

Summary:
The document is well written for the part describing how end-users/CC-client
request services from Credit Control server.

Is it mandatory to use the Section 4 provided mechanism for Rating Input to the
Credit Control? Can the Credit Control get credit rating from offline process
(manual, offline, etc)?

Major issues: None

Minor issues: Is Section 4 mechanism mandatory?

Nits/editorial comments:

Regards, Linda Dunbar

---

From: Yuval Lifshitz <[email-masked]>
Date: Sun, 6 May 2018 08:42:04 +0000 (UTC)

Section 4 does not use normative language that dictates the *only* source for rating would be the CC-client. As the act of rating is done on the CC-server it may take into account other factors (for e.g. may fetch the subscriber's tier from an external system and use it together with service ID coming from the CC-Client to do the rating). However, if the rating input comes entirely from a different source (e.g. consumption of offline UDRs) then we cannot say that the above spec is implemented, as the concepts of online-charging is pivotal to the protocol between the CC-Client and CC-Server.
Yuval