Subject: Genart telechat review of draft-ietf-ccamp-microwave-framework-05

From: Linda Dunbar <[email-masked]>
Date: Sun, 13 May 2018 18:56:44 -0700

Reviewer: Linda Dunbar
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair. Please wait for direction from your
document shepherd or AD before posting a new version of the draft.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-ccamp-microwave-framework-05
Reviewer: Linda Dunbar
Review Date: 2018-05-13
IETF LC End Date: 2018-04-20
IESG Telechat date: 2018-05-24

Summary:

IETF LC End Date: N/A
IESG Telechat date: 2018-05-

Summary:  with a potential issue.

Page11, Section 4.5:
Missing signal degradation or partial fault management. Radio link is heavily
impacted by weather. Rain/cloud can make a radio link lose up to 50% of its
capacity. Therefore, it will be quite useful to report the effective bandwidth
of the radio link.

Some questions:

Page 6: Can one Radio Link be shared by multiple Carrier Terminations?  If yes,
are those multiple Carrier Terminations terminated at one physical device?

Page 7: do you mean “key goal or key purpose of this work” in the following
sentence? “The adoption of an SDN framework for management and control the
microwave interface is one of the key applications for this work.”

Page 10, Section 4.1.2: What does “over the hop” mean in the first sentence?
Isn’t it same as “… establish L1 connectivity to an associated radio link…”?

Major issues:  N/A

Minor issues:

Nits/editorial comments:

Best Regards, Linda Dunbar

---

From: "Yemin (Amy)" <[email-masked]>
Date: Mon, 14 May 2018 06:10:02 +0000

Hi Linda,

Thanks for your review.

Please see my reply inline below.

We will soon update the draft to address the comments.

BR,

Amy

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Monday, May 14, 2018 9:57 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: [CCAMP] Genart telechat review of draft-ietf-ccamp-microwave-framework-05

Reviewer: Linda Dunbar

I am the assigned Gen-ART reviewer for this draft. The General Area Review Team (Gen-ART) reviews all IETF documents being processed by the IESG for the IETF Chair. Please wait for direction from your document shepherd or AD before posting a new version of the draft.

Reviewer: Linda Dunbar

Review Date: 2018-05-13

Summary:

IETF LC End Date: N/A

Page11, Section 4.5:

Missing signal degradation or partial fault management. Radio link is heavily impacted by weather. Rain/cloud can make a radio link lose up to 50% of its capacity. Therefore, it will be quite useful to report the effective bandwidth of the radio link.
[Amy] Yes, the bandwidth of the radio link is a very important characteristic. We put the bandwidth in the mw topology model, not in the interface model, just following the way in generic TE topology model.
Originally, this framework is for interface model only, therefore it doesn’t address the bandwidth. We could update the framework to address your comments.

Some questions:

Page 6: Can one Radio Link be shared by multiple Carrier Terminations?  If yes, are those multiple Carrier Terminations terminated at one physical device?
[Amy] Yes and yes.  The figure below (from draft-ietf-ccamp-mw-yang) is for your reference.

Page 7: do you mean “key goal or key purpose of this work” in the following sentence? “The adoption of an SDN framework for management and control the microwave interface is one of the key applications for this work.”

[Amy] Yes, your wording is much better, will use it.

Isn’t it same as “… establish L1 connectivity to an associated radio link…”?
[Amy] Please see the figure above, normally we call the near end node and far end node as a hop.  Here “over the hop” can be moved to the end of the sentences, or completely removed.

Major issues:  N/A

Minor issues:

Nits/editorial comments:

_______________________________________________

CCAMP mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/ccamp

---

From: "Yemin (Amy)" <[email-masked]>
Date: Fri, 18 May 2018 01:55:08 +0000

Hi Linda,

We updated the draft, https://datatracker.ietf.org/doc/draft-ietf-ccamp-microwave-framework/ .
The following text is added to address your first comments:

1.       Add "It's important to report the effective bandwidth of a radio link since it can be configured to dynamically adjust the modulation based on the current signal conditions." at the end of section 4.3.1. Actual status and performance of a radio link interface.

2.       Add "It's important to report signal degradation of the radio link." at the end of section 4.5.2 Alarm management.
Your rest comments are also addressed in the latest version.

BR,
Amy
From: CCAMP [mailto:[email-masked]] On Behalf Of Yemin (Amy)
Sent: Monday, May 14, 2018 2:10 PM
To: Linda Dunbar <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [CCAMP] Genart telechat review of draft-ietf-ccamp-microwave-framework-05

Hi Linda,

Thanks for your review.

BR,

Amy

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Monday, May 14, 2018 9:57 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [CCAMP] Genart telechat review of draft-ietf-ccamp-microwave-framework-05

Reviewer: Linda Dunbar

Reviewer: Linda Dunbar

Review Date: 2018-05-13

Summary:

IETF LC End Date: N/A

Page11, Section 4.5:

Some questions:

Major issues:  N/A

Minor issues:

Nits/editorial comments:

CCAMP mailing list

---

From: Linda Dunbar <[email-masked]>
Date: Fri, 18 May 2018 07:43:36 +0000

Amy,

Thank you for making the changes. Your changes are very good. No more comments. I think the draft is ready for publication.

Linda Dunbar

From: Yemin (Amy)
Sent: Thursday, May 17, 2018 8:55 PM
To: Yemin (Amy) <[email-masked]>; Linda Dunbar <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [CCAMP] Genart telechat review of draft-ietf-ccamp-microwave-framework-05

Hi Linda,

BR,
Amy
To: Linda Dunbar <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>

Hi Linda,

Thanks for your review.

BR,

Amy

-----Original Message-----
From: CCAMP [mailto:[email-masked]] On Behalf Of Linda Dunbar
Sent: Monday, May 14, 2018 9:57 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [CCAMP] Genart telechat review of draft-ietf-ccamp-microwave-framework-05

Reviewer: Linda Dunbar

Reviewer: Linda Dunbar

Review Date: 2018-05-13

Summary:

IETF LC End Date: N/A

Page11, Section 4.5:

Some questions:

Major issues:  N/A

Minor issues:

Nits/editorial comments:

CCAMP mailing list