Subject: Internet Drafts' Destiney.

From: Khaled Omar <[email-masked]>
Date: Sun, 27 May 2018 20:15:32 +0000

Hi All,

It is long time since I've uploaded 3 Internet Drafts (KRP, NEP, and IPv10) to the IETF repository and there is no official decision has been taken regarding these drafts till now (maybe IPv10 was the only one that had official rejection by the Internet area chair and his own opinion is respected) but what about other drafts.

I've presented NEP remotely at the IETF 101 but nothing happened after that, there was no reviews, no active discussions and that makes me feel that drafts from outside the IETF (individual draft submissions) has no destiny, it is no more than bringing new ideas to the IETF and that's all.

I wish I'm able to attend personally any coming IETF meeting as I got this question many times from different people at the IETF, and I hope this is not the reason why the drafts are not taken into consideration because this is something out of the hands.

So again I'm asking the same question that I've asked in the past, when the IETF will discuss drafts seriously!!! I think the IETF with all it processes should have something official to do with drafts, they must be reviewed and evaluated so a decision can be taken whether to take them into consideration or to remove them from the repository as long as they are useless.

My work on these drafts took so much efforts from my side, and I'm welcoming co-authors to add more to these ideas as I believe they will bring a great value to the internet, but there is something missing from the IETF side regarding these drafts, they must be evaluated and this evaluation should be clear at least to let me know whether these ideas are good or I shouldn't submit more drafts to the IETF, I hope there is no place for politics within the IETF because this will affect the reputation of any organization, and I hope I'm wrong on this.

Looking forward to read any evaluation or reviews or comments regarding these drafts.

Regards,

Khaled

---

From: Michel Py <[email-masked]>
Date: Mon, 28 May 2018 01:26:04 +0000

Repeat after me :

I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.
I will not feed the troll.

---

From: Khaled Omar <[email-masked]>
Date: Mon, 28 May 2018 17:36:09 +0000

It is better to say something good and responsible other than saying trivial repeated words because these words represents only your culture and yourself.

I feel sorry for the people who are reading this.

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Michel Py
Sent: Monday, May 28, 2018 3:26 AM
To: [email-masked]
Subject: RE: Internet Drafts' Destiney.

Repeat after me :

---

From: Ole Jacobsen <[email-masked]>
Date: Mon, 28 May 2018 10:50:40 -0700 (PDT)

On Mon, 28 May 2018, Khaled Omar wrote:

> It is better to say something good and responsible other than saying 
> trivial repeated words because these words represents only your 
> culture and yourself.
> 

"Culture" is indeed the key phrase here. The IETF has its own culture,
its own way of developing standards/drafts/whatever. This has been
repeatedly explained to you, yet you've chosen a different approach
and now you're asking the IETF to engage. 

I am sorry, but it just doesn't work that way. Perhaps it should, but
that's not currently the way things work.

Ole

---

From: Khaled Omar <[email-masked]>
Date: Mon, 28 May 2018 17:57:06 +0000

As I just told Ted privately, all what I'm trying to do is to ask good minds to evaluate the ideas, if I don't believe that the best minds are here I wouldn't ask for evaluation at least maybe there is something needs modification or something more to add.

I'm not forcing people to show interest, but maybe someone will find the idea interesting, I feel it is not good to submit drafts to a reputable organization such as the IETF and find no response, that's all.

-----Original Message-----
From: Ole Jacobsen [mailto:[email-masked]] 
Sent: Monday, May 28, 2018 7:51 PM
To: Khaled Omar <[email-masked]>
Cc: Michel Py <[email-masked]>; [email-masked]
Subject: RE: Internet Drafts' Destiney.

> I feel sorry for the people who are reading this.

"Culture" is indeed the key phrase here. The IETF has its own culture, its own way of developing standards/drafts/whatever. This has been repeatedly explained to you, yet you've chosen a different approach and now you're asking the IETF to engage. 

I am sorry, but it just doesn't work that way. Perhaps it should, but that's not currently the way things work.

Ole

---

From: Nick Hilliard <[email-masked]>
Date: Mon, 28 May 2018 20:31:50 +0100

Here's what grep says about previous discussions since Nov 2016:

> % egrep -i '(IPv10|krp|When the IETF can discuss|Re: Individual Draft Submissions.)' * | wc -l
>      271
> %

Sergeant-at-arms, could you please do something?  This is wasting 
peoples' time.

Nick

Khaled Omar wrote on 28/05/2018 18:57:
> I feel it is not good to submit drafts to a
> reputable organization such as the IETF and find no response, that's
> all.

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 28 May 2018 17:29:37 -0500

> Sergeant-at-arms, could you please do something?  This is wasting 

Well, we already had
https://www.ietf.org/mail-archive/web/ietf/current/msg102743.html
and
https://www.ietf.org/mail-archive/web/ietf/current/msg103024.html ,
and the current thread so far don't seem to support an RFC 3683
posting rights action.  I don't think that "I wish my document got
more review" is grounds for restricting mailing list posting
privileges, until it becomes abusive/inappropriate due to volume or
other issues.

So maybe you could say more on what "something" you had in mind, and
what BCP justifies it.  (I'm happy to hear that on the [email-masked]
list, since presumably we don't need to further contribute to the
traffic on [email-masked].)

-Ben

---

From: Melinda Shore <[email-masked]>
Date: Mon, 28 May 2018 15:46:55 -0800

> Sergeant-at-arms, could you please do something?  This is wasting

<no hats>It's annoying but I don't see anything here that's
sufficiently problematic to merit a PR action.  If you find it
particularly bothersome, there's technology available that would
allow you to filter out things you know in advance that
you don't want to see.

Melinda

---

From: Randy Bush <[email-masked]>
Date: Mon, 28 May 2018 18:18:16 -0700

> Sergeant-at-arms, could you please do something?  This is wasting

maybe do an actual review?

randy

---

From: Michel Py <[email-masked]>
Date: Tue, 29 May 2018 03:00:53 +0000

> Randy Bush wrote :

I once hated Bandy Rush because he told me in no uncertain terms that my ideas were worthless.
A long time after, he was right. I still don't like him, for the same reason most readers don't like me.
I remember being the troll. I invented the wheel, hot water, and how to make the Internet right.
Of course, I was wrong. Randy said that I was full of it.

I remember Randy having very harsh words about my work. In hindsight, he was right.
It hurts me to say that Randy Bush was right.

Randy Bush, I think you are an asshole.
That being said, you have been providing guidance on this list that history will painfully remember as an obstruction. I still remember you as being a problem.

In the end, you and I have the same problem : we have been telling the truth. It is not palatable.

Go to hell without me. Humor me please, get the ball rolling on this one.

Michel.

---

From: Michel Py <[email-masked]>
Date: Tue, 29 May 2018 03:32:52 +0000

> Ted Lemon wrote :
> Stop being abusive on the IETF mailing list, please and thank you.

If you have anything to say about the way I conduct myself on this mailing list, make it public.
I know it is not palatable to post publicly what was a private message, sue me. I do this in bright daylight.

Sue me.

Bandy Rush, you have my attention. We have been enemies for years.

Michel.

---

From: Michel Py <[email-masked]>
Date: Tue, 29 May 2018 03:50:48 +0000

> Ted Lemon wrote:
> top being abusive on the IETF mailing list, please and thank you.

You know why the IETF has become irrelevant ? it's because you are so full of it that you think you can decide what I can say to Randy and what I can't.

Randy, please say something. Become part of the bullshit buddy system, or don't.

Michel.

---

From: Lloyd Wood <[email-masked]>
Date: Tue, 29 May 2018 04:59:10 +0000 (UTC)

I think there's an underestimation of the effort and work involved to develop good, useful, protocols and progress the drafts describing them, and to get the community engaged in those drafts as an appropriate solution to a problem the community sees as needing addressing. There's a lot of convincing, technical and otherwise, to be done to build interest, with work develop the drafts further technically and gain consensus.

>From personal experience, it's possible to have quite mature designs and individual internet-drafts with theoretical justifications, presentations at IETF meetings, implementations, testing experience etc.:
http://saratoga.sf.net/
http://http-dtn.sf.net/

and yet still have little interest from the appropriate workgroups, who are busy with other concerns, such as trying to make the bundle protocol work the second time around.
Gaining interest is difficult to do when there are already incumbent established designs and working implementations, or already chosen preferred approaches. Being different is not enough, being better may not be enough. Even when you understand how the IETF and its processes work.

But that's fine; the work should be able to stand by itself on its own merits, while validation by the IETF with eventual RFC publication can be just a bonus. If you really want to publish an RFC, write an April Fool's RFC, or something descriptive, useful and informational that is needed; protocol design is not the easiest path to publication.

 Lloyd Wood
http://sat-net.com/L.Wood/dtn 

any organisation is political.
________________________________
From: Khaled Omar <[email-masked]>
To: "[email-masked]" <[email-masked]> 
Sent: Monday, 28 May 2018, 6:16
Subject: Internet Drafts' Destiney.

Hi All,
 
It is long time since I’ve uploaded 3 Internet Drafts (KRP, NEP, and IPv10) to the IETF repository and there is no official decision has been taken regarding these drafts till now (maybe IPv10 was the only one that had official rejection by the Internet area chair and his own opinion is respected) but what about other drafts.
 
I’ve presented NEP remotely at the IETF 101 but nothing happened after that, there was no reviews, no active discussions and that makes me feel that drafts from outside the IETF (individual draft submissions) has no destiny, it is no more than bringing new ideas to the IETF and that’s all.
 
I wish I’m able to attend personally any coming IETF meeting as I got this question many times from different people at the IETF, and I hope this is not the reason why the drafts are not taken into consideration because this is something out of the hands.
 
So again I’m asking the same question that I’ve asked in the past, when the IETF will discuss drafts seriously!!! I think the IETF with all it processes should have something official to do with drafts, they must be reviewed and evaluated so a decision can be taken whether to take them into consideration or to remove them from the repository as long as they are useless.
 
My work on these drafts took so much efforts from my side, and I’m welcoming co-authors to add more to these ideas as I believe they will bring a great value to the internet, but there is something missing from the IETF side regarding these drafts, they must be evaluated and this evaluation should be clear at least to let me know whether these ideas are good or I shouldn’t submit more drafts to the IETF, I hope there is no place for politics within the IETF because this will affect the reputation of any organization, and I hope I’m wrong on this.

Regards,
 
Khaled

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 29 May 2018 09:00:03 +0200

According to RFC3005, the discussion in this list of documents that have other venue, is not allowed.

So, if an author of IDs that have been discussed already in specific WG/area mailing list without success, keeps asking for support in the general area, it is perfectly reasonable to restrict his/her posting rights.

As in this case that was done already for some time, the next action is to increase that period of time.

Regards,
Jordi

-----Mensaje original-----
De: ietf <[email-masked]> en nombre de Benjamin Kaduk <[email-masked]>
Fecha: martes, 29 de mayo de 2018, 0:30
Para: Nick Hilliard <[email-masked]>
CC: "[email-masked]" <[email-masked]>
Asunto: Re: Internet Drafts' Destiney.

    Well, we already had

    -Ben

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Nick Hilliard <[email-masked]>
Date: Tue, 29 May 2018 11:40:40 +0100

> maybe do an actual review?

There's nothing to say that hasn't already been said by many other 
people, but let's rinse and repeat anyway:

IPv10: the proposals ignore all previous discussions about ipv4 to ipv6 
compatibility schemas.  There's been a good deal of discussion about 
this over the years, and the general opinion is that direct ipv4-ipv6 
compatibility shims are unworkable for a variety of reasons.  Brian 
Carpenter sent this helpful and constructive email in Nov 2016:

https://www.ietf.org/mail-archive/web/ietf/current/msg99798.html

This still stands today.

KRP: describes some form of hierarchical address allocation mechanism 
but there are no details provided about the "protocol" itself.  There 
isn't anything to review here because the draft has no workable content.

The problem isn't a lack of reviews, it's that these ideas have been 
discussed repeatedly at the ietf over many years and the consensus is 
that they are unworkable.

Khaled has not gone to the effort of looking into why they were 
unworkable, nor has he developed his proposals to the point that they 
are actually testable in a lab environment (at which point it would 
become clear that they are unworkable in the real world).

Khaled apparently isn't interested in listening to this feedback.  The 
feedback and reviews are there.

We've had ~300 emails on ietf@, and nothing has progressed beyond what 
was stated in Nov 2016, at which stage Khaled was warned multiple times 
by the sergeant-at-arms of the time that his attempts to bring these 
topics up on the ietf@ mailing list were not ok:

https://www.ietf.org/mail-archive/web/ietf/current/msg99875.html
https://www.ietf.org/mail-archive/web/ietf/current/msg99932.html

... hence the request for sergeant-at-arms to intervene again.

Nick

---

From: Randy Bush <[email-masked]>
Date: Tue, 29 May 2018 06:53:50 -0700

[ sory to add to this convo ]

> that they are unworkable.

omg!  an unworkable ipv6 transition mechanism.  be sure to get a picture
of it.  (sorry, could not resist)

agree that brian's message,
https://www.ietf.org/mail-archive/web/ietf/current/msg99798.html, was on
technical point.  perhaps we can remind khaled to respond to it.

> Khaled was warned multiple times by the sergeant-at-arms of the time
> that his attempts to bring these topics up on the ietf@ mailing list
> were not ok:

i was rather horrified by this censorship aimed at just one more eng
pushing their ideas; the dos attack was the responses, not khaled's
postings from outside the in-crowd culture.  no need to repeat.

attack the ideas, not the person.  brian's message is a great example of
the high ground.

randy

---

From: Khaled Omar <[email-masked]>
Date: Tue, 29 May 2018 18:20:27 +0000

> KRP: describes some form of hierarchical address allocation mechanism but there are no details provided about the "protocol" itself.  There isn't anything to review here because the draft has no workable content.

It is not actually a hierarchical address allocation, it is some kind of organizing the allocation mechanism, the way KRP uses can be applied to the recent allocation mechanism, 1st hex digit of the second group of an IPv6 address determines on which region you are located, the 2nd and 3rd groups of an IPv6 address determines the KRP ASN, no changes will be applied to the recent allocation way.

KRP describes the full routing mechanism from the source to the destination, other details I know should be added but the main idea is described on the KRP ID.

> hence the request for sergeant-at-arms to intervene again.

We can continue the discussion privately so we do not bother the list with many e-mails.

Khaled

-----Original Message-----
From: ietf [mailto:[email-masked]] On Behalf Of Nick Hilliard
Sent: Tuesday, May 29, 2018 12:41 PM
To: Randy Bush <[email-masked]>
Cc: [email-masked]; IETF Rinse Repeat <[email-masked]>
Subject: Re: Internet Drafts' Destiney.

> maybe do an actual review?

There's nothing to say that hasn't already been said by many other people, but let's rinse and repeat anyway:

IPv10: the proposals ignore all previous discussions about ipv4 to ipv6 compatibility schemas.  There's been a good deal of discussion about this over the years, and the general opinion is that direct ipv4-ipv6 compatibility shims are unworkable for a variety of reasons.  Brian Carpenter sent this helpful and constructive email in Nov 2016:

This still stands today.

KRP: describes some form of hierarchical address allocation mechanism but there are no details provided about the "protocol" itself.  There isn't anything to review here because the draft has no workable content.

The problem isn't a lack of reviews, it's that these ideas have been discussed repeatedly at the ietf over many years and the consensus is that they are unworkable.

Khaled has not gone to the effort of looking into why they were unworkable, nor has he developed his proposals to the point that they are actually testable in a lab environment (at which point it would become clear that they are unworkable in the real world).

Khaled apparently isn't interested in listening to this feedback.  The feedback and reviews are there.

We've had ~300 emails on ietf@, and nothing has progressed beyond what was stated in Nov 2016, at which stage Khaled was warned multiple times by the sergeant-at-arms of the time that his attempts to bring these topics up on the ietf@ mailing list were not ok:

.... hence the request for sergeant-at-arms to intervene again.

Nick

---

From: Bernardo Soares <[email-masked]>
Date: Tue, 29 May 2018 15:27:48 -0300

> It is not actually a hierarchical address allocation, it is some kind of
organizing the allocation mechanism, the way KRP uses can be applied to the
recent allocation mechanism, 1st hex digit of the second group of an IPv6
address determines on which region you are located, the 2nd and 3rd groups
of an IPv6 address determines the KRP ASN, no changes will be applied to
the recent allocation way.

why not bgp?

> KRP describes the full routing mechanism from the source to the
destination, other details I know should be added but the main idea is
described on the KRP ID.

in case of inter-as routing exchange, no KRP on one side. does it make
sense using two distinct EGPs?

On Tue, May 29, 2018 at 3:20 PM, Khaled Omar <[email-masked]>
wrote:

> but there are no details provided about the "protocol" itself.  There isn't
> anything to review here because the draft has no workable content.
>
> It is not actually a hierarchical address allocation, it is some kind of
> organizing the allocation mechanism, the way KRP uses can be applied to the
> recent allocation mechanism, 1st hex digit of the second group of an IPv6
> address determines on which region you are located, the 2nd and 3rd groups
> of an IPv6 address determines the KRP ASN, no changes will be applied to
> the recent allocation way.
>
> KRP describes the full routing mechanism from the source to the
> destination, other details I know should be added but the main idea is
> described on the KRP ID.
>
> compatibility schemas.  There's been a good deal of discussion about this
> over the years, and the general opinion is that direct ipv4-ipv6
> KRP: describes some form of hierarchical address allocation mechanism but
> there are no details provided about the "protocol" itself.  There isn't
> anything to review here because the draft has no workable content.
>
> discussed repeatedly at the ietf over many years and the consensus is that
> they are unworkable.
>
> unworkable, nor has he developed his proposals to the point that they are
> actually testable in a lab environment (at which point it would become
> clear that they are unworkable in the real world).
>
> was stated in Nov 2016, at which stage Khaled was warned multiple times by
> the sergeant-at-arms of the time that his attempts to bring these topics up
> on the ietf@ mailing list were not ok:
>

---

From: Khaled Omar <[email-masked]>
Date: Tue, 29 May 2018 18:47:52 +0000

> why not bgp?

As mentioned on the ID … short routing table, the use of the efforts already made by the IGP within each AS, use dedicated links for different traffic classes, and the use of the stored information within each IP in the routing process.

> in case of inter-as routing exchange, no KRP on one side. does it make sense using two distinct EGPs?

KRP works on both sides … it is a replacement to the bgp except using its AS path selection using the best path algorithm.

From: Bernardo Soares [mailto:[email-masked]]
Sent: Tuesday, May 29, 2018 8:28 PM
To: Khaled Omar <[email-masked]>
Cc: Nick Hilliard <[email-masked]>; Randy Bush <[email-masked]>; IETF Rinse Repeat <[email-masked]>
Subject: Re: Internet Drafts' Destiney.

why not bgp?

> KRP describes the full routing mechanism from the source to the destination, other details I know should be added but the main idea is described on the KRP ID.

in case of inter-as routing exchange, no KRP on one side. does it make sense using two distinct EGPs?

Khaled

-----Original Message-----
From: ietf [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Nick Hilliard
Sent: Tuesday, May 29, 2018 12:41 PM
To: Randy Bush <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; IETF Rinse Repeat <[email-masked]<mailto:[email-masked]>>
Subject: Re: Internet Drafts' Destiney.

This still stands today.

Nick

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 29 May 2018 13:54:49 -0500

As has been pointed out multiple times already, there are more
appropriate topic lists for discussion of specific routing protocols
than [email-masked].  Please use them.

-Ben