Subject: Agenda experiment for IETF 103 in November in Bangkok

From: IETF Chair <[email-masked]>
Date: Fri, 11 May 2018 09:07:46 -0400

The IESG will experiment with a new agenda structure at IETF 103. We will be running working group meetings Monday to Thursday, November 5-8, only. There will be no working group meetings on Friday, November 9. A variety of facilities will be available for ad hoc meetings on Friday, including some breakout rooms available until 13:30 and the Code Lounge until 15:00. Participants will be able to sign up to use ad hoc meeting space on Friday starting when we open up WG scheduling for IETF 103. 

The motivations for this experiment are twofold. First, with the growth of the IETF Hackathon, the IETF meeting week is getting very long for a larger number of people. This is affecting even people who do not attend the Hackathon, because other pre-meeting events are now being scheduled prior to the Hackathon. Second, we would like to provide more unstructured time for IETF participants. Given that 20-25% of working groups typically request not to be scheduled on Friday already, we will be experimenting with more unstructured time on Friday.

While running this experiment we will still be able to accommodate our usual number of working group scheduling requests, in part by offering a larger number of shorter slots. There will be no 2.5-hour slots in the meeting session request tool; 2 hours will be the longest slot available for sign-up. WG chairs who want a slot that is longer than 2 hours will be encouraged to check the ‘Other’ box in the list of slot lengths in the meeting request tool and explain in the text box that they would like a longer slot. We will be able to combine slots on some days and in some meeting rooms to provide longer slots for WGs that need them. (This is basically just a reversal of the current default, where WG chairs already can indicate that they are willing to split their slot with another WG). 

We will be collecting feedback about this experiment via the meeting survey. You will also be welcome to send feedback directly to [email-masked] <mailto:[email-masked]> or by speaking with IESG members at the meeting.

Alissa Cooper
on behalf of the IESG

---

From: Linda Dunbar <[email-masked]>
Date: Sun, 13 May 2018 13:20:07 +0000

IMHO, no meeting on Friday doesn’t really facilitate more unstructured discussion as most people will book flight leaving on Friday if no meeting is scheduled on Friday.
It is much more effective to facilitate more unstructured discussion if less sessions are scheduled per day, longer break time, etc. such as morning sessions start later, say 10am (giving people time to have morning informal discussions), longer lunch break or session break in afternoon.

Linda Dunbar

From: ietf [mailto:[email-masked]] On Behalf Of IETF Chair
Sent: Friday, May 11, 2018 8:08 AM
To: ietf <[email-masked]>
Subject: Agenda experiment for IETF 103 in November in Bangkok

We will be collecting feedback about this experiment via the meeting survey. You will also be welcome to send feedback directly to [email-masked]<mailto:[email-masked]> or by speaking with IESG members at the meeting.

Alissa Cooper
on behalf of the IESG

---

From: Paul Wouters <[email-masked]>
Date: Sun, 13 May 2018 10:17:24 -0400

> IMHO, no meeting on Friday doesn’t really facilitate more unstructured discussion as most people will book flight leaving on Friday if no meeting is scheduled on Friday.

Exactly what I was thinking,

Paul

---

From: John C Klensin <[email-masked]>
Date: Sun, 13 May 2018 11:25:39 -0400

--On Sunday, 13 May, 2018 13:20 +0000 Linda Dunbar
<[email-masked]> wrote:

> IMHO, no meeting on Friday doesn't really facilitate more
> unstructured discussion as most people will book flight
> leaving on Friday if no meeting is scheduled on Friday. It is
> much more effective to facilitate more unstructured discussion
> if less sessions are scheduled per day, longer break time,
> etc. such as morning sessions start later, say 10am (giving
> people time to have morning informal discussions), longer
> lunch break or session break in afternoon.

Linda,

I've always hated Friday sessions and believe that the decision
to expand into Friday, rather than saying "this is all we have
time for and we need to prioritize meeting schedules, approval
of WGs, and the threshold for shutting down WGs that are not
making progress accordingly".  Part of my reason is that people
who are anxious to get home before the weekend will leave
Thursday night or Friday anyway, resulting in a very different
profile of participants on Friday that earlier in the week.
Another part, probably more important, is the observation that,
for people who are really participating actively, four very long
and intense days (even without intense tutorials and
side-meetings on Sunday) are burned out.  I have vivid memories
of Friday IAB and IESG wrap-up sessions in which most people
could do little more than sit around and stare at each other.  

More opportunities for informal interactions are clearly part of
that story, but I don't believe that trying to push them into
Friday is the solution, especially if one sees the problem as
IESG inability to prioritize.

    john

---

From: Jared Mauch <[email-masked]>
Date: Sun, 13 May 2018 12:20:04 -0400

I appreciate trying to keep the agenda in check. When trying to balance family life and IETF activities plus natural airline schedules it’s often hard to stay on Fridays. Often when we are in Europe the last flights to the US are at times that don’t allow attendance unless one stays until Saturday. Removing this risk will make it more productive in the 4 days. 

Trying to make IEPG through Friday noon sessions often leaves no time to catch a flight or arrive just in time. 

I would be supportive of adjusting this based on common departure times in the region, such as Asia there are afternoon flights to reach common destinations. Europe there are not. If we try to balance this with 50% of the population that likely helps. 

Jared Mauch

> On May 13, 2018, at 9:20 AM, Linda Dunbar <[email-masked]> wrote:
> 
> We will be collecting feedback about this experiment via the meeting survey. You will also be welcome to send feedback directly to [email-masked] or by speaking with IESG members at the meeting.
>  
> Alissa Cooper
> on behalf of the IESG

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 14 May 2018 08:28:03 +1200

> Exactly what I was thinking,

I think we need to dig a bit deeper.

1) We'ved slowly moved from a meeting that started on Monday morning,
with a couple of tutorials for newcomers on Sunday afternoon, and an
early evening reception on Sunday for those whose flight arrived in time,
to a meeting that for many people starts on Saturday morning.

2) There's an apparent constant of nature, known as N(WG), that hovers
around 120, regardless of how many WGs are created and destroyed.

3) We have constant complaints that WGs hold too many presentation-based
pseudo-discussions and not enough actual discussions.

4) Partly because of 3), we have constant complaints that there isn't
enough informal discussion.

I'm not sure that dropping the Friday morning schedule will fix this.

But that doesn't mean the experiment is a bad thing. Just be prepared
for failure or unexpected consequences.

    Brian

---

From: Loa Andersson <[email-masked]>
Date: Mon, 14 May 2018 10:06:35 +0200

Folks,

Initially I was at least somewhat positive this experiment, but then I
saw the mails that were connecting this experiment with the mythological
need for IETF participants to leave the meeting site on Friday.

I think if there is a meeting on Friday that the company paying my trip
think I should attend on the Friday. I stay the Friday. If there is
"no meeting" on Friday (yes - you can call it informal) then I believe
that my sponsors would not like to pay an extra hotel night.

I guess this experiment is a no starter.

/Loa

On 2018-05-13 16:17, Paul Wouters wrote:
> On May 13, 2018, at 09:20, Linda Dunbar <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>> IMHO, no meeting on Friday doesn’t really facilitate more unstructured 
>> discussion as most people will book flight leaving on Friday if no 
>> meeting is scheduled on Friday.
>>
> 

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 14 May 2018 10:39:37 +0100

If we are going formally include a sightseeing day in the agenda, then 
mid-week would be my preference :)

I think this is a silly experiment. There may be a few who use it to 
meet informally, but given the reluctance of so many to stay to Friday 
even when there are formal meetings, I think the IETF on Friday is 
likely to become even more of a ghost town.

If you want to create  informal time, I suggest the IESG simply declare 
some mid-week open slots, where nothing is allowed to be scheduled. 
Ideally neither the first or the last slots in the day. That way people 
will be in the building but free to talk, just like they are for the 
Sunday reception, and for most lunch, refreshment breaks and dinner breaks.

- Stewart

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 14 May 2018 08:20:08 -0400

+100.

On Mon, May 14, 2018 at 5:39 AM, Stewart Bryant <[email-masked]>
wrote:

> I think this is a silly experiment. There may be a few who use it to meet
> informally, but given the reluctance of so many to stay to Friday even when
> there are formal meetings, I think the IETF on Friday is likely to become
> even more of a ghost town.
>
> some mid-week open slots, where nothing is allowed to be scheduled. Ideally
> neither the first or the last slots in the day. That way people will be in
> the building but free to talk, just like they are for the Sunday reception,
> and for most lunch, refreshment breaks and dinner breaks.
>
> - Stewart
>
>
>

---

From: John C Klensin <[email-masked]>
Date: Mon, 14 May 2018 13:53:36 -0400

Yes.  Another option would be to lengthen all or most of the
refreshment breaks.

Bottom line and a suggestion:

(1) Especially if the IESG has concluded that informal
conversations have become more important relative to the value
of WG sessions, BOFs, and two plenaries, it may be time for the
IESG, with the support of the community to become much more
aggressive about reviewing whether proposed WGs will actually
serve the Internet and whether established ones are doing so.
For a possible starting point, see the now-ancient
draft-huston-ietf-pact and possibly draft-klensin-overload for
discussions of related topics more than fifteen years ago.

(2) Historically, the main justification for thrice-yearly and
week-long IETF meetings has been to facilitate cross-area review
and broad perspectives on technical work.  While there are
clearly exceptions, most informal discussions, other than
unmonitored, un-minuted BoFs, are among those who already know
and/or work with each other, so they don't contribute much to
that diversity of technical perspectives.  Given improvements in
remote communications facilities, cut IETF meetings back to two
a year, concentrate on cross-area activities and even technical
plenaries that focus on the IETF's work, and require strong
justification for WGs who are making progress to take up f2f
meeting time.

I note that (2) would significantly change the cost models, both
for running the IETF and for attendees and would do so by
reducing costs rather than raising rates.

I don't imagine this suggestion will go any further than its
predecessors did, but it is worth thinking about such options as
worse ones, like this Friday plan, are explored.

   john

--On Monday, May 14, 2018 10:39 +0100 Stewart Bryant
<[email-masked]> wrote:

>...
> I think this is a silly experiment. There may be a few who use
> it to meet informally, but given the reluctance of so many to
> stay to Friday even when there are formal meetings, I think
> the IETF on Friday is likely to become even more of a ghost
> town.
> 
> If you want to create  informal time, I suggest the IESG
> simply declare some mid-week open slots, where nothing is
> allowed to be scheduled. Ideally neither the first or the last
> slots in the day. That way people will be in the building but
> free to talk, just like they are for the Sunday reception, and
> for most lunch, refreshment breaks and dinner breaks.

---

From: Adam Roach <[email-masked]>
Date: Mon, 14 May 2018 15:51:52 -0500

Replying to the thread in general rather than any one message: most of 
the responses so far have been focusing on perceived efficacy of 
informal meetings on Friday (which is good feedback, although I suspect 
it will be better informed after the experiment is run).

I have yet to see any comments on the fact that we have O(30) working 
groups ask not to be scheduled on Fridays every single meeting. One of 
my personal hopes for this experiment is that we learn whether we can 
avoid these requests (and the consequent scheduling complications, which 
are non-trivial) by simply removing the broadly unwanted Friday slots 
from consideration altogether.

I am curious if anyone has thoughts about how this particular scheduling 
difficulty can be addressed beyond what we might learn from the Bangkok 
experiment.

/a

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 15 May 2018 08:59:47 +1200

On 15/05/2018 08:51, Adam Roach wrote:
...
> groups ask not to be scheduled on Fridays every single meeting. 
...
> difficulty can be addressed beyond what we might learn from the Bangkok 

By simply ignoring those requests in the scheduling process.

I've found Friday morning meetings to be very useful. Firstly
there are fewer lookers-on and secondly they run efficiently
because nobody wants them to over-run.

(That applies up to about 11:30 a.m. Later than that, people really are
eager to get to the airport.)

   Brian

---

From: Adam Roach <[email-masked]>
Date: Mon, 14 May 2018 16:08:02 -0500

> By simply ignoring those requests in the scheduling process.

That might be an interesting experiment to run as well.

/a

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 14 May 2018 22:09:17 +0100

Hiya,

> it will be better informed after the experiment is run).

I'm happy to see the experiment tried. At the same time I agree with
those who are doubting that Friday is likely a productive time for
informal interactions. I suspect that should flight timing permit, I'd
be likely to take an earlier flight home than gamble on finding the
time on Friday productive. But we'll see I guess.

> difficulty can be addressed beyond what we might learn from the Bangkok

My suggestion for a next experiment would be to (optionally) cancel
all sessions Friday, or leave Friday alone, but to move the formal
session start times to 11am (or whenever) Monday to Wednesday, and
run the hackathon continuously Sun-Wed, with 0900-1100 only for
hackathon or informal work. In running such an experiment, I'd be
fine if the IESG decided however it wanted which wGs get what formal
session time for one meeting like that. (And then see how it went,
just like with all experiments.)

But again, thanks to the IESG for being willing to experiment with
meeting session planning. Please keep doing that.

Cheers,
S.

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 15 May 2018 10:09:00 -0500

On Mon, May 14, 2018 at 3:51 PM, Adam Roach <[email-masked]> wrote:

> Replying to the thread in general rather than any one message: most of the
> responses so far have been focusing on perceived efficacy of informal
> meetings on Friday (which is good feedback, although I suspect it will be
> better informed after the experiment is run).
>
> groups ask not to be scheduled on Fridays every single meeting. One of my
> personal hopes for this experiment is that we learn whether we can avoid
> these requests (and the consequent scheduling complications, which are
> non-trivial) by simply removing the broadly unwanted Friday slots from
> consideration altogether.
>
It seems like the experiment will go ahead :-)

My suggestion is:
either treat Friday as a regular work day and put complete scheduling on
that day. I don't think companies treat Fridays special, you work on Friday
like any other day, right?

or completely make it off. Now we are including Saturday in the meeting
days and starting to eat up from the other side to make up for it, isn't
that strange?

Regarding flight times, if the meeting is overseas, airline companies want
you to stay one week, usually from Saturday/Sunday to next Saturday. So in
Bangkok, I am going to have to stay on Friday in order to get a cheaper
flight.

Why not get back to the good old Sunday-Friday schedule?

Behcet

---

From: Ted Lemon <[email-masked]>
Date: Tue, 15 May 2018 12:24:21 -0400

The issue I see with this experiment is that I think that the predictions
that nobody will stay for Friday is accurate—this belief produces a
negative network effect that will mean that even people who would want to
show up because the proposed schedule for Friday would in theory be useful
won't show up, because they know that in practice there won't be a quorum
of people who stay through Friday.   And this means that a lot of
facilities will be paid for and not used.   So in that sense I think this
is a bad idea.   If we aren't going to have meetings on Friday, Friday
should just be a teardown day, and not a day when we hold meeting rooms
available.

If we want to have informal meetings as described in the proposal, the way
to do this is to announce that Friday will be a full day of meetings, just
like any other day, announce that we will schedule popular meetings on
Friday so that if you decide to leave Friday, you will miss those meetings,
and then schedule the informal time in the middle somewhere as others have
suggested.   It's always frustrating to me that meetings that I think are
fairly important get scheduled on Friday and then nobody shows up for them
because people already assumed that they could leave on Friday.   In that
sense this proposal is a win for me, because it means I will not have to
worry about that if I attend the Bangkok IETF.   But it seems like a waste
of resources to hold informal meeting times when it's vanishingly unlikely
that anyone at all will attend.

On Tue, May 15, 2018 at 11:09 AM, Behcet Sarikaya <[email-masked]>
wrote:

>> the responses so far have been focusing on perceived efficacy of informal

---

From: Wes Hardaker <[email-masked]>
Date: Tue, 15 May 2018 17:09:08 -0700

Adam Roach <[email-masked]> writes:

> avoid these requests (and the consequent scheduling complications,
> which are non-trivial) by simply removing the broadly unwanted Friday
> slots from consideration altogether.

Or the other option is to simply overbook ourselves from M-Th.  Which
would people prefer?

1) Give in to the longer and longer IETF sessions as we need to get
   there earlier and earlier.  [It's certainly hitting me personally.]

2) Having *and attending* meetings on Friday

3) Or cramming more sessions in during the rest of the week (e.g.,
   throwing out the social and Tuesday and the Meet-n-greet on Thursday)
   and having an additional slots then?

It's all weighted choices with no good answer, of course.  Don't shoot
the questioner please :-)
-- 
Wes Hardaker
USC/ISI

---

From: Michael Richardson <[email-masked]>
Date: Tue, 15 May 2018 21:43:00 -0400

> and having an additional slots then?

4) every WG gets 1 hr with conflicts sorted out.
   I read in the thread somewhere that we have some 260hours of meeting time
   available, and 120 WG.
   (I could go look it up, but 9hr * 8 slots * 4 days = 288)

   That leaves a second hour (where conflicts would mostly be ignored) for nearly
   every WG, and a few hours left over.  Many groups won't need a second
   hour, and some like 6man regularly take 4 hours.

I understand that 103 will eliminate 2.5 hour slots, and will have more 1hr
slots.  This is good, and I think that this will actually be where the more
interesting results of the experient are.

It would be nice if there was a survey asking people about WG conflicts for 101,
102 and 103. (We could go back further, but remembering 101 will be hard
enough)

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 16 May 2018 08:03:27 -0400

I could not agree more with Ted. I much prefer that either Friday be a
normal working day with sessions so we all plan on traveling home on Friday
night or Saturday, or we just end on Thursday. No in-between, because then
people will blow off Friday and leave anyway.

Cheers,
Andy

On Tue, May 15, 2018 at 12:24 PM, Ted Lemon <[email-masked]> wrote:

>> Regarding flight times, if the meeting is overseas, airline companies
>> want you to stay one week, usually from Saturday/Sunday to next Saturday.
>> So in Bangkok, I am going to have to stay on Friday in order to get a
>> cheaper flight.
>>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 16 May 2018 12:09:37 +0000

Hi,

If Friday is a non-working day, we may end up in a situation where people stop showing up at the late Thursday sessions, and/or request their WGs not to be scheduled on late Thursday…

Regards,

Christer

From: ietf [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: 16 May 2018 14:03
To: Ted Lemon <[email-masked]>
Cc: John C Klensin <[email-masked]>; Paul Wouters <[email-masked]>; ietf <[email-masked]>; IETF Chair <[email-masked]>
Subject: Re: Agenda experiment for IETF 103 in November in Bangkok

I could not agree more with Ted. I much prefer that either Friday be a normal working day with sessions so we all plan on traveling home on Friday night or Saturday, or we just end on Thursday. No in-between, because then people will blow off Friday and leave anyway.

Cheers,
Andy

On Tue, May 15, 2018 at 12:24 PM, Ted Lemon <[email-masked]<mailto:[email-masked]>> wrote:
The issue I see with this experiment is that I think that the predictions that nobody will stay for Friday is accurate—this belief produces a negative network effect that will mean that even people who would want to show up because the proposed schedule for Friday would in theory be useful won't show up, because they know that in practice there won't be a quorum of people who stay through Friday.   And this means that a lot of facilities will be paid for and not used.   So in that sense I think this is a bad idea.   If we aren't going to have meetings on Friday, Friday should just be a teardown day, and not a day when we hold meeting rooms available.

If we want to have informal meetings as described in the proposal, the way to do this is to announce that Friday will be a full day of meetings, just like any other day, announce that we will schedule popular meetings on Friday so that if you decide to leave Friday, you will miss those meetings, and then schedule the informal time in the middle somewhere as others have suggested.   It's always frustrating to me that meetings that I think are fairly important get scheduled on Friday and then nobody shows up for them because people already assumed that they could leave on Friday.   In that sense this proposal is a win for me, because it means I will not have to worry about that if I attend the Bangkok IETF.   But it seems like a waste of resources to hold informal meeting times when it's vanishingly unlikely that anyone at all will attend.

On Tue, May 15, 2018 at 11:09 AM, Behcet Sarikaya <[email-masked]<mailto:[email-masked]>> wrote:

On Mon, May 14, 2018 at 3:51 PM, Adam Roach <[email-masked]<mailto:[email-masked]>> wrote:
Replying to the thread in general rather than any one message: most of the responses so far have been focusing on perceived efficacy of informal meetings on Friday (which is good feedback, although I suspect it will be better informed after the experiment is run).

I have yet to see any comments on the fact that we have O(30) working groups ask not to be scheduled on Fridays every single meeting. One of my personal hopes for this experiment is that we learn whether we can avoid these requests (and the consequent scheduling complications, which are non-trivial) by simply removing the broadly unwanted Friday slots from consideration altogether.

I am curious if anyone has thoughts about how this particular scheduling difficulty can be addressed beyond what we might learn from the Bangkok experiment.

My suggestion is:
either treat Friday as a regular work day and put complete scheduling on that day. I don't think companies treat Fridays special, you work on Friday like any other day, right?

or completely make it off. Now we are including Saturday in the meeting days and starting to eat up from the other side to make up for it, isn't that strange?

Regarding flight times, if the meeting is overseas, airline companies want you to stay one week, usually from Saturday/Sunday to next Saturday. So in Bangkok, I am going to have to stay on Friday in order to get a cheaper flight.

Behcet
/a

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 16 May 2018 13:22:28 +0100

> 102 and 103. (We could go back further, but remembering 101 will be hard
Yes, because my experience is that the IESG are not getting this right. 
Sure some responsibility
belongs with the chairs, but I would expect the IESG to add to that 
input and modify the conflict sets
accordingly.

I would be good to have some hard evidence through a survey of what 
conflicts the attendees
think were a problem.

Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 16 May 2018 13:29:11 +0100

I am probably alone in thinking that the Hackathon is suplimentary to 
the main purpose of the meeting, and thus don't much care when they are 
held, but perhaps we could move them to the Friday/Saturday after the 
standards sessions so people fatigued for the WG sessions. Those slots 
could then double as a sort of forml-informal time for extended WG 
discussions.

- Stewart

On 15/05/2018 17:24, Ted Lemon wrote:
> The issue I see with this experiment is that I think that the 
> predictions that nobody will stay for Friday is accurate—this belief 
> produces a negative network effect that will mean that even people who 
> would want to show up because the proposed schedule for Friday would 
> in theory be useful won't show up, because they know that in practice 
> there won't be a quorum of people who stay through Friday.   And this 
> means that a lot of facilities will be paid for and not used.   So in 
> that sense I think this is a bad idea.   If we aren't going to have 
> meetings on Friday, Friday should just be a teardown day, and not a 
> day when we hold meeting rooms available.
>
> If we want to have informal meetings as described in the proposal, the 
> way to do this is to announce that Friday will be a full day of 
> meetings, just like any other day, announce that we will schedule 
> popular meetings on Friday so that if you decide to leave Friday, you 
> will miss those meetings, and then schedule the informal time in the 
> middle somewhere as others have suggested.   It's always frustrating 
> to me that meetings that I think are fairly important get scheduled on 
> Friday and then nobody shows up for them because people already 
> assumed that they could leave on Friday.   In that sense this proposal 
> is a win for me, because it means I will not have to worry about that 
> if I attend the Bangkok IETF. But it seems like a waste of resources 
> to hold informal meeting times when it's vanishingly unlikely that 
> anyone at all will attend.
>
> On Tue, May 15, 2018 at 11:09 AM, Behcet Sarikaya 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>
>
>         Replying to the thread in general rather than any one message:
>         most of the responses so far have been focusing on perceived
>         efficacy of informal meetings on Friday (which is good
>         feedback, although I suspect it will be better informed after
>         the experiment is run).
>
>         I have yet to see any comments on the fact that we have O(30)
>         working groups ask not to be scheduled on Fridays every single
>         meeting. One of my personal hopes for this experiment is that
>         we learn whether we can avoid these requests (and the
>         consequent scheduling complications, which are non-trivial) by
>         simply removing the broadly unwanted Friday slots from
>         I am curious if anyone has thoughts about how this particular
>         scheduling difficulty can be addressed beyond what we might
>         learn from the Bangkok experiment.
>
>
>     either treat Friday as a regular work day and put complete
>     scheduling on that day. I don't think companies treat Fridays
>     special, you work on Friday like any other day, right?
>
>
>
>     or completely make it off. Now we are including Saturday in the
>     meeting days and starting to eat up from the other side to make up
>     for it, isn't that strange?
>
>     Regarding flight times, if the meeting is overseas, airline
>     companies want you to stay one week, usually from Saturday/Sunday
>     to next Saturday. So in Bangkok, I am going to have to stay on
>     Friday in order to get a cheaper flight.
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 16 May 2018 08:50:46 -0400

Christer Holmberg <[email-masked]> wrote:
    > If Friday is a non-working day, we may end up in a situation where
    > people stop showing up at the late Thursday sessions, and/or request
    > their WGs not to be scheduled on late Thursday…

I disagree.  It's not a slippery slope.
Yes, there will be a few, there are some already who do that.

The number of people who can get home faster by leaving the conference space
at 3 or 4pm for a 5pm-ish flight home is small.  Yes, that's when my
preferred flight home to Canada is from Seoul or Tokyo is, but I could have
taken a later flight with a US routing.  That's the only kind of location where
I think it would matter.  There are either no flights, or there are
additional flights later in the evening.

I think that this is even smaller still now that we are seldom in the US.
Maybe some Europeans and Asians can comment on feasbility of returning early evening
Thursday vs late Thursday, or having to stay to Friday anyway.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 16 May 2018 14:59:42 -0400

Thanks all for the feedback thus far. I have a few personal observations to share (not sure if the rest of the IESG would agree with these or not).

It is indeed difficult to experiment with both the shortened week and more unstructured time at once without changing up the agenda too drastically. Personally I had been in favor of experimenting with just ending the meeting on Thursday evening, but the feeling in the IESG was that there would be certain groups of people who might take advantage of the ability to schedule ad hoc meetings on the Friday. This is easy enough to experiment with, so it will be interesting to see what happens (and also interesting to see if there is a slippery slope that extends into Thursday as Christer described). We also discussed future experiments with unstructured time mid-week and we’re working on agenda proposals of that sort, so I hope this can be viewed as the beginning of the experimentation, not the end.

There are a few different vectors for enforcing “agenda discipline,” so to speak. This proposal focuses on the length of WG sessions and will involve some days running longer than they have in the past (to the point about “cramming” more sessions in). But certainly focusing on the number of WG sessions is also possible independently or together with reduction in session lengths. This has come up before and could be fodder for future experiments.

Regarding the hackathon timing, one trend we’ve observed is that we have people who live near enough to the meeting site that they are able to join the hackathon precisely because it is on the weekend and does not interfere with work or school time. These folks tend to be new(er) to the IETF (and the hackathon) so this provides them with some valuable exposure and cross-pollination with the IETF crowd without requiring extensive travel and time away from day job. This isn’t a reason to never move it to different days but was one reason to keep it where it is while we experiment with other changes. 

Understanding how attendees feel about conflicts would indeed be useful, altough I suspect generic feedback (“I keep having to miss 5 WGs where I’m a contributor due to conflicts”) would be more helpful than specific feedback about particular WG clashes at a particular meeting, since there will always be some conflicts for some people as long as we have multiple WG meetings scheduled at once in the agenda. We can think about how to incorporate a question in the post-meeting survey.

Thanks,
Alissa

> On May 11, 2018, at 9:07 AM, IETF Chair <[email-masked]> wrote:
>

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 16 May 2018 15:04:25 -0400

I don't see the same problem with things sliding into Thursday because I
expect to be in a meeting at 6pm on the Thursday or 8pm if there isn't the
social that evening.

It is quite important to continue the official meeting through Friday
however because if I am going to have discussions, I want them to be under
Note Well.

On Wed, May 16, 2018 at 2:59 PM, Alissa Cooper <[email-masked]> wrote:

> Thanks all for the feedback thus far. I have a few personal observations
> to share (not sure if the rest of the IESG would agree with these or not).
>
> It is indeed difficult to experiment with both the shortened week and more
> unstructured time at once without changing up the agenda too drastically.
> Personally I had been in favor of experimenting with just ending the
> meeting on Thursday evening, but the feeling in the IESG was that there
> would be certain groups of people who might take advantage of the ability
> to schedule ad hoc meetings on the Friday. This is easy enough to
> experiment with, so it will be interesting to see what happens (and also
> interesting to see if there is a slippery slope that extends into Thursday
> as Christer described). We also discussed future experiments with
> unstructured time mid-week and we’re working on agenda proposals of that
> sort, so I hope this can be viewed as the beginning of the experimentation,
> not the end.
>
> There are a few different vectors for enforcing “agenda discipline,” so to
> speak. This proposal focuses on the length of WG sessions and will involve
> some days running longer than they have in the past (to the point about
> “cramming” more sessions in). But certainly focusing on the number of WG
> sessions is also possible independently or together with reduction in
> session lengths. This has come up before and could be fodder for future
> experiments.
>
> Regarding the hackathon timing, one trend we’ve observed is that we have
> people who live near enough to the meeting site that they are able to join
> the hackathon precisely because it is on the weekend and does not interfere
> with work or school time. These folks tend to be new(er) to the IETF (and
> the hackathon) so this provides them with some valuable exposure and
> cross-pollination with the IETF crowd without requiring extensive travel
> and time away from day job. This isn’t a reason to never move it to
> different days but was one reason to keep it where it is while we
> experiment with other changes.
>
> Understanding how attendees feel about conflicts would indeed be useful,
> altough I suspect generic feedback (“I keep having to miss 5 WGs where I’m
> a contributor due to conflicts”) would be more helpful than specific
> feedback about particular WG clashes at a particular meeting, since there
> will always be some conflicts for some people as long as we have multiple
> WG meetings scheduled at once in the agenda. We can think about how to
> incorporate a question in the post-meeting survey.
>
> Thanks,
> Alissa
>
>
> The IESG will experiment with a new agenda structure at IETF 103. We will
> be running working group meetings Monday to Thursday, November 5-8, only.
> There will be no working group meetings on Friday, November 9. A variety of
> facilities will be available for ad hoc meetings on Friday, including some
> breakout rooms available until 13:30 and the Code Lounge until 15:00.
> Participants will be able to sign up to use ad hoc meeting space on Friday
> starting when we open up WG scheduling for IETF 103.
>
> The motivations for this experiment are twofold. First, with the growth of
> the IETF Hackathon, the IETF meeting week is getting very long for a larger
> number of people. This is affecting even people who do not attend the
> Hackathon, because other pre-meeting events are now being scheduled prior
> to the Hackathon. Second, we would like to provide more unstructured time
> for IETF participants. Given that 20-25% of working groups typically
> request not to be scheduled on Friday already, we will be experimenting
> with more unstructured time on Friday.
>
> While running this experiment we will still be able to accommodate our
> usual number of working group scheduling requests, in part by offering a
> larger number of shorter slots. There will be no 2.5-hour slots in the
> meeting session request tool; 2 hours will be the longest slot available
> for sign-up. WG chairs who want a slot that is longer than 2 hours will be
> encouraged to check the ‘Other’ box in the list of slot lengths in the
> meeting request tool and explain in the text box that they would like a
> longer slot. We will be able to combine slots on some days and in some
> meeting rooms to provide longer slots for WGs that need them. (This is
> basically just a reversal of the current default, where WG chairs already
> can indicate that they are willing to split their slot with another WG).
>
> We will be collecting feedback about this experiment via the meeting
> survey. You will also be welcome to send feedback directly to
> [email-masked] or by speaking with IESG members at the meeting.
>
> Alissa Cooper
> on behalf of the IESG
>
>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 17 May 2018 09:01:15 +1200

On 17/05/2018 00:29, Stewart Bryant wrote:

> the main purpose of the meeting, 

True, but very valuable if we're serious about "running code".

> and thus don't much care when they are

I do. If the hackathon is held before the relevant WG session, the
WG can get hot feedback on whether the latest spec is actually
implementable and whether any interop problems point to ambiguous
text. Also, minor fixes can be made and tested in odd moments
later in the week.

> could then double as a sort of forml-informal time for extended WG 

Why do we assume informal sessions are more valuable at the end of
the week? I've often found it annoying to have a Monday WG session,
because of the need for informal discussions *before* the meeting
itself.

On 17/05/2018 07:04, Phillip Hallam-Baker wrote:
...> It is quite important to continue the official meeting through Friday
> however because if I am going to have discussions, I want them to be under

I would like legal advice about that. What do we have to do to
be sure whether an informal, unscheduled meeting is part of the
IETF meeting or not?

I'm fairly sure that if I bump into Phill in the departure lounge
at Bangkok airport, it's not the IETF. But if I meet with him and
a few other participants in the venue at 11 a.m. on the Friday?

https://tools.ietf.org/html/rfc8179#section-1 doesn't really
seem to answer this:
"Statements made outside of an IETF session, mailing list, or other
 function, or that are clearly not intended to be input to an IETF
 activity, group, or function, are not Contributions in the context
 of this document."
Is an informal, unscheduled discussion on Friday morning "an IETF
activity, group, or function"?

    Brian

---

From: Ted Lemon <[email-masked]>
Date: Wed, 16 May 2018 17:07:09 -0400

It seems clear to me that if you don't meet in a meeting that is officially
part of the IETF, then you aren't under the note well.   So if you meet
Phillip in the airport, no Note Well.   On the other hand, informal
sessions on Friday can be covered by the Note Well if they are announced as
such, to as great an extent as any other meeting can.   IANAL, of course,
but this seems straightforward.

I've found Hackathons to be valuable, and the fact that they precede the
IETF is very good.   I agree with you that earlier "informal" discussions
are more important than later ones.   Having those covered under the note
well when desired would also be good—I don't think that a conversation in
the hallway is covered under the note well.   Like you I would be curious
to know if the IETF lawyer has an opinion on this.

On Wed, May 16, 2018 at 5:01 PM, Brian E Carpenter <
[email-masked]> wrote:

> ....> It is quite important to continue the official meeting through Friday

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 16 May 2018 17:20:18 -0400

As always, anyone that wants to have a meeting not covered by the Note Well
can use a private meeting room or other space (such as a restaurant) not
being provided by the IETF. IMHO, any meeting or discussion in a space
being provided by the IETF, such as the IETF lounge or a session room, is
covered by the Note Well.

Cheers,
Andy

On Wed, May 16, 2018 at 5:07 PM, Ted Lemon <[email-masked]> wrote:

> It seems clear to me that if you don't meet in a meeting that is
> officially part of the IETF, then you aren't under the note well.   So if
> you meet Phillip in the airport, no Note Well.   On the other hand,
> informal sessions on Friday can be covered by the Note Well if they are
> announced as such, to as great an extent as any other meeting can.   IANAL,
> of course, but this seems straightforward.
>
>> .....> It is quite important to continue the official meeting through
>> Friday

---

From: János Farkas <[email-masked]>
Date: Thu, 31 May 2018 16:59:09 +0200

Hi,

I'm afraid IETF 103 may not be the best IETF meeting to experiment with 
ending the IETF meeting on Thursday.

November 2018 is one of the very rare occasions when the IETF and the 
IEEE 802 Plenary meetings are back-to-back in the same hotel. The 
previous occasion was March 2013, the one before was before 2007 afak. 
The two meetings are typically in the same month but often on different 
continents.

Given the unique opportunity of this November, we have started to 
investigate the possibility of joint workshops of different groups of 
the two organizations. I'm aware of two: IETF - IEEE 802 Coordination 
workshop and DetNet - TSN/IEC workshop, but there may be more.

IEEE 802 Plenary meetings start on Monday 
(http://802world.org/plenary/schedule/).

Increasing the gap between the two meetings may decrease the 
participation thus the success of such workshops

Best regards,
János

>
>
> *From:*ietf [mailto:[email-masked]] *On Behalf Of *IETF Chair
> *Sent:* Friday, May 11, 2018 8:08 AM
> *To:* ietf <[email-masked]>
> *Subject:* Agenda experiment for IETF 103 in November in Bangkok
>
> The IESG will experiment with a new agenda structure at IETF 103. We 
> will be running working group meetings Monday to Thursday, November 
> 5-8, only. There will be no working group meetings on Friday, November 
> 9. A variety of facilities will be available for ad hoc meetings on 
> Friday, including some breakout rooms available until 13:30 and the 
> Code Lounge until 15:00. Participants will be able to sign up to use 
> ad hoc meeting space on Friday starting when we open up WG scheduling 
> for IETF 103.
>
> The motivations for this experiment are twofold. First, with the 
> growth of the IETF Hackathon, the IETF meeting week is getting very 
> long for a larger number of people. This is affecting even people who 
> do not attend the Hackathon, because other pre-meeting events are now 
> being scheduled prior to the Hackathon. Second, we would like to 
> provide more unstructured time for IETF participants. Given that 
> 20-25% of working groups typically request not to be scheduled on 
> Friday already, we will be experimenting with more unstructured time 
> on Friday.
>
> usual number of working group scheduling requests, in part by offering 
> a larger number of shorter slots. There will be no 2.5-hour slots in 
> the meeting session request tool; 2 hours will be the longest slot 
> available for sign-up. WG chairs who want a slot that is longer than 2 
> hours will be encouraged to check the ‘Other’ box in the list of slot 
> lengths in the meeting request tool and explain in the text box that 
> they would like a longer slot. We will be able to combine slots on 
> some days and in some meeting rooms to provide longer slots for WGs 
> that need them. (This is basically just a reversal of the current 
> default, where WG chairs already can indicate that they are willing to 
> split their slot with another WG).
>
> [email-masked] <mailto:[email-masked]> or by speaking with IESG members 
> at the meeting.
>
> Alissa Cooper
>
> on behalf of the IESG
>

---

From: Michael Richardson <[email-masked]>
Date: Thu, 31 May 2018 11:56:14 -0400

> ending the IETF meeting on Thursday.

Interesting.

    > Given the unique opportunity of this November, we have started to investigate
    > the possibility of joint workshops of different groups of the two
    > organizations. I'm aware of two: IETF - IEEE 802 Coordination workshop and
    > DetNet - TSN/IEC workshop, but there may be more.

Maybe some of these things could occur on the Friday?

    > Increasing the gap between the two meetings may decrease the participation
    > thus the success of such workshops

So the gap will grow from two days to three days.

I'm not among those who is involved in IEEE802 meetings, but if I were, I
don't think the change would negatively affect my decision to stay: it's not
like I get home a day earlier either way.

(If I were among those who had the time and funding to do both meetings, I
would find the back to back meetings would be a significant dis-incentive to
attend both. I don't think it contributes to cross-fertilization, and I think
that it creates significant family-based barriers to entry)

Having the three day gap might even make the gap easier to enjoy, if one
did bring a family with you.

To me, the only thing that would change this is if we moved the Hackathon to
the weekend afterwards, such that the gap was entirely filled. That would
also potentially mix hackathoners with IETF and IEEE people.