Subject: Yangdoctors early review of draft-ietf-i2rs-yang-l2-network-topology-04

From: Ladislav Lhotka <[email-masked]>
Date: Wed, 02 May 2018 06:32:28 -0700

Reviewer: Ladislav Lhotka
Review result: Ready

This draft and YANG modules contained therein fit into the framework of I2RS
network topology models. I have no substantial comments, from the YANG point of
view this document is ready to be published.

Comments and questions:

1. What is the purpose of the 'flag-type' type and 'flag-identity' identity?
There are no identities derived from the latter.

2. Some descriptions overuse capitalization. For example, instead of 'VLAN
Name' I would suggest 'VLAN name'.

3. An example of an instance document in an appendix would be very helpful.

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Fri, 4 May 2018 02:08:37 +0000

Hi Lada, 

Thanks a lot for your review comments. Please see some replies inline:

> -----Original Message-----
> From: Ladislav Lhotka [mailto:[email-masked]]
> Sent: Wednesday, May 02, 2018 9:32 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked];
> [email-masked]
> Subject: Yangdoctors early review of draft-ietf-i2rs-yang-l2-network-topology-04
> 
> network topology models. I have no substantial comments, from the YANG point
> of view this document is ready to be published.
> 
> Comments and questions:
> 

The "flag-type" type is used in the grouping "l2-network-attributes", "l2-node-attributes" and "l2-link-attributes".

While there is no identities derived from the "flag-identity", it is used in the typedef flag-type. Is this OK?

> 2. Some descriptions overuse capitalization. For example, instead of 'VLAN Name'
> I would suggest 'VLAN name'.

Thanks for catching this. Will fix in next revision.

> 3. An example of an instance document in an appendix would be very helpful.

Thanks for your suggestion. We will add an example to the appendix.

Best regards,
Jie

---

From: Ladislav Lhotka <[email-masked]>
Date: Fri, 04 May 2018 10:04:48 +0200

On Fri, 2018-05-04 at 02:08 +0000, Dongjie (Jimmy) wrote:
> The "flag-type" type is used in the grouping "l2-network-attributes", "l2-
> node-attributes" and "l2-link-attributes".
> 

>From the YANG point of view it is certainly OK. Do you expect other modules to
define identities derived from "flag-identity"?

> Thanks for your suggestion. We will add an example to the appendix.

Thanks, Lada

-- 
Ladislav Lhotka
Head, CZ.NIC Labs
PGP Key ID: 0xB8F92B08A9F76C67