Subject: Visas for IETF 103 in Thailand

From: IETF Administrative Director <[email-masked]>
Date: Tue, 14 Aug 2018 10:32:25 -0700

The IETF is going to Thailand for the first time this November, and we've received a number of requests to provide guidance on visa requirements for IETF attendees. 

A representative of the Thailand Convention and Exhibitions Bureau (TCEB) informed us that if an attendee does not require a tourist visa to come to Thailand, that attendee does not require a visa to attend a conference. 

However we are also aware that there is information online that indicates that a visa is required to attend a conference, regardless of tourist visa requirements. 

In short: the information available is difficult to parse, and is confusing.  

We also know that many companies and organizations have their own internal requirements and processes; sometimes these processes may seem at odds with published or anecdotal information. 

As always, please take the initiative to determine if you require a visa to attend a particular IETF Meeting. Many attendees need visas to attend IETF meetings and the requirements change from time to time. Because of this, we strongly urge all attendees to review the visa requirements for traveling to each IETF meeting location and determine for themselves, or in collaboration with their employer, if a visa is required. 

If you require a letter of invitation to obtain a visa, you can obtain one directly after registering for the meeting. You can register for IETF 103 here: https://www.ietf.org/registration/ietf103/ietfreg.py.

In addition, if you've attended an IETF meeting in the past, you are able to obtain a letter of invitation prior to registering for the meeting at https://www.ietf.org/registration/letterofinvite/singleletter.py.

Regards,

Portia Wenze-Danley
Interim IETF Administrative Director
on behalf the IAOC

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 14 Aug 2018 15:36:37 -0400

Portia,

This page
https://www.businesseventsthailand.com/plan-your-events/general-travel-information/visa-requirements/
seems pretty clear.

Cheers,
Andy

On Tue, Aug 14, 2018 at 1:32 PM, IETF Administrative Director <[email-masked]>
wrote:

> The IETF is going to Thailand for the first time this November, and we've
> received a number of requests to provide guidance on visa requirements for
> IETF attendees.
>
> A representative of the Thailand Convention and Exhibitions Bureau (TCEB)
> informed us that if an attendee does not require a tourist visa to come to
> Thailand, that attendee does not require a visa to attend a conference.
>
> However we are also aware that there is information online that indicates
> that a visa is required to attend a conference, regardless of tourist visa
> requirements.
>
> We also know that many companies and organizations have their own internal
> requirements and processes; sometimes these processes may seem at odds with
> published or anecdotal information.
>
> As always, please take the initiative to determine if you require a visa
> to attend a particular IETF Meeting. Many attendees need visas to attend
> IETF meetings and the requirements change from time to time. Because of
> this, we strongly urge all attendees to review the visa requirements for
> traveling to each IETF meeting location and determine for themselves, or in
> collaboration with their employer, if a visa is required.
>
> If you require a letter of invitation to obtain a visa, you can obtain one
> directly after registering for the meeting. You can register for IETF 103
> here: https://www.ietf.org/registration/ietf103/ietfreg.py.
>
> In addition, if you've attended an IETF meeting in the past, you are able
> to obtain a letter of invitation prior to registering for the meeting at
> https://www.ietf.org/registration/letterofinvite/singleletter.py.
>
> Regards,
>
> Portia Wenze-Danley

---

From: Andrew Sullivan <[email-masked]>
Date: Tue, 14 Aug 2018 15:47:22 -0400

Hi,

(speaking for myself)

On Tue, Aug 14, 2018 at 03:36:37PM -0400, Andrew G. Malis wrote:
> Portia,
> 
> This page https://www.businesseventsthailand.com/plan-your-events/
> general-travel-information/visa-requirements/ seems pretty clear.

Yes.  Lots of pages of various kinds seem quite clear, and some
contradict others.  Moreover, they are often written from the POV of
someone with one or another nationality.

This problem is true even for places we go regularly.  For instance,
our Czech colleagues had a series of bizarre (and in my opinion
unjustifiable) visa interactions with the Government of Canada some
years ago, even though that country (my home) is reputed to have
relatively friendly immigration practices compared to other North
American countries.  I've no idea whether that got any better, but I
think there is reason to suppose it might get worse for others.

As near as I can tell, there is nothing we collectively can do about
this: we each need to be aware of the immigration realities affecting
us.  The IAD and Secretariat and all of IASA can do as much as it
likes to try to get information it knows, but IASA cannot and should
not offer legal advice to any of us.  We all must evaluate our
respective situations and make the determination best in each case.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Portia Wenze-Danley <[email-masked]>
Date: Tue, 14 Aug 2018 16:45:20 -0400

Thank you for your input Andy and your guidance Andrew.

In keeping with IASA’s best practices, we continue to encourage individuals to seek what is best for their own individual cases and to plan accordingly.

Thanks again and my regards to you both.
________________________________
Portia Wenze-Danley
IETF Administrative Director (IAD)	
Internet Engineering Task Force (IETF)
[email-masked]

> On Aug 14, 2018, at 3:47 PM, Andrew Sullivan <[email-masked]> wrote:
> 
> Hi,
> 
> (speaking for myself)
>

---

From: "John Levine" <[email-masked]>
Date: 14 Aug 2018 17:10:36 -0400

>https://www.businesseventsthailand.com/plan-your-events/general-travel-information/visa-requirements/

That's the Thailand Convention and Exhibitions Bureau, same
organization whose US rep told us the same thing.

It's a Thai government agency so they are likely as well informed as
anyone, but as Andrew pointed out, what the rules say or appear to say
and how they're interpreted don't always agree.

R's,
John

---

From: Ted Lemon <[email-masked]>
Date: Tue, 14 Aug 2018 17:19:16 -0400

IANAL, so take this as anecdata, not advice, but what seems to create
sticking points for people who have visa waiver programs is that if you are
going to the country to *work*, you need a work visa, and a visa waiver
visa won't do it.   So the question is, when you go to IETF, are you going
to IETF to work for the IETF?   I always answer this question "no," because
I am working for whatever company I'm working for back home, not for the
IETF.   If you answer "yes," you will probably have an unpleasant
conversation, which will get more and more unpleasant until the person you
are talking to either convinces you that you should be saying "not here for
work" or becomes convinced (I believe incorrectly) that you *are* here for
work, at which point you will probably be denied entry.

Of course every country is different, but whenever I hear people describe
bad experiences they have had at passport control, the conversation seems
to have gone something like what I described.   I once had trouble getting
into Canada because I had a MIDI keyboard in the back of my car, and the
border agent thought I was coming in to play a gig.   I finally managed to
talk them out of this belief, but that definitely would have got me refused
entry.

On Tue, Aug 14, 2018 at 5:10 PM, John Levine <[email-masked]> wrote:

> In article <CAA=duU0ijWy8hxRdDE0arC1MhBZwSt=YQ
> [email-masked]> you write:
> >This page

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Aug 2018 10:03:51 +0200

> respective situations and make the determination best in each case.

Hi Andrew,

while this probably faithfully mirrors what a lawyer would tell you, it is also terribly inefficient.

The organization behind the IETF can very well collect information about the situation for, say, citizens of the 10 leading regions that will originate participants.  I would expect my meeting fee dollars to already have paid for that, because the venue selection committee must already have looked at that.  So why withhold that information?

Yes, it would need to be qualified as “not legal advice”, “subject to change”, “void where prohibited”, etc.
It would help if it contains pointers to authoritative information I can look up myself.
And, ultimately, it is my decision (or that of my organization) how to handle this information, but the IETF could do most of the legwork here.  Regularly, as a routine component of venue selection and preparing for a meeting.

Grüße, Carsten

---

From: Saleem Bhatti <[email-masked]>
Date: Wed, 15 Aug 2018 09:01:31 +0000

For those with a British passport, visa information (as well as other travel advice) from the UK government is here:

  https://www.gov.uk/foreign-travel-advice/thailand/entry-requirements

Worth reading all the information, but from the page above, I have the following:

----

British passport holders arriving by air or land can enter Thailand for 30 days without a visa - this is known as a visa exemption.

----

I visited Bangkok last year (just after IETF100/Singapore) and had no problems.

Cheers,
--/Saleem

On 14 Aug 2018, at 18:32, IETF Administrative Director <[email-masked]<mailto:[email-masked]>> wrote:

Regards,

Portia Wenze-Danley

--
103all mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/103all

---

From: Jared Mauch <[email-masked]>
Date: Wed, 15 Aug 2018 08:25:39 -0400

When we went to Argentina things did change if you held a US passport. I had already paid my fee and then in the days up to the meeting things changed. 

Talk to your travel agent or use a visa service if necessary. Your unique situation may be different than me or someone else. International travel carries risks and you should know what those are before you leave home. 

I have been advised by CBSA agents that speaking at a conference in Canada would/should require a visa for example. Does this count as presenting at a WG meeting? IANAL, but you need to adjust your behaviors according to the laws of where you are. 

Importantly: you can always participate remotely. The tools are quite good

Jared Mauch

> On Aug 15, 2018, at 4:03 AM, Carsten Bormann <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Aug 2018 15:36:42 +0200

> When we went to Argentina things did change if you held a US passport. I had already paid my fee and then in the days up to the meeting things changed. 

Indeed, that happens.  
If the secretariat keeps an eye on these things, people can be alerted in time about changes, more reliably.

> Talk to your travel agent or use a visa service if necessary.

Well, I don’t know whether that’s necessary.  
Finding out takes time that I’d rather use for advancing specifications.
(What exactly was a travel agent?  And why on earth do you believe they would know?)

> Your unique situation may be different than me or someone else. International travel carries risks and you should know what those are before you leave home. 

Yes, I made myself aware of the murder rate before I went to Chicago IETF.

Here, we are talking about visa procedures, which are a bit more arcane.
I just want to make sure that the legwork that already is being done is not wasted due to misplaced “no legal advice” thinking.

> I have been advised by CBSA agents that speaking at a conference in Canada would/should require a visa for example. Does this count as presenting at a WG meeting? IANAL, but you need to adjust your…

Right.  And there are well-known strategies for working around the red tape that we maybe don’t want to discuss in the open.

But what *can* be communicated, *should* be.  Even if there are lawyers advising us to be inefficient.

> Importantly: you can always participate remotely. The tools are quite good

True, but we still do want to enable participating in person.

Grüße, Carsten

---

From: Jared Mauch <[email-masked]>
Date: Wed, 15 Aug 2018 09:50:59 -0400

> On Aug 15, 2018, at 9:36 AM, Carsten Bormann <[email-masked]> wrote:
> 

I think the problem here is that your situation is unique.  You use umlauts so I can make some assumptions, but I don’t know if you’re German, Swiss or just an American with an umlaut fetish :-).  We have about a thousand unique people.  Some may fall into different classes because they may have been arrested, have a DUI or some other life situation that may make border crossing a problem.  General advise like what is on the US Embassy site https://th.usembassy.gov/u-s-citizen-services/thai-visas-americans/ indicates what is normal.  (I also feel it’s fairly clear, but there’s this thread and an internal thread at my employer list about this, so I’m seeing these differing opinions).

This is why you must seek your own advice and people say things like “Generally”, etc.

> Right.  And there are well-known strategies for working around the red tape that we maybe don’t want to discuss in the open.

I was informed of the process at my NEXUS interview, but it’s also my responsibility to stay up to date with the latest regulations regarding my travel.  Arriving in Montreal I did not speak to a single person from leaving the plane until I was past all immigration.

> But what *can* be communicated, *should* be.  Even if there are lawyers advising us to be inefficient.

Call the local embassy/consulate or visit their websites, this is the best guidance one can provide.

> True, but we still do want to enable participating in person.

I agree, which is why this thread is ongoing.  We want people to participate in-person as there’s value to those personal interactions and relationships that doesn’t always translate well despite how good the technology is.

Either way, tourism (which is what some people will do while) accounts for almost 20% of GDP, I don’t suspect the bar for entry will be high.  It’s much higher for Canada (for example) where many of us just were.

- jared

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 15 Aug 2018 08:53:24 -0500

On Wed, Aug 15, 2018 at 4:01 AM, Saleem Bhatti <[email-masked]>
wrote:

>
>
> For those with a British passport, visa information (as well as other
> travel advice) from the UK government is here:
>
> British passport holders arriving by air or land can enter Thailand for 30
> days without a visa - this is known as a visa exemption.
>
> ----
>
>

> I visited Bangkok last year (just after IETF100/Singapore) and had no
+1
with a US passport.

Behcet

> Cheers,
> --/Saleem
>
>
> On 14 Aug 2018, at 18:32, IETF Administrative Director <[email-masked]>
> wrote:
>
> In short: the information available is difficult to parse, and is
> confusing..
>
> [email-masked]

---

From: Ole Jacobsen <[email-masked]>
Date: Wed, 15 Aug 2018 07:18:16 -0700 (PDT)

Above all, what you actually *say* at the border can determine what 
happens next. A friend was denied entry to Canada on Saturday because 
he told the immigration people he was unemployed (or perhaps "between 
jobs"). No SIGGRAPH 2018 for him.

Ole

Ole J. Jacobsen
Editor and Publisher
The Internet Protocol Journal
Office: +1 415-550-9433
Cell:   +1 415-370-4628
UK EE:  +44 7805 977889
Docomo: +81 090 3337-9311
E-mail: [email-masked]
Skype:  organdemo

On Wed, 15 Aug 2018, Jared Mauch wrote:

> When we went to Argentina things did change if you held a US 
> passport. I had already paid my fee and then in the days up to the 
> meeting things changed.
> 
> Talk to your travel agent or use a visa service if necessary. Your 
> unique situation may be different than me or someone else. 
> International travel carries risks and you should know what those 
> are before you leave home.
> 
> I have been advised by CBSA agents that speaking at a conference in 
> Canada would/should require a visa for example. Does this count as 
> presenting at a WG meeting? IANAL, but you need to adjust your 
> behaviors according to the laws of where you are.
> 
> > Yes, it would need to be qualified as “not legal advice”, “subject 
> > to change”, “void where prohibited”, etc. It would help if it 
> > contains pointers to authoritative information I can look up 
> > myself.
> 
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 Aug 2018 10:46:52 -0400

Ted Lemon <[email-masked]> wrote:
    > sticking points for people who have visa waiver programs is that if you
    > are going to the country to work, you need a work visa, and a visa
    > waiver visa won't do it. So the question is, when you go to IETF, are
    > you going to IETF to work for the IETF? I always answer this question
    > "no," because I am working for whatever company I'm working for back
    > home, not for the IETF.

Exactly.

It would be nice if the IETF had a letter (that we could print) from a
government agency (immigration is best) in the host country, in two languages
(the local language and english), explaining exactly this.  It can be totally
generic. (The invitations that we create for VISA applications are not generic)

Given that english is the likely language used at the border, and is likely
the second language of both people for whom this is a problem, I'm hardly
surprised that this happens.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Fred Baker <[email-masked]>
Date: Wed, 15 Aug 2018 09:14:49 -0700

For myself, the information seems pretty readily obtained. I asked my favorite search engine “do I need a visa to go to Thailand”, and up popped https://th.usembassy.gov/u-s-citizen-services/thai-visas-americans/. You might make a similar inquiry.

Sent using a machine that autocorrects in interesting ways...

> On Aug 15, 2018, at 1:03 AM, Carsten Bormann <[email-masked]> wrote:
>

---

From: Mary B <[email-masked]>
Date: Wed, 15 Aug 2018 11:26:02 -0500

So, Fred, are you going to tell immigration you're there as a tourist or to
work?   That's the whole crux of it.  There is the referenced website in
this thread about conferences, expos, etc. that suggests you don't need a
VISA for those, but that's not an official website.

On Wed, Aug 15, 2018 at 11:14 AM, Fred Baker <[email-masked]>
wrote:

> For myself, the information seems pretty readily obtained. I asked my
> favorite search engine “do I need a visa to go to Thailand”, and up popped
> https://th.usembassy.gov/u-s-citizen-services/thai-visas-americans/. You
> might make a similar inquiry.
>
> The organization behind the IETF can very well collect information about
> the situation for, say, citizens of the 10 leading regions that will
> originate participants.  I would expect my meeting fee dollars to already
> have paid for that, because the venue selection committee must already have
> looked at that.  So why withhold that information?
>
> And, ultimately, it is my decision (or that of my organization) how to
> handle this information, but the IETF could do most of the legwork here.
> Regularly, as a routine component of venue selection and preparing for a
> meeting.
>
> Grüße, Carsten
>
> --
> 103all mailing list
> [email-masked]

---

From: "John Levine" <[email-masked]>
Date: 15 Aug 2018 13:41:53 -0400

In article <CABmDk8kGx4OpT3Gz6XJDO3MrRLUW1MRBxx1Y=[email-masked]> you write:
>-=-=-=-=-=-

Actually, it is an official website.  businesseventsthailand.com is the
Thailand Convention and Exhibition Bureau which is a government agency.

But there are other government websites which say other things.  If we
could give you a simple answer, we would.

R's,
John

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Wed, 15 Aug 2018 17:42:13 +0000

On 8/15/18, 1:04 AM, "ietf on behalf of Carsten Bormann" <[email-masked] on behalf of [email-masked]> wrote:

>>    The organization behind the IETF can very well collect information about the situation for, say, citizens of the 10 leading regions that will originate participants.  
>> I would expect my meeting fee dollars to already have paid for that, because the venue selection committee must already have looked at that.  
>> So why withhold that information?
   
>>    And, ultimately, it is my decision (or that of my organization) how to handle this information, but the IETF could do most of the 
>> legwork here.  Regularly, as a routine component of venue 
>>selection and preparing for a meeting.
    
>>    Grüße, Carsten

Hi Carsten,

As Chair of the IAOC let me say that no information is being withheld on Thailand visas.  We are simply reminding everyone to do what you already do when visiting a new country - learn what the entry requirements for your personal situation are, such as reading on the web, asking your travel agent, or consulting a visa service.

When venues are selected there is a review of entry into the country to gauge the difficulty or ease that IETF attendees will incur.     The assessment of Thailand is that it does meet the MTGVENUE requirement on border entry. (https://datatracker.ietf.org/doc/draft-ietf-mtgvenue-iaoc-venue-selection-process).

The IETF is a community of distinct individuals from a wide variety of countries and backgrounds . The question of what do you need is very much on a personal situation basis and it isn't possible to advise on as everyone's situation is different depending on a great many factors such as what country issued your passport, what your birth country is, what other countries you have stamps in your passport from, even if you are employed currently, a consultant, or are unemployed.  It can also depended on the interpretation of your situation by the individual inspector you speak with at the border.  An IETF meeting has over a 1000 individuals, each with their own situation.  

The IAOC is doing legwork to get the word out to say: 

     Thailand is a new IETF meeting country and every attendee should take the time to check what, if anything, knowing their own unique personal situation, they need to do to enter Thailand.      

A lot of info is available on the web with a google search.  John Levine's search turned up https://www.businesseventsthailand.com/plan-your-events/general-travel-information/visa-requirements/ which has info and which also links to the Ministry of Foreign Affairs of the Kingdom of Thailand website (http://www.mfa.go.th/main/en/services/4908).  A google search turns up a great many links to the question "Do I need a visa to travel to Thailand". In the end, the answer is every traveler is responsible to read the rules and apply them to the their personal situation.

I personally spent about 20 minutes with google search and some reading to understand how it applies to my own situation.   One thing that caught my eye was in the Questions and Answers on Thai Visa section on the Ministry of Foreign Affairs of the Kingdom of Thailand website (http://www.mfa.go.th/main/en/services/4908/15380-Questions-&-Answers-on-Thai-Visa.html), which stated a financial support requirement for tourists from the US and 41 other countries that don't require a visa for tourist travel up to 30 days, do need to have "adequate finances equivalent to at least 10,000 Baht per person or 20,000 Baht per family".    5,000 Bhat is as of today's exchange rate around $150 US.   In other words - if I visit as a tourist, I need to have at least $150 US in my wallet when entering.    That's a something I didn't know until I read about it.

This illustrates the point that the IAOC is trying to make.  If you aren't familiar with Thailand's entry rules for your situation, you should take the time to read up on them as you may learn something that you didn't expect that may apply to your situation. 

This is in no way special to Thailand and it's something every traveler should do when visiting a new country.   The IAOC is raising awareness now so that everyone takes the time to educate themselves and has the time to do what they need to do.

Regards
Glenn Deen - IAOC Chair

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 Aug 2018 14:05:36 -0400

Mary B <[email-masked]> wrote:
    > So, Fred, are you going to tell immigration you're there as a tourist
    > or to work? That's the whole crux of it.

Those are not the only two answers to the question.
"I am here for a business meeting" is the correct answer.

(They will ask, "who do you work for", and you give them the answer
that matches the business card you have.  If you attend IETF meetings for
fun, I suggest you explain that you are retired from your last company,
rather than being "between jobs". But, surely we all have a consulting
company that we "work" for)

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Sean Turner <[email-masked]>
Date: Wed, 15 Aug 2018 14:12:59 -0400

That is typically what I do too, but I also stumbled across this handy link at United:

https://www.united.com/web/en-US/apps/vendors/default.aspx?i=TIMATIC

spt

> On Aug 15, 2018, at 12:14, Fred Baker <[email-masked]> wrote:
>

---

From: "John Levine" <[email-masked]>
Date: 15 Aug 2018 14:24:07 -0400

>https://www.united.com/web/en-US/apps/vendors/default.aspx?i=TIMATIC

TIMATIC is fairly definitive about whether the airline will let you on
the plane, but not about whether the country will admit you.

On the other hand, airlines have an incentive to be conservative so they
don't have to pay to fly refused travellers home.

---

From: Bob Hinden <[email-masked]>
Date: Wed, 15 Aug 2018 11:58:12 -0700

Mary,

> On Aug 15, 2018, at 9:26 AM, Mary B <[email-masked]> wrote:
> 
> So, Fred, are you going to tell immigration you're there as a tourist or to work?   That's the whole crux of it.  There is the referenced website in this thread about conferences, expos, etc. that suggests you don't need a VISA for those, but that's not an official website.

When asked by immigration why I am there I answer something like “I am attending an IETF meeting at the Fairmont Hotel in Montreal”.   That is truthful and avoids the work issue.  I haven’t been rejected yet :-)

Bob

---

From: Fred Baker <[email-masked]>
Date: Wed, 15 Aug 2018 12:05:02 -0700

Useful. Thanks. Maybe it deserves a link from the IETF Meeting Page.

> On Aug 15, 2018, at 11:12 AM, Sean Turner <[email-masked]> wrote:
> 

--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 15 Aug 2018 21:18:40 +0200 (CEST)

On Wed, 15 Aug 2018, Bob Hinden wrote:

> When asked by immigration why I am there I answer something like “I am 
> attending an IETF meeting at the Fairmont Hotel in Montreal”.  That is 
> truthful and avoids the work issue.  I haven’t been rejected yet :-)

Yes, it's best to avoid the word "work" when travelling. You're there to 
attend a conference, meet vendors or similar. You're there for business. 
Never "to work".

For thailand:

http://www.thaiembassy.com/thailand/changes-visa-exempt.php

http://www.thaiembassy.org/helsinki/en/customize/28150-ConferenceBusiness-meetingSeminar.html

"1.     Foreign nationals wishing to enter the Kingdom of Thailand to 
attend a MICE event, which is endorsed or sponsored by TCEB, without being 
employed or working for income, are regarded as tourists"

Having spent a total of over a year and traveled in and out of thailand a 
non-trivial amount of time, I'd recommend to make things easier for 
everybody and just say you're going there for tourism if you're a passport 
holder from one of those 55 countries. If someone questions that, point to 
above rule and say you interpreted it as you should say tourism. Apologise 
profusely for the mix-up.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Clint Chaplin <[email-masked]>
Date: Wed, 15 Aug 2018 12:28:40 -0700

Instead of " I am attending an IETF meeting at the Fairmont Hotel in
Montreal",  I say " I am attending an IETF conference at the Fairmont Hotel
in Montreal"

"Meeting" can imply business meeting, which is close to work.  "Conference"
does not have the same implication.  I once had to spend five minutes
explaining to Canada Immigration what kind of "meeting" I was attending.

-- 
Clint Chaplin
Principal Standards Engineer
Samsung Research America

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Aug 2018 21:41:17 +0200

On Aug 15, 2018, at 21:18, Mikael Abrahamsson <[email-masked]> wrote:
> 
> "1.     Foreign nationals wishing to enter the Kingdom of Thailand to attend a MICE event, which is endorsed or sponsored by TCEB, without being employed or working for income, are regarded as tourists”

Thanks Mikael for this find — that is exactly what I was asking for.
That is the kind of information the secretariat/meeting organization should collect and make available.
(And make sure we are endorsed/sponsored by the TCEB — are we?)

> Having spent a total of over a year and traveled in and out of thailand a non-trivial amount of time, I'd recommend to make things easier for everybody and just say you're going there for tourism if you're a passport holder from one of those 55 countries. If someone questions that, point to above rule and say you interpreted it as you should say tourism. Apologise profusely for the mix-up.

Let me tell a story about this: There is a check box on a US visa waiver form that asks “have you ever had a visa canceled?”.

Now, I started going to the US regularly when Germans still needed visa, and at the time I was too young for a permanent one, so I got one that lasted only a couple of years.  Later, when I went for a trip that might have gone beyond the end date of that visa, I finally got a permanent one, and my time-limited one (which was still valid for a couple more months) was canceled.  Some time later, when the visa waiver program became active, at first I continued to travel with my permanent visa, until one day an immigration officer just wrote a big “canceled” on top of that (I must have let out a big gasp) and said I didn’t need that any more.

OK, so the next time I entered, I did have to use the visa waiver program, and I dutifully put my check mark for “have you ever had a visa canceled” on the true answer: Yes (actually, by then I had that happen twice to me).  Of course, I turned up in “that room” after briefly talking to the usual immigration officer.  After about two hours later, an immigration officer told me off in no uncertain terms to never make that check mark in the check box again and sent me on to my meeting.

How should I have known that the expected answer to that question was not the truth, but the expedient answer?
That was a highly learnable moment.

Grüße, Carsten

---

From: Joe Touch <[email-masked]>
Date: Wed, 15 Aug 2018 12:52:16 -0700

> On Aug 15, 2018, at 12:18 PM, Mikael Abrahamsson <[email-masked]> wrote:
> 
> Yes, it's best to avoid the word "work" when travelling. You're there to attend a conference, meet vendors or similar. You're there for business. Never "to work".

It’s not a conference - it doesn’t say so on our web pages. It’s a meeting of a standards body, but that is considered work by some people. 

And saying “business” isn’t a win either. 

Joe

---

From: Michael Richardson <[email-masked]>
Date: Wed, 15 Aug 2018 15:52:53 -0400

Deen, Glenn (NBCUniversal) <[email-masked]> wrote:
    Carsten> Yes, it would need to be qualified as “not legal advice”, “subject to
    Carsten> change”, “void where prohibited”, etc.  It would help if it contains
    Carsten> pointers to authoritative information I can look up myself.  And,
    Carsten> ultimately, it is my decision (or that of my organization) how to
    Carsten> handle this information, but the IETF could do most of the legwork
    Carsten> here.  Regularly, as a routine component of venue selection and
    Carsten> preparing for a meeting.

    > As Chair of the IAOC let me say that no information is being withheld
    > on Thailand visas.  We are simply reminding everyone to do what you
    > already do when visiting a new country - learn what the entry
    > requirements for your personal situation are, such as reading on the
    > web, asking your travel agent, or consulting a visa service.

Glenn, what Carsten is asking is that we get a list of what the IAOC
found to be *authoritative* information sources.  Yes, we can Google, but
there is a motive for the non-authortative sources (particularly those with
a service to sell) to do better SEO, so they are going to show up earlier,
and there may be language issues that keep us from finding the real site.

I think that we all have experiences where talking to Travel Agents or
company travel people results in more confusion because they simply do not
have the information they need.  We have to tell *them* what the
authoritative information is.

I am surprised that https://www.businesseventsthailand.com is authoritative
as I'd expect to find it at something.go.th...

We aren't asking that you determine for us if we need a VISA, but rather to
help us find authoritative code that we can run ourselves (or point our
travel people at) to make that determination.

    > I personally spent about 20 minutes with google search and some reading
    > to understand how it applies to my own situation.  One thing that
    > caught my eye was in the Questions and Answers on Thai Visa section on
    > the Ministry of Foreign Affairs of the Kingdom of Thailand website
    > (http://www.mfa.go.th/main/en/services/4908/15380-Questions-&-Answers-on-Thai-Visa.html),
    > which stated a financial support requirement for tourists from the US
    > and 41 other countries that don't require a visa for tourist travel up
    > to 30 days, do need to have "adequate finances equivalent to at least
    > 10,000 Baht per person or 20,000 Baht per family".  5,000 Bhat is as of
    > today's exchange rate around $150 US.  In other words - if I visit as a
    > tourist, I need to have at least $150 US in my wallet when entering.
    > That's a something I didn't know until I read about it.

This is useful to know. (How did 10000 Baht become 5000 = 150US?, btw?)
Is a valid credit card "finances equivalent to"?  Or do I really need $150US?
How about 150EU? Or 150CDN?

I'm annoyed by the above page that keeps telling me that the list of 41
countries is at www.mfa.go.th/ which after some puzzling through, I finally
find at:
   http://www.consular.go.th/main/contents/filemanager/VISA/Visa%20on%20Arrival/VOA_%E0%B9%81%E0%B8%81%E0%B9%89%E0%B9%84%E0%B8%82%2015-03-61.pdf

I saved that PDF file, the filename is in Thai.

---

From: "Deen, Glenn (NBCUniversal)" <[email-masked]>
Date: Wed, 15 Aug 2018 21:18:02 +0000

In line....[GD]

On 8/15/18, 12:53 PM, "Michael Richardson" <[email-masked]> wrote:

    

[GD]  The site John Levine cited (https://www.businesseventsthailand.com/plan-your-events/general-travel-information/visa-requirements/) is run by the a government agency and it links to  (http://www.mfa.go.th/main/en/services/4908)  which is the Kingdom's Ministry of Foreign affairs page which has visa info and Q&A.   So far in my own reading those seem to be the two most authoritative sites and are both published by the Kingdom.  The second site is a .th domain. There two are where I started reading.

[GD] My mistake - I should have said 10,000 Baht which is about $300 US.  Some sites say you don't literally need $300 as major credit cards will be accepted by inspectors.  However, this isn't clearly stated on either of the sites I mention above.  The Ministry of Foreign Affairs Q&A says "adequate finances equivalent to ..." which could be interpreted a couple ways in by own reading of it - either cash in pocket, or credit cards, or I guess gold bars if you like carrying them around.   

-glenn

---

From: Stig Venaas <[email-masked]>
Date: Wed, 15 Aug 2018 18:22:25 -0700

Hi

> [GD]  The site John Levine cited (https://www.businesseventsthailand.com/plan-your-events/general-travel-information/visa-requirements/) is run by the a government agency and it links to  (http://w…

I did not quite trust the businessevents web site, so I tried to to
look at the cited references, including the Ministry of Foreign
affairs, and I could not find any place there where it says that a
visa is not needed when attending a conference. The info I've seen
from various Thai consulates' web sites all seem to indicate that a
visa is required for attending a conference. Is there a more
authoritative source than the businessevents site stating this?

Stig

> 103attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/103attendees

---

From: "Paul Hoffman" <[email-masked]>
Date: Wed, 15 Aug 2018 18:37:33 -0700

On 15 Aug 2018, at 18:22, Stig Venaas wrote:

> Is there a more

As others have indicated, the only truly authoritative source is the 
customs and immigration people who you meet when entering a country. 
Everything else is "anecdata". Those people get to decide whether or not 
you prepared correctly.

--Paul Hoffman

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 16 Aug 2018 17:49:10 +1200

On 2018-08-16 13:22, Stig Venaas wrote:
....
> authoritative source than the businessevents site stating this?

I hope it's clear why IASA does not, cannot and should not offer
any advice. If a person born in country A but having a passport
from country B and resident in country C wants to attend a
conference in country D, travelling via country E, that person
(or their travel agent) needs to find out whether a visa is needed
in their particular case. As far as I can see, except for very clear
cases, that means contacting the relevant consulate (the one that
handles travellers from country C, but it might be located in yet
another country).

  Brian

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 16 Aug 2018 09:19:04 +0200

On Aug 16, 2018, at 07:49, Brian E Carpenter <[email-masked]> wrote:
> .....
> any advice.

Of course.

> If a person born in country A but having a passport
> in their particular case.

All that I was asking that, maybe, we could be efficient about that.

> As far as I can see, except for very clear

The majority of the cases are those very clear cases.
If we could collect relevant information in a ready-to-process form, we could be way more efficient than with everyone having to start from scratch.

I apologize for asking for efficiency here; that may be a German thing.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 16 Aug 2018 09:50:28 +0200

> It’s not a conference - it doesn’t say so on our web pages. It’s a meeting of a standards body, but that is considered work by some people. 

Joe,

while I understand that it can be very satisfying, this is the kind of hair splitting that in the end benefits no-one.

*Of course* the IETF event is a conference:

conference | ˈkɑnf(ə)rəns | 
noun 
1 a formal meeting for discussion: he gathered all the men around the table for a conference. 
• a formal meeting that typically takes place over a number of days and involves people with a shared interest, especially one held regularly by an association or organization: an international conference on the environment | the third annual National Wilderness Conference. 
• [usually as modifier] a linking of several telephones or computers, so that each user may communicate with the others simultaneously: a conference call. 
2 an association of sports teams that play each other. 
3 the governing body of some Christian churches, especially the Methodist Church. 

(Sense 1, in case you wondered, although I sometimes wonder about whether the other ones apply too…)

The IETF event is not a business meeting in the sense that we are discussing contract conditions and signing agreements.  I would not use the term “meeting” because it does carry this implication to many.  And I don’t care (at all!) whether that is right: I try to communicate with officials and I have to use language that evokes the right connotations with *them*, not with learned scholars of the English language.

(The problem with “work” is that it implies gainful employment.  Immigration officials will then additionally infer “for a business entity in the host country”, which of course isn’t true for the foreign attendees except for the AMS people.  [BTW, I would love to learn how they are handling the visa issue…  But maybe that cannot be discussed in the open.])

If the IETF web pages are broken in this regard, maybe they can be fixed.  I haven’t yet had immigration officials google the conference I’m going to, but it appears that does happen.

(And I’m still wondering whether we are endorsed/sponsored by TCEB.)

Grüße, Carsten

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 16 Aug 2018 09:05:05 +0100

FWIW I always say that I am attending an international technical 
standards meeting.

- Stewart

On 15/08/2018 20:28, Clint Chaplin wrote:
> Montreal",  I say " I am attending an IETF conference at the Fairmont 
> Hotel in Montreal"
>
> "Meeting" can imply business meeting, which is close to work.  
> "Conference" does not have the same implication.  I once had to spend 
> five minutes explaining to Canada Immigration what kind of "meeting" I 
> was attending.
>
> On Wed, Aug 15, 2018 at 12:19 PM Mikael Abrahamsson <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     attend a conference, meet vendors or similar. You're there for
>     business..
>     Never "to work".
>
>     For thailand:
>
>     <mailto:[email-masked]>
>
>
>
> -- 
> Clint Chaplin

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Thu, 16 Aug 2018 13:53:55 +0000

Grüße, Carsten
[deborah] 

My 2cent guess, checking TCEB/MICE calendar:
http://www.micecapabilities.com/mice/event/filterevent?keyword=&filter_month=8&filter_year=2018

Not listed.

And if wiki is correct:
https://en.wikipedia.org/wiki/Thailand_Convention_and_Exhibition_Bureau

The conference/meeting needs "inclusion of Thai arts and culture in these events in order to promote the national heritage".

IETF's invitation letter is on-demand, submit and immediately receive. It says "meeting".

---

From: Adam Roach <[email-masked]>
Date: Thu, 16 Aug 2018 09:58:05 -0500

> That is the kind of information the secretariat/meeting organization should collect and make available.

When the IAOC said "conflicting information," they really did mean it. 
The Thai Embassy in Canada rather unambiguously claims that you need a 
non-tourist business visa to "attend business conferences":

http://www.thaiembassy.ca/en/visiting-thailand/visas/types-visas-periods-stay-fees/non-immigrant-visa

/a

---

From: John C Klensin <[email-masked]>
Date: Thu, 16 Aug 2018 11:31:31 -0400

--On Thursday, August 16, 2018 09:58 -0500 Adam Roach
<[email-masked]> wrote:

> When the IAOC said "conflicting information," they really did
> mean it. The Thai Embassy in Canada rather unambiguously
> claims that you need a non-tourist business visa to "attend
> business conferences":
> 

FWIW (and please see disclamer below), I've been in and out of
Thailand perhaps a dozen times since the first half of the 1980s
always in conjunction with something that could be described as
a "business conference" or "professional or scientific meeting".
The answers we have gotten  as to whether a non-tourist visa is
needed have changed many times.  I don't have any idea whether
those changes are actual changes in the regulations, exactly
what question was asked and how, the weather in Bangkok or at
some embassy location on a particular day, or something else.  

I have also gotten one piece of consistent advice from a visa
agency in these matters.  It is that, if one really wants to get
into the country for a particular meeting that starts at a
particular time, apply for and get the relevant business visa.
If one gets to the border and it is judged unnecessary, the
worst problem is having spent the extra time and money to get
the visa and maybe to apologize for the choice of category.   On
the other hand, if one decides to enter on a tourist visa and
that turns out to be the wrong choice, one either gets sent home
or spends a lot of time filling out forms and/or being hassled
at the airport.

There is nothing unique about Thailand in that regard other than
the IETF has not been there.

Disclaimer:  I am not a visa specialist, not a lawyer, and have
no affiliation that would allow me to speak for the Thai
government or any of its representatives.  The above is a
comment about my experience, not advice, and, if it were advice,
it would be worth what you just paid for it or a bit less.

   best,
    john

---

From: Nico Williams <[email-masked]>
Date: Thu, 16 Aug 2018 11:23:24 -0500

On Thu, Aug 16, 2018 at 09:50:28AM +0200, Carsten Bormann wrote:
> > It’s not a conference - it doesn’t say so on our web pages. It’s a
> > meeting of a standards body, but that is considered work by some
> > people. 
> 
> while I understand that it can be very satisfying, this is the kind of
> hair splitting that in the end benefits no-one.
> 

Whatever a *dictionary* says is irrelevant.  What the laws in the host
country say is.

I'm sure the meeting vs conference designation can make a difference in
some cases.

The reason a host country might want you to get a worker visa to be
compensated for talking at a conference is that the conference might be
the sort where locals might be paid to speak otherwise.  E.g., a
doctors' conference where the attendees are mostly local doctors.  If
you're not compensated, but still a local might have been then it could
still be a problem.  These things are almost entirely about protecting
locals from foreign competition.

But if you're there to meet with and talk to people who are mostly not
locals, and where you're not in competition with locals, and where
you're not compensated for the act of being there and speaking, then
it's less of a problem, and maybe a non-problem altogether.  Thus the
word 'meeting'.

And, personally, given the nature of IETF meetings, I'd call them
meetings, not conferences.  We do need a distinction between the things
those two words refer to, because we really are not like a typical
conference.

Nico
--

---

From: Nico Williams <[email-masked]>
Date: Thu, 16 Aug 2018 11:34:34 -0500

On Thu, Aug 16, 2018 at 09:05:05AM +0100, Stewart Bryant wrote:
> FWIW I always say that I am attending an international technical standards
> meeting.

I think this is good advice, though, of course, IANAL.

It means you're not lying to the immigration officer, for one, nor
misleading them in any way.  The fact that we call these "meetings"
helps.  If they ask more questions, you can explain more, and no detail
will show you to have been lying earlier.

It also denotes a) that this meeting has no competition-with-locals
angle, and b) that it's the sort of meeting that brings the host country
prestige ("international technical standards" -> good, right?).

Above all it's important that the immigration officer understand that
under no circumstance are you getting compensated for speaking at the
meeting, and that all your compensation is as normal for your day job in
your country of residence (though, obviously, you may be getting your
travel costs covered by the same employer).  Protectionism is the real
reason for the "are you coming to work here [competing with locals]?"
line of questioning, and it is and should be absolutely clear that IETF
meetings simply don't involve any competition with locals anywhere.

IANAL,

Nico
--

---

From: Michael Richardson <[email-masked]>
Date: Thu, 16 Aug 2018 12:41:24 -0400

> five minutes explaining to Canada Immigration what kind of "meeting" I

I disagree: stick to meeting, even if you have to spend five minutes
explaining what the IETF is.  The reason that they ask you this is to find
out if you have a clue about what you are talking about, or if it's a fib.

Don't be afraid to go into the most minute detail of how the protocols work,
because what they really care about, is are you really an engineer?

Conferences engages and pays speakers.
Are you speaking at the IETF?   Oh, you are. (Because, we *all* are)
You have a document?  And presenting the document is part of your work? Oops.

---

From: "Pete Resnick" <[email-masked]>
Date: Thu, 16 Aug 2018 16:33:43 -0500

> best guidance one can provide.

Heh. I called the Chicago consulate. This is as close as I can get to a 
verbatim transcript of my phone call:

Me: I am coming to Thailand for an Internet conference. What sort of 
visa do I need? I am a US citizen.
Consulate: Oh, for that, they are only giving Tourist visas.
Me: A tourist visa?
Consulate: Are you going to be making any money?
Me: No, I am not making money.
Consulate: Yes, then a tourist visa is fine. When you arrive, just tell 
them you are there for pleasure.
Me: Is that written down anywhere official?
Consulate: No.
Me: OK, thank you.

And on their website, it is crystal clear, in the other direction:

NON-IMMIGRANT VISA ( Maximum stay 90 days, extension of stay may be 
applied in Thailand )
Purpose of visit :
- To conduct business, attend conference, or to work (Category “B”)

I always do find meeting with the lot of you “pleasurable”, and 
I’m bringing along my scuba gear, so I can point to it if asked, so I 
guess I’m going to save the $80 and say that I am “here for 
pleasure”.

pr

---

From: Randy Bush <[email-masked]>
Date: Thu, 16 Aug 2018 15:27:51 -0700

> Heh. I called the Chicago consulate. This is as close as I can get to
> a verbatim transcript of my phone call:
> ...

there is a amusement in watching westerners try to deal with southeast
asian bureaucracy

randy, who does not claim any understanding other than go with the flow

---

From: Mikael Abrahamsson <[email-masked]>
Date: Fri, 17 Aug 2018 07:19:22 +0200 (CEST)

On Thu, 16 Aug 2018, Pete Resnick wrote:

> Me: I am coming to Thailand for an Internet conference. What sort of visa do 
> I need? I am a US citizen.
> Consulate: Yes, then a tourist visa is fine. When you arrive, just tell them 
> you are there for pleasure.

This is exactly what I meant with "make it easier for everybody". This is 
what Randy meant by "south east asia bureaucracy".

I'll give another example. Thailand just recently announced a new rule 
that if you have some kind of temporary permit to stay in the country, 
then you must always report if you're staying somewhere that is not a 
hotel. Hotels take copies of your passport and entry stamp and reports 
this to the authorities, so now the same thing must happen whereever 
you're staying. So now the house/apartment owner and you need to go to the 
local immigration office and report (or the owner can create an online 
account and report there). So since I was staying at a regular house half 
the time, I went there with the house owner to report. This is in a non 
touristy area. So I go to the local immigration office (15km drive away 
near the Myanmar border), with already filled in forms according to what I 
thought was necessary. When we show up, first they basically have no idea 
what we're after, it takes 5 minutes before they realise what needs to be 
done, I see "*sigh*" and almost "*rolling eyes*" on the officer, gets more 
forms, we have to fill in them, documents are copied, signed, stamped, 
signed by a higher ranking officer and off I go. Took 20-30 minutes of 
their (and my) time, to follow rules that clearly wasn't designed to find 
people like me (westerner on holiday for a month staying with family in 
the country).

So my advice is to follow what the people said at the consulate. Make it 
easier for everybody and just say you're there to eat nice thai food and 
look at the views. This is not untruthful, right?

---

From: Andrew Sullivan <[email-masked]>
Date: Fri, 17 Aug 2018 14:05:14 -0400

> All that I was asking that, maybe, we could be efficient about that.

Maybe we could, but in practice we can't, for the very reasons people
have stated.  The message that was posted gave you all the information
we actually have -- it's a site that is apparently operated by the
Kingdom.  Whether it will work for you is a decision you must make
yourself.

> The majority of the cases are those very clear cases.

I am a dual US-Canadian citizen who has had trouble entering the
United States on my US passport because the guy at the border didn't
think Merrikans should live in another country.  There are literally
_no_ very clear cases when crossing international borders, and there
never have been, and the best anyone can do is give you the
information they have and urge you to make a decision according to
your best analysis.  I believe that IASA has done this.

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 20 Aug 2018 19:36:14 +0200

This URL from MICE is very helpfull. I at least feel safe to
just go there just as a "tourist", no visa needed.

We had the same disucssion two years ago for Buenos Aires,
and there was no official statement like this on any argentinian
web page i found, and the consulates all told me different useless
stuff. We finally figured out in the discussion on the mailing
list something similar though (no money received == tourist).

It would be good for IASA to ask new host countries to
provide as clear an unambiguous guidance as they can for
conference attendees. The text from this thailand page would
be a good reference for future countries.

Of course, this likely will only make life easier for the hmm.. 
> 70% of IETF attendees with passport privilege to go places as
tourists without any Visa.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Eliot Lear <[email-masked]>
Date: Mon, 20 Aug 2018 20:29:10 +0200

Hi Andrew,

To be sure, “Your mileage will vary”  pretty much sums it up.  It will
vary due to citizenship, it will vary due to residence, it will vary
based on who one works for, and it will vary based on the interaction at
the border. And worse, past experience is no predictor of future
behaviors.  Just because you were able to cross the border yesterday is
not dispositive of whether you'll be able to do so tomorrow.

How do we address this in our policies?  The recent mtgvenue document
contains the following statement:

>    o  Travel barriers to entry, including visa requirements, are likely
>       to be such that an overwhelming majority of participants who wish
>       to do so can attend.  The term "travel barriers" is to be read
>       broadly by the IASA in the context of whether a successful meeting
>       can be had.

How do we establish that likelihood?  I wonder if we could leverage that
process to inform people just a bit more.  Some of that could be
retrospective (with all the attendant hazards of things having changed),
perhaps from the experience of other organizations that are willing to
share.

And to that end, perhaps we should be sharing more, as well.

Anyway.  just some thoughts.

Eliot

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 20 Aug 2018 21:55:32 +0200

On Aug 20, 2018, at 20:29, Eliot Lear <lear=[email-masked]> wrote:
> 
> past experience is no predictor of future
> behaviors

Actually, it is, just not a perfect one.
So, indeed, collecting that experience is a useful exercise before going to untried destinations.

Surprises will happen, and they are not a reason to give up planning for the usual case.
(And yes, it is also useful to keep a finger on the pulse for how likely surprises will be.)

Grüße, Carsten (who already once needed to evacuate from a business meeting while caught in a revolution)

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 20 Aug 2018 23:25:33 +0200

So, what insight data was collected and published from
Buenos Aires and Singapore from the respective IETF ?
I must have missed the IETF questionaire web page collecting
that information.