Subject: Re: Enabling DMARC workaround code for all IETF/IRTF mailing lists

From: Brian E Carpenter <[email-masked]>
Date: Fri, 28 Sep 2018 17:45:19 +1200

As a matter of curiosity (well, it's Friday afternoon here and I'm stuck
indoors recovering from flu) I looked at today's 'Narten list'.

9 out of 93 posters (i.e. ~10%) have dmarc.ietf.org rewritten addresses.

Assuming this is representative, is this extra load bothering the IETF's
mail servers?

Regards
   Brian

On 2018-05-12 00:00, Alexey Melnikov wrote:
> Hi,
> Many of you have seen several long discussions thread about DMARC and how it affects use of IETF/IRTF mailing lists.
> 
> After testing DMARC workaround code written by Henrik Levkowetz on several high volume IETF and IRTF mailing lists (e.g. CFRG, WebRTC, DMARC, QUIC), the tools team and the IESG decided that Henrik's code should be deployed for all IETF and IRTF mailing lists. In particular the workaround allows people from DMARC p=reject domains to participate in IETF mailing lists, as well as to avoid the problem of recipients being unsubscribed from mailing lists. These 2 issues were the main reasons for developing the DMARC workaround code..
> 
> The workaround will be deployed today, May 11th.
> 
> 
> Below are some technical details on how the email address rewriting workaround is going to work:
> 
> Emails from domains that don't have a p=reject DMARC setting are not going to be affected in any way.
> 
> For emails from p=reject domains:
> 
> - The From header field of such emails will be rewritten to be under @dmarc.ietf.org domain (which will have a p=none policy). For example, "[email-masked]" email address would become "alexey=[email-masked]". The original From header field will be preserved in the X-Original-From header field, which can be used for automatic message processing by Sieve and Mail User Agents.
> 
> Note that the mapping is reversible, so it is possible to send replies or new messages to an original sender by sending them to the corresponding mapped @dmarc.ietf.org email address.
> 
> Best Regards,
> Alexey
> 
>

---

From: Glen <[email-masked]>
Date: Fri, 28 Sep 2018 07:52:45 -0700

> Assuming this is representative, is this extra load bothering the IETF's

Hi Brian, Hi Everyone -

Although I am not normally on this list, this message was forwarded to me.

As the voice of the servers, I am pleased to report that the answer to
your question is:

Not even slightly.

We've got some pretty strong servers running the IETF's IT operations.
This change has not impacted them in any material way whatsoever.
They're not even breathing hard.

If you or anyone has further questions about the IETF servers, I'm the
one to answer them, and am happy so to do.  But I'm not on this list
normally, so be sure to CC me directly at:     [email-masked]   so that
I can be sure to see your questions.  :-)

Have a great weekend!
Glen
--
Glen Barney
IT Director
AMS (IETF Secretariat)