Subject: Re: Diversity and offensive terminology in RFCs

From: Glenn Deen <[email-masked]>
Date: Fri, 21 Sep 2018 20:48:39 +0000

Aren't we being very English and US culturally centric and ignoring the rest of the globe in this discussion ?   

Terms like man-in-the-middle, blacklist and whitelist may have additional cultural centric connotations assigned to them by regional cultural uses, but in the wider world view there are a lot of cultures and a lot of local meanings.  

Yet these words are also terms of art that on their own carry both defined and understood meaning within the context of technical documentation.  They are defined and have history that technical practitioners worldwide have learned to understand and know. Many terms have been used for decades and are in textbooks and training programs around the world.

It's the aspect of being well established in the context of technical documentation that is import here as that is the output of the IETF and that output is read and used by many non-native English speakers that in their training in the terminology of the art have come to know and understand the technical meanings of the terms when used in the work of the IETF.    They themselves may have little or no awareness of the cultural connotations other groups have assigned the words, but they do know and recognize the technical terms and the meaning in the art.  

Those words are also translated into other languages, and deviating from terms of art makes it harder for translators to carry over the specific technical meaning.    

Inventing new words to replace the technical terms can cause problems for the non-English readers of the IETF's documents.  It makes it more difficult for them to follow and use the documents produced by the IETF and somewhat disenfranchises them.

This stuff has significant technical consequences too. Changing words like changing units of measure is on the surface simple, but in practice hard - an inch is 2.54 centimeters inches but ask someone who isn't used to metric to gauge a properly cut steak as 3.5 centimeters and you may end with anything from a see through slice to a pot roast.    Silly examples aside, there have been serious industrial accidents when someone has mistaken the meaning or units of an important measurement.  So technical words and their established meaning in art do matter and it' non-trivial to change them.

This is exactly the sort of the unintended consequence John Levine mentioned when you approach the problem with a narrow set of objectives and don't consider other consequences and aspects of the situation.  

As a suggestion - Instead of a posting on the IETF's main town square which results in opinions being thrown about and little progress - it may be much more productive to have an I-D which has a problem statement, covers possible solution approaches and also includes discussion of negative impacts to the proposed solutions so that the problem and solution space can be discussed and explored. When the I-D is available it could be discussed in a BoF perhaps to see if there is enough community interest in moving forward with such work.    It's much more effective than the current town square discussion being had and produces something material along the way.

-glenn deen

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 22 Sep 2018 22:32:21 +0200

The technical terminologies in each knowledge/organisation is not easy
to replace (needs time) because we get to depend on it to describe
concepts. The Internet terms are well known with good history, we are still
teaching using them. I don't think the terms you mentioned are offensive,
but just technical terms with known definitions (not social terms).

For future WG terminology work, I don't recommend changing ietf-used-terms
with new-dversity-term only if we refer to the old-term used, that makes a
work/draft more defined.

AB

On Thu, Sep 20, 2018 at 5:26 AM Niels ten Oever <lists at
digitaldissidents.org> wrote:

> Hi all,
>
> On the hrpc-list [0] there has been an intense conversation which was
> spurred by the news that the Python community removed Master/Slave
> terminology from its programming language [1].
>
> In the discussion that followed it was remarked that in RFCs terms like
> Master/Slave, blacklist/whitelist, man-in-middle, and other terminology
> that is offensive to some people and groups is quite common.
>
> This is not a discussion that can be resolved in hrpc, but rather should
> be dealt with in the IETF community (because hrpc doesn't make policy
> for terminology in the IETF), which is why I am posting this here.
>
> If people find the discussion worthwhile, we might also be just in time
> to request a BoF on this topic.
>
> Looking forward to discuss.
>
> Best,
>
> Niels
>
>
> [0] https://mailarchive.ietf.org/arch/browse/hrpc/
> [1]
>
> https://motherboard.vice.com/en_us/article/8x7akv/masterslave-terminology-was-removed-from-python-programming-language
>