Subject: Re: New Non-WG Mailing List: CACAO

From: Barry Leiba <[email-masked]>
Date: Wed, 12 Sep 2018 22:37:51 -0400

This really should have come with a fuller description: I shouldn't
have to contact the list admins just to find out whether a new mailing
list ought to be on my radar or not.

Barry

On Wed, Sep 12, 2018 at 4:58 PM, IETF Secretariat
<[email-masked]> wrote:
> A new IETF non-working group email list has been created.
>
> List address: [email-masked]
> Archive: https://www.ietf.org/mail-archive/web/cacao/
> To subscribe: https://www.ietf.org/mailman/listinfo/cacao
>
> Purpose:
> This email list will be used to discuss Collaborative Automated Course of
> Action Operations (CACAO) for Cyber Security
>
> For additional information, please contact the list administrators.
>

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 13 Sep 2018 03:55:09 +0100

Hiya,

> list ought to be on my radar or not.

Yeah. And the archive's empty. And it uses the almost
always meaningless prefix "cyber" over and over in
many predictable (but meaningless) ways.

There is a draft [1] though (from a pointer sent to
the saag list). Mind you that includes this sentence:
"Threat Actors and Intrusion Sets are constantly
advancing at an increasing rate relative to cyber
defense."

So that's all bad signs IMO then (except for the
existence of the draft.)

I'm also a bit sad that we've gotten to the point
where we're setting up lists driven to any extent
by what's really an ill-defined marketing buzzword.

OTOH, the goal according to [1] is an information
model, so it could be mostly to totally harmless I
guess;-)

Only other thing to note is that this happens so
often (new list for who knows what) that maybe the
tooling's a bit wrong and encourages folks to ok
or ask for lists without considering that others
don't have the same (or any) context.

Cheers,
S.

[1] https://tools.ietf.org/html/draft-jordan-cacao-introduction-00

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 13 Sep 2018 00:23:55 -0300

Dear colleagues,

> don't have the same (or any) context.

While I think that is part of a possible explanation, I will note some
other things that may be leading to these meta-whether-list-should-be
discussions:

1.  People try to discuss a draft in a place where others don't want
to hear about it, at which point they are told that getting a list is
easy and they should just go do that.  Not unreasonably, they do, and
given the story they've been told it is hard to justify saying no.

2.  IETFers complain that "the leadership" is doing too much, making
too many decisions, or otherwise being to gatekeeper-y.  If we send
others constant negative feedback about them turning down things they
might have accepted with a few adjustments, their natural response
will be quite naturally to approve more things, particularly when it
is relatively low cost such as the creation of a mailing list.  (It is
worth observing that the combination of 1 and 2 means that people who
are approving lists might be thought of as appearing in a Joseph
Heller book.)

3.  IETF has in fact become rather gatekeeper-y.  There used to be
_lots of_ lists that were not hosted on ietf.org, and that required
absolutely no permission from anyone to get set up (you could do it
yourself on your own box).  This turned out to have some occasionally
negative consequences (for instance, that a long-lived WG could rely
on a list that could be deleted out from under the WG chairs while
they were flying to, say, China).  Now, it might be that people are
treating the creation of a mailing list as a sort of
proto-proto-chartering decision, rather like the way BoFs have become
such a Big Deal, but I am not sure that outcome is desirable.

It might be worth asking whether everyone who might care about the
IETF really needs to know what every @ietf.org mailing list is for.
If you don't know whether something is worth following, and there's no
history in the archive, what are the chances that learning about it
later is going to be fatal for your ability to say something useful
about the work?

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: Melinda Shore <[email-masked]>
Date: Wed, 12 Sep 2018 19:50:45 -0800

> later is going to be fatal for your ability to say something useful

I think it really depends on what the point of announcing
the mailing list is.  If it's to hook up people who are
interested in working on/reading about/taking shots at
some prospective piece of work it doesn't seem to me to
be too much to ask to include a brief description in the
announcement.

I'll add that I do feel rather strongly about IETF work
being hosted on IETF assets, but the point at which something
becomes "IETF work" is admittedly rather fuzzy.

Melinda

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 12 Sep 2018 21:30:31 -0700

Full disclosure: I approved this list, so feel free to be unhappy at me.

> many predictable (but meaningless) ways.

Well, the archive is empty because it was created today, so I don't think
that's much of a critique.

I'll take responsibility for not insisting on there being a very detailed
description. I generally find the descriptions pretty uninformative (see,
for instance https://www.ietf.org/mailman/listinfo/cicm) so my bar isn't
very high here, but I see how others might feel differently.

> don't have the same (or any) context.

I think you and I are just going to have to disagree here. Lists are cheap
-- they're not WGs -- and I bias in favor of facilitating discussion. I
think this is appropriate especially in view of the fact that one of the
first questions we ask for a proposed BOF is whether there has been a lot
of list traffic. Again, you're free to feel differently.

-Ekr

---

From: Barry Leiba <[email-masked]>
Date: Thu, 13 Sep 2018 00:58:59 -0400

I agree that lists are cheap and that one of our main jobs is to
facilitate discussion, so I have no issue with the creation of the
list.  I just hoped for a bit more explanation -- even "For details
see <this draft>" would have helped (I didn't know there was a draft
at all).

Anyway, just for future reference; thanks for listening.

Barry

On Thu, Sep 13, 2018 at 12:30 AM, Eric Rescorla <[email-masked]> wrote:
> first questions we ask for a proposed BOF is whether there has been a lot of
> list traffic. Again, you're free to feel differently.
>
> -Ekr
>
>
>>
>> Cheers,
>> S.
>>

-- 
Barry
--
Barry Leiba  ([email-masked])
http://internetmessagingtechnology.org/

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 13 Sep 2018 07:51:42 +0200

On Sep 13, 2018, at 06:30, Eric Rescorla <[email-masked]> wrote:
> 
> I'll take responsibility for not insisting on there being a very detailed description. I generally find the descriptions pretty uninformative (see, for instance https://www.ietf.org/mailman/listinfo/cicm) so my bar isn’t very high here, but I see how others might feel differently.

I read Barry’s initial email (which I’m sure 100 people like me silently agreed with) as a request to set the bar for that description a little (really just a little) higher.  It is better that the people requesting a list spend an hour coming up with a two-sentence elevator description than that 1000 people need to spend 10 minutes each to find and extract that information from the clues provided.

(I still have to spend those 10 minutes.)

Grüße, Carsten

---

From: John C Klensin <[email-masked]>
Date: Thu, 13 Sep 2018 03:36:35 -0400

--On Wednesday, September 12, 2018 19:50 -0800 Melinda Shore
<[email-masked]> wrote:

>...

--On Wednesday, September 12, 2018 21:30 -0700 Eric Rescorla
<[email-masked]> wrote:

>...
> I think you and I are just going to have to disagree here.
> Lists are cheap -- they're not WGs -- and I bias in favor of
> facilitating discussion. I think this is appropriate
> especially in view of the fact that one of the first questions
> we ask for a proposed BOF is whether there has been a lot of

While I mostly agree with this, I think it is worth pointing out
that we've had the existence of work being hosted on IETF assets
used in non-IETF contexts to claim, not only that it is IETF
work, but that there is IETF endorsement for particular ideas
and positions. 

That experience suggests to me that the acceptable level of
explanation of what a list is about and why it is being created
should probably be somewhat higher than this announcement shows,
especially if we are going to be permissive about creating such
lists, and indeed that the threshold should be higher the less
the list is directly associated with active or generally
anticipated IETF work.

    john

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 13 Sep 2018 11:30:12 +0100

Hiya,

> Full disclosure: I approved this list, so feel free to be unhappy at me.

So two things:

1 - I think a vague list description, lack of messages in
the archive and omitting pointers drafts are all things that
seem to happen a lot with new lists. My suggestion is that
some text like this be somehow visible to proponents and
ADs approving new lists to try reduce that:

   New mailing lists are announced on the ietf-annouce
   list. In a bunch of cases the list description is too
   vague for someone with no context. There may also be
   no messages in the list archive at that point and no
   link to an Internet-draft. In maybe one out of three
   such cases someone asks/complains about that leading
   to other old-farts chiming in about the badness of
   the wrong end of the stick they've inferred from the
   lack of information. That may be followed up by an
   old-fart generalising the discussion, leading to text
   like this being proposed. That's all inauspicious and
   better avoided.

(To be clear, I'm the only old-fart referred to above:-)

2 - as to this list - I've no problem at all with having
a very low bar for new lists, and there is perhaps a topic
for the IETF here - it's just not possible to tell from
the draft. Basically, I'd just prefer that the IETF not
be involved in discussion of the cybercardinality of
cyberangels on cyberpinheads;-)

Cheers,
S.

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 13 Sep 2018 07:12:47 -0700

On Thu, Sep 13, 2018 at 3:30 AM, Stephen Farrell <[email-masked]>
wrote:

> the draft.

Right now, the IETF isn't involved, other than we're hosting the mailing
list. Unless you think Github is "involved" in the QUIC WG.

Basically, I'd just prefer that the IETF not
> cyberangels on cyberpinheads;-)

You'll have your chance to offer that perspective if/when this is proposed
as IETF work.

-Ekr

---

From: Michael StJohns <[email-masked]>
Date: Thu, 13 Sep 2018 13:04:58 -0400

> I think you and I are just going to have to disagree here. Lists are 
> cheap -- they're not WGs -- and I bias in favor of facilitating 
> discussion.. I think this is appropriate especially in view of the 
> fact that one of the first questions we ask for a proposed BOF is 
> whether there has been a lot of list traffic. Again, you're free to 
> feel differently.
>
> -Ekr

Lists are cheap to *create* - the costs come (and they add up) to those 
who have to determine whether to subscribe and participate. Having 
enough information in the announcement so a prospective "investor" can 
decide without having to dig that the list may be safely ignored seems 
like common sense.  The converse - an announcement with no useful 
description - is usually one of either being lazy, or being oblivious or 
dismissive of other peoples time, or - in rare circumstances - trying to 
comply with the rules while hiding what's actually going on under a 
boring label.

I don't have any problems with creating lists, but compare the 
description of this list with sdwan which was created on the same day:

> Purpose:
> SDWAN-SEC Mailing Listing is for discussing optimized (and in some sense
> compromised) mechanisms in securing large scale SD-WAN deployment with
> constrained resources. Discussing the security risks for special type of
> IPsec solutions that utilize central controller to simplify some features
> of IPsec to fit within the common constrains of large number low power
> nodes managed by controller(s) via secure management channel.

Mike

---

From: Sean Turner <[email-masked]>
Date: Fri, 14 Sep 2018 12:33:26 -0300

Eh I saw it fly by, then did a datatracker search on caco and found the draft. I guess more info would have saved me some time, but I’m kind of used to following references and searching the datatracker at this point. 

spt

> On Sep 13, 2018, at 01:58, Barry Leiba <[email-masked]> wrote:
>