Subject: Further Clarification Re: IETF 104 Preliminary Agenda

From: IETF Agenda <[email-masked]>
Date: Fri, 22 Feb 2019 21:08:39 -0800

Hi everyone,

Our message earlier today announcing the preliminary agenda [1] was missing some further context. As previously mentioned by Alissa after IETF 103 [2], the IESG wanted to continue the unstructured time experiment at IETF 104.

Wednesday's schedule has regular sessions until 13:20, unstructured time in the afternoon, and the plenary in the evening at 17:10. This leaves almost four hours of unstructured time for attendees to reserve for side meetings. During this period, there will also be one unique Technology Deep Dive session with the acronym WGTLGO [3].

Monday through Friday, we will have two rooms available for attendees to reserve for side meetings as usual. On Wednesday afternoon, we will have five rooms available for side meetings. Further details about how to sign up for these rooms will be announced shortly. 

Thanks,
IETF Secretariat

[1]  https://mailarchive.ietf.org/arch/msg/ietf-announce/_JeP2fQ7rHPosZWpNtpl8I_uL5U
[2]  https://mailarchive.ietf.org/arch/msg/ietf-announce/H64AuTYhxsGqM1a8BfTkszCZyso
[3]  https://www.ietf.org/blog/ietf104-bofs/

---

From: Alissa Cooper <[email-masked]>
Date: Sat, 23 Feb 2019 06:13:08 -0500

Thank you, Secretariat. 

We got a bunch of feedback after the last meeting (and previously) that people want to experiment with open time in the schedule. We’re trying it on Wednesday this time. Depending on how people like it we can try something different or not at future meetings.

Alissa

> On Feb 23, 2019, at 12:08 AM, IETF Agenda <[email-masked]> wrote:
> 
> Hi everyone,
> 
> -- 
> 104all mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/104all

---

From: Stewart Bryant <[email-masked]>
Date: Sun, 24 Feb 2019 08:24:25 +0000

Am I alone I wishing that the IESG had used this time to address the unacceptable number of scheduling conflicts that exist in the meeting agenda?

Stewart

Sent from my iPad

> On 23 Feb 2019, at 11:13, Alissa Cooper <[email-masked]> wrote:
> 
> Thank you, Secretariat. 
>

---

From: Lou Berger <[email-masked]>
Date: Sun, 24 Feb 2019 06:48:42 -0500

nope.  Couldn't agree me more.  These experiments seem to me to be 
reducing the value of the meetings.

Yes, people meet on their own during the meeting, but this has always 
worked pretty well in self organizing ways - and having rooms formally 
available for this *is* helpful in this regard.

Lou

---

From: Bob Hinden <[email-masked]>
Date: Sun, 24 Feb 2019 08:19:46 -0800

Same here.  I also miss the 2 1/2 hour slots.

Bob

> On Feb 24, 2019, at 3:48 AM, Lou Berger <[email-masked]> wrote:
> 
> nope.  Couldn't agree me more.  These experiments seem to me to be reducing the value of the meetings.
> 
> Yes, people meet on their own during the meeting, but this has always worked pretty well in self organizing ways - and having rooms formally available for this *is* helpful in this regard.
> 
> Lou
>

---

From: Ted Lemon <[email-masked]>
Date: Sun, 24 Feb 2019 11:39:33 -0500

FWIW, I think having open time during the day is great, but if we’re going to do that, the way to do it is by expanding our Friday, not by shortening our Wednesday.   Or else being more disciplined about our use of meeting time, which we very much are not.   I suspect that it is this second knob that the IESG is trying to turn.   

Unfortunately I think that in order to do this job effectively, better tooling is required.   Right now we have very poor conflict detection tooling, which essentially only works for WG chairs.   I had a little brainstorm about tooling prior to the last IETF, when I had a slot with four sessions in it I wanted to attend, but unfortunately didn’t have the energy to actually lay down any code.   I think we would also need even shorter slots, and more of them, to make this work.   But for that to work, we’d need to get disciplined about how we use time.   This means that WG chairs need to say “no” a lot more than they currently do to presentations that aren’t ready for discussion.

While I understand the tendency to get triggered by any change to the status quo, I actually support the IESG in trying to work this issue, because it’s an issue that won’t go away as long as we have more working groups than time.   I served on an IESG where we discussed this, but took no action, and that was quite a few years ago.   It’s high time that some creativity was applied to the problem.

I think our time would be better spent trying to figure out how to make the IETF function under its present workload than requesting a return to the status quo ante, which, quite frankly, still had a _lot_ of conflicts, and was in no way satisfactory.

---

From: Michael Richardson <[email-masked]>
Date: Sun, 24 Feb 2019 13:34:32 -0500

Ted Lemon <[email-masked]> wrote:
    > Unfortunately I think that in order to do this job effectively, better
    > tooling is required. Right now we have very poor conflict detection tooling,
    > which essentially only works for WG chairs. I had a little brainstorm about

It's only visible to WG chairs and ADs, but actually can be applied to
additional people if we can figure out who is authorized to add those people.

    > tooling prior to the last IETF, when I had a slot with four sessions in it I
    > wanted to attend, but unfortunately didn’t have the energy to actually lay
    > down any code. I think we would also need even shorter slots, and more of
    > them, to make this work. But for that to work, we’d need to get disciplined
    > about how we use time.

I have been pushing for more short slots at the beginning of the week, which
would have full conflict detection.  And then a much more relaxed Wed/Thur.
in which bigger slots could be allocated, but with much less promise of no conflicts.

    > This means that WG chairs need to say “no” a lot more
    > than they currently do to presentations that aren’t ready for
    > discussion.

I agree completely.

    > While I understand the tendency to get triggered by any change to the status
    > quo, I actually support the IESG in trying to work this issue, because it’s
    > an issue that won’t go away as long as we have more working groups than time.
    > I served on an IESG where we discussed this, but took no action, and that was
    > quite a few years ago. It’s high time that some creativity was applied to the
    > problem.

    > I think our time would be better spent trying to figure out how to make the
    > IETF function under its present workload than requesting a return to the
    > status quo ante, which, quite frankly, still had a _lot_ of conflicts, and
    > was in no way satisfactory.

What I see is that some conflicts were resolved in favour of some areas,
while other cross-area people were regularly having difficulties.  I find
that I have about the same conflicts as before.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Ted Lemon <[email-masked]>
Date: Sun, 24 Feb 2019 14:33:33 -0500

> additional people if we can figure out who is authorized to add those people.

It would be interesting to see what would happen if everybody just listed all the working groups they wanted to attend, in order of preference.   I doubt that simply using that data would produce an optimal schedule, but it would be interesting to collect it and see what results it produced.

> in which bigger slots could be allocated, but with much less promise of no conflicts.

That wouldn’t suck. :)

> that I have about the same conflicts as before.

The idea that people are only interested in a particular area is really counter to my personal experience, though.   In order to only be interested in one area, you have to really limit what you do.   If you are trying to deliver a solution, it probably touches upon many areas.   E.g., the work I’m doing in homenet and dnssd hits intarea, routing, security and applications.   And because I’m also interested in email delivery and human rights, that creates even more conflict for me.   It’s possible that I’m atypical, but I suspect that it’s the other way around—that people tend to focus on an area because if they don’t, they get too many conflicts, or to put it differently, they tend to show up for one area in preference to others because that’s the way the scheduling currently works.

---

From: Fred Baker <[email-masked]>
Date: Sun, 24 Feb 2019 11:43:50 -0800

Ditto on the longer slots.

The biggest issue I see in these experiments, though, is that we find out about them very late in the game, after we have paid for travel arrangements and arranged side meetings guessing at what the IETF will do. In my case, we planned two RSSAC caucus working meetings on the guess that IETF slots would start at 9:30, and it turns out that they start at 9:00, and scheduled a company meeting Friday-Sunday following on the assumption that Friday would be open, and are now flexing those arrangements given that it conflicts with important working groups.

I miss the 2.5 hour slots, and I deeply wish that people could make rational predictions about how the IETF week will run before they purchase travel. 

The IESG is important. Earth to IESG: there is another 1000 people at every meeting that is also important.

Sent using a machine that autocorrects in interesting ways...

> On Feb 24, 2019, at 8:19 AM, Bob Hinden <[email-masked]> wrote:
>

---

From: Michael Richardson <[email-masked]>
Date: Sun, 24 Feb 2019 18:34:22 -0500

Fred Baker <[email-masked]> wrote:
    > The biggest issue I see in these experiments, though, is that we find
    > out about them very late in the game, after we have paid for travel
    > arrangements and arranged side meetings guessing at what the IETF will
    > do. In my case, we planned two RSSAC caucus working meetings on the
    > guess that IETF slots would start at 9:30, and it turns out that they
    > start at 9:00, and scheduled a company meeting Friday-Sunday following
    > on the assumption that Friday would be open, and are now flexing those
    > arrangements given that it conflicts with important working groups.

I agree.
I think I sent the IESG an email 6 to 8 weeks ago asking for a clear
and early statement.  Clearly they made a decision in time to tell the
secretariat, but not the rest of us... :-)

    > I miss the 2.5 hour slots, and I deeply wish that people could make
    > rational predictions about how the IETF week will run before they
    > purchase travel.

The 2.5 hour slots are just not doable with so many groups.
If we want big chunks of time, then we need bigger/wider groups.
Otherwise, we need smaller allocation units....

Spring IETF usually overruns my wife's birthday, so I having been waiting
until the last minute to book.. Annoyingly there is an afternoon flight on
Saturday that does not exist on Friday.

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 24 Feb 2019 20:07:13 -0600

On Sun, Feb 24, 2019 at 11:43:50AM -0800, Fred Baker wrote:
> The biggest issue I see in these experiments, though, is that we find out
> about them very late in the game, after we have paid for travel
> do. In my case, we planned two RSSAC caucus working meetings on the guess
> that IETF slots would start at 9:30, and it turns out that they start at
> 9:00, and scheduled a company meeting Friday-Sunday following on the

My understanding (could be wrong) is that while the start time is
influenced by many factors, a big factor is what WG session requests
actually come in.  E.g., if you are doing morning 2.5-hour sessions, then a
9:30 start can work well, but if you have to squeeze in 2-hour plus 1-hour
sessions, that basically forces a 9:00 start.  And of course the WGs won't
know how much time they need incredibly far in advance, so it's a hard
problem.

> assumption that Friday would be open, and are now flexing those

https://mailarchive.ietf.org/arch/msg/ietf-announce/H64AuTYhxsGqM1a8BfTkszCZyso
seemed pretty clear that Friday would have sesions until lunchtime or
mid-afternoon.

> The IESG is important. Earth to IESG: there is another 1000 people at every meeting that is also important.

I of course can't speak for everyone, but as far as I personally am
concerned, if the only conflict between two WGs is that they share me as
responsible AD but the overlap is otherwise minimal, I'm willing to accept
that I can't be at both.  The main input into the scheduling is the list of
conflicts that the WG chairs provide.  If you are seeing bad conflicts,
please let the relevant WG chairs know about it!

-Ben

---

From: Loa Andersson <[email-masked]>
Date: Mon, 25 Feb 2019 10:34:50 +0800

Folks,

I strongly agree with Stewart Lou, I think that we sent a strong message
to the IESG that any experiment that decreases the the number of
available slots is causing problem and should be avoided. Instead we
have another such experiment :(.

Stewart, you are not alone, but I think what you see is that more and
more people feel that they are not listen too, because the opinions we
have is not what the people that should list don't want to hear them.

/Loa

On 2019-02-24 19:48, Lou Berger wrote:
>> Am I alone I wishing that the IESG had used this time to address the 
>> unacceptable number of scheduling conflicts that exist in the meeting 
>> agenda?
>>
>> Stewart
>>
>> Sent from my iPad
>>
>>> We got a bunch of feedback after the last meeting (and previously) 
>>> that people want to experiment with open time in the schedule. We’re 
>>> trying it on Wednesday this time. Depending on how people like it we 
>>> can try something different or not at future meetings.
>>>
>>> Alissa
>>>
>>>> Our message earlier today announcing the preliminary agenda [1] was 
>>>> missing some further context. As previously mentioned by Alissa 
>>>> after IETF 103 [2], the IESG wanted to continue the unstructured 
>>>> time experiment at IETF 104.
>>>>
>>>> Wednesday's schedule has regular sessions until 13:20, unstructured 
>>>> time in the afternoon, and the plenary in the evening at 17:10. This 
>>>> leaves almost four hours of unstructured time for attendees to 
>>>> reserve for side meetings. During this period, there will also be 
>>>> one unique Technology Deep Dive session with the acronym WGTLGO [3].
>>>>
>>>> Monday through Friday, we will have two rooms available for 
>>>> attendees to reserve for side meetings as usual. On Wednesday 
>>>> afternoon, we will have five rooms available for side meetings. 
>>>> Further details about how to sign up for these rooms will be 
>>>> announced shortly.
>>>>
>>>> Thanks,
>>>> IETF Secretariat
>>>>
>>>>
>>>> [1]  
>>>> https://mailarchive.ietf.org/arch/msg/ietf-announce/_JeP2fQ7rHPosZWpNtpl8I_uL5U 
>>>>
>>>> [2]  

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 25 Feb 2019 07:34:23 +0100

Hi Loa,

We have multiple sources of feedback. Individual complaints are one and the meeting survey is another. See Q11-13 at 
https://www.surveymonkey.com/results/SM-KDSV3LH9V/ 

Of course, the point of publishing the preliminary agenda (what we did last week) is to solicit even further feedback before the agenda is finalized. 

Alissa

> On Feb 25, 2019, at 3:34 AM, Loa Andersson <[email-masked]> wrote:
> 
> Folks,
>

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Feb 2019 07:34:10 +0000

That survey says that 62% of people who responded had a conflict.

The problem with only relying on chair assessment of the conflicts is that generally they underestimate the degree of interest overlap. 

A better approach might be to ask people at registration what sessions they needed to attend. That would allow a statistical basis to be applied in the design of the agenda, rather than an informal guess. It might also provide encouragement to register and perhaps pay (I.e. commit to attend) earlier.

Stewart

Sent from my iPad

> On 25 Feb 2019, at 06:34, Alissa Cooper <[email-masked]> wrote:
> 
> Hi Loa,
>

---

From: Melinda Shore <[email-masked]>
Date: Sun, 24 Feb 2019 22:47:56 -0900

> That survey says that 62% of people who responded had a conflict.

But if you look at the responses to Q13 ("Which
sessions?") the only sessions mentioned consistently
were spring/bier and detnet/{several things}.  FWIW
I've noticed that in session requests some chairs are
asking to avoid things they've got people who'd prefer
not to miss and others are asking to avoid things
where they've got people who absolutely must be at
both.  I'm not sure that we're asking the right
questions, on the one hand, and answering the right
questions, on the other.

While our tooling has changed and there have been a
few other adaptations, I do think it's an issue that
we're approaching how we meet pretty much the same
way we did 25 years ago, despite massive improvements
in remote participation tools and the increase in
the use of virtual interims, distributed authoring
tools, etc.

Melinda

-- 
Melinda Shore
[email-masked]

Software longa, hardware brevis

---

From: Tim Chown <[email-masked]>
Date: Mon, 25 Feb 2019 08:10:00 +0000

Hi,

It can also help if WG chairs try to regularly  review and minimise their conflict lists wherever possible, so the scheduling team / software has more room to fit things in.  Sometimes you see quite long conflict lists that aren't strictly needed.

Tim 

> On 25 Feb 2019, at 07:47, Melinda Shore <[email-masked]> wrote:
>

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Feb 2019 10:43:34 +0000

On 25/02/2019 07:47, Melinda Shore wrote:
> were spring/bier and detnet/{several things}.

Routing does seem to be particularly problematic.

I would be happy if we fixed the problem for routing.

- Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Feb 2019 10:54:53 +0000

My experience, a long time ago when I was an AD, was that we needed to 
add to the conflict list that the chair supplied.

Further I don't think we can simply look at this from the perspective of 
the logical connections between works items. We need to also take into 
account the WGs that the attendees need to cover as part of the day to 
day work package that they do.

The more I think about it, a registration survey might well be a better 
input database than the chairs estimate. Perhaps we also need to go to 
electronic session registration rather than the blue sheets so that we 
can look at actual attendance. Then we know about draft contribution 
which helps build a more complete picture, and we know who spoke up on 
each agenda item. We are the organization that enabled, perhaps even 
created, big data, perhaps we should be using it to make our meetings 
more productive?

- Stewart

---

From: Loa Andersson <[email-masked]>
Date: Mon, 25 Feb 2019 19:11:05 +0800

Alissa,

> Hi Loa,
< snip>
> 
> Of course, the point of publishing the preliminary agenda (what we did 
> last week) is to solicit even further feedback before the agenda is 
> finalized.

Then I say that the strong feedback you have now, a few days after
posting the agenda is that there are unacceptable conflicts.

My advice would be to scratch the agenda, start over, leave the
experiment out and optimize to avoid conflicts!

/Loa

--

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Feb 2019 11:42:14 +0000

+1

Stewart

On 25/02/2019 11:11, Loa Andersson wrote:
>> Of course, the point of publishing the preliminary agenda (what we 
>> did last week) is to solicit even further feedback before the agenda 
>> is finalized.
>

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 25 Feb 2019 07:29:29 -0800

Dear All,
I'm disappointed to find that the number of conflicts for me at IETF-104 is
as high as in Bangkok which was two times higher than at any meeting
before. I'm stressed that I'll have to run from DetNet to BFD to deliver
presentations on work being done, forget being able to follow the
discussion adequately. If that's the new normal, then why to come to the
meeting at all.
I strongly encourage IESG to let us use all available time for WG sessions
and let attendees use their time for "corridor talks".

Regards,
Greg

On Fri, Feb 22, 2019 at 9:08 PM IETF Agenda <[email-masked]> wrote:

> missing some further context. As previously mentioned by Alissa after IETF
> 103 [2], the IESG wanted to continue the unstructured time experiment at
> IETF 104.
>
> Wednesday's schedule has regular sessions until 13:20, unstructured time
> in the afternoon, and the plenary in the evening at 17:10. This leaves
> almost four hours of unstructured time for attendees to reserve for side
> meetings. During this period, there will also be one unique Technology Deep
> Dive session with the acronym WGTLGO [3].
>
> Monday through Friday, we will have two rooms available for attendees to
> reserve for side meetings as usual. On Wednesday afternoon, we will have
> five rooms available for side meetings. Further details about how to sign
> up for these rooms will be announced shortly.
>
> Thanks,
> IETF Secretariat
>
>
> [1]

---

From: Ted Lemon <[email-masked]>
Date: Mon, 25 Feb 2019 10:30:50 -0500

> experiment out and optimize to avoid conflicts!

How would they do that?   What information do they have now that they didn’t have before they published the agenda?

I ask because in fact, this agenda is the least conflicted one for me that I have seen in a long time.   I’m really happy with the current agenda, and can really only lose from a re-do.   This is not to say that a re-do is not the right thing to do.   What I’m saying is that the fact that a couple of people have griped about conflicts and about an over-full agenda is not data.   It is anecdata.

As Stewart has said, if we want to do better at this, we need data, not anecdata.

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 25 Feb 2019 15:42:18 +0000

On 25/02/2019 15:30, Ted Lemon wrote:
> What I’m saying is that the fact that a couple of people have griped 
> about conflicts and about an over-full agenda is /not data./   It is 
> /anecdata/.

My experience is that just a tiny number of people are prepared to say 
what it turns out many think.

Maybe we should take a consensus in RTG on how we use our allocated time 
plus the free meeting time for meetings, then if the other areas are 
happy, nothing changes for them.

- Stewart

---

From: Kyle Rose <[email-masked]>
Date: Mon, 25 Feb 2019 15:26:00 -0500

There seem to be two separate issues here:

1. The meeting ends on Friday.

2. There is some combination of too few slots, too many (or too long) WG
session requests, and not enough information about meaningful conflicts to
construct a viable schedule.

#2 is a problem that the secretariat can partially address through changes
to the conflict declaration process. For example, by allowing chairs to
specify *individuals* who need to be at particular sessions because they're
presenting or are heavily involved in work, rather than via the working
group proxy, which may (and does IME) encode preference as well as need,
may become stale over the course of meetings, and often fails to capture
critical conflicts. This is a hard problem, but if it's possible to get a
viable schedule for the requested WG sessions given the number of slots,
there is a solution.

The secretariat can't address the problem of too many (or too long) WG
sessions, because it's a judgment call on the part of those involved in the
WGs. Perhaps sponsoring ADs can get more involved in deciding whether a WG
really needs to consume an official meeting slot, or whether they really
need as much time as requested for in-person work. This is also a hard
problem, but if we're going to make the most efficient use of limited
official in-person meeting time, hard choices will need to be made. (IMO,
leave the draft status updates to the mailing list. Use the meeting for
issues chosen in advance that will benefit from in-person discussion and
collaboration.)

#1, by contrast, is an easy problem to solve. Your WG can be assigned to a
slot anywhere from Monday to Friday at the secretariat's discretion.
Therefore: don't schedule your return trip until late on Friday at the
earliest, or don't complain when you are scheduled to leave before the
meeting ends. Which is on Friday. Seems straightforward.

Kyle

---

From: Fred Baker <[email-masked]>
Date: Mon, 25 Feb 2019 12:33:25 -0800

> On Feb 24, 2019, at 11:34 PM, Stewart Bryant <[email-masked]> wrote:
> 
> A better approach might be to ask people at registration what sessions they needed to attend.

An even better approach, although it delays feedback by one meeting, would be to look into the IETFers Application data. People list what they want to attend for the purpose of calendar maintenance. That would inform the next meeting's agenda development.
--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Mon, 25 Feb 2019 20:45:24 +0000

Kyle –

It seems to me that your summary has overlooked one key point. As per the announcement:

<snip>
Wednesday's schedule has regular sessions until 13:20, unstructured time in the afternoon, and the plenary in the evening at 17:10. This leaves almost four hours of unstructured time for attendees to reserve for side meetings.
<end snip>

And part of your response is:

<snip>
The secretariat can't address the problem of too many (or too long) WG sessions,
<end snip>

Presumably the alternative could have been to have another slot in the afternoon on Wednesday for WG meetings – which would have provided more flexibility in avoiding conflicts.

Without taking sides, I think the question is whether the introduction of “unstructured time” is adding or subtracting value.

   Les

From: Recentattendees <[email-masked]> On Behalf Of Kyle Rose
Sent: Monday, February 25, 2019 12:26 PM
To: [email-masked]
Cc: WG Chairs <[email-masked]>; [email-masked]; IETF Discussion Mailing List <[email-masked]>; IETF Announcement List <[email-masked]>; [email-masked]
Subject: Re: [Recentattendees] [104all] Further Clarification Re: IETF 104 Preliminary Agenda

2. There is some combination of too few slots, too many (or too long) WG session requests, and not enough information about meaningful conflicts to construct a viable schedule.

#2 is a problem that the secretariat can partially address through changes to the conflict declaration process. For example, by allowing chairs to specify *individuals* who need to be at particular sessions because they're presenting or are heavily involved in work, rather than via the working group proxy, which may (and does IME) encode preference as well as need, may become stale over the course of meetings, and often fails to capture critical conflicts. This is a hard problem, but if it's possible to get a viable schedule for the requested WG sessions given the number of slots, there is a solution.

The secretariat can't address the problem of too many (or too long) WG sessions, because it's a judgment call on the part of those involved in the WGs. Perhaps sponsoring ADs can get more involved in deciding whether a WG really needs to consume an official meeting slot, or whether they really need as much time as requested for in-person work. This is also a hard problem, but if we're going to make the most efficient use of limited official in-person meeting time, hard choices will need to be made. (IMO, leave the draft status updates to the mailing list. Use the meeting for issues chosen in advance that will benefit from in-person discussion and collaboration.)

#1, by contrast, is an easy problem to solve. Your WG can be assigned to a slot anywhere from Monday to Friday at the secretariat's discretion. Therefore: don't schedule your return trip until late on Friday at the earliest, or don't complain when you are scheduled to leave before the meeting ends. Which is on Friday. Seems straightforward.

Kyle

On Sat, Feb 23, 2019 at 12:08 AM IETF Agenda <[email-masked]<mailto:[email-masked]>> wrote:
Hi everyone,

Thanks,
IETF Secretariat

--
104all mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/104all

---

From: Kyle Rose <[email-masked]>
Date: Mon, 25 Feb 2019 15:56:13 -0500

On Mon, Feb 25, 2019 at 3:45 PM Les Ginsberg (ginsberg) <[email-masked]>
wrote:

> *<snip>*
> *Wednesday's schedule has regular sessions until 13:20, unstructured time
> meetings.*
> *<end snip>*
> *<snip>*
> *The secretariat can't address the problem of too many (or too long) WG
> sessions,*
>
> *<end snip>*
>
>
>
> Presumably the alternative could have been to have another slot in the
> afternoon on Wednesday for WG meetings – which would have provided more
> flexibility in avoiding conflicts.
>

No contest. I should have listed that as a third issue.

> Without taking sides, I think the question is whether the introduction of
> “unstructured time” is adding or subtracting value.
>

It really seems like we're trying to stuff too much into 5 days. (When you
have 5 lbs of manure and a 4 lbs bag...) Were side meetings in the
mornings, evenings, or during slots without important sessions not working?
Are there groups that really are too busy to skip less important sessions
in favor of collaborative side work? (E.g., there are WGs I *like* to
attend, but when it conflicts with some work I *need* to do, I know where
I'm going to be. These 3 weeks per year are precious, and with every
session being recorded, anything I'm passively consuming gets watched
later.) It's not like the entire IETF needs to collaborate in the same
place at the same time, so I'm skeptical of the need for slots dedicated to
unstructured work.

That said, even with the addition of Wednesday afternoon to the available
slots, the crunch would still exist. The other two issues need to be
addressed.

Kyle

---

From: Ted Lemon <[email-masked]>
Date: Mon, 25 Feb 2019 16:02:37 -0500

On Feb 25, 2019, at 3:56 PM, Kyle Rose <[email-masked]> wrote:
> It really seems like we're trying to stuff too much into 5 days. (When you have 5 lbs of manure and a 4 lbs bag...) Were side meetings in the mornings, evenings, or during slots without important sessions not working? Are there groups that really are too busy to skip less important sessions in favor of collaborative side work? (E.g., there are WGs I *like* to attend, but when it conflicts with some work I *need* to do, I know where I'm going to be. These 3 weeks per year are precious, and with every session being recorded, anything I'm passively consuming gets watched later.) It's not like the entire IETF needs to collaborate in the same place at the same time, so I'm skeptical of the need for slots dedicated to unstructured work.

The problem is that everyone has _different_ conflicts.   Coming up with a time when everybody is available for any value of “everybody” greater than about three is quite difficult.   So no, not the entire IETF, but that’s an extreme example of the actual problem.

---

From: Kyle Rose <[email-masked]>
Date: Mon, 25 Feb 2019 16:24:34 -0500

On Mon, Feb 25, 2019 at 4:02 PM Ted Lemon <[email-masked]> wrote:

> The problem is that everyone has _different_ conflicts.   Coming up with a
> time when everybody is available for any value of “everybody” greater than
> about three is quite difficult.   So no, not the entire IETF, but that’s an
> extreme example of the actual problem.
>

How widespread of a problem is this? Most of the groups I'm involved in
comprise folks who have the same conflicts I do, because we're all working
in the same general areas. There are also 5 mornings and 4 or 5 evenings
(if you count Sunday) available for cross-functional collaborative work
that can't fit elsewhere. I suppose some attendees are enough in-demand
that those are all spoken for, but if those folks are outliers, I'm not
sure their needs should drive meeting policy. To figure this out, we really
need some survey of the attendees to find out how *uniquely* helpful the
unstructured time slots are to resolving conflicts for collaboration.

---

From: Jared Mauch <[email-masked]>
Date: Mon, 25 Feb 2019 16:32:24 -0500

> On Feb 25, 2019, at 4:24 PM, Kyle Rose <[email-masked]> wrote:
> 
> How widespread of a problem is this? Most of the groups I'm involved in comprise folks who have the same conflicts I do, because we're all working in the same general areas. There are also 5 mornings and 4 or 5 evenings (if you count Sunday) available for cross-functional collaborative work that can't fit elsewhere. I suppose some attendees are enough in-demand that those are all spoken for, but if those folks are outliers, I'm not sure their needs should drive meeting policy. To figure this out, we really need some survey of the attendees to find out how *uniquely* helpful the unstructured time slots are to resolving conflicts for collaboration.
> 

I think there’s challenges that many of us face from being overcommitted or over-interested in areas that previously we could have done more by focusing.  We also need the cross-pollination so we don’t end up with decisions happening devoid from expertise gained by other teams (eg: operations, security, transport).

Sometimes being a WG tourist can be useful (JMAP is an example of a group I visited to get a quick summary of what’s going on) while there’s other WG’s that have really disturbing things occurring when it comes to areas where a cross-wg approach would be useful.  Maybe there’s a library or existing way/method to achieve the goal you’re desiring without the complex overhead.

I’m trying to not call out the WG’s where sometimes disturbing things happen, but it’s an ongoing problem of getting the proper feedback about realities in handling of security, operational realities and other critical items that impact how things interoperate.  It’s too large for someone to know how to do it all anymore.

- Jared

PS. If you’re rain man and get it all, then good for you, this isn’t the norm.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 25 Feb 2019 16:33:49 -0500

Kyle Rose <[email-masked]> wrote:
    > mornings,

Yes, that's true.

    > evenings, or during slots without important sessions not working? Are there
    > groups that really are too busy to skip less important sessions in favor of
    > collaborative side work? (E.g., there are WGs I *like* to attend, but

Yes.  Don't forget a bunch of other things that occur:
  * nomcom (March meeting... selecting a new chair, who might want to chat
           with previous chairs... )
  * talking to and selecting new chairs, document authors, etc.
  * talking to new Area Directors

Breakfast meetings have already eated up all the mgmt-type people.
Our lunch hours are already full of various talks and briefings, to the point
that I basically bring a protein bar, and eat a bigger breakfast.

    > when it
    > conflicts with some work I *need* to do, I know where I'm going to be. These
    > 3 weeks per year are precious, and with every session being recorded,
    > anything I'm passively consuming gets watched later.) It's not like the
    > entire IETF needs to collaborate in the same place at the same time, so I'm
    > skeptical of the need for slots dedicated to unstructured work.

If not for the side meetings, and attending the meetings that I *like* to
attend, we wouldn't really need to have in-person meetings three times a
year.  Everything could be accomplished with virtual-interim meetings of the
core people involved (doing the work).

The reason the in-person meetings are valuable is because
* they allow new people to become "core" people
* they allow cross-WG issues (and commonalitities) to be discovered and
worked upon.
* they provide enough bandwidth to discuss new work (both side-meetings,
  and BarBOFs, and actual BOFs)

The thing that has occured is that we actually are now too busy to
attend things we *like* while still having some unstructured time.
That's why the Wednesday afternoon experiment.
Unstructured time is really really really important, because it is
essentially what we can't do online.
In particular, this includes just hanging out at the bar/cafe/lounge/etc.
and *overhearing* a conversation that turns out to be relevant.
I'd hazard that 80% of really relevant new work comes from this.

I keep suggesting more 1-hr slots, with the option to ask for three of them,
but this schedule is full of 2-hr slots.  It doesn't work for gong-shows
like 6man and secdispatch and the like, but for many other groups, I think
that there should be more virtual interims.  This is already happening.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 25 Feb 2019 11:36:36 -1000

> On Feb 25, 2019, at 10:33 AM, Fred Baker <[email-masked]> wrote:
> 
> 
> 

While a neat idea, it’s not currently possible because I don’t save any private data. And while no user is associated with that data, (I don’t even create users), it is something that could be collected anonymously in the future. There’s a lot that could be done with anonymous statistics or even creating actual users (like automatic blue sheet sign in using Bluetooth LE Proximity sensors or locating colleagues or subscribing to notifications), but I haven’t had time to think through the GDPR implications.

Tom

---

From: Ted Lemon <[email-masked]>
Date: Mon, 25 Feb 2019 16:45:30 -0500

> How widespread of a problem is this? Most of the groups I'm involved in comprise folks who have the same conflicts I do, because we're all working in the same general areas. There are also 5 mornin…

I don’t know, unfortunately.   :]

But consider how it goes when there’s a BoF you’re tempted to attend.

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 25 Feb 2019 21:48:11 +0000

(cutting down the cc list...)

> unstructured time slots are to resolving conflicts for collaboration.

FWIW, I am a fan of unstructured time (but would prefer it
early mornings:-). My main reason is I think we do waste a
lot of expensive f2f time in WG sessions and could do better
organising ourselves. That may turn out correct or not, but
I do think it's a defensible proposition, worth testing if
the IESG wanna experiment with that.

That said, I think Kyle makes some reasonable points above,
except that it is far too early to survey people to see if
they do like unstructured time. This is the 2nd experiment
and the first, involving a Friday, was never gonna work I
reckon. Perhaps this one will fail too, but we can't yet
know. Maybe a survey after 3-4 meetings like this would be
good.

I'd also echo calls for the IESG to flag up the specific
schedule experiments a bit earlier, but I'm still ok with
those happening, despite the conflicts that ensue. (And
FWIW the draft agenda conflicts this time seem no worse
to me, for me. YMMV of course.)

Cheers,
S.

---

From: Ted Lemon <[email-masked]>
Date: Mon, 25 Feb 2019 16:51:31 -0500

On Feb 25, 2019, at 4:33 PM, Michael Richardson <[email-masked]> wrote:
> It doesn't work for gong-shows
> like 6man and secdispatch and the like

Which brings up the question, why do we have gong shows?   If something can’t attract any support on the mailing list, why are we spending extremely expensive meeting time sleeping while someone gives a presentation on it?   Because let’s be honest, that’s what’s going on—this is why there’s so much typing on laptops during WG sessions. 

Why aren’t we spending that time working on stuff that we’re actually working on?

---

From: Kent Watsen <[email-masked]>
Date: Mon, 25 Feb 2019 22:11:15 +0000

> On Feb 25, 2019, at 10:30 AM, Ted Lemon <[email-masked]> wrote:
> 
> On Feb 25, 2019, at 6:11 AM, Loa Andersson <[email-masked] <mailto:[email-masked]>> wrote:

With awareness of the urgency, and as opportunity redo the scheduling requests, some chairs may 
be able to reduce their request (length and/or number of sessions) and/or eliminate some conflicts.

Kent

---

From: Ted Lemon <[email-masked]>
Date: Mon, 25 Feb 2019 17:17:15 -0500

> be able to reduce their request (length and/or number of sessions) and/or eliminate some conflicts.

Hm.   When I was a WG chair, I generally knew how much budget I had on my schedule, and I was always keenly aware of the shortage of meeting time at IETF, and was careful to only ask for as much as I needed.   So it’s hard to see how I would have been able to help.   Perhaps other WG chairs ask for as much time as possible, though, and so perhaps this could have some useful effect.

One thing I noticed in Bangkok was that several of the meetings I attended didn’t use their full time slot, and indeed got larger slots than they asked for.   So mcr’s theory about shorter slots seems valid to me.

---

From: Fred Baker <[email-masked]>
Date: Mon, 25 Feb 2019 17:03:06 -0800

Puzzling about the CC line, and have reduced it somewhat. I am a paid attendee at IETF 104, and got a bounce from [email-masked] saying that mere mortals can't post to it.

> On Feb 25, 2019, at 1:36 PM, Tom Pusateri <[email-masked]> wrote:

OK, I'm confused. There is this app, which runs on IOS or Android. I don't know where the data is stored, but I know I can tell it what WGs I care about and it will be displayed both on my phone, and on my laptop in a calendar called "IETFers". If it can get from my phone to my calendar on my laptop, it can get to somewhere else. I'm suggesting that the "somewhere else" might anonymize the data and summarize it in some useful way.

Is that "every IETFer?" No. But I'll bet it's a large sample...

---

From: Tom Pusateri <[email-masked]>
Date: Mon, 25 Feb 2019 15:15:31 -1000

> On Feb 25, 2019, at 3:03 PM, Fred Baker <[email-masked]> wrote:
> 

You gave permission for IETFers to have read/write access to a calendar. Your other devices also have access to that calendar. In most cases, that calendar is private to you. In some cases, you may decide to share it with others. There is no access to that calendar information to the general public. And the IETF wouldn’t know where to look for it. And what I was trying to communicate is that while the app has access to that calendar, it doesn’t know who you are and that information never leaves the app so I can’t summarize it in any way.

Tom

---

From: Loa Andersson <[email-masked]>
Date: Tue, 26 Feb 2019 09:33:55 +0800

Ted,

On 2019-02-25 23:30, Ted Lemon wrote:
> How would they do that?   What information do they have now that they 
> didn’t have before they published the agenda?

I didn't say there is new any new information AFTER the agenda was
posted. The new info is the preliminary agenda itself! I you look at
MPLS and LSR meeting across the lunch slot on Wednesday, we have some
key participants of the MPLS wg, required to be in the LSR wg meeting.

I'm really unhappy about the current agenda.

What I said was that IESG should refocus in the light of the many
conflicts and redo the agenda with the objective to avoid conflicts.

/Loa
> 
> I ask because in fact, this agenda is the least conflicted one /for 
> me/ that I have seen in a long time.   I’m /really/ happy with the 
> current agenda, and can really only lose from a re-do.   This is not to 
> say that a re-do is not the right thing to do.   What I’m saying is that 
> the fact that a couple of people have griped about conflicts and about 
> an over-full agenda is /not data./   It is /anecdata/.
> 
> As Stewart has said, if we want to do better at this, we need /data, 
> /not /anecdata./
> /
> /

--

---

From: Mark Andrews <[email-masked]>
Date: Tue, 26 Feb 2019 12:36:16 +1100

> On 26 Feb 2019, at 12:15 pm, Tom Pusateri <[email-masked]> wrote:
> 
> 
> 

I’m thinking Fred is asking for the app to send the set of working groups selected somewhere (after asking).  It would need some sufficiently large random token so that updates can replace old data.  

-- 
Mark Andrews, ISC
1 Seymour St., Dundas Valley, NSW 2117, Australia
PHONE: +61 2 9871 4742              INTERNET: [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Mon, 25 Feb 2019 20:48:36 -0500

> conflicts and redo the agenda with the objective to avoid conflicts.

I got that.   The thing is, how do you know that if they reshuffle, it won’t cause me a similarly bad conflict?  I’m not saying they shouldn’t reshuffle if they have good data. I’m saying they don’t have good data.  The fact that you have a conflict is not good data.   It’s an anecdote.   I don’t have a conflict.   That’s also an anecdote.   Anecdotes aren’t useful guidance here.

---

From: Michael Richardson <[email-masked]>
Date: Tue, 26 Feb 2019 07:48:29 -0500

Ted Lemon <[email-masked]> wrote:
    > they have good data. I’m saying they don’t have good data. The fact
    > that you have a conflict is not good data. It’s an anecdote. I don’t
    > have a conflict.
    > That’s also an anecdote. Anecdotes aren’t useful guidance here.

I also think that the RTG area has had very good conflict resolution in the
past, and that they don't have a lot of cross-area participants.  That is,
this agenda, which for many of us, is average for conflicts, is very
surprising for some RTG area people, because they suddendly are experiencing
what the rest of us have experienced for a decade.

---

From: Василий Долматов <[email-masked]>
Date: Wed, 27 Feb 2019 10:35:20 +0300

Agreed…

There are number of options for side meetings which can be used and IETF could assist in organizing it.

For instance - to reserve rooms on Saturday-Sunday-Friday_afternoon_ for possible use for side meetings.

I agree that IETF time should be used for IETF mostly and any modifications in the schedule should lower number of conflicts between IETF WG meetings.

dol@

> 25 февр. 2019 г., в 18:29, Greg Mirsky <[email-masked]> написал(а):
> 
> Dear All,
> I'm disappointed to find that the number of conflicts for me at IETF-104 is as high as in Bangkok which was two times higher than at any meeting before. I'm stressed that I'll have to run from DetNet to BFD to deliver presentations on work being done, forget being able to follow the discussion adequately. If that's the new normal, then why to come to the meeting at all. 
> I strongly encourage IESG to let us use all available time for WG sessions and let attendees use their time for "corridor talks".
> 
> Regards,
> Greg
> 
> 
> 
> 
> On Fri, Feb 22, 2019 at 9:08 PM IETF Agenda <[email-masked] <mailto:[email-masked]>> wrote:
> Hi everyone,
> 
> [1]  https://mailarchive.ietf.org/arch/msg/ietf-announce/_JeP2fQ7rHPosZWpNtpl8I_uL5U <https://mailarchive.ietf.org/arch/msg/ietf-announce/_JeP2fQ7rHPosZWpNtpl8I_uL5U>
> [2]  https://mailarchive.ietf.org/arch/msg/ietf-announce/H64AuTYhxsGqM1a8BfTkszCZyso <https://mailarchive.ietf.org/arch/msg/ietf-announce/H64AuTYhxsGqM1a8BfTkszCZyso>
> [3]  https://www.ietf.org/blog/ietf104-bofs/ <https://www.ietf.org/blog/ietf104-bofs/>
> 
> -- 
> 104all mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/104all <https://www.ietf.org/mailman/listinfo/104all>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 27 Feb 2019 11:49:59 -0500

Tom Pusateri <[email-masked]> wrote:
    >> An even better approach, although it delays feedback by one meeting,
    >> would be to look into the IETFers Application data. People list what
    >> they want to attend for the purpose of calendar maintenance. That would
    >> inform the next meeting's agenda development.

    > While a neat idea, it’s not currently possible because I don’t save any
    > private data. And while no user is associated with that data, (I don’t
    > even create users), it is something that could be collected anonymously
    > in the future. There’s a lot that could be done with anonymous
    > statistics or even creating actual users (like automatic blue sheet
    > sign in using Bluetooth LE Proximity sensors or locating colleagues or
    > subscribing to notifications), but I haven’t had time to think through
    > the GDPR implications.

Your GDPR concerns are a good point.
I don't think we need to go to BTLE to see if you are actually there.
In particular, that fails to catch the case where people wanted to be there.

Among those of us that don't use your app, but rather use the datatracker ics
creation tool, we should have data in the logs about what people selected.
Alas, Google calendar does not you edit the calendar URL, so it's hard to
update what you want to add/remove items.  So I added a layer of indirection:

cd /ssw/docs/SSW/ietf/meeting/ietf104

curl -s >agenda.ics 'https://datatracker.ietf.org/meeting/104/agenda.ics#6lo,6man,6tisch,dnssd,homenet,lwig,gaia,hrpc,v6ops,opsawg,netconf,dnsop,anima,babel,bier,roll,tokbind,teep,suit,secevent,secdispatch,rats,ipsecme,ace,acme,dots,lamps,core,cbor,capport,cacao,ksk,smart'

and I add this agenda.ics file to my calendar program(s).
agenda.html takes the WG names as #foo,bar, while agenda.ics takes them as ?foo,bar)

What this does *not* tell you is which items I added for "like", and which
ones I added because it's a must attend.  Also I admit that this time I just
copy and pasted from last time, and added a few things.

In particular, part of this exercise is for me to see what conflicts I have.
I wish I could intelligently subscribe to a calendar entry such that I'd get
updates if it moved, but actually have it in my calendar, not have a new
calendar.  Instead, I'm force to copy entries to my calendar to remember how
I've decided to resolve the conflict, and that breaks the updates (such as
room changes).  I suppose I should use your app and star things, but it's
just too many moving parts :-)