Subject: The anti-harassment policy has gone missing on the Web site.

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 25 Apr 2019 16:33:34 -0400

I just spent five minutes trying to find the anti-harassment / open
participation statement on the new Web site. Like many other things, I can
no longer find it.

Point is that this is something participants need to see even if they are
not looking for it.

---

From: Russ Housley <[email-masked]>
Date: Thu, 25 Apr 2019 16:39:00 -0400

https://www.ietf.org/blog/ietf-anti-harassment-policy/ <https://www.ietf.org/blog/ietf-anti-harassment-policy/>

> From: Phillip Hallam-Baker <[email-masked] <mailto:[email-masked]>>
> Subject: The anti-harassment policy has gone missing on the Web site.
> Date: April 25, 2019 at 4:33:34 PM EDT
> To: IETF Discussion Mailing List <[email-masked] <mailto:[email-masked]>>, IETF Chair <[email-masked] <mailto:[email-masked]>>
> 
> I just spent five minutes trying to find the anti-harassment / open participation statement on the new Web site. Like many other things, I can no longer find it.
> 
> Point is that this is something participants need to see even if they are not looking for it.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Thu, 25 Apr 2019 16:45:49 -0400

My point is that this the people I want to read this are the people who
would never think to search for it.

On Thu, Apr 25, 2019 at 4:39 PM Russ Housley <[email-masked]> wrote:

> https://www.ietf.org/blog/ietf-anti-harassment-policy/
>
>
> *From: *Phillip Hallam-Baker <[email-masked]>
> *Subject: **The anti-harassment policy has gone missing on the Web site.*
> *Date: *April 25, 2019 at 4:33:34 PM EDT
> *To: *IETF Discussion Mailing List <[email-masked]>, IETF Chair <
> [email-masked]>
>

---

From: Allison Mankin <[email-masked]>
Date: Thu, 25 Apr 2019 16:46:59 -0400

The link to IESG statement  cited in RFC 7776 (the anti harassment
procedures BCO) is a 404 now:

 [Policy]   IESG, "IETF Anti-Harassment Policy",
              <https://www.ietf.org/iesg/statement/
<https://www.ietf.org/iesg/statement/ietf-anti-harassment-policy.html>
              ietf-anti-harassment-policy.html
<https://www.ietf.org/iesg/statement/ietf-anti-harassment-policy.html>>.

---

From: Russ Housley <[email-masked]>
Date: Thu, 25 Apr 2019 16:55:25 -0400

I agree.  There is a plan to improve the parts of the web site that have IESG statements and implementation reports.  This task was just given to the Tools Team, and we are workin on the design.  This is an area where the Wagtail content management system has let us down, and we will probably release the changes back to the Wagtail code base.

Russ

> On Apr 25, 2019, at 4:45 PM, Phillip Hallam-Baker <[email-masked]> wrote:
> 
> My point is that this the people I want to read this are the people who would never think to search for it.
> 
> On Thu, Apr 25, 2019 at 4:39 PM Russ Housley <[email-masked] <mailto:[email-masked]>> wrote:

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 25 Apr 2019 21:56:04 +0100

It’s important.

I searched using the built-in function…

https://www.ietf.org/search/?query=harass

Several hits are relevant.

You’ll also find the IESG statement.

Adrian

From: ietf <[email-masked]> On Behalf Of Phillip Hallam-Baker
Sent: 25 April 2019 21:34
To: IETF Discussion Mailing List <[email-masked]>; IETF Chair <[email-masked]>
Subject: The anti-harassment policy has gone missing on the Web site.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 26 Apr 2019 10:29:38 -0400

Yes, I know how that happens, it is not fun getting this sort of thing
right. I am having similar difficulties with my own site.

I think the statement itself needs to be prominent in the 'about us'
section of the site. The point of such a statement is not what it says but
that it is made and that everyone sees it. From a purely functional point
of view, an anti harassment policy statement that starts 'Lorem ipsum'
transfers the same information.

Its like a software license, I don't actually have to read it to know what
it is going to say.

On Thu, Apr 25, 2019 at 4:55 PM Russ Housley <[email-masked]> wrote:

> I agree.  There is a plan to improve the parts of the web site that have
> IESG statements and implementation reports.  This task was just given to
> the Tools Team, and we are workin on the design.  This is an area where the
> Wagtail content management system has let us down, and we will probably
> release the changes back to the Wagtail code base.
>
> Russ
>
>

---

From: "Pete Resnick" <[email-masked]>
Date: Fri, 26 Apr 2019 09:41:42 -0500

Having IESG Statements appear under the Blog and News seems 
inappropriate, and the scrolling sidebar to look through them makes them 
quite difficult to look through. These really shouldn't appear as just 
random blogable thoughts that the IESG once had. Many of them are quite 
important policies and procedures. A proper index page to IESG 
Statements, and of course fixing the old links to work, should really be 
a top priority to fix.

pr

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 26 Apr 2019 15:37:15 +0000

*   I think the statement itself needs to be prominent in the 'about us' section of the site.

Strong +1 for thisk.

---

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 26 Apr 2019 15:47:37 +0000

As input to the Tools Team working on the design – this may be worthy of inclusion in the page footer for the site. I know many companies will have a footer item “Policies” which then takes you to a page with links off to privacy/data collection, code of conduct/harassment, etc. Another that may be good for the footer is Trademarks / Copyrights.

  *   Jason

From: ietf <[email-masked]> on behalf of Russ Housley <[email-masked]>
Date: Thursday, April 25, 2019 at 4:56 PM
To: Phillip Hallam-Baker <[email-masked]>
Cc: IETF <[email-masked]>
Subject: Re: The anti-harassment policy has gone missing on the Web site.

Russ

On Apr 25, 2019, at 4:45 PM, Phillip Hallam-Baker <[email-masked]<mailto:[email-masked]>> wrote:

On Thu, Apr 25, 2019 at 4:39 PM Russ Housley <[email-masked]<mailto:[email-masked]>> wrote:
https://www.ietf.org/blog/ietf-anti-harassment-policy/

From: Phillip Hallam-Baker <[email-masked]<mailto:[email-masked]>>
Subject: The anti-harassment policy has gone missing on the Web site.
Date: April 25, 2019 at 4:33:34 PM EDT
To: IETF Discussion Mailing List <[email-masked]<mailto:[email-masked]>>, IETF Chair <[email-masked]<mailto:[email-masked]>>

---

From: Alexa Morris <[email-masked]>
Date: Fri, 26 Apr 2019 11:48:53 -0700

Hi Allison,

Yes, unfortunately at the moment there are a number of links that will 404. This is a recent development that has to do with the integration of the Wagtail CMS with other IETF services and tools. I want to specifically note that the issues do not reflect a problem with Wagtail per se, nor are they the fault of volunteers or staff. However, there are conflicting directives that are causing issues, and a corrective clean-up is required.

In order to avoid extended periods of slowness due to server restarts and testing, this project will proceed at a slower than normal pace; Glen, AMS IT Director, will start on Monday morning and it's anticipated to take 2-3 days.  While there should be no downtime during the clean-up, there are likely to be periods of perceived sluggishness with www and the Datatracker. 

Alexa

> On Apr 25, 2019, at 1:46 PM, Allison Mankin <[email-masked]> wrote:
> 
> The link to IESG statement  cited in RFC 7776 (the anti harassment procedures BCO) is a 404 now:
> 
>  [Policy <>]   IESG, "IETF Anti-Harassment Policy",
>               <https://www.ietf.org/iesg/statement/ <https://www.ietf.org/iesg/statement/ietf-anti-harassment-policy.html>
>               ietf-anti-harassment-policy.html <https://www.ietf.org/iesg/statement/ietf-anti-harassment-policy.html>>.
> 
>

---

From: Allison Mankin <[email-masked]>
Date: Fri, 26 Apr 2019 16:30:24 -0400

Hi Alexa,

Thanks for the update.  I wrote mostly because of having so much experience
pointing people to the ombudsteam related links, and very much appreciate
your constructive detail on this!

Allison

On Fri, Apr 26, 2019 at 2:48 PM Alexa Morris <[email-masked]> wrote:

> Hi Allison,
>
> Yes, unfortunately at the moment there are a number of links that will
> 404. This is a recent development that has to do with the integration of
> the Wagtail CMS with other IETF services and tools. I want to specifically
> note that the issues do not reflect a problem with Wagtail per se, nor are
> they the fault of volunteers or staff. However, there are conflicting
> directives that are causing issues, and a corrective clean-up is required.
>
> In order to avoid extended periods of slowness due to server restarts and
> testing, this project will proceed at a slower than normal pace; Glen, AMS
> IT Director, will start on Monday morning and it's anticipated to take 2-3
> days.  While there should be no downtime during the clean-up, there are
> likely to be periods of perceived sluggishness with www and the
> Datatracker.
>
> Alexa
>
>

---

From: Russ Housley <[email-masked]>
Date: Mon, 29 Apr 2019 18:46:31 -0400

The website cleanup is underway, and the previous redirect is working again.  Others are still being worked.

https://www.ietf.org/iesg/statement/ietf-anti-harassment-policy.html <https://www.ietf.org/iesg/statement/ietf-anti-harassment-policy.html> has now been fixed and does work, redirecting correctly to the IESG statement.

The Cloudflare CDN node nearest to you may still have something else in its cache.  That will get sorted in the next few hours.

As I said earlier in this thread, the work on moving the IESG statement out of the blog requires the Toole Team to develop some code for Wagtail.  That work will begin shortly.

Russ

> On Apr 26, 2019, at 4:30 PM, Allison Mankin <[email-masked]> wrote:
> 
> Hi Alexa,
> 
> Thanks for the update.  I wrote mostly because of having so much experience pointing people to the ombudsteam related links, and very much appreciate your constructive detail on this!  
> 
> Allison
> 
> On Fri, Apr 26, 2019 at 2:48 PM Alexa Morris <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Allison,
> 
>> On Apr 25, 2019, at 1:46 PM, Allison Mankin <[email-masked] <mailto:[email-masked]>> wrote:
>>