Subject: Re: [MMUSIC] Last Call: <draft-ietf-mmusic-rfc4566bis-34.txt> (SDP: Session Description Protocol) to Proposed Standard

From: Magnus Westerlund <[email-masked]>
Date: Thu, 11 Apr 2019 08:14:26 +0000

MMUSIC WG, Document Editors

In the processing of draft-ietf-mmusic-data-channel-sdpneg-25 an interesting question arose regarding text strings in SDP attribute values.

Currently the document says:

4.5.  Internationalization

   The SDP specification recommends the use of the ISO 10646 character
   set in the UTF-8 encoding [RFC3629] to allow many different languages
   to be represented.  However, to assist in compact representations,
   SDP also allows other character sets such as ISO 8859-1 to be used
   when desired.  Internationalization only applies to free-text sub-
   fields (session name and background information), and not to SDP as a
   whole.

If one like to include UTF-8 field for attributes it would be good if
the requirement would be clear going forward that there is an expectancy
that at least parser can process any UTF-8 strings that may occur in any
fields.

That would allow future SDP field values to use UTF-8 strings without risks
and simplify processing. Like in the case of the data channel SDP mapping
where the extra step of encoding lable characters not visually safe as escaped
characters could be avoided.

Does anyone have input if making such a change would have significant impact on
the interoperability?

Cheers

Magnus

On 2019-03-22 15:46, The IESG wrote:

The IESG has received a request from the Multiparty Multimedia Session
Control WG (mmusic) to consider the following document: - 'SDP: Session
Description Protocol'
  <draft-ietf-mmusic-rfc4566bis-34.txt> as Proposed Standard

The IESG plans to make a decision in the next few weeks, and solicits final
comments on this action. Please send substantive comments to the
[email-masked]<mailto:[email-masked]> mailing lists by 2019-04-12. Exceptionally, comments may be
sent to [email-masked]<mailto:[email-masked]> instead. In either case, please retain the beginning of
the Subject line to allow automated sorting.

Abstract

   This memo defines the Session Description Protocol (SDP).  SDP is
   intended for describing multimedia sessions for the purposes of
   session announcement, session invitation, and other forms of
   multimedia session initiation.  This document obsoletes RFC 4566.

The file can be obtained via
https://datatracker.ietf.org/doc/draft-ietf-mmusic-rfc4566bis/

IESG discussion can be tracked via
https://datatracker.ietf.org/doc/draft-ietf-mmusic-rfc4566bis/ballot/

No IPR declarations have been submitted directly on this I-D.

_______________________________________________
mmusic mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mmusic

--

Magnus Westerlund

----------------------------------------------------------------------
Network Architecture & Protocols, Ericsson Research
----------------------------------------------------------------------
Ericsson AB                 | Phone  +46 10 7148287
Torshamnsgatan 23           | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden | mailto: [email-masked]<mailto:[email-masked]>
----------------------------------------------------------------------

---

From: "Roni Even (A)" <[email-masked]>
Date: Thu, 11 Apr 2019 10:04:41 +0000

Hi Magnus,
I think it will affect the IANA registries where values may be shared with non SDP attribute. For example the sub-protocol in the IANA WebSocket Subprotocol name registry

Roni Even

From: mmusic [mailto:[email-masked]] On Behalf Of Magnus Westerlund
Sent: Thursday, April 11, 2019 11:14 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [MMUSIC] Last Call: <draft-ietf-mmusic-rfc4566bis-34.txt> (SDP: Session Description Protocol) to Proposed Standard

   whole.

fields.

the interoperability?

Cheers

Magnus

Description Protocol'

Abstract

mmusic mailing list

--

Magnus Westerlund

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 11 Apr 2019 12:08:47 -0400

On 4/11/19 4:14 AM, Magnus Westerlund wrote:
> In the processing of draft-ietf-mmusic-data-channel-sdpneg-25 an 
> interesting question arose regarding text strings in SDP attribute values.
> 

I'm inclined to just say that attribute values are limited to values 
that are natively representable in the chosen charset. That will impose 
limitations on use with charsets more limited than UTF-8.

	Thanks,
	Paul

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 12 Apr 2019 08:59:48 +0000

Hi,

To be clear, I am not proposing that any existing attribute would be forced to suddenly accept UTF-8 strings with no charset restriction. Simply that new attribute's values can be defined to be UTF-8 in general. I think the important distinction here is that a parser must be ready to accept any UTF-8 character as the sender can't know if a particular charset limitation applies to a specific consumer. However, in form I don't see a problem of the SDP itself informing the consumer that there is a charset limitation applied in this document.

My interpretation of the current situation is that it we hesitate to use UTF-8 fields due to the uncertainty in the requirements on consumers of SDP.

Cheers

Magnus Westerlund
(As Individual)

On 2019-04-11 12:05, Roni Even (A) wrote:
Hi Magnus,
I think it will affect the IANA registries where values may be shared with non SDP attribute. For example the sub-protocol in the IANA WebSocket Subprotocol name registry

Roni Even

From: mmusic [mailto:[email-masked]] On Behalf Of Magnus Westerlund
Sent: Thursday, April 11, 2019 11:14 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [MMUSIC] Last Call: <draft-ietf-mmusic-rfc4566bis-34.txt> (SDP: Session Description Protocol) to Proposed Standard

   whole.

fields.

the interoperability?

Cheers

Magnus

Description Protocol'

Abstract

mmusic mailing list

--

Magnus Westerlund

--

Magnus Westerlund