Subject: Secdir last call review of draft-ietf-calext-eventpub-extensions-12

From: Rich Salz via Datatracker <[email-masked]>
Date: Mon, 22 Apr 2019 11:14:21 -0700

Reviewer: Rich Salz
Review result: Has Nits

This is the SECDIR last-call review, intended to be input to the Security AD's.

Ready with nits.

The Security Considerations and Privacy Considerations are short, but they seem
to reasonably refer to already-published documents.

Following are nits I noticed.

Abstract "a number of new iCalendar properties and components" -> "a new
iCalendar component and a number of properties"  Maybe stike "iCalendar"

Sec 1, STRUCTURED-DATA. In my opinion the confirmation code would be the most
useful new info :)

Sec 1, SOURCE Is it redefined or extended?

Sec 2, para 2.  "In a break with this 'tradition' ..." --> "Breaking with this
practice, ..."

Sec 3, "When a calendar client receives a calendar component" Should the second
calendar be CALENDAR? Should the first be "iCalendar"?

Sec 3.1.1, uppercase "vcard"?

Sec 3.1.2.1 "non of which" --> "none of which"

Sec 4 Perhaps add a sentence saying where this syntax is defined. Is this the
complete iCalendar spec or is it just changing a few things?

Sec 5.1, etc "as laid down in" Is kind of informal wording.

Sec 6, the notation has "value=URI" but the example has "URL" (Sec 7.3, etc.,
uses URI in both parts)

Sec 10, "applications using" Is "acting on" better?

---

From: Daniel Migault <[email-masked]>
Date: Tue, 23 Apr 2019 13:02:42 +0000

Thanks for the review Rich!
Yours, 
Daniel

-----Original Message-----
From: Rich Salz via Datatracker <[email-masked]> 
Sent: Monday, April 22, 2019 2:14 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Secdir last call review of draft-ietf-calext-eventpub-extensions-12

Reviewer: Rich Salz
Review result: Has Nits

Ready with nits.

The Security Considerations and Privacy Considerations are short, but they seem to reasonably refer to already-published documents.

Abstract "a number of new iCalendar properties and components" -> "a new iCalendar component and a number of properties"  Maybe stike "iCalendar"

Sec 1, STRUCTURED-DATA. In my opinion the confirmation code would be the most useful new info :)

Sec 2, para 2.  "In a break with this 'tradition' ..." --> "Breaking with this practice, ..."

Sec 3, "When a calendar client receives a calendar component" Should the second calendar be CALENDAR? Should the first be "iCalendar"?

Sec 4 Perhaps add a sentence saying where this syntax is defined. Is this the complete iCalendar spec or is it just changing a few things?

Sec 6, the notation has "value=URI" but the example has "URL" (Sec 7.3, etc., uses URI in both parts)

---

From: Michael Douglass <[email-masked]>
Date: Tue, 23 Apr 2019 10:56:35 -0400

Thanks for the comments:

All useful - and yes - I'll add the confirmation code.

I'll incorporate these changes