Subject: Call for Input: BCP 83 PR-Action Against Pradeep Kumar Xplorer

From: Adam Roach <[email-masked]>
Date: Fri, 3 May 2019 16:08:55 -0500

The ART area directors have received a request from several individuals to
revoke the posting rights to IETF mailing lists of Pradeep Kumar Xplorer as
per the procedures in BCP 83 (RFC 3683).

The IESG plans to make a decision in the next few weeks, and solicits final
comments on this action. Please send substantive comments to the 
[email-masked]
mailing lists by 2019-03-17. Exceptionally, comments may be sent to
[email-masked] instead. In either case, please retain the Subject line to 
allow
automated sorting.

PLEASE NOTE: Comments should be limited to the criteria described in BCP 83,
specifically in this case whether the person has posted "discussion of
subjects unrelated to IETF policy, meetings, activities, or technical
concerns" or "unprofessional commentary, regardless of the general subject",
and whether such posts have had an effect to "disrupt the consensus-driven
process." In particular, IT IS INAPPROPRIATE TO MAKE COMMENTS ABOUT THE
POSTER'S STATE OF MIND WHILE MAKING THESE POSTS OR WHETHER THE POSTS 
HAVE SOME
BROADER MEANING OUTSIDE OF THE IETF PROCESS. The questions posed by this 
Last
Call are whether the posts are off-topic, whether the posts disrupt the
process, and whether the PR-action is the appropriate remedy.

The following is an incomplete sampling of messages that have been 
identified
as being potentially off-topic and disrupting:

https://mailarchive.ietf.org/arch/msg/ietf-smtp/CneRIG1vjNNbFYPW-z7mtUXe8Ik
https://mailarchive.ietf.org/arch/msg/ietf-smtp/ZOczccDHvHHpD6XaYc_UFLTPrYQ
https://mailarchive.ietf.org/arch/msg/ietf-smtp/hErM9rufrp_qaj8CAHF96itK84I
https://mailarchive.ietf.org/arch/msg/ietf-smtp/1r0EIqqHCkDgwR32w3MuBSWrOc0
https://mailarchive.ietf.org/arch/msg/http-auth/-KvTfv1sl6Z7QSKBHNaKg0UYw28
https://mailarchive.ietf.org/arch/msg/art/kT3lDkJvhKeFXSVZaJaXfyXNT24
https://mailarchive.ietf.org/arch/msg/art/iqARH4h-OkNdQ7eeziUl66sLFqk
https://mailarchive.ietf.org/arch/msg/art/k46FrrbEaYzCkKetjL1SapZ6Jq0
https://mailarchive.ietf.org/arch/msg/art/7eovYBGvWq-yLmlUgIBCX2fqST0
https://mailarchive.ietf.org/arch/msg/art/Xw3anU69JWowFQvpbA8NNVsCASI
https://mailarchive.ietf.org/arch/msg/art/CDwYKiVjwbVNJXD_OyYFc2K91q4

/Adam Roach

---

From: Jared Mauch <[email-masked]>
Date: Fri, 3 May 2019 19:27:47 -0400

Aside from the date below (I assume it was a typo), this seems appropriate after reviewing the sampling of messages.

- Jared

> On May 3, 2019, at 5:08 PM, Adam Roach <[email-masked]> wrote:
> 
> comments on this action. Please send substantive comments to the [email-masked]
> [email-masked] instead. In either case, please retain the Subject line to allow
> automated sorting.
> 
> POSTER'S STATE OF MIND WHILE MAKING THESE POSTS OR WHETHER THE POSTS HAVE SOME
> BROADER MEANING OUTSIDE OF THE IETF PROCESS. The questions posed by this Last
> The following is an incomplete sampling of messages that have been identified

---

From: Job Snijders <[email-masked]>
Date: Fri, 3 May 2019 18:40:00 -0500

Dear Adam, others,

I’ve reviewed BCP83 and the messages you referenced. I believe the postings
are off topic and disrupt the IETF process, the proposed PR action is
appropriate.

I wish the involved people all the best.

Kind regards,

Job

---

From: Adam Roach <[email-masked]>
Date: Fri, 3 May 2019 18:42:12 -0500

Apologies; yes, the date should have read "2019-05-17." Thanks for the 
correction.

/a

---

From: Kurt Andersen <[email-masked]>
Date: Fri, 3 May 2019 17:12:25 -0700

Ditto (from a small virtual keyboard)

On Fri, May 3, 2019, 16:40 Job Snijders <[email-masked]> wrote:

> Dear Adam, others,
>
> I’ve reviewed BCP83 and the messages you referenced. I believe the
> postings are off topic and disrupt the IETF process, the proposed PR action
> is appropriate.
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 4 May 2019 13:06:07 +1200

Agreed. At least one of the sampled messages clearly breaches personal privacy as well as normal decency and should probably be deleted from the archive as quickly as possible to avoid legal issues.

Regards
   Brian Carpenter

On 04-May-19 12:12, Kurt Andersen wrote:
> On Fri, May 3, 2019, 16:40 Job Snijders <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Dear Adam, others,
> 
>     I’ve reviewed BCP83 and the messages you referenced. I believe the postings are off topic and disrupt the IETF process, the proposed PR action is appropriate.
> 
>     On Fri, May 3, 2019 at 16:09 Adam Roach <[email-masked] <mailto:[email-masked]>> wrote:
> 
>         [email-masked] <mailto:[email-masked]>
>         [email-masked] <mailto:[email-masked]> instead. In either case, please retain the Subject line to
>         allow
>         automated sorting.
>

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 3 May 2019 20:33:15 -0700

+1

Regards,
Jeff

> On May 3, 2019, at 16:27, Jared Mauch <[email-masked]> wrote:
>

---

From: John C Klensin <[email-masked]>
Date: Sat, 04 May 2019 00:38:43 -0400

Adam,

The necessity for this move saddens me, but I agree with those
who favor this action.   I would add to your list the suggestion
that much of the July 2018 thread on the IETF list that contains 
https://mailarchive.ietf.org/arch/msg/ietf/fo_yF-u0B7UE0qPGSurPilbGbak
Is off-topic for the IETF (that particular message appears to
call for Android software modifications) and some of those
messages, including
https://mailarchive.ietf.org/arch/msg/ietf/zs19Nz1KJmfAmKHPx4pX2hXaYwk
includes claims about person injuries that are even more clearly
off-topic for the IETF.  Continuing that discussion after being
told by several people, both on and off list clearly changes the
S/N ratio on the IETF list in negative directions and is hence
disruptive.

Other messages, while they contain some content that might be
relevant to the IETF, also contain considerable (well over 50%)
content that is irrelevant and, by its nature, disruptive.  See,
for example,
https://mailarchive.ietf.org/arch/msg/ietf/FE6vkL_Ego7-DDP-YhjeXn_FCJQ
or
https://mailarchive.ietf.org/arch/msg/ietf/Ohn5gHK3SU3HObz_axDzW3lS1qY
where the latter contains even less IETF-relevant material.

My point in mentioning the above is to point out that the
problem behavior has been going on for rather a long time and on
multiple IETF lists.

best,
   john

---

From: Leif Johansson <[email-masked]>
Date: Sat, 4 May 2019 10:04:48 +0200

Skickat från min iPhone

> 4 maj 2019 kl. 06:38 skrev John C Klensin <[email-masked]>:
> 
> Adam,
> 

+1

Well put John

---

From: Keith Moore <[email-masked]>
Date: Sat, 4 May 2019 09:06:12 -0400

IMO, the poster has sent numerous messages to IETF lists that violate 
the criteria mentioned below.  I support the proposed action.

On 5/3/19 5:08 PM, Adam Roach wrote:
> Comments should be limited to the criteria described in BCP 83,
> process."

---

From: Paul Wouters <[email-masked]>
Date: Sat, 4 May 2019 11:48:15 -0400

I have tried on-list advise and offlist advise on process and content of their email and it did not seem to have had any effect. So I sadly agree with the proposed action.

Paul

Sent from mobile device

> On May 4, 2019, at 09:06, Keith Moore <[email-masked]> wrote:
> 
> IMO, the poster has sent numerous messages to IETF lists that violate the criteria mentioned below.  I support the proposed action.
>

---

From: Loganaden Velvindron <[email-masked]>
Date: Sat, 4 May 2019 22:44:07 +0400

Please go ahead.

---

From: "Bron Gondwana" <[email-masked]>
Date: Sat, 04 May 2019 18:45:32 -0400

I also agree with the other chairs. I have had interactions with the individual which included both unprofessional commentary and insistence on continuing to discuss proposed work which he had been informed was not within the charter of the list on which he was posting.

Regards,

Bron.

--
 Bron Gondwana, CEO, FastMail Pty Ltd
 [email-masked]

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sat, 4 May 2019 22:34:33 -0500

I could say more, but John said what I needed to say, better than I would
have.

I find this appropropriate.

Best regards, of course.

Spencer

---

From: Bob Hinden <[email-masked]>
Date: Sun, 5 May 2019 10:20:11 -0700

I also looked at the posts, and agree with the conclusions and proposed action.

Bob

> On May 4, 2019, at 8:34 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> I could say more, but John said what I needed to say, better than I would have. 
>

---

From: "John R. Levine" <[email-masked]>
Date: 5 May 2019 14:09:03 -0400

> I also looked at the posts, and agree with the conclusions and proposed action.

I'm also forced to agree.  FYI he just sent some messages to the 
ietf-privacy list so it's an ongoing issue.

https://mailarchive.ietf.org/arch/msg/ietf-privacy/mJ6c5gnMfTiITM-LhI7h_7YXFMQ
https://mailarchive.ietf.org/arch/msg/ietf-privacy/9d4YubWvfIyc_Flqv65d6BboN7g

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: "Stan Kalisch" <[email-masked]>
Date: Sun, 05 May 2019 18:26:51 -0400

FWIW, Mr. Kumar Xplorer's postings (a number of which are included in the samples below) created enough difficulty for me in reviewing some mailing lists that I've already simply blackholed mail from any of his addresses that I could find.

Thanks,
Stan

---

From: Eric Burger <[email-masked]>
Date: Sun, 5 May 2019 20:52:37 -0400

I am not convinced “Kumar Xplorer” is a human. ‘He’ sent an email to a long-dead IETF mail list, with an incoherent body text, sent to a ton of non-human email addresses, only a few that resolve to ietf.org, that looked scraped from the Internet.

Let’s block the address and move on.

> On May 5, 2019, at 6:26 PM, Stan Kalisch <[email-masked]> wrote:
> 
>> https://mailarchive.ietf.org/arch/msg/ietf-smtp/CneRIG1vjNNbFYPW-z7mtUXe8Ik <https://mailarchive.ietf.org/arch/msg/ietf-smtp/CneRIG1vjNNbFYPW-z7mtUXe8Ik>
>> https://mailarchive.ietf.org/arch/msg/ietf-smtp/ZOczccDHvHHpD6XaYc_UFLTPrYQ <https://mailarchive.ietf.org/arch/msg/ietf-smtp/ZOczccDHvHHpD6XaYc_UFLTPrYQ>
>> https://mailarchive.ietf.org/arch/msg/ietf-smtp/hErM9rufrp_qaj8CAHF96itK84I <https://mailarchive.ietf.org/arch/msg/ietf-smtp/hErM9rufrp_qaj8CAHF96itK84I>
>> https://mailarchive.ietf.org/arch/msg/ietf-smtp/1r0EIqqHCkDgwR32w3MuBSWrOc0 <https://mailarchive.ietf.org/arch/msg/ietf-smtp/1r0EIqqHCkDgwR32w3MuBSWrOc0>
>> https://mailarchive.ietf.org/arch/msg/http-auth/-KvTfv1sl6Z7QSKBHNaKg0UYw28 <https://mailarchive.ietf.org/arch/msg/http-auth/-KvTfv1sl6Z7QSKBHNaKg0UYw28>
>> https://mailarchive.ietf.org/arch/msg/art/kT3lDkJvhKeFXSVZaJaXfyXNT24 <https://mailarchive.ietf.org/arch/msg/art/kT3lDkJvhKeFXSVZaJaXfyXNT24>
>> https://mailarchive..ietf.org/arch/msg/art/iqARH4h-OkNdQ7eeziUl66sLFqk <https://mailarchive..ietf.org/arch/msg/art/iqARH4h-OkNdQ7eeziUl66sLFqk>
>> https://mailarchive.ietf.org/arch/msg/art/k46FrrbEaYzCkKetjL1SapZ6Jq0 <https://mailarchive.ietf.org/arch/msg/art/k46FrrbEaYzCkKetjL1SapZ6Jq0>
>> https://mailarchive.ietf.org/arch/msg/art/7eovYBGvWq-yLmlUgIBCX2fqST0 <https://mailarchive.ietf.org/arch/msg/art/7eovYBGvWq-yLmlUgIBCX2fqST0>
>> https://mailarchive.ietf.org/arch/msg/art/Xw3anU69JWowFQvpbA8NNVsCASI <https://mailarchive.ietf.org/arch/msg/art/Xw3anU69JWowFQvpbA8NNVsCASI>
>> https://mailarchive.ietf.org/arch/msg/art/CDwYKiVjwbVNJXD_OyYFc2K91q4 <https://mailarchive.ietf.org/arch/msg/art/CDwYKiVjwbVNJXD_OyYFc2K91q4>
>> 
>> /Adam Roach

---

From: Eric Burger <[email-masked]>
Date: Sun, 5 May 2019 20:55:24 -0400

By “block the address," I mean IETF-wide, not just the IETF list. The bot is apparently attacking every list we host. It would be nice to turn it off once instead of having to manually do it on every list.

> On May 5, 2019, at 8:52 PM, Eric Burger <[email-masked]> wrote:
> 
> I am not convinced “Kumar Xplorer” is a human. ‘He’ sent an email to a long-dead IETF mail list, with an incoherent body text, sent to a ton of non-human email addresses, only a few that resolve to ietf.org <http://ietf.org/>, that looked scraped from the Internet.
> 
>> On May 5, 2019, at 6:26 PM, Stan Kalisch <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Michael StJohns <[email-masked]>
Date: Sun, 5 May 2019 21:07:46 -0400

After reviewing the list of messages provided, I'm impressed with the 
level of tolerance the various lists have extended to the poster so far.

I support a permanent PR action for this poster and suggest that if 
after the nominal year noted in RFC3683 the poster asks for restoration 
of rights, that some attempt be made to verify the poster is an actual 
identifiable human.

Mike

On 5/3/2019 5:08 PM, Adam Roach wrote:
> ...

---

From: "Stan Kalisch" <[email-masked]>
Date: Sun, 05 May 2019 22:11:38 -0400

On Sun, May 5, 2019, at 8:53 PM, Eric Burger wrote:
> I am not convinced “Kumar Xplorer” is a human. 

Maybe, maybe not. I think, though, that if one just applies the BCP 83 standard *vis a vis* disruption that that settles the matter, regardless.

Stan

> ‘He’ sent an email to a long-dead IETF mail list, with an incoherent body text, sent to a ton of non-human email addresses, only a few that resolve to ietf.org, that looked scraped from the Internet.
> 
>>> https://mailarchive..ietf.org/arch/msg/art/iqARH4h-OkNdQ7eeziUl66sLFqk
> *Attachments:*
>  * signature.asc

---

From: Nico Williams <[email-masked]>
Date: Mon, 6 May 2019 00:19:48 -0500

On Sun, May 05, 2019 at 09:07:46PM -0400, Michael StJohns wrote:
> After reviewing the list of messages provided, I'm impressed with the level
> of tolerance the various lists have extended to the poster so far.
> 
> I support a permanent PR action for this poster and suggest that if after
> the nominal year noted in RFC3683 the poster asks for restoration of rights,
> that some attempt be made to verify the poster is an actual identifiable
> human.

+1

---

From: Ólafur Gudmundsson <[email-masked]>
Date: Mon, 06 May 2019 13:21:05 +0700

I agree and support longer than one year ban

⁣Get BlueMail for Android ​

On May 6, 2019, 12:20, at 12:20, Nico Williams <[email-masked]> wrote:
>level
>after

---

From: John C Klensin <[email-masked]>
Date: Mon, 06 May 2019 06:35:02 -0400

--On Sunday, May 5, 2019 20:52 -0400 Eric Burger
<[email-masked]> wrote:

> I am not convinced "Kumar Xplorer" is a human. 'He'
> sent an email to a long-dead IETF mail list, with an
> incoherent body text, sent to a ton of non-human email
> addresses, only a few that resolve to ietf.org, that looked
> scraped from the Internet.

Eric,

Having corresponded with him privately and taken a few other
off-list actions some months ago in attempts to get the issues
this PR-request is about (and some others) under control, my
confidence that he is a real person (and that he is a "he") is
_extremely_ high.  Not as high as my confidence that you and
Adam are real and human (because I've never met anyone claiming
to be him face to face and shaken his hand, as I have with two
of you) but not more than one or two confidence-steps below that.

Even if I did not have that personal experience, he has
responded to some correspondence at a level of detail that
considerably exceeds what I know about the state of the art in
bots carrying on conversations with humans (it is, of courwe,
possible that the state of the art has advanced very
significantly since I was last paying attention). 

He has also, multiple times, copied messages and responses to
messages to IETF lists when the original messages were
explicitly sent privately  and has done so after being
asked/reminded to not do so.  While not called out in Adam's
note, that behavior also constitutes unprofessional and
disruptive behavior on IETF lists.

As Adam's note pointed out, his behavior, or behavior of someone
claiming to be him, in correspondence or on lists not connected
to the IETF is irrelevant to a BCP 83 PR-action.

> Let's block the address and move on.

Responding to this and Mike's suggestion about a permanent ban,
I think it is important that, when the IETF takes any action
that could be interpreted as disciplinary or punitive, we adhere
strictly to our own procedures, especially procedures that were
designed around reforming or correcting behavior rather than as
punishment.  That would apply in this case as well unless there
was much stronger evidence of bot (or other fake individual)
behavior than an analysis of the content and patterns of
messages would actually suggest and, obviously, no strong
evidence to the contrary.  Now, if we apply a PR action for a
year and he requests reauthorization, that latter should clearly
be considered carefully rather than automatically granted and,
if it should be granted, any unprofessional (or otherwise
rule-violating) behavior after that time should be met with
little or zero tolerance.  But that low level of tolerance would
clearly be consistent with our rules and procedures.

best,
    john

---

From: Michael StJohns <[email-masked]>
Date: Mon, 6 May 2019 11:55:31 -0400

On 5/6/2019 6:35 AM, John C Klensin wrote:

> punishment.

John - As I read it, BCP 83 PR action IS a permanent ban with the 
possibility of parole or commutation after a year.  That's all I meant 
by "Permanent PR" action.    In this case, many attempts - including 
yours - have been made to attempt to reform and correct the poster's 
behavior.  The poster has shown no evidence of any attempt to conform to 
the necessary behavioral parameters after many attempts to make him 
understand those parameters, making a permanent ban within the meaning 
of BCP83 appropriate.

Mike

The relevant text is:

> Once taken, this action remains in force until explicitly nullified
>     and SHOULD remain in force for at least one year.
>
>     One year after the PR-action is approved, a new PR-action MAY be
>     introduced which restores the posting rights for that individual.
>     The IESG SHOULD consider the frequency of nullifying requests when
>     evaluating a new PR-action.  If the posting rights are restored the
>     individual is responsible for contacting the owners of the mailing
>     lists to have them restored.

---

From: Rich Kulawiec <[email-masked]>
Date: Tue, 7 May 2019 11:07:01 -0400

On Sun, May 05, 2019 at 08:55:24PM -0400, Eric Burger wrote:
> The bot is apparently attacking every list we host. It would be nice
> to turn it off once instead of having to manually do it on every list.

I offer no opinion on whether this is a bot or not, but within the
last day I observed a very similar message from the same sender on
one of the W3C mailing lists (semantic-web).

---rsk

---

From: Mary B <[email-masked]>
Date: Tue, 7 May 2019 11:08:16 -0500

Obviously, I fully support this decision having dealt with him on the ART
list - he definitely posted discussions on unrelated topics and it was
definitely unprofessional.

Regards,
Mary