Subject: Call for Community Input: Web Analytics on www.ietf.org

From: Roman Danyliw <[email-masked]>
Date: Tue, 21 May 2019 15:17:58 +0000

Hi!

The Internet Engineering Steering Group (IESG) is seeking community input on implementing web analytics on www.ietf.org ("the website"). 

There is currently no accurate data reported about visits to the website.  For example, it is not possible to understand: which pages are most commonly visited; which paths visitors travel to find IETF meeting registration pages; or whether introductory information, such as tutorials, leads to further exploration of website content. Web analytics would provide insight into overall utilization and inform future improvements to the website.

In consultation with the tools team, Greg Wood developed an implementation plan to integrate a self-hosted analytics package into the existing infrastructure.  The full details of this proposal are available at:

https://www.ietf.org/iesg/docs/www.ietf.org-AnalyticsProposal-forReview.pdf

The IESG appreciates any input from the community on this proposal and will consider all input received by June 4, 2019.

Regards,
Roman
(as the IESG Tools Liaison)

---

From: Paul Wouters <[email-masked]>
Date: Tue, 21 May 2019 11:27:49 -0400 (EDT)

> The IESG appreciates any input from the community on this proposal and will consider all input received by June 4, 2019.

I'm a bit confused that tools.ietf.org is not included. It's where I go
mostly to read RFCs. (in fact, I google "rfc XXX tools" to not get any
ancient www.ietf.org text versions but the proper html version on
tools.ietf.org".

> Providing a publicly-available summary of analytics data will be explored.

Since I'm part of the data collection, it makes sense to me to see the
end summary. I see no reason this should be restricted to the IESG and
IETF Secretariat - unless you don't trust your anonymization ?

Otherwise, the plan looks fine to me.

Paul

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 21 May 2019 16:43:13 +0100

On 21/05/2019 16:17, Roman Danyliw wrote:
>  The IESG appreciates any input from the community on this proposal
> and will consider all input received by June 4, 2019.

More tracking;-(

I don't think this is particularly harmful though
and do accept that people are trying to do the
right thing, but I'd argue to not bother with it
myself.

Assuming you do go ahead with it:

- 13 months seems like a long time to keep logs.
  What will be in those logs? Why 13 months?

- I don't understand what IP address anonymisation
  is planned. [1] has options, and doesn't explain
  what happens with IPv6.

- I'd prefer if information was deleted as soon as
  possible, and it's not clear to me that that is
  the plan.

- Do the IESG plan to evaluate the utility of this
  with the possibility to ditch it if it doesn't
  in fact tell us something useful? If so, when?
  How will you decide if it's worth keeping?

- Will this new information be shared with anyone
  else (e.g. ISOC as allowed for in [2]).

- Does this constitute tracking behaviour? The
  current privacy policy [2] says we don't do that.

- To whom should I send my GDPR subject data access
  request? I guess [email-masked] is it?

There's no rush in getting answers to the above
btw.

Thanks,
S.

[1]
https://matomo.org/docs/privacy/#step-1-automatically-anonymize-visitor-ips
[2] https://www.ietf.org/privacy-statement/

> 
> Regards, Roman (as the IESG Tools Liaison)
> 
>

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 21 May 2019 16:51:39 +0100

I agree that tools and datatracker should be included; while the "main" site is important, they are the critical resources that most people interact with.

For performance monitoring, are we going to be measuring the server-side view of page generation time, or from the client (i.e. using RUM)?

Collecting errors -- e.g., JavaScript exceptions, those reported by CSP and similar facilities -- is extremely useful for finding problems on the site. Will we be doing that?

Cheers,

> On 21 May 2019, at 4:27 pm, Paul Wouters <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 21 May 2019 16:00:23 +0000

>    I agree that tools and datatracker should be included; while the "main" site is important, they are the critical resources that most people interact with.
  
I believe the community that uses datatracker is, mostly, different from the community that uses the main website. What is the point of doing analytics -- which community are we mainly trying to assess and improve?  I believe datatracker has a broad enough input channel for improvement and should be left out of this effort.

I will be sad on the day that the IETF puts up a "we use cookies" GDPR notification.  I share Stephen's mild concerns about tracking and privacy.

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 21 May 2019 17:04:08 +0100

Frankly, I want to track how long it takes to generate pages on them, because my perception of the performance is that it's pretty bad. I don't care about tracking users from page to page, etc.

Cheers,

> On 21 May 2019, at 5:00 pm, Salz, Rich <[email-masked]> wrote:
>

---

From: Miles Fidelman <[email-masked]>
Date: Tue, 21 May 2019 14:07:17 -0400

Seems like a good idea to me.  Ahh.. remember the days when lots of 
sites would post analytics?

Miles Fidelman

-- 
In theory, there is no difference between theory and practice.
In practice, there is.  .... Yogi Berra

Theory is when you know everything but nothing works.
Practice is when everything works but no one knows why.
In our lab, theory and practice are combined:
nothing works and no one knows why.  ... unknown

---

From: Roman Danyliw <[email-masked]>
Date: Wed, 22 May 2019 15:24:16 +0000

Hi Paul!

> -----Original Message-----
> From: Paul Wouters [mailto:[email-masked]]
> Sent: Tuesday, May 21, 2019 11:28 AM
> To: Roman Danyliw <[email-masked]>
> Cc: [email-masked]
> Subject: Re: Call for Community Input: Web Analytics on www.ietf.org
> 
> > The IESG appreciates any input from the community on this proposal and
> will consider all input received by June 4, 2019.
> 
> I'm a bit confused that tools.ietf.org is not included. It's where I go mostly to
> read RFCs. (in fact, I google "rfc XXX tools" to not get any ancient
> www.ietf.org text versions but the proper html version on tools.ietf.org".

If the analytics meet their intent, the desired would be expand them across all of the web properties (e.g., tools.ietf, datatracker.ietf).  However, in the spirit of starting with a smaller scope and getting operational experience, www.ietf was chosen as an initial target.

> Since I'm part of the data collection, it makes sense to me to see the end
> summary. I see no reason this should be restricted to the IESG and IETF
> Secretariat - unless you don't trust your anonymization ?

Agreed.  This hesitance is a matter of not overcommitting, and getting initial operational experience with this new approach to gather usage data.  Incomplete stats are currently shared at [1].

Thanks for the feedback.

Roman

[1] https://www.ietf.org/usagedata/

---

From: Paul Wouters <[email-masked]>
Date: Wed, 22 May 2019 12:02:22 -0400 (EDT)

> If the analytics meet their intent, the desired would be expand them across all of the web properties (e.g., tools.ietf, datatracker.ietf).  However, in the spirit of starting with a smaller scope…

Okay, but my example shows 
> Agreed.  This hesitance is a matter of not overcommitting, and getting initial operational experience with this new approach to gather usage data.  Incomplete stats are currently shared at [1].

Ok. Fair enough.

> [1] https://www.ietf.org/usagedata/

Ironically, that page connects to www.google-analytics.com :)

Paul

---

From: Keith Moore <[email-masked]>
Date: Wed, 22 May 2019 12:25:52 -0400

> The IESG appreciates any input from the community on this proposal and will consider all input received by June 4, 2019.

The main concern I have is: be careful how you use the statistics.   For 
instance, don't interpret the frequency that a page is used, by itself, 
as an indicator of the importance of that page.  If a page is visited 
often, it might mean the page is important, or it might mean that the 
page is getting in the way - a needless extra click or a dead end at 
which people give up. Similarly, if a page is not visited often, it 
might still be important - it might be a page that helps the rare user 
who needs an answer to a very important question.

There's an unfortunate tendency everywhere these days to place faith in 
data that's easy to collect but not a good indication of what is wanted, 
because the information really wanted is hard to collect.   ("Where did 
you lose your keys?"  "Inside the house." "Then why are you looking for 
them under the streetlight?"  "The light is better here.")

Keith

---

From: Roman Danyliw <[email-masked]>
Date: Wed, 22 May 2019 18:48:20 +0000

> From: ietf [mailto:[email-masked]] On Behalf Of Keith Moore
> Sent: Wednesday, May 22, 2019 12:26 PM
> To: [email-masked]
> > The Internet Engineering Steering Group (IESG) is seeking community input
> on implementing web analytics on www.ietf.org ("the website").
> >
> > There is currently no accurate data reported about visits to the website.
> For example, it is not possible to understand: which pages are most
> commonly visited; which paths visitors travel to find IETF meeting registration
> pages; or whether introductory information, such as tutorials, leads to
> further exploration of website content. Web analytics would provide insight
> into overall utilization and inform future improvements to the website.
> >
> > In consultation with the tools team, Greg Wood developed an
> implementation plan to integrate a self-hosted analytics package into the
> existing infrastructure.  The full details of this proposal are available at:
> >
> instance, don't interpret the frequency that a page is used, by itself, as an
> indicator of the importance of that page.  If a page is visited often, it might
> mean the page is important, or it might mean that the page is getting in the
> way - a needless extra click or a dead end at which people give up. Similarly, if
> a page is not visited often, it might still be important - it might be a page that
> helps the rare user who needs an answer to a very important question.
> 
> because the information really wanted is hard to collect.   ("Where did you
> lose your keys?"  "Inside the house." "Then why are you looking for them
> under the streetlight?"  "The light is better here.")

Your caution is noted.  Next to nothing is comprehensively collected now so the proposal is positioning for future decision making on the basis of usage data.

Roman

---

From: Roman Danyliw <[email-masked]>
Date: Wed, 22 May 2019 18:53:59 +0000

> From: Mark Nottingham [mailto:[email-masked]]
> Sent: Tuesday, May 21, 2019 12:04 PM
> To: Salz, Rich <[email-masked]>
> Cc: Roman Danyliw <[email-masked]>; [email-masked]
> Frankly, I want to track how long it takes to generate pages on them,
> because my perception of the performance is that it's pretty bad. I don't care
> about tracking users from page to page, etc.

I can pass this back to the tools team.  This type of performance measurement is not in scope for this web analytics proposal.

Roman

> >>   I agree that tools and datatracker should be included; while the "main"
> site is important, they are the critical resources that most people interact
> with.
> >
> > I believe the community that uses datatracker is, mostly, different from the
> community that uses the main website. What is the point of doing analytics --
> which community are we mainly trying to assess and improve?  I believe
> datatracker has a broad enough input channel for improvement and should
> be left out of this effort.
> >
> > I will be sad on the day that the IETF puts up a "we use cookies" GDPR
> notification.  I share Stephen's mild concerns about tracking and privacy.
> >
> >
> 
> --

---

From: Roman Danyliw <[email-masked]>
Date: Wed, 22 May 2019 19:00:14 +0000

> From: Roman Danyliw
> Sent: Wednesday, May 22, 2019 2:54 PM
> To: 'Mark Nottingham' <[email-masked]>; Salz, Rich <[email-masked]>
> Cc: [email-masked]
> Subject: RE: Call for Community Input: Web Analytics on www.ietf.org
> 
> 
> 
> > because my perception of the performance is that it's pretty bad. I
> > don't care about tracking users from page to page, etc.
> 
> I can pass this back to the tools team.  This type of performance
> measurement is not in scope for this web analytics proposal.

I was imprecise.  Sorry.  Page generation time will be collected but the currently planned set of reports that will analyze it would not focus on performance analysis.

Roman

> > site is important, they are the critical resources that most people
> > interact with.
> > >
> > community that uses the main website. What is the point of doing
> > analytics -- which community are we mainly trying to assess and
> > improve?  I believe datatracker has a broad enough input channel for
> > improvement and should be left out of this effort.
> > >

---

From: Keith Moore <[email-masked]>
Date: Wed, 22 May 2019 16:31:42 -0400

> Your caution is noted.  Next to nothing is comprehensively collected now so the proposal is positioning for future decision making on the basis of usage data.

The site is so poorly organized now (at least from the perspective of a 
30-year IETF participant) that I have to wonder how meaningful any 
statistics based on this site will be.   There may be a temptation to 
use the statistics to justify small incremental changes to the site when 
a complete redesign is needed.    Will the statistics provide any 
indication of that?

Keith

---

From: Roman Danyliw <[email-masked]>
Date: Wed, 22 May 2019 20:49:12 +0000

Hi Stephen!

A few answers below.

> From: Stephen Farrell [mailto:[email-masked]]
> Sent: Tuesday, May 21, 2019 11:43 AM
> To: Roman Danyliw <[email-masked]>; [email-masked]
> I don't think this is particularly harmful though and do accept that people are
> trying to do the right thing, but I'd argue to not bother with it myself.
> 

I'll have to follow-up later with the details.

>   How will you decide if it's worth keeping?

In the "Implementation" section the proposal notes that "[f]ollowing finalization and implementation of the proposal, ...  the web analytics and reports will be reviewed by the IETF Tools Team after one-year to confirm they are delivering anticipated results."  The IETF Tools Team will bring a recommendation to the IESG.  Whether these analytics are worth keeping will be determined by whether they informed site improvement (as outlined in the "Introduction" section).

>   else (e.g. ISOC as allowed for in [2]).

The proposal outlines that the "IETF Secretariat, communications staff, and the IESG" will get access through an "analytics data dashboard"; and a "publicly-available summary of analytics data will be explored" to improve upon https://www.ietf.org/usagedata/.
 
I'll have to follow-up on the additional users (ISOC) implied by [2].

>   current privacy policy [2] says we don't do that.

My read is no.

[3] says that "tracking is the collection of data regarding a particular user's activity across multiple distinct contexts and the retention, use, or sharing of data derived from that activity outside the context in which it occurred. A context is a set of resources that are controlled by the same party or jointly controlled by a set of parties."

*.ietf.org servers are single context controlled by the same party (IETF).  The proposed implementation plan is a self-hosted solution which does indeed collect activity data but NOT across "multiple, distinct contexts".

>   request? I guess [email-masked] is it?

Correct.

Roman

> There's no rush in getting answers to the above btw.
> 
> Thanks,
> S.
> 
> [1]

[3] https://www.w3.org/TR/tracking-dnt/

---

From: Roman Danyliw <[email-masked]>
Date: Wed, 22 May 2019 21:02:10 +0000

> Sent: Wednesday, May 22, 2019 4:32 PM
> To: [email-masked]
> > Your caution is noted.  Next to nothing is comprehensively collected now so
> the proposal is positioning for future decision making on the basis of usage
> data.
> 
> The site is so poorly organized now (at least from the perspective of a 30-
> year IETF participant) that I have to wonder how meaningful any statistics
> based on this site will be.   There may be a temptation to use the statistics to
> justify small incremental changes to the site when a complete redesign is
> needed.    Will the statistics provide any indication of that?

The analytics will describe how the web-site is used today.  For example:
** overall number of visitors;
** views per webpage;
** time spent on pages;
** traffic sources; and
** aggregated visitor profiles
** visitors’ paths through the site

These metrics would not directly answer an incremental change vs. complete redesign question.  However, they will provide accurate and rich usage data that should be the input into decision process on how improve the effectiveness of the site.

Roman

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 22 May 2019 22:20:35 +0100

Hiya,

On 22/05/2019 21:49, Roman Danyliw wrote:
>> - Does this constitute tracking behaviour? The current privacy
>> policy [2] says we don't do that.
> My read is no.
> 
> [3] says that "tracking is the collection of data regarding a
> particular user's activity across multiple distinct contexts and the
> retention, use, or sharing of data derived from that activity outside
> the context in which it occurred. A context is a set of resources
> that are controlled by the same party or jointly controlled by a set
> of parties."
> 
> *.ietf.org servers are single context controlled by the same party
> (IETF).  The proposed implementation plan is a self-hosted solution
> which does indeed collect activity data but NOT across "multiple,
> distinct contexts".

(Re-)identification over time would I guess represent "multiple
distinct contexts." If you geo-locate the addresses e.g. at a
country level then that's not anonymous - .mu and .ie would not
be hard to translate into people's names given the relevant
population sizes. These are just more reasons to minimise the
data being collected and stored. (Did I already say I'd go for
zero of both? :-) And while I'm sure the IESG would be aware
of that, these things can get lost between the people who want
it done a certain way and the people who end up doing the doing
who may be more used to customers being more invasive than us;-)

S.

---

From: John C Klensin <[email-masked]>
Date: Wed, 22 May 2019 18:32:34 -0400

Roman,

Your response actually raises (at least for me) some additional
questions (saving for later issues on which you have promised
details later)...

--On Wednesday, May 22, 2019 20:49 +0000 Roman Danyliw
<[email-masked]> wrote:

>...
>...
 
> In the "Implementation" section the proposal notes that
> "[f]ollowing finalization and implementation of the proposal,
> ...  the web analytics and reports will be reviewed by the
> IETF Tools Team after one-year to confirm they are delivering
> anticipated results."  The IETF Tools Team will bring a
> recommendation to the IESG.  Whether these analytics are worth
> keeping will be determined by whether they informed site
> improvement (as outlined in the "Introduction" section).

I'm still not clear as to why this effort is needed at all.  I
am sympathetic to Keith Moore's observations which I read as
being about collecting measurements and doing statistics that
are easy rather than digging down far enough to determine which
are needed for specific purposes, and then figuring out how, if
possible, to gather those statistics and keeping them as focused
as possible.  Gathering data because we can, because tools are
readily available to capture certain data, and then passing it
off to the Tools Team to figure out what it is good for (or
whether it provided "anticipated results" without that being
specified in advance) does not strike me as a good way to
proceed.  It also violates the most basic of privacy protection
principles, which is that data that are not collected are data
one don't have to worry about securing, retention times, etc.

It seems to me that the first step in this process should be a
clear statement from the Tools Team or other decision makers
about how they expect to use the data and what data are needed
for that purpose.  That expectation is supported by a statement
in the Proposal that says "website analytics must be implemented
to ... ● limit data being collected to that needed to serve
specific identified purposes".  The first two items in the list
of data to be reported are:
  ● overall number of visitors;
  ● views per webpage;

Why do we care?  If, e.g.,
https://www.ietf.org/about/groups/iesg/members/ does not attract
as much traffic as, e.g.,
https://www.ietf.org/how/meetings/upcoming/ does that mean we
are going to take it down?  Redesign it with more animation in
the hope of drawing additional traffic?  That is a silly
example, but I trust the problem is clear.  

The next paragraph starts "After considering several options for
implementing analytics,...", which sounds a lot like we have
skipped over "why" and "what" to get to "how".

However, assuming for purposes of discussion that this is really
needed for some useful purpose...

> The proposal outlines that the "IETF Secretariat,
> communications staff, and the IESG" 
>...

I note that the Tools Team, who are explicitly called out as
getting the data, are, except for individual coincidences, not
part of the IETF Secretariat, the communications staff (I think
I know who/what that means, but am not sure), or the IESG, so
the list of parties with whom information is shared is a
superset of that list even before ISOC staff is considered.  It
is also interesting that neither the IETF LLC Exec Director nor
the IETF LLC Board are on the list of people to be given access
to the data, something that would probably make it hard to
evaluate the results and utility of this work.  Given that this
sort of thing isn't free even if we (volunteers or the
Secretariat) maintain the software on our own equipment, I'd
hope that sort of evaluation would be part of any ongoing effort.

>>   current privacy policy [2] says we don't do that.

reporting
● traffic sources; and
● aggregated visitor profiles (including OS, browser, and
primary languages)
● visitors' paths through the site (including time spent on
webpages, as well as
entry and exit pages

Certainly sounds like tracking behavior to me.   I'm interested
in why you don't read it that way because we may have different
definitions.

> particular user's activity across multiple distinct contexts
> and the retention, use, or sharing of data derived from that
> activity outside the context in which it occurred. A context
> is a set of resources that are controlled by the same party or
> jointly controlled by a set of parties."

By this definition, one can do just about anything one likes to
capture information about user behavior as long as that user
doesn't leave "a context" and then defining "context" in an
appropriately broad way.  In particular...

> *.ietf.org servers are single context controlled by the same
> party (IETF).  The proposed implementation plan is a
> self-hosted solution which does indeed collect activity data
> but NOT across "multiple, distinct contexts".

Really?  First, whether *.ietf.org servers are "controlled by
the same party" is questionable.  One could suggest that they
are "controlled by" some combination of the IETF LCC, AMS, the
Tool Team, and maybe some "cloud" or "CDN" suppliers.  Perhaps
at least some of those relationships are tightly enough
specified contractually to make the control by the IETF LLC (not
the IESG) clear, but "the IETF" (as a community of participants)
doesn't know enough about the details of those contracts to be
confident about that.  And, unless the Tools Team started being
subject to Close Technical Supervision while I wasn't looking,
pages in ietf.org subdomains they control and manage cannot be
said to be "controlled by" the IETF.
 
IMO, lots of loose ends here.  From my point of view, the most
important is why we actually need to do this, what we hope to
accomplish, and, from those things, what data we actually need.
The "information to be collected" part of the proposal is not
especially helpful in this regard.  Some of the comments do help
in imagining what is intended and why, but I don't think we
should need to imagine.

best,
   john

---

From: S Moonesamy <[email-masked]>
Date: Thu, 23 May 2019 09:54:35 -0700

Hi Roman,
At 08:17 AM 21-05-2019, Roman Danyliw wrote:
>The Internet Engineering Steering Group (IESG) is seeking community 
>input on implementing web analytics on www.ietf.org ("the website").

I assume that the proposed change(s) will not materially impact the 
existing privacy statement or else there would be a prompt 
notification of the changes.

It is the first time I see "communication staff" (Page 4 of the 
proposal) being used.  I could not figure out the reason for giving 
those external parties access to non-public information as it is not 
clear how it is liked to the intended purposes.

One of the software providers describes one of the methods listed on 
Page 3 as tracking. The existing privacy statement defines several 
parties. They do not fit within the "context" {1] definition.  It is 
not clear whether tracking is being proposed or not.

Regards,
S. Moonesamy

1. A context is a set of resources that are controlled by the same 
party or jointly controlled by a set of parties.

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 24 May 2019 02:41:23 +0000

Hi Stephen!

A few more detailed answers inline:

> Sent: Wednesday, May 22, 2019 4:49 PM
> To: Stephen Farrell <[email-masked]>; [email-masked]

[snip]

> >   What will be in those logs? Why 13 months?

The motivation for 13 months is to have data for one annual cycle of IETF meetings.

I'm still tracking down an explicit log entry example.  The classes of data it would entail are in the proposal.

> >   is planned. [1] has options, and doesn't explain

See https://github.com/matomo-org/matomo/commit/c072a0e5911b544890a39e86c9efe024bb2475.  This reference describes the IPv4 and IPv6 anonymization options in a single table.  Level 2 is the initial thinking.

Roman

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 24 May 2019 02:41:21 +0000

Hi Stephen!

> Sent: Wednesday, May 22, 2019 5:21 PM
> >> - Does this constitute tracking behaviour? The current privacy policy
> >> [2] says we don't do that.
> > My read is no.
> >
> > the context in which it occurred. A context is a set of resources that
> > are controlled by the same party or jointly controlled by a set of
> > parties."
> >
> (Re-)identification over time would I guess represent "multiple distinct
> contexts." If you geo-locate the addresses e.g. at a country level then that's
> not anonymous - .mu and .ie would not be hard to translate into people's
> names given the relevant population sizes. These are just more reasons to
> minimise the data being collected and stored. (Did I already say I'd go for
> zero of both? :-) And while I'm sure the IESG would be aware of that, these
> things can get lost between the people who want it done a certain way and
> the people who end up doing the doing who may be more used to
> customers being more invasive than us;-)

Even if the this re-identification was done, it still wouldn't by my read constitute tracking per [3] because of the second clause about "retention, use or sharing ... outside of the context in which it occurred".  The underlying data is staying in the same context (i.e., ietf.org).

Now irrespective of the interpretation relative to [3], Matomo has all variety of capabilities for re-identification primarily to enable "unique visitor" metrics.  This is done with an explicit user ID added by the tracking API, cookies, and/or fingerprinting.  The proposal explicitly rules out the use of the user ID and cookies.  The fingerprint is "operating system, browser, browser plugins, [anonymized] IP address and browser language".  See [4] and [5] more details per Matomo's documentation.

Roman

[4] https://matomo.org/faq/general/#faq_43  
[5] https://matomo.org/faq/general/faq_21418/

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 24 May 2019 02:41:26 +0000

Hi Mark,

> Sent: Tuesday, May 21, 2019 11:52 AM
> I agree that tools and datatracker should be included; while the "main" site is
> important, they are the critical resources that most people interact with.

Agreed.  {tools, datatracker}.ietf would be next steps if the current approach proves itself on the smaller scope of www.ietf.

> For performance monitoring, are we going to be measuring the server-side
> view of page generation time, or from the client (i.e. using RUM)?

The details on how Matomo approaches page generation can be found here:

https://matomo.org/docs/page-speed/

The implementation choice between tracking API and Javascript will constrain how the measurement is done.  

> Collecting errors -- e.g., JavaScript exceptions, those reported by CSP and
> similar facilities -- is extremely useful for finding problems on the site. Will we
> be doing that?

This is likely possible with the tool, but isn't considered in scope for this proposal.

Roman

> > I'm a bit confused that tools.ietf.org is not included. It's where I
> > go mostly to read RFCs. (in fact, I google "rfc XXX tools" to not get
> > any ancient www.ietf.org text versions but the proper html version on
> > tools.ietf.org".
> >

---

From: Hector Santos <[email-masked]>
Date: Fri, 24 May 2019 12:01:35 -0400

On 5/21/2019 12:04 PM, Mark Nottingham wrote:
> Frankly, I want to track how long it takes to generate pages on them, because my perception of the performance is that it's pretty bad.
>
> Cheers,

+1.  Whatever the reasons, I think it has been pretty slow over the 
years. Nothing new. It always was.

-- 
HLS

---

From: Dick Franks <[email-masked]>
Date: Fri, 24 May 2019 22:00:48 +0100

On Wed, 22 May 2019 at 21:32, Keith Moore <[email-masked]>
wrote:
> > Your caution is noted.  Next to nothing is comprehensively collected
now so the proposal is positioning for future decision making on the basis
of usage data.
> a complete redesign is needed. ...

+1   The present design is positively grotesque

>   ... Will the statistics provide any
> indication of that?

Weighing and measuring frustrated users digging through a mountain of
waffle to find anything useful, provides little insight into how a better
design would perform.

--Dick

---

From: Keith Moore <[email-masked]>
Date: Fri, 24 May 2019 17:06:00 -0400

On 5/24/19 5:00 PM, Dick Franks wrote:

> waffle to find anything useful, provides little insight into how a 
> better design would perform.

exactly.

I'm sorely tempted to set up my own site for IETF participants, with 
links to the resources that people who actually work in IETF, need.  
Rather than fluff.

(or maybe such a thing could be on the tools site?)

PR is fine, it's fine to use the IETF page for that, but it displaced 
something that was actually useful with something much less so.

Keith

---

From: "John Levine" <[email-masked]>
Date: 24 May 2019 17:33:25 -0400

>links to the resources that people who actually work in IETF, need.  

As was discussed at great length when the new site was built,
www.ietf.org is primarily a billboard for people unfamiliar with the
IETF.  After the previous round of grousing, they added a Tools link
at the upper right which leads to all of the stuff that IETF
participants use.  Assuming your web browser is modern enough to have
bookmarks, perhaps you could bookmark that link instead.

Perhaps we could save time by simply pretending that we read the
previous complaints into the record here.

R's,
John

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 25 May 2019 10:56:37 +1200

On 25-May-19 09:33, John Levine wrote:
> participants use.  

There's that, but my goto page is the attached file, which also includes a
search option that works.

     Brian

> Assuming your web browser is modern enough to have

---

From: Roman Danyliw <[email-masked]>
Date: Sat, 25 May 2019 03:11:15 +0000

Hi John!

> From: John C Klensin [mailto:[email-masked]]
> Sent: Wednesday, May 22, 2019 6:33 PM
> Cc: Stephen Farrell <[email-masked]>; Keith Moore
> <[email-masked]>; [email-masked]
> Your response actually raises (at least for me) some additional questions
> (saving for later issues on which you have promised details later)...
> 
> --On Wednesday, May 22, 2019 20:49 +0000 Roman Danyliw <[email-masked]>
> wrote:
> 
> >...
> > A few answers below.
> >
> > In the "Implementation" section the proposal notes that "[f]ollowing
> > finalization and implementation of the proposal, ...  the web
> > analytics and reports will be reviewed by the IETF Tools Team after
> > one-year to confirm they are delivering anticipated results."  The
> > IETF Tools Team will bring a recommendation to the IESG.  Whether
> > these analytics are worth keeping will be determined by whether they
> > informed site improvement (as outlined in the "Introduction" section).
> 
> I'm still not clear as to why this effort is needed at all.  I am sympathetic to
> Keith Moore's observations which I read as being about collecting
> measurements and doing statistics that are easy rather than digging down
> far enough to determine which are needed for specific purposes, and then
> figuring out how, if possible, to gather those statistics and keeping them as
> focused as possible.  Gathering data because we can, because tools are
> readily available to capture certain data, and then passing it off to the Tools
> Team to figure out what it is good for (or whether it provided "anticipated
> results" without that being specified in advance) does not strike me as a
> good way to proceed.  It also violates the most basic of privacy protection
> principles, which is that data that are not collected are data one don't have
> to worry about securing, retention times, etc.
>
> It seems to me that the first step in this process should be a clear statement
> from the Tools Team or other decision makers about how they expect to use
> the data and what data are needed for that purpose.  That expectation is
> supported by a statement in the Proposal that says "website analytics must
> be implemented to ... ● limit data being collected to that needed to serve
> specific identified purposes".  The first two items in the list of data to be
> reported are:

The expected utility of the usage data is to have an empirical basis for improving the site.  I'm not sure how we improve the web site without a feedback loop (active where comments on it are made explicitly and passively by watching usage).  We have some usage data now (https://www.ietf.org/usagedata/) but it is incomplete based on the instrumentation possible with the current architecture.  This proposal is suggesting an alternative approach that would provide equivalent usage data (as prior to the CDN migration) and also enhancements.

There are already a few questions posed in the proposal on how that data would be used:
** which pages are most commonly visited, 
** which paths visitors travel to find IETF meeting registration pages, or 
** whether introductory information, such as tutorials, leads to further exploration of website content.

> https://www.ietf.org/about/groups/iesg/members/ does not attract as much
> traffic as, e.g., https://www.ietf.org/how/meetings/upcoming/ does that
> mean we are going to take it down?  Redesign it with more animation in the
> hope of drawing additional traffic?  That is a silly example, but I trust the
> problem is clear.

I don't agree.  Stats about the visits to a page/resource can be useful for managing the site.

Imagine one looked at the usage of the meeting agenda pages (yes, I know that's in datatracker.ietf) in all of their forms -- it comes as a txt, html, iCal, etc.  Generating all of those formats takes effort. If the stats showed one is very unpopular, there might need to be a conversation about whether it's worth the effort.  Perhaps, it was noticed that the area specific drill down is quite popular.  More resources might be applied to enrich that.

Imagine one noticed that particular deeply nested content was rising in popularity (e.g., say a given blog post), this material could be promoted or referenced more prominently.

I know you meant animation comment to be as you put it a "silly example", but the notion of tuning www.ietf.org to attract more traffic as long as it positively raises awareness/visibility of our work is a good idea.  www.ietf.org is our site to the world, not just an inward facing resource to those already in the community.

> implementing analytics,...", which sounds a lot like we have skipped over
> "why" and "what" to get to "how".
> 
> However, assuming for purposes of discussion that this is really needed for
> some useful purpose...
>
> > The proposal outlines that the "IETF Secretariat,  communications
> >staff, and the IESG"
> >...
> I note that the Tools Team, who are explicitly called out as getting the data,
> are, except for individual coincidences, not part of the IETF Secretariat, the
> communications staff (I think I know who/what that means, but am not
> sure), or the IESG, so the list of parties with whom information is shared is a
> superset of that list even before ISOC staff is considered.  It is also interesting
> that neither the IETF LLC Exec Director nor the IETF LLC Board are on the list
> of people to be given access to the data, something that would probably
> make it hard to evaluate the results and utility of this work.  Given that this
> Secretariat) maintain the software on our own equipment, I'd hope that sort
> of evaluation would be part of any ongoing effort.
> 
> ● aggregated visitor profiles (including OS, browser, and primary languages)
> ● visitors' paths through the site (including time spent on webpages, as well
> as entry and exit pages
> 
> in why you don't read it that way because we may have different definitions.

I agree that tracking can have a variety of definitions.  I'm only say it isn't tracking behavior as defined by [3].  More thoughts below.

> By this definition, one can do just about anything one likes to capture
> information about user behavior as long as that user doesn't leave "a
> context" and then defining "context" in an appropriately broad way.  In
> particular...

I agree there is grey here on what is "jointly controlled".  This is the precision of the spec.

> Really?  First, whether *.ietf.org servers are "controlled by the same party" is
> questionable.  One could suggest that they are "controlled by" some
> combination of the IETF LCC, AMS, the Tool Team, and maybe some "cloud"
> or "CDN" suppliers.  Perhaps at least some of those relationships are tightly
> enough specified contractually to make the control by the IETF LLC (not the
> IESG) clear, but "the IETF" (as a community of participants) doesn't know
> enough about the details of those contracts to be confident about that.
> And, unless the Tools Team started being subject to Close Technical
> Supervision while I wasn't looking, pages in ietf.org subdomains they control
> and manage cannot be said to be "controlled by" the IETF.

I'm not entirely tracking on distinction being made with "controlled".  I cribbed the use of "IETF" as the controlling party because the privacy policy only names IETF, IAB and IRTF.  If the distinction you're making is that the IETF, as in the broader community of participants, doesn't control the website sure I concede that.  However, I disagree that www.ietf.org isn't a either a single (or jointly) controlled context per [3] simply because contractors, detailees, volunteers, LLC individuals might be involved in its operation.

> IMO, lots of loose ends here.  

No disagreement.  That's why the proposal was put out for comment.   A number of implementation details remain.

Regards,
Roman

> From my point of view, the most important is
> why we actually need to do this, what we hope to accomplish, and, from
> those things, what data we actually need.
> The "information to be collected" part of the proposal is not especially
> helpful in this regard.  Some of the comments do help in imagining what is
> intended and why, but I don't think we should need to imagine.
> 
> best,
>    john

---

From: Roman Danyliw <[email-masked]>
Date: Sat, 25 May 2019 03:15:59 +0000

Hi!

> From: S Moonesamy [mailto:[email-masked]]
> Sent: Thursday, May 23, 2019 12:55 PM
> I assume that the proposed change(s) will not materially impact the existing
> privacy statement or else there would be a prompt notification of the
> changes.

Correct.  Furthermore, this will be double checked again when specific implementation choices are made.

> proposal) being used.  I could not figure out the reason for giving those
> external parties access to non-public information as it is not clear how it is
> liked to the intended purposes.

In this case "communication staff" means individuals working on behalf of the IETF on communications matters.  Practically, this is Greg Woods (ISOC).

> One of the software providers describes one of the methods listed on Page 3
> as tracking. The existing privacy statement defines several parties. They do
> not fit within the "context" {1] definition.  It is not clear whether tracking is
> being proposed or not.

This observation may overlap with what was previously posed in the thread by Stephen and John. As I noted in my responses to Stephen and John, my statements reference tracking behavior as defined by DNT spec (as that's the language in the privacy statement)

Can you expand on why you think the "IETF" (the named "party" from the privacy statement) isn't appropriate as the "party" in the DNT spec definition.

Regards,
Roman

> Regards,
> S. Moonesamy
> 
> 1. A context is a set of resources that are controlled by the same party or
> jointly controlled by a set of parties.

---

From: S Moonesamy <[email-masked]>
Date: Sat, 25 May 2019 00:47:17 -0700

Hi Roman,
At 08:15 PM 24-05-2019, Roman Danyliw wrote:
>In this case "communication staff" means individuals working on 
>behalf of the IETF on communications matters.  Practically, this is 
>Greg Woods (ISOC).

Thank you for the information.

>This observation may overlap with what was previously posed in the 
>thread by Stephen and John. As I noted in my responses to Stephen 
>and John, my statements reference tracking behavior as defined by 
>DNT spec (as that's the language in the privacy statement)

Ok.

>Can you expand on why you think the "IETF" (the named "party" from 
>the privacy statement) isn't appropriate as the "party" in the DNT 
>spec definition.

According to information provided on the web site, the IETF 
Administration LLC is a legal entity.  The IETF Administration LLC 
stated that it is responsible for establishing and enforcing policies 
to ensure compliance with applicable laws, regulations, and rules.

There is a definition in Section 2.4 of the Tracking Preference 
Expression specification:  "A party is a natural person, a legal 
entity, or a set of legal entities ..."  In my opinion, the usage of 
"party" in the privacy statement does not fit that definition.  The 
legal entity, namely the IETF Administration LLC, is not identified 
in the privacy statement.

Regards,
S. Moonesamy

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 26 May 2019 09:59:09 +1200

Hi Roman,

On 25-May-19 15:11, Roman Danyliw wrote:
...
> The expected utility of the usage data is to have an empirical basis for improving the site.  I'm not sure how we improve the web site without a feedback loop (active where comments on it are made explicitly and passively by watching usage).  

Isn't the first question whether the site is fit for purpose? I can certainly see that analytics will help optimise details, but are we at that point yet?

My understanding when the improvement project was started was that the main issues were the highly manual maintenance cost of the old site, and ease of use for newcomers. What we got wasn't an improved version of a site fit for geeks, but something that looks like lots of other marketing-oriented sites. I feel sad when I look back at how good www6.ietf.org still seems today.

     Brian

---

From: "John Levine" <[email-masked]>
Date: 25 May 2019 19:03:52 -0400

In article <[email-masked]>,
Brian E Carpenter  <[email-masked]> wrote:
>My understanding when the improvement project was started was that the main issues were the highly manual maintenance
>cost of the old site, and ease of use for newcomers. What we got wasn't an improved version of a site fit for geeks,
>but something that looks like lots of other marketing-oriented sites. I feel sad when I look back at how good
>www6.ietf.org still seems today.

If our goal is to scare away everyone who isn't already deeply
familiar with IETF culture and practice, I would agree.

If we think it might be nice for new people to learn about the IETF
and perhaps start joining mailing lists and reading and writing drafts
before we old pharts all die off, perhaps not.

It is my impression that there are not many active IETF participants
who are unable to bookmark the tools link page, or do something like
your local link page hack, but who knows, there are a lot of WGs I
don't go to.

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 26 May 2019 00:15:32 +0100

> before we old pharts all die off, perhaps not.

Were there a separate effort to determine if the current
IETF web site has been better or worse at getting new folks
usefully engaged in the IETF, compared to the version Brian
liked, that might be interesting.

That, however, doesn't match the subject line of this thread.

S.

---

From: Lloyd Wood <[email-masked]>
Date: Thu, 30 May 2019 07:26:53 +0000 (UTC)

I second Brian's comments.

www6.ietf.org is far more useful and functional than www.ietf.org.

("were a highlight the Internet Research Task Force (IRTF)"
- the marketing doesn't extend to subediting for grammar. Sigh.)

Lloyd Wood [email-masked] http://about.me/lloydwood

________________________________
From: Brian E Carpenter <[email-masked]>
To: Roman Danyliw <[email-masked]> 
Cc: "[email-masked]" <[email-masked]>; Keith Moore <[email-masked]>
Sent: Sunday, 26 May 2019, 7:59
Subject: Re: Call for Community Input: Web Analytics on www.ietf.org

Hi Roman,

....

     Brian

---

From: Tim Chown <[email-masked]>
Date: Thu, 30 May 2019 08:28:44 +0000

On 30 May 2019, at 08:26, Lloyd Wood <lloyd.wood=[email-masked]<mailto:lloyd.wood=[email-masked]>> wrote:

www6.ietf.org<http://www6.ietf.org> is far more useful and functional than www.ietf.org<http://www.ietf.org>.

If only www6.ietf.org<http://www6.ietf.org> were up to date :)

Tim

Lloyd Wood [email-masked]<mailto:[email-masked]> http://about.me/lloydwood

________________________________
From: Brian E Carpenter <[email-masked]<mailto:[email-masked]>>
To: Roman Danyliw <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>; Keith Moore <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, 26 May 2019, 7:59
Subject: Re: Call for Community Input: Web Analytics on www.ietf.org<http://www.ietf.org>

Hi Roman,

.....

My understanding when the improvement project was started was that the main issues were the highly manual maintenance cost of the old site, and ease of use for newcomers. What we got wasn't an improved version of a site fit for geeks, but something that looks like lots of other marketing-oriented sites. I feel sad when I look back at how good www6.ietf.org<http://www6.ietf.org> still seems today.

    Brian

---

From: Scott Bradner <[email-masked]>
Date: Thu, 30 May 2019 07:28:03 -0400

I just tried to load this document and got a 404 message

I was looking to see if the proposal included a change to the IETF privacy statement (https://www.ietf.org/privacy-statement/)
that revealed that the IETF was monitoring the activities of visitors to the IETF web pages

Scott

> On May 21, 2019, at 11:17 AM, Roman Danyliw <[email-masked]> wrote:
> 
> Hi!
>

---

From: Roman Danyliw <[email-masked]>
Date: Thu, 30 May 2019 11:55:15 +0000

Hi Scott!

I'm getting the same error.  The site maintainers have been notified.  Thanks for pointing this out.

In the interim, I attached the proposed plan.

Thanks for your patience.

Roman

> From: Scott Bradner [mailto:[email-masked]]
> Sent: Thursday, May 30, 2019 7:28 AM
> I was looking to see if the proposal included a change to the IETF privacy
> statement (https://www.ietf.org/privacy-statement/)
> commonly visited; which paths visitors travel to find IETF meeting
> registration pages; or whether introductory information, such as tutorials,
> leads to further exploration of website content. Web analytics would
> provide insight into overall utilization and inform future improvements to
> the website.
> >

---

From: "John Levine" <[email-masked]>
Date: 30 May 2019 09:10:40 -0400

>that revealed that the IETF was monitoring the activities of visitors to the IETF web pages

The page looks fine to me, perhaps the paren was confusing

https://www.ietf.org/privacy-statement/

It says this:

  Certain visitor characteristics may be reflected in our web server
  logs (such as, operating system, browser version, and Internet
  Protocol (IP) address). We do not make such information available to
  the public. When you interact with our web sites we may use cookies to
  uniquely identify you during a session to allow us to process your
  online transactions and requests and to verify your identity, after
  you have logged in to a web site and to track user activity between
  sessions. 

Assuming the reports are aggregated I don't see anything new here.

R's,
John

---

From: Roman Danyliw <[email-masked]>
Date: Thu, 30 May 2019 17:10:19 +0000

This link should now work.

Roman

> Sent: Thursday, May 30, 2019 7:55 AM
> To: Scott Bradner <[email-masked]>
> Cc: [email-masked]
> > I was looking to see if the proposal included a change to the IETF
> > privacy statement (https://www.ietf.org/privacy-statement/)
> > > input
> > registration pages; or whether introductory information, such as
> > tutorials, leads to further exploration of website content. Web
> > analytics would provide insight into overall utilization and inform
> > future improvements to the website.
> > >
> > implementation plan to integrate a self-hosted analytics package into
> > the existing infrastructure.  The full details of this proposal are available at:
> > >
> > > and

---

From: Scott Bradner <[email-masked]>
Date: Thu, 30 May 2019 16:54:50 -0400

Roman,
	Thanks for the copy

First you will need to update the privacy statement if you actually implement this proposal

and I will echo what others have said - I think you need to say what you will do with the information
you collect - in the sense, what types of changes do you expect to make to the web site based on the 
data 

The IETF.org web site was changed a few years back to be non-useful to IETF participants.  If I thought that 
this type of analysis would rethink that goal then I would strongly support the effort but I doubt that the
type of data to be collected would actually help make the site’s core purpose be to support IETF participants 

Scott

> On May 30, 2019, at 7:55 AM, Roman Danyliw <[email-masked]> wrote:
> 
> Hi Scott!
> 
> <www.ietf.org-AnalyticsProposal-forReview.pdf>

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 31 May 2019 06:28:37 -0700

This seems extremely reasonable. Doing some kind of measurement of the use
of Web sites is pretty much standard industry practice and critical if you
are going to know how the site is being used and whether it works.

I would second Mark Nottingham's call to do performance monitoring and
include datatracker. Anecdotally, we see real performance problems here and
measuring that is the first step. I'd also suggest that some sort of uptime
monitoring (pingdom, etc.) would be a good idea, though perhaps it's a
different project.

-Ekr

On Tue, May 21, 2019 at 8:18 AM Roman Danyliw <[email-masked]> wrote:

> In consultation with the tools team, Greg Wood developed an implementation
> plan to integrate a self-hosted analytics package into the existing
> infrastructure.  The full details of this proposal are available at:
>

---

From: Sean Turner <[email-masked]>
Date: Fri, 31 May 2019 11:18:25 -0400

> On May 31, 2019, at 09:28, Eric Rescorla <[email-masked]> wrote:
> 
> This seems extremely reasonable. Doing some kind of measurement of the use of Web sites is pretty much standard industry practice and critical if you are going to know how the site is being used and whether it works.

+1

spt

---

From: Bob Hinden <[email-masked]>
Date: Fri, 31 May 2019 08:31:10 -0700

I also support doing this.

Bob

> On May 31, 2019, at 6:28 AM, Eric Rescorla <[email-masked]> wrote:
> 
> I would second Mark Nottingham's call to do performance monitoring and include datatracker. Anecdotally, we see real performance problems here and measuring that is the first step. I'd also suggest that some sort of uptime monitoring (pingdom, etc.) would be a good idea, though perhaps it's a different project.
> 
> -Ekr
> 
>

---

From: Randy Bush <[email-masked]>
Date: Fri, 31 May 2019 10:57:47 -0700

fwiw, while i think measurement to improve web site performance are a
good idea, i also agree with sob that the privacy statement should be
examined to cover this.

also, fwiw, that something has become standard practice in the industry
does not weigh much with me.  some horrifying things have become
standard practice.

randy

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 31 May 2019 20:58:10 +0100

> does not weigh much with me.  some horrifying things have become

many things have become standard practice where they oughtn't have.  One 
of these things is cross-site tracking.

The analytics package suggested - Matamoto - is restricted to local 
tracking only and the ietf's privacy policy is clear and not hugely 
evil.  The benefit to the ietf is clear, namely that they will be able 
to glean useful information about how the web site is working for its 
intended audience.  People who manage web sites need feedback in order 
to be able to do their jobs.

There's a balance of benefit of both parties going on here.  Many other 
organisations tilt that balance towards themselves or inadvertently and 
worse still towards tracking agencies.  This doesn't seem to be 
happening in this situation.

Nick

---

From: Roman Danyliw <[email-masked]>
Date: Fri, 31 May 2019 20:35:22 +0000

Hi Scott!

> Sent: Thursday, May 30, 2019 4:55 PM

Agreed.  The feedback is noted that when implementation details are refined to be sufficiently specific, the privacy statement should be reviewed again; and revised and communicated as approach prior to implementation.

> and I will echo what others have said - I think you need to say what you will
> do with the information you collect - in the sense, what types of changes do
> you expect to make to the web site based on the data

Understood.  As I've noted in the other threads, this data would inform improvements on the website (and allow the existing baseline metrics to be collected).  The currently identified uses are the ones specified in the proposal.

Roman

> The IETF.org web site was changed a few years back to be non-useful to IETF
> participants.  If I thought that this type of analysis would rethink that goal
> then I would strongly support the effort but I doubt that the type of data to
> be collected would actually help make the site’s core purpose be to support
> IETF participants
> 
> Scott
>

---

From: Keith Moore <[email-masked]>
Date: Fri, 31 May 2019 16:44:32 -0400

On 5/31/19 1:57 PM, Randy Bush wrote:

> fwiw, that something has become standard practice in the industry

+1

---

From: "Livingood, Jason" <[email-masked]>
Date: Fri, 31 May 2019 22:29:45 +0000

+1

From: ietf <[email-masked]> on behalf of Eric Rescorla <[email-masked]>
Date: Friday, May 31, 2019 at 9:29 AM
To: Roman Danyliw <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: Call for Community Input: Web Analytics on www.ietf.org

-Ekr

On Tue, May 21, 2019 at 8:18 AM Roman Danyliw <[email-masked]<mailto:[email-masked]>> wrote:
Hi!

The Internet Engineering Steering Group (IESG) is seeking community input on implementing web analytics on www.ietf.org<http://www.ietf.org> ("the website").

Regards,
Roman