Subject: virtual-only wgs?

From: "Aaron Falk" <[email-masked]>
Date: Thu, 16 May 2019 14:04:31 -0400

Can anyone tell me whether our standards process allows for virtual-only 
working groups?  In other words, could a working group choose to stop 
meeting at IETF venues and only convene online?

--aaron

---

From: "Eliot Lear (elear)" <[email-masked]>
Date: Thu, 16 May 2019 18:11:08 +0000

I have done these before under Barry and Alexey. It works fine for non-controversial well defined stuff.

Eliot

On May 16, 2019, at 20:07, Aaron Falk <[email-masked]<mailto:[email-masked]>> wrote:

Can anyone tell me whether our standards process allows for virtual-only working groups? In other words, could a working group choose to stop meeting at IETF venues and only convene online?

--aaron

---

From: John C Klensin <[email-masked]>
Date: Thu, 16 May 2019 14:51:49 -0400

--On Thursday, May 16, 2019 14:04 -0400 Aaron Falk
<[email-masked]> wrote:

> Can anyone tell me whether our standards process allows for
> virtual-only working groups?  In other words, could a working
> group choose to stop meeting at IETF venues and only convene
> online?

Yes.  A WG could also chose to not "convene" at all, doing 100%
of its work on its mailing list and noting that, no matter how
much convening is done, the rules still require that consensus
be determined on the mailing list.  There have been examples of
that too... and some of them haven't fallen into the
"non-controversial" and "well defined" categories Eliot
mentioned although that certainly makes things easier.

   john

---

From: Randy Presuhn <[email-masked]>
Date: Thu, 16 May 2019 16:12:04 -0700

Hi -

> meeting at IETF venues and only convene online?

As best I can remember, the ltru working group never had
a face-to-face meeting.  I don't think I even met my co-chair
during the course of the work.

Randy

---

From: Keith Moore <[email-masked]>
Date: Thu, 16 May 2019 19:59:21 -0400

On 5/16/19 2:04 PM, Aaron Falk wrote:

> virtual-only working groups? In other words, could a working group 
> choose to stop meeting at IETF venues and only convene online?
>
I don't think it violates our process rules.   I agree  that it's better 
if such groups are doing narrowly-scoped, noncontroversial work that 
doesn't need broad review.

Keith

p.s. However, IMO, a WG that only held interim face-to-face meetings, 
but NOT at IETF meetings, would at the very least be acting in bad 
faith.   (In the distant past I knew of one WG that was explicitly doing 
this as a way to avoid having to educate, or answer to, the broader 
community.)

---

From: John C Klensin <[email-masked]>
Date: Thu, 16 May 2019 21:59:17 -0400

--On Thursday, May 16, 2019 19:59 -0400 Keith Moore
<[email-masked]> wrote:

>...
> p.s. However, IMO, a WG that only held interim face-to-face
> meetings, but NOT at IETF meetings, would at the very least be
> acting in bad faith.   (In the distant past I knew of one WG
> that was explicitly doing this as a way to avoid having to
> educate, or answer to, the broader community.)

In the distant past, the IESG would not allow a WG that was not
meeting at IETF meetings to hold f2f interims.  The reason was
closely linked to your concern about bad faith.  Then, IIR, it
became "no f2f interims within some number of weeks before or
after and IETF meeting" to avoid or mitigate the same problem.
I gather that rule has eroded as well.

So, yes.

   john

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 17 May 2019 09:38:33 +0000

... but it works horribly when there's any controversy or disagreement about scope. For example, the ATOMPUB WG was probably the worst experience I've ever had in a standards body, and in my opinion it's largely because the group never met face-to-face (except for a single pre-chartering meeting). This was sold as enabling small developers to participated, but what it ended up being was a mess, because people had little shared context and no established trust.

Cheers,

> On 16 May 2019, at 6:11 pm, Eliot Lear (elear) <[email-masked]> wrote:
> 
> On May 16, 2019, at 20:07, Aaron Falk <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Ted Lemon <[email-masked]>
Date: Fri, 17 May 2019 06:33:29 -0400

On May 17, 2019, at 5:38 AM, Mark Nottingham <[email-masked]> wrote:
> .... but it works horribly when there's any controversy or disagreement about scope. For example, the ATOMPUB WG was probably the worst experience I've ever had in a standards body, and in my opinion it's largely because the group never met face-to-face (except for a single pre-chartering meeting). This was sold as enabling small developers to participated, but what it ended up being was a mess, because people had little shared context and no established trust.

What could have been done differently?

For example, were there f2f interims?

---

From: Russ Housley <[email-masked]>
Date: Fri, 17 May 2019 08:01:27 -0400

I recall we have one very small WG that was chartered to produce one RFC, and it do the job without ever holding a WG session, just mail list discussion.

Russ

> On May 16, 2019, at 2:04 PM, Aaron Falk <[email-masked]> wrote:
>

---

From: John C Klensin <[email-masked]>
Date: Fri, 17 May 2019 09:44:22 -0400

--On Friday, May 17, 2019 09:38 +0000 Mark Nottingham
<[email-masked]> wrote:

> .... but it works horribly when there's any controversy or
> disagreement about scope. For example, the ATOMPUB WG was
> probably the worst experience I've ever had in a standards
> body, and in my opinion it's largely because the group never
> met face-to-face (except for a single pre-chartering meeting).
> This was sold as enabling small developers to participated,
> but what it ended up being was a mess, because people had
> little shared context and no established trust.

But Mark, I've never seen any WG work well if there is
controversy or disagreement about scope, and more f2f meetings
-- at IETF or otherwise-- typically turn into more debates about
scope and objectives.  So, yes, launching such WGs is probably a
bad idea but it is not clear that how many f2f meetings they
hold (again, at IETF or elsewhere) makes much difference.  There
is an advantage for those without clear scope statements, which
is that open, f2f meetings with a wide range of perspectives
represented often converge faster -- whether on a solution on on
a conclusion that solutions are not going to be forthcoming --
than mailing lists.  That is true whether the needed solutions
are agreement about scope or a technical topic.   

This threat is symptomatic of part of the advantage of such
meetings over a mailing list discussion for at least some types
of controversies: it is hard to believe that, in a f2f meeting,
people would be coming to the microphone to repeat each other as
many times as we have seen duplicative answers to Aaron's
question.   In that sense, thanks for saying something different
:-(

   john

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 17 May 2019 14:22:31 +0000

> On 17 May 2019, at 10:33 am, Ted Lemon <[email-masked]> wrote:
> 

There were not. I think they could have had a set of people meet and build trust. While there's a risk of creating an "in group" there, if done well you have a group of folks who have mutual respect and demonstrate that to the rest of the group, creating a culture that's respectful and productive.

I've heard folks in other venues opine that the real purpose of F2F meetings is just this; socialisation, so that when you're arguing with someone on the other side of the planet behind a keyboard, there's some shared context / good will.

Cheers,

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 17 May 2019 14:37:48 +0000

> choose to stop meeting at IETF venues and only convene online?

The geojson working group met 0 times in person.  I have never met the individuals involved in person, other than having once met my co-chair at an unrelated event some years before the working group was chartered.  Aside from some video calls during the process, all the work was done via email.

That worked because we were all very clear about goals and the people involved were broadly aligned on those goals.  It wasn't free of controversy and drama, but it did work.

Proof that this *can* work, but not strong evidence that this will work for every case.

---

From: "Aaron Falk" <[email-masked]>
Date: Fri, 17 May 2019 11:02:58 -0400

On 17 May 2019, at 10:22, Mark Nottingham wrote:

> I've heard folks in other venues opine that the real purpose of F2F 
> meetings is just this; socialisation, so that when you're arguing with 
> someone on the other side of the planet behind a keyboard, there's 
> some shared context / good will.

This is an important insight, IMO.  A lot of what we do is about getting 
agreement between humans and relationships are an important part of 
that.

--aaron

---

From: Keith Moore <[email-masked]>
Date: Fri, 17 May 2019 11:07:22 -0400

On 5/17/19 9:44 AM, John C Klensin wrote:

> scope and objectives.

As far as I can tell, this depends.

People who have met in person - perhaps even just once - have a much 
better sense of how the others think, than those who have only 
interacted over email or similar "text only" media.   I suspect that 
people with different ideas of scope can not only more easily arrive at 
a consensus on scope in a face-to-face meeting, they can more easily 
arrive at a consensus on scope over email if they've already met in person.

Sometimes, however, there are irreconcilable differences.   The worst 
cases of this I've seen have been when there were participants from 
multiple companies with conflicting agendas of how they wanted to 
manipulate the market, and part of each of these companies' strategies 
was to influence IETF standards in order to support their agendas.   In 
such cases the participants sponsored by those companies were not 
actually free to work out what was best for the Internet as a whole.   
I'm not sure that IETF can do much about this, but it may help if the 
ADs realize if this is the situation.  But yes, it's unlikely that more 
than say 2 face to face meetings will help such a group to converge on a 
reasonable scope.

(Then again, it's quite common in my experience for a working group to 
be chartered in such a way as to mask inherent tussles between different 
user communities or different layers of the network,  by giving the 
group a narrow charter that prevents the group from attempting to 
resolve those tussles.   In such a case, the group may appear to make 
progress, only to produce a result that either can't be successful in 
the real world, or one which unfairly favors one legitimate interest 
over another, and which may in practice degrade interoperability rather 
than improving it.   So we shouldn't assume that the groups with 
forcibly narrowed scope are more successful just because they don't 
spend time on scope discussions or because they get RFCs out the door 
sooner.)

But I do think that face-to-face meetings can help a group reach 
consensus on scope if the conditions otherwise permit it.

(What I don't know is whether remote participation media with 
high-fidelity audio and video would work well enough to rely less on the 
face-to-face meetings.   Part of the problem is that different users' 
network conditions and equipment vary, so what works well for one 
participant may not work well for another. Another part of the problem 
is that video conferencing software I've seen seems better suited to 
"presentation" format discussions - where there's one speaker at any 
time and everyone else is the audience - than to interactive discussions.)

Keith

---

From: Michael Richardson <[email-masked]>
Date: Fri, 17 May 2019 15:53:45 -0400

Aaron Falk <[email-masked]> wrote:
    > working groups? In other words, could a working group choose to stop meeting
    > at IETF venues and only convene online?

Yes, CELLAR, of which I am co-chair, has an approximate monthly virtual-interim.
The key authors of the documents are librarians/archivists and open source authors.
Many of the authors have previously met in person at other events, but never
been to IETF.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Bob Hinden <[email-masked]>
Date: Sat, 18 May 2019 08:15:49 -0700

Aaron,

> On May 16, 2019, at 11:04 AM, Aaron Falk <[email-masked]> wrote:
> 

As many folks have said, this is possible and has been done.

However, as a follow-on question, could there be a working forming BOF that is virtual?   

Bob

---

From: Aaron Falk <[email-masked]>
Date: Sat, 18 May 2019 11:22:11 -0400

On Sat, May 18, 2019 at 11:15 AM Bob Hinden <[email-masked]> wrote

> However, as a follow-on question, could there be a working forming BOF

Maybe a BoF on virtual BoFs?
-- 
-- aaron Sent from Gmail Mobile

---

From: John C Klensin <[email-masked]>
Date: Sat, 18 May 2019 11:29:47 -0400

> forming BOF that is virtual?   

I think the IESG gave a "yes" answer to that in response to the
discussion of draft-moonesamy-recall-rev and the formation of
the eligibility-discuss WG.  I don't know what Subramanian has
decided (or will decide) to do.  However, a different and
perhaps better answer is that, because a BOF is not prerequisite
to forming a WG, presumably a group of people could hold a
mailing list discussion, reach a conclusion that a WG was needed
and what its scope should be, and then approach appropriate ADs
and simply ask that the WG be chartered.

  john

---

From: Jared Mauch <[email-masked]>
Date: Sat, 18 May 2019 13:21:45 -0400

> On May 17, 2019, at 11:02 AM, Aaron Falk <[email-masked]> wrote:
> 
> This is an important insight, IMO. A lot of what we do is about getting agreement between humans and relationships are an important part of that.
> 
> --aaron
> 

Somewhat-OT, but related: I’ve worked remotely 20 of the past 25 years of my employment history.  What has worked well was there were regular F2F meetings scheduled with these people distributed around the country or the globe so we could meet with each other.  Without that it’s much harder for the reasons listed above.  Sometimes you only find out something by that f2f meeting.

If you work remote and the rest of the culture is around f2f and doesn’t support you remotely or the ability to travel periodically to see these people, it will be more challenging is my experience.  I regularly find things where people only bring them up because we are f2f when they could have contacted me remotely.

Some of the cross-area review really depends on the f2f nature of meetings IMO, more to socialize than the technical bits as Mark noted above.

- Jared

---

From: S Moonesamy <[email-masked]>
Date: Sat, 18 May 2019 14:08:04 -0700

Hi John,
>and simply ask that the WG be chartered.

The scope of the draft is intentionally narrow.  The scope of 
eligibility-discuss is unknown [1].  The IETF Chair mentioned changes 
to the governance structure in her reply.  I'll contact her again as 
the draft fits within her area.

Regards,
S. Moonesamy

1. https://mailarchive.ietf.org/arch/msg/ietf/S4qJtyNVB0BqGZmKRg_wuZMsKiQ

---

From: Michael Richardson <[email-masked]>
Date: Sat, 18 May 2019 18:46:25 -0400

> However, as a follow-on question, could there be a working forming BOF that is virtual?

I think that this has happened, but I don't have an existence proof.

I know that WGs have been formed without in-person BOFs, and I suspect it
resulted from a few email conversations, and some well written charters.
Whether there were informal phone calls or unofficial virtual interim
meetings, I don't know.

Our rules say you don't have to have a BOF.

---

From: Loa Andersson <[email-masked]>
Date: Sun, 19 May 2019 15:58:25 +0800

Michael, Bob, all,

> Whether there were informal phone calls or unofficial virtual interim

I guess we could run a working group, as long as there is a solid
rough consensus on what should be done, based on virtual meetings or
entirely on a wg mailing list.

Same for a BoFs.

However we all know that working groups frequently run into issues
that needs to be discussed f2f.

Same for BoFs.

I don't think that we ever can charter a working group that is not
allowed to hold f2f meetings at an IETF meeting. I also think that wg
chairs in such a wg must be quite liberal listening to request for
f2f meetings.
> Our rules say you don't have to have a BOF.

Well, yes IESG can form a working group as soon as it is convinced
that there is work to be done and enough people interested in doing
this work.

Now, the BoFs are there to investigate those two issues. BoFs are
useful, but not always necessary.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 19 May 2019 15:14:12 -0400

On Fri, May 17, 2019 at 10:23 AM Mark Nottingham <[email-masked]> wrote:

> >> .... but it works horribly when there's any controversy or disagreement
> about scope. For example, the ATOMPUB WG was probably the worst experience
> I've ever had in a standards body, and in my opinion it's largely because
> the group never met face-to-face (except for a single pre-chartering
> meeting). This was sold as enabling small developers to participated, but
> what it ended up being was a mess, because people had little shared context
> and no established trust.
> >
> There were not. I think they could have had a set of people meet and build
> trust. While there's a risk of creating an "in group" there, if done well
> you have a group of folks who have mutual respect and demonstrate that to
> the rest of the group, creating a culture that's respectful and productive.
>
> someone on the other side of the planet behind a keyboard, there's some
> shared context / good will.
>

The IETF process and meetings are more the result of evolution rather than
design. Before the net existed, the only way to collaborate effectively was
through in person meetings. It would have been difficult to design SMTP
entirely on mailing lists (yes, there were earlier mail protocols but...).

That said, I am pretty sure that the calming effect that in-person meetings
have is one of the major reasons we continue them. It is certainly one of
the reasons W3C started in-person meetings for WGs.

I can certainly imagine circumstances in which it would make sense for a
semi-detached WG to meet only at interims. But mostly where they are in
effect a joint working group with another body. IETF chose not to do policy
work in PKIX. That is now done in CABForum as a result.

I think we are going to face choices about how we want to work at some
point and it is far from clear to me that holding plenary meetings three
times a year is the best approach. One of the considerable problems with
the current model is that the meetings also fund the secretariat which is
better than selling standards but limits scope for innovation. Another
problem with the current approach is that it is ideal for people who do a
small amount in a large number of groups. It is less than ideal to progress
one particular work item swiftly.

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 20 May 2019 10:40:13 +0000

Hi Bob,

> On May 18, 2019, at 3:15 PM, Bob Hinden <[email-masked]> wrote:
> 
> Aaron,
> 

Sure. As previously noted, LURK did a virtual BOF, although it was non-WG-forming. Recent WGs that I think were chartered without an in-person BOF that I can remember include geojson, justfont, dart, rum, l3sm, eman, l2sm, and emu (reboot of a closed WG).

Alissa

---

From: Bob Hinden <[email-masked]>
Date: Mon, 20 May 2019 07:41:00 -0700

Alissa,

> On May 20, 2019, at 3:40 AM, Alissa Cooper <[email-masked]> wrote:
> 
> Hi Bob,
> 

Thanks, good to know.

Bob

---

From: Donald Eastlake <[email-masked]>
Date: Mon, 20 May 2019 11:57:43 -0400

Another example of a mostly virtual WG is CALEXT. Although it has had
a few fact-to-face meetings recently, it existed for years and
produced 3 RFCs doing all of its work on the mailing list.

Thanks,
Donald (former CALEXT co-chair)
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 1424 Pro Shop Court, Davenport, FL 33896 USA
 [email-masked]