Subject: LLC Board and contracts -- plenary comments

From: "Leslie Daigle" <[email-masked]>
Date: Thu, 25 Jul 2019 18:20:59 -0400

Jason, LLC Board,

I wanted to follow up my comments at the mic last night in plenary.

I asked what the strategic oversight imperative was behind your comment 
that the LLC Board was “simplifying contracts”; and, specifically, 
how you were translating that into a directive for your (eventual) 
Executive Director.

My point was not actually to argue whether the current contracts are 
perfect, or the merits/challenges of simplifying contracts.

Instead, my point was that what you described sounds awfully low level 
for the board to be engaging.  Your reply suggested to me that you think 
it is obvious that simpler contracts are better and allow for less 
(legal) exposure for the IETF, but that doesn’t actually address my 
point.

The IAOC was often accused of having gotten too operational in the 
administrative workings of the IETF.
For an illustration of what happens when the oversight board implements 
the “obviously best approach to implementing administrative feature 
X”, I urge you to review the past history of financial representation 
for the IETF, which changed with the membership of the IAOC.  Each one 
was “best” in the eyes of the then-current IAOC.

Among other things, moving to the LLC was meant to create an executive 
board that would be able to refrain from that sort of digging into the 
details.

So, I think the answer I was hoping for was more along the lines of:   
We have (or will) outlined the issues of exposure due to complexity of 
contracts to the Executive Director, and look for their proposals for 
addressing those exposures or motivating the complexity/identifying 
remediation paths.

That seems a lot more like the executive board identifying a (potential) 
strategic issue, and letting the implementors, who will actually hold 
the contracts and live with the contracts going forward, do the work.

In later parts of the plenary, which you’ll want to catch up with when 
the recording is available, concerns were raised from the community 
about the state of relationship with the people and organizations that 
are on the other end of those contracts.    It did make me wonder 
whether complexity of contracts was our biggest exposure — breaking 
relationships with critical expert support could actually be a threat 
with a greater risk factor.

Best,
Leslie.

-- 

-------------------------------------------------------------------
Leslie Daigle
Principal, ThinkingCat Enterprises
[email-masked]
-------------------------------------------------------------------

---

From: Michael Richardson <[email-masked]>
Date: Fri, 26 Jul 2019 01:52:02 -0400

Leslie Daigle <[email-masked]> wrote:
    > Instead, my point was that what you described sounds awfully low level for
    > the board to be engaging. Your reply suggested to me that you think it is
    > obvious that simpler contracts are better and allow for less (legal)
    > exposure 
    > for the IETF, but that doesn’t actually address my point.

I also felt as Leslie did about this.
Both that this was too-low-level (and I was on the IAOC finance subcmte
before), and I think that your answer missed the point.

    > In later parts of the plenary, which you’ll want to catch up with when the
    > recording is available, concerns were raised from the community about the
    > state of relationship with the people and organizations that are on the
    > other end of those contracts. It did make me wonder whether complexity
    > of contracts was our biggest exposure — breaking relationships with
    > critical expert 
    > support could actually be a threat with a greater risk factor.

+1

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Leif Johansson <[email-masked]>
Date: Tue, 30 Jul 2019 13:10:01 +0200

> are on the other end of those contracts. It did make me wonder whether
> complexity of contracts was our biggest exposure — breaking
I want to "bump" this thread lest this point gets lost. I am worried
that looking at contracts as something mostly affecting the contractor
and the IETF LLC poses signifficant risk for further breakage.

	Cheers Leif

---

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 31 Jul 2019 18:46:50 +0000

Hi Leslie – Please see comments inline below.
Thanks,
Jason

From: LLC-Board <[email-masked]> on behalf of Leslie Daigle <[email-masked]>
Date: Thursday, July 25, 2019 at 6:21 PM
To: "[email-masked]" <[email-masked]>
Cc: Ietf <[email-masked]>
Subject: [LLC-Board] LLC Board and contracts -- plenary comments

Jason, LLC Board,

I asked what the strategic oversight imperative was behind your comment that the LLC Board was “simplifying contracts”; and, specifically, how you were translating that into a directive for your (eventual) Executive Director.

My point was not actually to argue whether the current contracts are perfect, or the merits/challenges of simplifying contracts.

Instead, my point was that what you described sounds awfully low level for the board to be engaging. Your reply suggested to me that you think it is obvious that simpler contracts are better and allow for less (legal) exposure for the IETF, but that doesn’t actually address my point.

[JL] This is about the strategic need to limit risk, and contain costs/complexity.

The IAOC was often accused of having gotten too operational in the administrative workings of the IETF.

For an illustration of what happens when the oversight board implements the “obviously best approach to implementing administrative feature X”, I urge you to review the past history of financial representation for the IETF, which changed with the membership of the IAOC. Each one was “best” in the eyes of the then-current IAOC.

Among other things, moving to the LLC was meant to create an executive board that would be able to refrain from that sort of digging into the details.

So, I think the answer I was hoping for was more along the lines of: We have (or will) outlined the issues of exposure due to complexity of contracts to the Executive Director, and look for their proposals for addressing those exposures or motivating the complexity/identifying remediation paths.

That seems a lot more like the executive board identifying a (potential) strategic issue, and letting the implementors, who will actually hold the contracts and live with the contracts going forward, do the work.

[JL] I believe we are aligned with what you hope to see. The Board asked the Executive Director to work with legal counsel to do all this.