Subject: Applying "Note Well" to side meetings

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 20 Jul 2019 20:18:37 +0100

Hi,

Normally [1] when we have a "bar BoF" (also known as a "side meeting") we do
not apply the terms of the "Note Well" [2]. We have usually considered bar
BoFs to be outside the IETF because the IETF has no control over who meets
and drinks.

However, this time around, the side meetings are somewhat more formal with
room bookings and projectors and advertisements and so on.

So, does the Note Well apply to these side meetings?

Apologies if I missed an email on this: I sometimes don't focus as much as I
should.

Thanks,
Adrian

[1] For some practical definition of "normal"
[2] https://www.ietf.org/about/note-well/
--
Read some fairy stories for adults of all ages
. Tales from the Wood
. More Tales from the Wood
. Tales from Beyond the Wood
. Tales from the Castle
Get them on line https://www.feedaread.com/profiles/8604/
Or buy a signed copy from me by post
*** Stop me in the corridor at IETF-105 to get a copy ***

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 21 Jul 2019 01:57:24 +0000

It was my understanding that note well always applied

________________________________
From: ietf <[email-masked]> on behalf of Adrian Farrel <[email-masked]>
Sent: Saturday, July 20, 2019 3:19 PM
To: 'IETF Rinse Repeat'
Subject: Applying "Note Well" to side meetings

Hi,

Thanks,
Adrian

[1] For some practical definition of "normal"
[2] https://www.ietf.org/about/note-well/
--
Read some fairy stories for adults of all ages
.. Tales from the Wood
.. More Tales from the Wood
.. Tales from Beyond the Wood
.. Tales from the Castle
Get them on line https://www.feedaread.com/profiles/8604/
Or buy a signed copy from me by post
*** Stop me in the corridor at IETF-105 to get a copy ***

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 21 Jul 2019 03:24:34 +0100

I don't think it applies to conversations I have with passing strangers when
I am in the street outside the hotel. My point being that there is a line. I
am asking on what side of the line a "side meeting" now falls.

Adrian

From: Phillip Hallam-Baker <[email-masked]> 
Sent: 21 July 2019 02:57
To: [email-masked]; 'IETF Rinse Repeat' <[email-masked]>
Subject: Re: Applying "Note Well" to side meetings

 

  _____  

From: ietf <[email-masked] <mailto:[email-masked]> > on behalf
of Adrian Farrel <[email-masked] <mailto:[email-masked]> >
Sent: Saturday, July 20, 2019 3:19 PM
To: 'IETF Rinse Repeat'
Subject: Applying "Note Well" to side meetings 

Hi, 

should. 

Thanks, 
Adrian

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 21 Jul 2019 04:01:16 +0000

Speaking as an IPR holder, I would consider it prudent to regard any conversation during IETF week as being potentially covered, regardless of venue

Speaking as someone who might be concerned about having someone promote covert IPR claims, I have been known to raise note well in such discussions.

________________________________
From: Adrian Farrel <[email-masked]>
Sent: Saturday, July 20, 2019 10:24 PM
To: 'Phillip Hallam-Baker'; 'IETF Rinse Repeat'
Subject: RE: Applying "Note Well" to side meetings

I don’t think it applies to conversations I have with passing strangers when I am in the street outside the hotel. My point being that there is a line. I am asking on what side of the line a “side meeting” now falls.

Adrian

________________________________
From: ietf <[email-masked]<mailto:[email-masked]>> on behalf of Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Sent: Saturday, July 20, 2019 3:19 PM
To: 'IETF Rinse Repeat'
Subject: Applying "Note Well" to side meetings

Hi,

Thanks,
Adrian

---

From: "Salz, Rich" <[email-masked]>
Date: Sun, 21 Jul 2019 10:17:06 +0000

>It was my understanding that note well always applied

Same here.

---

From: "Scott O. Bradner" <[email-masked]>
Date: Sun, 21 Jul 2019 06:23:54 -0400

speaking as co-editor of the ruleset

see the definition of “Contribution” in RFC 8179

basically, the “note well” applies whenever activities that are "intended to 
affect the IETF Standards Process” may happen

Scott

> On Jul 20, 2019, at 3:18 PM, Adrian Farrel <[email-masked]> wrote:
> 
> Hi,
>

---

From: Richard Barnes <[email-masked]>
Date: Sun, 21 Jul 2019 06:25:12 -0400

On Sun, Jul 21, 2019 at 06:17 Salz, Rich <[email-masked]> wrote:

> *>*It was my understanding that note well always applied
>
>
>
> Same here.
>

Maybe folks could provide a citation for this?  Because I have exactly the
opposite impression — that the Note Well only applies in contexts where it
is explicitly stated that it does, e.g., official sessions.

As Adrian says, there is a line.  I understood that line to be something
like, “The organizers of the meeting decide to apply Note Well”, just as
one might apply the Chatham House Rule.  So side meetings could be covered
if they chose, but not by default.

In any case, the premise for this thread seems a bit confused, since side
meetings are by definition not subject to IETF control.

—RLB

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 21 Jul 2019 12:26:08 +0100

Thanks Scott, that's helpful.
A

-----Original Message-----
From: Scott O. Bradner <[email-masked]> 
Sent: 21 July 2019 11:24
To: Adrian Farrel <[email-masked]>
Cc: IETF Rinse Repeat <[email-masked]>
Subject: Re: Applying "Note Well" to side meetings

Scott

---

From: Richard Barnes <[email-masked]>
Date: Sun, 21 Jul 2019 07:42:47 -0400

Scott, I think you may be over-stating things a bit.  The IETF doesn't get
to make universal statements that apply to things out of its remit.  For
example, there are numerous research conferences that are held on
IETF-related technologies -- often with a specific focus on providing
helpful input to IETF! -- which are not held under note well.

The location of such meetings alongside IETF meetings does not change this
fact.  AFAICT, ANRW is not covered by Note Well, despite having the
explicit goal of "transition[ing] research back into IETF".

The definition of Contribution in 8179 makes this clear from the start:

"""
"Contribution": any submission to the IETF ...
"""

---

From: "Scott O. Bradner" <[email-masked]>
Date: Sun, 21 Jul 2019 08:02:26 -0400

you are entitled to your opinion, of course, but I am speaking as a person who ran the BOF where the specific
text "intended to affect the IETF Standards Process” was developed and agreed to as well as a person who 
edited the specific text - it is my opinion that the BOF (and thus the IETF) intended the rules to apply
wherever actions are taken or text developed that are "intended to affect the IETF Standards Process” 
in particular, IPR disclosure is required if known

I have no opinion as to the facts of the specific case of ANRW since I have not been following that

Scott

> On Jul 21, 2019, at 7:42 AM, Richard Barnes <[email-masked]> wrote:
> 
> Scott, I think you may be over-stating things a bit.  The IETF doesn't get to make universal statements that apply to things out of its remit.  For example, there are numerous research conferences that are held on IETF-related technologies -- often with a specific focus on providing helpful input to IETF! -- which are not held under note well.
> 
> The location of such meetings alongside IETF meetings does not change this fact.  AFAICT, ANRW is not covered by Note Well, despite having the explicit goal of "transition[ing] research back into IETF".
>

---

From: "Scott O. Bradner" <[email-masked]>
Date: Sun, 21 Jul 2019 08:08:15 -0400

ps - I see that ANRW is an IRTF research group - thus https://irtf.org/ipr applies 
(and that says that the IETF rules apply)

Scott

> On Jul 21, 2019, at 8:02 AM, Scott O. Bradner <[email-masked]> wrote:
>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 22 Jul 2019 00:12:05 +1200

IANAL and I think the IESG needs to get the IETF's lawyer's opinion, preferably before tomorrow morning. But given the words in the BCP, better safe than sorry.

A meeting scheduled in a room paid for as part of the IETF meeting sure seems as if it's probably intended to affect the standards process.

   Brian

---

From: Warren Kumari <[email-masked]>
Date: Sun, 21 Jul 2019 08:33:32 -0400

On Sun, Jul 21, 2019 at 6:25 AM Richard Barnes <[email-masked]> wrote:
> Maybe folks could provide a citation for this?  Because I have exactly the opposite impression — that the Note Well only applies in contexts where it is explicitly stated that it does, e.g., official sessions.
>
> As Adrian says, there is a line.  I understood that line to be something like, “The organizers of the meeting decide to apply Note Well”, just as one might apply the Chatham House Rule.

IANAL, these are only my muddled thoughts, etc, but that is completely
exactly 100% the opposite of my understanding:

" m. "Participating in an IETF discussion or activity": making a
      Contribution, as described above, or **in any other way acting in
      order to influence the outcome of a discussion relating to the
      IETF Standards Process**.  Without limiting the generality of the
      foregoing, acting as a Working Group Chair or Area Director
      constitutes "Participating" in all activities of the relevant
      working group(s) he or she is responsible for in an area.
      "Participant" and "IETF Participant" mean any individual
      Participating in an IETF discussion or activity.
"
[ Emphasis mine ]

Perhaps if there was a side-meeting on the best way to plant potatoes
it wouldn't have to apply -- however, I think any realistic side
meeting at the IETF is likely to be "acting in order to influence the
outcome of a discussion relating to the IETF Standards Process."
If I were chairing a WG meeting and the VGA cable fell out just as I
was showing the Note Well, it's clear that it would still apply.
Similarly if I were to organize an interim meeting on V6OPS and forgot
to display the Note Well, I'd think it is clear it would still apply.
Side meetings might not be same thing, but other than "Luigi Iannone
@TPT" (which I simply have no idea what it's about) all of them seem
to me like they are likely to have discussions which may be "acting in
order to influence the outcome of a discussion relating to the IETF
Standards Process. "

> So side meetings could be covered if they chose, but not by default.
>
> In any case, the premise for this thread seems a bit confused, since side meetings are by definition not subject to IETF control.

I'm not 100% sure I understand what you mean by "IETF control" here --
if participants are "in any other way acting in order to influence the
outcome of a discussion relating to the IETF Standards Process" the
Note Well applies (at least according to my understanding).
The Note Well isn't something which gets invoked by summoning it, it
applies whenever I'm acting in a way which influences the discussions
about a document, etc.; the Note Well slide doesn't invoke the
protections, it *reminds* people of them.

Much of the note well process also falls into the "don't be a jerk"
category -- if we are sitting next to each other on a plane, and
complaining about flight delays, even though we are not "acting in
order to influence the outcome of a discussion relating to the IETF
Standards Process" if I know of IPR which affects your draft, I'd be a
jerk if I didn't tell you....

It feel to me like the IETF is drifting from a culture of "let's make
protocols to make the Internet work better; 'tis good for all and also
fun!" into a much more corporate / "how can I leverage this
organization for my benefit" feel - yes, companies have always tried
to optimize for themselves, but I'm talking more about the culture /
"feeling" of the IETF. It feels to me[0] like we are moving from (to
quote Spencer) "Do the right thing" to "the rules say I *can* do X, so
X is fine to do..."

W
[0]: Note: I haven't had my morning coffee, I might be more cynical
than normal...

-- 
I don't think the execution is relevant when it was obviously a bad
idea in the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair
of pants.
   ---maf

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 21 Jul 2019 08:36:04 -0400

It is worth remembering that the original concern arose out of an episode
many decades ago when a patent holder sent people to a standards meeting to
insert a requirement to make use of technology they had an undeclared
interest in.

That particular case was self-healing in that the court invalidated the
patent as a result.

So if you have IPR and wish to keep it, it would probably be in your best
interest to avoid any activity a court might interpret as deliberately
doing something of the sort.

The much bigger IPR problem comes from the far more numerous claims made by
parties that never send anyone to anything and from the people who monitor
standards processes so that they can make claims on the technology being
discussed. The fact that such a patent will 'probably' not stand in court
is no guarantee it won't.

Someone had a patent purporting to claim the invention of Web Mail. Which
is really odd because a Web Mail system just happened to be the test case I
used as a test case for HTTP and discovered that the POST method was broken
as a result. (Web Mail was not very useful in 1993 because it solved a
problem most people didn't yet have)

One of the reasons I pushed to have the IETF mailing lists run by IETF and
permanently archived was precisely to mitigate this type of behavior.

On Sun, Jul 21, 2019 at 8:12 AM Brian E Carpenter <
[email-masked]> wrote:

> IANAL and I think the IESG needs to get the IETF's lawyer's opinion,
> preferably before tomorrow morning. But given the words in the BCP, better
> safe than sorry.
>
> A meeting scheduled in a room paid for as part of the IETF meeting sure
> seems as if it's probably intended to affect the standards process.
>
>    Brian
>
> > you are entitled to your opinion, of course, but I am speaking as a
> person who ran the BOF where the specific
> >> Scott, I think you may be over-stating things a bit.  The IETF doesn't
> get to make universal statements that apply to things out of its remit.
> For example, there are numerous research conferences that are held on
> >> The location of such meetings alongside IETF meetings does not change
> this fact.  AFAICT, ANRW is not covered by Note Well, despite having the

---

From: John C Klensin <[email-masked]>
Date: Sun, 21 Jul 2019 09:05:19 -0400

--On Sunday, 21 July, 2019 08:33 -0400 Warren Kumari
<[email-masked]> wrote:

>...
> It feel to me like the IETF is drifting from a culture of
> "let's make protocols to make the Internet work better; 'tis
> good for all and also fun!" into a much more corporate / "how
> can I leverage this organization for my benefit" feel - yes,
> companies have always tried to optimize for themselves, but
> I'm talking more about the culture / "feeling" of the IETF. It
> feels to me[0] like we are moving from (to quote Spencer) "Do
> the right thing" to "the rules say I *can* do X, so X is fine
> to do..."

This is a feeling, and point, I've tried to suggest several
times recently in a variety of contexts.  Not good, either
generally or because our procedures and safeguards are not
well-designed for situations in which people are trying to split
hairs or beat the system.

The other observation about "IETF control" is that, if the IETF
is providing the facilities, facilitating the meetings (even by
supplying a web page or bulleting board telling that they are
being held or where they are) or considering postings about them
to IETF lists to be within our rules, then they are most likely
IETF discussions or activities .

IANAL, but what I was told by lawyers specializing in standards
bodies and their legal status many years ago is that activities
of standards bodies, at least ones that meet other criteria, are
given a certain amount of tolerance.  Rules like those of BCP 78
and BCP 79 (they are the source of the rules, the Note Well, no
matter how many times we repeat or point to it, is just a
pointer and reminder), really protect the recipient.  Suppose,
for example, that Warren decided to hold a private meeting with
someone from a major competitor of Google's, say Baidu.  They
didn't publicize the meeting, they claimed it was not about IETF
business, and Warren explicitly left his AD hat outside the
door.   Well, they had better be discussing planting potatoes
and be able to prove it because, otherwise such a meeting is
bait for competitiveness and antitrust regulators. From what I
was told "back then", if Goodgle's and Baidu's lawyers haven't
warned them about such situations, they aren't doing their jobs.
And, at least for that particular situation, claiming that we
all participate in IETF as individuals so there is no problem
wouldn't pass a laugh test.   

Have a few others present, keep Warren's hat on, etc., and most
likely no problem.  

Let's not even try to figure out how finely the lines can be
drawn.

best,
   john

---

From: Colin Perkins <[email-masked]>
Date: Sun, 21 Jul 2019 09:36:24 -0400

The ANRW is an academic workshop that happens to be co-located with IETF. We made an explicit decision when starting the workshop, several years ago now, that the Note Well does not apply to it. 

If work is brought from ANRW into either an IRTF RG or an IETF WG, then the Note Well would apply, of course.

Colin

> On 21 Jul 2019, at 08:08, Scott O. Bradner <[email-masked]> wrote:
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: John C Klensin <[email-masked]>
Date: Sun, 21 Jul 2019 09:41:43 -0400

Actually, Phill, you may well be referring to something earlier,
but the case that raised (or created) awareness of the problem
in the US and several SDOs who had not been paying enough
attention before was ASME vs. Hydrolevel case that started in
1971 and cumulated in a US Supreme Court Decision in 1982. But
the problem (which is actually at least two separate potential
problems, see below) was known, and discussed in ANSI and
ANDI-accredited SDOs, long before that.  I would be surprised if
there were not similar discussions in ISO and assorted other
national standards bodies, but I was not aware of them.  

The ASME case was special for another reason, because is was
less about IPR but about conflicts of interest in interpretation
of a standard and violations of antitrust laws.   As Scott has
heard me say too many times and for too long, I've always been
concerned that the IETF's policies concentrate almost
exclusively on patent issues and disclosure and largely ignore
issues that could be construed as attempts it interfere with
competition or violation associated laws and regulations in
relevant countries.  In a way, those other issues should be even
more important to the IETF.  As you point out, in many cases
when a standards body is used to reinforce or give some
advantage to a particular patent, the patent gets invalidated
(probably not enough cases, but many) hurting the patent
claimant and everyone trying to use the IPR.    But taking
actions that can be interpreted as conspiracies to restrain
trade put the IETF in jeopardy.  Much of the standards community
was surprised that the courts allowed ASME to continue as a
standards developer because the outcome could possibly even have
shut them down as a professional society.  

In that context, while I have no concerns about the personal
integrity and ethics of any of the people involved, we now
apparently have two separate Areas with more than one AD from
the same company.  The optics are nonetheless terrible.  If
someone wanted to devote time to developing an explicit code of
ethics for such situations, it would probably help both the IETF
and the individuals by being able to show, if questions arose,
that there were explicit rules, that they were reasonable, and
that they had been followed.

best,
   john

--On Sunday, 21 July, 2019 08:36 -0400 Phillip Hallam-Baker
<[email-masked]> wrote:

> It is worth remembering that the original concern arose out of
> an episode many decades ago when a patent holder sent people
> to a standards meeting to insert a requirement to make use of
> technology they had an undeclared interest in.

---

From: "Scott O. Bradner" <[email-masked]>
Date: Sun, 21 Jul 2019 09:41:54 -0400

you made an explicit decision that people can hide their IPR?

have fun with that

Scott

> On Jul 21, 2019, at 9:36 AM, Colin Perkins <[email-masked]> wrote:
>

---

From: Colin Perkins <[email-masked]>
Date: Sun, 21 Jul 2019 09:46:31 -0400

Since the ANRW is an academic conference, we made the decision to follow the usual norms for such events and not require IPR disclosure. 

If the work is brought into an IRTF RG, or an IETF WG, then the usual IRTF and IETF IPR disclosure rules apply.

Colin

> On 21 Jul 2019, at 09:41, Scott O. Bradner <[email-masked]> wrote:
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: "Scott O. Bradner" <[email-masked]>
Date: Sun, 21 Jul 2019 09:53:37 -0400

sorry, I was confused by the meeting at the IETF - I expect I’m not the only one based on the discussion - maybe the first slide needs to say 

	“THIS IS NOT AN IRTF RG”

Scott

> On Jul 21, 2019, at 9:46 AM, Colin Perkins <[email-masked]> wrote:
>

---

From: Colin Perkins <[email-masked]>
Date: Sun, 21 Jul 2019 09:59:49 -0400

I’ve previously asked the chairs to make this clear in their introductory slides.
Colin

> On 21 Jul 2019, at 09:53, Scott O. Bradner <[email-masked]> wrote:
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: John C Klensin <[email-masked]>
Date: Sun, 21 Jul 2019 10:01:09 -0400

Colin,

The problem is that, if ANSW is an IRTF group and/or it is using
facilities that are supported in any way by the IETF (probably
including such things as discounts on hotel or meeting rooms due
to the IETF contract), you don't get to decide, any more than
you get to decide that whatever rule Montreal has about public
drunkenness don't apply.  If you want to be exempt, don't
co-locate or use IETF facilities and consult with the IAB, the
IETF LLC, and appropriate lawyers as to whether other measures
are appropriate.

Phill's comments about concealing the existence of patents
(pending or granted) in order to strengthen their position in
the marketplace would apply whether the IETF has its IPR rules
or not.

Long ago, almost certainly before IASA 1.0, the IETF had a
fairly firm rule about pre-organized side meetings which were
not part of the IETF process.  They were not allowed to use
_any_ IETF-provided or related resource or facilities.
Concurrent or co-located meetings were discouraged, cards
announcing such meetings were taken off announcement bulletin
boards, companies wanting to hold staff meeting or do recruiting
were told use a different hotel or other location, and so on.
Just "no".     I never asked, but assumed that was done on
advice of counsel because it kept the lines extremely clear.  If
it was, I can even guess at the name of the relevant lawyer.

Coming back to my response to Warren, I fear that we are
behaving in a way that encourages trying to draw fine lines and
hair-splitting.  I don't think that is good for the IETF
generally.   Given that some to the issues could involve acts
that are criminal in some locations and that courts might
disagree with how we split those hairs, I also hope that ADs,
IETF LLC Board members, and anyone similarly situated how gotten
advice from their lawyers about potential risks.

(my last posting on this thread before I get to Montreal)

best,
  john

--On Sunday, 21 July, 2019 09:36 -0400 Colin Perkins
<[email-masked]> wrote:

> The ANRW is an academic workshop that happens to be co-located
> with IETF. We made an explicit decision when starting the
> workshop, several years ago now, that the Note Well does not
> apply to it. 
> 
> If work is brought from ANRW into either an IRTF RG or an IETF
> WG, then the Note Well would apply, of course.
> 
> Colin
> 
> 
> 
>> ps - I see that ANRW is an IRTF research group - thus
>> https://irtf.org/ipr applies  (and that says that the IETF
>> rules apply)
>> 
>> Scott
>> 
>> 
>>> you are entitled to your opinion, of course, but I am
>>> speaking as a person who ran the BOF where the specific text
>>> "intended to affect the IETF Standards Process" was
>>> developed and agreed to as well as a person who  edited the
>>> specific text - it is my opinion that the BOF (and thus the
>>> IETF) intended the rules to apply wherever actions are taken
>>> or text developed that are "intended to affect the IETF
>>> Standards Process"  in particular, IPR disclosure is
>>> required if known
>>> 
>>> I have no opinion as to the facts of the specific case of
>>> ANRW since I have not been following that
>>> 
>>> Scott
>>> 
>>>> Scott, I think you may be over-stating things a bit.  The
>>>> IETF doesn't get to make universal statements that apply to
>>>> things out of its remit.  For example, there are numerous
>>>> research conferences that are held on IETF-related
>>>> technologies -- often with a specific focus on providing
>>>> The location of such meetings alongside IETF meetings does
>>>> not change this fact.  AFAICT, ANRW is not covered by Note
>>>> Well, despite having the explicit goal of "transition[ing]
>>>> research back into IETF".
>>>> 
>>>> On Sun, Jul 21, 2019 at 7:27 AM Adrian Farrel
>>>> <[email-masked]> wrote: Thanks Scott, that's helpful.
>>>> A
>>>> 
>>>> see the definition of "Contribution" in RFC 8179
>>>> 
>>>> basically, the "note well" applies whenever activities
>>>> that are "intended to  affect the IETF Standards Process"
>>>> may happen
>>>> 
>>>> Scott
>>>> 
>>>>> Normally [1] when we have a "bar BoF" (also known as a
>>>>> "side meeting") we do not apply the terms of the "Note
>>>>> Well" [2]. We have usually considered bar BoFs to be
>>>>> outside the IETF because the IETF has no control over who
>>>>> meets and drinks.
>>>>> 
>>>>> However, this time around, the side meetings are somewhat
>>>>> more formal with room bookings and projectors and
>>>>> advertisements and so on.
>>>>> 
>>>>> Apologies if I missed an email on this: I sometimes don't
>>>>> focus as much as I should.
>>>>> 
>>>>> Thanks,
>>>>> Adrian
>>>>>

---

From: Richard Barnes <[email-masked]>
Date: Sun, 21 Jul 2019 10:02:08 -0400

Great, so unless anyone wants to tell Colin that ANRW needs to adopt the
Note Well, we've validated that side meetings held alongside IETF can have
their own IPR rules.

To Warren's "don't be a jerk" point -- this absolutely doesn't mean that
people *shouldn't* disclose their IPR, it just means they're not
*obligated* to, in the sense of RFC 8179.

--Richard

On Sun, Jul 21, 2019 at 9:54 AM Scott O. Bradner <[email-masked]> wrote:

> sorry, I was confused by the meeting at the IETF - I expect I’m not the
> only one based on the discussion - maybe the first slide needs to say
>
>         “THIS IS NOT AN IRTF RG”
>
> Scott
>
>
>
> > Since the ANRW is an academic conference, we made the decision to follow
> the usual norms for such events and not require IPR disclosure.
> >
> > If the work is brought into an IRTF RG, or an IETF WG, then the usual
> IRTF and IETF IPR disclosure rules apply.
> >
> > Colin
> >
> >
> >>> The ANRW is an academic workshop that happens to be co-located with
> IETF. We made an explicit decision when starting the workshop, several
> years ago now, that the Note Well does not apply to it.
> >>>
> >>> If work is brought from ANRW into either an IRTF RG or an IETF WG,
> then the Note Well would apply, of course.
> >>>
> >>> Colin
> >>>
> >>>
> >>>
> https://irtf.org/ipr applies
> >>>>>> Scott, I think you may be over-stating things a bit.  The IETF
> doesn't get to make universal statements that apply to things out of its
> remit.  For example, there are numerous research conferences that are held
> on IETF-related technologies -- often with a specific focus on providing
> >>>>>> The location of such meetings alongside IETF meetings does not
> change this fact.  AFAICT, ANRW is not covered by Note Well, despite having
> the explicit goal of "transition[ing] research back into IETF".
> >>>>>>

---

From: Allison Mankin <[email-masked]>
Date: Sun, 21 Jul 2019 10:02:56 -0400

Ah, this issue escaped my attention while I was IRTF Chair during ANRW18.

Good to message it clearly this time, given the decision

On Sun, Jul 21, 2019 at 10:00 AM Colin Perkins <[email-masked]> wrote:

> >> Since the ANRW is an academic conference, we made the decision to
> follow the usual norms for such events and not require IPR disclosure.
> >>

---

From: Richard Barnes <[email-masked]>
Date: Sun, 21 Jul 2019 10:04:14 -0400

On Sun, Jul 21, 2019 at 10:02 AM John C Klensin <[email-masked]> wrote:

> drunkenness don't apply.

John: Do you have a citation for this?  It seems like if there were a
document that said, "A meeting that in any way using facilities that are
supported in any way by the IETF is subject to the Note Well", that would
be dispositive.  And if not, there's no obligation.

--Richard

> If you want to be exempt, don't

---

From: Lars Eggert <[email-masked]>
Date: Sun, 21 Jul 2019 10:08:49 -0400

Hi,

> IETF LLC, and appropriate lawyers as to whether other measures

by that measure, the Note Well would also start applying to company-internal coordination meetings during the IETF, because they happen in meeting rooms reserved out of the IETF contracted block. Not to mention the various ISOC meeting and/or host presentations that are on the agenda.

Lars

---

From: Keith Moore <[email-masked]>
Date: Sun, 21 Jul 2019 10:22:02 -0400

> by that measure, the Note Well would also start applying to company-internal coordination meetings during the IETF, because they happen in meeting rooms reserved out of the IETF contracted block. N…

I'm not sure where to draw the line.  The hotel can presumably rent 
space to whomever it wishes, unless its contract with I* states otherwise.

But surely any attempt by an external organization to "blur the line" 
and make it appear as if their activities are somehow part of IETF, 
without adhering to IETF rules, is at least acting in bad faith.

For instance, I'd have a serious problem with a private company renting 
a meeting room at the same venue and time at which IETF meetings were 
being held, inviting other IETF participants to have conversations there 
without drawing a clear distinction between the private meeting and 
IETF, and not adhering to IETF's rules for IPR and other things.

Keith

---

From: S Moonesamy <[email-masked]>
Date: Sun, 21 Jul 2019 07:37:06 -0700

Hi Adrian,
>room bookings and projectors and advertisements and so on.

The "Note Well" policies are applicable for IETF activities.  BCP78 
and BCP 79  are part of those policies.  If I am not mistaken, side 
meetings did not usually meet the requirements of the standards process.

>So, does the Note Well apply to these side meetings?

Please see the message at 
https://mailarchive.ietf.org/arch/msg/ietf/2kHXUHM3MAUnrtcakVg1_5FEcgM 
and the thread at 
https://mailarchive.ietf.org/arch/msg/mud/bCGhkSXOM_M2-bO5LLykR7ij4kE

Regards,
S. Moonesamy

---

From: Colin Perkins <[email-masked]>
Date: Sun, 21 Jul 2019 11:26:52 -0400

> On 21 Jul 2019, at 10:02, Richard Barnes <[email-masked]> wrote:
> 
> Great, so unless anyone wants to tell Colin that ANRW needs to adopt the Note Well, we've validated that side meetings held alongside IETF can have their own IPR rules.

The IRTF has chosen a particular policy for one of its events. I’m not sure that says anything about the IETF’s policy for side meetings it facilitates.

Colin

> To Warren's "don't be a jerk" point -- this absolutely doesn't mean that people *shouldn't* disclose their IPR, it just means they're not *obligated* to, in the sense of RFC 8179.
> 
> --Richard
> 
> 
> On Sun, Jul 21, 2019 at 9:54 AM Scott O. Bradner <[email-masked] <mailto:[email-masked]>> wrote:
> > On Jul 21, 2019, at 9:46 AM, Colin Perkins <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> >> On 21 Jul 2019, at 09:41, Scott O. Bradner <[email-masked] <mailto:[email-masked]>> wrote:
> >> 
> >>> On Jul 21, 2019, at 9:36 AM, Colin Perkins <[email-masked] <mailto:[email-masked]>> wrote:
> >>> 
> >>>> On 21 Jul 2019, at 08:08, Scott O. Bradner <[email-masked] <mailto:[email-masked]>> wrote:
> >>>> 
> >>>> ps - I see that ANRW is an IRTF research group - thus https://irtf.org/ipr <https://irtf.org/ipr> applies 
> >>>>> On Jul 21, 2019, at 8:02 AM, Scott O. Bradner <[email-masked] <mailto:[email-masked]>> wrote:
> >>>>> 
> >>>>>> On Sun, Jul 21, 2019 at 7:27 AM Adrian Farrel <[email-masked] <mailto:[email-masked]>> wrote:
> >>>>>> From: Scott O. Bradner <[email-masked] <mailto:[email-masked]>> 
> >>>>>> Sent: 21 July 2019 11:24
> >>>>>> To: Adrian Farrel <[email-masked] <mailto:[email-masked]>>
> >>>>>> Cc: IETF Rinse Repeat <[email-masked] <mailto:[email-masked]>>
> >>>>>>> On Jul 20, 2019, at 3:18 PM, Adrian Farrel <[email-masked] <mailto:[email-masked]>> wrote:
> >>>>>>> 
> >>>>>>> Hi,
> >>>>>>> 
> >>>>>>> [2] https://www.ietf.org/about/note-well/ <https://www.ietf.org/about/note-well/>
> >>>>>>> --
> >>>>>>> Get them on line https://www.feedaread.com/profiles/8604/ <https://www.feedaread.com/profiles/8604/>
> >>> https://csperkins.org/ <https://csperkins.org/>
> >>> 
> >>> 
> >>> 
> >>> 
> >> 
> > 
> > 
> > 
> > -- 
> > Colin Perkins
> > https://csperkins.org/ <https://csperkins.org/>
> > 
> > 
> > 
> > 
> 

-- 
Colin Perkins
https://csperkins.org/

---

From: Alissa Cooper <[email-masked]>
Date: Sun, 21 Jul 2019 11:32:59 -0400

Hi Adrian,

The IESG considers unofficial side meetings registered on the wiki to be IETF activities, and as such the note well and the policies it references apply to these meetings. I have updated the wiki [1] to make this clear. Note that all IETF meeting attendees also accept the note well when they register for the IETF meeting.  

The note well itself explains that "exceptions may apply” [2]. Other kinds of meetings held under the IETF Meeting Rooms Policy [3] may make exceptions on a case-by-case basis. Updating the meeting rooms policy and sharing it for community comment is on the to-do list of the IETF LLC, and clarifying this point seems like it could be one useful update. 

Cheers,
Alissa Cooper
for the IESG

[1] https://trac.ietf.org/trac/ietf/meeting/wiki/105sidemeetings
[2] https://www.ietf.org/about/note-well/
[3] https://www.ietf.org/how/meetings/meeting-rooms-policy/

---

From: John C Klensin <[email-masked]>
Date: Sun, 21 Jul 2019 11:57:48 -0400

--On Sunday, 21 July, 2019 10:04 -0400 Richard Barnes
<[email-masked]> wrote:

>> The problem is that, if ANSW is an IRTF group and/or it is
>> using facilities that are supported in any way by the IETF
>> (probably including such things as discounts on hotel or
>> meeting rooms due to the IETF contract), you don't get to
>> decide, any more than you get to decide that whatever rule
>> Montreal has about public drunkenness don't apply.
> 
> 
> John: Do you have a citation for this?  It seems like if there
> were a document that said, "A meeting that in any way using
> facilities that are supported in any way by the IETF is
> subject to the Note Well", that would be dispositive.  And if
> not, there's no obligation.

No.  And, if I did, I wouldn't post it on this list (nothing
personal, just a long-standing aversion to getting involved in
amateur lawyer debates).

So, a final comment from me: BCP 78 and 79 are ultimately about
a combination of some ethical principles that keep the IETF open
and transparent and looking that way and some legal
requirements.  If some group, presumably for good reason, wants
to declare themselves exempt from the first, fine with me as
long as the decision is clear.  As to the legal requirement, our
enforcement provisions notwithstanding, if there is ever a real
issue, it could easily end up in front of a judge.  If the judge
is convinced that rules that were intended to benefit the public
have been interpreted in a way that favors some particular
interests, it will often go badly for the hair-splitter.  So,
from a "protect the IETF" standpoint, I recommend against
hair-splitting, arguing over interpretations or precedents, or
encouraging any of those things.    

That is not to say someone can't get away with announcing that
the Note Well (or BCP 78 and 79) doesn't apply, just that it
might be risky, especially if the result of the other meeting
results in a decision to do (or alter) standards-related work
and someone later starts asking tough questions about just when
disclosure was required.

Looking ahead to Lar's note, same answer.  of course, a company
can hold private meetings with no one not associated with the
company present.  I'd hope that such meetings would be
absolutely above suspicion, which is why I think the old rule
was "different hotel or facility" but caution would suggest
that, if they meet in the same hotel, they be able to
demonstrate (should anyone ask or claim otherwise) that there
was no IETF support for their meeting.  I'd also hope that
someone at every company that is sending people to the IETF, and
especially ones that are holding on-site company strategy
meetings, is concerned that opposing litigators might get very
excited if IETF participants who attended those meetings then
claimed that their participation in the IETF was strictly as
individuals rather than on behalf of the company.  

Again, from my standpoint, that is just ordinary caution and a
variation on Warren's "don't be a jerk" comment.  If your
attorney says something different, listen to her.

Finally, I had understood that ANRW functioned as an IRTF RG in
addition to the academic conference.  That was apparently a
misunderstanding (I saw Colin's note on that subject after
sending mine) for which I apologize.  _IF_ it were an RG, then I
would stand my my statement that they don't get to decide.
Given that it isn't, that statement isn't applicable.  However,
if that meeting is co-located in the same facilities and taking
advantage of any IETF (or IETF LLC) resources, things are back
in hair-splitting territory.  They (and the IETF LLC) should
make whatever decisions -- not just about the Note Well but
about the nature of the boundary-- that make sense to them and
their lawyers.  I'll just be glad that, if something goes
astray, I'm not the one who has any liability.

best,
   john

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 21 Jul 2019 17:10:41 +0100

Thanks Alissa (and several people who have provided thoughts to me on list and in the corridor),

I'm grateful for the clarification and the note on the wiki that makes this easy for people to refer to in future.

Best,
Adrian

-----Original Message-----
From: Alissa Cooper <[email-masked]> 
Sent: 21 July 2019 16:33
To: Adrian Farrel <[email-masked]>
Cc: IETF Rinse Repeat <[email-masked]>
Subject: Re: Applying "Note Well" to side meetings

Hi Adrian,

Cheers,
Alissa Cooper
for the IESG

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 21 Jul 2019 23:30:50 -0400

John brings up a different but entirely relevant point here to the one I
was making. I was actually thinking about a later case where the issue was
the patent.

Back in the 1970s, the US had ferocious anti-Trust laws. What a lot of folk
have failed to note is that the laws never changed, only the enforcement of
them. And signs are that enforcement may be about to change.

This may yet come up in the WebPKI if a certain party makes a very very
ill-advised move.

---

From: Nico Williams <[email-masked]>
Date: Mon, 22 Jul 2019 10:57:15 -0500

> is explicitly stated that it does, e.g., official sessions.

I've long understood that Note Well applies when and only when
('WWHEN'?) it is invoked, and should be invoked whenever IETF work is
discussed among participants with different employers even if the
meeting is not an official IETF meeting.

Depending on the cast of attendees I might not invoke Note Well in a
side meeting with an unstated understanding that we're not out to screw
each other on IP.  However, this is a bad habit, and I should always
invoke Note Well when discussing IETF work or potential IETF work with
colleagues from other organizations.  It's a bad habit not just because
my friends might purposefully or otherwise screw me, but also because I
might forget to invoke Note Well when others are around.

Official IETF meetings are (I guess) required to invoke the Note Well,
whether they be interim or not, whether they be remote or not, but it
still needs to be invoked in order to really apply.

Bar BoFs are unofficial meetings, and thus not required to invoke Note
Well, thus too arguably there is no implied intent to have Note Well
apply to them, which is why Note Well should be invoked explicitly.  My
advice would be that Note Well always be invoked at the start of the bar
BoF and in any email threads for organizing a bar BoF and any
invitations sent (so that late arrivals understand the expectation that
Note Well applies).

It must not be a common occurrence that bar BoF participants intend Note
Well to _not_ apply.  It would be nice if Note Well could be made to
impliedly apply by default, but I guess that's not feasible.

> if they chose, but not by default.

+1

> meetings are by definition not subject to IETF control.

A lot of work happens in bar BoFs though, so it's a fair question.  So
either we shouldn't have them at all or we should acknowledge that they
are a thing.  The IETF can't control a bar BoF, but a) it can provide
advice about them, and b) it could provide rooms for ad-hoc BoFs with
Note Well plastered on the walls :)

Nico
--

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 23 Jul 2019 05:13:28 +1200

On 23-Jul-19 03:57, Nico Williams wrote:
> ('WWHEN'?) it is invoked, 

No. It's only a reminder of the IETF rules, and the rules apply to
all IETF activities -- all "contributions" in the IPR disclosure case.
See the earlier responses in this thread.

> and should be invoked whenever IETF work is

Since it's only a reminder, it is indeed a "should" but not invoking
it doesn't cancel the rules.

    Brian

> impliedly apply by default, but I guess that's not feasible.>

---

From: Nico Williams <[email-masked]>
Date: Mon, 22 Jul 2019 12:27:27 -0500

> See the earlier responses in this thread.

Thanks.  However, it's still the case that outside official IETF
meetings (interim and otherwise), Note Well applies WWHEN invoked --
surely it must be.

Nico
--

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 22 Jul 2019 13:40:02 -0400

Well...
If you have a side meeting, and discuss papers (which do not happen to 
have been Internet Drafts) and you do not invoke Note Well, then you do 
not have the right to use those papers for future IETF work.

Note Well is not just about patent disclosure.  It covers multiple things.

Yours,
Joel

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 22 Jul 2019 13:45:43 -0400

I realized after I sent this that there was an unintended implication.
I do not actually agree that Note Well needs to be invoked for side 
meetings at the IETF.  I was commenting on the implication if it were 
possible not to do so.

As others have commented, the relevant wording is about activities for 
the purpose of influencing IETF standardization.

Yours,
Joel

---

From: "Pete Resnick" <[email-masked]>
Date: Mon, 22 Jul 2019 15:23:14 -0400

> meetings (interim and otherwise), Note Well applies WWHEN invoked --

First, a clarification: When we say "The Note Well" (blech!), we're 
referring to the summary text that we put up at the beginning of 
meetings and on registration forms and the like, which is a reminder of 
*all* of the IETF policies and procedures; it is not itself a policy or 
procedure. So when people say, "invoke the Note Well", I'm not really 
sure what they mean; perhaps just, "We are hereby announcing that IETF 
rules apply here". But while I can try to "invoke the Note Well" with 
all of the patrons at my local coffee shop or at my next tai chi class, 
I can assure you that the folks there are not instantly bound to, for 
example, start disclosing their patents to me or anyone else at the 
IETF. The policies and procedures of the IETF apply when we are engaged 
in an IETF activity, and the only question is when we are engaged in an 
IETF activity. There's no "invoking" going on.

Also, remember that the policies and procedures really have two effects:

- They allow the IETF to say, "If you don't follow these rules, we can 
kick you out of the meeting / revoke your posting privileges / stop 
publication of your document / etc."

- They allow someone who is suing you, outside of the IETF context, to 
tell a judge "Hey, they didn't follow the rules at the IETF", at which 
point the judge can say, "Well, if you didn't follow the rules in the 
IETF you deserve to pay that person damages / lose rights to your IP / 
etc."

Strictly viewing from the perspective of the IETF, we only care about 
the first one, but we each personally might care very deeply about the 
second one.

As far as the IPR rules go, whether they apply depends on whether you 
are making a contribution, and RFC 8179 has pretty extensive text about 
what a contribution is: It's any "any statement made within the context 
of an IETF activity, in each case that is intended to affect the IETF 
Standards Process", and it goes on to say that such statements are those 
that are addressed to (among others):

       o  WG design teams (see BCP 25) and other design teams that 
intend
          to deliver an output to IETF, or portions thereof,

       o  the IESG, or any member thereof on behalf of the IESG,

       o  the IAB, or any member thereof on behalf of the IAB,

       o  any IETF mailing list, web site, chat room, or discussion 
board
          operated by or under the auspices of the IETF, including the
          IETF list itself,

And then the question is whether any particular side meeting meets one 
of those definitions above. Alissa posted earlier that the IESG 
considered the question and believes that the side meetings registered 
on the wiki *do* count as an "IETF activity" as described above. That 
means that (a) the IETF might say that you are subject to the sorts of 
punishments mentioned above if you don't follow the IPR rules in such a 
side meeting, and (b) if asked by a judge in a case outside of the IETF 
context, IESG members are likely to say that such a side meeting was 
operating under IETF rules, and the judge might take that opinion 
seriously and act accordingly. In other more nebulous cases, "your 
mileage may vary", as the saying goes.

pr
-- 
Pete Resnick http://www.episteme.net/
All connections to the world are tenuous at best