Subject: RSOC Apology

From: Sarah Banks <[email-masked]>
Date: Wed, 24 Jul 2019 13:45:15 -0400

IETF Community,

Since Heather announced her decision not to renew her contract as RFC Series Editor (RSE), there has been a considerable amount of discussion within the community. The RSOC has been watching closely, and we wanted to take the opportunity to share some further thoughts.

It's clear to us that the community is unhappy with this outcome; we share that feeling. We believe that our recommendation to put the contract out to bid again in two years was part of the reason behind her decision. In retrospect we would not make the same decision again, and we apologise to both her and the community for the decision, its repercussions, and the situation we now find ourselves in.

It was not RSOC's intent to put Heather in a difficult position, but rather to address an issue that concerned both us and her -- succession planning -- and we shared it with her in the spirit of transparency. While we took care to communicate that this was not a reflection of her performance, in retrospect, we should have handled it differently. 

To give some more detail: a few months ago, we had a large concern regarding the low number of responses to the previous RFP, and we believed that we would have a problem if for some reason we had to run that process again. Because of that, we wanted to learn how to get more responses. We convinced ourselves that the best way to do this was by exercising the process in 2021. With the benefit of hindsight, we recognize that this was a mistake. 

We also convinced ourselves that Heather would understand the thought process and agree with it. While we took some precautions to express that our decision was not a judgement of Heather's performance, we did not actually socialise the idea with her before making a recommendation. That was very clearly a mistake. If we had discussed the proposal with her, we would have better gauged her state of mind and understood the accumulated tensions.

We remain concerned that the RSE position seems to be subject to an unusual amount of tension. Currently, we are discussing how we can gather information from the community (including Heather) to further understand those tensions, and make recommendations with more positive outcomes for the role and the RFC series. We're also discussing how we can improve communication between the RSE, ourselves, the community, and the other leadership bodies.

We are also listening to the community about the next steps to be taken; in particular, coming to an agreement about whether the RFP process should be run to find a replacement RSE, thereby gaining the benefit of a smooth transition while Heather is still in the post, or whether another process first needs to be run (e.g., to reconsider the role and its relationship to other bodies). 

If you have thoughts about that or want to discuss other issues, please find an RSOC member this week; we want to hear from the community.

Finally, we'd like to thank Heather again for her dedication and long service as the RFC Series Editor to date; she entered a position that already had big shoes to fill, and in our estimation has enlarged them.

Regards,
Sarah Banks
For the RSOC

---

From: Ted Lemon <[email-masked]>
Date: Wed, 24 Jul 2019 14:37:06 -0400

To summarize, it is your belief that Heather did not renew because of the decision to rebid early, and for no other reason.

Is that correct?

In addition, it is your (collective) impression that there is an problem with the RSE position, and that we need to change how the RSE position is, but you haven’t stated what the problem is or how you would like to change the position.   You would like the community to help with this problem, although you haven’t said what it is.

Is that also correct?

---

From: Sarah Banks <[email-masked]>
Date: Wed, 24 Jul 2019 14:45:27 -0400

Hi Ted,
	Let me answer inline.

> On Jul 24, 2019, at 2:37 PM, Ted Lemon <[email-masked]> wrote:
> 

My email on this thread stated, "We believe that our recommendation to put the contract out to bid again in two years was part of the reason behind her decision." This is the RSOC belief.

> In addition, it is your (collective) impression that there is an problem with the RSE position, and that we need to change how the RSE position is, but you haven’t stated what the problem is or how…

The RSOC hasn't made a statement on any of this, outside of the fact that we recognize that the community is discussing most or all of the points you're asking above, and we're stating that we're following that conversation. You're welcome tor review our minutes, but to my knowledge, we haven't had a conversation about having a problem with the RSE position, or changing it (we've talked about the relationship of RSE to RPC as defined within 6635, within the context of the missed SLA, but I don't believe it rises to the occasion of "change something fundamental about entire roles"). To be clear, we're not saying there is a problem, but rather, acknowledging that the community believes there is, and following Ted's email regarding the search for an RSE, or revise the process, or any new options that arise, we're currently listening and taking the feedback.

Thanks,
Sarah

---

From: "Aaron Falk" <[email-masked]>
Date: Wed, 24 Jul 2019 14:57:51 -0400

Sarah-

Thank you for your apology and your explicit thoughts on what you think 
were mistakes made by the RSOC.  Your public accountability is to be 
commended.  I realize how hard it can be to admit fault in this 
emotional environment.

As the RSOC is responsible to the IAB, I would very much like to hear a 
similar statement from the IAB, the chair or the IAB’s RSOC program 
lead, regarding what mistakes were made so the community can consider 
whether the current arrangements require change before moving forward 
with finding an interim RSE.

--aaron

On 24 Jul 2019, at 13:45, Sarah Banks wrote:

> IETF Community,
>
> Since Heather announced her decision not to renew her contract as RFC 
> Series Editor (RSE), there has been a considerable amount of 
> discussion within the community. The RSOC has been watching closely, 
> and we wanted to take the opportunity to share some further thoughts.
>
> It's clear to us that the community is unhappy with this outcome; we 
> share that feeling. We believe that our recommendation to put the 
> contract out to bid again in two years was part of the reason behind 
> her decision. In retrospect we would not make the same decision again, 
> and we apologise to both her and the community for the decision, its 
> repercussions, and the situation we now find ourselves in.
>
> It was not RSOC's intent to put Heather in a difficult position, but 
> rather to address an issue that concerned both us and her -- 
> succession planning -- and we shared it with her in the spirit of 
> transparency. While we took care to communicate that this was not a 
> reflection of her performance, in retrospect, we should have handled 
> it differently.
>
> To give some more detail: a few months ago, we had a large concern 
> regarding the low number of responses to the previous RFP, and we 
> believed that we would have a problem if for some reason we had to run 
> that process again. Because of that, we wanted to learn how to get 
> more responses. We convinced ourselves that the best way to do this 
> was by exercising the process in 2021. With the benefit of hindsight, 
> we recognize that this was a mistake.
>
> We also convinced ourselves that Heather would understand the thought 
> process and agree with it. While we took some precautions to express 
> that our decision was not a judgement of Heather's performance, we did 
> not actually socialise the idea with her before making a 
> recommendation. That was very clearly a mistake. If we had discussed 
> the proposal with her, we would have better gauged her state of mind 
> and understood the accumulated tensions.
>
> We remain concerned that the RSE position seems to be subject to an 
> unusual amount of tension. Currently, we are discussing how we can 
> gather information from the community (including Heather) to further 
> understand those tensions, and make recommendations with more positive 
> outcomes for the role and the RFC series. We're also discussing how we 
> can improve communication between the RSE, ourselves, the community, 
> and the other leadership bodies.
>
> We are also listening to the community about the next steps to be 
> taken; in particular, coming to an agreement about whether the RFP 
> process should be run to find a replacement RSE, thereby gaining the 
> benefit of a smooth transition while Heather is still in the post, or 
> whether another process first needs to be run (e.g., to reconsider the 
> role and its relationship to other bodies).
>
> If you have thoughts about that or want to discuss other issues, 
> please find an RSOC member this week; we want to hear from the 
> community.
>
> Finally, we'd like to thank Heather again for her dedication and long 
> service as the RFC Series Editor to date; she entered a position that 
> already had big shoes to fill, and in our estimation has enlarged 
> them.
>
> Regards,
> Sarah Banks
> For the RSOC

---

From: Ted Hardie <[email-masked]>
Date: Wed, 24 Jul 2019 15:11:57 -0400

Hi Aaron,

On Wed, Jul 24, 2019 at 2:58 PM Aaron Falk <[email-masked]> wrote:

> commended. I realize how hard it can be to admit fault in this emotional
> environment.
>
> similar statement from the IAB, the chair or the IAB’s RSOC program lead,
> regarding what mistakes were made so the community can consider whether the
> current arrangements require change before moving forward with finding an
> interim RSE.
>
The two comments sent by the IAB already express our regret and discuss one
aspect of what we think might need to change.  The first was here:

https://mailarchive.ietf.org/arch/msg/ietf/_Le5BN-GsJA-424DHbcFupgZHAA
(there's a long thread after)

One particular issue called out in previous discussions was the IAB's
decision to refresh the RSOC as we do other programs:

https://mailarchive.ietf.org/arch/msg/ietf/_Le5BN-GsJA-424DHbcFupgZHAA .

That calls out a specific proposal to switch to a rotating model, where
each member has a 3-year term and two are selected per year.  So far the
feedback on that has been positive, and I invite your comments on it as
well.

There are number of other issues that the larger community has discussed as
potential root causes of some of the tensions.   My personal take is that
there are some structural issues here in the complex web of reporting
structures in RFC 6635, but I do not see yet that the community has come to
an agreement on that.  One of the reasons to ask Olaf to present this
evening was to make sure that the folks at the plenary had at least some
grounding in the current model, so that they can also assess that.

regards,

Ted

> Series Editor (RSE), there has been a considerable amount of discussion
> within the community. The RSOC has been watching closely, and we wanted to
> take the opportunity to share some further thoughts.
>
> It's clear to us that the community is unhappy with this outcome; we share
> that feeling. We believe that our recommendation to put the contract out to
> bid again in two years was part of the reason behind her decision. In
> retrospect we would not make the same decision again, and we apologise to
> both her and the community for the decision, its repercussions, and the
> situation we now find ourselves in.
>
> rather to address an issue that concerned both us and her -- succession
> planning -- and we shared it with her in the spirit of transparency. While
> we took care to communicate that this was not a reflection of her
> performance, in retrospect, we should have handled it differently.
>
> regarding the low number of responses to the previous RFP, and we believed
> that we would have a problem if for some reason we had to run that process
> again. Because of that, we wanted to learn how to get more responses. We
> convinced ourselves that the best way to do this was by exercising the
> process in 2021. With the benefit of hindsight, we recognize that this was
> a mistake.
>
> process and agree with it. While we took some precautions to express that
> our decision was not a judgement of Heather's performance, we did not
> actually socialise the idea with her before making a recommendation. That
> was very clearly a mistake. If we had discussed the proposal with her, we
> would have better gauged her state of mind and understood the accumulated
> tensions.
>
> unusual amount of tension. Currently, we are discussing how we can gather
> information from the community (including Heather) to further understand
> those tensions, and make recommendations with more positive outcomes for
> the role and the RFC series. We're also discussing how we can improve
> communication between the RSE, ourselves, the community, and the other
> leadership bodies.
>
> We are also listening to the community about the next steps to be taken;
> in particular, coming to an agreement about whether the RFP process should
> be run to find a replacement RSE, thereby gaining the benefit of a smooth
> transition while Heather is still in the post, or whether another process
> first needs to be run (e.g., to reconsider the role and its relationship to
> other bodies).
>
> If you have thoughts about that or want to discuss other issues, please
> find an RSOC member this week; we want to hear from the community.
>
> already had big shoes to fill, and in our estimation has enlarged them.
>
> Regards,
> Sarah Banks
> For the RSOC
>
>

---

From: "Aaron Falk" <[email-masked]>
Date: Wed, 24 Jul 2019 15:22:27 -0400

On 24 Jul 2019, at 15:11, Ted Hardie wrote:

>> As the RSOC is responsible to the IAB, I would very much like to hear 
>> a similar statement from the IAB, the chair or the IAB’s RSOC 
>> program lead, regarding what mistakes were made so the community can 
>> consider whether the current arrangements require change before 
>> moving forward with finding an interim RSE.
>
> The two comments sent by the IAB already express our regret and 
> discuss one aspect of what we think might need to change. 

(I’m mindful of conserving my minute at the plenary mic so I’m 
trying to hash this out here...)

Are you saying the the IAB has not erred in this?  The note you point to 
below discusses the IAB’s regret (not an apology to the community) nor 
any admission of error.  Is there nothing the IAB should have done 
differently?  It’s a long thread so maybe I missed it.  That is 
different as to whether the RFC6635 should change.

--aaron

---

From: Richard Barnes <[email-masked]>
Date: Wed, 24 Jul 2019 15:29:46 -0400

On Wed, Jul 24, 2019 at 3:23 PM Aaron Falk <[email-masked]> wrote:

> The two comments sent by the IAB already express our regret and discuss
> one aspect of what we think might need to change.
>
> (I’m mindful of conserving my minute at the plenary mic so I’m trying to
> hash this out here...)
>
> Are you saying the the IAB has not erred in this?
>
Not to speak for Ted, but my understanding as a community member, based on
the fact presented, is that the IAB has not erred in their oversight of the
RSE.  They have followed the processes established in RFC 6635, and
conducted due oversight of the RSE function, via the RSOC.  The RFC++ BoF
was misguided, but the IAB acknowledged that more than a year ago.

--Richard

> The note you point to below discusses the IAB’s regret (not an apology to
> the community) nor any admission of error. Is there nothing the IAB should
> have done differently? It’s a long thread so maybe I missed it. That is

---

From: Ted Hardie <[email-masked]>
Date: Wed, 24 Jul 2019 15:38:37 -0400

Hi Aaron,

Hi Aaron,

The base error here was not realizing that Heather was still unhappy with
issues that occurred significantly before this straw fell on the camel's
back.  You note that the her view from the RSE cited the rfcplusplus BoF,
for example, which the IAB recognized as a mistake and acknowledged as such
a year ago:

https://mailarchive.ietf.org/arch/msg/ietf/x0jRbmwdxXTGwhh-14Tl9YDx8Rs

Speaking personally, I never saw her behavior to IAB members change at all
during the period after this point, and I obviously mistook her
professionalism on this point as her being satisfied that we were leaving
the matter in her hands.  Hindsight can be clear on this, but we obviously
missed any signs there were that these issues were not resolved.

We're sorry about that, but there's no way to undo that now.  The best we
can do is work out whether some of the causes are structural (e.g. if you
have 3 bosses, will you always get 3 times the employment-related agita?)
and try and fix those for the future. That's why our aim in this exercise
is to work out how we can changes things so they work better in the future;
it's very unlikely that the IAB will be the same the next time  a similar
issue occurs, and we need more than lore to guide us.

regards,

Ted Hardie

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 25 Jul 2019 08:05:24 +1200

On 25-Jul-19 07:29, Richard Barnes wrote:
> 
> 
> On Wed, Jul 24, 2019 at 3:23 PM Aaron Falk <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     __
> 
>             As the RSOC is responsible to the IAB, I would very much like to hear a similar statement from the IAB, the chair or the IAB’s RSOC program lead, regarding what mistakes were made so the community can consider whether the current arrangements require change before moving forward with finding an interim RSE.
> 
>         The two comments sent by the IAB already express our regret and discuss one aspect of what we think might need to change. 
> 
>     (I’m mindful of conserving my minute at the plenary mic so I’m trying to hash this out here...)
> 
> Not to speak for Ted, but my understanding as a community member, based on the fact presented, is that the IAB has not erred in their oversight of the RSE.  They have followed the processes established in RFC 6635, and conducted due oversight of the RSE function, via the RSOC.  The RFC++ BoF was misguided, but the IAB acknowledged that more than a year ago.

I have to say that I didn't think carefully enough about this during public comment time in 2009 (RFC5620) or 2012 (RFC6635). Also at that time, we mainly didn't realise how easily an "oversight" committee such as the IAOC could fall into bad habits of micromanagement. With my excellent 20/20 hindsight, I think it was a grave error to apply the "oversight" terminology to the RSE role. Of course, contractual oversight of the production and publication services was needed, but the role of the Series Editor is very different. 

As I've hinted already, I think the IAB stepped out of its box by moving from "approving" the appointment and general policy, as its charter lays down, to "overseeing" the RSE (who should have a collegial relationship with the IAB) and the contracts (which are IASA/IETF LLC business). I'm not blaming anyone personally for that, but I think it has led us to a dark place.

Regards
    Brian
> 
> --Richard
> 
>  
> 
>     The note you point to below discusses the IAB’s regret (not an apology to the community) nor any admission of error. Is there nothing the IAB should have done differently? It’s a long thread so maybe I missed it. That is different as to whether the RFC6635 should change.
> 
>     --aaron
>

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 24 Jul 2019 20:07:27 +0000

Sarah,

Thanks for posting this; it is one of the best messages in this whole discussion. I am sure it wasn't the easiest thing for the RSOC to write or post.

---

From: "Eliot Lear (elear)" <[email-masked]>
Date: Wed, 24 Jul 2019 20:09:38 +0000

+1.

Thank you, Sarah. 

Eliot

> On Jul 24, 2019, at 16:08, Salz, Rich <[email-masked]> wrote:
> 
> Sarah,
>

---

From: Terry Manderson <[email-masked]>
Date: Wed, 24 Jul 2019 18:07:01 -0400

Indeed. +1.

Seeing this level of leadership, finally, is encouraging - even if only from RSOC. Thank you Sarah.

Cheers,
Terry

> On 24 Jul 2019, at 4:09 pm, Eliot Lear (elear) <[email-masked]> wrote:
> 
> +1.
> 
> Thank you, Sarah. 
> 
> Eliot
>

---

From: Alia Atlas <[email-masked]>
Date: Wed, 24 Jul 2019 19:35:40 -0400

Sarah & the RSOC,

Thank you for the apology.

Regards,
Alia

On Wed, Jul 24, 2019, 6:07 PM Terry Manderson <[email-masked]> wrote:

> >> Thanks for posting this; it is one of the best messages in this whole
> discussion. I am sure it wasn't the easiest thing for the RSOC to write or
> post..
> >>
> >>
> >
>
>

---

From: tom petch <[email-masked]>
Date: Thu, 25 Jul 2019 16:39:19 +0000

<inline>
Tom Petch

----- Original Message -----
From: "Sarah Banks" <[email-masked]>
Sent: Wednesday, July 24, 2019 6:45 PM

IETF Community,

Since Heather announced her decision not to renew her contract as RFC
Series Editor (RSE), there has been a considerable amount of discussion
within the community. The RSOC has been watching closely, and we wanted
to take the opportunity to share some further thoughts.

It's clear to us that the community is unhappy with this outcome; we
share that feeling. We believe that our recommendation to put the
contract out to bid again in two years was part of the reason behind her
decision. In retrospect we would not make the same decision again, and
we apologise to both her and the community for the decision, its
repercussions, and the situation we now find ourselves in.

It was not RSOC's intent to put Heather in a difficult position, but
rather to address an issue that concerned both us and her -- succession
planning -- and we shared it with her in the spirit of transparency.
While we took care to communicate that this was not a reflection of her
performance, in retrospect, we should have handled it differently.

that process again.

<tp>

I recall a discussion between us workers and a senior company manager
where we criticised the lack of response to a recruitment advertisement
to which the senior manager responded that they were seeking to fill
just one post so the perfect result would be just one response, a
suitably qualified candidate, who might just be the best candidate.

That has always stayed with me and comes to mind whenever I see
recruiters trying to create as big a list as they can, I imagine so that
they can exercise their skill in selecting from the list, something that
may not produce the best outcome.

Tom Petch

         Because of that, we wanted to learn how to get more responses.
We convinced ourselves that the best way to do this was by exercising
the process in 2021. With the benefit of hindsight, we recognize that
this was a mistake.

We also convinced ourselves that Heather would understand the thought
process and agree with it. While we took some precautions to express
that our decision was not a judgement of Heather's performance, we did
not actually socialise the idea with her before making a recommendation.
That was very clearly a mistake. If we had discussed the proposal with
her, we would have better gauged her state of mind and understood the
accumulated tensions.

We remain concerned that the RSE position seems to be subject to an
unusual amount of tension. Currently, we are discussing how we can
gather information from the community (including Heather) to further
understand those tensions, and make recommendations with more positive
outcomes for the role and the RFC series. We're also discussing how we
can improve communication between the RSE, ourselves, the community, and
the other leadership bodies.

We are also listening to the community about the next steps to be taken;
in particular, coming to an agreement about whether the RFP process
should be run to find a replacement RSE, thereby gaining the benefit of
a smooth transition while Heather is still in the post, or whether
another process first needs to be run (e.g., to reconsider the role and
its relationship to other bodies).

Regards,
Sarah Banks
For the RSOC