Subject: RFC Series Editor (RSE) Statement of Work

From: Sarah B <[email-masked]>
Date: Mon, 15 Jul 2019 07:25:16 -0700

Hello,
	Attached is the RSE SOW intended for the upcoming RFP. You'll find it very much inline with the previous SOW we sent out as part of the RFP during the last iteration of this process. The RSOC is requesting community feedback, and would like to run a 4 week feedback period. That period starts today, July 15, and ends August 15, 2019. Please direct your feedback to the RSOC directly.

Kind regards,
Sarah Banks, Chair
on behalf of the RSOC

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 15 Jul 2019 14:29:09 +0000

Can you summarize the changes between this RFP and the last one?  As I recall, the purpose for doing an early RFP was to revise the process (which presumably includes the RFP).  Or am I mistaken?

On 7/15/19, 10:26 AM, "Sarah B" <[email-masked]> wrote:

    Hello,
    
    Kind regards,
    Sarah Banks, Chair
    on behalf of the RSOC

---

From: Sarah Banks <[email-masked]>
Date: Mon, 15 Jul 2019 08:05:53 -0700

Hi,
	To follow up, I wanted to touch base on the process we mention below. We understand that the community is still discussing larger process points, but the RSOC would like to collect feedback on the following SOW in parallel.  This will allow the RSOC to move quickly if the community concludes that running the process as described in RFC 6635 is the best choice for now. Please let me know if you have any questions.

Thanks
Sarah

> On Jul 15, 2019, at 7:25 AM, Sarah B <[email-masked]> wrote:
> 
> Hello,
> <RSE-SOW-2019.pdf>

---

From: Sarah Banks <[email-masked]>
Date: Mon, 15 Jul 2019 08:07:35 -0700

Hi Rich,
	I don't think there are any changes in the SOW itself, short of dates; the process as a whole, should we choose to execute against the process we currently have, or amend it, is a separate issue. The goal here is to get the SOW agreed upon and ready to go.

Thanks
Sarah

> On Jul 15, 2019, at 7:29 AM, Salz, Rich <[email-masked]> wrote:
>

---

From: Leif Johansson <[email-masked]>
Date: Mon, 15 Jul 2019 17:15:10 +0200

> 	Attached is the RSE SOW intended for the upcoming RFP. You'll find it very much inline with the previous SOW we sent out as part of the RFP during the last iteration of this process. The RSOC is r…

I don't think its a good idea to include "experience as an RFC author"
as a desired skill. Including that requirement will skew the selection
towards the usual suspects and Recruiting the next RSE from within the
community should imo not be a high priority for us.

	Cheers Leif

---

From: Richard Barnes <[email-masked]>
Date: Mon, 15 Jul 2019 11:37:43 -0400

+1

If anything, experience as a consumer of RFCs would be way more useful.

--Richard

On Mon, Jul 15, 2019 at 11:16 AM Leif Johansson <[email-masked]> wrote:

> >       Attached is the RSE SOW intended for the upcoming RFP. You'll find
> it very much inline with the previous SOW we sent out as part of the RFP
> during the last iteration of this process. The RSOC is requesting community
> feedback, and would like to run a 4 week feedback period. That period
> starts today, July 15, and ends August 15, 2019. Please direct your
> feedback to the RSOC directly.
> >
> > Kind regards,
> > Sarah Banks, Chair
> > on behalf of the RSOC
> >
>

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 15 Jul 2019 16:39:15 +0000

>    I don't think its a good idea to include "experience as an RFC author"

Strongly agree.  We want a good technical copy-editor, which strikes almost all RFC authors from consideration, IMO.

---

From: Sarah Banks <[email-masked]>
Date: Mon, 15 Jul 2019 09:47:32 -0700

This isn't a "yes/no" comment, but rather, a bit of colour - I think requiring the experience with having written an RFC means the candidate would have been through the process previously and hence, has some experience with it. Also, it's not a requirement, just a desirable skill :)

/S

> On Jul 15, 2019, at 9:39 AM, Salz, Rich <[email-masked]> wrote:
>

---

From: heather flanagan <[email-masked]>
Date: Mon, 15 Jul 2019 09:48:52 -0700

> Strongly agree. We want a good technical copy-editor, which strikes almost all RFC authors from consideration, IMO.

To chime in on this particular point - no, you don’t want a good technical copy editor, at least not as a primary skill. The RSE never directly edits Internet Drafts. Someone with experience being a professional editor for a scholarly journal gets you closer.

Some useful reading material:

https://www.councilscienceeditors.org/resource-library/editorial-policies/white-paper-on-publication-ethics/2-1-editor-roles-and-responsibilities/

Heather

---

From: "Paul Hoffman" <[email-masked]>
Date: Mon, 15 Jul 2019 10:06:22 -0700

On 15 Jul 2019, at 9:47, Sarah Banks wrote:

> This isn't a "yes/no" comment, but rather, a bit of colour - I think 
> requiring the experience with having written an RFC means the 
> candidate would have been through the process previously and hence, 
> has some experience with it.

Heather Flanagan did not have RFC writing experience before she became 
the RSE. Thus, the one data point we have speaks against this as even a 
desirable skill.

> Also, it's not a requirement, just a desirable skill :)

Then the SOW needs to be revised. "Experience as an RFC author desired" 
is listed in a section called "EDUCATION AND EXPERIENCE REQUIRED:". In 
fact, three of the five bullets in that section, and the first bullet of 
the next section, confuse "desired" and "required".

--Paul Hoffman

---

From: Keith Moore <[email-masked]>
Date: Mon, 15 Jul 2019 13:34:49 -0400

> community should imo not be a high priority for us.

I emphatically disagree.   Why should IETF entrust the editing of its 
work product to someone who might not understand IETF's mission or share 
its values?

Keith

---

From: Leif Johansson <[email-masked]>
Date: Mon, 15 Jul 2019 19:38:20 +0200

Skickat från min iPhone

> 15 juli 2019 kl. 19:34 skrev Keith Moore <[email-masked]>:
> 
> I emphatically disagree.   Why should IETF entrust the editing of its work product to someone who might not understand IETF's mission or share its values?
> 
> Keith
> 
> 

I submit that there are other ways to come to share the values of the Internet community than to publish RFCs...

---

From: Keith Moore <[email-masked]>
Date: Mon, 15 Jul 2019 13:53:53 -0400

> I submit that there are other ways to come to share the values of the Internet community than to publish RFCs...

To me the perspective of a standards author (especially if also an 
implementor) seems fairly unique.   Even people who broadly support 
IETF's goals don't always properly understand its perspective.

Keith

---

From: Richard Barnes <[email-masked]>
Date: Mon, 15 Jul 2019 14:02:42 -0400

Hi Sarah,

Thanks for posting this document for comment.  My feedback is below.  To be
clear, I am reviewing this de novo, without regard to previous versions.

--Richard

=====

Overall, this document seems odd for an SOW.  The point of an SOW is to
state what the contractor must do in order to fulfill their end of the
contract.  This document contains a lot of text that irrelevant to that
point, and is vague on the details of what is actually to be done.  Going
through the document in more detail...

> Contractor will also be required to attend three annual IETF meetings...

This seems overly specific.  Would we find the RSE in breach of their
contract if they had to miss an IETF meeting?  Even if the answer is "it
depends", this should be softened.

> CONTRACT PERIOD

This is irrelevant to the SOW.  It should be specified elsewhere in the
contract.

> REPORTING RELATIONSHIPS

If I were bidding on this, I would find this section terrifyingly vague.  I
would want to know at least:

* What are my obligations to the RSOC?  Do I need to provide them
reporting, or attend meetings, or...?  Otherwise, they could tell the
contracting organization that I'm non-compliant for any reason.

* What are my powers with regard to the RPC and RFC Publisher?  I can't
"manage" them if I don't have any control over them, and again, I don't
want to be found in breach because I'm not doing something I wasn't
empowered to do.

> Operational Oversight Areas
> Policy Development Areas

I don't have the time at the moment to comment on these in detail, but
again, if I were bidding, I would be concerned about the vagueness here.
How am I supposed to know if I'm, for example, "Ensuri[ing] the ongoing
improvement rfc-editor.org" to sufficient degree?  What does it mean to
"serve as the primary representative of the RFC Series"?

> EDUCATION AND EXPERIENCE REQUIRED
> SKILLS AND ABILITIES REQUIRED

These do not belong in the SOW, they belong in the RFP.  Once the SOW
enters into force, it doesn't matter what these sections say, since the
selection will have been made.  I also note that these are already in RFC
6635.

---

From: Leif Johansson <[email-masked]>
Date: Mon, 15 Jul 2019 20:13:42 +0200

Skickat från min iPhone

> 15 juli 2019 kl. 19:53 skrev Keith Moore <[email-masked]>:
> 
> To me the perspective of a standards author (especially if also an implementor) seems fairly unique.   Even people who broadly support IETF's goals don't always properly understand its perspective.
> 
> Keith
> 
> 

Oh I’m sure. The world is full of unique perspectives.

I’ve often found that success is the result of allowing other perspectives to encroach on ones own.

---

From: Keith Moore <[email-masked]>
Date: Mon, 15 Jul 2019 14:36:07 -0400

> I’ve often found that success is the result of allowing other perspectives to encroach on ones own.

I suppose it depends on how one defines "success".    For example, you 
may make other choices, but personally I'm inclined to lock my car doors 
when I park it, and take the keys with me, no matter how much I might 
benefit from the perspective of a stranger encroaching on my car.

More to the point, I really think we need to be careful to pick future 
RSEs who won't try to impose their own agenda on IETF.    I think we've 
been very lucky so far but should not rely on being lucky in the future.

Keith

---

From: Adam Roach <[email-masked]>
Date: Mon, 15 Jul 2019 13:41:41 -0500

> Can you summarize the changes between this RFP and the last one?  As I recall, the purpose for doing an early RFP was to revise the process (which presumably includes the RFP).  Or am I mistaken?

With 18 months of lead-time, that was the plan. Removing 12 months from 
the equation does have a planning impact.

/a

---

From: Michael StJohns <[email-masked]>
Date: Mon, 15 Jul 2019 15:35:40 -0400

On 7/15/2019 2:41 PM, Adam Roach wrote:
>> Can you summarize the changes between this RFP and the last one?  As 
>> I recall, the purpose for doing an early RFP was to revise the 
>> process (which presumably includes the RFP).  Or am I mistaken?
>
>
> With 18 months of lead-time, that was the plan. Removing 12 months 
> from the equation does have a planning impact.
>
> /a
>
Don't you mean 30 months of lead time?   And I assume there was some 
sort of genesis of a plan described in the minutes of the RSOC that 
described what you wanted to accomplish with  an RSE re-compete - 
perhaps your documented discussion could be shared with the rest of the 
IETF?

Mike

---

From: Nico Williams <[email-masked]>
Date: Mon, 15 Jul 2019 15:33:25 -0500

On Mon, Jul 15, 2019 at 01:34:49PM -0400, Keith Moore wrote:
> > I don't think its a good idea to include "experience as an RFC
> > author" as a desired skill. Including that requirement will skew the
> > selection towards the usual suspects and Recruiting the next RSE
> > from within the community should imo not be a high priority for us.
> 
> work product to someone who might not understand IETF's mission or
> share its values?

I want the RSE to have enough technical knowledge w.r.t.:

 - typesetting

 - XML, XML Schema

 - technical language

in addition to English language copy-editing experience.

In other words: a technical writer who has experience in typesetting.

I would also suggest that the RSE has to know what "process" means and
have had some experience with org / publication processes of some sort.

Candidates will probably need a portfolio.

Oh yeah, one more thing: leadership -- at the very least they must not
be shy.  The incumbent certainly shown leadership.

The rest they'll learn on the job.

-----

Having been an I-D author/co-author/editor?  That would imply meeting
some of the above criteria, so it's useful in itself, but it's neither
necessary nor sufficient.

-----

Finding a new RSE sounds daunting.  Hope it all works out.

Nico
--

---

From: S Moonesamy <[email-masked]>
Date: Mon, 15 Jul 2019 14:25:17 -0700

Dear RFC Series Oversight Committee,
At 07:25 AM 15-07-2019, Sarah B wrote:
>         Attached is the RSE SOW intended for the upcoming RFP. 
> You'll find it very much inline with the previous SOW we sent out 
> as part of the RFP during the last iteration of this process. The 
> RSOC is requesting community feedback, and would like to run a 4 week

I would like to request the information which the initial RFC Series 
Oversight Committee (RSOC) gathered from the previous RSE hiring exercise.

I read the proposed statement of work.  The "reporting relationships" 
Section does not look like it is based on some logic.  The 
description in the "scope of work" Section makes it look like a 
management position.  How will the skills and abilities which are 
required be evaluated?  I suggest considering whether that even fits 
within what is desired for the evolution of the Series.

Regards,
S. Moonesamy

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 16 Jul 2019 11:14:28 +1200

Hi,

I'm going to start with Richard's first comment, and then come back to a couple of other comments, and then give my own comments on the "experience required" bullets:
On 16-Jul-19 06:02, Richard Barnes wrote:
...

> Overall, this document seems odd for an SOW.  The point of an SOW is to state what the contractor must do in order to fulfill their end of the contract.

Of course it's odd, because the concept of a "statement of work" with specific deliverables is off target for a job such as the RSE. I think that's part of the broader discussion we need to have, but for now we have to stick to the current model, which means an SOW.

> Strongly agree.  We want a good technical copy-editor, which strikes almost all RFC authors from consideration, IMO.

I want to repeat what the current RSE said. The job is not that of a copy-editor, nor that of a technical editor (which are both well-defined job descriptions). It's much closer to the job of a commissioning editor in a publishing house, but even that isn't correct.

Experience as an RFC author is largely irrelevant, IMHO. Understanding what the IETF and the IRTF do, what other SDOs do, and even what academic journals do, is much more to the point.

> work product to someone who might not understand IETF's mission or share 

We shouldn't. But firstly, it's the Production Center that actually does the technical and copy editing, and secondly, writing an RFC is not a precondition for understanding the IETF.

My bottom line:

"* Significant editorial and publishing experience desired."

That understates the case. I think our experience with Heather has shown that this isn't just desirable, it's essential. Try:

* Significant senior editorial and publishing experience required.

"* Familiarity with a wide range of Internet technologies."

That seems parochial, and there also seems to be a missing aspect. Try:

* Familiarity with Internet technologies and technical standards.

"* Experience as an RFC author desired."

On balance I'd delete that. Possibly replace it with:

* Experience with standards publication desired.

Regards
    Brian

---

From: "John Levine" <[email-masked]>
Date: 15 Jul 2019 19:16:26 -0400

>in addition to English language copy-editing experience.

The RSE really, REALLY is not a copy editor.  We have copy editors, we
have the RSE, and they are different jobs with very different skills.
If you have ever talked to Sandy and Alice, whose table at IETF meetings
usually has candy on it, they are copy editors, rather good ones, and
as far as I know, they plan to keep doing what they're doing.

Perhaps this would be a good time to go learn about the difference and
see what skills you actually want the RSE to have.

---

From: Nico Williams <[email-masked]>
Date: Mon, 15 Jul 2019 19:03:54 -0500

> see what skills you actually want the RSE to have.

I see.  Fair enough.

---

From: Nevil Brownlee <[email-masked]>
Date: Tue, 16 Jul 2019 16:53:35 +1200

+1 about Heather not having RFC writing experience before taking on the RSE
position.

Actually, the former RSOC's search committee (yes, I was on it), made sure
applicants had lots of experience of publishing technical material, as well
as considerable experience with networking and computer technology.  We
narrowed down the field to three likely applicants, and brought them all to
the Beijing IETF meeting so that they could see for themselves how the IETF
worked.

Cheers, Nevil

-- 

 --------------------------------
Nevil Brownlee, Taupo, NZ

---

From: John C Klensin <[email-masked]>
Date: Tue, 16 Jul 2019 10:38:45 -0400

--On Tuesday, July 16, 2019 16:53 +1200 Nevil Brownlee
<[email-masked]> wrote:

> +1 about Heather not having RFC writing experience before
> taking on the RSE position.
> 
> Actually, the former RSOC's search committee (yes, I was on
> it), made sure applicants had lots of experience of publishing
> technical material, as well as considerable experience with
> networking and computer technology.  We narrowed down the
> field to three likely applicants, and brought them all to the
> Beijing IETF meeting so that they could see for themselves how
> the IETF worked.

Hi.

I don't know whether to respond on this thread or the "RSE Bid
Process" one - this may be a bit of both.   

First, I want to confirm what Nevil says above (I am fairly sure
I was on that committee too; I was certainly on the RSOC). 

Unless "we" are trying to make changes in how the RFC Editor
Function works that go far beyond what is (or is not) in what is
in the draft SOW, there have been several misconceptions in this
thread and the related ones.    First and foremost, let me
reinforce something several others have said: This is not a
copy-editing role.  it is not even a technical editing role.
I'd be concerned about a candidate who did not have technical
editing experience but I'm not sure that is a showstopper (i.e.,
"required").  I'd like to hear from Heather and Ole (and anyone
else with in-depth experience and not just opinions) about that.
I'd be much less concerned if a candidate did not have
copy-editing experience, but I believe all of the good technical
editors I've known and worked with have had that experience.  If
that generalizes, copy-editing experience is a non-issue if we
more or less insist on technical editing experience.   Someone
who sees the RSE job as editing documents would be an
inappropriate choice for it.

As far as experience writing RFCs is concerned, maybe it would
be helpful, but  the perspective gaining from experience running
and splicing fiber optic cable in production environments might
be helpful in designing network-level protocols.. .but not very
much.   It is essential that someone selected for the role be
(or be able to rapidly become) comfortable working with the
community, but we should remember --as some recent threads have
illustrated -- that the culture is changing rapidly.  I'm not
entirely sure that Jon Postel would have been comfortable
working in today's culture.for themselve
   
Instead, this is a strategic leadership and management role.  In
retrospect, maybe we would have less confusion about, e.g., copy
editing, if we had called the position "RFC Series Publisher"
when we made up the "RSE" title, but, given how few people seem
to understand what a publisher actually does, maybe it would
have made no difference.  However, the old adage about really
smart managers and executives choosing staff and looking for
colleagues who know more than they do would apply here: nothing
in the job description the IAB has proposed for themselves for
the nomcom says "understands issues in technical publishing well
enough to do a senior-level job in that area".  I'm not even
sure that is a requirement for the RSOC (and don't know how many
current RSOC members would qualify if it were)..

If the RSOC and IAB are looking for someone who will quietly do
the job, follow their lead about strategy directions, and not
try to educate (and, if necessary, push back based on greater
specialist expertise, then they are making a really fundamental
change in the role.    If 6635 appears to say anything about
that sort of focus of authority and restrictions on the role,
rather than the strategic leadership one, then it is broken and
needs to be fixed rather than slavishly followed... but I don't
believe there is any language in it to that effect.

So, as Nevil pointed out, what we looked for was lots of
experience of publishing technical material, as well as
considerable experience with
networking and computer technology.  I think that is still what
we need to look for, noting the priority of the "publishing
technical material" criterion.  I would have added "experience
in preparing technical standards for publication" as at least
highly desirable.  My recollection is that we considered that
too and considered it quite a bit.

Something Nevil didn't mention was that plausible candidates
were not easy to find, even with no incumbent to compete
against.  We did considerable beating of the proverbial bushes,
reaching out via personal contacts at publishers of relevant
technical journals, at professional societies who publish
journals of record, present and former editorial staff for other
standards bodies, and so on rather than confining ourselves to
anything that would correspond to the IETF LLC (or IAOC) issuing
an RFP, announcing it to the community, and seeing who shows up
to "bid".  For a position like this, even describing the
position search a and process as a "bid" is offensive and likely
to convince some people we would like to have as candidates to
say "they either don't understand what they are doing or are not
interested in anyone like me" and then move on.   This is not
like, e.g., getting someone to build a software package to a
complete set of specifications.  It is lots more like recruiting
someone to design a system and then oversee its implementation.
Unless we are making significant changes to the role, the RSE
should probably be seen as less even responsible to the IAB and
RSOC on day to day details than the IETF LLC Executive Director
is to the LLC Board.

Finally, for those who think an "acting" or "interim"
appointment while we reconsider the position is the right thing
to do... maybe you are right.  We have gotten ourselves into
such a horrible position that I have trouble thinking about
optimal solutions.  However, please be very careful about
analogies and assumptions about how Olaf's term as Acting RSE
worked out.  Olaf obviously had a great deal of IETF experience,
both as a recognized leader in the community and as an RFC
author.  That made it easier for him to function in a
placeholder role without alienating the community, which was
undoubtedly important.  However, he did not (at least as far as
I recall) have the depth of technical and standards publishing,
and publishing strategy, experience discussed above and that
others have been trying to get at.   I think it was very
important (his comments would be welcome) that he did have an
RSOC that contained multiple people with at least significant
pieces of those types of experience.   That RSOC saw its mission
much more in terms of supporting him and helping him succeed in
the role -- including giving advise on the strategic publication
issues to which he was happy to listen-- than as "oversight" or
supervision or evaluation of contractual compliance.    That
seems to have changed and, unless we can get back there, an
Acting RSE with only IETF experience might be at a significant
disadvantage relative to keeping the Series going in a stable
and efficient way.

Mote generally, putting someone into the RSE role --either
"acting" or semi-permanently -- who has good community
experience and relationships, little or no strategic publication
leadership perspective and experience, and without the support
of in-depth expertise in the RSOC (or some other arrangement to
which a supportive RSOC is prepared to defer in matters of
expertise) is a recipe for disaster... or at least major changes
in the character of the Series whether intentional or not and
whether reflecting community consensus or not.

Finally, we have to keep in mind that whomever takes the
position next is, at least IMO, going to be facing a much more
difficult situation than Heather did when she came on Board.
First, the community appears to be much more divided about the
role of the RSE and the Series more generally.  For example,
there were no loud voices for radical changes around such as
those that manifested themselves in the RFC++ effort a year ago.
In particular, whether it is the case or not, recent discussion
on the IETF list has made it clear that there are are suspicions
in part of community that at least parts of the present
situation are the result of efforts to accomplish goals that
could not be accomplished by community consensus.  Again
independent of the validity of that concern, its existence has a
corrosive effect that will make the role of the appointee harder
and that may make recruiting of highly-qualified candidates
harder.  In addition, we are in the midst of a very significant
change to how RFCs are published and made available -- probably
the most significant change since sometimes in the 1980s.  Some
recent events have convinced me that, as we discover where what
we wanted leads, we are likely to have to debug and reconsider
parts of the design as well as the particular tools that
implement it.  Unless we change the job so that some appointed
volunteer body [micro]manages the decisions that will be needed,
the new RSE, acting or not and with Heather's help or not, is
going to be the critical decision-maker about what will
certainly turn to be complex tradeoffs.  

That, too, is likely to be a recruiting issue because it is
likely that anyone who is really qualified for the job is going
to ask many focused questions about what they would be getting
into.   If someone who asks and gets accurate answers says to
themselves "especially in the light of a divided community, do I
really want that stress and risk of failure because of decisions
made before I came on board and things I won't be able to
control?" that is one less possible qualified candidate for the
RSOC to consider.

It is more than a little scary.  If I has a plan about an easy
path to navigate the situation and do so easily, I'd say do, but
I don't.  However, I do believe that it is unlikely that we are
going to make significant progress as long as some members of
the community are behaving in a way that --justly or not-- cause
others to be concerned about whether information is being hidden
from the community or that there os a hidden agenda about using
the change of RSE to radically change the RFC Editor Function.

best,
   john

---

From: Michael StJohns <[email-masked]>
Date: Wed, 17 Jul 2019 12:18:11 -0400

Hi - John's note makes a lot of different very good points, and he does 
note that some could be made on one of the other threads.  I've 
extracted a few points that are particularly germane to the SOW thread 
primarily for emphasis and added ellipsis to shrink some of those 
hopefully without changing meaning.  I recommend all of you read John's 
original post - but if you don't have the time, this at least attempts 
to pull out points that frame the role of the RSE and the depth of the 
problem we're going to have finding a new one.

Mike

On 7/16/2019 10:38 AM, John C Klensin wrote:
>  *
>     thread and the related ones.
>
>  *
>     This is not a
>  *
>     have made no difference.
>  *
>     change in the role.
>  *
>     against.
>  *
>  *
>       For a position like this, even describing the
>     interested in anyone like me" and then move on.
>
>   * Olaf obviously had a great deal of IETF experience....However,he
>     did not ... have the
>     depth of technical and standards publishing,and publishing
>     strategy, experience ... I think it was very important ... that he
>     did have an RSOC that contained multiple people with at least
>     significant pieces of those types of experience. That RSOC saw its
>     missionmuch more in terms of supporting him and helping him
>     succeed in the role -- including giving advise on the strategic
>     publication issues to which he was happy to listen-- than as
>     "oversight" or supervision or evaluation of contractual compliance.
>
>  *
>     More generally, putting someone into the RSE role --either

---

From: John C Klensin <[email-masked]>
Date: Wed, 17 Jul 2019 21:16:35 -0400

Mike,

Many thanks.  Those probably are, indeed, the high points.

It also illustrates one other point that various of us have been
trying to make.  Mike's surgical job on my test could be
considered the work of a very skilled editor with subject matter
expertise, making a probably over-long document more readable.
In the case of the RFC Series and professional journals in,
e.g., computing and computer networks, we identify that subject
matter expertise as "technical" and call such a person a
"technical editor"... with the equivalent to a job that Mike did
requiring a very skilled one of those.  Nothing that Mike did
would be described as copy-editing.  Indeed, his result is
almost as much in need of a copy editor as my original was.
And, finally, the role of someone in a role like the RSE wrt my
document and Mike's edits/ condensation would be to decide
whether the Series preference should be for bullet points (like
Mike's example) or more extensive and better supported (but
likely much longer) prose (more like my original) and then to
try to figure out how to set stylistic guidelines, educate
people, etc., to support that preference (or to not decide at
all, leaving the choice up to individual authors or documents).  

That is just one type of example, but it illustrates the
difference between copy editing, technical editing (in the case
of the RFC Series, at a far higher level of text changes and
reorganization than we've seen since Jon Postel passed away and
rarely even then), and the Series strategic leadership role that
we've traditionally expected of the RSE.

best,
   john

--On Wednesday, July 17, 2019 12:18 -0400 Michael StJohns
<[email-masked]> wrote:

> Hi - John's note makes a lot of different very good points,
> and he does note that some could be made on one of the other
> threads.  I've extracted a few points that are particularly
> germane to the SOW thread primarily for emphasis and added
> ellipsis to shrink some of those hopefully without changing
> meaning.  I recommend all of you read John's original post -
> but if you don't have the time, this at least attempts to pull
> out points that frame the role of the RSE and the depth of the
>>     Unless "we" are trying to make changes in how the RFC
>>     Editor Function works that go far beyond what is (or is
>>     not) in what is in the draft SOW, there have been several
>>     misconceptions in this thread and the related ones.
>> 
>>  *
>>     This is not a
>>     Instead, this is a strategic leadership and management
>>     role.  In retrospect, maybe we would have less confusion
>>     about, e.g., copy editing, if we had called the position
>>     "RFC Series Publisher" when we made up the "RSE" title,
>>     but, given how few people seem to understand what a
>>     publisher actually does, maybe it would have made no
>>     difference.
>> 
>>  *
>>     If the RSOC and IAB are looking for someone who will
>>     quietly do the job, follow their lead about strategy
>>     directions, and not try to educate (and, if necessary,
>>     push back based on greater specialist expertise, then
>>     they are making a really fundamental change in the role.
>> 
>>  *
>>     Something Nevil didn't mention was that plausible
>>     candidates were not easy to find, even with no incumbent
>>     to compete against.
>> 
>>  *
>>     Unless we are making significant changes to the role, the
>>     RSE should probably be seen as less even responsible to
>>     the IAB and RSOC on day to day details than the IETF LLC
>>     Executive Director is to the LLC Board.
>> 
>>  *
>>     position search a and process as a "bid" is offensive and
>>     likely to convince some people we would like to have as
>>     candidates to say "they either don't understand what they
>>     are doing or are not interested in anyone like me" and
>>     then move on.
>> 
>>   * Olaf obviously had a great deal of IETF
>>   experience....However,he did not ... have the
>>     strategy, experience ... I think it was very important
>>     ... that he did have an RSOC that contained multiple
>>     people with at least significant pieces of those types of
>>     experience. That RSOC saw its missionmuch more in terms
>>     of supporting him and helping him succeed in the role --
>>     including giving advise on the strategic publication
>>     issues to which he was happy to listen-- than as
>>     experience and relationships, little or no strategic
>>     publication leadership perspective and experience, and
>>     without the support of in-depth expertise in the RSOC (or
>>     some other arrangement to which a supportive RSOC is
>>     prepared to defer in matters of expertise) is a recipe
>>     for disaster... or at least major changes in the
>>     character of the Series whether intentional or not and

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 23 Jul 2019 00:52:15 +1200

Hi,

There's something I've found myself saying to a couple of people in Montreal that I think is worth repeating here:

The RFC Series Editor has always been treated as a senior colleague, and part of our community leadership; never as a hired hand, because it isn't the sort of job that can easily be measured or priced. Obviously, as a practical matter, the RSE has to be paid for their time and expenses, but it really doesn't matter whether that's as an employee, an individual contractor, or via their existing employer. That's basically a clerical matter, once the right person has been identified.

I now think that the notion of a pre-defined statement of work and a competitive bidding process is *completely* inappropriate. What we should do, IMHO, is identify the right person by a search process with a well-informed search committee, and then leave IETF LLC to figure out any necessary employment or contractual details later.

Obviously there will be a finite budget limit that the search committee will bear in mind. But we aren't trying to find the cheapest RSE; we're trying to find the best one.

Regards
   Brian Carpenter

---

From: John C Klensin <[email-masked]>
Date: Mon, 22 Jul 2019 09:09:44 -0400

Brian,

I agree and would add two things both of which, like you, I've
shared with various others.   First, for at least a significant
fraction of those who would be appropriate for the RSE role,
even describing the process as a "bid" will turn people off and
prevent them from applying, no matter how they are recruited.
Second, if we go with a search firm, it must be one with
specific expertise and experience recruiting senior people with
technical, preferable standard-related technical, and strategic
publishing experience, not one whose skills lie in engineering
recruitment.   If we ignore either of those things (or your
other comments), we ate quite likely to get whatever the process
and people that created this mess deserves but not what the
broader Internet community (not just the IETF need and deserve).
Or, to say that differently, however bad the current situation
is, it could be made worse.

best,
   john

--On Tuesday, July 23, 2019 00:52 +1200 Brian E Carpenter
<[email-masked]> wrote:

> Hi,
> 
> There's something I've found myself saying to a couple of
> people in Montreal that I think is worth repeating here:
> 
> The RFC Series Editor has always been treated as a senior
> colleague, and part of our community leadership; never as a
> hired hand, because it isn't the sort of job that can easily
> be measured or priced. Obviously, as a practical matter, the
> RSE has to be paid for their time and expenses, but it really
> doesn't matter whether that's as an employee, an individual
> contractor, or via their existing employer. That's basically a
> clerical matter, once the right person has been identified.
> 
> I now think that the notion of a pre-defined statement of work
> and a competitive bidding process is *completely*
> inappropriate. What we should do, IMHO, is identify the right
> person by a search process with a well-informed search
> committee, and then leave IETF LLC to figure out any necessary
> employment or contractual details later.
> 
> Obviously there will be a finite budget limit that the search
> committee will bear in mind. But we aren't trying to find the
> cheapest RSE; we're trying to find the best one.
> 
> Regards
>    Brian Carpenter
> 
>> I'm going to start with Richard's first comment, and then
>> come back to a couple of other comments, and then give my own
>> comments on the "experience required" bullets: On 16-Jul-19
>> 06:02, Richard Barnes wrote:
>> ...
>> 
>>> Overall, this document seems odd for an SOW.  The point of
>>> an SOW is to state what the contractor must do in order to
>>> fulfill their end of the contract.
>> 
>> Of course it's odd, because the concept of a "statement of
>> work" with specific deliverables is off target for a job such
>> as the RSE. I think that's part of the broader discussion we
>> need to have, but for now we have to stick to the current
>> model, which means an SOW.
>> 
>>> Strongly agree.  We want a good technical copy-editor, which
>>> strikes almost all RFC authors from consideration, IMO.
>> 
>> I want to repeat what the current RSE said. The job is not
>> that of a copy-editor, nor that of a technical editor (which
>> are both well-defined job descriptions). It's much closer to
>> the job of a commissioning editor in a publishing house, but
>> even that isn't correct.
>> 
>> Experience as an RFC author is largely irrelevant, IMHO.
>> Understanding what the IETF and the IRTF do, what other SDOs
>> do, and even what academic journals do, is much more to the
>> point.
>> 
>>>> I don't think its a good idea to include "experience as an
>>>> RFC author" as a desired skill. Including that requirement
>>>> will skew the selection towards the usual suspects and
>>>> Recruiting the next RSE from within the community should
>>>> imo not be a high priority for us.
>>> 
>>> I emphatically disagree.   Why should IETF entrust the
>>> editing of its  work product to someone who might not
>>> understand IETF's mission or share  its values?
>> 
>> We shouldn't. But firstly, it's the Production Center that
>> actually does the technical and copy editing, and secondly,
>> writing an RFC is not a precondition for understanding the
>> IETF.
>> 
>> My bottom line:
>> 
>> That understates the case. I think our experience with
>> Heather has shown that this isn't just desirable, it's
>> essential. Try:
>>

---

From: Leif Johansson <[email-masked]>
Date: Mon, 22 Jul 2019 15:24:13 +0200

> Obviously there will be a finite budget limit that the search committee will bear in mind. But we aren't trying to find the cheapest RSE; we're trying to find the best one.

I could not agree more.

---

From: Richard Barnes <[email-masked]>
Date: Mon, 22 Jul 2019 09:56:56 -0400

Hi Brian,

Sorry to be so horribly prosaic, but I have some practical questions...

On Mon, Jul 22, 2019 at 8:52 AM Brian E Carpenter <
[email-masked]> wrote:

> Hi,
>
> There's something I've found myself saying to a couple of people in
> Montreal that I think is worth repeating here:
>
> The RFC Series Editor has always been treated as a senior colleague, and
> part of our community leadership; never as a hired hand, because it isn't
> the sort of job that can easily be measured or priced. Obviously, as a
> practical matter, the RSE has to be paid for their time and expenses, but
> it really doesn't matter whether that's as an employee, an individual
> contractor, or via their existing employer. That's basically a clerical
> matter, once the right person has been identified.
>
> I now think that the notion of a pre-defined statement of work and a
> competitive bidding process is *completely* inappropriate. What we should
> do, IMHO, is identify the right person by a search process with a
> well-informed search committee, and then leave IETF LLC to figure out any
> necessary employment or contractual details later.
>

Assuming we're going to adopt this approach:

How should this search committee make its decision?  Do you envision them
working from some sort of job description, or just "I know it when I see
it"?

How should this search committee be constituted?  RFC 6635 pretty clearly
places the IAB in this role, but the fact that you didn't say "IAB"
suggests that you mean some thing different.

Thanks,
--Richard

> Obviously there will be a finite budget limit that the search committee
> will bear in mind. But we aren't trying to find the cheapest RSE; we're
> trying to find the best one.
>
> Regards
>    Brian Carpenter
>
> > I'm going to start with Richard's first comment, and then come back to a
> couple of other comments, and then give my own comments on the "experience
> required" bullets:
> > Of course it's odd, because the concept of a "statement of work" with
> specific deliverables is off target for a job such as the RSE. I think
> that's part of the broader discussion we need to have, but for now we have
> to stick to the current model, which means an SOW.
> >
> author"
> >> Strongly agree.  We want a good technical copy-editor, which strikes
> almost all RFC authors from consideration, IMO.
> >
> > I want to repeat what the current RSE said. The job is not that of a
> copy-editor, nor that of a technical editor (which are both well-defined
> job descriptions). It's much closer to the job of a commissioning editor in
> a publishing house, but even that isn't correct.
> >
> > Experience as an RFC author is largely irrelevant, IMHO. Understanding
> what the IETF and the IRTF do, what other SDOs do, and even what academic
> journals do, is much more to the point.
> >
> share
> > We shouldn't. But firstly, it's the Production Center that actually does
> the technical and copy editing, and secondly, writing an RFC is not a
> precondition for understanding the IETF.
> >
> > My bottom line:
> >
> > That understates the case. I think our experience with Heather has shown
> that this isn't just desirable, it's essential. Try:
> >

---

From: Bob Hinden <[email-masked]>
Date: Mon, 22 Jul 2019 09:58:16 -0400

Brian,

> On Jul 22, 2019, at 8:52 AM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 

I also agree.

I don’t think the groups that brought us to the current situation, should be the ones who take the lead in running the process to find the next RSE.  It’s not clear to me that they have the required skills and knowledge, based on several recent actions they have taken.

There is a quote sometimes attributed to Albert Einstein that applies here.

Bob

---

From: Keith Moore <[email-masked]>
Date: Mon, 22 Jul 2019 10:05:27 -0400

On 7/22/19 8:52 AM, Brian E Carpenter wrote:

> I now think that the notion of a pre-defined statement of work and a competitive bidding process is*completely*  inappropriate. What we should do, IMHO, is identify the right person by a search process with a well-informed search committee, and then leave IETF LLC to figure out any necessary employment or contractual details later.
>

Either that, or we need to completely rethink the role of RSE.

IMO, we keep trying to replace Jon Postel, who was a very unique 
individual who grew into that role at a unique time.

I certainly agree with Brian (and also John) /if/ we persist in thinking 
of the RSE as a senior (and wise) colleague who can be trusted to act in 
the best interests of the Internet and IETF (in that order).    (note 
that I don't mention governments or corporations or even other 
standards-making bodies as having legitimate interests here.)

But maybe that's not the best idea, maybe such people are extremely 
scarce by now, and maybe they'll be nonexistent in the future.   And if 
we can't count on having suitable candidates in the future, then it 
seems likely that the role should be redefined, less independent, and 
subject to closer oversight.

choose carefully!

Keith

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 23 Jul 2019 02:18:39 +1200

Hi Richard,
On 23-Jul-19 01:56, Richard Barnes wrote:
> On Mon, Jul 22, 2019 at 8:52 AM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Hi,
> 
> How should this search committee make its decision?  Do you envision them working from some sort of job description, or just "I know it when I see it"?

If they are people with deep knowledge of the RFC Series and good understanding of technical and standards publishing, they might well know it when they see it. But there should certainly be a job description, and a lot of the material in the draft SOW would be relevant. But since you can't order RSEs by the square metre, IMHO it does need to read like a job description rather than a SOW.

> How should this search committee be constituted?  RFC 6635 pretty clearly places the IAB in this role, but the fact that you didn't say "IAB" suggests that you mean some thing different.

As I already pointed out, that's not a BCP. So I think the community can be flexible here. "Do the right thing" as Spencer says from time to time. As above, people with deep knowledge of the RFC Series and of the whole publishing aspect would be appropriate. Clearly, it's not going to be the IAB as a whole.

Regards,
     Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 23 Jul 2019 02:34:28 +1200

> Either that, or we need to completely rethink the role of RSE.

I think that was already done, in the last round of relevant RFCs. What seems to be happening now is an undiscussed rethink of the role.
 
> IMO, we keep trying to replace Jon Postel, who was a very unique individual who grew into that role at a unique time.

No, I don't think so. Jon wasn't a professional in that particular role; he was a protocol expert from our community who thought carefully about the publishing aspect. So was Bob Braden. That's exactly the model we moved away from a few years ago. We essentially moved to the opposite: a publishing expert who thought carefully about the technical community aspect. 
 
> I certainly agree with Brian (and also John) /if/ we persist in thinking of the RSE as a senior (and wise) colleague who can be trusted to act in the best interests of the Internet and IETF (in that order).    (note that I don't mention governments or corporations or even other standards-making bodies as having legitimate interests here.)  
> 
> But maybe that's not the best idea, maybe such people are extremely scarce by now, and maybe they'll be nonexistent in the future.   And if we can't count on having suitable candidates in the future, then it seems likely that the role should be redefined, less independent, and subject to closer oversight.

Not joking: that sounds like what ITU-T does.
 
> choose carefully!

Indeed.

    Brian

---

From: John C Klensin <[email-masked]>
Date: Mon, 22 Jul 2019 10:35:27 -0400

Keith,

One observation:  "replace Jon Postel" has never been a
realistic goal.  Jon, in combination with Joyce Reynolds (and
I'm very concerned about what it might mean that we keep
forgetting her and her role) were carrying out the role of the
current RSE and ISE (and, for a long time, doing most of the
editing).  However, they were also exercising a strong technical
role, including applying a check on the technical quality,
sensibility, and even sanity of what was submitted  to them.  In
the reorganized model, we have split the RSE and ISE roles out
and have dropped that technical sanity check role for the RFC
Editor function (outside the Independent Stream) entirely,
trusting the Streams to get their own documents right.   Those
decisions were very explicit and the knowledge that we weren't
going to find another Jon Postel was a large part of the reason
for the redesign of what we now call the RFE Editor model.

Heather has been a demonstration of the above.  She has, in my
opinion (and apparently that of others) done a superb job.  She
has even done some things that the community thinks are
important that I don't believe Jon would have spent time on.
But she is no Jon Postel and has, as far as I know, shown no
signs of thinking that she is.  

Indeed, I would consider anyone who believed they could run the
Series the way Jon did, applying all of the skills and authority
that he had, to be too self-deluded to be an appropriate
candidate for the job.

   best,
     john

--On Monday, July 22, 2019 10:05 -0400 Keith Moore
<[email-masked]> wrote:

>> contractor, or via their existing employer. That's basically
>> a clerical matter, once the right person has been identified.
>> 
>> I now think that the notion of a pre-defined statement of
>> work and a competitive bidding process is*completely*
>> committee, and then leave IETF LLC to figure out any
> IMO, we keep trying to replace Jon Postel, who was a very
> unique individual who grew into that role at a unique time.
> 
> I certainly agree with Brian (and also John) /if/ we persist
> in thinking of the RSE as a senior (and wise) colleague who
> can be trusted to act in the best interests of the Internet
> and IETF (in that order).    (note that I don't mention
> governments or corporations or even other standards-making
> bodies as having legitimate interests here.)
> 
> But maybe that's not the best idea, maybe such people are
> extremely scarce by now, and maybe they'll be nonexistent in
> the future.   And if we can't count on having suitable
> candidates in the future, then it seems likely that the role
> should be redefined, less independent, and subject to closer
> oversight.
> 
> choose carefully!
> 
> Keith
> 
>

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 22 Jul 2019 14:38:33 +0000

It's a much much bigger world/scope than it used to be; HTTP/1.1 was published a year after he passed, for example.

---

From: Keith Moore <[email-masked]>
Date: Mon, 22 Jul 2019 10:41:58 -0400

On 7/22/19 10:35 AM, John C Klensin wrote:

> forgetting her and her role)
fair - and my apologies to Joyce.
> that he had, to be too self-deluded to be an appropriate

agree.

Keith

---

From: John C Klensin <[email-masked]>
Date: Mon, 22 Jul 2019 10:46:38 -0400

--On Monday, July 22, 2019 14:38 +0000 "Salz, Rich"
<[email-masked]> wrote:

>     Series the way Jon did, applying all of the skills and
> authority     that he had, to be too self-deluded to be an
> appropriate     candidate for the job.
>   
> It's a much much bigger world/scope than it used to be;
> HTTP/1.1 was published a year after he passed, for example.

Yes, and that reinforced my point.  You equally well could have
pointed out the ratio of the number of RFCs published before he
passed and after.   The other reason why we better not be
looking for another Jon Postel is that it isn't clear to me that
Jon would have either been able to do the job as it is seen
today or wanted to.   Indeed, I fear that the current state of
oversight by the present IAB and RSOC would make a comment Joyce
Reynolds once made about how Jon would have reacted to some of
the early turmoil in ICANN (both vis-a-vis the IANA role and
more generally) applicable here too. [1]

   john

[1] For those of you who don't know that comment, forget it.
I'm not going  to repeat it in public.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 23 Jul 2019 02:57:52 +1200

And I too should have mentioned Joyce Reynolds as well as Jon Postel and Bob Braden. But indeed, that was a different era.

    Brian

---

From: Michael Richardson <[email-masked]>
Date: Mon, 22 Jul 2019 13:59:44 -0400

Brian E Carpenter <[email-masked]> wrote:
    > competitive bidding process is *completely* inappropriate. What we
    > should do, IMHO, is identify the right person by a search process with
    > a well-informed search committee, and then leave IETF LLC to figure out
    > any necessary employment or contractual details later.

300 messages ago on this thread, I suggested that maybe the RSE needed to be
an employee.  I went on to wonder if an academic institution was an
appropriate clerical mechanism to consider, and I think that point was seized
upon, rather than the fundamental point that you are making.

So I agree completely with you.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: S Moonesamy <[email-masked]>
Date: Mon, 22 Jul 2019 15:29:27 -0700

Hi Richard,
>Sorry to be so horribly prosaic, but I have some practical questions...

[snip]

>How should this search committee make its decision?  Do you envision 
>them working from some sort of job description, or just "I know it 
>when I see it"?

If I am not mistaken, there is usually a description for this type of 
search.  I am not sure whether there would be agreement on 
identifying and approaching people who might fit in the position [1] 
instead of only advertising the position.

RSOC did not respond to my request for information.  As a response to 
the last question in your email, that approach might not be practical 
for a search committee.

Regards,
S. Moonesamy

1.  I used the word "position" to keep it simple.

---

From: Jari Arkko <[email-masked]>
Date: Mon, 22 Jul 2019 18:57:53 -0400

First, big +1 to mentioning Joyce more often :-)

> The RFC Series Editor has always been treated as a senior colleague, and part of our community leadership; never as a hired hand, because it isn't the sort of job that can easily be measured or pri…

I fully agree!

(With a small caveat of relevant RFCs being flexible enough to allow that. But RFCs can be changed.)

> Obviously there will be a finite budget limit that the search committee will bear in mind. But we aren't trying to find the cheapest RSE; we're trying to find the best one.

I agree with you.

> I now think that the notion of a pre-defined statement of work and a competitive bidding process is *completely* inappropriate. What we should do, IMHO, is identify the right person by a search pro…

I agree that a RSE is a very high level leader. But I’m not sure it directly follows that no statement of work or definition of role should exist. Usually when there’s a role to be filled somewhere in the world, even for a high level leader, there is some definition of what’s the scope and the expectations. But perhaps you meant to have an argument that the current RFC and/or SOW are far too focused on details and should emphasise the leadership aspect and not the details. And should clearly leave room for the selected leader to drive into a direction that she or he will eventually find the best direction. I’d be much easier convinced of that.

I have a similar reservation about appropriateness of “competitive bidding process”. I fully agree that making a search primarily a competition (and particularly, a finance-based competition) for any leadership position is a bad idea. But whether you’re looking for a CEO, Area Director, or the RSE there’s at least some possibility of alternative choices. If competition is the only thing in the search team’s mind, that would be bad. But they need to be aware of the potential out there when they are doing a search.

Jari

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 22 Jul 2019 19:07:23 -0400

As far as I know, the RSE search has never been principally (or at all) 
a financially based selection.
The bids were evaluated based on the apparent likelihood of the person 
successfully performing the needed job.  And if at all possible, doing 
more than we asked for.

I don't know why anyone thinks that the RSE search was price based.  The 
negotiation of salary is left to the IAD (ED) AFTER the selection.  (In 
fact, it is because that negotiation needs to take place, and could 
fail, that there is latitude in the request from the IAB to the IAD / ED 
/ IAOC / LLC.)

Yours,
Joel

---

From: Sarah Banks <[email-masked]>
Date: Mon, 22 Jul 2019 20:18:42 -0400

Hi,
   Considering the vast amount of email that I’ve been swimming in, it seems I missed an email. I could go searching, but to expedite, help me understand what your ask was for, again?

Thanks
Sarah

> On Jul 22, 2019, at 6:29 PM, S Moonesamy <[email-masked]> wrote:
> 
> Hi Richard,
> If I am not mistaken, there is usually a description for this type of search.  I am not sure whether there would be agreement on identifying and approaching people who might fit in the position [1] instead of only advertising the position.
> 
> RSOC did not respond to my request for information.  As a response to the last question in your email, that approach might not be practical for a search committee.
> 
> Regards,
> S. Moonesamy
> 
> _______________________________________________
> Rsoc mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rsoc

---

From: S Moonesamy <[email-masked]>
Date: Tue, 23 Jul 2019 00:28:27 -0700

Hi Sarah,
At 05:18 PM 22-07-2019, Sarah Banks wrote:
>    Considering the vast amount of email that I've been swimming in, 
> it seems I missed an email. I could go searching, but to expedite, 
> help me understand what your ask was for, again?

I asked for the information which the initial RFC Series Oversight 
Committee (RSOC) gathered from the previous RSE hiring exercise.

Regards,
S. Moonesamy

---

From: Sarah Banks <[email-masked]>
Date: Tue, 23 Jul 2019 21:01:19 -0400

Hi,
   Can you help me understand a bit more the ask here; could you expand a bit on what you’re thinking about when you say “information”?

Thanks
Sarah

> On Jul 23, 2019, at 3:28 AM, S Moonesamy <[email-masked]> wrote:
> 
> Hi Sarah,
>>   Considering the vast amount of email that I've been swimming in, it seems I missed an email. I could go searching, but to expedite, help me understand what your ask was for, again?
> 
> I asked for the information which the initial RFC Series Oversight Committee (RSOC) gathered from the previous RSE hiring exercise.
> 
> Regards,
> S. Moonesamy

---

From: S Moonesamy <[email-masked]>
Date: Tue, 23 Jul 2019 23:13:35 -0700

Hi Sarah,
At 06:01 PM 23-07-2019, Sarah Banks wrote:
>    Can you help me understand a bit more the ask here; could you 
> expand a bit on what you're thinking about when you say "information"?

I read the following: "During the creation of this document, it was 
expected that the RSOC would describe the process it ultimately 
selected to the community.  The RSOC did involve the community in 
interim considerations when that was likely to be of 
value.  Following completion of the selection process, the RSOC will 
determine the best way to share information learned and experience 
gained with the community and determine how to best preserve that 
information for future use".  I was thinking about whether there is a 
report of what was learned from what was done previously.  I used the 
word "information" not to make the request too difficult.

Regards,
S. Moonesamy

---

From: John Wroclawski <[email-masked]>
Date: Thu, 25 Jul 2019 15:51:43 -0400

> I now think that the notion of a pre-defined statement of work and a competitive bidding process is *completely* inappropriate. What we should do, IMHO, is identify the right person by a search pro…

Walking in from the distant sidelines, I would like to +1, or perhaps +1000, this note.

It hadn’t crystalized for me until Brian said it, but I think he’s got the key point exactly.

The basic gestalt of a search committee process is to find the best person in the world for a job, whether or not that person would have otherwise applied, or even whether they had any idea beforehand that the job existed and they’d be good at it.

The basic mindset of an RFP process is to pick the best person that applies.

I think the IETF wants option one.

To address a couple of points raised in replies to Brian, a) search committees absolutely _do_ work from written descriptions of the job, its key objectives, and likely-desirable candidate qualifications, and b) senior/executive search committees do indeed do this type of thing successfully all the time, and c) absolutely there are a great number of details to work out about responsibilities, structuring, communications, etc. that are extremely important as well.

But the key point is, I think, the IETF wants option one.

Cheers, —john

---

From: Bob Hinden <[email-masked]>
Date: Thu, 25 Jul 2019 18:49:14 -0400

John,

> On Jul 25, 2019, at 3:51 PM, John Wroclawski <[email-masked]> wrote:
> 
> 

I completely agree.  This should be treated as a search, not writing an RFP and see who applies.

Bob

---

From: Leif Johansson <[email-masked]>
Date: Fri, 26 Jul 2019 06:04:44 +0200

> I completely agree.  This should be treated as a search, not writing an RFP and see who applies.

Thats absolutely right - people & community over process!

	Cheers Leif

---

From: Richard Barnes <[email-masked]>
Date: Fri, 26 Jul 2019 08:30:44 -0400

> Thats absolutely right - people & community over process!

This seems ironic, given how focused this thread has been on process.  The
process (RFP vs search) doesn’t matter — either way we need to get the best
person for the role.

To put it in contrast to Klensin’s comment at the plenary — just because
someone is engaged as a contractor doesn’t make them a bag of nails.

—Richard

---

From: Leif Johansson <[email-masked]>
Date: Fri, 26 Jul 2019 16:43:09 +0200

On 2019-07-26 14:30, Richard Barnes wrote:
> On Fri, Jul 26, 2019 at 00:05 Leif Johansson <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
> 
> This seems ironic, given how focused this thread has been on process. 
> The process (RFP vs search) doesn’t matter — either way we need to get
> the best person for the role. 
> 

Richard,

That is not what "people over process" means.

What I mean is this: you find the right person for the job and then you
figure out how to get them into the position to do the job.

Maybe I should have said "people before process".

	Cheers Leif

---

From: Richard Barnes <[email-masked]>
Date: Fri, 26 Jul 2019 17:34:24 -0400

> Maybe I should have said "people before process".

You say this as if the right person just appears out of thin air.  There’s
always a process to find the right person, whether that’s posting a job
description and collecting CVs or posting an RFP and collecting RFP
responses.

The only way you find the right person without a process is to pick someone
you already know.  It would be irresponsible of this community to limit
ourselves in that way.

—Richard

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 27 Jul 2019 09:53:00 +1200

Richard,

> The only way you find the right person without a process is to pick someone you already know.

Of course. That's exactly why the procedure for senior appointments starts with a search committee. That's how we got Heather, for example. It's a completely different process than an RFP for a measurable job of work.

Regards
   Brian

On 27-Jul-19 09:34, Richard Barnes wrote:
> On Fri, Jul 26, 2019 at 10:43 Leif Johansson <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> 
>     > On Fri, Jul 26, 2019 at 00:05 Leif Johansson <[email-masked] <mailto:[email-masked]>
>     > <mailto:leifj@mnt..se <mailto:[email-masked]>>> wrote:
>     >
>     >
>     >     > I completely agree.  This should be treated as a search, not
>     >     writing an RFP and see who applies.
>     >
> You say this as if the right person just appears out of thin air.  There’s always a process to find the right person, whether that’s posting a job description and collecting CVs or posting an RFP and collecting RFP responses.
> 
> The only way you find the right person without a process is to pick someone you already know.  It would be irresponsible of this community to limit ourselves in that way.
> 
> —Richard
> 
>

---

From: Richard Barnes <[email-masked]>
Date: Sat, 27 Jul 2019 09:32:39 -0400

On Fri, Jul 26, 2019 at 5:54 PM Brian E Carpenter <
[email-masked]> wrote:

> Of course. That's exactly why the procedure for senior appointments starts
> with a search committee. That's how we got Heather, for example.

https://iaoc.ietf.org/documents/RSE-RFP-4August2017.pdf ?

> It's a completely different process than an RFP for a measurable job of
> work.
>
> Regards
>    Brian
>
> <mailto:[email-masked]>
> > You say this as if the right person just appears out of thin air.
> There’s always a process to find the right person, whether that’s posting a
> job description and collecting CVs or posting an RFP and collecting RFP
> responses.
> >
> > The only way you find the right person without a process is to pick
> someone you already know.  It would be irresponsible of this community to
> limit ourselves in that way.
> >
> > —Richard
> >
> >
>
>

---

From: "Livingood, Jason" <[email-masked]>
Date: Sat, 27 Jul 2019 19:38:10 +0000

>    I think the IETF wants option one.
    
[JL] If this is the case, I wonder if it much matters to the community whether the role is an employee (full or part time) or a contractor (full or part time)? Or whether that might be left open-ended to depend upon the particulars of the country in which someone resides or their other commitments & preferences. IIRC, Sean Turner raised this question perhaps six months ago - which of course predated the current situation (so views may have changed). 

Jason

---

From: Stephen Farrell <[email-masked]>
Date: Sat, 27 Jul 2019 20:59:14 +0100

Hiya,

On 27/07/2019 20:38, Livingood, Jason wrote:
> [JL] If this is the case, I wonder if it much matters to the
> community whether the role is an employee (full or part time) or a
> contractor (full or part time)?
For reasons stated earlier on the iasa2 list and as I stated
at the plenary during open mic, I remain opposed to the idea
of an employee-RSE. It does seem to keep being suggested, but
that won't IMO make it a better idea;-)

S.

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 28 Jul 2019 08:51:57 +1200

> that won't IMO make it a better idea;-)

I think it will depend on the personal circumstances of the individual person selected. That's why I recently referred to it as a clerical detail.

   Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 28 Jul 2019 08:56:51 +1200

On 28-Jul-19 01:32, Richard Barnes wrote:
> On Fri, Jul 26, 2019 at 5:54 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Richard,
> 
>     Of course. That's exactly why the procedure for senior appointments starts with a search committee. That's how we got Heather, for example. 
> 
> 

Don't ask me why the RSOC+IAOC chose to do that in 2017. Heather was found by a search committee of the RFSOC in 2011.

   Brian
  
> 
>     It's a completely different process than an RFP for a measurable job of work.
> 
>     Regards
>        Brian
> 
>     > On Fri, Jul 26, 2019 at 10:43 Leif Johansson <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>     >
>     >
>     >
>     >     > On Fri, Jul 26, 2019 at 00:05 Leif Johansson <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>     >     > <mailto:leifj@mnt. <mailto:leifj@mnt.>.se <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:
>     >     >
>     >     >
>     >     >     > I completely agree.  This should be treated as a search, not
>     >     >     writing an RFP and see who applies.
>     >     >
>     >     >     Thats absolutely right - people & community over process!
>     >     >
>     >     >
>     >     > This seems ironic, given how focused this thread has been on process. 
>     >     > The process (RFP vs search) doesn’t matter — either way we need to get
>     >     > the best person for the role. 
>     >     >
>     >     > To put it in contrast to Klensin’s comment at the plenary — just because
>     >     > someone is engaged as a contractor doesn’t make them a bag of nails.
>     >
>     >     Richard,
>     >

---

From: Ole Jacobsen <[email-masked]>
Date: Sat, 27 Jul 2019 15:06:33 -0700

> On 27 Jul 2019, at 12:38, Livingood, Jason <[email-masked]> wrote:
> 

Jason,

I don’t think the employment mechanism matters either, so I agree with you in principle.

However, statements to the effect of “Oh, s[h]e is just a contractor!” have apparently
been uttered in the broader context of the IETF and the various roles we have
been discussing on this list (not just the RSE). That might be reflective of
attitudes that do not serve us well in the long run, and lead us to consider
these roles in a different light.

Ole

Ole J. Jacobsen
Editor and Publisher
The Internet Protocol Journal
Office: +1 415-550-9433
Cell:   +1 415-370-4628
Web: protocoljournal.org
E-mail: [email-masked]
E-mail: [email-masked]
Skype: organdemo

---

From: Michael StJohns <[email-masked]>
Date: Sat, 27 Jul 2019 19:08:48 -0400

> [JL] If this is the case, I wonder if it much matters to the community whether the role is an employee (full or part time) or a contractor (full or part time)? Or whether that might be left open-en…

Hi Jason -

Let me run a few terms past you (we can quibble about each, but this 
seems to be the general  set I've seen - there are variations within each):

Employee, contract employee, employee with a contract, 
contractor/consultant.

* Employee - generally at will employment, most positions within a 
company, can be told what to do, when to do it and how to do it 
generally by anyone above them in the food chain.  Generally only has a 
single employer (at least for salaried employees).

* Contract employee - an employee of an organization that is contracted 
by a second organization for work.  AKA Body shop contractor (but there 
are other variations on this for more senior folk - something like 
outside counsel arrangements with law firms).

* Employee with a contract - an employee, but with a contract that 
spells out conditions and modifications to the general labor practices 
of the company, may include bonus, and exceptional compensation items 
(e.g. golden parachutes); usually the way a number of the C staff in 
larger companies are hired.  Employment is generally not at will, but 
there are mechanisms for termination that can be exercised by each 
party.  Usual manager is either CEO or the board, or rarely another C staff.

* Contractor/consultant.  Has a contract for services to a given 
company, may do work for multiple entities.  May be tasked by the 
company (generally a specific contract POC), *_but not told when or how 
to do it_*.    May be an individual or a company.   Includes both common 
services contractors (e.g. IT) and Subject matter expert consultants.  
Contracts may be very specific in deliverables, or much more open 
ended.  May be duration or task based.

The main problem I see with trying to do this role as an "employee",  is 
that the LLC doesn't have a deep enough organization to handle an 
employee as senior and independent as the role needs to be.   It's 
possible that the "employee with a contract" model might work, but given 
our experience with Heather and the fact that we were only utilizing  
about 50% or so of her time, it might be difficult to cover the 
additional 50% of an full time employee and keep them fully engaged and 
interested year after year.

SME Consultant with a lot more constraints on who gets to give the RSE 
direction than we currently have seems to  me to be a better choice than 
either of the employee variations.

As I was writing the above, something struck me.   Heather (and Jon, Bob 
and Joyce before her) is as senior and competent in her field as the 
various lawyers we've engaged to deal with the LLC, Trust etc over the 
years are in theirs.  We wouldn't think it would be a good idea to 
micromanage the lawyers (and I'm sure they wouldn't tolerate it).  I'm 
not quite sure why we thought it was a good idea to provide the level of 
"oversight" and management to such a senior level position, and that 
appears to have been part of the problem.

Later, Mike

---

From: Keith Moore <[email-masked]>
Date: Sat, 27 Jul 2019 20:27:30 -0400

On 7/27/19 6:06 PM, Ole Jacobsen wrote:

> been discussing on this list (not just the RSE).

One meaning of "just a contractor" is, basically, "expendable". Because 
in many situations, companies hire contractors specifically when they 
don't want to commit to hiring employees.

Or more subtly, I've worked as a contractor many times, sometimes for 
years at a time, and felt like I was part of the team - but was always 
treated just a bit differently.   Not disrespectfully, but in the sense 
of "you're not quite one of us; we're here for the indefinite future and 
you're not".

So if you want someone to stay around indefinitely, "contractor" is 
definitely the wrong way to speak of them.    That doesn't mean there 
can't be an employment contract, but that contract needs to be 
(re)negotiated by people who fully understand the value in keeping that 
person around and the need to treat that person well, and have the power 
to make that happen.

Keith

---

From: Wes Hardaker <[email-masked]>
Date: Mon, 29 Jul 2019 11:08:49 -0700

> seems to be the general  set I've seen - there are variations within

I think your terms and definitions are reasonable, so I won't quibble
about those. I've been on both sides of most of those terms.  And none
of them are as rigid as you state, of course, because there is a lot of
gray area in any definition list.  I've seen contractors be told exactly
what to do and be micro-managed (and they put up with it or they lose
the contract), and I've seen employees be let free to roam and do what
they thought was best because they were hired to be smart.

> * Employee - generally at will employment, most positions within a company, can be
> told what to do, when to do it and how to do it generally by anyone above them in the
> food chain.  Generally only has a single employer (at least for salaried employees).

Your use of "can be" in the employee definition is the important part.
Its not the definitions of the position type that matters.  It's how we,
as the organization and people that are defining the role interact and
manage said role.  If we want to attract and keep good talent for the
critical RSE role, then the way to do that is by being the type of
organization and manager that will attract talented folks and make them
want to stick around regardless of the business relationship type we select.

[...other quotes snipped for length...]

-- 
Wes Hardaker
USC/ISI

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 29 Jul 2019 14:15:58 -0400

I agree that the way we behave towards our staff (senior and 
otherwise) is the important part.  Unfortunately, we have two problems 
in that area.
     First, we have recently been interacting with the RSE in ways that 
seem unlikely to encourage strong professionals to expect positive 
treatment.  I do not think that was the intention, even of those who 
want changes in the series.  But I think it is a likely effect.
     Second, we are in the process of hiring the person who, if the RSE 
were to be an employee, would be that person's boss.  So it is hard for 
anyone interviewing to judge how the organization will work.  Again, 
that was not a deliberate choice on anyone's part.  But it is an 
important part of the reality.

     It seems to me therefore that we have to find ways to define and 
describe the job so that we can give likely candidates confidence in 
what they are likely to face / be supported by.  While the formal part 
of that falls to the RSOC, we all share in the informal part of it.

Yours,
Joel

---

From: Michael Richardson <[email-masked]>
Date: Mon, 29 Jul 2019 16:06:20 -0400

> seems to be the general  set I've seen - there are variations within

Thank you.

...

    > company (generally a specific contract POC),

        *_but not told when or how to do it_*.

    >     May be an individual or a company.   Includes both
    > common services contractors (e.g. IT) and Subject matter expert
    > consultants.  Contracts may be very specific in deliverables, or much
    > more open ended.  May be duration or task based.

In Canada our federal tax people ("Revenue Canada", now "CRA") have rules
about whether people are contractor/consultants or employees, and generally contractors:
   - work when they want
   - where they want.
   - bring their own tools
     [what that means in an era of "cloud" tools on corporate accounts...]

If the contractee specifies too much of this, then they become an employee.
Among federal departments who are most blantant about disregarding those
rules, is naturally, CRA.

    > The main problem I see with trying to do this role as an "employee", 
    > is that the LLC doesn't have a deep enough organization to handle an
    > possible that the "employee with a contract" model might work, but
    > given our experience with Heather and the fact that we were only
    > utilizing  about 50% or so of her time, it might be difficult to cover
    > the additional 50% of an full time employee and keep them fully engaged
    > and interested year after year.

I don't think it's the details of this "clerical" mechanism that matters.
It's the process (RFP+BID) vs Search-committee+interview that matters.

    > As I was writing the above, something struck me.   Heather (and Jon,
    > Bob and Joyce before her) is as senior and competent in her field as
    > the various lawyers we've engaged to deal with the LLC, Trust etc over
    > the years are in theirs.  We wouldn't think it would be a good idea to
    > not quite sure why we thought it was a good idea to provide the level
    > of "oversight" and management to such a senior level position, and that

:-)
+10.

I thought the RSOC was also responsible for the details of the RPC contract.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Michael Richardson <[email-masked]>
Date: Mon, 29 Jul 2019 16:07:40 -0400

Stephen Farrell <[email-masked]> wrote:
    >> [JL] If this is the case, I wonder if it much matters to the community
    >> whether the role is an employee (full or part time) or a contractor
    >> (full or part time)?
    
    > For reasons stated earlier on the iasa2 list and as I stated at
    > the plenary during open mic, I remain opposed to the idea of an
    > employee-RSE. It does seem to keep being suggested, but that won't
    > IMO make it a better idea;-)

Are you opposed to the "clerical" issue of how the person is paid,
or are you opposed to the person being hired by interview rather than RFP?

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 29 Jul 2019 21:19:55 +0100

Hiya,

(I think all these points were raised on the iasa2 list fwiw.)

On 29/07/2019 21:07, Michael Richardson wrote:
> are you opposed to the person being hired by interview rather than
> RFP?

More, but not quite, the former. My main reasons are that I at
least perceive employers to generally have more sway over
employees than contractors (YMMV, but nonetheless), and secondly
an RSE-employee on a fixed term contract, based where I live,
whose employment contract was renewed twice, regardless of being
part-time or not, could then legally claim to be the permanent
RSE until their retirement date, thanks to (what I consider good)
employment law. I don't think Ireland is alone in having such
laws and would prefer that the RSE selection process not have to
omit such countries from a hiring process. That latter reason
may or may not apply depending on the person, but is another
reason why a more independent RSE is better IMO.

RSOC are the ones who need to figure the details of the latter,
so I'll leave those details to them, but I really hope they factor
in the need to re-gain community confidence in the process and
outcome.

Cheers,
S.

PS: Some IAB members are on vacation this week so some specific
responses may take a while longer than usual.

---

From: Michael StJohns <[email-masked]>
Date: Mon, 29 Jul 2019 16:48:07 -0400

> or are you opposed to the person being hired by interview rather than RFP?
Practical:

1) The general LOE for the RSE according to RFC6635 is 20 hours a week.  
It's difficult to be just a part-time employee as a salaried worker for 
various reasons including benefits, and the general assumption that if 
you're working for company A, you're not working for company B.  Throw 
in the need to do full time weeks 3-5 times a year for the RSE (IETF and 
various retreats or other meetings) and that time has to be taken from 
other employers and you get into some messy situations.

2) The employing organization (e.g. the LLC) doesn't really have the 
size to be able to handle traditional employees.  Even the ED hire is 
going to be interesting.  Think about payroll, HR, benefits, etc.  Then 
think about the need for some manager.  You could make it the LLC under 
an "employee with a contract model" and assign them to the LLC to 
manage, but there would still be a lot of things to work out.  Then 
there's "advancement" or the lack thereof.   For Ray, we punted - he was 
really a contracted for employee by the IAOC of a larger company (ISOC) 
as far as I can tell.   And placing the RSE under the ED is pretty much 
a recipe for failure for oh so many reasons.

3) Stephen's other note (surprising to me) about life tenure after a 
period of time in certain companies.  I don't think we want to limit our 
selection to countries where this isn't the law.

Relational:

1) This is a senior person who really should be co-equal with the IAB 
and IESG.  Contracts at least allow for some specification of 
relationships between these three entities without screwing up supremacy 
issues in each of the entities bailiwick.   I would expect the next 
contract to be rather restrictive on who gets to give direction to the RSE.

2) We haven't any one who could actually be a manager respected (in 
terms of the ability to actually provide value add in managing someone 
who knows more about publishing than the putative manager) by a good 
candidate for the RSE position.

Obvious:

1) Publishing is not in any way a core competency of the IETF.

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 31 Jul 2019 13:28:29 -0400

Hi Mike,

> On Jul 29, 2019, at 4:48 PM, Michael StJohns <[email-masked]> wrote:
> 
> 1) The general LOE for the RSE according to RFC6635 is 20 hours a week.  It's difficult to be just a part-time employee as a salaried worker for various reasons including benefits, and the general assumption that if you're working for company A, you're not working for company B.  Throw in the need to do full time weeks 3-5 times a year for the RSE (IETF and various retreats or other meetings) and that time has to be taken from other employers and you get into some messy situations.
> 
> 2) The employing organization (e.g. the LLC) doesn't really have the size to be able to handle traditional employees.  Even the ED hire is going to be interesting.  Think about payroll, HR, benefits, etc.  Then think about the need for some manager. 

The LLC has planned and is preparing for the situation where the executive director and potentially others could be sustained as traditional employees.

> You could make it the LLC under an "employee with a contract model" and assign them to the LLC to manage, but there would still be a lot of things to work out.  Then there's "advancement" or the lack thereof.   For Ray, we punted - he was really a contracted for employee by the IAOC of a larger company (ISOC) as far as I can tell.  

Ray was an ISOC employee. 

Best,
Alissa

> And placing the RSE under the ED is pretty much a recipe for failure for oh so many reasons.
> 
> 3) Stephen's other note (surprising to me) about life tenure after a period of time in certain companies.  I don't think we want to limit our selection to countries where this isn't the law.
> 
> Relational:
> 
> 1) This is a senior person who really should be co-equal with the IAB and IESG.  Contracts at least allow for some specification of relationships between these three entities without screwing up supremacy issues in each of the entities bailiwick.   I would expect the next contract to be rather restrictive on who gets to give direction to the RSE.
> 
> 2) We haven't any one who could actually be a manager respected (in terms of the ability to actually provide value add in managing someone who knows more about publishing than the putative manager) by a good candidate for the RSE position.
> 
> Obvious:
>

---

From: Michael StJohns <[email-masked]>
Date: Wed, 31 Jul 2019 13:44:27 -0400

> The LLC has planned and is preparing for the situation where the executive director and potentially others could be sustained as traditional employees.

I know this.  I also know there will be growing pains, and that the RSE 
is not a "traditional employee" in any sense of the word. In any event, 
until you can deal with (1), you don't need to think about (2) or (3) or 
the other bullets.

> Ray was an ISOC employee.

*sigh*  Either I need to take writing lessons or others need to read 
more closely.  I'm not sure what the correct answer is.

Yes, Ray was an ISOC employee and as an employee was a contracted for 
resource of the IETF.  That contract might have been implicit or 
explicit, in kind or with a dollar value attached, but it was a contract 
between the IETF and the ISOC for Ray's services.   Maybe "contracted 
for employee, by the IAOC, of a larger company (ISOC)" would have been 
clearer?

Later, Mike

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 31 Jul 2019 14:34:20 -0400

Hi Mike,

> On Jul 31, 2019, at 1:44 PM, Michael StJohns <[email-masked]> wrote:
> 
> I know this. 

Great! Just wanted to make sure the facts are clear for everyone.

> I also know there will be growing pains, and that the RSE is not a "traditional employee" in any sense of the word. In any event, until you can deal with (1), you don't need to think about (2) or (3) or the other bullets.
> 
>> 
> *sigh*  Either I need to take writing lessons or others need to read more closely.  I'm not sure what the correct answer is.
> 
> Yes, Ray was an ISOC employee and as an employee was a contracted for resource of the IETF.  That contract might have been implicit or explicit, in kind or with a dollar value attached, but it was a contract between the IETF and the ISOC for Ray's services.   Maybe "contracted for employee, by the IAOC, of a larger company (ISOC)" would have been clearer?

Since the thread had turned in the direction of discussing the details of specific employment relationships, it seems like the subtleties here matter. Since the IETF was organized as an activity of ISOC while Ray was IAD, there was no written contract to speak of between the IETF or the IAOC and ISOC that I’m aware of (though happy to be corrected if I’m wrong). The understanding of the IAD role was documented in RFC 4071. I wasn’t thinking of RFC 4071 as an “implicit contract” when I read your mail, but perhaps that is one way of thinking about it.

By contrast, Portia was not an employee of ISOC. She was a contractor to ISOC before the IETF LLC was created, and is now a contractor to the IETF LLC, under your definition of “contractor/consultant.”

Best,
Alissa