Subject: Re: Effective discourse in the IETF

From: "Salz, Rich" <[email-masked]>
Date: Wed, 3 Jul 2019 16:27:27 +0000

The world has moved on, and that’s a good thing. What used to be acceptable in terms of communication, isn’t; the bar has been raised. If the IETF wants to draw from global membership, it’s going to need to modify (and/or mollify) behavior that used to be acceptable. There is a whole wide world of cultures and genders that can, and should, have something to say about how to make the world better, and *we need to be nice* and *we need to be welcoming.* That doesn’t mean we have to accept poor technical solutions, but we can and should do a better job talking to each other.

If you grew up writing RFC’s whose numbers are in the double digits, and you think it’s the same community, you probably need to look around and think again.

If your personal philosophy is “I am responsible for my mind, just tell me the facts” then please think of others who don’t share your mental discipline and don’t use your admirable self-control as a justification for you to ignore common courtesy to them.

If you’ve worked with folks for years and stand up at the mic, before saying “that’s really stupid” consider how others in the room might be intimidated from contributing, and how much worse off we’ll be because of that loss.

                /r$

---

From: Ted Lemon <[email-masked]>
Date: Wed, 3 Jul 2019 12:50:09 -0400

> The world has moved on, and that’s a good thing. What used to be acceptable in terms of communication, isn’t; the bar has been raised. If the IETF wants to draw from global membership, it’s going t…

To be clear, Rich, the reason I shared those books is that I think the IETF would benefit greatly from some of us who are vocal reading them.   I certainly benefited from reading them.   I am not suggesting that we go back to the bad old days of excusing deliberate rudeness.

I think we do need to be nice and welcoming, but we also need to speak up when we see something happening that seems wrong.  When that speech is dismissed, the result of this is that the speaker has no choice but to be silenced or speak louder.   If we ignore this aspect of the feedback cycle, the only possible outcome is that unwanted speech will be suppressed, either through self-censorship or through PR-action once the volume gets too high.

I took a course last year called the altMBA where all we did was write, criticize each other, and then reflect on the criticism.   Okay, that’s a gross oversimplification, but the point is that the value of that cycle was immense.  When people got up their courage and really offered generous criticism, which included saying things like “this doesn’t make sense to me” and “I don’t think you are right about this,” it was incredibly useful.   We were explicitly told to expect this kind of criticism, and requested to offer it, and that’s why it worked.   We have to encourage both sides of the criticism loop, not just one.

I don’t mean that the IETF needs to turn into the altMBA, but I hear a lot of people really completely ignoring the responsibility that participants have when they are being criticized, and just talking about the responsibilities of critics.  And not even talking about the importance of criticism.  That’s not going to work.  I think we could benefit by thinking about this more seriously, and not just sloganing about it, although I will make my attempt as well:

Yes, we can and should do a better job of talking to each other.  But that’s a shared responsibility.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 4 Jul 2019 12:06:34 +1200

On 04-Jul-19 04:27, Salz, Rich wrote:
> The world has moved on, and that’s a good thing. What used to be acceptable in terms of communication, isn’t; the bar has been raised. If the IETF wants to draw from global membership, it’s going to need to modify (and/or mollify) behavior that used to be acceptable. There is a whole wide world of cultures and genders that can, and should, have something to say about how to make the world better, and **we need to be nice** and **we need to be welcoming.** That doesn’t mean we have to accept poor technical solutions, but we can and should do a better job talking to each other.

I worried about this quite a bit when drafting what became the newcomer guidance on the IETF web site. At the moment it says:

"The IETF is normally very welcoming to newcomers, and tolerance is the rule. The technical level is quite high, so if you write something that turns out to be wrong, you may get some quite frank replies. Or sometimes you will get a reply from someone whose first language is not English, and they can be rude without intending it. (If someone is seriously offensive, the WG Chairs are supposed to deal with it.) Don't be discouraged; everybody started as a newcomer."

Whether that is accurate is of course open to discussion.

    Brian