Subject: Re: The RSE's perspective

From: Richard Barnes <[email-masked]>
Date: Wed, 3 Jul 2019 18:49:36 -0400

¡Hola Heather!

Maybe you could help clear up some confusion for me, in light of the more
detailed information that Ted and Alissa have recently provided to the
community.

> The RSOC/IAB is pushing hard on the missed SLA, not acknowledging that
statements were made (with full support and understanding of earlier
leadership cohorts) on plenary stage and in meetings that the SLA would be
missed as the format tool testing and transition ramped up.

>From the details Alissa provided, the IAB's oversight of the SLA seems
entirely reasonable, and they seem to be making tweaks in a good direction.
Could you clarify how you wish this had gone differently?

> My oversight committee, which is a group that I must work with most
closely, was almost completely replaced without any input from me. I have
what essentially acts as a design team, the RFC Series Advisory Group. They
generally aren’t consulted either.

>From Ted's note, it seems like the IAB's normal processes were followed
here, including soliciting feedback on the candidates for RSOC. But you say
the decision was made "without any input" from you. Did you not provide
feedback?

Thanks,
--Richard

On Thu, Jun 20, 2019 at 8:40 AM Heather Flanagan <[email-masked]> wrote:

> Hola a todos!
>
> As with all endings, every side of the story has their own perceptions of
> what’s happened. I want to share my thinking and perceptions behind my
> decision not to renew my contract as RSE at the end of this year.
>
> My view for the RFC Series is one that supports making available
> high-quality technical documents by and for the Internet, from a variety of
> sources. My view for the RFC Editor is one that supports a
> technology-neutral but highly skilled partner in the process. The RFC
> Series Editor represents those views in an equal role to the various stream
> managers. The IETF is the RFC Editor’s biggest client, so the collaboration
> between the organizations is critical. But it needs to *be* a
> collaboration, where both sides respect the skills and knowledge of the
> other. It is not a subordinate relationship, where the RFC Editor is simply
> a group offering services are useful but not truly critical. It is also not
> a relationship where the strategy and decisions for the Series itself are
> dictated by IETF leadership.
>
> Over the last year, I’ve seen the rfcplusplus BoF happen, against my
> recommendation. My oversight committee, which is a group that I must work
> with most closely, was almost completely replaced without any input from
> me. I have what essentially acts as a design team, the RFC Series Advisory
> Group. They generally aren’t consulted either. The RSOC/IAB is pushing hard
> on the missed SLA, not acknowledging that statements were made (with full
> support and understanding of earlier leadership cohorts) on plenary stage
> and in meetings that the SLA would be missed as the format tool testing and
> transition ramped up. And then I see the new RSOC completely ignore the
> learnings of the first and second RFPs for the RSE role, and make
> recommendations again without input from people who have experience with
> the process. With all that said,  RSOC/IAB have done nothing that they
> aren’t allowed to do in their various charters. But if that’s the way the
> organization is going to be run, I don’t feel like I’m at all a good fit
> for how business is handled.  I would rather find other ways I can be
> effective in helping to do my part in improving the Internet.
>
> My interpretation of events of the last year as described above,
> culminating with the decision to put the RSE contract out to bid at year
> four instead of year six, is that my view for the RFC Series and the RFC
> Editor are not aligned with the expectations of the IETF leadership. At the
> end of the day, I am a contractor, and what I see here is a relationship
> with a client that is unhappy with my performance, but they can’t or won’t
> tell me why. Rather than drag this out, I think it’s best to let the client
> go, and the communities that depend on the RFC Series can decide what it is
> they really want in an RFC Series Editor.
>
> I will do what I can, within reason, to ensure a smooth transition to a
> new RSE. And I will be in Montreal and Singapore, where I hope to tell many
> of you in person just how much I’ve enjoyed working with you over the last
> seven years. Thank you for the well wishes, and best of fortunes into the
> next stage of evolution for the IETF and the RFC Editor!
>
> Thank you for all the many fine lunches and dinners,
> Heather
>

---

From: Heather Flanagan <[email-masked]>
Date: Wed, 3 Jul 2019 15:59:24 -0700

> On Jul 3, 2019, at 3:49 PM, Richard Barnes <[email-masked]> wrote:
> 
> ¡Hola Heather!

¡Hola Richard!

> 
> Maybe you could help clear up some confusion for me, in light of the more detailed information that Ted and Alissa have recently provided to the community.
> 
> 
> > The RSOC/IAB is pushing hard on the missed SLA, not acknowledging that statements were made (with full support and understanding of earlier leadership cohorts) on plenary stage and in meetings that the SLA would be missed as the format tool testing and transition ramped up.
> 
> From the details Alissa provided, the IAB's oversight of the SLA seems entirely reasonable, and they seem to be making tweaks in a good direction. Could you clarify how you wish this had gone differently?

Of course. Oversight of the SLA is entirely reasonable. Where I started to have difficulties were around how, when presented with information that the gaps in SLA were understood and expected, I felt the pressure was on determining fault more than working to improve the SLA, what is measured, how exceptions are handled, etc. It may very well be that wasn’t the intention, but communication is a tricky thing (as we’re demonstrating on the list). There’s what was said, what was heard, and what was meant, and sometimes those things diverge beyond any reasonable set of expectations. 

> 
> 
> > My oversight committee, which is a group that I must work with most closely, was almost completely replaced without any input from me. I have what essentially acts as a design team, the RFC Series Advisory Group. They generally aren’t consulted either.
> 
> From Ted's note, it seems like the IAB's normal processes were followed here, including soliciting feedback on the candidates for RSOC. But you say the decision was made "without any input" from you. Did you not provide feedback?

I asked if it would be accepted and received no reply; feedback offered to me in person in the past indicated that I needed to tread carefully when it came to offering any kind of feedback during a community process such as this. I had also expected that, much like when I’ve had bosses hired in the past (not a direct analogy, but close enough for this conversation) that an explicit attempt would be made to engage the employees in the interview process to make sure there was a fit in all directions.  

Hope that helps,
Heather

> 
> 
> Thanks,
> --Richard
> 
> On Thu, Jun 20, 2019 at 8:40 AM Heather Flanagan <[email-masked] <mailto:[email-masked]>> wrote:
> Hola a todos!
> 
> As with all endings, every side of the story has their own perceptions of what’s happened. I want to share my thinking and perceptions behind my decision not to renew my contract as RSE at the end of this year. 
> 
> My view for the RFC Series is one that supports making available high-quality technical documents by and for the Internet, from a variety of sources. My view for the RFC Editor is one that supports a technology-neutral but highly skilled partner in the process. The RFC Series Editor represents those views in an equal role to the various stream managers. The IETF is the RFC Editor’s biggest client, so the collaboration between the organizations is critical. But it needs to *be* a collaboration, where both sides respect the skills and knowledge of the other. It is not a subordinate relationship, where the RFC Editor is simply a group offering services are useful but not truly critical. It is also not a relationship where the strategy and decisions for the Series itself are dictated by IETF leadership. 
> 
> Over the last year, I’ve seen the rfcplusplus BoF happen, against my recommendation. My oversight committee, which is a group that I must work with most closely, was almost completely replaced without any input from me. I have what essentially acts as a design team, the RFC Series Advisory Group. They generally aren’t consulted either. The RSOC/IAB is pushing hard on the missed SLA, not acknowledging that statements were made (with full support and understanding of earlier leadership cohorts) on plenary stage and in meetings that the SLA would be missed as the format tool testing and transition ramped up. And then I see the new RSOC completely ignore the learnings of the first and second RFPs for the RSE role, and make recommendations again without input from people who have experience with the process. With all that said,  RSOC/IAB have done nothing that they aren’t allowed to do in their various charters. But if that’s the way the organization is going to be run, I don’t feel like I’m at all a good fit for how business is handled.  I would rather find other ways I can be effective in helping to do my part in improving the Internet.
> 
> My interpretation of events of the last year as described above, culminating with the decision to put the RSE contract out to bid at year four instead of year six, is that my view for the RFC Series and the RFC Editor are not aligned with the expectations of the IETF leadership. At the end of the day, I am a contractor, and what I see here is a relationship with a client that is unhappy with my performance, but they can’t or won’t tell me why. Rather than drag this out, I think it’s best to let the client go, and the communities that depend on the RFC Series can decide what it is they really want in an RFC Series Editor.
> 
> I will do what I can, within reason, to ensure a smooth transition to a new RSE. And I will be in Montreal and Singapore, where I hope to tell many of you in person just how much I’ve enjoyed working with you over the last seven years. Thank you for the well wishes, and best of fortunes into the next stage of evolution for the IETF and the RFC Editor!
>