Subject: About BCP 45

From: Brian E Carpenter <[email-masked]>
Date: Thu, 25 Jul 2019 02:58:58 +1200

Hi,

To avoid this consuming microphone time tonight, I'll raise two points here instead:

1) draft-ietf-iasa2-consolidated-upd-07, which is approved and in the RFC queue, says:

>    o  RFC 3005, IETF Discussion List Charter [RFC3005], section titled
>       "Charter for the IETF Discussion List".  This document is modified
>       to remove the authorization for the IETF Executive Director to
>       restrict people from posting, etc.

However, I note that this hasn't yet been applied in the relevant place in the IESG wiki (https://trac.ietf.org/trac/iesg/wiki/EnsuringAppropriateDiscussionOnIetfAtIetfList#Sergeants-at-Arms). There is no such person as the "IETF Executive Director" today.

2) More seriously, although this point isn't addressed in BCP 45 (RFC 3005), one of the current sergeants-at-arms has since been appointed to the IESG. If a point in debate on the list directly concerns the IESG -- and possibly the sergeant-at-arms in person -- there would be a clear conflict. Do people think this is OK?

It's also the case that BCP 45 gives the IETF Chair the power to restrict postings, but that was clearly intentional. It seems to me that the reason BCP 45 added the sergeant-at-arms role was precisely to avoid the risk of conflict for the IETF Chair. But that isn't stated in the RFC.

Regards
   Brian Carpenter

---

From: Alissa Cooper <[email-masked]>
Date: Wed, 24 Jul 2019 11:06:49 -0400

Hi Brian,

Thanks for your email. A few responses below.

> On Jul 24, 2019, at 10:58 AM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 

See https://tools.ietf.org/html/draft-ietf-iasa2-consolidated-upd-07, which is in the RFC Editor’s queue. This draft removes the IETF Executive Director from the document.

> It's also the case that BCP 45 gives the IETF Chair the power to restrict postings, but that was clearly intentional. It seems to me that the reason BCP 45 added the sergeant-at-arms role was preci…

I have a few thoughts about this that I plan to share at the plenary today. Given the tenor of discussions on this list recently I thought that would be a better venue for discussion.

Regards,
Alissa