Subject: Fwd: Things that used to be clear (was Re: Evolving Documents (nee "Living Documents") side meeting at IETF105.)

From: Keith Moore <[email-masked]>
Date: Thu, 4 Jul 2019 23:05:22 -0400

Summary: in private email Job Snijders clarified the specific purpose he had in mind for evolving/living documents, and I replied that I didn’t think I was in a position to evaluate use of such documents for that purpose and my only concern was that they shouldn’t be used for protocol specifications without a lot more discussion.  He asked that I disclose the result of our conversation to the list, and I’m hereby doing so.  (Hope forwarding from my phone is sufficient and not confusing.)

Keith

Sent from my iPhone

Begin forwarded message:

> From: Keith Moore <[email-masked]>
> Date: July 4, 2019 at 6:46:06 PM EDT
> To: Job Snijders <[email-masked]>
> Cc: Ted Lemon <[email-masked]>
> Subject: Re: Things that used to be clear (was Re: Evolving Documents (nee "Living Documents") side meeting at IETF105.)
> 
> Okay, I’m thinking more in terms of protocol specifications (ie most of IETF’s output) than operational recommendations.  I don’t think I have enough insight into ops to recommend for or against your proposal in that space as long as it’s not assumed to be broadly applicable to IETF as a whole.  
> 
> Or, if you want to recommend that mechanism for IETF-wide use it’s probably going to be a long discussion, with lots of different aspects to be considered.
> 
> Keith
> 
> Sent from my iPhone
>> 
>> On Jul 4, 2019, at 1:48 PM, Job Snijders <[email-masked]> wrote:
>> 
>> I want us to go be able to produce operational guidance how to operate BGP-4 networks at a faster rate than the IETF can review and publish at this point in time. But smaller groups would be able to do it (like the motivated GROW working group) can. If you care about BGP-4 you should join the working group, if you don’t subscribe I will assume you don’t care and won’t either when the IETF side review happens.
>> 
>> We can’t tell people to stop using BGP-4, and we must provide the community with up-to-date information how to operate. We have to share the latest insights.
>> 
>> I don’t get your comments about early deployment, we are already 20 years into the deployment. This also has nothing to do with interopability, because IDR already requires multiple different implementations before a document can proceed to RFC.
>> 
>> I am an operator, I’m a consumer of IETF protocols, I see a gap and would like IETF to address it.
>> 
>> Kind regards,
>> 
>> Job

---

From: Randy Bush <[email-masked]>
Date: Thu, 04 Jul 2019 23:04:05 -0700

>>> I want us to go be able to produce operational guidance how to
>>> operate BGP-4 networks at a faster rate than the IETF can review and
>>> publish at this point in time.

the ops communities have such mechanisms.  the ietf is not the ideal
place to seek operational guidance for bgp networks.

does the ops community want the ietf's imprimatur on an under-reviewed
documents?

randy

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 5 Jul 2019 07:53:11 -0700

> does the ops community want the ietf's imprimatur on an under-reviewed

First, let me say that i am not an operator, so I do not know what
operators need.

With that said, it's not uncommon to see operational guidance published in
ad hoc
forms (see, for instance: https://wiki.mozilla.org/Security/Server_Side_TLS).
Obviously,
the IETF could and does publish this kind of thing (cf. RFC 7525), but
publishing
a new RFC with consensus whenever you want to make a change along these
lines
is pretty heavyweight (which is likely why 7525 is now out of date). So,
it's not clear
to me that the current situation is that ideal.

-Ekr