Subject: Re: New Version Notification for draft-ietf-6man-segment-routing-header-25.txt

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 10 Oct 2019 19:33:33 +0000

This update resolves the remaining Discuss and Comments from the IESG review.  Specifically:

Roman Danyliw (1) - Section 7.1 clarification of source routing attacks.
Ben Kaduk (1) - removed local configuration text from 2.1.2.1 around what the HMAC protects, protect RESERVED bits, added text to programmatically verify destination address.
Ben Kaduk (4) - change the scope of the KEY ID to SR Domain global.
Barry Leiba  - s/register/registry/

Thanks to all the reviewers who have provided valuable comments, and spent time to thoroughly review and work through solutions to the issues they saw.

I believe this is the final draft revision.

Thanks
  Darren

> This update resolves most open discuss and comments raised during IESG last call.
> This update does not resolve discuss items from Ben (1 and 4) and Roman (1).
> Those to be updated in a subsequent revision.

> On Oct 10, 2019, at 3:15 PM, [email-masked] wrote:
> 
> 
> A new version of I-D, draft-ietf-6man-segment-routing-header-25.txt
> has been successfully submitted by Darren Dukes and posted to the
> IETF repository.
> 
> Name:		draft-ietf-6man-segment-routing-header
> Revision:	25
> Title:		IPv6 Segment Routing Header (SRH)
> Document date:	2019-10-10
> Group:		6man
> Pages:		32
> URL:            https://www.ietf.org/internet-drafts/draft-ietf-6man-segment-routing-header-25.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-6man-segment-routing-header/
> Htmlized:       https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header-25
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-6man-segment-routing-header
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-6man-segment-routing-header-25
> 
> Abstract:
>   Segment Routing can be applied to the IPv6 data plane using a new
>   type of Routing Extension Header called the Segment Routing Header.
>   This document describes the Segment Routing Header and how it is used
>   by Segment Routing capable nodes.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Barry Leiba <[email-masked]>
Date: Thu, 10 Oct 2019 21:45:43 +0200

Hi, Darren,

> Barry Leiba  - s/register/registry/

That was a nit, and thanks for correcting it.

But you addressed neither my DISCUSS issue (about the registry policy)
nor my comment (about the fact that "IETF Review" is not defined in
BCP 26).

Barry

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 10 Oct 2019 20:12:25 +0000

Hi Barry, thanks for the fast response!  Please see inline.

On Oct 10, 2019, at 3:45 PM, Barry Leiba <[email-masked]<mailto:[email-masked]>> wrote:

Hi, Darren,

The draft now states the registries are "IETF Review” which is defined in BCP 26, and which you suggested we use in your discuss:
  - "I suggest that you instead go with "IETF Review" and eliminate the need for a designated expert.”

We made that change a couple of revisions ago because many reviewers noted the same thing
I believe I only updated Joe’s thread on the same so I’m not surprised you didn’t notice it yet - sorry for that!

Here is the link to the new text that you and others requested:
https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header-25#section-8.1
https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header-25#section-8.2

Thanks!
  Darren

Barry

---

From: Barry Leiba <[email-masked]>
Date: Thu, 10 Oct 2019 22:34:33 +0200

Sorry, sorry, sorry... I stupidly checked the DIFFs from the previous
version only, and there were multiple updates.  I claim that it's late
and I've had too much Dutch beer.  You're quite right that you have
addressed my comments and my DISCUSS, and I'm off to clear that now.
Thanks for the updates and for your patience with me.

:-O

Barry

On Thu, Oct 10, 2019 at 10:12 PM Darren Dukes (ddukes) <[email-masked]> wrote:
> On Oct 10, 2019, at 3:45 PM, Barry Leiba <[email-masked]> wrote:
>
> Hi, Darren,
>