Subject: A different approach to remote meetings / Mesh videos

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 13 Oct 2019 00:33:13 -0400

The IETF has not changed its meeting format since I attended IETF 34 in
Dallas back in 1995. We have developed much remote presence technology
since. Surely we should start using it.

Do we really need to meet in plenary session three times a year? Is the
model where IETF meeting time is limited to brief status updates and most
of the work is 'taken to the list' optimal ?

Maybe we need to change our existing model or maybe we need to keep it
unchanged and supplement it somehow. Remote meeting attendance is better
than nothing. But does it really help for me to wake up at 2am to listen to
a complex technical talk? Perhaps all meeting at the same time has to be
rethought, not just meeting in the same place.

Perhaps what we could do is to move some of the technical content out of
the meetings altogether and put it up on the Web. To test this theory and
also to promote my efforts to make computers easier to use by making them
more secure, I have begun filming a series of videos explaining the Mesh
technology. These are currently available through the links below and I
will work out some way to distribute the material in a downloadable format
(2k/4K) so people can take them for 'in flight entertainment' on that 24
hour flight to Singapore.

The channel is here:
https://www.youtube.com/channel/UCaWFcKKJOO8KBzvlbdHtK8Q

The material itself is currently unlisted but can be accessed directly from
the links below.

For the purposes of this experiment, the four videos have very different
material:

Mesh 1: The Mesh at 10,000 ft, explains the requirements the project is
designed to address without drilling down into the technical details. It is
the sort of pitch I give to potential investors / stakeholders.
https://youtu.be/pPuV1Wz3CIY

Mesh 2: The Devil is in the Deployment, is not technical at all. It is
explaining just why I think a proposal of this scope it entirely feasible
and describes the strategies I copied from Tim Berners-Lee to get it
deployed.
https://youtu.be/mUoFtxWc28w

Mesh 3: How the Mesh works, is a more technical overview of how the various
parts of the Mesh are designed to work together.  The sort of thing an IAB
plenary tech talk might be. Technical knowledge is assumed but not deep
understanding.
https://youtu.be/mv2edt7HT4g

Mesh 4: Meta-cryptography for key splitting is a graduate level technical
presentation giving material that is not in the cryptography textbooks
(yet). The sort of presentation I might give at MIT CSAIL etc.
https://youtu.be/zY7ygPnpDzk

Given the IETF preference for a minimalist approach to presentation, there
are no PowerPoint slides at all.

The remaining videos will be posted as they are completed, these will
include technical drill downs on each of the three technologies I am
proposing and an explanation of how we can then apply the Mesh to create
novel and interesting security solutions for the Web, SSH, OpenPGP, S/MIME
etc.

The videos will be going out to the public shortly. They are all Creative
Commons with attribution

---

From: Yoav Nir <[email-masked]>
Date: Sun, 13 Oct 2019 08:23:36 +0300

So “Who here has read the drafts” will be replaced by “Who here has watched the videos” ?

Phil, you are really good at public speaking. You make compelling and entertaining videos. Most of us are not able to make videos that good. Additionally, videos are far less interactive than a presentation unless you expect the technical discussion to happen on the youtube comments. Which it totally shouldn’t.

And then there’s the effect of the technical discussion. It’s fairly easy to update slides or drafts. If the group has decided to ditch CBOR in favor of DER, that’s fixing a slide or two plus a paragraph in the draft. The video, you’d probably need to reshoot several minutes of it if you’re good at planning and editing videos, or reshoot the whole thing if you’re not.

While I see the utility of making videos for tutorials, introductions and the like, I don’t see how it meshes (pun intended) with the whole standards-making process.

Yoav

> On 13 Oct 2019, at 7:33, Phillip Hallam-Baker <[email-masked]> wrote:
> 
> The IETF has not changed its meeting format since I attended IETF 34 in Dallas back in 1995. We have developed much remote presence technology since. Surely we should start using it.
> 
> Do we really need to meet in plenary session three times a year? Is the model where IETF meeting time is limited to brief status updates and most of the work is 'taken to the list' optimal ?
> 
> Maybe we need to change our existing model or maybe we need to keep it unchanged and supplement it somehow. Remote meeting attendance is better than nothing. But does it really help for me to wake up at 2am to listen to a complex technical talk? Perhaps all meeting at the same time has to be rethought, not just meeting in the same place.
> 
> Perhaps what we could do is to move some of the technical content out of the meetings altogether and put it up on the Web. To test this theory and also to promote my efforts to make computers easier to use by making them more secure, I have begun filming a series of videos explaining the Mesh technology. These are currently available through the links below and I will work out some way to distribute the material in a downloadable format (2k/4K) so people can take them for 'in flight entertainment' on that 24 hour flight to Singapore.
> 
> The channel is here:
> https://www.youtube.com/channel/UCaWFcKKJOO8KBzvlbdHtK8Q <https://www.youtube.com/channel/UCaWFcKKJOO8KBzvlbdHtK8Q> 
> 
> The material itself is currently unlisted but can be accessed directly from the links below. 
> 
> For the purposes of this experiment, the four videos have very different material:
> 
> Mesh 1: The Mesh at 10,000 ft, explains the requirements the project is designed to address without drilling down into the technical details. It is the sort of pitch I give to potential investors / stakeholders.
> https://youtu.be/pPuV1Wz3CIY <https://youtu.be/pPuV1Wz3CIY>
> 
> Mesh 2: The Devil is in the Deployment, is not technical at all. It is explaining just why I think a proposal of this scope it entirely feasible and describes the strategies I copied from Tim Berners-Lee to get it deployed.
> https://youtu.be/mUoFtxWc28w <https://youtu.be/mUoFtxWc28w>
> 
> Mesh 3: How the Mesh works, is a more technical overview of how the various parts of the Mesh are designed to work together.  The sort of thing an IAB plenary tech talk might be. Technical knowledge is assumed but not deep understanding.
> https://youtu.be/mv2edt7HT4g <https://youtu.be/mv2edt7HT4g>
> 
> Mesh 4: Meta-cryptography for key splitting is a graduate level technical presentation giving material that is not in the cryptography textbooks (yet). The sort of presentation I might give at MIT CSAIL etc. 
> https://youtu.be/zY7ygPnpDzk <https://youtu.be/zY7ygPnpDzk>
> 
> Given the IETF preference for a minimalist approach to presentation, there are no PowerPoint slides at all.
> 
> The remaining videos will be posted as they are completed, these will include technical drill downs on each of the three technologies I am proposing and an explanation of how we can then apply the Mesh to create novel and interesting security solutions for the Web, SSH, OpenPGP, S/MIME etc.
> 
> The videos will be going out to the public shortly. They are all Creative Commons with attribution

---

From: Scott Brim <[email-masked]>
Date: Sun, 13 Oct 2019 12:38:15 -0400

There's a reason why "flipped classroom" teaching strategies have taken
off. They allow better use of face-to-face time.

Once upon a time in IntArea WG we set a policy that nothing should be
brought to the physical meeting unless it had been discussed on the list
and we were clear on the issues that needed f2f discussion. It didn't last
long. People like to talk in person.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 13 Oct 2019 17:42:40 -0400

> So “Who here has read the drafts” will be replaced by “Who here has

Yes!

> Phil, you are really good at public speaking. You make compelling and
> entertaining videos.
>

Thanks.

> Most of us are not able to make videos that good.
>

People can hire me to make their videos for them... ?

> Additionally, videos are far less interactive than a presentation unless
> you expect the technical discussion to happen on the youtube comments.
> Which it totally shouldn’t.
>

The primary purpose of these videos is recruitment of people, businesses,
stakeholders, etc. to work on the Mesh. Hence the choice of YouTube as the
venue.

I don't propose to use YouTube long term, or at least not in its current
form. One option is to wrap YouTube with a separate comment forum. That
means we can still make use of all the really cool YouTube features like
transcripts and speeding up or slowing down the videos.

Long term, I want everything, *everything* end-to-end secure. I want all
the data on the Web server encrypted including the comments and no way that
a breach of the key service causes disclosure of the contents. So we will
be building a comment forum anyway for confidential and classified
application. Think, discussion on a response to an RFP or discussion of a
security breach with law enforcement and/or counter-intelligence sitting in.

> And then there’s the effect of the technical discussion. It’s fairly easy
> to update slides or drafts. If the group has decided to ditch CBOR in favor
> of DER, that’s fixing a slide or two plus a paragraph in the draft. The
> video, you’d probably need to reshoot several minutes of it if you’re good
> at planning and editing videos, or reshoot the whole thing if you’re not.
>

It might well be that the scheme works best for what I am using it for
which is a green field site proposal. I am asking the question 'how would
we build a user centric PKI with no legacy commitments at all'. So I have
to start with a presentation of a lot of new stuff.

The more usual standards issue is, 'how do we add feature X to the existing
systems'. And that is actually harder technically. Particularly if it
involves SMTP or DNS which have severe legacy deployment expectations and
constraints.

> off. They allow better use of face-to-face time.

That is the idea of course, work the issues list. Spend more time in
discussion and less in information transfer.

> long. People like to talk in person.

There is always the problem that often folk don't realize what the issues
are until the meeting starts. Which is what the discussions are often
about.