Subject: IETF principles on open access

From: John Mattsson <[email-masked]>
Date: Wed, 2 Oct 2019 08:11:13 +0000

What is IESG's plan for the statement discussed on the wgchairs list?

https://mailarchive.ietf.org/arch/msg/wgchairs/baCQkc6fIkja4z705-E2NG6bUvs

The initial mail mentioned the date 2019/06/26. There are a lot of very good comments in this thread and I assume IESG will come with an updated statement at some point. It is great that IESG is thinking about this. The proposed statement is a big step in the right direction.

I think this is a bigger topic than processes, this is about fundamental principles of the IEFT.  I think IETF should have as a principle that people should be able to implement and analyze IETF standards without being limited by paywalls and other restrictions by the party hosting the specification. For specifications that includes security of any kind (which nowadays is most RFCs), open access is even more important as history has showed over and over again that lack of analysis often lead to serious weaknesses.

I agree with earlier comments in the thread that also informal references SHOULD be open access. For normative references, I do not think it is enough that nobody in the WG objects. I think authors should have to show that there is no other reasonable solution other that referencing documents with restricted access. The more IETF is fighting for open access, the more documents will be open access.

I would like to see the IESG make a bold statement embracing open access.

John

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 2 Oct 2019 11:24:36 +0200

Le 02/10/2019 à 10:11, John Mattsson a écrit :
>  The initial mail mentioned the date 2019/06/26. There are a lot of
> very good comments in this thread and I assume IESG will come with an
> updated statement at some point. It is great that IESG is thinking
> about this. The proposed statement is a big step in the right
> direction.
> 
> I think this is a bigger topic than processes, this is about
> fundamental principles of the IEFT.  I think IETF should have as a
> principle that people should be able to implement and analyze IETF
> standards without being limited by paywalls

I agree.

I would like to add:

Paywall is not the right term.  The best term is 'easiness of access',
or similar.

There are many specs, (e.g. IEEE specs), who dont require one to pay -
so the access can be considered as 'free' as in 'gratuitous', or 'zero
thalers and zero dollars'.  Yet they require to agree to some
conditions, give some private data (name, location) and worse of all: it
requires to spend a lot of time to click at left and at right, reply to
confirmation emails, to understand what's going on: it is Difficult access.

The specs must not only be concise, readable and coherent in themselves
but their presentation too must be attractive, easily accessible,
discutable, so programmers pick them among the plethora available, and
implement them.

Alex

Alex

  and other restrictions by
> the party hosting the specification. For specifications that includes
> security of any kind (which nowadays is most RFCs), open access is
> even more important as history has showed over and over again that
> lack of analysis often lead to serious weaknesses.
> 
> I agree with earlier comments in the thread that also informal
> references SHOULD be open access. For normative references, I do not
> think it is enough that nobody in the WG objects. I think authors
> should have to show that there is no other reasonable solution other
> that referencing documents with restricted access. The more IETF is
> fighting for open access, the more documents will be open access.
>