Subject: Re: IETF 107 Standard Registration and Internet Draft Deadline Approaching

From: Jay Daley <[email-masked]>
Date: Fri, 6 Mar 2020 15:03:03 +1300

Randy

>> On 6/03/2020, at 2:40 PM, Randy Bush <[email-masked]> wrote:
> 
>> 
>> One thing that becomes obvious while serving in the IETF leadership is
>> that no-win situations are unavoidable. If you try to make decisions
>> based on objective criteria and take your time to gather data, you get
>> criticized.  If you try to make decisions based on anecdotal evidence
>> or take what seems to be the path of least resistance, you get
>> criticized.  If you follow the advice of one group of participants,
>> you get criticized by a different group that disagrees. It can seem
>> like an endless, thankless torrent of messages telling you that no
>> matter what you do, it’s wrong and it isn’t good enough.
> 
> i hope and presume you are not surprised by this.  it is just part of
> life in leadership roles.

There is a big difference between people asking questions, making recommendations, providing alternative analysis, challenging decisions, etc and impugning motives, deliberately misrepresenting people/processes, plain insults, etc. The former is perfectly acceptable, the latter is never acceptable. 

Yes the former is something we sign up for but it doesn’t take much of the latter to poison the atmosphere. 

>  [ not so much in management roles, where
> blame shifting and avoidance of black marks plays a large role. ] which
> is why one does one's best to do what one perceives as the right thing,
> motivate it well, and then get on with life and the inevitable next
> pile.

I prefer to aim for a more positive culture both by the way I contribute and by what I expect of others. The culture of an organisation is set by the worst behaviour people are willing to expect. 

Jay

-- 
Jay Daley
IETF Executive Director

> randy

---

From: Larry Masinter <[email-masked]>
Date: Thu, 5 Mar 2020 22:38:31 -0800

The ancient greeks invented https://en.wikipedia.org/wiki/Ad_hominem and indeed it should be “unacceptable” in that those arguments should not be accepted.

Whether or not the source or target of their claims are working group participants or part of the management.

--

LarryMasinter.net

---

From: Keith Moore <[email-masked]>
Date: Fri, 6 Mar 2020 16:27:14 -0500

I want to state at the outset that this message is about organizational 
culture in general and not about anyone in particular in the past or 
present.

On 3/5/20 9:03 PM, Jay Daley wrote:

> I prefer to aim for a more positive culture both by the way I 
> contribute and by what I expect of others. The culture of an 
> organisation is set by the worst behaviour people are willing to expect.

I would state your sentence differently - the behavior of those who 
control an organization, in the long term, approaches the worst behavior 
that the community is willing to tolerate.   This is because there will 
always be pressures on the leaders that tempt them to "bend the rules", 
and has nothing to do with the specific people who are in charge.

The problem with a "more positive" culture (if by that you mean one in 
which it's considered inappropriate to ask questions or air concerns), 
is that a lack of transparency is the perfect incubator for 
corruption.   There is perhaps some room for fine-tuning, but it is not 
possible to have the best of both worlds.

I would say that a positive culture for an organization like IETF is one 
in which every contributor has reason to believe that their 
contributions will be evaluated fairly and openly, and in which there is 
no reason to suspect that anyone is putting a thumb on the scale to 
favor one contribution over another for reasons other than technical 
suitability.

But those conditions absolutely require transparency, even at the 
expense of some discomfort.

Keith

---

From: Jay Daley <[email-masked]>
Date: Sat, 7 Mar 2020 11:06:42 +1300

Keith

> On 7/03/2020, at 10:27 AM, Keith Moore <[email-masked]> wrote:
> 
> I want to state at the outset that this message is about organizational culture in general and not about anyone in particular in the past or present.

Thanks. I found this very helpful. 

>> I prefer to aim for a more positive culture both by the way I contribute and by what I expect of others. The culture of an organisation is set by the worst behaviour people are willing to expect.

I meant to write ‘accept’ there not ‘expect’ so sorry for any confusion. 
> 
> I would state your sentence differently - the behavior of those who control an organization, in the long term, approaches the worst behavior that the community is willing to tolerate. 

I don’t agree that is inevitable. There are plenty of people out there, both in leadership positions and not, who have a strong moral compass or some other strong personal limiter and so will not bend.  That is not to say that I think safeguards should not be in place to prevent this - they should. 

The behaviour of leadership, while important, is not the sole issue - it is the behaviour of *all* of us that is important as we are all important in this community. Overly focusing  on leadership ignores the power of individual community members to set the culture of the organisation. 

>   This is because there will always be pressures on the leaders that tempt them to "bend the rules", and has nothing to do with the specific people who are in charge.
> 
> The problem with a "more positive" culture (if by that you mean one in which it's considered inappropriate to ask questions or air concerns)

I am not sure that I could have made it any clearer that is not what I meant. I’m quite happy to state it again that I think it is perfectly acceptable (the same words I used before) for people to ask questions or raise concerns. 

> , is that a lack of transparency is the perfect incubator for corruption.

I absolutely agree with that. Before taking this role my consultancy business focused mainly on open data. 

>    There is perhaps some room for fine-tuning, but it is not possible to have the best of both worlds.

You’re implying a dichotomy there that I don’t see or understand. 

> I would say that a positive culture for an organization like IETF is one in which every contributor has reason to believe that their contributions will be evaluated fairly and openly, and in which there is no reason to suspect that anyone is putting a thumb on the scale to favor one contribution over another for reasons other than technical suitability.

I completely agree as I explained above. I would add though “no *reasonable* reason to suspect” as paranoia or personal distrust also need to be mitigated against. 

> But those conditions absolutely require transparency, even at the expense of some discomfort.

I fully agree. One of the reasons I took this role is because of the embedded principle of transparency and the commitment of the LLC board to look at new ways of making things even more transparent. 

— 
Jay Daley 
IETF Executive Director

---

From: S Moonesamy <[email-masked]>
Date: Fri, 06 Mar 2020 16:56:09 -0800

Hello,
At 02:06 PM 06-03-2020, Jay Daley wrote:
> > I want to state at the outset that this message is about 
> organizational culture in general and not about anyone in 
> particular in the past or present.
>

Yes.

>I don't agree that is inevitable. There are plenty of people out 
>there, both in leadership positions and not, who have a strong moral 
>compass or some other strong personal limiter and so will not 
>bend.  That is not to say that I think safeguards should not be in 
>place to prevent this - they should.
>
>The behaviour of leadership, while important, is not the sole issue 
>- it is the behaviour of *all* of us that is important as we are all 
>important in this community. Overly focusing  on leadership ignores 
>the power of individual community members to set the culture of the 
>organisation.

The position(s) taken "at the top" provides an impetus.  There are 
other factors.  For example is there a culture of accountability 
within the organization?

The power of the individual depends on the rights of the 
individual.  Using the word "positive" may be viewed as another way 
of recommending against exercising those rights.  At the end of the 
day it is about institutional trust.

Regards,
S. Moonesamy

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 9 Mar 2020 01:36:46 +0100

> There is a big difference between people asking questions, making recommendations, providing alternative analysis, challenging decisions, etc and impugning motives, deliberately misrepresenting peo…

Luckily, i am not aware of any intentional cases of this, but maybe i am
also only living under a rock. But of course agreed.

I would like to two more observations:

In general, even a technial, well intentioned discuss can turn into
something perceived to be unfriendly enough that collaboration
diminishes, and i think that may be a more common issue in IETF
than you what you describe.

(1) Most compromises IMHO are found much easier in person in a setting
where there is also no third party present to whom one or both sides
would want to pander to. This type of "small hallway" discussion is
already absent from some conflicts i observe, and of course it will
be worse when we have more and more remote-only attendance and Email-only discuss.

IMHO, "rough consensus" is necessary, but not sufficient. For those cases
where i see this issue i wonder if the folks did try to pick up at least a phone to
talk to each other or discuss the conflict in PM.

(2) Community discussions should follow best protocol interop principles:
Be strict on what you send, and loose on what you accept. If you
send something thats goes beyond technical and could be perceived
personal or otherwise non-technical, that is worth an excuse, but
it is IMHO equally bad if the receipient uses that language to 
shame the sender publically and use this as an escape not to tckle
the technical issue. The best solution for these issues is again (IMHO)
PM or audio channel without a third party to pander to.

Cheers
    Toerless

---

From: Keith Moore <[email-masked]>
Date: Sun, 8 Mar 2020 22:04:12 -0400

> I don’t agree that is inevitable. There are plenty of people out there, both in leadership positions and not, who have a strong moral compass or some other strong personal limiter and so will not b…
(Again, I'm not talking about any specific persons here.)

Even people with strong moral compasses will occasionally "bend".   
Those with weaker moral compasses will "bend" more often.   Some people 
will not even see the same decisions as having a moral or ethical 
consideration.

People with more political skill may be able to negotiate better 
compromises than those with less skill.   If those with such skill are 
also wise and well-intended, that's great.   But sometimes politically 
skilled and/or well-intended people make unfortunate decisions, as we 
all do.

Individuals also have personal biases which may affect their decision 
making, in ways that are not well-aligned with IETF's goals.  Sincere 
and thoughtful opinions can differ about that alignment.

All of these factors are always present to varying degrees. Over time,  
the mistakes tend to accumulate, as unfortunate decisions made in the 
past become used as justifications to demand additional unfortunate 
decisions.   It is _very_ difficult for even the best-intentioned, 
wisest, and most politically skilled persons to buck that trend.

It would be extremely unwise for IETF to adopt an organizational culture 
that presumes we can always have leaders with strong moral compasses, 
considerable political skill, wisdom, good intentions, and no harmful 
biases.   We have generally been fortunate, I believe, in often having 
very good leaders.   But we should know better than to presume we will 
always be so fortunate.

That's why IETF's organizational culture needs to be one that is both 
crafted and maintained by the whole community, not dictated by its 
leaders.   And that's just one reason why IETF's expectations for 
behavior between contributors (and leaders are also contributors) need 
to favor openness and transparency.

But back to a statement you made in a note to Randy Bush:

> There is a big difference between people asking questions, making 
> recommendations, providing alternative analysis, challenging 
> decisions, etc and impugning motives, deliberately misrepresenting 
> people/processes, plain insults, etc. The former is perfectly 
> acceptable, the latter is never acceptable.

I am largely in agreement with this statement (and have used similar 
words myself).   I certainly don't find personal insults acceptable.   
When someone misrepresents a person or a process, my general assumption 
is that it's more likely to be a misunderstanding than deliberate.  (But 
deliberate misrepresentations do sometimes occur. )

I also agree that it's not appropriate to impugn others' motives - at 
least not without citing supporting evidence and even then it should be 
done only as a last resort.    But we should not be so naive as to 
assume that people never have inappropriate motives. The problems I have 
with such accusations are: (a) it's very easy to misunderstand someone 
else's motive and for the accusation to simply be wrong; and (b) 
discussions about motive almost always serve as distractions from 
development of better technical solutions.   So at least in most IETF 
contexts, it seems better to try to keep the discussion in the technical 
realm.   For instance, if a proposal is motivated by a desire to use the 
standards process to gain an unfair technical advantage over 
competitors, it almost always will do some harm to Internet users - and 
that harm may be easier to demonstrate than the motive.

But sometimes inappropriate motive does rear its ugly head.   IMO 
current IETF processes are not well-designed to deal with these cases, 
but I'm not sure what remedy to recommend.

Where you and I might disagree is in use of the word "positive" to 
describe the culture that is needed.   For IETF to function well, it is 
essential to have technical disagreements and criticism of technical 
proposals.   These disagreements and criticism are often unpleasant, 
because the process of examining potential flaws in one's own proposals 
is itself unpleasant.   The process is unpleasant even if everyone is 
being respectful, so it's not a surprise if discussions sometimes get 
heated.   But it's only by exposing such flaws that we can fix them, or 
discard proposals that can't be fixed.   And many people understand that 
it's more important to ultimately get good results than to have their 
own proposals win.   It's even possible to be happy that someone else 
has found a better way, and good engineers know that.

I've also seen cases (both inside and outside of IETF) in which a demand 
for positivity has been deliberately used to suppress input that those 
in leadership positions didn't want to have aired.

Bottom line: I believe that for IETF to be able to do its job well, 
transparency must be more important than a vague notion of positivity.   
Or, to put it differently, I prefer to emphasize a different kind of 
positivity:  I believe we as a community should commit ourselves to 
producing solutions of benefit for a broad spectrum of Internet users, 
and our norms of interacting among ourselves should be defined in 
furtherance of that purpose.

Keith

---

From: Jay Daley <[email-masked]>
Date: Mon, 9 Mar 2020 15:56:20 +1300

Keith

Again thanks for that.

> On 9/03/2020, at 3:04 PM, Keith Moore <[email-masked]> wrote:
> 
> Even people with strong moral compasses will occasionally "bend".   Those with weaker moral compasses will "bend" more often.   Some people will not even see the same decisions as having a moral or ethical consideration.
> 
> People with more political skill may be able to negotiate better compromises than those with less skill.   If those with such skill are also wise and well-intended, that's great.   But sometimes politically skilled and/or well-intended people make unfortunate decisions, as we all do.
> 
> Individuals also have personal biases which may affect their decision making, in ways that are not well-aligned with IETF's goals.  Sincere and thoughtful opinions can differ about that alignment.
> 
> All of these factors are always present to varying degrees. Over time,  the mistakes tend to accumulate, as unfortunate decisions made in the past become used as justifications to demand additional unfortunate decisions.   It is _very_ difficult for even the best-intentioned, wisest, and most politically skilled persons to buck that trend.
> 
> It would be extremely unwise for IETF to adopt an organizational culture that presumes we can always have leaders with strong moral compasses, considerable political skill, wisdom, good intentions, and no harmful biases.   We have generally been fortunate, I believe, in often having very good leaders.   But we should know better than to presume we will always be so fortunate.
> 
> That's why IETF's organizational culture needs to be one that is both crafted and maintained by the whole community, not dictated by its leaders.   And that's just one reason why IETF's expectations for behavior between contributors (and leaders are also contributors) need to favor openness and transparency.

I fully agree and if I’ve said anything that suggests I feel otherwise then please let me know.   Of course, in case it’s not clear, my part in that is limited to the LLC and our interactions and the policies we set for ourselves and contractors.

> I am largely in agreement with this statement (and have used similar words myself).   I certainly don't find personal insults acceptable.   When someone misrepresents a person or a process, my general assumption is that it's more likely to be a misunderstanding than deliberate.  (But deliberate misrepresentations do sometimes occur. )
> 
> I also agree that it's not appropriate to impugn others' motives - at least not without citing supporting evidence and even then it should be done only as a last resort.    But we should not be so naive as to assume that people never have inappropriate motives. The problems I have with such accusations are: (a) it's very easy to misunderstand someone else's motive and for the accusation to simply be wrong; and (b) discussions about motive almost always serve as distractions from development of better technical solutions.   So at least in most IETF contexts, it seems better to try to keep the discussion in the technical realm.   For instance, if a proposal is motivated by a desire to use the standards process to gain an unfair technical advantage over competitors, it almost always will do some harm to Internet users - and that harm may be easier to demonstrate than the motive.
> 
> But sometimes inappropriate motive does rear its ugly head.   IMO current IETF processes are not well-designed to deal with these cases, but I'm not sure what remedy to recommend.
> 
> 
> Where you and I might disagree is in use of the word "positive" to describe the culture that is needed.   For IETF to function well, it is essential to have technical disagreements and criticism of technical proposals.   These disagreements and criticism are often unpleasant, because the process of examining potential flaws in one's own proposals is itself unpleasant.   The process is unpleasant even if everyone is being respectful, so it's not a surprise if discussions sometimes get heated.   But it's only by exposing such flaws that we can fix them, or discard proposals that can't be fixed.   And many people understand that it's more important to ultimately get good results than to have their own proposals win.   It's even possible to be happy that someone else has found a better way, and good engineers know that.
> 
> I've also seen cases (both inside and outside of IETF) in which a demand for positivity has been deliberately used to suppress input that those in leadership positions didn't want to have aired.
> 
> Bottom line: I believe that for IETF to be able to do its job well, transparency must be more important than a vague notion of positivity.   Or, to put it differently, I prefer to emphasize a different kind of positivity:  I believe we as a community should commit ourselves to producing solutions of benefit for a broad spectrum of Internet users, and our norms of interacting among ourselves should be defined in furtherance of that purpose.

I also regard transparency as absolutely critical.  What I am talking about is just how much more can be achieved if positivity is added to that.  So not a choice between the two, but the combination of the two.

The best way I can explain the difference in our views here is to ask you to visualise or recall a process where everyone involved had confidence that everyone else wanted a positive outcome (perhaps 'win-win' is a better phrase) and where everyone was able to put their ego aside and not think of an idea as their own proposal, but just one possible way of many.   When that level is reached then neither 'robust' nor 'unpleasant' seem appropriate descriptions.

Analogous to your explanation that a moral compass without safeguards behind it has an inherent risk of broken behaviour, my view is that safeguards alone without a very clear desire/aim to take things to that level also has an inherent risk of broken behaviour. 

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]
+64 21 678840

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 10 Mar 2020 18:52:02 +0100

On Sun, Mar 08, 2020 at 10:04:12PM -0400, Keith Moore wrote:
> For instance, if a proposal is
> motivated by a desire to use the standards process to gain an unfair
> technical advantage over competitors, it almost always will do some harm to
> Internet users - and that harm may be easier to demonstrate than the motive.

I think this argument works only in simple, "evil" cases.
In reality today, i observe quite the opposite: 

I think one can understand the competitive grounding of a lot of technical
positions and in many cases, proponent can be quite open about it (*).

Where we do get problem is when the "harm to the internet user"
argument is (IMHO) intelligently "abused". Especially when in one
option the harm comes through a particular standard and then the
opposing option takes that harm out of the standard but creates
more harm outside of the scope that the IETF can influence and
reduces the business of the opposing option that maybe ultimately
would have greated more ability for the IETF to limit and control 
the harm.

> But sometimes inappropriate motive does rear its ugly head.

> IMO current IETF processes are not well-designed to deal with these cases, but I'm not
> sure what remedy to recommend.

In the cases i am thinking of, the best solution may be not to permit
only one standard enforced by the side that manages to engineer the
rough mayority, but also for the otherwise oppressed rough minority.
Aka: loosen up on the ability of a rough mayority to inhibit options
that do not serve their commercial interests.

> I've also seen cases (both inside and outside of IETF) in which a demand for
> positivity has been deliberately used to suppress input that those in
> leadership positions didn't want to have aired.

Something like you pick the one word in an opposing view that can be misconstrued
to be marginally offensive or rude and then you shift the discussion to
one of pure language, not answering to the technical concern ?

That is at least what i have seen happening, and only in one
case i remember did this result in some serious backslash, aka: we are
IMHO definitely living in a time of PC language as a weapon).

> transparency must be more important than a vague notion of positivity.

Indeed. Here was my personal (*) example how one can be open
about commercial positions:

In Multicast we have this complex protocol IGMPv3 (2000). 10 years
later a new company and propose a simplified version. Whereupon
i stood up in WG and said that this may be technically interesting,
but creates even more new work for companies that have implemented
the complex version, and makes only market entrance for new companies
easer, effectively shifting the cost away from the proponents to their
competitors. 

I have seen very little open discussion about commercial positions
though over the years, i think more would be helpfull.

Cheers
    Toerless

---

From: Keith Moore <[email-masked]>
Date: Tue, 10 Mar 2020 14:03:17 -0400

> positions and in many cases, proponent can be quite open about it (*).
I do see this sometimes.  But I have also seen cases in which one party 
basically attempts a DoS attack against a proposal, doing their best to 
thwart consensus by any means available, and doesn't offer any 
constructive path forward.
> one of pure language, not answering to the technical concern ?
I have seen precisely that tactic used to sabotage a proposal.
> IMHO definitely living in a time of PC language as a weapon).
Indeed.
> though over the years, i think more would be helpfull.
I agree that it can help to understand these incentives and barriers to 
adoption of proposals, though I realize that practically speaking this 
may not always be possible.

Keith