Subject: Re: Make an all-virtual IETF meeting a 24 hour affair

From: Fred Baker <[email-masked]>
Date: Mon, 2 Mar 2020 14:36:28 -0800

> On Feb 27, 2020, at 6:57 AM, Thomas Fossati <[email-masked]> wrote:
> 
> On Thu, Feb 27, 2020 at 2:32 PM Vittorio Bertola
> <vittorio.bertola=[email-masked]> wrote:
>> Il 27/02/2020 14:06 Andrew G. Malis <[email-masked]> ha scritto:
>> But people that have to attend multiple WGs that meet on the same day would potentially have to stay up for 24 hours, if each of those WGs chose a different timezone. I think this would be even worse, and it would make it hard to pop into WGs that you do not normally follow, which is one of the added values of IETF meetings.
> 
> Just a thought: in a fully virtual scenario there is no need to keep
> all the meetings within the current 4.5 days wide slot.

True, but only works if participants only participate in IETF. For me, that would be a non-starter.

---

From: John C Klensin <[email-masked]>
Date: Mon, 02 Mar 2020 19:50:18 -0500

--On Thursday, February 27, 2020 15:57 +0100 Robert Raszuk
<[email-masked]> wrote:

>> But people that have to attend multiple WGs that meet on the
>> same day
> 
> Who says that virtual meetings must be contained to all happen
> in 5 days ? If you extend it to say 1 month everyone can
> easily attend those he pays attention to without any burden or
> stretch. 5 day IETF sessions are mainly due to local logistics
> which are all gone with moving to virtual reality.

At least for those of us who have responsibilities other than
IETF, it sounds like a complete disaster.   Even for those who
could take a month off for IETF work more or less exclusively,
there are benefits from going to a meeting --virtual or f2f--
and then having time to let idea sink in, comment on mailing
lists, write documents, etc.  

Just my opinion, of course,
   john

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 2 Mar 2020 20:39:04 -0700

> On Feb 27, 2020, at 6:06 AM, Andrew G. Malis <[email-masked]> wrote:
> 
> the WG chairs choose, for each WG, what time out of the 24-hour clock works for the majority of their active participants

I just want to point out one other issue in with this type of algorithm. When you do this for a given WG, you often get a time that is after 8 am pacific time and before early evening in Europe as that is simply the distribution of participants in many WGs. If, for every meeting, you always use this algorithm, you always get a time that is really bad for Asia. That does not seem fair and even if you don’t care about fair, it does not seem like an optimal outcome for the internet. I don’t think that anyone wants an algorithm that selects meetings that are always convenient for silicon valley at the cost of never being convenient for Asia. 

It’s really hard to decide what is it we are trying to optimize when choosing meetings. For a bunch of the WebRTC meeting we tried to place them in the location or times where the frequency of how often the meeting was convenient for users in region X was roughly proportional to the number of participants from region X.

---

From: Christian Huitema <[email-masked]>
Date: Mon, 2 Mar 2020 19:58:01 -0800

What we did for the IAB meetings was compute the minimax, i.e. the time that minimized the pain for the worst hit attendee. In fact pick two such times, one for winter and one for summer, to spread the pain.

-- Christian Huitema 

> On Mar 2, 2020, at 7:39 PM, Cullen Jennings <[email-masked]> wrote:
> 
> 
>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 03 Mar 2020 09:31:19 -0500

Cullen Jennings <[email-masked]> wrote:
    > I just want to point out one other issue in with this type of
    > algorithm. When you do this for a given WG, you often get a time that
    > is after 8 am pacific time and before early evening in Europe as that
    > is simply the distribution of participants in many WGs. If, for every
    > meeting, you always use this algorithm, you always get a time that is
    > really bad for Asia. That does not seem fair and even if you don’t care
    > about fair, it does not seem like an optimal outcome for the
    > internet. I don’t think that anyone wants an algorithm that selects
    > meetings that are always convenient for silicon valley at the cost of
    > never being convenient for Asia.

I agree that this happens.

    > It’s really hard to decide what is it we are trying to optimize when
    > choosing meetings. For a bunch of the WebRTC meeting we tried to place
    > them in the location or times where the frequency of how often the
    > meeting was convenient for users in region X was roughly proportional
    > to the number of participants from region X.

Part of the challenge is that there is effectively nobody (except Brian
Carpenter!) living in the 8 hours/timezones between China and San Francisco,
so "night" almost always winds up in the pacific.  So, if we could just move
a couple of extra million people (including a thousand IETFs) to New Zealand...
Or Google's  Syndey office.

So we need a variation of the doodle poll, where we simply ask what your time
zone is.  Maybe we could actually just pull that out of mailing list
headers.  Hmm.  There is some bias there, but it might be a good bias (post
more, and you'll get it at a better time?), or it might wind up as a
self-selecting bias (since the time always sucks, you never get involved, and
thus never post).

But, I agree with making the pain shared.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Jen Linkova <[email-masked]>
Date: Wed, 4 Mar 2020 09:51:25 +1100

> Carpenter!) living in the 8 hours/timezones between China and San Francisco,

eeeeexcuse me.....;)

> Or Google's  Syndey office.

It's a bit late, summer is almost over...

> zone is.

It's entirely possible to reach a rough consensus on a timeslot for a
single meeting, so everyone will be equally unhappy.
However I'm not sure how this approach would work for multiple working
groups, when a chair of one WG is an active participant/presenter in
another.
We can solve this problem with computers indeed but it does not look easy.

> Maybe we could actually just pull that out of mailing list
> more, and you'll get it at a better time?),

There are some security considerations...
;)

-- 
SY, Jen Linkova aka Furry

---

From: Wes Hardaker <[email-masked]>
Date: Fri, 06 Mar 2020 09:59:54 -0800

Kent Watsen <[email-masked]> writes:

> 1b) the presentation should have "pause points" where feedback is
> being solicited.

Hi Kent,

I love your write up and it's much more detailed than the similar idea I
presented at a hotrfc about a year ago.  My thought was to make all
WG meetings a full week long with a similar 'mic queue' formed via
video/audio/whatever chats spread out as well.  I love your idea of
pause points above, which is something I hadn't considered for the
presentation side of things.  Note that there is nothing stopping a WG
from having multiple topic presentations happening at the same time
too...

The one idea I talked about that isn't in your list, that you may want
to consider, is a rate-limit for the number of comments you can say in
24 hours (2? 3?).  My thinking was that we needed to avoid the "oh my,
look how much mail arrived while I was sleeping because a topic blew up,
and now its too late to insert my points" problem.  This, combined with
the simul-track of every presentation and every wg should bring us close
to the number of comments you can reasonably make at mic lines during a
physical WG meeting.
-- 
Wes Hardaker
USC/ISI

---

From: Kent Watsen <[email-masked]>
Date: Fri, 6 Mar 2020 20:58:00 +0000

Hi Wes,

> too…

Cool beans.  I’ve gotten positive feedback offline as well.

The “pause point” idea could take various forms...

A simple implementation would have no break in the presentation video
as the author simply says “please provided questions, comments,
concerns to this item via ’topic #N’, whereas the system then maintains
an list of comments, order by time entered, by anyone, including the 
presenter, whose response could be a mutli-response (i.e., addressing
the collective of comments in one go).

A more complex implementation would instead arrange the responses
Into a hierarchical tree, effectively mimicking threading.  The launch-
point for each pause point could be like one of those on-screen link
boxes seen on many YouTube videos.   A hierarchical tree of responses
should provide better topic focus, but may make cross-referencing
things said in another branch awkward.

> to the number of comments you can reasonably make at mic lines during a

Agreed, there should be something equivalent to cutting off the mic
queue.  Again, the goal is to bound the wall-clock time for the entire
session to roughly what exists today.   Here are some thoughts:

1) while your concern might occur, I question how often it would occur.
This might be something worth deferring creating a policy for until after
more information is known...

2) one idea to suppress "reply-storms” might be to limit each participant
to single response per day, or at least until the presenter has had a
chance to reply to it.  Another idea might be to hide "audience” 
responses from others until after the presenter has had a chance to
reply.  Care should be taken, though, as these might have a negative
dampening effect on the velocity of idea exchange.

Kent

---

From: Eric Gray <[email-masked]>
Date: Mon, 9 Mar 2020 13:11:33 +0000

I agree that mixing meetings where you have to travel with neighboring meetings where you have to accommodate a TZ shift is a hard problem.

And it is made much worse if there is a lot of each.  For folks that have to maintain a reasonably constant meal schedule, this means finding the time to work out a meal schedule that may have to include scheduling weeks in advance (which precludes preparing meals in advance).

Unfortunately, I am not seeing a choice in this case...

-----Original Message-----
From: ietf <[email-masked]> On Behalf Of Joel M. Halpern
Sent: Thursday, February 27, 2020 10:17 AM
To: Stewart Bryant <[email-masked]>
Cc: IETF Discussion <[email-masked]>
Subject: Re: Make an all-virtual IETF meeting a 24 hour affair

It really is different than traveling.  I have been trying to figure out a simpler case, where I have already shifted my time by traveling, then am going home and attending a remote meeting in the time zone where I was.  Even for that, trying to figure out when and I how I will eat and sleep is complicated.  And that is with my family being very supportive.

Yours,
Joel

On 2/27/2020 10:09 AM, Stewart Bryant wrote:
> 
> 
>> On 27 Feb 2020, at 13:06, Andrew G. Malis <[email-masked]> wrote:
>>
>> There have been a number of comments that an all-virtual IETF meeting would be difficult for some set of attendees due to time zone shifting while they're in their home time zone. While it's impossible to hold a particular WG session that works for ALL attendees around the world, let the WG chairs choose, for each WG, what time out of the 24-hour clock works for the majority of their active participants. It'll be up to the WG chairs to figure that out for each WG, with the approval of the relevant AD. But there's no reason why all of the WGs need to meet during the same "daylight" hours if the meeting is all virtual. WGs could also have multiple sessions optimized for different parts of the world, to spread the pain. Just a thought ....
>>
>> Cheers,
>> Andy
>>
> 
> That is not a good idea.
> 
> Different WGs would pick different “day” times making it difficult to attend multiple groups.
> 
> A better idea is to shift your day to whatever TZ is proposed for the meeting as a whole. That will be no different from what you have to do when travelling, with the advantage of no dehydration and no time lost at the airport.
> 
> - Stewart
> 
>