Subject: Re: Why are Cloudflare checking my browser?

From: Tim Chown <[email-masked]>
Date: Sun, 1 Mar 2020 13:09:35 +0000

On 28 Feb 2020, at 16:10, Christopher Morrow <[email-masked]> wrote:
> 
> This has been in place on the IETF site for ~4 yrs at this point.
> welcome to the party! :)

But it’s only recently that it’s doing it so much.  Used to be very rare, now I see it most visits.  Very irritating.

There’s also shenanigans on the mail list signup pages where you have to fill the form in slowly now (with a somewhat cryptic warning to do so if you do it too fast), and failures due to “IP mismatches” on the form pages.

Tim

---

From: Warren Kumari <[email-masked]>
Date: Sun, 1 Mar 2020 08:28:45 -0500

On Sun, Mar 1, 2020 at 8:09 AM Tim Chown <[email-masked]> wrote:

> But it’s only recently that it’s doing it so much.  Used to be very rare,
> now I see it most visits.  Very irritating.

Oh, are you perhaps blocking or clearing cookies? If you have and present a
cookie I believe this is much less likely to occur - you’ve “proven” your
existence / behavior.

I *think* that there is also a decision based on how likely a visit from
your IP / subnet / ASN is likely to be a DoS / malicious.
The feedback loop *seems* relatively fast - I arrive at the IETF hotel
almost a week early because I’m part of the NOC team. Because the week
before the meeting is busy, and I’m an AD, I spend a fair bit of time using
the hotel network - and there *seems* to be a correlation. The first N
times I use the hotel network to access DT it looks anomalous and I’m more
likely to get the interstitial, but this decreases over time. This could
also be an illusion - I use multiple devices (laptop, phone, tablets, etc)
and it could just be once per device and I’m not correcting for that in my
perception.

W

>
> There’s also shenanigans on the mail list signup pages where you have to
> fill the form in slowly now (with a somewhat cryptic warning to do so if
> you do it too fast), and failures due to “IP mismatches” on the form pages.
>
> Tim
>
-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sun, 1 Mar 2020 09:10:12 -0500

John,

https://support.cloudflare.com/hc/en-us/articles/115002059131 gives you
more details on what Cloudflare is doing.

Cheers,
Andy

On Thu, Feb 27, 2020 at 5:27 AM John Dickinson <[email-masked]> wrote:

> Hi,
>
> Maybe I missed an announcement but please could someone explain why I am
> seeing:
>
> Checking your browser before accessing ietf.org.
>
> This process is automatic. Your browser will redirect to your requested
> content shortly.
> Please allow up to 5 seconds…
> DDoS protection by Cloudflare
> Ray ID: 56b9671cdc01e608
>
> whilst going to an ietf mailman page?
>
> What is Cloudflare checking for? What is Cloudflare’s privacy policy
> for this “service”?
>
> BTW the link
> https://www.cloudflare.com/5xx-error-landing?utm_source=iuam shown as
> the text “DDoS protection by Cloudflare” doesn’t provide any
> explanation.
>
> regards
> John
>
>
> John Dickinson
>
> https://sinodun.com
>
> Sinodun Internet Technologies Ltd.
> Magdalen Centre
> Oxford Science Park
> Robert Robinson Avenue
> Oxford OX4 4GA
> U.K.
>
>