Subject: Free (as in beer) webex

From: Cullen Jennings <[email-masked]>
Date: Mon, 2 Mar 2020 19:00:33 -0700

Just as bit of information for folks about a change in Webex …

One of the concerns in the past has been access to local dial in numbers and cost of Webex. Due to COVID-19 situation, during this time, Cisco is making webex free for most places it operates and for meetings up to 100 people. You can find more details and the fine print at 

https://blog.webex.com/video-conferencing/cisco-webex-supporting-customers-during-this-unprecedented-time/

The WebRTC version of webex works in my favorite browsers so no need to install anything proprietary. 

Webex is preparing to add multiple billions of minutes of month more of capacity to the existing billions of minutes it currently sees (yah cloud and thanks to whoever designed this scaleable internet thing ). 

I’m only providing this updated information as this tool is often used by IETF WGs. I’m perfectly happy if the IETF chooses to use hangouts, or zoom, or MS Teams, meet echo, or whatever you like - I am only providing some info about the greatly expanded ability to use a tool we often use. If you find this free tool helpful, great, if you do not, please forgive me for adding one more unhelpful message to this, uh words fail me, mailing list.

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 3 Mar 2020 14:19:14 +0100

[the announcement relayed is worth noting, because it seems this 
manufacturer makes free an otherwise paid access to webex, during these 
times of virus with a crown]

[this is probably better discussed on the 'manycouches' email list, 
which is more focused on the aspects of remote attendance]

Le 03/03/2020 à 03:00, Cullen Jennings a écrit :
> One of the concerns in the past has been access to local dial in
> numbers and cost of Webex. Due to COVID-19 situation, during this
> time, Cisco is making webex free for most places it operates and for
> meetings up to 100 people. You can find more details and the fine
> print at
> 
> Webex is preparing to add multiple billions of minutes of month more
> of capacity to the existing billions of minutes it currently sees
> (yah cloud and thanks to whoever designed this scaleable internet
> thing ).
> 
> I’m only providing this updated information as this tool is often
> used by IETF WGs. I’m perfectly happy if the IETF chooses to use
> hangouts, or zoom, or MS Teams, meet echo, or whatever you like

Me too I am happy about these tools in general.

In particular I am unhappy with some aspects of them.

One aspect that is important to me, happened last time I tried to attend 
remotely: I was told that I needed to register to the meeting prior to 
joining a meeting.

I find it unnecessary to register prior to joining a meeting.  When I 
participate in other meetings (elsewhere than at IETF) I am provided 
with an URL, I click on it, and there I am in the meeting.  I do not 
need to register, and even less to pay.

The technical reasons I was given for this necessity to register relates 
to analysis to understand the participant origin and behaviour 
(available publicly at 
https://www.ietf.org/about/administration/reports/).  It is 
understandable, but it might happen in a simpler manner - request the 
participants to type in their names, origins etc at the moment of 
joining (e.g. webex as a pre-filled field of 20 characters or so that 
contains my name, I could put there just the initials, some country 
code, etc.)

If, on the other hand, the reason of need registration prior to 
attending has to do with payment, then we're on a totally different 
discussion.  That too might be addressed; and now, in this time of virus 
with a crown, in a different manner.

> - I
> am only providing some info about the greatly expanded ability to use
> a tool we often use. If you find this free tool helpful, great, if
> you do not, please forgive me for adding one more unhelpful message
> to this, uh words fail me, mailing list.

This makes me think why not trying this tool during some of the meetings.

Alex

---

From: Michael Richardson <[email-masked]>
Date: Tue, 03 Mar 2020 09:19:35 -0500

> install anything proprietary.

Unless you are logged in, in which case it insists that you use the javaws
version and/or it tells you that your browser is unsupported.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Sarah Banks <[email-masked]>
Date: Tue, 3 Mar 2020 16:10:57 -0800

Hi,
	Thanks for the note and thanks to Cisco for the community service - it's useful, good to know, and I appreciate you letting ietf@ know.

	(No, I don't work for Cisco. No, I'm not buying you beer. But I thought someone should say thanks!)

/S

> On Mar 2, 2020, at 6:00 PM, Cullen Jennings <[email-masked]> wrote:
> 
>

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 4 Mar 2020 03:35:23 +0100

+1

IMHO: The blog entries by Cisco as well as of competitors like zoom
or goto-meeting are interesting to read not only to find free services,
but also to learn more about the increase/change of use of conferencing
due to CoVid-1.

Wrt. client side integration: Given how WebRTC communications uses
the IETF rtcweb WG standards, it certainly makes sense for
IETF'ler to try it (own dog food...). AFAIK, all the web conferencing
vendors support it now. Most newer market competitors may not even have
a native client options anymore.

Mileage if its better than "native" clients will of course vary,
but in my experience the RTCweb option is often also a great fallback
when some native client option does not work because of incompatibilities
of OS (e.g.: linux), OS-versions, audio/video I/O or the like.
I use it regularily with zoom and webex. 

On Tue, Mar 03, 2020 at 04:10:57PM -0800, Sarah Banks wrote:
> > Just as bit of information for folks about a change in Webex ???
> > 
> > I???m only providing this updated information as this tool is often used by IETF WGs. I???m perfectly happy if the IETF chooses to use hangouts, or zoom, or MS Teams, meet echo, or whatever you like - I am only providing some info about the greatly expanded ability to use a tool we often use. If you find this free tool helpful, great, if you do not, please forgive me for adding one more unhelpful message to this, uh words fail me, mailing list. 
> > 

-- 
---
[email-masked]

---

From: Larry Masinter <[email-masked]>
Date: Tue, 3 Mar 2020 20:07:04 -0800

https://etherpad.ietf.org:9009/p/ManyCouches

 I thought the whole point of WebRTC was to get rid of need
for native clients of need for conferencing vendors (or at least
 those who could charge per-minute.)

> -----Original Message-----
> From: ietf <[email-masked]> On Behalf Of Toerless Eckert
> Sent: Tuesday, March 3, 2020 6:35 PM
> To: Sarah Banks <[email-masked]>
> Cc: IETF Free Beer <[email-masked]>; Cullen Jennings <[email-masked]>
> Subject: Re: Free (as in beer) webex
> 
> +1
> 
> IMHO: The blog entries by Cisco as well as of competitors like zoom or
goto-
> meeting are interesting to read not only to find free services, but also
to
> learn more about the increase/change of use of conferencing due to CoVid-
> 1.
> 
> Wrt. client side integration: Given how WebRTC communications uses the
> IETF rtcweb WG standards, it certainly makes sense for IETF'ler to try it
> (own dog food...). AFAIK, all the web conferencing vendors support it now.
> Most newer market competitors may not even have a native client options
> anymore.
> 
> Mileage if its better than "native" clients will of course vary, but in my
> experience the RTCweb option is often also a great fallback when some
> native client option does not work because of incompatibilities of OS
(e.g.:
> linux), OS-versions, audio/video I/O or the like.
> > 	Thanks for the note and thanks to Cisco for the community service -
> it's useful, good to know, and I appreciate you letting ietf@ know.
> >
of
> capacity to the existing billions of minutes it currently sees (yah cloud
and
> thanks to whoever designed this scaleable internet thing ).
> > >
> > > I???m only providing this updated information as this tool is often
used
> by IETF WGs. I???m perfectly happy if the IETF chooses to use hangouts, or
> zoom, or MS Teams, meet echo, or whatever you like - I am only providing
> some info about the greatly expanded ability to use a tool we often use.
If
> you find this free tool helpful, great, if you do not, please forgive me
for
> adding one more unhelpful message to this, uh words fail me, mailing list.
> > >
> 
> --
> ---
> [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 4 Mar 2020 06:50:22 +0100

On 2020-03-04, at 03:35, Toerless Eckert <[email-masked]> wrote:
> zoom

Known malware provider.
Can’t be used by anyone security conscious.
Too bad, because they got a lot of things right.

Grüße, Carsten

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 4 Mar 2020 02:03:40 -0500

>  those who could charge per-minute.)

It is relatively easy to get 2 person communications working peer-peer
'most of the time'. All you need to work out is the NAT traversal.

But NAT traversal isn't going to be 100% reliable and when you get to a
group call, you really have to make use of some sort of reflector service.
And video is quite a bit of bandwidth, especially if you have lots of
people.

My complaint is that these are not end-to-end secure.

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 4 Mar 2020 09:06:23 +0100

Oh nice... a guessing game. 

This one ?

https://www.wired.com/story/zoom-bug-webcam-hackers/

Does not apply to me. I always change zoom URLs so they will
only start the zoom javascript webrtc client instead of the native one.

More trust into the constrained execution environment
of javascript on my browsers than against networked native
MacOS/Windows code.

Also tape over my camera by default.

That issue is not "malware provider" to me, its 
"malware friendly" or more topical "anti-vax".
Stupid and dangerous, but not evil.

Cheers
   Toerless

On Wed, Mar 04, 2020 at 06:50:22AM +0100, Carsten Bormann wrote:
> Can???t be used by anyone security conscious.

-- 
---
[email-masked]

---

From: Larry Masinter <[email-masked]>
Date: Wed, 4 Mar 2020 00:12:50 -0800

Dogfooding (https://en.wikipedia.org/wiki/Eating_your_own_dog_food)

only helps if there’s commitment to improve the product (WebRTC)

From: Phillip Hallam-Baker <[email-masked]> 
Sent: Tuesday, March 3, 2020 11:04 PM
To: Larry Masinter <[email-masked]>
Cc: Toerless Eckert <[email-masked]>; Sarah Banks <[email-masked]>; IETF Free Beer <[email-masked]>; Cullen Jennings <[email-masked]>
Subject: Re: Free (as in beer) webex

On Tue, Mar 3, 2020 at 11:07 PM Larry Masinter < <mailto:[email-masked]> [email-masked]> wrote:

It is relatively easy to get 2 person communications working peer-peer 'most of the time'. All you need to work out is the NAT traversal.

But NAT traversal isn't going to be 100% reliable and when you get to a group call, you really have to make use of some sort of reflector service. And video is quite a bit of bandwidth, especially if you have lots of people.

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 4 Mar 2020 09:43:20 +0100

On Wed, Mar 04, 2020 at 02:03:40AM -0500, Phillip Hallam-Baker wrote:
> But NAT traversal isn't going to be 100% reliable

WebRTC protocols rely on the BEHAVE standards for NAT traversal 
and that already allows for it to be more flexible to get across
NAT than solutions that would e.g.: rely on TCP connections.

> and when you get to a

I don't think the NAT traversal issue changes dramatically whether you
have p2p or multipoint sessions.

Its true that you want to have a reflector/mixer to optimize bandwidth
utilization when all your transport is unicast. Alas WebRTC WG was
not interest to add support for IP multicast, or else it could have
offloaded large-group communications first to AMT relays and not bother
whether or when native IP multicast would be adopted. Water under a very
long and annoying bridge of IETF and IP multicast. But each WG is only
representing the interests of the parties creating rough consensus in
it.

> My complaint is that these are not end-to-end secure.

You just need a design where the reflector/mixer (WebRTC server) is
included in the group trust of the other endpoints. Typically the
organizer/initiator of a multi-party call should be able to decide
on a trustworthy WebRTC service. If not, then such an
organizer/initiator should set up its own WebRTC server.

IMHO this is not a workaround, but an intrinsic result of the desire/
benefits of being able to process/mix media in a bandwidth/latency
optimized location which typically can not be any of the client
endpoints.

Cheers
    Toerless

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 4 Mar 2020 10:36:37 +0100

> but also to learn more about the increase/change of use of conferencing

What is D in CoVid?

Alex

---

From: Loa Andersson <[email-masked]>
Date: Wed, 4 Mar 2020 17:45:57 +0800

Alex.

>> but also to learn more about the increase/change of use of conferencing

I think it is

Corona Virus Disease 2019 (COVID-19)

/Loa
>>>     Thanks for the note and thanks to Cisco for the community service 
>>> - it's useful, good to know, and I appreciate you letting ietf@ know.
>>>
>>>> used by IETF WGs. I???m perfectly happy if the IETF chooses to use 
>>>> hangouts, or zoom, or MS Teams, meet echo, or whatever you like - I 
>>>> am only providing some info about the greatly expanded ability to 
>>>> use a tool we often use. If you find this free tool helpful, great, 
>>>> if you do not, please forgive me for adding one more unhelpful 
>>>> message to this, uh words fail me, mailing list.
>>>>
>>
> 

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert
Bronze Dragon Consulting             phone: +46 739 81 21 64

---

From: Matthew Kerwin <[email-masked]>
Date: Wed, 4 Mar 2020 19:46:39 +1000

>From a unicef website:

"coronavirus disease 2019 (COVID-19) – ‘CO’ stands for corona, ‘VI’
for virus, and ‘D’ for disease"

https://www.unicef.org/indonesia/coronavirus

Cheers
-- 
  Matthew Kerwin
  https://matthew.kerwin.net.au/

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 4 Mar 2020 11:09:25 +0100

On 2020-03-04, at 09:06, Toerless Eckert <[email-masked]> wrote:
> not evil

Totally evil.  Corporate suicide level evil.
https://en.wikipedia.org/wiki/Eternal_sin level.

https://www.schneier.com/blog/archives/2019/07/zoom_vulnerabil.html

The problem was not that they had a backdoor (which is seriously bad already, but don’t we all have vulns).
The problem was that they pretended to have fixed it and then kept a hidden backdoor that allowed them to re-install their software surreptitiously while the computer owner thought they had uninstalled it.
We had to wait for Apple to release an OS fix that silently removed the zoom bridgehead.

You don’t do that and ever expect to be accepted back into the community.

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 4 Mar 2020 11:09:41 +0100

> > but also to learn more about the increase/change of use of conferencing

https://en.wikipedia.org/wiki/Coronavirus_disease_2019#Terminology

Disease

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 4 Mar 2020 11:33:25 +0100

> https://en.wikipedia.org/wiki/Coronavirus_disease_2019#Terminology

A nice example for how to completely mess up in choosing terminology.

Calling the thing nCoV-2019 first, and then trying to establish the completely diverging pair of COVID-19 as the name of the disease and SARS-CoV-2 as the name for its cause is something the IETF could have done.

Result: 
https://xkcd.com/2275/
https://empirenews.net/parent-company-of-corona-beer-sues-china-over-bad-press-during-their-coronavirus-scare/

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 4 Mar 2020 11:39:36 +0100

Thanks for the explanation.

I don't really want to speak out for or against zoom, as i don't really care
that much. I was more interested in having a bit of fun in a nerd
conversation about appropriate use of terminology here, but the list is
a bit too large to continue that branch of the thread. Hope we can continue
in person @IETF107, CoVid-19 permitting.

Cheers
    Toerless

On Wed, Mar 04, 2020 at 11:09:25AM +0100, Carsten Bormann wrote:
> The problem was not that they had a backdoor (which is seriously bad already, but don???t we all have vulns).
> You don???t do that and ever expect to be accepted back into the community.
> 
> Grüße, Carsten

---

From: Kathleen Moriarty <[email-masked]>
Date: Wed, 4 Mar 2020 11:31:02 -0500

Thanks, Cullen and Cisco!  This is useful and if school/daycares shut down,
a free option like this will come in handy for my son's daycare to run
circle time and keep up the kids Spanish.  It may only be for a short
period of time daily, but this could be a very helpful option to keep some
sense of normalcy for them and to see their friends/teachers.

Best regards,
Kathleen

Top posting as this is back on topic.

On Wed, Mar 4, 2020 at 5:40 AM Toerless Eckert <[email-masked]> wrote:

> > The problem was that they pretended to have fixed it and then kept a
> hidden backdoor that allowed them to re-install their software
> surreptitiously while the computer owner thought they had uninstalled it.

-- 

Best regards,
Kathleen

---

From: Sean Turner <[email-masked]>
Date: Wed, 4 Mar 2020 12:17:07 -0500

> On Mar 4, 2020, at 11:31, Kathleen Moriarty <[email-masked]> wrote:
> 
> Thanks, Cullen and Cisco!

This! Thanks.

spt

---

From: "S. Moonesamy" <[email-masked]>
Date: Wed, 04 Mar 2020 09:53:30 -0800

Dear Carsten,
At 02:09 AM 04-03-2020, Carsten Bormann wrote:
>The problem was not that they had a backdoor (which is seriously bad 
>already, but don't we all have vulns).

I could not use WebEx due to a DNS issue.  There isn't any dial-in 
coverage for my location.  I looked at the updated country list.  It 
only covers one country in Africa.

I share the concern which you mentioned above.  I ended up having to 
use Zoom.  I am aware that it does not work reliably in some 
countries.  The dial-in coverage is also not adequate.

Regards,
S. Moonesamy

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 4 Mar 2020 17:39:40 -0500

> NAT than solutions that would e.g.: rely on TCP connections.

BEHAVE works if the NAT implements it. Otherwise, not. A reflector in the
cloud is a sure bet.

Maybe we are getting to 100%. But remote meeting technology is still
sufficiently twitchy for it to be an issue. VOIP does seem to have crossed
that hurdle though.

> representing the interests of the parties creating rough consensus in

I did think of a different way to do multicast stacking multiple IP headers
on a single frame and then bursting where the ASNs diverge but it puts a
lot of complexity into the network.

> organizer/initiator should set up its own WebRTC server.

No, you do not get to call your system end-to-end secure by defining the
cloud as an endpoint.

> optimized location which typically can not be any of the client

Most client drops have far more spare upload bandwidth than download. So I
disagree with the last assertion.

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 5 Mar 2020 20:29:09 +0100

I don't quite think [email-masked] is the right mailing list for these
technical discussions, but i think better understanding of
conferencing is quite useful if we actually want to make progress
with going more virtual in IETF.

So, for the time being, i'll Bcc: ietc and add [email-masked],
if there is a better mailing list pls. let me know.

> sufficiently twitchy for it to be an issue. VOIP does seem to have crossed

Actually, i think RTCweb will have less problems with NAT than SIP.

SIP was based on the silly connotation that you wanted to have
competition between alternative components of a communications solution,
such as separately picking server and picking endpoints, maybe even
from different companies. This meant you had to understand SIP
parameters, maybe even third-party STUN/TURN servers, and the user 
likely has to figure out the semantics of strange SIP parameters.
And a lot of available services for SIP date back so long, that they
do not support IPv6.

In RTCweb the model is that of complete walled garden end-to-end
solutions, servers and (javascript) clients from the same vendor,
all just using standardized comm & ww protocols. This takes out a
lot of interop problems and customer based solution stitching. 
I hope i don't need to start listing all the downsides of this approach.

For example, i was extremely frustrated and gave up on SIP to my
mobile phone: My DSL contract SIP only supports IPv4, my mobile
network only IPv6 APN, and now try to figure out which of the
10 SIP parameters in the client might make 464XLAT work. I think
there is actually a broken 464XLAT implementation in my android,
but i wouldn't know how to even figure out if that is google or
phone vendor code.

Never had problems with RTCweb on phones. Of course, the GUIs
are often useless, so i do of course hate the whole vertical
integration approach of RTCweb solutions (can't pick the client
of my dreams), but thats a different story.

Bigger corporate solutions of course do support 3rd prty endpoint
interop because RTCweb, but those are integrated via SIP and
that means quite limited conferencing "metadata" services.

Cheers
    Toerless