Subject: videoconference technology challenge: choral rehearsals

From: Randy Presuhn <[email-masked]>
Date: Wed, 18 Mar 2020 11:22:21 -0700

Hi -

Looking for videoconference technology that would support:
    - a conference with a single host and up to, say, 120 participants
    - only the host needs to have their video image distributed
    - the audio from the host and all participants must be mixed and
      distributed to all with good synchronization with respect to the
      host video and minimal delay
   - on occasion, the host might mute the other participants,  but
     normally all would be on.
    - ideally, the sound mixing could happen in smaller sub-groups
      (perhaps up to 12, but at least 8 (bass, baritone, tenor 2, tenor 1,
      alto 2, alto 1, soprano2, soprano 1) so that the audio delivered
      to a particular subgroup could be either the "hall" experience
      (what the conductor hears) or with the subgroup boosted to
      reflect what the participant would hear in a physical rehearsal.

Is there anything out there?

Randy

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 18 Mar 2020 15:02:43 -0600

> On Mar 18, 2020, at 12:22 PM, Randy Presuhn <[email-masked]> wrote:
> 
> Hi -
> 

That would be cool. The mainstream systems don’t support that because the noise floor gets so high as you start mixing lots of participants but some universities have experimented with simular things. Google Stanford Laptop Orchestra.

---

From: Ole Jacobsen <[email-masked]>
Date: Wed, 18 Mar 2020 14:10:42 -0700

I don’t know the details, but check out Eric Whitacre:

https://ericwhitacre.com/the-virtual-choir/about

and

https://www.youtube.com/watch?v=vGngoGvOSuY#t=280

> On 18 Mar 2020, at 14:02, Cullen Jennings <[email-masked]> wrote:
> 
> 
> 

Ole J. Jacobsen
Editor and Publisher
The Internet Protocol Journal
Office: +1 415-550-9433
Cell:   +1 415-370-4628
Web: protocoljournal.org
E-mail: [email-masked]
E-mail: [email-masked]
Skype: organdemo

---

From: Randy Presuhn <[email-masked]>
Date: Wed, 18 Mar 2020 14:32:17 -0700

Hi -

On 3/18/2020 2:02 PM, Cullen Jennings wrote:
...
> That would be cool. The mainstream systems don’t support that because the noise floor gets so high as you start mixing lots of participants but some universities have experimented with simular thin…

Thanks.
Totally not my field, but...
I think the concern about the noise floor makes sense if  one were trying
to get good fidelity for a soloist.  But in the normal use case for a 
choral rehearsal,
unlike the business meeting scenarios that seem to predominate, most of 
the time
at least 10%, and more likely 75-100% of the participants would be 
singing, so there'd
an awful lot of signal atop whatever the noise floor added up to. 
(Another reason
why I think it might make sense to pre-process the divisi separately.)  
Plus, if one is
used to performing with an orchestra, one learns to filter out an awful 
lot of noise
while taking all the timing cues from the conductor.  :-)

Randy

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 19 Mar 2020 02:08:27 +0100

Hmm... 130 orchestra members, each in their own home, good
microphones, good headsets. Audio from all members 
gets centrally mixed and sent back to members. Likewise
composer video. I wouldn't be worried about sound floor,
a bit of adaptive mixing should well be able to take care of that.

Depending on distance, I would be worried about latency.
Differential latency is likely a big killer, but also absolute.

There are i think a bunch of those remote orchestra experiments,
but i have not seen good quantitative number about its impact
(differential/absolute).

There was a nice exhibition 2? years ago at SF MOMA of a (prerecorded) 
small 6..8? people orchestra doing this gig within a larger home, each
in a different room. Would love to put a configurable latency mixer
into such a setup and see what happens when i play with latency and
jitter ;-)

Toerless

On Wed, Mar 18, 2020 at 02:32:17PM -0700, Randy Presuhn wrote:
> ....
> > That would be cool. The mainstream systems don???t support that because the noise floor gets so high as you start mixing lots of participants but some universities have experimented with simular things. Google Stanford Laptop Orchestra.
> 
> Thanks.
> to get good fidelity for a soloist.  But in the normal use case for a choral
> rehearsal,
> unlike the business meeting scenarios that seem to predominate, most of the
> time
> at least 10%, and more likely 75-100% of the participants would be singing,
> so there'd
> an awful lot of signal atop whatever the noise floor added up to. (Another
> reason
> used to performing with an orchestra, one learns to filter out an awful lot
> of noise

-- 
---
[email-masked]

---

From: Larry Masinter <[email-masked]>
Date: Wed, 18 Mar 2020 19:27:46 -0700

Wouldn't the latency for  the group be the latency od  slowest group member?
I thought the latency of a single hop for a single wireless mic or headset
exceeds the maximum tolerable. 

> -----Original Message-----
> From: ietf <[email-masked]> On Behalf Of Toerless Eckert
> Sent: Wednesday, March 18, 2020 6:08 PM
> To: Randy Presuhn <[email-masked]>
> Cc: [email-masked]
> Subject: Re: videoconference technology challenge: choral rehearsals
> 
> microphones, good headsets. Audio from all members gets centrally mixed
> and sent back to members. Likewise composer video. I wouldn't be worried
> about sound floor, a bit of adaptive mixing should well be able to take
care
> of that.
> There are i think a bunch of those remote orchestra experiments, but i
have
> not seen good quantitative number about its impact
(differential/absolute).
> small 6..8? people orchestra doing this gig within a larger home, each in
a
> different room. Would love to put a configurable latency mixer into such a
> setup and see what happens when i play with latency and jitter ;-)
> 
> Toerless
> 
> > > That would be cool. The mainstream systems don???t support that
> because the noise floor gets so high as you start mixing lots of
participants
> but some universities have experimented with simular things. Google
> Stanford Laptop Orchestra.
> >
> > Thanks.
> > I think the concern about the noise floor makes sense if  one were
> > trying to get good fidelity for a soloist.  But in the normal use case
> > for a choral rehearsal, unlike the business meeting scenarios that
> > seem to predominate, most of the time at least 10%, and more likely
> > 75-100% of the participants would be singing, so there'd an awful lot
> > of signal atop whatever the noise floor added up to. (Another reason
> > Plus, if one is used to performing with an orchestra, one learns to
> > filter out an awful lot of noise while taking all the timing cues from
> > the conductor.  :-)
> >
> > Randy
> 
> --
> ---
> [email-masked]