Subject: Re: [Rfced-future] Eliot Lear to Serve as RFC Editor Future Development Program Chair

From: Eliot Lear <[email-masked]>
Date: Wed, 25 Mar 2020 20:54:54 +0100

Hi!

We’ll kick things off after folk have had an opportunity to get onto the mailing list, figure by Monday or so.  Have a great rest of the virtual IETF.

Eliot

> On 25 Mar 2020, at 18:50, IAB Executive Administrative Manager <[email-masked]> wrote:
> 
> The IAB has selected Eliot Lear to serve as chair of the RFC Editor 
> Future Development Program [1].
> 
> The IAB thanks all of the candidates who were willing to serve. This was 
> a difficult decision with many strong candidates.
> 
> Like an IETF working group, this program will have completely open 
> participation. The program will use the mailing list 
> [email-masked]. To subscribe, please go to 
> <https://www.iab.org/mailman/listinfo/rfced-future>.
> 
> Future details about the operation of the program will be coming 
> shortly.
> 
> [1] https://www.iab.org/activities/programs/rfc-editor-future-development-program/
> 
> -- 
> Rfced-future mailing list
> [email-masked]
> https://www.iab.org/mailman/listinfo/rfced-future

---

From: Michael StJohns <[email-masked]>
Date: Wed, 25 Mar 2020 16:46:20 -0400

On 3/25/2020 1:50 PM, IAB Executive Administrative Manager wrote:
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

To satisfy my curiosity - could the IAB give us some idea of its 
thinking in selecting Eliot?

While I appreciate Eliot's attributes, I would have thought Neville - 
who has substantial experience as the ISE, or John - who was a 
substantial contributor to the original process that led to us hiring 
Heather or some combination of the two* would have been a slam dunk 
choice.   I may not have all the details on Eliot's experience related 
to editing and publication.

*AIRC, there was substantial desire expressed by the community for this 
program to be led by co-chairs rather than a single person.

Feel free to take this as a question (perhaps the first question) for 
the Plenary.

Mike

---

From: Michael StJohns <[email-masked]>
Date: Wed, 25 Mar 2020 16:48:01 -0400

On 3/25/2020 4:46 PM, Michael StJohns wrote:
>> [1] 
>> https://www.iab.org/activities/programs/rfc-editor-future-development-program/
>>
> *AIRC, there was substantial desire expressed by the community for 
> this program to be led by co-chairs rather than a single person.
>
Sorry - one last question.  Which IAB selected Eliot?  The Incoming one 
or the outgoing one?

Thanks - Mike

---

From: Ted Hardie <[email-masked]>
Date: Wed, 25 Mar 2020 15:30:04 -0700

Hi Mike,

> thinking in selecting Eliot?
The IAB followed the same process it uses for many appointments:  it
solicited volunteers (and then extended the deadline for volunteers), asked
them for statements of interests, in some cases held conversations with
them, and solicited comments from the community.  The details of that
community feedback and those discussions with the candidates are
confidential, as are most personnel discussions.

> program to be led by co-chairs rather than a single person

This selection was made by the outgoing IAB (
https://www.iab.org/documents/minutes/minutes-2020/iab-minutes-2020-03-04/).
The next IAB may decide that a second chair selection round would be
useful, and there has some discussion among the large group (outgoing,
ongoing, and incoming) on that point.

> Feel free to take this as a question (perhaps the first question) for
regards,

Ted Hardie

---

From: Michael StJohns <[email-masked]>
Date: Wed, 25 Mar 2020 18:48:03 -0400

See below.

On 3/25/2020 6:30 PM, Ted Hardie wrote:
> Hi Mike,
>
> On Wed, Mar 25, 2020 at 1:47 PM Michael StJohns <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
> solicited volunteers (and then extended the deadline for volunteers), 
> asked them for statements of interests, in some cases held 
> conversations with them, and solicited comments from the community.  
> The details of that community feedback and those discussions with the 
> candidates are confidential, as are most personnel discussions.

Let's stay away from "personnel" discussions (and I'm not really sure 
this qualifies as such - but we'll go with that for now), and instead go 
to what should be public information:

1) What experience in Publishing and Editing does Eliot bring to the table?

2) Why didn't you appoint co-chairs as appeared to be the community 
desire?    I can see at least two reasons to do so: a) To spread the 
load and ensure the program is successful, and b) to provide for more 
than one point of view in the chair position. This is a question 
irrespective of the "personnel" discussion of who you might appoint.  
E.g. tell me the things that argued against appointing multiple people?

Later, Mike

>     this
> This selection was made by the outgoing IAB 
> (https://www.iab.org/documents/minutes/minutes-2020/iab-minutes-2020-03-04/).

---

From: Leif Johansson <[email-masked]>
Date: Thu, 26 Mar 2020 09:12:12 +0100

>>     Feel free to take this as a question (perhaps the first question) for

For those who couldn't stay up for the plenary... was this discussed last night?

	Cheers Leif

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 26 Mar 2020 13:46:31 +0000

>    For those who couldn't stay up for the plenary... was this discussed last night?
  
No.

---

From: Jari Arkko <[email-masked]>
Date: Sat, 28 Mar 2020 01:03:24 +0200

Mike,

We didn’t get to discuss this on voice in the plenary. But the process is as Ted outlined it; call for volunteers for a task, written & interview interaction, community feedback, IAB consideration and then selection. I don’t think we should go into specific questions about particular persons and selections. I will say that we were of course lucky with excellent volunteers and we’re very happy to have Eliot serve. 

I personally see the role of chairing this program as primarily focused on managing this discussion and helping the group come to consensus. As the program is an open program, I’d love to see participation of all those in the community who have background in publishing and editing.

The new IAB will continue to discuss and be actively engaged with the group as it is starting up, and can certainly decide to appoint a co-chair. The IAB has made no decision against multiple chairs of the group going forward, and input on this is appreciated.

Jari (just speaking for myself)

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 28 Mar 2020 13:43:50 +1300

Jari, and the current IAB (all of whom are, I presume, on this list),

Thanks for the clarification. But I think it's *essential* to have co-chairs in this case, since any plausible chair for this topic is bound to have some definite opinions and that makes fair chairing very difficult. This has nothing to do with the choice of Eliot.

It was however explicit in the preceding discussions *and* in the IAB's call for nominations:

https://mailarchive.ietf.org/arch/msg/ietf/RSM0PyZ0CERQswyZ3CakuH8BT0k/

Regards
   Brian

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 28 Mar 2020 01:20:04 +0000

>    https://mailarchive.ietf.org/arch/msg/ietf/RSM0PyZ0CERQswyZ3CakuH8BT0k/

Yeah, seems like something (someone?) slipped through the cracks here.

---

From: Eliot Lear <[email-masked]>
Date: Sat, 28 Mar 2020 12:06:50 +0100

[Sorry- I meant to send this publicly earlier].

Hi Brian,

> On 28 Mar 2020, at 01:43, Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 

I agree it is important to have a co-chair, but not for that reason.  We should have another chair for institutional reasons (like if I get sick; not an unheard of possibility, given Switzerland’s circumstances).  I also want the IAB to have the opportunity to easily replace me if they decide they don’t like how I am performing.  But my position is that the board should find the right second chair, and not just fill a seat.  If the right person comes along tomorrow, great.  If it takes a little time, let it.  You’ll prefer the results.

Do I have opinions about the role of RFC Editor?  Of course I do. I am a longstanding member of this community, I’ve served on the IAB, and as you will see from last year’s discussion, my opinions are on record.  Are they strongly held?   As part of this process I had to ask myself that very question, and delayed putting my name into the hat so I could search how I felt.

How the RFC Editor role is structured is not something about which I have strong opinions.  In fact I strongly believe that a great many others such as yourself have far better grounded opinions on the role than I do!  I have faith that the participants in the effort that will kick off on Monday will conscientiously draw out the issues that need to be addressed, decide which issues don’t need to be addressed, come up with approaches for the ones that do, and come to consensus.

But I do have an agenda.  It is to see that both this process and its subsequent implementation be a positive experiences for the community and those who work for us.  That’s all.

Eliot

---

From: Wes Hardaker <[email-masked]>
Date: Mon, 30 Mar 2020 12:48:20 -0700

Brian E Carpenter <[email-masked]> writes:

> Thanks for the clarification. But I think it's *essential* to have
> co-chairs in this case, since any plausible chair for this topic is
> bound to have some definite opinions and that makes fair chairing very
> difficult. This has nothing to do with the choice of Eliot.

Speaking entirely from a <nohats> point of view: I agree with you, and
others, completely that the program should have two chairs.  I think the
community entirely agrees with this perspective, and I'll certainly do
my part to make this happen.

-- 
Wes Hardaker
USC/ISI

---

From: Michael StJohns <[email-masked]>
Date: Mon, 30 Mar 2020 16:37:32 -0400

> my part to make this happen.
Given that you were part of the outgoing IAB as well as the incoming 
one, can you give us some insight as to why that didn't happen already?

(And thanks for getting the Liaisons appointed)

Mike

---

From: Wes Hardaker <[email-masked]>
Date: Mon, 30 Mar 2020 13:47:15 -0700

> one, can you give us some insight as to why that didn't happen

I'm afraid that conversation was in executive session, and it would not
be prudent of my to share any discussions related to the final decision.

Personally, I'm actually happy that we only appointed one chair, but
probably not for the reason you think: this way, with the large turn
over of IAB members, it turns out that the incoming IAB members will
have a voice in potentially selecting a second chair.
 
-- 
Wes Hardaker
USC/ISI

---

From: Michael StJohns <[email-masked]>
Date: Mon, 30 Mar 2020 17:16:12 -0400

> be prudent of my to share any discussions related to the final decision.
*sigh* Let me try this again.   Per community discussion and announced 
intent the IAB should have come back with 2 or 3 chairs, or it should 
have re-opened the call for chairs.  Neither of these happened.  What 
caused that IAB to fail to follow the rules - again?
> have a voice in potentially selecting a second chair.

I don't mean to pick on you, but this seems to be retconning [1] what 
actually happened.  If this was the intent of the IAB, then it should 
have been announced and action taken transparently.

Seriously, if this is a mistake, say "oops", apologize and explain what 
actions are being taken to fix the problem.

Mike

[1] https://www.google.com/search?q=retcon

---

From: Mirja Kuehlewind <[email-masked]>
Date: Mon, 30 Mar 2020 23:50:14 +0200

Hi Brian, hi Rich,

Thanks for your feedback. The IAB is planning to consider the appointment of a second chair in the coming months. At the moment we see it as most important to have a venue to develop proposals for discussion, and the IAB liaisons will logically support Elliot, if and whenever needed, to get the work started as soon as possible.

Best,
Mirja

---

From: John C Klensin <[email-masked]>
Date: Tue, 31 Mar 2020 00:58:53 -0400

Wes,

I trust Mike's reading of the advice/instructions from the
community to the IAB and what the IAB agreed to do (and then
didn't) more than mine, but I think your note raises a few extra
issues that may be worth identifying.

--On Monday, March 30, 2020 13:47 -0700 Wes Hardaker
<[email-masked]> wrote:

>> Given that you were part of the outgoing IAB as well as the
>> incoming one, can you give us some insight as to why that
>> didn't happen already?
> 
> I'm afraid that conversation was in executive session, and it
> would not be prudent of my to share any discussions related to
> the final decision.

Unfortunately, part of what got us into the present situation
--one in which we are, perhaps, trying to have a discussion of
the future of the RFC Series and the RFC Editor Function and
doing so without the guidance and input from an experienced
RSE-- involved the IAB using the executive session mechanism to
exclude Heather from discussions of the Series that might
reasonably have been expected to affect her. From the
perspective of a former IAB member and chair, I think the IAB
has an obligation to be as open and transparent as possible
about its discussions, decisions, and the reasons for them and
that implies that executive sessions should be used rarely and
kept as narrow in focus as possible.  YMMD, but I hope not.

In that context, the decisions about who to select or not select
and why should clearly be confidential and remain that way.  The
decision to appoint only a single chair and, given that there
was not going to be a meeting or session at IETF 107 as
originally announced, the decision to not simply turn over the
whole decision-making process to the new IAB (who, as someone
suggested, might reopen the call for candidates and do some
arm-twisting, do not, it seems to me, deserve that protection. 

Remembering that the list of people from whom the IAB was going
to select is public [1] and that I was on it (and noting that
I'm definitely not speaking for Nevil or Chibuzor) let me open
the kimono a bit further and reveal something that you probably
cannot comfortably reveal.  I didn't want the co-chair job and I
think made the quite clear in my submission to the IAB.  After
some arm-twisting from a few community members and the second
call for candidates, I put my name in to expand the pool and
indicated that I was willing to serve if the IAB though that was
the right answer (and even attached a few conditions to that).
I have no idea why neither Nevil or Chibuzor were selected (if I
had known Nevil's name was in the group, before I put my name
in, I would have kept my name out and endorsed him).  I don't
know why you didn't pick at least one of them but, as others
have pointed out, if you concluded that none of the three of us
were appropriate, you had the option (especially with the IETF
107 deadline removed) of reopening the call for candidates and
pushing things over the wall to the new IAB.

> Personally, I'm actually happy that we only appointed one
> chair, but probably not for the reason you think: this way,
> with the large turn over of IAB members, it turns out that the
> incoming IAB members will have a voice in potentially
> selecting a second chair.  

But that "voice" could have been better accomplished by turning
the whole problem over to them.  The official announcement was
not made until the middle of last week when such a handoff would
have been very convenient.   I assume the decision had been made
when I got a "thanks anyway" note indicating I had not been
selected about ten days earlier, but, by then, it was clear who
was going to make up the new Nomcom, I gather some decisions had
been made by the combined group, and it was very clear there
wasn't going to be a meeting of the Program last week.  The
decision may have been perfectly reasonable, but I think, given
that it violated both the community's advice and the IAB's
commitment when the call for candidates was announced, it would
be reasonable to tell the community why it was made without
hiding behind "executive session".

That is, IMO, especially important in this situation because, if
the "future development" effort (when did it change from
"evolution"?) starts off with the same level of distrust that
characterized some of last year's discussions, clear and useful
results would seem rather unlikely no matter how much effort
Eliot and others put in.

regards,
   john

[1]
https://mailarchive.ietf.org/arch/msg/ietf-announce/bpWX2XOhymGc3CS8CByRT1s34J8/

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 1 Apr 2020 09:26:45 +1300

Mirja,

Thanks. I am a bit concerned that you say "months" not "weeks".

Regards
   Brian

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 31 Mar 2020 21:55:11 +0100

Hiya,

Not directed at or to John only, and this is just from
me and wasn't discussed with rest of the IAB...

On 31/03/2020 05:58, John C Klensin wrote:
> if

That's a pity and I'm sorry that we didn't decide to
explain how we ended up where we ended up. Not grokking
that we needed to explain ending up with one chair was
an error, and one I was part of. Apologies for that.

It's difficult to say much more though as this was a
straightforward IAB appointment aka personnel decision,
so I doubt that we'll be able to satisfy Mike's query
really, but fwiw:

- As far as I know there is no IAB skullduggery related
to the chair selection going on at all. I know that's a
bare assertion to just trust the IAB, and in a situation
where that's far from a given, but I did say fwiw;-)

- Please bear in mind that there were shifting logistics
as the IAB was processing the feedback. At one point we
were mostly focused on ensuring a session could happen in
Vancouver with a non-IAB person as chair at the front of
the room. That of course was OBE in the end, but did
factor into how things played out. (Please also believe
me that that says nothing about the capabilities of any
of the folks who volunteered, I'm only saying that there
was a logistics aspect.)

Again, I'm sorry that it's kind of impossible to say
more about this, hopefully those of you who've done IETF
personnel stuff might be able to understand that opening
the kimono at all is just really hard. And as Mirja has
said we'll be getting a co-chair for Eliot - hopefully
one positive outcome of this thread will be that people
consider again taking on the role.

Lastly, (and again more in hope than in the expectation
that people will just believe in the IAB;-), every
indication that I've gotten tells me that the IAB
collectively do want to support, but not control, this
activity. I do expect individual IAB members will get
involved (incl. me) but there hasn't been any collective
IAB attempt to put a thumb on the scales that I've seen.

Cheers,
S.

---

From: John C Klensin <[email-masked]>
Date: Tue, 31 Mar 2020 19:19:54 -0400

Hi.

This is very reassuring.  

However, inline below...

--On Tuesday, March 31, 2020 21:55 +0100 Stephen Farrell
<[email-masked]> wrote:

>> characterized some of last year's discussions, clear and
>> useful results would seem rather unlikely no matter how much
>> effort Eliot and others put in.
> 

Not speaking for Mike, but it would seem to me that, after the
IAB got a clear recommendation from the community about
co-chairs _and_ put out an announcement that confirmed that
recommendation and stated that it what was going to be done,
that the IAB took on an obligation to come back to the community
if that objective turned out to be impractical or impossible.
Maybe I'm just missing something, but I don't see that as a
personnel matter, whether particular personnel issues influenced
it or not.

> the room. 

Again, you and the community said "two or three", so, if that
focus was on "a non-IAB person as chair...", something had
already changed and there should have been an opportunity to
notify the community (or ask for alternate suggestions, as
appropriate).

> That of course was OBE in the end, but did
 
> the kimono at all is just really hard. 

I have been there and understand.  At the same time, I think it
should have been possible to separate the personnel-specific
matters from the more strategic one of the agreement with the
community about co-chairs.

> And as Mirja has

Ok, but I have two concerns.  One echoes Brian's and may relate
to Eliot's scope question.  I see the critical task for this
effort as being to get our ducks lined up and pointed
sufficiently in the same direction that we can either write a
job and move toward hiring a new, non-temporary, RSE or decide
we don't need one (at least for this conversation, I'm trying to
keep an open mind about that).  When Mirja says "months", that
sounds like a very long time wrt that objective, possibly long
enough to preempt the answer.  And it might also imply that the
course of the effort will be sufficiently well set, under
Eliot's able leadership, that the role of a co-chair in practice
might easily be a supporting one rather than having the pair of
equals that I think the community was anticipating.

> IAB attempt to put a thumb on the scales that I've seen.

Again, thanks for the reassurance.

    john

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 1 Apr 2020 00:34:41 +0100

Hiya,

> personnel matter, whether particular personnel issues influenced

Yep, I get it (now;-). We should've provided a
justification for the selection of only one chair.

And WRT the "months" point, message received and
I'll make sure it's considered.

Cheers,
S.

---

From: Wes Hardaker <[email-masked]>
Date: Tue, 31 Mar 2020 16:37:14 -0700

John C Klensin <[email-masked]> writes:

Hi John,

<more entirely without hats thinking>

> reasonably have been expected to affect her.

In general, I'm always happy to voice my personal opinions on matters.
I can't, unfortunately, talk about things that I'm not supposed to
(e.g. things received in confidence, which includes non-public email,
conversations and, of course, executive sessions), or about things that
I have no personal knowledge about.  What happened before my time on the
board started, or what happens in RSOC, both of which fall into the
above category I can't help with unfortunately.

[I'll note that all of the IAB's executive session discussion topics
are on the published agendas, and in at least all the sessions I've
participated in we've only discussed those topics and it's not used as a
free-for-all discussion of anything, which is critical (IMHO).]

What I do want to point out, is that the RFCed-Futures mailing list and
related program is the perfect place to design a better system to find
the right balance in the future.  I'm personally looking forward to the
outcomes of that effort.

> From the perspective of a former IAB member and chair, I think the IAB
> has an obligation to be as open and transparent as possible about its
> discussions, decisions, and the reasons for them and that implies that
> executive sessions should be used rarely and kept as narrow in focus
> as possible.  YMMD, but I hope not.

Over in the ICANN land, I've pushed heavily for open and transparent
meetings for the last few years.  I'm firmly in your camp of "everything
that can and should be open should be".  Unfortunately, when it comes to
collecting and discussing private feedback for appointments, which is
something the IAB spends a lot of meeting time doing (I've learned in
the last year), that can't really be done as transparently and is one of
the reasons the nomcom appointment process to the various bodies exists.

> I didn't want the co-chair job and I think made the quite clear in my
> submission to the IAB.

And I thank you and everyone that volunteered.  It's an incredibly
important position (IMHO).

[As before, I can't respond to much of the rest of the text about the
decision making process]

-- 
Wes Hardaker
USC/ISI

---

From: Wes Hardaker <[email-masked]>
Date: Tue, 31 Mar 2020 16:42:28 -0700

Michael StJohns <[email-masked]> writes:

> actually happened.

It was just my personal thoughts, not a representation of board
opinion (as I said).

-- 
Wes Hardaker
USC/ISI

---

From: Michael StJohns <[email-masked]>
Date: Tue, 31 Mar 2020 20:12:37 -0400

> Vancouver with a non-IAB person as chair at the front of

Sorry - I'm confused about the timeline.  The announcement appointing 
Eliot happened 25 March.  The IETF was cancelled  10 March.  I.e.. the 
IAB knew there was no need for a chair for the in-person meeting 2 weeks 
prior to when you might need one.  Which further suggests (based on your 
statement above) the had settled on Eliot and not John or Nevil before 
10 March.    And Nominations closed on 24 February for the second time - 
so that decision was made between 24 Feb and 10 March.   So the IAB had 
determined not to seek another chair at some time before 10 March but 
hadn't gotten around to making the announcement?  And in the period 
between cancellation and the 25th the IAB didn't reconsider the 
immediate need for a chair?

Which Executive session minutes would show the selection of Eliot (if of 
course we could see them)?

Later, Mike