Subject: Jabber at IETF107 and a thank you

From: Robert Moskowitz <[email-masked]>
Date: Fri, 27 Mar 2020 10:20:30 -0400

First I want to thank all the people that worked hard to make this first 
ever virtual IETF a reality.  ;)

I hope it is the last we need, as there was a lot missing, but there are 
a lot of take-aways to make in-person IETFs better and to perhaps make 
remote participation in in-person IETFs a richer experience.

In My Not So Humble Opinion EVERYONE should get Jabber working and join 
in the Jabber for their session.

Maybe it was always this way, and I never Jabbered, as I was in the 
session room, but this week Jabber was used for side discussions about 
the slide material without interupting the speaker.  I feel that 
valuable information was exchanged and maybe some questions answered 
well in the Jabber rather than at the mike and were thus captured in the 
Jabber log.

Jabber should be a regular activity for all session attendees.

The Hallway Jabber was kind of nice.  Lots of people in the Hallway but 
little jabbering.  It did give a sense of connection and was a bit fun.  
It is an interesting question how to make something like this work for 
remote participants in the future.

The WebEx worked reasonably well.  Lots of fumbling with slides, but 
that was expected.  Will MeetEcho scale up to a couple hundred remote 
participants per session?  Well when we have in-person, probably only a 
few sessions will have that many remotes.

Etherpad seemed to work better than in the past.  I applaud note takers; 
I am terrible at it.  If more jabbered their comments, the notetaker's 
job SHOULD be earier.

Every presenter:  Remember to number your slides!  (I did not, oops).  
We had participants that were not recieving the slides on WebEx and 
someone in Jabber was telling them which slide was showing so they could 
view the slides locally.

More of grey-hairs (so to include those that do not have facial grey 
hair) will be looking to remote participation rather than expend 
retirement benefits for all the travel costs, so we can expect to see 
more non-attendees attending if the experience was like it was this week.

Again, thanks to all involved.  Thanks to all participants to making the 
efforts of those that did the work being worthwhile.

My plane fhlight hoem was uneventful and now I have to get busy reving 
drafts per session discussions.

See you around the cookie table next time!

Bob

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 27 Mar 2020 15:46:43 +0100

[Bcc ietf, Cc wgchairs]

Great summary, Rob. Thanks!

The one point sticking out to me was the jabber log. I think so far,
we did not attempt to capture side discussions on jabber in meeting
minutes, but only those jabber discuss that where taken to the official
microphone. Hopefully i am not wrong on this. But in any case, with
more remote attendants it seems like a good idea for wgchairs
to fold back relevant jabber side discussions into the meeting minutes
for posterity. Or post jabber logs to the proceedings. That probably
reequires tooling improvements (not sure).

Cheers
    Toerless

On Fri, Mar 27, 2020 at 10:20:30AM -0400, Robert Moskowitz wrote:
> I hope it is the last we need, as there was a lot missing, but there are a
> lot of take-aways to make in-person IETFs better and to perhaps make remote
> participation in in-person IETFs a richer experience.
> 
> In My Not So Humble Opinion EVERYONE should get Jabber working and join in
> the Jabber for their session.
> 
> Maybe it was always this way, and I never Jabbered, as I was in the session
> room, but this week Jabber was used for side discussions about the slide
> material without interupting the speaker.  I feel that valuable information
> was exchanged and maybe some questions answered well in the Jabber rather
> than at the mike and were thus captured in the Jabber log.
> 
> little jabbering.  It did give a sense of connection and was a bit fun.  It
> is an interesting question how to make something like this work for remote
> participants in the future.
> 
> 
> The WebEx worked reasonably well.  Lots of fumbling with slides, but that
> was expected.  Will MeetEcho scale up to a couple hundred remote
> participants per session?  Well when we have in-person, probably only a few
> sessions will have that many remotes.
> 
> 
> Etherpad seemed to work better than in the past.  I applaud note takers; I
> am terrible at it.  If more jabbered their comments, the notetaker's job
> SHOULD be earier.
> 
> Every presenter:  Remember to number your slides!  (I did not, oops).  We
> had participants that were not recieving the slides on WebEx and someone in
> Jabber was telling them which slide was showing so they could view the
> slides locally.
> 
> More of grey-hairs (so to include those that do not have facial grey hair)
> will be looking to remote participation rather than expend retirement
> benefits for all the travel costs, so we can expect to see more
> non-attendees attending if the experience was like it was this week.
> 

-- 
---
[email-masked]

---

From: Vittorio Bertola <[email-masked]>
Date: Fri, 27 Mar 2020 17:04:32 +0100 (CET)

> Il 27/03/2020 15:20 Robert Moskowitz <[email-masked]> ha scritto:
> 

I don't know. I liked the side conversations on jabber, they were the only social element of this IETF, but at times (not always) they went beyond commenting what the current speaker was saying, and started being separate complex technical conversations, and at that point it became impossible to focus at the same time on the presentation and on the side discussion. Sometimes it felt like the actual session was going on in jabber, and the set of slowly changing slides with spoken comment (which in a videoconference are bound to be boring anyway) had become almost a background noise; perhaps that was not the intended effect.

This was compounded by the fact that in my timezone it was night and I had already been working all day before the IETF sessions even started, and this for multiple days, so I was possibly also a bit tired.

-- 
 
Vittorio Bertola | Head of Policy & Innovation, Open-Xchange
[email-masked] 
Office @ Via Treviso 12, 10144 Torino, Italy

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 27 Mar 2020 17:12:09 +0100

The logic in jabber for folks to move an offtopic discuss to
a different place is not ideal. There is no option to
quickly open some channel wgname_disuss1 or the like.
Other chat systms have no limitations to quickly create
channels with arbitrary names. Probably a bit too strict
setups on the IETF jabber.

-- 
---
[email-masked]

---

From: "Paul Hoffman" <[email-masked]>
Date: Fri, 27 Mar 2020 09:12:58 -0700

On 27 Mar 2020, at 9:04, Vittorio Bertola wrote:

> I don't know. I liked the side conversations on jabber, they were the 
> only social element of this IETF, but at times (not always) they went 
> beyond commenting what the current speaker was saying, and started 
> being separate complex technical conversations, and at that point it 
> became impossible to focus at the same time on the presentation and on 
> the side discussion. Sometimes it felt like the actual session was 
> going on in jabber, and the set of slowly changing slides with spoken 
> comment (which in a videoconference are bound to be boring anyway) had 
> become almost a background noise; perhaps that was not the intended 
> effect.

Vittorio is completely correct here, at least from my experience this 
week. Paying attention to speakers at the same time as Jabber, 
particularly during Q&A, was impossible. Jabber will always be more 
entertaining than speakers, particularly during Q&A.

The result of the high volume of chatter in Jabber is that the meetings 
themselves become even more just a place for presentations and mic 
lines, not a group of people moving ideas forward.

--Paul Hoffman

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 27 Mar 2020 17:19:37 +0100

On 2020-03-27, at 17:04, Vittorio Bertola <vittorio.bertola=[email-masked]> wrote:
> 
> Sometimes it felt like the actual session was going on in jabber, and the set of slowly changing slides with spoken comment (which in a videoconference are bound to be boring anyway) had become almost a background noise; perhaps that was not the intended effect.

Note that this has happened at physical meetings before.

One reason is that creating and affirming consensus is an important component of meetings, and that is not very interesting for the people who are either already part of that consensus or have made up their minds already that they do not want to become part of that.  But it also is really useful to thread off a discussion that is not really fully on-topic.

And I agree with Toerless’ comment that it is not easy to manage those threads in today’s jabber tools.
(We also had meta-threads about the brokenness of various tools or of they way they were used.)

Grüße, Carsten

---

From: "Pete Resnick" <[email-masked]>
Date: Fri, 27 Mar 2020 11:24:59 -0500

On 27 Mar 2020, at 11:12, Paul Hoffman wrote:

>> became impossible to focus at the same time on the presentation and 
>> on the side discussion. Sometimes it felt like the actual session was 
>> comment (which in a videoconference are bound to be boring anyway) 
>> had become almost a background noise; perhaps that was not the 
>> intended effect.
>
> The result of the high volume of chatter in Jabber is that the 
> meetings themselves become even more just a place for presentations 
> and mic lines, not a group of people moving ideas forward.

I think this was worsened this week because most of the groups were BoFs 
or first-time-meeting-WGs. That means that the presentations were truly 
bringing some people up to speed on the technology, while folks already 
familiar (proponents or folks steeped in the field) were having more 
elaborate jabber discussions. For regular WGs, where the presentations 
are (should be?) just issues slides to frame discussion, mic discussion 
will take more bandwidth for everyone and jabber won't be as busy.

Figuring out how to do less linear mic discussion would also improve 
interaction and put less pressure on jabber.

pr
-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: Michael Richardson <[email-masked]>
Date: Fri, 27 Mar 2020 12:25:43 -0400

> than at the mike and were thus captured in the Jabber log.

It has always been this way.  You aren't a newbie.

***
Maybe you can tell us why you haven't never bothered with jabber before?
I have observed many people who just don't bother.
***

Having a back channel for clarifying questions, and just to well... get the
snark out... is really important.  It's even fun, and I tend to find that it
keeps me engaged, particularly for material that I already know, (or already
know I don't care about).

I have regularly been in the "hallway" room in my desktop client for like... a
decade. Even between meetings, and I am often in the rooms for which I am (or
have been) a chair, basically all the time.
Okay, some of this is just too lazy to close the tab, but some of this is intentional.
Some goes back to the period when I didn't travel much due to funding and family.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 27 Mar 2020 13:34:02 -0400

> (We also had meta-threads about the brokenness of various tools or of they way they were used.)

Pidgin was always telling me who joined and who left.  I can't find how 
to turn this off, as it was breaking the flow of the actual jabbering.  
So good tools is always good.

---

From: Donald Eastlake <[email-masked]>
Date: Fri, 27 Mar 2020 13:36:06 -0400

On Fri, Mar 27, 2020 at 10:21 AM Robert Moskowitz
<[email-masked]> wrote:
> ...

Perhaps there should also be Area specific hallways if the overall
hallway gets too noisy...

> ...
> We had participants that were not receiving the slides on WebEx and

When uploading slides for a WG meeting as chair or secretary, I try to
add slides numbers if they are not there. Easy if it's a powerpoint
presentation. If it's PDF, I ask the authors to add slides numbers and
send it to me again.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

> ...

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 27 Mar 2020 13:38:09 -0400

> I have observed many people who just don't bother.

I was there at the session and never really got into Jabber.  It meant 
installing a new app (pidgin) that previously I had no need to use.  I 
am not an IM kind of guy.  I was even late to SMS.  I am a relatively 
oldtime email person (I did X.400 as well, but that was more limited).

This week forced me to dive in and just swim with the rest of the fish.

---

From: Keith Moore <[email-masked]>
Date: Fri, 27 Mar 2020 13:44:59 -0400

On 3/27/20 12:12 PM, Paul Hoffman wrote:

> entertaining than speakers, particularly during Q&A. \

I also found this to be true, the jabber conversations were a 
distraction from the speaker.   But I found the jabber conversations 
more productive than the presentations, much like at a physical IETF the 
bar conversations are more productive than the sessions.

The odd thing is that the productive jabber conversations would hardly 
exist without the presentations, so in a sense the presentations do 
facilitate the useful conversations.   But maybe it's possible to 
structure things so that this works better. Maybe have sessions 
alternate between video presentations and jabber conversations?

> and mic lines, not a group of people moving ideas forward. 

Or maybe the jabber conversations are closer to the real purpose of the 
meetings than the presentations are, and that's what we need to optimize.

(this reminds me of the algorithm for laying out sidewalks on a 
university campus - just grow grass everywhere, and see where the grass 
gets worn, then put sidewalks along those paths.)

Keith

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 27 Mar 2020 18:45:16 +0100

> presentation. If it's PDF, I ask the authors to add slides numbers and

In real life, I just pester the authors (i.e., students who give a talk without slide numbers get a tell-off).

In WG meetings, we tend to use consolidated decks that are numbered all the way through.

BTW, for PDF numbering:
https://stackoverflow.com/questions/1603301/how-to-add-page-numbers-to-postscript-pdf
Yeah, not pretty.

Grüße, Carsten