Subject: Re: Planned experiment: A new mailing list for last-call discussions

From: Rob Sayre <[email-masked]>
Date: Fri, 13 Mar 2020 16:36:22 +1000

Hi,

In my view, the experiment is a success.

It seems like the general IETF is currently concerned with issues not
related to document review.

thanks,
Rob

On Fri, Sep 13, 2019 at 2:14 AM Barry Leiba <[email-masked]> wrote:

> As we discussed in the plenary session at IETF 105 in Montréal, some
> community members have suggested moving document last-call discussions
> onto a dedicated "last-call" mailing list, and off of the general
> <[email-masked]> list.  The latter is a high-volume list with a lot of
> varied discussion, and some think that it would be useful to separate
> the general discussion from the last-call discussion, to allow people
> to choose which discussions (or both) to follow.  In the IETF 105
> plenary, support was expressed for that separation.
>
> The IESG agrees, and wants to try an experiment to that end.  We
> propose to create <[email-masked]> and to direct last-call
> comments and discussions there (the last-call announcements would
> still go to <[email-masked]>, with "reply-to" set to the new
> list).  That list would be monitored by volunteers recruited by the
> IETF Chair, and digressions would be nudged back to <[email-masked]>,
> while we would ask people having last-call discussions on this list to
> please move them to the new list.  We would get the tools team
> involved so that the distribution lists for directorate and
> review-team reviews would be updated appropriately.
>
> Our plan is to create the new list and pre-subscribe everyone who is
> subscribed to <[email-masked]> at that time.  Of course, anyone could
> unsubscribe to either or both lists immediately or later, but we think
> that doing it this way would minimize the likelihood that people would
> miss important stuff because of the move, and folks can choose what
> they prefer from there.
>
> After six months, we would do an initial evaluation, including getting
> feedback from the community, to see how the experiment is working.  If
> it seems worth continuing we would do so, and at a point that the
> community decides that the experiment is a success (should it so
> decide), we would start an update to BCP 45 to formally move the
> location for last-call discussions, and we would update the 2007 IESG
> Statement on Last Call Guidance.
>
> We invite comments, here, on this plan, by the end of September. As I
> say above, we've heard support from the community for the general
> idea, and we'd like to make sure this direction is what the community
> wants.
>
> Barry, for the IESG
>
>

---

From: "tom petch" <[email-masked]>
Date: Fri, 13 Mar 2020 12:10:09 +0000

----- Original Message -----
From: Rob Sayre [email-masked]
Sent: 13/03/2020 06:36:22

Hi,

In my view, the experiment is a success.
<tp>
A partial success.  It took me a while to realise that Last  Call announcements could not be found there.  This was a particular issue last week when I blinked and while I did, in excess of 500 new posts appeared on the ietf-announce list  making any last call announcement hard to find (My MUA support is wrecked and the web interface is primitive

---
New Outlook Express and Windows Live Mail replacement - get it here:
https://www.oeclassic.com/

),  I have found myself responding to a gen-art or secdir post which can only muddy the waters as my comments are totally unrelated to their comments,
So to make it work, please post all Last Call announcements to the Last Call list; it is obvious really.
Tom Petch
</tp>
It seems like the general IETF is currently concerned with issues not related to document review.

thanks,
Rob

Barry, for the IESG

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 13 Mar 2020 13:59:54 +0100

> It seems like the general IETF is currently concerned with issues not related to document review.

This is the question I am raising to myself, too.

I think in general, there are very few things important right now.

I struggle to concentrate on the ietf matter precisely.

I think as long as we post here as usual, regardless of how far the 
topic is on topic or not, is a good thing.

Alex

---

From: Paul Wouters <[email-masked]>
Date: Fri, 13 Mar 2020 12:12:49 -0400 (EDT)

> In my view, the experiment is a success.

Yes, but it could use improvements.

I would prefer a reply-to: the [email-masked] list with the lastcall
list not getting any further CC:s. This helps me see last call for new
documents on this list without being drowned by a discussion on drafts
that are not in my area of expertise. Currently, I think I miss some
lastcall requests due to the high discussion volume on the list.

Paul

---

From: Robert Sparks <[email-masked]>
Date: Fri, 13 Mar 2020 11:24:47 -0500

Paul -

Consider watching ietf-announce instead. LC announcements go there. The 
volume of other things announced there is low enough that you won't be 
as likely to miss LC announcements.

RjS

---

From: Keith Moore <[email-masked]>
Date: Fri, 13 Mar 2020 12:30:14 -0400

On 3/13/20 12:12 PM, Paul Wouters wrote:

> list not getting any further CC:s.

I would prefer that replies go to a list created specifically for that 
last call, and archived separately, so that it would be easy to find the 
last call comments for any particular document.

IMO it would be pointless to send replies to [email-masked] because that 
would put most of the discussion on the IETF list, and I thought the 
whole point of having separate lists was to put those discussions 
somewhere else.

IMO the [email-masked] list shouldn't get in the loop unless there 
emerges some issue of concern to the wider community.

Keith

---

From: Jared Mauch <[email-masked]>
Date: Fri, 13 Mar 2020 12:50:14 -0400

> On Sep 13, 2019, at 4:09 PM, Eric Rescorla <[email-masked]> wrote:
> 
> I disagree with this. Part of the value proposition here is to allow people to engage with last calls and avoid the... unpleasantness... which is the ietf@ list.
> 

Disclaimers: in theory I moderate last-call.  Also inbound IAB

With those said, I agree 100% with this, it allows for a more focused discussion and review without.

- Jared

---

From: "tom petch" <[email-masked]>
Date: Fri, 13 Mar 2020 18:13:17 +0000

---- Original Message -----
From: Robert Sparks <[email-masked]>>
Sent: 13/03/2020 16:24:47
Paul -
Consider watching ietf-announce instead. LC announcements go there. The 
volume of other things announced there is low enough that you won't be 
as likely to miss LC announcements.
<tp>
Now I am totally confused.  I miss Last Call announcements precisely because there are hundreds and hundreds and hundreds of posts to ietf-announce at times like last weekend when the submission window is about to close.
And in response to Paul the whole point of Last Call is to get announcements that are NOT in my area of expertise; it is the kind of peer review that improves the quality of the RFC that the IETF produce so I want to see what others have to say and that may make me take a greater interest.
tom petch
</tp> 

---

RjS

---

From: <[email-masked]>
Date: Fri, 13 Mar 2020 17:30:26 -0400

> Now I am totally confused.  I miss Last Call announcements precisely because
> there are hundreds and hundreds and hundreds of posts to ietf-announce at
> times like last weekend when the submission window is about to close.

This is problem I face on a regular basis as well... I've tried to sort out the last calls based on the contents of the email, but it would be more convenient  if there were a separate list, I think (?).

😊 /r

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 13 Mar 2020 14:33:51 -0700

> This is problem I face on a regular basis as well... I've tried to sort out the last calls based on the contents of the email, but it would be more convenient  if there were a separate list, I thin…

It's entirely possible I have different calibration for email volume than
many people, but just to check: we're talking about the number of emails
being too much on [email-masked], not [email-masked]?
I agree that the latter is indeed quite a lot...

-Ben

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 14 Mar 2020 10:47:47 +1300

> I agree that the latter is indeed quite a lot...

I don't understand this discussion. For many years, I've had messages with "last call" in their subject header sorted into an inbox named, strangely enough, "lastcallsin". I had to slightly augment my filters when the new list was created, but otherwise... nothing changed.

i-d-announce is indeed challenging, especially around I-D cutoff dates. But frankly, if your MUA can't filter or sort adequately, you either need a new MUA or you need to abandon hope of following IETF work.

   Brian

---

From: "tom petch" <[email-masked]>
Date: Sat, 14 Mar 2020 15:47:19 +0000

---- Original Message -----
From: Benjamin Kaduk <[email-masked]>
Sent: 13/03/2020 21:33:51
________________________________________________________________________________

Ah yes, I am conflating the two, wh;ich I am because I use the same e-mail address for both and have lost my ability to filter out what I want from the noise (and the web interface is dire).  So yes, I drown in the announcements of I-D and miss the IESG announcements of Last Call, tom petch

---

-Ben