Subject: iesg: Re: [arch-d] Updates on IAB mailing lists

From: Toerless Eckert <[email-masked]>
Date: Mon, 20 Apr 2020 20:44:56 +0200

Dear IESG [Cc'in IETF]

I would hereby like IESG to reconfirm that [email-masked]
is an IETF mailing list subject to IETF mailing list rules and its
"about" statement and not subject to intended strict IAB controlled
communications policies for IAB mailing lists as proposed by Tommy.

If this is not yet the case, then please make sure that it is in the
future because the proposed IAB policies do neither match the mailing
lists name, the actual discussion (mostly absent IAB involvement), nor the 
intended discussion on it (as on mailman).

See below for more detailled justification.

Dear Tommy, *:

Wrt to your intention to put IAB mailing lists under the following proposed policies:

> Inappropriate postings consist of: spam and bulk e-mail;
> unprofessional commentary, regardless of subject;

OK.

> announcements of conferences or activities that are not sponsored
> or endorsed by the Internet Society, the IETF, or the IAB

OK.

> and discussion of subjects unrelated to IAB policy,
> programs, activities, or technical concerns"

NOK for list that go beyond those points. [email-masked]
clear goes beyond those points.

a) I read this as a long-winding workaround to prohibit
   the IETF community to self-organize without official leadership
   support in inofficial side meetings using the IETF mailing list
   [email-masked]

   I suspect these rules have especially been crafted to prohibit me to
   invite community members interested in architecture discussion around
   New IP to inofficial side meetings via the [email-masked]
   mailing list in the future, as i did in the past for IETF106 and IETF107.

   AFAIK, it is not only common practice, but quite desirable
   for the community to use IETF/IRTF mailing lists to self-organize
   into whatever form of inoffical side meeting is appropriate on
   topics of intererst to that mailing list. Bar BOFs not being easy
   in times of corona.  Likewise i think that notifications about events
   related to a mailing lists topic are quite common. The notion that
   only official sponsored events can be brought up sounds quite strange
   to me and quite contrary to the open nature of the IETF/IRTF.

b) If IAB wants to enforce such restrictive policies for communications
   on an intentional open mailing list such as [email-masked],
   then this adds severely to my concerns about how IAB operates. I think 
   it is unbecoming for an ISOC entity.

   To me, [email-masked] is clearly not a mailing list
   that currently is or in the future should be subject to such IAB
   communication constraints:

   1. It is called [email-masked], not @iab.org

   2. About: https://www.ietf.org/mailman/listinfo/Architecture-discuss

    > The architecture-discuss list serves as a technical discussion
    > forum for all members of the IETF community that are interested
    > in larger > architectural issues. It is meant to be an open discussion
    > forum for all long and/or wide range architectural concerns related
    > to the Internet Architecture. In particular, it may be used to
    > discuss and bring forth different points of view on controversial
    > architectural questions. Discussions that drill down and dwell
    > on specifics of individual protocols or technologies are to be
    > discouraged, redirected to appropriate other fora, or re-cast to
    > discussions of broader implications for Internet architecture.

   3. The mayority of the discussions on the mailing list are clearly not
   lead by IAB, but are useful for the community. There is absolutely no
   need for such a mailing list to be constrained to proposed new strict
   IAB regime. Instead i think IAB membersh should be welcome into the
   discussion of the community.

Cheers
    Toerless

On Mon, Apr 20, 2020 at 09:08:48AM -0700, Tommy Pauly wrote:
> Hello architecture-discuss,
> 
> We???d like to share a few updates about IAB mailing lists, and solicit the community???s feedback on some new text.
> 
> First, Tommy Pauly will be joining Stephen Farrell on the (existing, but rarely employed) sergeants-at-arms team to help moderate the list.
> 
> Second, we???d like to clarify the sergeants-at-arms roles for the lists. The current description on https://www.iab.org/iab-mailing-lists/ <https://www.iab.org/iab-mailing-lists/> does mention that the lists use a sergeant-at-arms model for moderation, but does not describe what this role entails. It also does not specify if this role applies to all of the lists on the page, such as program lists.
> 
> We???re proposing adding the following text to https://www.iab.org/iab-mailing-lists/ <https://www.iab.org/iab-mailing-lists/>, largely based on the IETF list SAA. We???d love to hear feedback on this approach!
> 
> ====
> 
> IAB mailing lists have sergeants-at-arms, whose role is ensure there are no inappropriate postings. Inappropriate postings consist of: spam and bulk e-mail; announcements of conferences or activities that are not sponsored or endorsed by the Internet Society, the IETF, or the IAB; unprofessional commentary, regardless of subject; and discussion of subjects unrelated to IAB policy, programs, activities, or technical concerns.
> 
> The sergeants-at-arms are empowered to restrict posting by a person or of a thread when the content is inappropriate and represents a pattern of abuse. Complaints regarding a decision should be referred to the IAB chair.
> 
> The current sergeants-at-arms for ???[email-masked] <mailto:[email-masked]>??? are Stephen Farrell and Tommy Pauly. For program-specific lists, the program chairs act as moderators. The "[email-masked] <mailto:[email-masked]>??? list is moderated by the Temporary RFC Series Project Manager.
> 
> ====
> 
> Third, we have many lists that are enumerated on the website that are for closed programs or past workshops. We checked the activity on these lists, and we believe that we can close the following lists. Any further discussion on these topics is welcome on architecture-discuss.
> 
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> 
> The remaining lists will be:
> 
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> - [email-masked] <mailto:[email-masked]>
> 
> Best,
> Tommy Pauly, on behalf of the IAB

> _______________________________________________
> Architecture-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/architecture-discuss

---

From: Melinda Shore <[email-masked]>
Date: Mon, 20 Apr 2020 11:42:06 -0800

>    1. It is called [email-masked], not @iab.org

Note that ietf.org hosts a number of mailing lists that are not
"official" IETF activities.  You can find a list of all IETF
mailing lists at https://www.ietf.org/mailman/listinfo.  The
main reason we have so many mailing lists is to group things which
are like and separate things which are not like, to keep discussions
manageable.  architecture-discuss exists to support the activities of
the IAB.  Presumably a discussion of homenet architecture would
not be welcome on architecture-discuss.

It seems to me that it makes more sense to request a new list for the
discussions that you'd like to have than to repurpose an existing list
over the objections of the list owners/managers/SAAs.

Melinda

---

From: Mary Barnes <[email-masked]>
Date: Mon, 20 Apr 2020 14:49:19 -0500

If the intent is that the list is specific to IAB activities (as I said in
my response, that wasn't the intent in the past), then you all should
update the description.  Personally, I think it's a handy list to have for
purely technical discussions as opposed to all the non-technical
discussions on the main IETF discussion list.

---

From: Melinda Shore <[email-masked]>
Date: Mon, 20 Apr 2020 11:52:00 -0800

On 4/20/20 11:49 AM, Mary Barnes wrote:
> Personally, I think it's a handy list to have
> for purely technical discussions as opposed to all the non-technical

Right, but I think it's clear that it's not every technical
discussion, which circles back around to Toerless's argument.

Melinda

---

From: Mary Barnes <[email-masked]>
Date: Mon, 20 Apr 2020 15:13:57 -0500

Thanks - I hadn't followed Toeless' thread where he encountered the problem
that triggered his email.

Just to make sure I understand - the architecture-discuss list is intended
only for topics that the IAB deems of interest specifically to the IAB and
NOT a general community list to discuss things related to the Internet
architecture.  Is that correct?   If so, then it does seem we need a list
where folks can have discussion of technical topics that aren't necessarily
related to work IAB is doing.   I know we've discussed in the past that the
IETF discussion list is most suitable for those discussions but I think
most would agree that the list has a whole lot more discussion of how we do
non-technical things than technical (I would guess 90/10 for the most
part).   I think many don't pay near the attention to the list that they
might if it were technical discussions - for example, I subscribe to that
list using my general email that I use for not real work.

So, one question I would have then, is whether it's thus only appropriate
for someone in the community to post to architecture-discuss if they are
asking specific questions on current IAB activities and documents?

Regards,
Mary.

---

From: Tommy Pauly <[email-masked]>
Date: Mon, 20 Apr 2020 14:00:23 -0700

Hi Toerless,

>> programs, activities, or technical concerns"

How about “and mail with content unrelated to technical discussion, Internet architecture, or activities of the IAB”?

Please see further for more discussion of the intent here.

>   to me and quite contrary to the open nature of the IETF/IRTF.

It is not the intention of this clarification in the SAA role to at all restrict discussion of the topics you’re bringing up here, such as New IP, or to to limit discussion of side meetings about such. Indeed, such discussion (even if it isn’t an event organized by the IAB), is of relevance and interest to Internet architecture.

Working on this text is certainly good to do with your input, and others. The current text is lifted mainly from the IETF discussion list SAA description.

The goal of mentioning irrelevant activities was more to make it clear that if someone started posting what is effectively spam to a list, that the SAA could reach out to the person to moderate that. What is relevant to each list is dependent on the list. Architecture-discuss is indeed a broad list, and any discussion that is truly about Internet architecture fits.

Largely, the motivation to update and clarify this text is to ensure that the community agrees on what the *existing* role of the SAA is for these lists, and to ensure that if there is a instance in which the SAA does need to step in (let’s say, due to spamming the list), that there is a consistent and standard response to make. My hope is to limit this role such that it cannot be used in the ways you mention (limiting community discussion and organization of relevant topics).

>   2. About: https://www.ietf.org/mailman/listinfo/Architecture-discuss

This list is, in fact, an IAB-sponsored activity since its inception. The list does exist at both @ietf.org, and @iab.org.

>   discussion of the community.

Indeed, the discussion on the list is to be encouraged! The goal of clarifying the policy is to ensure that, as this list is an IAB-sponsored activity, that the community does have a productive and open space to discuss. The SAA’s role is to handle spam or abuse only.

Thanks,
Tommy

---

From: Adam Roach <[email-masked]>
Date: Mon, 20 Apr 2020 16:21:36 -0500

> Indeed, the discussion on the list is to be encouraged! The goal of clarifying the policy is to ensure that, as this list is an IAB-sponsored activity, that the community does have a productive and…

For avoidance of doubt: if you're referring to the Sergeants-at-Arms 
appointed by the IETF chair to assist in keeping the [email-masked] 
mailing list within its charter (as defined by RFC 3005), they have no 
responsibilities or authority on mailing lists other than [email-masked].

Other mailing lists have their own individual owners (typically, WG 
chairs, area directors, directorate secretaries, or similar) that are 
responsible for filling equivalent roles on their mailing lists (either 
directly or by delegation). For most lists, you can reach these owners 
by sending mail to <list>[email-masked] (e.g., 
[email-masked]).

/a

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 20 Apr 2020 23:39:05 +0200

Melinda,

The current description of the list is very clear and very useful,
and well defines whats in and whats out of scope. It should not
be changed or amended by new rules as proposed by the current IAB.

Whoever sponsors the list, IAB or else, if it is an @ietf.org
mailing list, it should follow what we have come to expect to
be appropriate for IETF. When the IAB wants to have more constrained
mailing lists, which may make perfect sense for other lists, they
can have them under @iab.org. [email-masked] was
specifically set up there to indicate its an IETF community mailing list
thats also explicitly what the description says. The IETF community
does not operate under IAB rules.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 20 Apr 2020 17:54:12 -0400

My read has been that architecture-discuss was for Internet Architecture 
topics of relevance to the IAB or IETF.

That does not, in my book, include random musing about research projects 
that may or may not lead to something in some ill-defined time in the 
future.

And even if you disagree with the specific example, it does mean that 
there are clearly things which are off-topic for architecture-discuss. 
Which means that someone needs to be authorized to deal with such things 
when they become problematic.

Yours,
Joel

On 4/20/2020 4:13 PM, Mary Barnes wrote:
> Thanks - I hadn't followed Toeless' thread where he encountered the 
> problem that triggered his email.
> 
> Just to make sure I understand - the architecture-discuss list is 
> intended only for topics that the IAB deems of interest specifically to 
> the IAB and NOT a general community list to discuss things related to 
> the Internet architecture.  Is that correct?   If so, then it does seem 
> we need a list where folks can have discussion of technical topics that 
> aren't necessarily related to work IAB is doing.   I know we've 
> discussed in the past that the IETF discussion list is most suitable for 
> those discussions but I think most would agree that the list has a whole 
> lot more discussion of how we do non-technical things than technical (I 
> would guess 90/10 for the most part).   I think many don't pay near the 
> attention to the list that they might if it were technical discussions - 
> for example, I subscribe to that list using my general email that I use 
> for not real work.
> 
> So, one question I would have then, is whether it's thus only 
> appropriate for someone in the community to post to architecture-discuss 
> if they are asking specific questions on current IAB activities and 
> documents?
> 
> Regards,
> Mary.
> 
> On Mon, Apr 20, 2020 at 2:52 PM Melinda Shore <[email-masked] 
> <mailto:[email-masked]>> wrote:
>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 21 Apr 2020 02:36:05 +0200

Thanks, Tommy, inline

> >> or endorsed by the Internet Society, the IETF, or the IAB

Oops. That was typo on my end. Should have been NOK, because
the way i read it, bar-bof/inofficial-side-meeting discussions
sound like not being permitted by this.

> How about ???and mail with content unrelated to technical discussion, Internet architecture, or activities of the IAB????

I think the scope of the mailing list is very well reflected
in the description on mail man. I don't think that type of
text would improve it or could/should replace it.

> It is not the intention of this clarification in the SAA role to at all restrict discussion of the topics you???re bringing up here, such as New IP, or to to limit discussion of side meetings about such. Indeed, such discussion (even if it isn???t an event organized by the IAB), is of relevance and interest to Internet architecture.

Thanks.

> Working on this text is certainly good to do with your input, and others. The current text is lifted mainly from the IETF discussion list SAA description.

Maybe refer to the intent of a specific mailing list as descibed
in its mailman "About" instead of trying to reinvent it.

> Largely, the motivation to update and clarify this text is to ensure that the community agrees on what the *existing* role of the SAA is for these lists, and to ensure that if there is a instance in which the SAA does need to step in (let???s say, due to spamming the list), that there is a consistent and standard response to make. My hope is to limit this role such that it cannot be used in the ways you mention (limiting community discussion and organization of relevant topics).

I have not seen a need on architecture-discuss for an
SAA to step in.  I think we have a robust peer
discussion culture on the list, and i think that there
is a good balance of well-meaning attempt to create
order and equally well-meaning rebuttals when those
seem to go overboard. No need to make that traditional
IETF equilibrium more complex through SAA roles unless
IMHO there is more hard evidence of need and likelyhood
of benefit.

> This list is, in fact, an IAB-sponsored activity since its inception. The list does exist at both @ietf.org, and @iab.org.

Sure. But the description makes this clearly an IETF activity,
it does not mention IAB at all, and i think that was intended
by its original sponsors and should stay this way. This is
a mailing list for the IETF community and IAB is welcome to
participante as IETF members. 

Its easy for any more iab centric activities to use @iab.org.

> >   IAB regime. Instead i think IAB membership should be welcome into the
> Indeed, the discussion on the list is to be encouraged! The goal of clarifying the policy is to ensure that, as this list is an IAB-sponsored activity, that the community does have a productive and open space to discuss. The SAA???s role is to handle spam or abuse only.

Thanks
    Toerless

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 21 Apr 2020 02:50:43 +0200

Hi Joel,

Don't you think it is sufficient for the mailing list
to self-manage ? i have seen nothing worse than on any of
the other 9999 IETF mailling lists that are not [email-masked].

Indeed, i think we have seen some good examples of self-management
on the list in the past month. Tell me if you think that did
or did not work well.

I for once would be afraid, that if specific persons where
given more power to control the scope of the discussion,
we might not even have had the technical exchange to answer
to specific claims made. On the other hand, i have seen bad
examples of the SAA model on the [email-masked] mailing list:

An SAA model can quickly deteriorates IMHO into more and
more passive-aggressive language policing discussion on all sides as
opposed to best effort minimizing robust language and sticking
to the technical topics - which i think what happens easier
without SAA.

I am very interested to hear you express a more specific definition
of what you think should be in scope of architecture-discuss than what
is written in the current mailmain "about".  But probably better to
discuss this in a separate thread.

Cheers
    Toerless

On Mon, Apr 20, 2020 at 05:54:12PM -0400, Joel M. Halpern wrote:
> And even if you disagree with the specific example, it does mean that there
> are clearly things which are off-topic for architecture-discuss. Which means
> that someone needs to be authorized to deal with such things when they
> become problematic.
> 
> Yours,
> Joel
> 

-- 
---
[email-masked]

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 20 Apr 2020 21:32:49 -0400

I have seen many examples on different lists around the IETF of 
situations where it needed someone to be able to say "no, that does not 
belong".  Or "your question has been answered.  Unless you have a new 
issue, please stop."  Or other variations.  There have been some 
postings on architecture-discuss that in my opinion (and I grant it is 
not mine to judge) were pushing the limits of what belongs.  And at 
least some of them seemed quite unable to hear "this does not belong". 
(Fortunately, in the case I am thinking of, the rate is low enough we 
survived.)

No, I do not think we need the moderator / SAA function very often.  But 
I do think it is entirely reasonable to be clear who has that 
responsibility / authority.  For IETF WGs, that is the chairs.

On the specifics, I read the note from the SAAs as saying that the list 
excludes things that aare off topic.  You reasonably read the note as 
saying something more restrictive.  That part we can (and I think have) 
clarify.  That is quite distinct from whether there should be a 
backstop.  And given that the list was set up by the IAB, it seems 
appropriate that they appoint the backstop.  (I am generally not in 
favor of the IAB or IESG grabbing extra authority.  I do not see this as 
being of that form.)

Yours,
Joel

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 21 Apr 2020 20:04:33 +0200

Thanks, Joel.

I think in general it would be good to avod creating multiple places
where to look for policies about mailing lists. IMHO the "about" on
mailman should be authoritative.

If a non-wg maiing list seems to need some explicit management
person(s), maybe add that info to the "about". I am not sure
any of the current non-WG IETF mailing lists actually has any
official designated persons for such a rule (except well-known
exceptions such as [email-masked]). IMHO self-management works
usually well, and in the few case where not, one could always
escalate to IESG/IAB. Whether a separate designated SAA is
better i doubt, but no strong opinion.

Chers
    Toerless

On Mon, Apr 20, 2020 at 09:32:49PM -0400, Joel M. Halpern wrote:
> I have seen many examples on different lists around the IETF of situations
> where it needed someone to be able to say "no, that does not belong".  Or
> "your question has been answered.  Unless you have a new issue, please
> stop."  Or other variations.  There have been some postings on
> architecture-discuss that in my opinion (and I grant it is not mine to
> judge) were pushing the limits of what belongs.  And at least some of them
> seemed quite unable to hear "this does not belong". (Fortunately, in the
> case I am thinking of, the rate is low enough we survived.)
> 
> No, I do not think we need the moderator / SAA function very often.  But I
> do think it is entirely reasonable to be clear who has that responsibility /
> authority.  For IETF WGs, that is the chairs.
> 
> excludes things that aare off topic.  You reasonably read the note as saying
> something more restrictive.  That part we can (and I think have) clarify.
> That is quite distinct from whether there should be a backstop.  And given
> that the list was set up by the IAB, it seems appropriate that they appoint
> the backstop.  (I am generally not in favor of the IAB or IESG grabbing
> extra authority.  I do not see this as being of that form.)
> 
> Yours,
> Joel
> 
> 

-- 
---
[email-masked]