Subject: ietf related E-mails.

From: Khaled Omar <[email-masked]>
Date: Mon, 6 Apr 2020 21:37:09 +0000

Hi,

I can see that all the ietf related e-mails comes to the junk folder, is this something happens with everyone or it is just with me?

Regards,

Khaled Omar

---

From: Keith Moore <[email-masked]>
Date: Mon, 6 Apr 2020 21:29:58 -0400

[private reply]

For what it's worth, this doesn't happen to me.

Keith

On 4/6/20 5:37 PM, Khaled Omar wrote:
>
> Hi,
>
> I can see that all the ietf related e-mails comes to the junk folder, 
> is this something happens with everyone or it is just with me?
>
> Regards,
>
> Khaled Omar
>

---

From: Khaled Omar <[email-masked]>
Date: Tue, 7 Apr 2020 09:11:02 +0000

So this happens only with me, thanks.

Khaled Omar

Get Outlook for Android<https://aka.ms/ghei36>
________________________________
From: ietf <[email-masked]> on behalf of Keith Moore <[email-masked]>
Sent: Tuesday, April 7, 2020 3:29:58 AM
To: [email-masked] <[email-masked]>
Subject: Re: ietf related E-mails.

[private reply]

Keith

Hi,

Regards,

Khaled Omar

---

From: Khaled Omar <[email-masked]>
Date: Tue, 7 Apr 2020 15:07:21 +0000

>> Anything related to you junk folder is just on your machine.
That’s an idiot situation really.

Khaled OMAR

From: Fred Baker <[email-masked]>
Sent: Tuesday, April 7, 2020 2:07 AM
To: Khaled Omar <[email-masked]>
Subject: Re: ietf related E-mails.

Anything related to you junk folder is just on your machine.
Sent from my iPad

On Apr 6, 2020, at 2:38 PM, Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Regards,

Khaled Omar

---

From: "Scott O. Bradner" <[email-masked]>
Date: Tue, 7 Apr 2020 11:11:16 -0400

Do you mean that junk mail should be marked as such by the sender so that your machine will know what to do with it?

Scott

> On Apr 7, 2020, at 11:07 AM, Khaled Omar <[email-masked]> wrote:
> 
> On Apr 6, 2020, at 2:38 PM, Khaled Omar <[email-masked]> wrote:
> 
>  
> Hi,
>

---

From: Doug Royer <[email-masked]>
Date: Tue, 7 Apr 2020 09:11:56 -0600

> I can see that all the ietf related e-mails comes to the junk folder, is this something happens with everyone or it is just with me?

Gmail does it to a lot of the lists. So, I step one was to having gmail do the IETF mail filtering.
I make the folder(s) that I want. And using gmail web interface, create a filter that matched the TO field, Check "Skip Inbox", and I check "Never send it to Spam".

For hotmail.com (and outlook.com?), add the mailing lists to the 'Safe Mailing Lists', under settings using their web interface.

The next problem I had was Thunderbird sending some to spam even after gmail put them in the correct folder. So, again, I created Thunderbird filters.

Now I just have to remember to make one web (gmail or hotmail) filter -and- one Thunderbird filter for each new mailing list I join.

I wish there was an IMAP way that clients and servers would use shared filters.

-- 
Doug Royer - (http://DougRoyer.US)
[email-masked]
714-989-6135

---

From: Khaled Omar <[email-masked]>
Date: Tue, 7 Apr 2020 15:15:15 +0000

>> Do you mean that junk mail should be marked as such by the sender so that your machine will know what to do with it?

From my side, I really mean it, he is the junk folder receives many e-mails.

Khaled OMAR

-----Original Message-----
From: Scott O. Bradner <[email-masked]> 
Sent: Tuesday, April 7, 2020 5:11 PM
To: Khaled Omar <[email-masked]>
Cc: [email-masked]
Subject: Re: ietf related E-mails.

Scott

---

From: Joseph Touch <[email-masked]>
Date: Tue, 7 Apr 2020 08:16:47 -0700

We have a mechanism for that already:
https://tools.ietf.org/html/rfc3514 <https://tools.ietf.org/html/rfc3514>

;-)

Joe

> On Apr 7, 2020, at 8:11 AM, Scott O. Bradner <[email-masked]> wrote:
>

---

From: Christopher Morrow <[email-masked]>
Date: Tue, 7 Apr 2020 11:20:21 -0400

/mute ... is there really a time when a long drawn out conversation
about local mail filtering perniciousness is a global problem we need
to solve?

On Tue, Apr 7, 2020 at 11:17 AM Joseph Touch <[email-masked]> wrote:
> https://tools.ietf.org/html/rfc3514
>
> ;-)
>
> Joe
>
>

---

From: Khaled Omar <[email-masked]>
Date: Tue, 7 Apr 2020 15:21:59 +0000

So it means many are affected, so why there are claims that everything comes to the intended folder!

One week ago, this wasn't happening with the e-mail client I'm using.

I can make the suggested MODIFICATION to make it work better.

Khaled OMAR

---

From: Doug Royer <[email-masked]>
Date: Tue, 7 Apr 2020 09:55:07 -0600

> about local mail filtering perniciousness is a global problem we need

That is kind of what the IETF is about. Technical problems. Technical solutions. In fact, if it happens a lot, it may be a time for a new solution.

---

From: "Pete Resnick" <[email-masked]>
Date: Tue, 07 Apr 2020 11:33:08 -0500

If you're using an IMAP client like Thunderbird, why don't you just 
create an account that points to imap.ietf.org and read your mail 
directly off of the IETF server?

pr

On 7 Apr 2020, at 10:11, Doug Royer wrote:

> I make the folder(s) that I want. And using gmail web interface, 
> create a filter that matched the TO field, Check "Skip Inbox", and I 
> check "Never send it to Spam".
>
> For hotmail.com (and outlook.com?), add the mailing lists to the 'Safe 
> Mailing Lists', under settings using their web interface.
>
> The next problem I had was Thunderbird sending some to spam even after 
> gmail put them in the correct folder. So, again, I created Thunderbird 
> filters.
>
> Now I just have to remember to make one web (gmail or hotmail) filter 
> -and- one Thunderbird filter for each new mailing list I join.
>

-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: Doug Royer <[email-masked]>
Date: Tue, 7 Apr 2020 12:05:24 -0600

On 4/7/20 10:33 AM, Pete Resnick wrote:
> If you're using an IMAP client like Thunderbird, why don't you just create an account that points to imap.ietf.org and read your mail directly off of the IETF server?
> 

Because on my system, I collect related email into -my- IETF folders as well as the lists. This includes out of band emails that do not appear on the list, and related to the subject.

---

From: Khaled Omar <[email-masked]>
Date: Tue, 7 Apr 2020 18:14:00 +0000

>> If you're using an IMAP client like Thunderbird, why don't you just create an account that points to imap.ietf.org and read your mail directly off of the IETF server?

This is a question or suggestion ?

I can see that using Thunderbird is not a solution for the junk issue.

Khaled OMAR

-----Original Message-----
From: ietf <[email-masked]> On Behalf Of Pete Resnick
Sent: Tuesday, April 7, 2020 6:33 PM
To: Doug Royer <[email-masked]>
Cc: [email-masked]
Subject: Re: ietf related E-mails.

pr

---

From: "John Levine" <[email-masked]>
Date: 7 Apr 2020 17:37:49 -0400

In article <[email-masked]> you write:
>
>That is kind of what the IETF is about. Technical problems. Technical solutions. In fact, if
>it happens a lot, it may be a time for a new solution.

In this case we seem to be discussing yet another mail handling issue
at Microsoft's hosted mail service.  So, no.

R's,
John

PS: We have time-saving checklists that can tell you where your
proposed innovative new anti-spam solution has failed before.

---

From: Doug Royer <[email-masked]>
Date: Tue, 7 Apr 2020 15:46:19 -0600

On 4/7/20 3:37 PM, John Levine wrote:
> at Microsoft's hosted mail service. 

And gmail, and Thunderbird, and I am betting more.

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 08 Apr 2020 10:33:31 +1000

> I wish there was an IMAP way that clients and servers would use shared filters.

Obviously there's SIEVE, but that's not being used by a lot of sites. We're looking at building a basic filtering language into JMAP which can be converted to the types of filters that most sites use.

Regards,

Bron.

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]