Subject: Re: Protecting Copyright.

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 30 Apr 2020 17:48:36 +0200

Hello Khaled,

This happens in IETF when the WG chair is not engaging the work with wg
participants. IMO the WG chair is the one to communicate with and to check
with or the AD. Overall it is healthy to share ideas/comments and to
acknowledge them.

My comments below [AB],

From: ietf <[email-masked]> <&lt;[email-masked]&gt;> On
Behalf Of Khaled Omar
Sent: 28 April 2020 16:35
To: [email-masked]
Subject: Protecting Copyright.

>Hi all,

>I would like to ask why ideas submitted into ietf drafts are applied without a notice to the draft authors ?!!!

[AB] that should not happen,

>Before NEP ID, there was no IGP uses a composite metric such as NEP uses, and now I can see that cisco added a third factor to its eigrp metric calculation (they call it K6) and became as NEP ID.

[AB] I did not understand, however, ideas can be used but always must
be acknowledged, but still most ietf culture still leave
acknowledgement to authors only and not the WG. That IMHO is wrong and
hopefully the culture changes to be more open to all and more social.

>The funny thing is that during NEP presentation at the ietf meeting someone from cisco asked "what are the benefits to add this factor to the metric", and then you see this factor added to their IGP.

>Actually, I received no notice from cisco before applying such thing to their IGP.

>Can someone tells me what this means or what to call this?

[AB] May call it bad situation or bad working-groupings. Some IETF WG
are having groups inside the main WG, which is not healthy. There is a
possibility of using the idea without copying, because may be no
direct input to the draft or WG. I once complained about authors not
acknowledging WG participants influenced a change to draft, and I
still think it is not right to use reviewer comments without
acknowledging.

Best Regards

AB

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Apr 2020 16:07:23 +0000

Hi AB,

> This happens in IETF when the WG chair is not engaging the work with wg participants

The issue is that WG chairs are not welcoming my drafts and they act like this ID is not related to my work area ☺ and you find someone copied and applied without a notice.

No discussion, no comments, only criticism, actually I use the ietf as a scientific journal, to publish my ideas, and they even don’t grant protection to the copyright in their journal ☺

Khaled Omar

From: Abdussalam Baryun <[email-masked]>
Sent: Thursday, April 30, 2020 5:49 PM
To: [email-masked]
Cc: ietf <[email-masked]>
Subject: Re: Protecting Copyright.

Hello Khaled,

This happens in IETF when the WG chair is not engaging the work with wg participants. IMO the WG chair is the one to communicate with and to check with or the AD. Overall it is healthy to share ideas/comments and to acknowledge them.

My comments below [AB],

From: ietf <[email-masked]><mailto:&lt;[email-masked]&gt;> On Behalf Of Khaled Omar

To: [email-masked]<mailto:[email-masked]>

>Before NEP ID, there was no IGP uses a composite metric such as NEP uses, and now I can see that cisco added a third factor to its eigrp metric calculation (they call it K6) and became as NEP ID.

[AB] I did not understand, however, ideas can be used but always must be acknowledged, but still most ietf culture still leave acknowledgement to authors only and not the WG. That IMHO is wrong and hopefully the culture changes to be more open to all and more social.

>Can someone tells me what this means or what to call this?

[AB] May call it bad situation or bad working-groupings. Some IETF WG are having groups inside the main WG, which is not healthy. There is a possibility of using the idea without copying, because may be no direct input to the draft or WG. I once complained about authors not acknowledging WG participants influenced a change to draft, and I still think it is not right to use reviewer comments without acknowledging.

Best Regards

AB

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 30 Apr 2020 16:13:34 +0000

*   No discussion, no comments, only criticism, actually I use the ietf as a scientific journal, to publish my ideas …

Then you are using it wrong.  That is not the way the IETF intends for its drafts to be used.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Apr 2020 16:17:07 +0000

I cannot force someone to discuss, give comments, make a review to my drafts … IETF main members should take the initiative at least in supporting a specific idea.

From: Salz, Rich <[email-masked]>
Sent: Thursday, April 30, 2020 6:14 PM
To: Khaled Omar <[email-masked]>
Cc: ietf <[email-masked]>
Subject: Re: Protecting Copyright.

Ø  No discussion, no comments, only criticism, actually I use the ietf as a scientific journal, to publish my ideas …

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 30 Apr 2020 16:35:18 +0000

>The issue is that WG chairs are not welcoming my drafts and they act like this ID is not related to my work area ☺ and you find someone copied and applied without a notice.
 
Are you expecting the WG chairs to be aware if some organization outside of IETF is using your idea without notice (or even using your idea *with* a notice)????

Regards,

Christer

 
Hello Khaled,

My comments below [AB],

From: ietf mailto:&lt;[email-masked]&gt; On Behalf Of Khaled Omar
Sent: 28 April 2020 16:35
To: mailto:[email-masked]
Subject: Protecting Copyright.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Apr 2020 16:45:22 +0000

This not what I meant, I mean that my drafts didn't get space inside the corresponding wg, I tried to contact the area directors and chairs but almost nothing received, drafts are only submitted to the ietf, and if they will be presented at any meeting, that would be the maximum thing happened.

Khaled Omar

-----Original Message-----
From: Christer Holmberg <[email-masked]> 
Sent: Thursday, April 30, 2020 6:35 PM
To: Khaled Omar <[email-masked]>; Abdussalam Baryun <[email-masked]>
Cc: ietf <[email-masked]>
Subject: Re: Protecting Copyright.

Regards,

Christer

 
Hello Khaled,

My comments below [AB],

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 30 Apr 2020 19:09:45 +0200

On Thu, Apr 30, 2020 at 6:45 PM Khaled Omar <[email-masked]>
wrote:

> This not what I meant, I mean that my drafts didn't get space inside the
> corresponding wg, I tried to contact the area directors and chairs but
> almost nothing received, drafts are only submitted to the ietf, and if they
> will be presented at any meeting, that would be the maximum thing happened.
>

That is how IETF operates ... it is extremely hard regardless if you have
brilliant idea or not to get through IETF standards process if you do not
have big vendors behind you willing to implement it and back it up along
the process. Especially in the networking space.

IETF will not fight for you - neither chairs nor ADs.

And as far as others using your idea - that normal - even without any acks.
I have had many cases where some ideas were used without any credit, but
that is what you need to realize by publishing your document. IETF will not
fight for protecting your rights. Quite frankly to progress the document in
iETF it better be open for free implementation by anyone.

And normally you protect your rights to the idea by patenting it and
disclosing such IPR as early in the process as possible.

Best,
R,.

---

From: Joseph Touch <[email-masked]>
Date: Thu, 30 Apr 2020 10:26:01 -0700

> On Apr 30, 2020, at 9:17 AM, Khaled Omar <[email-masked]> wrote:
> 
> I cannot force someone to discuss, give comments, make a review to my drafts

Nor can a WG chair. We don’t work for you or the IETF. We work for our employers and review what we and they find interesting and relevant.

If you don’t get reviews, you ARE getting feedback.

NB: besides writing drafts that address issues the WG cares about in ways they find useful, it also helps to provide substantive reviews of other drafts. The IETF is a two-way street.

Joe

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Apr 2020 17:27:56 +0000

> IETF will not fight for you - neither chairs nor ADs.

If they will not fight for me then at least they don’t fight against me.

From: Robert Raszuk <[email-masked]>
Sent: Thursday, April 30, 2020 7:10 PM
To: Khaled Omar <[email-masked]>
Cc: Christer Holmberg <[email-masked]>; Abdussalam Baryun <[email-masked]>; ietf <[email-masked]>
Subject: Re: Protecting Copyright.

On Thu, Apr 30, 2020 at 6:45 PM Khaled Omar <[email-masked]<mailto:[email-masked]>> wrote:
This not what I meant, I mean that my drafts didn't get space inside the corresponding wg, I tried to contact the area directors and chairs but almost nothing received, drafts are only submitted to the ietf, and if they will be presented at any meeting, that would be the maximum thing happened.

That is how IETF operates ... it is extremely hard regardless if you have brilliant idea or not to get through IETF standards process if you do not have big vendors behind you willing to implement it and back it up along the process. Especially in the networking space.

And as far as others using your idea - that normal - even without any acks. I have had many cases where some ideas were used without any credit, but that is what you need to realize by publishing your document. IETF will not fight for protecting your rights. Quite frankly to progress the document in iETF it better be open for free implementation by anyone.

And normally you protect your rights to the idea by patenting it and disclosing such IPR as early in the process as possible.

Best,
R,.

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 30 Apr 2020 20:52:04 +0100

I like the way Joe phrases…

> If you don’t get reviews, you ARE getting feedback.

Another way to look at that is that it is your job to interest people in your work. 

If the Abstract of your draft and the emails to relevant mailing lists aren’t enough then perhaps people don’t have enough time or simply aren’t interested.

Of course, a way to raise you profile and so incentivise people to read your work is for you to spend time constructively reviewing and contributing to the work of the IETF.

Enjoy.

Adrian

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Apr 2020 20:30:18 +0000

> Another way to look at that is that it is your job to interest people in your work.

People are interested, and the evidence is that some are applying my work, but they are not free enough to express their interest.

Khaled Omar
6th of October City, Egypt
@Eng_Khaled Omar

From: Adrian Farrel <[email-masked]>
Sent: Thursday, April 30, 2020 9:52 PM
To: 'Joseph Touch' <[email-masked]>; 'Khaled Omar' <[email-masked]>
Cc: 'ietf' <[email-masked]>
Subject: RE: Protecting Copyright.

Enjoy.
Adrian

---

From: John C Klensin <[email-masked]>
Date: Thu, 30 Apr 2020 16:37:57 -0400

--On Thursday, April 30, 2020 16:17 +0000 Khaled Omar
<[email-masked]> wrote:

> I cannot force someone to discuss, give comments, make a
> review to my drafts … IETF main members should take the
> initiative at least in supporting a specific idea.

As you have been told several times before and by multiple
people (both on and off list), the fact that the IETF does not
prevent you from posting I-Ds that you want to treat as a
"scientific journal, to publish my ideas" does not given you any
"rights" to have the IETF community (including WG Chairs and
ADs) pay any attention to, much less comment on,  those ideas.
Equally important, you can reasonably assume that the silence
you are getting about the substance of your ideas actually is,
as others have tried to point out, a comment by the community on
those ideas... a comment that those who do not respond are not
(for whatever reason) particularly interested.

There is, at least IMO, a big difference between our I-D system
and discussion lists and a scientific journal.  The IETF system
is intended primarily for ideas that people would like to see
evolve into freely-available consensus standards or other
documents that will get IETF community consensus.  Our IPR rules
(including both copyright and patent), which have been
extensively discussed on this thread, were developed around that
objective, one that includes sharing of ideas.  There are
consequently few restrictions on posting I-Ds other than
agreement to a few requirements that are consistent with those
goals -- precisely the requirements to which you agreed when the
I-D was posted and about which you are now complaining.

For scientific journals, at least those I've submitted papers
to, served on editorial boards of, etc., things are very
different.  Submitting an article does not guarantee that it
will be posted or published.  It does guarantee a response, but
that response could be just a note from a staff member that the
journal is not interested in the type of material the submission
represents.   If it gets further then that, you would at least
get a review or two or more, but, if the reviewers don't like
the article (for whatever reason makes sense to that journal)
your getting reviews does not guarantee publication either.  If
it is published, you have no guarantee that anyone will read it,
much less respond (in that respect, similar to the IETF).  And
your writing a nasty letter to the editor complaining that no
one has given you the useful feedback to which you think you are
entitled might have the effect of getting all future papers from
you that are submitted to that journal rejected.

Neither system is perfect, but you more or less have a choice...
and criticizing part of one system for not being more like parts
of the other is not, IMO, likely to get you very far.  

I am trying carefully to not tell you what to do and I am not
speaking for the IETF, but I suggest, personally, that reading
and understanding the above might help you... at least help you
understand why you have gotten some of the other responses you
have gotten.

regards,
  john

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 30 Apr 2020 21:42:42 +0100

>> Another way to look at that is that it is your job to

>> interest people in your work.

> People are interested, and the evidence is that some are

> applying my work, but they are not free enough to express

> their interest.

Well, that may good enough. If the people who are interested are applying your work, then perhaps everything is fine and you need go no further.

If, on the other hand, you are determined to make progress in the IETF then I should qualify my statement as…

Another way to look at that is that it is your job to interest people in your work and have them demonstrate their interest within the IETF by discussing and contributing to you work on the public IETF mailing lists.

Ciao,
Adrian

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Apr 2020 21:01:19 +0000

> And your writing a nasty letter to the editor complaining that no one has given you the useful feedback to which you think you are entitled might have the effect of getting all future papers from you that are submitted to that journal rejected.

No comment.

Khaled Omar

-----Original Message-----
From: John C Klensin <[email-masked]> 
Sent: Thursday, April 30, 2020 10:38 PM
To: Khaled Omar <[email-masked]>; Salz, Rich <[email-masked]>
Cc: ietf <[email-masked]>
Subject: RE: Protecting Copyright.

--On Thursday, April 30, 2020 16:17 +0000 Khaled Omar <[email-masked]> wrote:

> I cannot force someone to discuss, give comments, make a review to my 
> drafts … IETF main members should take the initiative at least in 
> supporting a specific idea.

As you have been told several times before and by multiple people (both on and off list), the fact that the IETF does not prevent you from posting I-Ds that you want to treat as a "scientific journal, to publish my ideas" does not given you any "rights" to have the IETF community (including WG Chairs and
ADs) pay any attention to, much less comment on,  those ideas.
Equally important, you can reasonably assume that the silence you are getting about the substance of your ideas actually is, as others have tried to point out, a comment by the community on those ideas... a comment that those who do not respond are not (for whatever reason) particularly interested.

There is, at least IMO, a big difference between our I-D system and discussion lists and a scientific journal.  The IETF system is intended primarily for ideas that people would like to see evolve into freely-available consensus standards or other documents that will get IETF community consensus.  Our IPR rules (including both copyright and patent), which have been extensively discussed on this thread, were developed around that objective, one that includes sharing of ideas.  There are consequently few restrictions on posting I-Ds other than agreement to a few requirements that are consistent with those goals -- precisely the requirements to which you agreed when the I-D was posted and about which you are now complaining.

For scientific journals, at least those I've submitted papers to, served on editorial boards of, etc., things are very different.  Submitting an article does not guarantee that it will be posted or published.  It does guarantee a response, but that response could be just a note from a staff member that the journal is not interested in the type of material the submission
represents.   If it gets further then that, you would at least
get a review or two or more, but, if the reviewers don't like the article (for whatever reason makes sense to that journal) your getting reviews does not guarantee publication either.  If it is published, you have no guarantee that anyone will read it, much less respond (in that respect, similar to the IETF).  And your writing a nasty letter to the editor complaining that no one has given you the useful feedback to which you think you are entitled might have the effect of getting all future papers from you that are submitted to that journal rejected.

Neither system is perfect, but you more or less have a choice...
and criticizing part of one system for not being more like parts of the other is not, IMO, likely to get you very far.  

I am trying carefully to not tell you what to do and I am not speaking for the IETF, but I suggest, personally, that reading and understanding the above might help you... at least help you understand why you have gotten some of the other responses you have gotten.

regards,
  john

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Apr 2020 21:09:26 +0000

> Well, that may good enough. If the people who are interested are applying your work, then perhaps everything is fine and you need go no further.

Yes, but something is missing, my acknowledgment, ideas and IDs posted to the IETF are not a matter of volunteering, it sounds like you go to a market and find something you like, then taking it and leave, so what is the responsibility of the market management !!! what are the benefits of the rules people are making.

But what is weird, is that you take something from the market, and before taking it you say “it is very bad”, and eventually you hide it on your pocket and leave :D and what is more funny is that some other people in the market are saying “yes, very bad product”, and they are watching that person hiding the product in the his pocket.

Khaled Omar

From: Adrian Farrel <[email-masked]>
Sent: Thursday, April 30, 2020 10:43 PM
To: 'Khaled Omar' <[email-masked]>; 'Joseph Touch' <[email-masked]>
Cc: 'ietf' <[email-masked]>
Subject: RE: Protecting Copyright.

Ciao,
Adrian

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 30 Apr 2020 22:17:20 +0000

*   Yes, but something is missing, my acknowledgment, ideas and IDs posted to the IETF are not a matter of volunteering

Yes it is.  Your analogies are flawed.  You agreed to follow the IETF rules, not some marketplace or journal, when you wrote and posted a draft.

---

From: Khaled Omar <[email-masked]>
Date: Thu, 30 Apr 2020 22:31:19 +0000

So let’s make it clear, one of the ietf rules is to use and apply the contents of any ID without any acknowledgment from either the author or the ietf.

Khaled Omar

From: Salz, Rich <[email-masked]>
Sent: Friday, May 1, 2020 12:17 AM
To: Khaled Omar <[email-masked]>; [email-masked]; 'Joseph Touch' <[email-masked]>
Cc: 'ietf' <[email-masked]>
Subject: Re: Protecting Copyright.

Ø  Yes, but something is missing, my acknowledgment, ideas and IDs posted to the IETF are not a matter of volunteering

---

From: S Moonesamy <[email-masked]>
Date: Thu, 30 Apr 2020 17:36:13 -0700

Hi Khaled,
At 09:07 AM 30-04-2020, Khaled Omar wrote:
>No discussion, no comments, only criticism, actually I use the ietf 
>as a scientific journal, to publish my ideas, and they even don't 
>grant protection to the copyright in their journal J

In my opinion, the IETF RFCs are not the equivalent of a scientific 
journal.  If I have some exclusive legal right on, for example, a 
book, it is up to me to see how to protect those rights.  I don't 
view it as workable for an IETF entity to evaluate who should be 
acknowledged in a RFC as it entails tracking all the persons 
contributing to the work.

I assume that the meaning of word "criticism" is: the act of 
expressing disapproval about an Internet-Draft.  It takes some effort 
to write a review.  The intent of that effort is (for me) to give my 
opinion about what I read.  There may be a defect in some part of the 
Internet-Draft.  That does not mean that I disapprove of the 
Internet-Draft; a defect can be fixed.

I don't know your level of expertise.  It is likely better than mine 
as the topic(s) which you write about is not the one I usually work 
on.  However, I do have some experience in catching the usual 
mistakes in an Internet-Draft as other persons on this mailing list 
have pointed them out to me.  It can be difficult at first.  After a 
while, it is, in my opinion, useful experience.

One of the things I learned over the years is that there are people 
on this mailing list will give credit where credit is due.  It can be 
a token of appreciation and/or it can be for attribution.

Regards,
S. Moonesamy

---

From: Khaled Omar <[email-masked]>
Date: Fri, 1 May 2020 01:07:06 +0000

Hi Moonesamy,

> In my opinion, the IETF RFCs are not the equivalent of a scientific journal.  If I have some exclusive legal right on, for example, a book, it is up to me to see how to protect those rights.  I don't view it as workable for an IETF entity to evaluate who should be acknowledged in a RFC as it entails tracking all the persons contributing to the work.

I think the only difference is that RFCs are promoted IDs to be standards, this gives the permission to those who are interested to apply it the same way, and for sure they will earn from it, so this doesn't means to apply the contents without permission (or acknowledgment or agreement) between the authors (or developers) and the interested parties.

For your example, the book, you still have the right to either stop, share the profit (if there is a rpofit), or don't care (keep silence and continue watching) if some parties used your book for their personal investment if the "same" book is copied to protect your own rights.

> I assume that the meaning of word "criticism" is: the act of expressing disapproval about an Internet-Draft.  It takes some effort to write a review.  The intent of that effort is (for me) to give my opinion about what I read.  There may be a defect in some part of the Internet-Draft.  That does not mean that I disapprove of the Internet-Draft; a defect can be fixed.

Any kind of contribution should be valued when the ID reaches the best form and becomes a standard as long as all defects (if there are) will be fixed, and if you will ask about it, no one can blame you, it is your right.

> I don't know your level of expertise.  It is likely better than mine as the topic(s) which you write about is not the one I usually work on.  However, I do have some experience in catching the usual mistakes in an Internet-Draft as other persons on this mailing list have pointed them out to me.  It can be difficult at first.  After a while, it is, in my opinion, useful experience.

I cannot say I've better expertise than yours as long as I don't know you or your experience, but regarding mistakes, it is our human nature, we do mistakes and the best of us are those who learn from mistakes and never do it again (it is on our beliefs, when you do a sin, and for sure all of us do sins, then ask God for forgiveness, and we don't do it again, this guarantees the removal of this sin as it was never happened), regarding feeling it is difficult at first, it depends on the person, for me, I appreciate it if the correction is really right, or I will be stupid if I will have arrogance and not to accept it and accept to be stupid :-)

> One of the things I learned over the years is that there are people on this mailing list will give credit where credit is due.  It can be a token of appreciation and/or it can be for attribution.

Yes, this is a sure thing, because it is a matter of rights.

Khaled Omar

-----Original Message-----
From: S Moonesamy <[email-masked]> 
Sent: Friday, May 1, 2020 2:36 AM
To: Khaled Omar <[email-masked]>; [email-masked]
Cc: Abdussalam Baryun <[email-masked]>
Subject: RE: Protecting Copyright.

Hi Khaled,
At 09:07 AM 30-04-2020, Khaled Omar wrote:
>No discussion, no comments, only criticism, actually I use the ietf as 
>a scientific journal, to publish my ideas, and they even don't grant 
>protection to the copyright in their journal J

In my opinion, the IETF RFCs are not the equivalent of a scientific journal.  If I have some exclusive legal right on, for example, a book, it is up to me to see how to protect those rights.  I don't view it as workable for an IETF entity to evaluate who should be acknowledged in a RFC as it entails tracking all the persons contributing to the work.

I assume that the meaning of word "criticism" is: the act of expressing disapproval about an Internet-Draft.  It takes some effort to write a review.  The intent of that effort is (for me) to give my opinion about what I read.  There may be a defect in some part of the Internet-Draft.  That does not mean that I disapprove of the Internet-Draft; a defect can be fixed.

I don't know your level of expertise.  It is likely better than mine as the topic(s) which you write about is not the one I usually work on.  However, I do have some experience in catching the usual mistakes in an Internet-Draft as other persons on this mailing list have pointed them out to me.  It can be difficult at first.  After a while, it is, in my opinion, useful experience.

One of the things I learned over the years is that there are people on this mailing list will give credit where credit is due.  It can be a token of appreciation and/or it can be for attribution.

Regards,
S. Moonesamy

---

From: S Moonesamy <[email-masked]>
Date: Thu, 30 Apr 2020 21:18:25 -0700

Hi Khaled,
At 06:07 PM 30-04-2020, Khaled Omar wrote:
>I think the only difference is that RFCs are promoted IDs to be 
>standards, this gives the permission to those who are interested to 
>apply it the same way, and for sure they will earn from it, so this 
>doesn't means to apply the contents without permission (or 
>acknowledgment or agreement) between the authors (or developers) and 
>the interested parties.

The license which is applicable for an IETF RFC is the same as the 
one for an I-D.  There isn't any requirement to seek 
permission.  That does not mean that a person can blindly copy parts 
of the work.  It is considered as dishonest, in some venues, to 
represent the work of another person as your own work.  The law can 
be invoked if the interested parties cannot reach an agreement on 
whether there should be an acknowledgement.  There are other ways to 
protect the idea, e.g. patents were mentioned on the thread.  It is 
the responsibility of the party who "owns" the work to ensure that 
the work will be protected as the party wishes.

>For your example, the book, you still have the right to either stop, 
>share the profit (if there is a rpofit), or don't care (keep silence 
>and continue watching) if some parties used your book for their 
>personal investment if the "same" book is copied to protect your own rights.

Yes.  It is different for IETF specifications as they are published 
so that anyone out there can implement those specifications.  It 
would not be a good idea, in my opinion, to copy them without, for 
example, the copyright notice.  Commenting on whether I would be 
silent if someone copies my book, I would say that it depends on the situation.

>Any kind of contribution should be valued when the ID reaches the 
>best form and becomes a standard as long as all defects (if there 
>are) will be fixed, and if you will ask about it, no one can blame 
>you, it is your right.

Ok.

>I cannot say I've better expertise than yours as long as I don't 
>know you or your experience, but regarding mistakes, it is our human 
>nature, we do mistakes and the best of us are those who learn from 
>mistakes and never do it again (it is on our beliefs, when you do a 
>sin, and for sure all of us do sins, then ask God for forgiveness, 
>and we don't do it again, this guarantees the removal of this sin as 
>it was never happened), regarding feeling it is difficult at first, 
>it depends on the person, for me, I appreciate it if the correction 
>is really right, or I will be stupid if I will have arrogance and 
>not to accept it and accept to be stupid :-)

Ok.

Regards,
S. Moonesamy