Subject: Re: [tlp-interest] Proposed Policy on Rights in IANA Parameter Registry Data

From: Timothy Mcsweeney <[email-masked]>
Date: Mon, 21 Sep 2020 19:47:40 -0400 (EDT)

Hi Glenn,

>Especially when you consider that so far not a single reason has been raised against the proposed action.

Allow me to be the first.

Attempting to wipe away someone copyrights by merely saying so seems a bit agressive to me.  Then to not give others a informed opportunity to open source or license those copyrights before the change is made seems even more aggressive.  But to give away someones copyrights to the general public without even attempted contact seems to me, most agessive.  Aren't the people in those registries your customers?  I have copywritten material on those registries and I was nt under any obligation to give up copyrights when a submission was made, nor am I in any particular hurry to do so.  Or perhaps this is just for submissions going forward, is that right?

It's interesting to me to see the support for this before the the lawyers finalize the language.  Things can, and usually do, change drastically after lawyers get involved.  Wouldn't it be better for everyone to see the final product first?  One of the things that really jumps out at me is where is says that this new policy...:

Must ensure that any text that may be considered as copyrighted,
including that from an RFC or another document, is included so
that there is no ambiguity.
<tools.ietf.org/html/draft-halpern-trust-ianapolicy-00>

>Eyeballs are welcome, but the hope/expectation was that between the IETF lists and the IANA group that would cover enough distribution channels and >have them share with anyone they felt needed to review it such as company attorneys etc. .

I will do my best to get you some more eyeballs.

Tim

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 22 Sep 2020 01:01:08 +0000

> I have copywritten material on those registries and I was nt under any obligation to give up copyrights when a submission was made
I do not think is correct, for at least two reasons:

  1.  It is unlikely that the text in an IANA registry is anything other than “de minimus” and therefor not copyrightable
  2.  You seem to be ignoring the implied compilation copyright that IANA has on the collection of registry items
  3.  If the registry entry came from an RFC (which I tend to doubt yours did), then the copyright is the IETF LLC
Can you point out which specific content in the registry is yours?

---

From: "John R. Levine" <[email-masked]>
Date: 21 Sep 2020 21:06:28 -0400

On Mon, 21 Sep 2020, Timothy Mcsweeney wrote:
> Attempting to wipe away someone copyrights by merely saying so seems a 
> bit agressive to me. ...

Please review Joel's draft.  We do not believe the protocol parameters are 
subject to copyright, and this just makes that clearer.  There is nothing 
to "wipe away".

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Dick Franks <[email-masked]>
Date: Tue, 22 Sep 2020 03:10:38 +0100

On Tue, 22 Sep 2020 at 00:47, Timothy Mcsweeney <[email-masked]> wrote:

> Attempting to wipe away someone copyrights by merely saying so seems a bit
> agressive to me.  Then to not give others a informed opportunity to open
> source or license those copyrights before the change is made seems even
> more aggressive.  But to give away someones copyrights to the general
> public without even attempted contact seems to me, most agessive.  Aren't
> the people in those registries your customers?  I have copywritten material
> on those registries and I was nt under any obligation to give up copyrights
> when a submission was made, nor am I in any particular hurry to do so.  Or
> perhaps this is just for submissions going forward, is that right?
>

Protocol registries are analogous to telephone directories.
The US Supreme Court held that white page directories are not entitled to
copyright, overturning the decisions of the District Court and Court of
Appeals.

*Feist Publications, Incorporated v. Rural Telephone Service Company,
Incorporated*, 499 U.S. 340 (1991).

---

From: Timothy Mcsweeney <[email-masked]>
Date: Mon, 21 Sep 2020 22:30:25 -0400 (EDT)

Hi John,

>Please review Joel's draft.

I already quoted text from it.  I also have a problem with this statement from Joel's draft:

"In addition some of the protocol parameter registries include text
snippets, some from RFCs or other documents, that could be considered
copyrighted and the existence of this text should not be allowed to
cause a problem."

Some may try to tell me that I'm reading that wrong but it says what it says.