Subject: is last-call working the way the IESG intended?

From: Michael Richardson <[email-masked]>
Date: Tue, 16 Mar 2021 16:20:39 -0400

There has been a very long thread on last-call about the crocker draft on
email emojis.  I'm now seeing the secdir review of
draft-ietf-ecrit-location-profile-registry-policy-01 and subsequent thread
related to that.  (Not yet as long as emoji)

Now, I think that the crocker draft was AD sponsored so maybe it didn't have
another place for the thread to go.  But, certain draft-ietf-ecrit should
go back to ecrit list only?

I'm just wondering if last-call is working the way it was imagined it would,
or if there are some anomalies here.   Should some kind of Reply-To: be enforced?

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 17 Mar 2021 09:46:33 +1300

> or if there are some anomalies here.   Should some kind of Reply-To: be enforced?

The WG should certainly be CCed but the whole point of IETF LC is to expose
the draft to the whole IETF to look for gotchas. So no, I don't see a problem.
Email is cheap, and easy to delete unread.

But... I do sort all last call traffic into a dedicated inbox, which makes
ignoring it very easy. This morning I see 13 unread messages in that inbox.
[pause]
It took me about 90 seconds to clear that inbox. Ten of the messages were
about drafts of no interest to me - deleted. One  was a reply to my own
comment on a particular draft - read & saved. Two others were trivia about
the same draft - deleted. It took longer to write this message than to clear
that inbox. So I still don't see a problem.

    Brian

---

From: tom petch <[email-masked]>
Date: Wed, 17 Mar 2021 11:22:17 +0000

> that inbox. So I still don't see a problem.

I have a problem when the specialist reviews take place months, or 
years, before Last Call so I would like a gate that the discussion 
cannot appear on the Last Call list until a Last Call has been announced 
by the IESG.  This is a regular problem with YANG doctor reviews, which 
WG Chairs often ask for at an early stage, but I see it too with 
Security Reviews and, perhaps, Transport, congestion-related.

My take is that these topics are ones where some think that the WG lack 
the expertise and so call in the specialists at an early stage, which is 
fine but does not need to clutter up the Last Call list.

Tom Petch

---

From: Lars Eggert <[email-masked]>
Date: Mon, 29 Mar 2021 15:10:45 +0300

Hi Michael,

> go back to ecrit list only?

both of these threads were on Last Call reviews, and so the last-call mailing list is an appropriate home for them.

I'll also note that he discussion on draft-ietf-ecrit-location-profile-registry-policy-01 was CC'ed to the ecrit WG, so you could set up your mail filter to move those into your ecrit mail folder instead of the last-call folder, should you prefer that.

> or if there are some anomalies here.   Should some kind of Reply-To: be enforced?

We discussed this in the IESG, and we believe that the last-call mailing list is working as intended. I'll note that there was a lengthy discussion (https://mailarchive.ietf.org/arch/msg/ietf/1Jum0QW3b6AATJXF31P3g7IpUF4/) six months after the last-call experiment started that seemed to indicate that the community agrees with that assessment.

Looking back at the mail archives, I noticed that the email establishing the last-call experiment (https://mailarchive.ietf.org/arch/msg/ietf/LiB_dlvv3ZFlTF8hGp7GbGngqSg/) suggested two actions in the case that the experiment concluded successfully, which seem to have not been implemented yet:

1. update BCP 45 to formally move the location for last-call discussions (https://datatracker.ietf.org/doc/rfc3005/)

2. update the 2007 IESG Statement on Last Call Guidance (https://www.ietf.org/about/groups/iesg/statements/last-call-guidance/)

I've started an individual draft on the fist item (https://datatracker.ietf.org/doc/draft-eggert-bcp45bis/), and we'll discuss the second item in the IESG.

Thanks,
Lars Eggert
IETF Chair

---

From: "Bron Gondwana" <[email-masked]>
Date: Tue, 30 Mar 2021 08:44:21 +1100

> I've started an individual draft on the fist item (https://datatracker.ietf.org/doc/draft-eggert-bcp45bis/), and we'll discuss the second item in the IESG.

Thanks Lars.

As one of the moderators for the list, I've found it very light work.  I skim all the threads to make sure they're staying on topic, and so far everything has.  There hasn't been any misbehaviour.  draft-crocker certainly lead to one of the longest discussions but despite being full of quite strongly held and stated opinions, it did appear to stay on the topic of the draft.

I find the last-call list to be useful myself because it separates the last-call discussions from other general topics - and since last-call is a decent fraction of the ietf-wide work, it's handy regardless of whether you want to focus on the last-call work, or focus on the other.  I file it into a separate mailbox.

Cheers,

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]