Subject: Propose opensource standard for a PDL (printer driver)

From: Sid <[email-masked]>
Date: Sun, 28 Mar 2021 11:46:12 +0200

The topic for an opensource PDL (Page Description Language) standard for printing that uses XML for vector graphics, raster compatibilities, and vector text that is backward compatible with ASCII. Raster or text outputs can simply pass through directly to a printer that can read those formats. If the resolution of a vector is higher than the printer can print, the printer instruction is scaled down to that resolution.

Allows extensions for high resolution graphics depending on a printer's needs. Extensions could be to allow opensource implementations for existing PDL's, if licenses permit. Make it so existing printers can have basic text and perhaps simple vector capabilities through a generic driver. It not being dependent on an existing PDL, including through PPD's for Postscript conversions, except ASCII.

This opensource standard or its extensions can be used in conjunction with Postscript's PPD's, or PDL's by manufacturers for a printer's specific needs.

Uses its own XML style sheet format for border spacing, headers and footers. The page sizes, and desired edging space needs to be known by printers. The printer or output program can resize the text to fit within page boundaries. This can simplify the use of filters to prevent stair-stepping.

Uses IPP and perhaps allow passthrough to LPD.

Thank you

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Mon, 29 Mar 2021 18:01:16 -0400

This sounds like a possibly useful piece of work but not really in IETF
remit. W3C has the SVG experience, compression experience, etc.

As a practical matter, this use case seems to be adequately served by
proprietary standards that have become so widely used as to be ubiquitous.

What is missing from Portable Document Format (PDF), standardized as ISO
32000?

The big irritation I have with printer drivers is that they live in the
wrong damn place. Printer drivers should not require system privileges to
install. The application running on my local machine should be able to
discover the available printers, select one and negotiate an interchange
format with the printers.

Some of that is in IETF space (via Bonjour). But there doesn't seem to be
interest in the platform provider and printer provider world to make it
completely seamless yet.

On Sun, Mar 28, 2021 at 10:59 PM Sid <[email-masked]> wrote:

> The topic for an opensource PDL (Page Description Language) standard for
> printing that uses XML for vector graphics, raster compatibilities, and
> vector text that is backward compatible with ASCII. Raster or text outputs
> can simply pass through directly to a printer that can read those formats.
> If the resolution of a vector is higher than the printer can print, the
> printer instruction is scaled down to that resolution.
>
> Allows extensions for high resolution graphics depending on a printer's
> needs. Extensions could be to allow opensource implementations for existing
> PDL's, if licenses permit. Make it so existing printers can have basic text
> and perhaps simple vector capabilities through a generic driver. It not
> being dependent on an existing PDL, including through PPD's for Postscript
> conversions, except ASCII.
>
> This opensource standard or its extensions can be used in conjunction with
> Postscript's PPD's, or PDL's by manufacturers for a printer's specific
> needs.
>
> Uses its own XML style sheet format for border spacing, headers and
> footers. The page sizes, and desired edging space needs to be known by
> printers. The printer or output program can resize the text to fit within
> page boundaries. This can simplify the use of filters to prevent
> stair-stepping.
>

---

From: Larry Masinter <[email-masked]>
Date: Mon, 29 Mar 2021 15:44:35 -0700

RFC 8118. There are numerous implementations, many open source. Ghostscript, PDF.js for example. 

What the IETF  needs now, however, is a standard for “Archival SVG” that is, to SVG, what PDF/A is to PDF.

I had the idea that the bijection  SVG --> PDF/A --> SVG  would be one way, but Brian reported that the result wasn’t good.

--

 <https://LarryMasinter.net> https://LarryMasinter.net  <https://interlisp.org> https://interlisp.org

---

From: Sid <[email-masked]>
Date: Tue, 30 Mar 2021 11:13:45 +0200

Thank you for your responses!
 
W3C seems like the organization pertaining a lot to this subject. Some W3C standards aren't limited to the Internet as well.
 
I found epub as an open standard alternative to pdf, woff (standards track font format), a proposal for SVG fonts. XSL for a style sheet or something XML based like that would be good for printer border information. A lot of this could be used in a PDL. IPP for printing is also over the an Internet protocol. Some printers are even meant to work on LANs or an Intranet, which does mean it can be a topic for W3C.
 
Ghostscript, PPD and Guten print are opensource solutions on the software end, but they are centric around a proprietary PDL on the hardware end. XML would be preferred as a standard over Javascript. It would be nice if there were an opensource standard, which there's compatibility of any printer on that end that uses that standard. PDF which has an ISO standard is still also centric around Postscript. Archival formats for standards are always an interest.

> Phillip Hallam-Baker

> Larry Masinter