Subject: question: are the various IETF web sites IPv6 enabled? If not, why not?

From: "Baird, John M CTR OSD HPCMP (USA)" <[email-masked]>
Date: Tue, 9 Mar 2021 00:44:29 +0000

I apologize in advance if this question has already been discussed ad naseum, and would appreciate pointers to previous discussions of this topic.

John Baird
619-212-2573
Office: San Diego, CA
ASRC Federal Data Networx, LLC | Purpose Driven. Enduring Commitment.

---

From: Fred Baker <[email-masked]>
Date: Mon, 8 Mar 2021 18:41:34 -0800

It is my understanding that they all are, and have been for some time. I might suggest that you ping6 (or ping -6 depending on your OS) to see whether you get a response.

Sent using a machine that autocorrects in interesting ways...

> On Mar 8, 2021, at 6:34 PM, Baird, John M CTR OSD HPCMP (USA) <john.m.baird10.ctr=[email-masked]> wrote:
> 
>

---

From: "John Levine" <[email-masked]>
Date: 8 Mar 2021 22:30:53 -0500

In article <[email-masked]> you write:
>-=-=-=-=-=-

Yes, they all are.  The mail is, too.

R's,
John

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 9 Mar 2021 16:57:05 +1300

> Yes, they all are.  The mail is, too.

https://www.irtf.org/ too.
https://www.rfc-editor.org/ too.
https://www.internetsociety.org/ too.

The "six or not" FireFox extension tells me that the ISOC site invokes a couple of IPv4 services, so needs dual stack. The IETF site is clean in that regard.

   Brian

---

From: Viktor Dukhovni <[email-masked]>
Date: Mon, 8 Mar 2021 23:00:26 -0500

On Mon, Mar 08, 2021 at 10:30:53PM -0500, John Levine wrote:

> > It is my understanding that they all are, and have been for some
> > time. I might suggest that you ping6 (or ping -6 depending on your
> > OS) to see whether you get a response.
> 

Yep, working DANE TLSA RRs for both the IPv4 and IPv6 address.

    https://stats.dnssec-tools.org/explore/?ietf.org

-- 
    Viktor.

---

From: "Baird, John M CTR OSD HPCMP (USA)" <[email-masked]>
Date: Tue, 9 Mar 2021 20:43:11 +0000

Brian, 
Thanks for the quick response. You mention the Firefox "six or not" extension, and that is why I asked the question about IPv6 and IETF websites.

When I browse the websites you cited, and also https://tools.ietf.org, IPvFoo lists several IPv4 addresses, but makes no mention of any IPv6 addresses.

I can see the IPv6 addresses in DNS, but for some reason IPvFoo reports that the websites respond to web browsers only via IPv4.

Any theories as to why this is so?

John

-----Original Message-----
From: Brian E Carpenter <[email-masked]> 
Sent: Monday, March 8, 2021 10:57 PM
To: Baird, John M CTR OSD HPCMP (USA) <[email-masked]>
Cc: [email-masked]
Subject: [Non-DoD Source] Re: question: are the various IETF web sites IPv6 enabled? If not, why not?
----

On 09-Mar-21 16:30, John Levine wrote:
>> time. I might suggest that you ping6 (or ping -6 depending on your OS) to see whether you get a response.
> 

Caution-https://www.irtf.org/ too.
Caution-https://www.rfc-editor.org/ too.
Caution-https://www.internetsociety.org/ too.

   Brian

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Tue, 09 Mar 2021 21:58:44 +0100

There may be several reasons for that.

Right now, it comes to my mind:
1) Your upstream provider IPv6 connectivity is not able to reach the IETF upstream provider with IPv6.
2) The latency of IPv6 is higher than the IPv4 one.

In those cases, happy eyeballs will prefer IPv4 so you will get IPvfoo extension showing IPv4 as preferred, but if you click, you can still see both the IPv4 and IPv6 addresses as provided by the DNS resolution.

Unfortunately, I've seen way too many ISPs that don't monitor IPv6 with the same degree of quality as IPv4, they rely on customers complains which don't happen because happy eyeballs ...

Regards,
Jordi
@jordipalet

El 9/3/21 21:52, "ietf en nombre de Baird, John M CTR OSD HPCMP (USA)" <[email-masked] en nombre de john.m.baird10.ctr=[email-masked]> escribió:

    Brian, 

    John

    -----Original Message-----
    From: Brian E Carpenter <[email-masked]> 
    Sent: Monday, March 8, 2021 10:57 PM
    To: Baird, John M CTR OSD HPCMP (USA) <[email-masked]>
    Cc: [email-masked]
    Subject: [Non-DoD Source] Re: question: are the various IETF web sites IPv6 enabled? If not, why not?
    ----

       Brian

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Bob Hinden <[email-masked]>
Date: Tue, 9 Mar 2021 13:14:24 -0800

John,

When I go to https://tools.ietf.org I get a single IPv6 address.  See attached.

Bob

> On Mar 9, 2021, at 12:43 PM, Baird, John M CTR OSD HPCMP (USA) <john.m.baird10.ctr=[email-masked]> wrote:
> 
> Brian,

---

From: Matt Mathis <[email-masked]>
Date: Tue, 9 Mar 2021 15:07:44 -0800

Another possible reason is that your CPE (modem, home router, etc) doesn't
properly support IPv6, or isn't configured to do so.

It is taking a long time but we (US and europe) are approaching 50% IPv6.
See
https://www.google.com/intl/en/ipv6/statistics.html#tab=per-country-ipv6-adoption

If you are on net 26/8, you may have other issues as well.

Thanks,
--MM--
The best way to predict the future is to create it.  - Alan Kay

We must not tolerate intolerance;
       however our response must be carefully measured:
            too strong would be hypocritical and risks spiraling out of
control;
            too weak risks being mistaken for tacit approval.

On Tue, Mar 9, 2021 at 12:59 PM JORDI PALET MARTINEZ <jordi.palet=
[email-masked]> wrote:

> In those cases, happy eyeballs will prefer IPv4 so you will get IPvfoo
> extension showing IPv4 as preferred, but if you click, you can still see
> both the IPv4 and IPv6 addresses as provided by the DNS resolution.
>
> Unfortunately, I've seen way too many ISPs that don't monitor IPv6 with
> the same degree of quality as IPv4, they rely on customers complains which
> don't happen because happy eyeballs ...
>
> Regards,
> Jordi
> @jordipalet
>
>
>
> El 9/3/21 21:52, "ietf en nombre de Baird, John M CTR OSD HPCMP (USA)" <
> [email-masked] en nombre de john.m.baird10.ctr=
> [email-masked]> escribió:
>
>     Brian,
>     Thanks for the quick response. You mention the Firefox "six or not"
> extension, and that is why I asked the question about IPv6 and IETF
> websites.
>
>     When I browse the websites you cited, and also https://tools.ietf.org,
> IPvFoo lists several IPv4 addresses, but makes no mention of any IPv6
> addresses.
>
>     I can see the IPv6 addresses in DNS, but for some reason IPvFoo
> reports that the websites respond to web browsers only via IPv4.
>
>     The "six or not" FireFox extension tells me that the ISOC site invokes
> a couple of IPv4 services, so needs dual stack. The IETF site is clean in
> that regard.
>
>        Brian
>
>
>
>
> This electronic message contains information which may be privileged or
> confidential. The information is intended to be for the exclusive use of
> the individual(s) named above and further non-explicilty authorized
> disclosure, copying, distribution or use of the contents of this
> information, even if partially, including attached files, is strictly
> prohibited and will be considered a criminal offense. If you are not the
> intended recipient be aware that any disclosure, copying, distribution or
> use of the contents of this information, even if partially, including
> attached files, is strictly prohibited, will be considered a criminal
> offense, so you must reply to the original sender to inform about this
> communication and delete it.
>
>
>
>

---

From: "Baird, John M CTR OSD HPCMP (USA)" <[email-masked]>
Date: Wed, 10 Mar 2021 01:20:25 +0000

Matt,
I have done some more testing, and have found that when I am connected to the open Internet correctly (not via the VPN used by my office), many of the IETF sites are indeed IPv6 enabled.

However, https://www.irtf.org/  reports “no address” and https://www.rfc-editor.org/ reports “access denied”, so there are still some unexpected results.

Thanks for the feedback.
John
From: Matt Mathis <mattmathis=[email-masked]>
Sent: Tuesday, March 9, 2021 6:08 PM
To: Baird, John M CTR OSD HPCMP (USA) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Non-DoD Source] Re: question: are the various IETF web sites IPv6 enabled? If not, why not?

All active links contained in this email were disabled. Please verify the identity of the sender, and confirm the authenticity of all links contained within the message prior to copying and pasting the address to a Web browser.
________________________________

Another possible reason is that your CPE (modem, home router, etc) doesn't properly support IPv6, or isn't configured to do so.

It is taking a long time but we (US and europe) are approaching 50% IPv6.  See Caution-https://www.google.com/intl/en/ipv6/statistics.html#tab=per-country-ipv6-adoption < Caution-https://www.google.com/intl/en/ipv6/statistics.html#tab=per-country-ipv6-adoption >

Thanks,
--MM--

We must not tolerate intolerance;
       however our response must be carefully measured:
            too strong would be hypocritical and risks spiraling out of control;
            too weak risks being mistaken for tacit approval.

On Tue, Mar 9, 2021 at 12:59 PM JORDI PALET MARTINEZ <jordi.palet=[email-masked] < Caution-mailto:[email-masked] <mailto:jordi.palet=[email-masked] %3c Caution-mailto:[email-masked] > > > wrote:
There may be several reasons for that.

Regards,
Jordi
@jordipalet

El 9/3/21 21:52, "ietf en nombre de Baird, John M CTR OSD HPCMP (USA)" <[email-masked] < Caution-mailto:[email-masked] <mailto:[email-masked] %3c Caution-mailto:[email-masked] > >  en nombre de john.m.baird10.ctr=[email-masked]<mailto:john.m.baird10.ctr=[email-masked]> < Caution-mailto:[email-masked] > > escribió:

    Brian,

    When I browse the websites you cited, and also Caution-https://tools.ietf.org < Caution-https://tools.ietf.org > , IPvFoo lists several IPv4 addresses, but makes no mention of any IPv6 addresses.

    John

    -----Original Message-----
    From: Brian E Carpenter <[email-masked] < Caution-mailto:[email-masked] <mailto:[email-masked] %3c Caution-mailto:[email-masked] > > >
    Sent: Monday, March 8, 2021 10:57 PM
    To: Baird, John M CTR OSD HPCMP (USA) <[email-masked] < Caution-mailto:[email-masked] <mailto:[email-masked] %3c Caution-mailto:[email-masked] > > >
    Cc: [email-masked]<mailto:[email-masked]> < Caution-mailto:[email-masked] >
    Subject: [Non-DoD Source] Re: question: are the various IETF web sites IPv6 enabled? If not, why not?
    ----

    On 09-Mar-21 16:30, John Levine wrote:
    > In article <[email-masked] < Caution-mailto:[email-masked] <mailto:[email-masked] %3c Caution-mailto:[email-masked] > > > you write:
    >> -=-=-=-=-=-
    >>

    Caution-Caution-https://www.irtf.org/ < Caution-https://www.irtf.org/ >  too.
    Caution-Caution-https://www.rfc-editor.org/ < Caution-https://www.rfc-editor.org/ >  too.
    Caution-Caution-https://www.internetsociety.org/ < Caution-https://www.internetsociety.org/ >  too.

       Brian

**********************************************
IPv4 is over
Are you ready for the new Internet ?
Caution-http://www.theipv6company.com < Caution-http://www.theipv6company.com >
The IPv6 Company

---

From: "John Levine" <[email-masked]>
Date: 9 Mar 2021 21:56:41 -0500

>there are still some unexpected results.

My browser connects to both on native v6 without trouble.

R's,
John

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Wed, 10 Mar 2021 08:43:46 +0100

All work for me.

Some VPNs force all the traffic via the VPN and then the VPN is only IPv4 … that may explain it.

Also, you may be using DNS resolvers that aren’t providing the “correct” information.

Regards,

Jordi

@jordipalet

El 10/3/21 2:21, "ietf en nombre de Baird, John M CTR OSD HPCMP (USA)" <[email-masked] en nombre de john.m.baird10.ctr=[email-masked]> escribió:

Matt,

Thanks for the feedback.

John

Thanks,

--MM--

 

On Tue, Mar 9, 2021 at 12:59 PM JORDI PALET MARTINEZ <jordi.palet=[email-masked] < Caution-mailto:[email-masked] > > wrote:

Regards,
Jordi
@jordipalet

El 9/3/21 21:52, "ietf en nombre de Baird, John M CTR OSD HPCMP (USA)" <[email-masked] < Caution-mailto:[email-masked] >  en nombre de john.m.baird10.ctr=[email-masked] < Caution-mailto:[email-masked] > > escribió:

    Brian, 

    John

    -----Original Message-----
    From: Brian E Carpenter <[email-masked] < Caution-mailto:[email-masked] > > 
    Sent: Monday, March 8, 2021 10:57 PM
    To: Baird, John M CTR OSD HPCMP (USA) <[email-masked] < Caution-mailto:[email-masked] > >
    Cc: [email-masked] < Caution-mailto:[email-masked] > 
    Subject: [Non-DoD Source] Re: question: are the various IETF web sites IPv6 enabled? If not, why not?
    ----

    On 09-Mar-21 16:30, John Levine wrote:
    > In article <[email-masked] < Caution-mailto:[email-masked] > > you write:
    >> -=-=-=-=-=-
    >>

       Brian

---

From: Fernando Gont <[email-masked]>
Date: Wed, 10 Mar 2021 12:18:03 -0300

> IPv4 … that may explain it.

https://tools.ietf.org/html/rfc7359

Thanks,
-- 
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

---

From: "Baird, John M CTR OSD HPCMP (USA)" <[email-masked]>
Date: Wed, 10 Mar 2021 23:40:27 +0000

John,
You are right. It took a while, but I finally got the VPN on my computer completely disabled, and I could then access them via IPv6.

-----Original Message-----
From: John Levine <[email-masked]> 
Sent: Tuesday, March 9, 2021 9:57 PM
To: [email-masked]
Cc: Baird, John M CTR OSD HPCMP (USA) <[email-masked]>
Subject: Re: [Non-DoD Source] Re: question: are the various IETF web sites IPv6 enabled? If not, why not?

----

In article <[email-masked]> you write:
>However, https://www.irtf.org/  reports “no address” and 
>https://www.rfc-editor.org/ reports “access denied”, so there are still some unexpected results.

R's,
John