Subject: media casting cluster*

From: Michael Thomas <[email-masked]>
Date: Tue, 16 Mar 2021 13:55:12 -0700

If we built such a thing would they come? It's extremely frustrating 
that Apple, Google and Amazon all have different proprietary protocols 
to cast media from your phone or laptop to a tv or whatever. they all 
have interoperability problems because their petty business fueds, and 
for users it is a complete nightmare to try to figure out what is going 
wrong which happens way too often. Worst of all, is that since it's 
proprietary we have no clue what is happening under the hood and 
especially what is going on the security front. For example, if I were 
to cast at a public venue would I potentially be opening myself up to 
some sort of attack? Nobody but them knows and they aren't telling.

Mike

---

From: Tim Cappalli <[email-masked]>
Date: Tue, 16 Mar 2021 23:14:08 +0000

The DIAL protocol, used by Chromecast, is at least publicly documented: DIAL-2ndScreenProtocol-2.2.1.pdf (google.com)<https://docs.google.com/viewer?a=v&pid=sites&srcid=ZGlhbC1tdWx0aXNjcmVlbi5vcmd8ZGlhbHxneDo1MWVmNzNhZDUyYTI0YTkz>
________________________________
From: ietf <[email-masked]> on behalf of Michael Thomas <[email-masked]>
Sent: Tuesday, March 16, 2021 16:55
To: IETF Discussion Mailing List <[email-masked]>
Subject: media casting cluster*

Mike

---

From: Michael Thomas <[email-masked]>
Date: Tue, 16 Mar 2021 16:17:14 -0700

On 3/16/21 4:14 PM, Tim Cappalli wrote:
> The DIAL protocol, used by Chromecast, is at least publicly 
> documented: DIAL-2ndScreenProtocol-2.2.1.pdf (google.com) 
> <https://docs.google.com/viewer?a=v&pid=sites&srcid=ZGlhbC1tdWx0aXNjcmVlbi5vcmd8ZGlhbHxneDo1MWVmNzNhZDUyYTI0YTkz>

I've seen this before, and I'm pretty sure that it's not the whole 
story. Or maybe it's something more recent?

Mike

> ------------------------------------------------------------------------
> *From:* ietf <[email-masked]> on behalf of Michael Thomas 
> <[email-masked]>
> *Sent:* Tuesday, March 16, 2021 16:55
> *To:* IETF Discussion Mailing List <[email-masked]>
> *Subject:* media casting cluster*
>

---

From: Tim Cappalli <[email-masked]>
Date: Tue, 16 Mar 2021 23:18:30 +0000

Are you asking about content handoff (aka casting) or screen mirroring? They operate very differently.

DIAL is used for content handoff.
________________________________
From: Michael Thomas <[email-masked]>
Sent: Tuesday, March 16, 2021 19:17
To: Tim Cappalli <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: media casting cluster*

On 3/16/21 4:14 PM, Tim Cappalli wrote:
The DIAL protocol, used by Chromecast, is at least publicly documented: DIAL-2ndScreenProtocol-2.2.1.pdf (google.com)<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fviewer%3Fa%3Dv%26pid%3Dsites%26srcid%3DZGlhbC1tdWx0aXNjcmVlbi5vcmd8ZGlhbHxneDo1MWVmNzNhZDUyYTI0YTkz&data=04%7C01%7CTim.Cappalli%40microsoft.com%7Ca7253e10c6f1471f080908d8e8d1a42a%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637515334395551096%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=qxFW05hl3mEJLHcVK9vkuSb2RxfdO1HGxZiN%2FxVvIbM%3D&reserved=0>

I've seen this before, and I'm pretty sure that it's not the whole story. Or maybe it's something more recent?

Mike

________________________________
From: ietf <[email-masked]><mailto:[email-masked]> on behalf of Michael Thomas <[email-masked]><mailto:[email-masked]>
Sent: Tuesday, March 16, 2021 16:55
To: IETF Discussion Mailing List <[email-masked]><mailto:[email-masked]>
Subject: media casting cluster*

Mike

---

From: Michael Thomas <[email-masked]>
Date: Thu, 18 Mar 2021 12:59:36 -0700

On 3/16/21 4:18 PM, Tim Cappalli wrote:
> Are you asking about content handoff (aka casting) or screen 
> mirroring? They operate very differently.
>

I'm talking about casting, but really both could use to be standardized. 
I looked over that document (i could only see the first 7 pages for some 
reason), and that kind of the way that Chromecast behaves but not 
exactly. Chomecast doesn't launch specific apps itself, it just fetches 
the media. I saw a vague reference to a token which I'm guessing is some 
sort of bearer token but didn't see how that works.

The larger issue is that this entire area is a mess with tons of opacity 
and lack of standardization. I can't, for example, use Firefox to drive 
Chromecast.

Mike

> *From:* Michael Thomas <[email-masked]>
> *Sent:* Tuesday, March 16, 2021 19:17
> *To:* Tim Cappalli <[email-masked]>; [email-masked] 
> <[email-masked]>
> *Subject:* Re: media casting cluster*
>
>
>> <https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.google.com%2Fviewer%3Fa%3Dv%26pid%3Dsites%26srcid%3DZGlhbC1tdWx0aXNjcmVlbi5vcmd8ZGlhbHxneDo1MWVmNzNhZDUyYTI0YTkz&data=04%7C01%7CTim.Cappalli%40microsoft.com%7Ca7253e10c6f1471f080908d8e8d1a42a%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C637515334395551096%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=qxFW05hl3mEJLHcVK9vkuSb2RxfdO1HGxZiN%2FxVvIbM%3D&reserved=0>
>
>> *From:* ietf <[email-masked]> <mailto:[email-masked]> 
>> on behalf of Michael Thomas <[email-masked]> <mailto:[email-masked]>
>> *To:* IETF Discussion Mailing List <[email-masked]> <mailto:[email-masked]>

---

From: Harald Alvestrand <[email-masked]>
Date: Fri, 26 Mar 2021 22:23:43 +0100

Don't be too sure. The chrome part of the name may be because there is a browser in it.

Den 18. mars 2021 20:59:36 CET, skrev Michael Thomas <[email-masked]>:
><mailto:[email-masked]>

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.

---

From: Michael Thomas <[email-masked]>
Date: Fri, 26 Mar 2021 15:37:59 -0700

> Don't be too sure. The chrome part of the name may be because there is 

Ah, good point. Makes app upgrades easy too. It's amazing what you can 
get in a SoC these days...

Mike

>     I'm talking about casting, but really both could use to be
>     standardized. I looked over that document (i could only see the
>     first 7 pages for some reason), and that kind of the way that
>     Chromecast behaves but not exactly. Chomecast doesn't launch
>     specific apps itself, it just fetches the media. I saw a vague
>     reference to a token which I'm guessing is some sort of bearer
>     token but didn't see how that works.
>
>
>     The larger issue is that this entire area is a mess with tons of
>     opacity and lack of standardization. I can't, for example, use
>     Firefox to drive Chromecast.
>
>
>     Mike
>
>
>
>>     I've seen this before, and I'm pretty sure that it's not the
>>     whole story. Or maybe it's something more recent?
>>
>>
>>     Mike
>>
>>
>>>     *From:* ietf <[email-masked]>
>>>     <mailto:[email-masked]> on behalf of Michael Thomas
>>>     <[email-masked]> <mailto:[email-masked]>