Subject: Fwd: Quic: the Elephant in the Room

From: Lars Eggert <[email-masked]>
Date: Wed, 21 Apr 2021 22:00:05 +0300

Hi,

for context, and to correct some misrepresentations, here is my reply to Michael from the QUIC list.

Thanks,
Lars

Begin forwarded message:
> 
> From: Lars Eggert <[email-masked]>
> Subject: Re: Quic: the Elephant in the Room
> Date: April 21, 2021 at 19:46:57 GMT+3
> To: Michael Thomas <[email-masked]>
> Cc: Eric Rescorla <[email-masked]>, Phillip Hallam-Baker <[email-masked]>, Matt Joras <[email-masked]>, Lucas Pardue <[email-masked]>, David Schinazi <[email-masked]>, IETF QUIC WG <[email-masked]>
> 
> Hi,
> 
> On 2021-4-21, at 19:11, Michael Thomas <[email-masked]> wrote:
>> I am a newcomer. I came here against my better judgement as I stated on the IETF list.
> 
> I have emails from you in my IETF mail archive at least as far back as 2006. But I assume you mean that you are a newcomer to the QUIC WG.
> 
>> I immediately had my head chopped off and told to go away by a working group chair in less than 24 hours.
> 
> I don't think you're helping your case by using dramatic phrases.
> 
> To recap: You brought a proposal that had been discussed elsewhere to the QUIC WG list. You got feedback from a number of different participants on your proposal. The discussion veered away from QUIC to other protocols that this WG is not working on. A chair suggested you continue the discussion on a mailing list better suited to your topic.
> 
>> If the number of packets exchanged in the initial handshake of a transport protocol is off topic, I am speechless. My better judgement wasn't that it was off topic, it was that this outcome is the ordinary behavior of insular IETF working groups.
> 
> A number of participants have commented on this already, for example, pointing out that the number of round trips matter much more than the number of packets, and that in their opinion your suggestion would not lead to further substantial enough gains. You then moved the topic of the discussion to why Google (and I assume other companies) are not signing their zones and offered theories as to why that is, which is not a topic of relevance to this WG. Hence the request to discuss it elsewhere.
> 
>> I also got told that signing a zone is tantamount to "boiling the ocean".
> 
> You're misquoting David. He said:
> 
> On 2021-4-20, at 20:20, David Schinazi <[email-masked]> wrote:
>> I'm not saying that a 3-packet handshake would be bad, I'm saying
>> that it's not worth boiling the ocean to remove 2 packets.
> 
> Nowhere in that sentence or the rest of David's email do I see any mention of signing zones.
> 
>> As IETF chair, do you agree with that? Because if it's true then there are serious issues with DNSSec and we should do something about it. I think it's nonsense, fwiw.
> 
> Again, not a topic for *this* mailing list.
> 
>> Mike, and what exactly are those venues? tia.
> 
> I'd start at DNSOP and ask if there is a more appropriate list.
> 
> Thanks,
> Lars
> 
>

---

From: Michael Thomas <[email-masked]>
Date: Wed, 21 Apr 2021 12:38:14 -0700

> to Michael from the QUIC list.

I counted the number of messages from the rest of the working group 
before one of the chairs called it off topic and for me to go way and it 
was 4 or maybe 5. And "as chair" is not a suggestion, it is a command. 
It sure seems to me that the number of messages a transport protocol 
needs to start a session is pretty on topic, or at least of interest.

Getting told to go elsewhere *is* dramatic, if not predictable.

Mike

>
> Thanks,
> Lars
>
>
> Begin forwarded message:
>>
>> *From: *Lars Eggert <[email-masked] <mailto:[email-masked]>>
>> *Subject: **Re: Quic: the Elephant in the Room*
>> *Date: *April 21, 2021 at 19:46:57 GMT+3
>> *To: *Michael Thomas <[email-masked] <mailto:[email-masked]>>
>> *Cc: *Eric Rescorla <[email-masked] <mailto:[email-masked]>>, Phillip 
>> Hallam-Baker <[email-masked] <mailto:[email-masked]>>, 
>> Matt Joras <[email-masked] <mailto:[email-masked]>>, 
>> Lucas Pardue <[email-masked] 
>> <mailto:[email-masked]>>, David Schinazi 
>> <[email-masked] <mailto:[email-masked]>>, IETF 
>> QUIC WG <[email-masked] <mailto:[email-masked]>>
>>
>> Hi,
>>
>> On 2021-4-21, at 19:11, Michael Thomas <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>> I have emails from you in my IETF mail archive at least as far back 
>> as 2006. But I assume you mean that you are a newcomer to the QUIC WG.
>>
>>> I immediately had my head chopped off and told to go away by a 
>>> working group chair in less than 24 hours.
>>
>> To recap: You brought a proposal that had been discussed elsewhere to 
>> the QUIC WG list. You got feedback from a number of different 
>> participants on your proposal. The discussion veered away from QUIC 
>> to other protocols that this WG is not working on. A chair suggested 
>> you continue the discussion on a mailing list better suited to your 
>> topic.
>>
>>> If the number of packets exchanged in the initial handshake of a 
>>> transport protocol is off topic, I am speechless. My better 
>>> judgement wasn't that it was off topic, it was that this outcome is 
>>> the ordinary behavior of insular IETF working groups.
>>
>> A number of participants have commented on this already, for example, 
>> pointing out that the number of round trips matter much more than the 
>> number of packets, and that in their opinion your suggestion would 
>> not lead to further substantial enough gains. You then moved the 
>> topic of the discussion to why Google (and I assume other companies) 
>> are not signing their zones and offered theories as to why that is, 
>> which is not a topic of relevance to this WG. Hence the request to 
>> discuss it elsewhere.
>>
>> On 2021-4-20, at 20:20, David Schinazi <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>>> As IETF chair, do you agree with that? Because if it's true then 
>>> there are serious issues with DNSSec and we should do something 
>>> about it. I think it's nonsense, fwiw.
>>

---

From: Vasilenko Eduard <[email-masked]>
Date: Wed, 21 Apr 2021 19:55:48 +0000

+1
As my colleague said when we have discussed a similar problem: "closed club".
It was in relation to different WG. I do not know anything about QUIC WG.
Ed/
From: ietf [mailto:[email-masked]] On Behalf Of Michael Thomas
Sent: Wednesday, April 21, 2021 10:38 PM
To: [email-masked]
Subject: Re: Fwd: Quic: the Elephant in the Room

I counted the number of messages from the rest of the working group before one of the chairs called it off topic and for me to go way and it was 4 or maybe 5. And "as chair" is not a suggestion, it is a command. It sure seems to me that the number of messages a transport protocol needs to start a session is pretty on topic, or at least of interest.

Mike

Thanks,
Lars

Begin forwarded message:

From: Lars Eggert <[email-masked]<mailto:[email-masked]>>
Subject: Re: Quic: the Elephant in the Room
Date: April 21, 2021 at 19:46:57 GMT+3
To: Michael Thomas <[email-masked]<mailto:[email-masked]>>
Cc: Eric Rescorla <[email-masked]<mailto:[email-masked]>>, Phillip Hallam-Baker <[email-masked]<mailto:[email-masked]>>, Matt Joras <[email-masked]<mailto:[email-masked]>>, Lucas Pardue <[email-masked]<mailto:[email-masked]>>, David Schinazi <[email-masked]<mailto:[email-masked]>>, IETF QUIC WG <[email-masked]<mailto:[email-masked]>>

Hi,

On 2021-4-21, at 19:11, Michael Thomas <[email-masked]<mailto:[email-masked]>> wrote:

On 2021-4-20, at 20:20, David Schinazi <[email-masked]<mailto:[email-masked]>> wrote:

Thanks,
Lars