Subject: Re: Wow, we're famous, was WG Review: Effective Terminology in IETF Documents (term)

From: "John Levine" <[email-masked]>
Date: 13 Apr 2021 16:05:34 -0400

Today's New York Times has a feature article about our terminology debate on page B1.

https://www.nytimes.com/2021/04/13/technology/racist-computer-engineering-terms-ietf.html

Anyone prone to heartburn would be well advised to skip the comments.

R's,
John

---

From: Masataka Ohta <[email-masked]>
Date: Wed, 14 Apr 2021 23:33:04 +0900

> Anyone prone to heartburn would be well advised to skip the comments.

So, as there is no consensus even in US that "blacklist"
and "master/slave" must be banned and those who are arguing
so, only to promote or, at least, preserve discrimination,
are noisy minorities, do we, most of us especially outside
of US, have to bother?

							Masataka Ohta

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 14 Apr 2021 16:26:07 +0000

>    So, as there is no consensus even in US 

It is erroneous to make a consensus call based on who comments on a newspaper's website.

---

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 15 Apr 2021 03:06:47 +1000

> It is erroneous to make a consensus call based on who comments on a newspaper's website.

Obviously that's not enough to make a "pro" case for consensus, but I am interested in your reasoning for not treating the 800+ comments which seem fairly spread between pro and con for this work as a "there's not consensus".

Particularly comments like these two which both have about the same number of recommends (just over 100 for each at the point that I cherry-picked them, which places them together in the "Reader Picks"):

https://nyti.ms/2PTNCWt#permid=112408644

https://nyti.ms/3gaUUQo#permid=112404519

They seem to cover the two main views:

a) "I'm a black engineer and I think this is misguided and not relevant to my needs"

b) "Doing small things to accommodate the concerns of others is pretty basic in a civil society"

... it seems pretty clear to me that there's not consensus in the comments section of the New York Times.  If there WAS consensus then I'd agree that extrapolating that to all of US society would be an error, but I don't see the opposite case - the fact that even among readers of a single newspaper there is clear disagreement would seem a pretty strong argument for there not being broad consensus.

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: Eliot Lear <[email-masked]>
Date: Wed, 14 Apr 2021 19:33:45 +0200

Here is what I take from those comments, Bron:
There is indeed no societal consensus on how terminology is should be used.
We simply cannot stop at terminology when we address inclusiveness.  It’s a VERY small component in an overall strategy.
What does this mean to the IETF?  I don’t think it means “stop doing TERM”.  Rather I think it means that we should work on the other aspects.  We should make it easy and fun to be here.  And mostly it is fun (of course I’m biased), but sometimes it’s not easy.

Mostly I think you hit the right tone in your quote in that article.

Eliot

> On 14 Apr 2021, at 19:06, Bron Gondwana <[email-masked]> wrote:
> 
> https://nyti.ms/2PTNCWt#permid=112408644 <https://nyti.ms/2PTNCWt#permid=112408644>
> 
> https://nyti.ms/3gaUUQo#permid=112404519 <https://nyti.ms/3gaUUQo#permid=112404519>
> 
>   [email-masked] <mailto:[email-masked]>

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 14 Apr 2021 17:52:02 +0000

> but I don't see the opposite case - the fact that even among readers of a single newspaper there is clear disagreement would seem a pretty strong argument for there not being broad consensus.

The NYTimes readership in particular, is not representative of the United States. They would be the first to admit it.

                /r$, by the way: long time subscriber

---

From: "Jim Fenton" <[email-masked]>
Date: Wed, 14 Apr 2021 11:01:55 -0700

On 14 Apr 2021, at 10:33, Eliot Lear wrote:

> What does this mean to the IETF?  I don’t think it means “stop 
> doing TERM”.  Rather I think it means that we should work on the 
> other aspects.  We should make it easy and fun to be here.  And mostly 
> it is fun (of course I’m biased), but sometimes it’s not easy.

The question I keep asking myself (and I don’t have an answer) is 
whether by focusing on terminology in this way we are distracting 
ourselves from making more meaningful efforts to make IETF more 
inclusive. I don’t know what those more meaningful efforts might be, 
but I hope we’re addressing the big problems first.

-Jim

---

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 15 Apr 2021 04:04:55 +1000

On Thu, Apr 15, 2021, at 03:52, Salz, Rich wrote:

>                 /r$, by the way: long time subscriber 

I think we're on the same page here about.  If someone tried to claim that NYTimes readers all agree and hence that was evidence of consensus within the USA, I would be the first to call shenanigans.

BUT - given that there's significant disagreement within the NYTimes readership, then there are two possibilities:

1) all the people in the rough are NYT readers, and the rest of the USA are in wild agreement with one half of the NYT-reader opinion.

2) the lack of consensus within NYT readership matches a wider lack of consensus within the USA.

I consider case (1) above to be extremely unlikely.

Bron.

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 14 Apr 2021 18:13:35 +0000

*   1) all the people in the rough are NYT readers, and the rest of the USA are in wild agreement with one half of the NYT-reader opinion.

Ø    I consider case (1) above to be extremely unlikely.

By the way, the discussion was “there is no US consensus, so the IETF shouldn’t do anything.” I pointed out that the presumption is wrong.

I don’t know what US consensus was. I know the industry is moving in this direction. I don’t recall seeing polls about it for the general population.

You can consider it to be extremely unlikely.  That’s okay, but it is nothing beyond your opinion.  I just say “we don’t know”

---

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 15 Apr 2021 04:32:08 +1000

I'll agree with "we don't know". A reliable poll on the issue would be interesting, though I suspect it's hard to craft questions that everyone would agree weren't leading.

Bron.

---

From: Nico Williams <[email-masked]>
Date: Wed, 14 Apr 2021 13:41:32 -0500

On Wed, Apr 14, 2021 at 07:33:45PM +0200, Eliot Lear wrote:
> We simply cannot stop at terminology when we address inclusiveness.
> It’s a VERY small component in an overall strategy.
> What does this mean to the IETF?  I don’t think it means “stop doing
> TERM”.  Rather I think it means that we should work on the other
> aspects.  We should make it easy and fun to be here.  And mostly it is
> fun (of course I’m biased), but sometimes it’s not easy.

Well, if we paid attention to practical proposals by participants who
most have a need for them, we'd have IETF sponsors and/or ISOC providing
sponsorships to participants from economically disadvantaged backgrounds
or countries.

E.g., see Fernando's commentary.

But you know, the response to that so far has been CRICKETS.

To pursue terminology changes with such fervor -changes that we can
easily find supposed beneficiaries scoffing at as patronizing and
useless- and sponsorships not at all serves only to underline our actual
and hypocritical lack of interest in actually achieving something.

J'accuse,

Nico
--

---

From: Nico Williams <[email-masked]>
Date: Wed, 14 Apr 2021 13:43:10 -0500

On Wed, Apr 14, 2021 at 11:01:55AM -0700, Jim Fenton wrote:
> The question I keep asking myself (and I don’t have an answer) is whether by
> focusing on terminology in this way we are distracting ourselves from making
> more meaningful efforts to make IETF more inclusive. I don’t know what those
> more meaningful efforts might be, but I hope we’re addressing the big
> problems first.

Fernando has pointed out repeatedly that ISOC used to have a sponsorship
program for participants from economically disadvantaged countries, and
that this program has been terminated.

But we _care_ so *so* much!

---

From: "John Levine" <[email-masked]>
Date: 14 Apr 2021 14:59:26 -0400

>that this program has been terminated.

It wasn't working. The people would come to a meeting but then
wouldn't write I-Ds or continue to engage with the IETF. In one
particularly unfortunate case, the person didn't even speak English
and somehow the selection process missed that. We want to resume it
with a selection process that finds people who can benefit from IETF
meetings and are likely to be ongoing IETF contributors.

>But we _care_ so *so* much!

Thanks for your thoughtful anaylsis.

R's,
John

---

From: Christian Huitema <[email-masked]>
Date: Wed, 14 Apr 2021 22:21:22 +0200

On 4/14/2021 8:32 PM, Bron Gondwana wrote:

> 'll agree with "we don't know". A reliable poll on the issue would be interesting, though I suspect it's hard to craft questions that everyone would agree weren't leading.

I think we should be quite cautious before deriving too much from the 
comments section of the NYT. Bron, I did read the two comments that you 
quoted, and I wonder to what extent the comment starting by "I'm a black 
engineer" is genuine. It may well be, the student loan situation that is 
mentioned there is indeed often a form of indentured service, there are 
many much greater ills affecting black people in America, so that's 
plausible. But there is also a fairly substantial amount of false flag 
commentary in online discussions.

As far as I am concerned, I already said I wished this issue was 
resolved already and I don't understand what is taking so long. But I 
think the quoted statement from Lars is fair. Let's follow the process, 
and reach a consensus with a stable basis.

-- Christian Huitema

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 14 Apr 2021 21:51:06 +0100

Hiya,

On 14/04/2021 19:59, John Levine wrote:
>   We want to resume it

Good stuff. Suggestion: try get some set of people similar
to a subset of WG chairs to help evaluate submissions. (But
don't ask WG chairs to evaluate submissions related to their
WGs - the directorate tooling might help there.) I think the
goal of helping people already involved is one that's
worthwhile enough that it'd be a shame if selections
were done by people uninvolved. Another suggestion: maybe
talk to OTF and similar people who fund fellowship things
to see what they'd suggest that's much better than my
suggestions:-)

Trying to figure out how to help people not already involved
is another topic, but should be separable I'd guess.

Cheers,
S.

---

From: Victor Kuarsingh <[email-masked]>
Date: Wed, 14 Apr 2021 17:33:20 -0400

> but I hope we’re addressing the big problems first.

I am most interested in meaningful changes that help people come and
participate.  I don't know if changing or updating terminology will help,
hinder or be neutral in that cause.  I guess it's worth a shot.

My (anecdotal) experience was that culture was the central and most
impactful obstacle to participating within the IETF versus any content of a
pre-existing documentation.  For example, when I read a draft or RFC
(others may disagree), I am absorbing technical content and associate
things I read, including words, to assisting in describing
the technology, method or principle.  On the other hand, when someone
engages, in-person or via email, I see that as a reflection of them
communicating and of their personal resolve.   How we communicate with each
other, as a unit, helps define our culture.

I think addressing culture, IMO, would likely result in more meaningful
ways to drive inclusion.

regards,

Victor K

---

From: "Livingood, Jason" <[email-masked]>
Date: Wed, 14 Apr 2021 21:35:19 +0000

[JL] The IETF has a Diversity & Inclusivity sponsorship program (https://www.ietf.org/about/support/#diversity-inclusivity) that provides support in the manner you suggest. IIRC it was developed just as COVID hit so it thus far has only been used to support waivers for online meetings.

From that page: "...providing a path to sustained engagement for those who would otherwise face difficulties participating in the IETF. The IETF’s Diversity and Inclusivity sponsorship supports fee waivers to lower economic barriers to meeting participation, and the IETF Systers program which offers women participants the opportunity to connect, share, and learn with each other."

---

From: Dan Harkins <[email-masked]>
Date: Wed, 14 Apr 2021 14:42:48 -0700

On 4/14/21 11:59 AM, John Levine wrote:
> and somehow the selection process missed that.

   So you mean that inclusion by itself is not the thing to
strive for. That is something I think we need to keep in mind
when people speak of inclusion as some shining goal that is
attainable if we just do something different (smile, mentor a
newcomer, stop using "master" in RFCs, etc).

> meetings and are likely to be ongoing IETF contributors.

   You're saying that we need to be more *discriminating* in who
we decide to help meet our goals of inclusion. Yes, I agree.

   The thing is, participation in the IETF is voluntary and depends
on interest by the volunteer. So we, as an institution, are at a
disadvantage in having much say in dictating who shows up in the
end. There's only so much we can do to actually change the makeup
of those who voluntarily choose to take part especially when we're
drawing from pools of potential volunteers that are not very diverse
(by almost any way you want to look at it-- gender, geographical
origin, race, professional affiliation, political temperament, etc)
to begin with.

   I advocated for my company to help create a scholarship in a
STEM field at a HBCU here in the states. You can do that too, or
something similar modulo your particular circumstance. It won't
end up paying dividends until after I've stopped attending but
it's gonna do more to achieve the ultimate goal than stopping
the use of the word "master" in an RFC.

   regards,

   Dan.

-- 
"The object of life is not to be on the side of the majority, but to
escape finding oneself in the ranks of the insane." -- Marcus Aurelius

---

From: Nico Williams <[email-masked]>
Date: Wed, 14 Apr 2021 16:52:44 -0500

On Wed, Apr 14, 2021 at 09:35:19PM +0000, Livingood, Jason wrote:
> [JL] The IETF has a Diversity & Inclusivity sponsorship program
> (https://www.ietf.org/about/support/#diversity-inclusivity) that
> provides support in the manner you suggest. IIRC it was developed just
> as COVID hit so it thus far has only been used to support waivers for
> online meetings.
> 
> From that page: "...providing a path to sustained engagement for those
> who would otherwise face difficulties participating in the IETF. The
> IETF’s Diversity and Inclusivity sponsorship supports fee waivers to
> lower economic barriers to meeting participation, and the IETF Systers
> program which offers women participants the opportunity to connect,
> share, and learn with each other."

Oh, I missed or forgot this.

Thank you for correcting me.

nico
--

---

From: Colin Perkins <[email-masked]>
Date: Wed, 14 Apr 2021 23:00:18 +0100

> On 14 Apr 2021, at 19:41, Nico Williams <[email-masked]> wrote:

We’ve had such a programme for many years for IRTF ANRW, and had a travel grant programme ready to announce for some other areas of IRTF, but then the pandemic hit, and travel stopped. We’re happy to accept future sponsors for such grants, to broaden the scope of the programme, for when the in-person meetings resume. 

Jason has mentioned activities on the IETF side. 

-- 
Colin Perkins
https://csperkins.org/

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 14 Apr 2021 15:23:45 -0700

I am more and more convinced that, instead on counting on some centralized way to attract new people and then get complaints when they do not stay, maybe there is a better way would permit to achieve our goal in a more distributed way.  I do not think that group mentorship for the IETF is working -- I tried at a previous company, and none of the mentorees are still participating, so that's not the way.

But I am thinking that the key could be a mentorship that would extend beyond a meeting week.  That would mean working with a mentoree for a whole publishing cycle, starting by explaining how to read an RFC (people told me that they do not know how to do that), then how to review an I-D (a place where most of the mentoring work should be done, IMO), then upgrading to co-writing an I-D and going through the whole publishing cycle.  I think offering that kind of guidance to a mentoree for a couple years would help more than that any other kind of program.

Now if most of the follicle pigmentation deficient people[1] at the IETF take on a couple of mentorees each two years, I think it could be possible to at the same time create a continuity of tradition and still embrace the energy of newcomers.

In fact I have someone in mind that would be perfect as my first IETF mentoree, so I am going to just do it.

[1] Graybeard.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 15 Apr 2021 11:17:41 +1200

On 15-Apr-21 10:23, Marc Petit-Huguenin wrote:
...
> But I am thinking that the key could be a mentorship that would extend beyond a meeting week.

That was always the theory. I acted as a mentor several times under the original version of the mentoring scheme, and did follow-up mails (phone calls were never practical). But my success rate with the follow-ups was approximately zero. Successful mentoring is not easy outside a more traditional work environment with frequent personal contact.

    Brian

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 14 Apr 2021 16:37:04 -0700

> That was always the theory. I acted as a mentor several times under the original version of the mentoring scheme, and did follow-up mails (phone calls were never practical). But my success rate wit…

So no nothing in the plus column.  But did any of the mentorees complained that they felt mistreated by the IETF?  Even if they cannot be added to the plus column, I expect that they cannot either be added on the minus column.

But you are right that it is hard to build a successful mentorship with someone with whom you do not already have some commonalities.  I think there is a step missing there -- where to meet and how to select these candidates?

Oh well, if the candidate I have in mind accept, I have a year to figure it out how to find the next one.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 15 Apr 2021 12:46:21 +1200

> So no nothing in the plus column.  But did any of the mentorees complained that they felt mistreated by the IETF?  Even if they cannot be added to the plus column, I expect that they cannot either…

Good point. Yes, I think they all gave me the impression that they were glad of the mentoring, found it useful as first-time attendees, and didn't find that they were unwelcome. But they didn't find the IETF to be a "must do" for the future.

Regards
   Brian

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 15 Apr 2021 13:48:14 +0900

> It is erroneous to make a consensus call based on who comments on a newspaper's website.

For existence of smooth consensus, may be.

For existence of rough consensus, may not be. We know humming is enough.

Anyway, for so obvious lack of consensus, "based on who comments on a
newspaper's website" is enough.

 > The NYTimes readership in particular, is not representative of
 > the United States.

IETF participants do not even have IETF membership.

						Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Thu, 15 Apr 2021 14:29:21 +0900

Salz, Rich wrote:

> By the way, the discussion was “there is no US consensus, so the IETF
> shouldn’t do anything.” I pointed out that the presumption is wrong.

According to NYT article:

: Now the organization is tackling an even thornier issue:
: getting rid of computer engineering terms that evoke
: racist history, like "master" and "slave" and "whitelist"
: and "blacklist."

unless there is US consensus that there are "computer
engineering terms that evoke racist history", we don't
have to do anything.

That's what NYT article says.

And, as you can see, so many people think "slave" has
nothing especially to do with recent slavery in US.

For me, even if there were, I don't think we must do something.

							Masataka Ohta

---

From: Vasilenko Eduard <[email-masked]>
Date: Thu, 15 Apr 2021 08:14:38 +0000

Hi Victor,
You are very close to the root cause. The root cause is motivation. Well, probably one could say that it is “culture” or part of the culture.

Many people in IETF have a personal motivation that is not fully in line with the “public good”.
For example: publish any nonsense to report personal IETF progress for the employer. Rigorously fight back even if somebody would show that particular idea is on the opposite side from perfect.
Example 2: never dispute any job of others, even if they propose something really bad. It would destroy your relationships, people could fight back to your proposals later.
Example 3: support whatever chair would propose, never criticize the boss – you are dependent on him.
Example 4: create small closed groups and help each other on every occasion (without paying any attention to the public good).
And so on, so on, so on. Humans are intelligent, especially in IETF.

A smaller number of people are driven in a different direction by their companies.
For example: avoid particular technology standardization that would be difficult to implement for their architecture.
Or the opposite: push technology that competitors would not be capable to implement.

People are partially egoistic in general with a wide range of deviation in motivation from 100% altruism to 100% egoism, the median is close to egoism.
This is the primary problem that degrades IETF efficiency. The IETF efficiency is low because of the wrong motivation of members.
I do not have a clue what anyone could do about it for an organization of such a wide scale.
It is the general problem of mankind. Mankind is extremely non-effective compare to what is potentially possible.
I have seen much more effective teams in my life, but it assumes selection and the boss’s willingness to do it.

Hence, I am smiling looking to the proposal to involve more people
In the situation when a big part of the IETF community would treat them as competitors.

Of course, everything above is just my personal opinion. It is easy to ignore.
Eduard
From: ietf [mailto:[email-masked]] On Behalf Of Victor Kuarsingh
Sent: Thursday, April 15, 2021 12:33 AM
To: Jim Fenton <[email-masked]>
Cc: The IETF List <[email-masked]>
Subject: Re: Wow, we're famous, was WG Review: Effective Terminology in IETF Documents (term)

On Wed, Apr 14, 2021 at 2:02 PM Jim Fenton <[email-masked]<mailto:[email-masked]>> wrote:

I am most interested in meaningful changes that help people come and participate.  I don't know if changing or updating terminology will help, hinder or be neutral in that cause.  I guess it's worth a shot.

My (anecdotal) experience was that culture was the central and most impactful obstacle to participating within the IETF versus any content of a pre-existing documentation.  For example, when I read a draft or RFC (others may disagree), I am absorbing technical content and associate things I read, including words, to assisting in describing the technology, method or principle.  On the other hand, when someone engages, in-person or via email, I see that as a reflection of them communicating and of their personal resolve.   How we communicate with each other, as a unit, helps define our culture.

I think addressing culture, IMO, would likely result in more meaningful ways to drive inclusion.

regards,

Victor K

-Jim

---

From: tom petch <[email-masked]>
Date: Thu, 15 Apr 2021 12:31:14 +0100

On 14/04/2021 19:01, Jim Fenton wrote:
> inclusive. I don’t know what those more meaningful efforts might be, but
> I hope we’re addressing the big problems first.

My answer would be yes, we are distracting ourselves.

Being inclusive means having enough in common which means we are clear 
and make clear to others what we do and how we do it so that they can 
see that they would fit in, or not as the case may be.  We are engineers 
and we work on the Internet.  Many think that the world depends on 
science when it is engineers that make it revolve.  And I struggle to 
explain to others what we mean by Internet; it is not fibre broadband, 
it is not Wi-Fi, it is not mobile/cell phone technology, it is not 
Facebook, it is not shopping on the internet.  It is something in the 
middle that lacks a definition.

Tom Petch

> .

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 15 Apr 2021 05:59:35 -0700

> Good point. Yes, I think they all gave me the impression that they were glad of the mentoring, found it useful as first-time attendees, and didn't find that they were unwelcome. But they didn't fin…

That's also, I think, an important point.  Staying at the IETF, i.e. taking on new work beyond the initial reason someone joined, is quite difficult.  The life cycle of an RFC nearly always spanned different employers for me, which means that I had to finish the work without a sponsor.  Worse, Internet interoperability is rarely deemed critical by employers, and so is the first budget that get cut-off -- and again forcing to choose between abandoning the work done or continuing without sponsor.

Maybe part of the money spent on diversity could be redirected in trying to give IETF members more options to continue working for the IETF beyond an initial need:  E.g., convince companies and other organizations that it is in their interest to help long-term contributors stay at the IETF.  Then maybe the effort to recruit would not be wasted.  A good example is students from universities:  As far as I remember there always was a constant stream of students coming to the IETF to do work, and that's a good thing.  But most of them disappear when they got a first job, mostly because the pressure of a first job is incompatible with participating in an organization like the IETF.  After all these years, it is nearly impossible for me to convince a new employer to reserve some of my time for the IETF, so there is no chance someone could get that in a first job.  How can we change that?

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 15 Apr 2021 14:06:18 +0000

>    I am more and more convinced that, instead on counting on some centralized way to attract new people and then get complaints when they do not stay, maybe there is a better way would permit to ac…

One idea I had, which I mentioned to Lars when we chatted after the Nomcom selections, was an "invite a friend" program. If you come to the IETF, and you "sponsor" a colleague, then they get reduced/free admission. Of course, all sorts of details to be worked out there.  But I hoped it could encourage distributed diversity. Especially for junior engineers, you can keep travel and lodging costs low :)

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 15 Apr 2021 07:29:51 -0700

> One idea I had, which I mentioned to Lars when we chatted after the Nomcom selections, was an "invite a friend" program. If you come to the IETF, and you "sponsor" a colleague, then they get reduce…

That could help, although I am not sure that going to one or more IETF meetings should be an immediate goal for the kind of mentorship I am talking about.  Reading RFCs, reviewing I-Ds, reading mailing-lists and learning to listen should come first.  That would take care of the potential tourists so attending an IETF would be the next logical step.  But I must say that the IETF did not help there by making itself in some aspects indistinguishable from a travel agency...

---

From: "John R Levine" <[email-masked]>
Date: 15 Apr 2021 10:38:22 -0400

>> One idea I had, which I mentioned to Lars when we chatted after the Nomcom 
>> selections, was an "invite a friend" program. ...

> That could help, although I am not sure that going to one or more IETF 
> meetings should be an immediate goal for the kind of mentorship I am talking 
> about.  Reading RFCs, reviewing I-Ds, reading mailing-lists and learning to 
> listen should come first. ...

Quite right.  If you're not already involved in some WGs, coming to an 
IETF meeting is likely to be a waste of your time.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: "Theodore Ts'o" <[email-masked]>
Date: Thu, 15 Apr 2021 10:45:18 -0400

On Thu, Apr 15, 2021 at 05:59:35AM -0700, Marc Petit-Huguenin wrote:
> > Good point. Yes, I think they all gave me the impression that they
> > were glad of the mentoring, found it useful as first-time
> > attendees, and didn't find that they were unwelcome. But they
> > didn't find the IETF to be a "must do" for the future.
> 
> That's also, I think, an important point.  Staying at the IETF,
> i.e. taking on new work beyond the initial reason someone joined, is
> quite difficult.  The life cycle of an RFC nearly always spanned
> different employers for me, which means that I had to finish the
> work without a sponsor.  Worse, Internet interoperability is rarely
> deemed critical by employers, and so is the first budget that get
> cut-off -- and again forcing to choose between abandoning the work
> done or continuing without sponsor.

So when I mentor someone at my company, what I find spending the
majority of my time is spent offering advice on how to manage the
considerations of internal company dynamics.  In the open source
world, for example, a lot of it is about how to justify a project
which contributes to open source in a way that doesn't harm your
career.  The fact of the matter is the easist way to get promoted is
to show $XXX million dollars in increased revenue, or decreased cost.
And while it is *possible* that a particular open source development
effort might result in that, it's much more difficult to show that the
open source development effort was a direct cause in growing revenue
or decreasing cost, at least in an easily demonstrable way that can be
considered by a promotion committee with very tight word count
constraints on your promotion packet.

I would submit that there is a similar issue with standards work.
Sure, standardation might improve a product's value in the eyes of the
customers --- but was it really what made your company make an extra
$XXX million?  It's hard to make that case, and how you need to make
that case is very dependent on internal company dynamics, and not
something where an external mentor could help all that much.

If many IETF'ers do standards work out of a passion to make the world
a better place, and continue their work across multiple employers
(which is very similar to many open source engineers), then it may
very well be that the most useful mentorship is from someone in the
company they are currently working for, or someone who has extensive
experience from inside that company, even if they aren't working there
any more.  This doesn't help engineers who are working at a smaller
company (or from lesser developed countries) where there aren't any
current IETF participants who can give them that insight, however.

> But most of them disappear when they got a first job, mostly because
> the pressure of a first job is incompatible with participating in an
> organization like the IETF.  After all these years, it is nearly
> impossible for me to convince a new employer to reserve some of my
> time for the IETF, so there is no chance someone could get that in a
> first job.  How can we change that?

Agreed, that's a hard problem.

The best answer I have at this point is that if you're lucky, your
company will cover travel expenses, but you may have to spend a lot of
time contributing to "public good projects" (either IETF
standardization or open source work), effectively on your own time,
and hopefully that will be an investment in your future career or
promotion prospects.  It will likely be only "brownie points",
especially early in your career, but hopefully in the long run, it
will be part of your own distinctive "brand" as an software engineer.

If anyone has a better answer, I'd love to hear about it!

					- Ted

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 15 Apr 2021 14:48:01 +0000

The idea is that the experienced IETFer would know these things and help the first-time attendee they are sponsoring to be productive.

I don't want to design this on-the-fly in an IETF@ thread, but you could for example add qualifications to what "experienced IETFer" means.

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 15 Apr 2021 07:54:22 -0700

> I don't want to design this on-the-fly in an IETF@ thread, but you could for example add qualifications to what "experienced IETFer" means.

On the right side of the Dunning-Kruger curve.

---

From: Keith Moore <[email-masked]>
Date: Thu, 15 Apr 2021 14:44:51 -0400

On 4/15/21 10:45 AM, Theodore Ts'o wrote:

> (which is very similar to many open source engineers)...

In asking myself why it's hard to attract new people to IETF, I find 
myself wondering if it's harder these days for newcomers to see how they 
can "make the world a better place" by working with IETF, than it used 
to be.

I don't want to dismiss those who claim the problem is "culture", but 
IETF culture exists for some reasons (some but maybe not all of them 
good ones), and I think there might be other factors also.

The "low hanging fruit" is mostly picked.  If you want to make a 
positive difference for the world/Internet it's harder to do these days 
than it used to be.   The existing protocols are more complex and often 
more entrenched, making them  harder to understand and harder to 
change.   The network is more hostile to innovation. There's a lot of 
inertia within IETF itself also, both in the sense of accumulated wisdom 
and accumulated prejudice about which ideas are "good" vs. "bad" (even 
if conditions have changed making old assumptions less valid).   The 
IETF organization itself is a lot more complex and bureaucratic than it 
used to be.   And a lot of the Internet is effectively controlled by a 
small number of large companies, so any innovation that wants to be 
successful has to be made in awareness of the economic landscape as well 
as the technical and political and cultural.

And yet, there are still opportunities to make valuable contributions, 
and in some sense to make even more valuable contributions than could be 
made in the past.   Because the growth of the Internet has made some 
problems larger and more important than ever.

But a newcomer faces a steep learning curve consisting of many different 
layers of complexity AND a unique culture: they have to know a LOT 
(technically and politically and economically and culturally) to make a 
useful difference.   (I suspect IETF culture is actually the least of 
these barriers - experienced IETF people still want to find and 
encourage new people who actually show interest and have a chance at 
making a useful difference)

So if I'm right, part of attracting newcomers means showing them how to 
navigate these layers.   And I believe there are things we could do to 
help educate newcomers (as well as some who are experienced but perhaps 
aren't quite up to date).   Take addressing and routing for example.  
There's a lot of accumulated wisdom about how to delegate addresses to 
make routing a more manageable problem in both hardware and software, 
about fairness in address block assignment, about routing policies, 
about route advertisements and aggregation, etc.   There are different 
types of addresses for each of IPv4 and IPv6 and a need to understand 
these.    There's a need to know about NATs, the different kinds of 
NATs, what's good and (mostly) bad about them.  There is also a need to 
know about the roles of IANA and the regional registries and some degree 
of current practice between RRs and operators, and routing arrangements 
between operators.

Somewhere there needs to be a resource that points IETFers who are 
interested in routing and addressing, or anything that touches them or 
relies on them, to some current information about those topics, with 
pointers to even more detail.   And that resource should probably also 
point out currently-unsolved important problems, just to get people 
interested (maybe kind of like the exercises in Knuth's /The Art of 
Computer Programming/ books).   If good resources like this already 
exist, great; if not, someone needs to be recruited to write them.   And 
similar resources are needed for several other layers or widely-used 
technologies: "the web", email, transport protocols, DNS, etc.

Keith

---

From: Leif Johansson <[email-masked]>
Date: Fri, 16 Apr 2021 00:32:59 +0200

> If anyone has a better answer, I'd love to hear about it!

I think we should give up on attracting the Good Individual (TM) to the IETF and focus on attracting
new communities into the organization.

Quite a bit of ad-hoc standardization happens without our involvement. Most of us would say this is a
Good Thing and proof that the overall Internet architecture is sound and allows innovation.

Despite all the turmoil in recent months and years, there is value in (some of) the culture of the
IETF. Perhaps if we tried to exercise a bit more humility when faced with potential new work we might
become more successful in attracting new talent at the same time.

(Also, a bit of humility often helps with inclusivity too)

No I don't want to get into specifics but I think we could all recall a BoF or two that made us
cringe at the thought of how we choose to treat newcomers sometimes.

	Cheers Leif

---

From: Warren Kumari <[email-masked]>
Date: Thu, 15 Apr 2021 18:53:52 -0400

On Thu, Apr 15, 2021 at 10:06 AM Salz, Rich <rsalz=
[email-masked]> wrote:

> >    I am more and more convinced that, instead on counting on some
> centralized way to attract new people and then get complaints when they do
> not stay, maybe there is a better way would permit to achieve our goal in a
> more distributed way.  I do not think that group mentorship for the IETF is
> working -- I tried at a previous company, and none of the mentorees are
> still participating, so that's not the way.
>
> selections, was an "invite a friend" program. If you come to the IETF, and
> you "sponsor" a colleague, then they get reduced/free admission. Of course,
> all sorts of details to be worked out there.  But I hoped it could
> encourage distributed diversity. Especially for junior engineers, you can
> keep travel and lodging costs low :)

Wow, I really like that idea. I've fairly much always worn one of the
"smiley face" stickers, and always try introduce myself to people wearing
the newcomers ribbon - I've struck up some good conversations, but I'm not
sure that they've "stuck".
I've also signed up to be a mentor a few times, but in most of the cases I
only briefly met my mentee, and in at least two of the cases I wasn't able
to find them at all (even after 5 or 6 mails).

I like the reduced charge for first time colleague idea - I've "mentored" a
few people from my company, and that's gone much, much better. I suspect
that a fair bit of this is simply that there is a different dynamic between
people in the same company...

However, as much as I like this idea, it also has some really bad downsides
-- it implicitly advantages those from larger companies. If someone is the
only attendee from a smaller company, they don't have anyone to mentor them.
If we do do something along these lines, I think that we also need to focus
on the mentoring program... actually, strike that - *whatever* we do we
should focus more on the mentoring program...

w

-- 
The computing scientist’s main challenge is not to get confused by the
complexities of his own making.
  -- E. W. Dijkstra

---

From: Michael McBride <[email-masked]>
Date: Thu, 15 Apr 2021 22:57:25 +0000

> Perhaps if we tried to exercise a bit more humility when faced with potential new work we might become more successful in attracting new talent at the same time.

Emphatic +1. This alone could help many of our problems including attracting new talent. 

mike

-----Original Message-----
From: ietf <[email-masked]> On Behalf Of Leif Johansson
Sent: Thursday, April 15, 2021 3:33 PM
To: [email-masked]
Subject: Re: the old fellowship program, was Wow, we're famous

> If anyone has a better answer, I'd love to hear about it!

I think we should give up on attracting the Good Individual (TM) to the IETF and focus on attracting new communities into the organization.

Quite a bit of ad-hoc standardization happens without our involvement. Most of us would say this is a Good Thing and proof that the overall Internet architecture is sound and allows innovation.

Despite all the turmoil in recent months and years, there is value in (some of) the culture of the IETF. Perhaps if we tried to exercise a bit more humility when faced with potential new work we might become more successful in attracting new talent at the same time.

No I don't want to get into specifics but I think we could all recall a BoF or two that made us cringe at the thought of how we choose to treat newcomers sometimes.

	Cheers Leif

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 15 Apr 2021 23:01:12 +0000

*   Wow, I really like that idea. I've fairly much always worn one of the "smiley face" stickers,

IMO, once we started making it trivial to have joke stickers, the badges become much more of an “in thing” and less useful to newcomers.

  *   However, as much as I like this idea, it also has some really bad downsides -- it implicitly advantages those from larger companies.

I did not mean to imply “colleague at the same company,” sorry for the confusion.

---

From: Michael Thomas <[email-masked]>
Date: Thu, 15 Apr 2021 16:45:32 -0700

[]

I think the first order question ought to be how to get new 
participation on working group mailing lists. I mean, it's free and just 
a click away so unlike meetings it is not an impediment for anything 
beyond investment in time. I wrote before how some wg mailing lists can 
be toxic in their treatment of "interlopers", and recently tuned out 
from yet another one because of that toxicity. For somebody starting 
out, the last thing you want is to have +3 fire breathed down on you for 
asking questions or pointing things out. Working groups can be rough and 
tumble and that is exacerbated by people who know each other for 
decades, but for newbies that is pretty off-putting.

Maybe one thing that could be done is to have a set of things that 
newbies can do to participate that are likely to be taken very 
favorably. What author doesn't like somebody who's gone through your ID 
with a fine tooth comb for nits, bad grammar, unclear text, etc and 
especially from fresh eyes from the perspective of a potential 
implementer, for example. Everybody would win in that situation. Their 
naivety is a huge benefit.

Mike

---

From: Keith Moore <[email-masked]>
Date: Thu, 15 Apr 2021 20:22:12 -0400

On 4/15/21 7:45 PM, Michael Thomas wrote:

> newbies can do to participate that are likely to be taken very favorably.

I've found that newcomers are much more likely to be taken favorably if 
they're well-prepared.

Unfortunately, this is difficult enough to do for a new working group, 
even more difficult for one that's been around for awhile.

If we'd like newcomers to be well-prepared to work in working groups, 
maybe the working group should put together a set of background info (at 
the start of the WG), and maintain a set of decisions already 
more-or-less taken and reasons why (though there might not actually be 
consensus on the reasons).

Maybe IETF meetings should have multiple sessions for each established 
WG - the first one a "catch up" session that presents and explains the 
work done to date, at which no decisions will be taken and which is 
optional for experienced attendees.

Keith

---

From: Wes Hardaker <[email-masked]>
Date: Thu, 15 Apr 2021 17:22:38 -0700

Michael Thomas <[email-masked]> writes:

> favorably. What author doesn't like somebody who's gone through your
> ID with a fine tooth comb for nits, bad grammar, unclear text, etc and

As a guide(s) I've (we've) mentioned this specific helpful task to
newcomers.  However, reviewing documents is sort of "boring" task to
many I'm sure.  What I've (we've?) failed to do is also state "and by
doing this your name will be put in the acknowledgements section", which
honestly might help motivate some.  Maybe.

-- 
Wes Hardaker
USC/ISI

---

From: Michael Thomas <[email-masked]>
Date: Thu, 15 Apr 2021 17:37:00 -0700

On 4/15/21 5:22 PM, Keith Moore wrote:
>> favorably.
> I've found that newcomers are much more likely to be taken favorably 
> if they're well-prepared.

Well, the nature of a newcomer is that they *won't* be well prepared. 
It's sort of the nature of the beast.

Another thing that occurs to me is that newcomers could be of help with 
things like ascii art. They are immensely helpful for documents but a 
pain for authors. Even better: if it's taken from the words written it, 
it shows how clear those words are and especially how hard it was for 
them to suss it out.

> optional for experienced attendees.
Yes, that's another obstacle: it can be embarrassing if you're bringing 
up ancient arguments. Some wg chairs I've seen have very short fuses on 
such things and it sends a pretty clear signal that you aren't welcome. 
Telling people to read the wg archives is really telling them to go 
away. If you want to attract new people, a little forbearance goes a 
long way.

Mike

---

From: Michael Thomas <[email-masked]>
Date: Thu, 15 Apr 2021 17:45:30 -0700

> honestly might help motivate some.  Maybe.
Yes, it's boring but it does need to get done. And it's exactly the kind 
of thing that fresh eyes can provide. Far too many working groups are 
completely blind as to how bad/underspecified their specs are. My 
favorite whipping boy, STIR, is a prime example. When confronted with it 
by multiple people, it got snarls and resentment. That is when then 
wheels have truly come off. If you want newbies to feel welcome, that is 
the exact wrong thing that should happen. But when you're first starting 
out, an acknowledgement is definitely an incentive.

Mike

---

From: Keith Moore <[email-masked]>
Date: Thu, 15 Apr 2021 20:54:32 -0400

> It's sort of the nature of the beast. 

Disagree.   They won't know everything, of course, but if they know 
enough about the subject matter to clearly know what they're talking 
about,  they're much more likely to be taken seriously.

And the problem of participants not being well-prepared isn't at all 
limited to newcomers to IETF.

Keith

---

From: Michael Thomas <[email-masked]>
Date: Thu, 15 Apr 2021 18:02:14 -0700

> limited to newcomers to IETF.
I remember when I first arrived on the scene and all I can say is that I 
was really cringeworthy. I'm pretty confident so I could take my lumps, 
but most people are much more risk adverse. We need to keep that in mind.

Mike

---

From: Keith Moore <[email-masked]>
Date: Thu, 15 Apr 2021 21:06:37 -0400

On 4/15/21 9:02 PM, Michael Thomas wrote:

> I remember when I first arrived on the scene and all I can say is that 
> I was really cringeworthy. I'm pretty confident so I could take my 
> lumps, but most people are much more risk adverse. We need to keep 
> that in mind.

I don't disagree, but if we make it easier for new participants to get 
up to speed, there will be a lot less need for cringeworthy moments.   
And WGs might also become more productive.

Keith

---

From: scott <[email-masked]>
Date: Thu, 15 Apr 2021 15:17:24 -1000

>> naivety is a huge benefit.

----------------------------------------------------

"What author doesn't like somebody who's gone through your ID with a fine tooth comb for nits, bad grammar, unclear text, etc and especially from fresh eyes from the perspective of a potential
implementer, for example."

This is what I tried when I first came over from NANOG after reading 'ops folks come on over to IETF' emails there.  Not everyone wants that.  I was told 'that's what the RFC editor is for.  Do you have any valuable input?'  Paraphrasing...  Since then I have been a lurker just because I want to learn.

scott

---

From: Michael Thomas <[email-masked]>
Date: Thu, 15 Apr 2021 18:19:02 -0700

On 4/15/21 6:06 PM, Keith Moore wrote:
>> I remember when I first arrived on the scene and all I can say is 
>> that I was really cringeworthy. I'm pretty confident so I could take 
>> my lumps, but most people are much more risk adverse. We need to keep 
>> that in mind.
>
The problem is that getting up to speed requires reading trigabytes of 
ancient messages in archives which just doesn't happen. Even we who have 
been around for a while who might know in our gut that something is not 
exactly new have a hard time determining that one way or the other. I'm 
sort of channeling the previous thread on outside researchers and their 
reluctance to bring their work forward thread. Getting snarled at for 
that is definitely a complete turn off.

Mike

---

From: Michael Thomas <[email-masked]>
Date: Thu, 15 Apr 2021 18:21:25 -0700

On 4/15/21 6:17 PM, scott wrote:
> "What author doesn't like somebody who's gone through your ID with a 
> fine tooth comb for nits, bad grammar, unclear text, etc and 
> This is what I tried when I first came over from NANOG after reading 
> 'ops folks come on over to IETF' emails there.  Not everyone wants 
> that.  I was told 'that's what the RFC editor is for.  Do you have any 
> valuable input?'  Paraphrasing...  Since then I have been a lurker 
> just because I want to learn.
>
Yeah, that's a problem. That shouldn't be controversial. Ever. Chairs 
should shut down prickly authors post haste.

Mike

---

From: Keith Moore <[email-masked]>
Date: Thu, 15 Apr 2021 21:34:20 -0400

On 4/15/21 9:19 PM, Michael Thomas wrote:

>>
>> I don't disagree, but if we make it easier for new participants to 
>> get up to speed, there will be a lot less need for cringeworthy 
>> moments.   And WGs might also become more productive.
>>
> ancient messages in archives which just doesn't happen. 

Getting up to speed requires reading trigabytes of ancient messages in 
archives because nobody summarizes it.

(Maybe that would be useful work for a newcomer, or not-so-newcomer, to 
take on.   But that person pretty well needs to start from day one of 
the WG, and even then supply some additional background material.)

> Even we who have been around for a while who might know in our gut 
> that something is not exactly new have a hard time determining that 
> one way or the other. I'm sort of channeling the previous thread on 
> outside researchers and their reluctance to bring their work forward 
> thread. Getting snarled at for that is definitely a complete turn off. 

Of course it is.   But there are two ways to deter people getting 
snarled at.  One of them is to tell people to not snarl.   The other is 
to teach newcomers what they need to know to not be snarled at.   
They're not mutually exclusive.

Keith

---

From: Andrew Sullivan <[email-masked]>
Date: Thu, 15 Apr 2021 23:17:04 -0400

Dear colleagues,

I work for the Internet Society, but I must emphasise that I do not
post in that capacity; neither does this represent the position of the
Internet Society.

On Thu, Apr 15, 2021 at 09:34:20PM -0400, Keith Moore wrote:

>The other 
>is to teach newcomers what they need to know to not be snarled at.   

Of course they aren't mutually exclusive, but only a culture of
entitled self-indulgent old fools who are going to die out due to the
inevitable ravages of age would suppose that the right approach to
possible newcomers is to beat them long enough that their morale
improves.  If that is really the future of the IETF, then I regret any
association I have ever had with it.  What a horrifying plan!  The
IETF is simply not that important, and if you think this is the way to
embrace the future I urge you that perhaps you might listen
(presumably again) to Dylan's "The Times They Are A-Changin'".

Best regards,

A

-- 
Andrew Sullivan
[email-masked]

---

From: John C Klensin <[email-masked]>
Date: Thu, 15 Apr 2021 23:49:22 -0400

--On Thursday, April 15, 2021 23:17 -0400 Andrew Sullivan
<[email-masked]> wrote:

>> is to teach newcomers what they need to know to not be
>> snarled at.    They're not mutually exclusive.
> 

As a possible candidate for your self-indulgent old fool
category (at least qualified on the basis of almost certainly
being older, and equally certainly around the ARPANET and
Internet longer, than either you or Keith)...

    +1

FWIW given the age allusion, I may be unique but, as I get
older, I find myself getting less tolerant of abusive or
dismissive behavior --whether directed toward me or toward
others including possible newcomers-- than I was 30 or 40 years
ago.

best,
   john

---

From: Ole Jacobsen <[email-masked]>
Date: Thu, 15 Apr 2021 22:12:40 -0700

+1000 to what both Andrew and John has said!

But I think this discussion has assumed that newcomers are
necessarily looking to get directly involved with a working group
from Day One and therefore need to do a lot of homework and
preparation. I know we keep telling the world that the IETF is "not
a conference" and that "people come here to work," but I see no harm
in simply exploring what the IETF is all about and then perhaps
getting involved in a particular effort after some time, after
having attended a few meetings, and most of all after having made
friends and even discovered who to avoid! :-)

Speaking as a Professional IETF Lurker with exactly 100 meetings
under my belt, I may not be your typical attendee, but I am surely
not the only person who participates in the IETF mostly to "learn what
is going on" and perhaps get involved in some projects or protocols
from time to time, and above all keep in touch with colleagues from
all over the world/industry. I have written exactly two RFCs and that
was a very long time ago, but some of you may remember other activities
that I have contributed to over the years.

If newcomers risk being "snarled at" it is only due to our own
culture and abusive behavior and not due to their lack of preparation.
or coaching.

Ole

> On Apr 15, 2021, at 20:17, Andrew Sullivan <[email-masked]> wrote:
> 
> Dear colleagues,
> 
>> The other is to teach newcomers what they need to know to not be snarled at.   They're not mutually exclusive.
> 

Ole J. Jacobsen
Editor and Publisher
The Internet Protocol Journal
Office: +1 415-550-9433
Cell:   +1 415-370-4628
Web: protocoljournal.org
E-mail: [email-masked]
E-mail: [email-masked]
Skype: organdemo

---

From: Fernando Gont <[email-masked]>
Date: Fri, 16 Apr 2021 02:59:45 -0300

On 14/4/21 15:59, John Levine wrote:
> It wasn't working. 

And that didn't seem to matter. I did report why I thought the program 
was failing, quite a few times, and also provided suggestions. -- but no 
changes.

Looked like the goal was having a program, in itself, rather than having 
a program to achieve a goal. (i.e., as if there was a box to tick).

> The people would come to a meeting but then

There are lots of aspects involved.

* Selection:
   Granting a fellowship to people who don't have a clue about the IETF,
   and didn't bother to have it, is a non-starter. At the very least,
   there should be proven technical participation.

* Clear expectations out of the program:
   There didn't use to be any, other than "sharing the experience with
   your community".

* Sustained support
   Supporting people to attend *one* meeting every now and then, when
   they have no chance to support their ongoing participation over time
   will not help much of a difference.

* Support such people in building a community
   If the program finds people that is capable, support them in further
   building their communities. -- this can indirectly support their own
   IETF work.

* Don't aim to create evangelizers, but rather support local engineers
   that can help evangelize via their IETF work.

And: If you want to help a community, rather than tell them what you 
think they need, ask them how they think you can help them.

Just my two cents,
-- 
Fernando Gont
e-mail: [email-masked] || [email-masked]
PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

---

From: Fernando Gont <[email-masked]>
Date: Fri, 16 Apr 2021 03:05:57 -0300

On 15/4/21 11:06, Salz, Rich wrote:
> One idea I had, which I mentioned to Lars when we chatted after the Nomcom selections, was an "invite a friend" program. If you come to the IETF, and you "sponsor" a colleague, then they get reduced/free admission. Of course, all sorts of details to be worked out there.  But I hoped it could encourage distributed diversity. 

Please define diversity. If by diversity you mean "some new face from a 
popular company, from one of the usual countries", maybe we have a 
different understanding on what diversity means.

Thanks,

---

From: Fernando Gont <[email-masked]>
Date: Fri, 16 Apr 2021 03:08:38 -0300

On 15/4/21 11:45, Theodore Ts'o wrote:
[...]
> will be part of your own distinctive "brand" as an software engineer.

That depends a lot on where you are based. In many places, career-wise, 
you might be better off getting a networking certification than writing 
a protocol standard -- no matter how good or important the standard is.

-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Fernando Gont <[email-masked]>
Date: Fri, 16 Apr 2021 03:14:25 -0300

On 15/4/21 19:53, Warren Kumari wrote:
[...]
> 
> 
> However, as much as I like this idea, it also has some really bad 
> downsides -- it implicitly advantages those from larger companies. 

So does the "power structure" in the IETF. -- the very requirement to be 
a NOMCOM member favor those who attend the f2f meetings, which tend to 
be sponsored by larger companies. Similarly, there seems to be a bias in 
leadership positions towards larger companies.

Cheers,

---

From: Fernando Gont <[email-masked]>
Date: Fri, 16 Apr 2021 02:45:41 -0300

On 14/4/21 15:01, Jim Fenton wrote:
> inclusive. 

Well, the amount of energy spent on the topic, and how little we have 
discussed all other issues, might seem to indicate that, indeed.

FWIW, people should probably talk about "non-derogatory" language rather 
than about "inclusive terminology" -- unless they really think e.g. 
those are the core reasons that hinder diversity.

> I don’t know what those more meaningful efforts might be, but 

At least when it comes to the *problems*, this might be of use: 
https://tools.ietf.org/html/draft-gont-diversity-analysis

Thanks,

---

From: Brian Carpenter <[email-masked]>
Date: Fri, 16 Apr 2021 19:01:33 +1200

The f2f part is simply not true for the next two years; please see RFC8989.

Regards,
    Brian Carpenter
    (via tiny screen & keyboard)

---

From: S Moonesamy <[email-masked]>
Date: Fri, 16 Apr 2021 00:43:13 -0700

Hi Eduard,
At 01:14 AM 15-04-2021, Vasilenko Eduard wrote:
>You are very close to the root cause. The root 
>cause is motivation. Well, probably one could 
>say that it is "culture" or part of the culture.
>
>Many people in IETF have a personal motivation 
>that is not fully in line with the "public good".
>For example: publish any nonsense to report 
>personal IETF progress for the employer. 
>Rigorously fight back even if somebody would 
>show that particular idea is on the opposite side from perfect.
>Example 2: never dispute any job of others, even 
>if they propose something really bad. It would 
>destroy your relationships, people could fight back to your proposals later.
>Example 3: support whatever chair would propose, 
>never criticize the boss – yoou are dependent on him.
>Example 4: create small closed groups and help 
>each other on every occasion (without paying any attention to the public good).

I'll express an opinion instead agreeing (or disagreeing) with you.

Every group learns and shares common some 
behavior and beliefs.  We both likely have 
different motivations to participate in this 
group.  We both have our own beliefs of what 
constitutes the "public good".  This group, or 
can I say task force, version of what constitutes 
the "public good" is the technical 
specifications, mailing list discussions, and 
minutes (of meetings) which are provided for 
free.  Does this version of the "public good" 
benefit, on balance, the public or private 
interests?  My guess is that it is the latter.

Regards,
S. Moonesamy

---

From: Lars Eggert <[email-masked]>
Date: Fri, 16 Apr 2021 11:21:08 +0300

Hi,

On 2021-4-15, at 21:44, Keith Moore <[email-masked]> wrote:
> Somewhere there needs to be a resource that points IETFers who are interested in routing and addressing, or anything that touches them or relies on them, to some current information about those topics, with pointers to even more detail.   And that resource should probably also point out currently-unsolved important problems, just to get people interested (maybe kind of like the exercises in Knuth's The Art of Computer Programming books).   If good resources like this already exist, great; if not, someone needs to be recruited to write them.   And similar resources are needed for several other layers or widely-used technologies: "the web", email, transport protocols, DNS, etc.

the EDU team and EMODIR have been producing such material and organized sessions, sometimes in collaboration with the IESG. For example, "Technology Deep Dive - Modern Router Architecture" at IETF-104: https://datatracker.ietf.org/meeting/104/materials/slides-104-wgtlgo-forwarding-plane-realities-00.pdf. Similar sessions on other part of the architecture have been done or are being prepared.

Participants who are interested in preparing and holding such sessions - or help with the IETF's education, mentoring and outreach activities - should get in contact with [email-masked].

Thanks,
Lars

---

From: tom petch <[email-masked]>
Date: Fri, 16 Apr 2021 09:27:56 +0100

On 16/04/2021 02:17, scott wrote:
> fine tooth comb for nits, bad grammar, unclear text, etc and especially
> from fresh eyes from the perspective of a potential
> valuable input?'  Paraphrasing...  Since then I have been a lurker just
> because I want to learn.

It varies a lot with the Working Group.  Yes, there are some closed 
shops, usually those producing one or a limited number of I-D, who 
resent anyone else daring to comment on their perfect product, even if 
the person concerned has been around a few decades and authored many RFC.

There are others, usually engaged in mass production, who thank you for 
pointing out that 'maybe' and 'perform' are being misused.

Rather than diving in with comments, ask if they are wanted.  e-mail the 
WG Chair - and that is an important first lesson, what is a Chair, what 
do they do and what do they not do uin the IETF, and again, it varies 
widely, and ask the Chair, such as I have been looking through 
draft-ietf and notice some unfamiliar usage, would you like me to post 
it to which the answer may be a link to Github at which point abandon 
that WG and try another- or not, depending on your background:-)

How do you join any group anywhere that has been around a while, is 
task-oriented and has created its own norms which you have no way of 
finding out about?  Again the fact that the e-mail history is accessible 
is a great help, but only people know of it.

HTH

Tom Petch

---

From: Vasilenko Eduard <[email-masked]>
Date: Fri, 16 Apr 2021 10:55:23 +0000

Hi S. Moonesamy,
The diversity of humans (for the matter that I have touched below) are very big even if one takes a very small and uniform part of the population.
IETF covering the whole world - diversity is in the full range possible (100%).
It does not help on average (or better median - for the biggest crowd) - the motivation is distorted.

The discussion for what is "public good" is not important in this context - the difference in understanding would be relatively small.
Eduard
-----Original Message-----
From: S Moonesamy [mailto:[email-masked]] 
Sent: Friday, April 16, 2021 10:43 AM
To: Vasilenko Eduard <[email-masked]>; [email-masked]
Subject: Re: Wow, we're famous, was WG Review: Effective Terminology in IETF Documents (term)

Hi Eduard,
At 01:14 AM 15-04-2021, Vasilenko Eduard wrote:
>You are very close to the root cause. The root cause is motivation. 
>Well, probably one could say that it is "culture" or part of the 
>culture.
>
>Many people in IETF have a personal motivation that is not fully in 
>line with the "public good".
>For example: publish any nonsense to report personal IETF progress for 
>the employer.
>Rigorously fight back even if somebody would show that particular idea 
>is on the opposite side from perfect.
>Example 2: never dispute any job of others, even if they propose 
>something really bad. It would destroy your relationships, people could 
>fight back to your proposals later.
>Example 3: support whatever chair would propose, never criticize the 
>boss - yoou are dependent on him.
>Example 4: create small closed groups and help each other on every 
>occasion (without paying any attention to the public good).

Every group learns and shares common some behavior and beliefs.  We both likely have different motivations to participate in this group.  We both have our own beliefs of what constitutes the "public good".  This group, or can I say task force, version of what constitutes the "public good" is the technical specifications, mailing list discussions, and minutes (of meetings) which are provided for free.  Does this version of the "public good" 
benefit, on balance, the public or private interests?  My guess is that it is the latter.

Regards,
S. Moonesamy

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 16 Apr 2021 14:12:00 +0200

I fully agree with those observations, and it happens not only in the IETF, but also in many other forums, such as the RIRs.

Motivation for participating in the IETF MUST BE the overall good of the community, but in many cases is not like that, which is pity.

There are commercial/competition decisions, egos (personal and companies), need to justify yourself towards your employers, etc.

It should be always technical decisions for the good of the community and that shold be observed when deciding about consensus.

Regards,

Jordi

@jordipalet

El 15/4/21 10:15, "ietf en nombre de Vasilenko Eduard" <[email-masked] en nombre de [email-masked]> escribió:

Hi Victor,

Eduard

 

regards,

Victor K

-Jim

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 16 Apr 2021 06:02:24 -0700

> should focus more on the mentoring program...

I also like that idea of "invite a friend", but IMO one of the conditions should be that the friend should be from a different company.  I agree that it is more difficult to mentor someone from a different company, but that should be the goal.  RFCs should not have authors all from the same company, for obvious reasons, so mentorship should not either.

As I said elsewhere, I do not think that attending an IETF meeting should be the very first item on the list of things to do in such mentorship.  So one cannot use IETF meetings to select a mentoree.  But maybe we could use other venues for that:  Local meet-ups, ISOC chapter meetings, ACM chapter meetings maybe good places to network with the intent of finding a mentoree.  Ask the organizer to ive you a coupel minutes to present the idea.  Have a couple lunches (or video calls until we are back to normal) to discuss the respective goals of mentor/future mentoree and see if there is enough affinity.  Choose one and proceed from there.

Again, most of the messages I read in these threads are about asking the IETF or ISOC to do something about it.  I think that's just procrastination.  My point is that we can make an impact without any sort of formal group telling us what to do.  Just do it, report your experience and do better with the next mentoree.

---

From: Ofer Inbar <[email-masked]>
Date: Thu, 15 Apr 2021 12:34:23 -0400

I'm not writing to express an opinion about what TERM should or should
not recommend; I'm writing to express frustration that people think the
NY Times comments section is applicable as a form of "lack of consensus".

I'm going to make three points, ordered from least to most important:

First of all, not only is the NY Times readership not representative
of the US population, but also the comments section is not
representative of NY Times readership - it is a small and
systematically different subset.  And, neither the US population nor
the NY Times readership is representative of potential IETF
participants or potential technologists who may use IETF documents.
So this population's relationship to the population we should care
about is vauge and indeterminate, which makes this inapplicable.
Even for the negative case.

Secondly, IETF consensus isn't based on the potential population as a
whole; it's supposed to be the consensus of the group that has spent
time working on and studying that specific issue and are very familiar
with all of the reasoning in various directions, and the pros and cons
of each decision.  It's their consensus we care about, not random
others - who may even be active IETF members - who just looked at a
brief summary and gave their opinion.  Those random others can give
very useful insights and if they make valid points we should consider
them, but they're not part of the consensus call, nor should they be.
I'm sure that there are many times when an IETF working group has come
to consensus even while plenty of less informed people leaned in a
different direction, and that's how the system is supposed to work,
for a reason.

Thirdly and most importantly, this discussion is blatantly conflating
"consensus" on completely different matters anyway.  I'll make an
analogy to usability testing to illustrate.

I once worked at social media web startup, before they launched, and I
instituted usability testing and organized the first several rounds.
We initially had a navigation bar down the left side plus another bar
on the right side that had some important links.  In one of my first
sessions, we brought six users in to try a series of simple tasks, at
least one of which called for using a feature whose link was on the
right.  4 of the users quickly clicked on the link, since its text
matched the task we asked them to do; 2 of the users searched around
the page for a while and gave up and said they couldn't figure out how
to do what we asked.  When shown the link by the tester (me) so we
could proceed, one said "oh I ignored all that section, it looked like
an ad" and the other wasn't sure why they didn't notice it, but they
had spent more than 60 seconds searching and mousing around the page.

If we went by the logic I've seen in this thread, I would have
concluded that there was no consensus that putting navigation links on
a colorful sidebar on the right was a problem, and in fact preponderance
of the evidence suggested it was not a problem because 4 out of 6
users had no trouble with it.

When it comes to what TERM is supposed to be doing, we are NOT looking
for "consensus" on whether you want terms changed or whether they're a
problem for you personally.  We're looking for the consensus of informed
people on whether changes in terminology can on balance make things
better, and that depends in part on whether existing terms are a
problem or barrier for *some* relevant people, as well as on other
things (such as what kinds of changes to recommend and the costs of
those recommendations), but absolutely does NOT require that any
particular terminology is a problem or barrier for a *majority* of
relevant people in order to recommend changes.

I leave it to the people in the group to spend the time to actually
study the issue and determine what the issues and tradeoffs are, in
the context of IETF documents.
  -- Cos

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 16 Apr 2021 15:27:06 +0000

Again, I apparently led people to think that I meant colleague.  I deliberately said "bring a friend."

---

From: Warren Kumari <[email-masked]>
Date: Fri, 16 Apr 2021 11:47:12 -0400

On Thu, Apr 15, 2021 at 8:54 PM Keith Moore <[email-masked]>
wrote:

> Well, the nature of a newcomer is that they **won't** be well prepared.
> Disagree.   They won't know everything, of course, but if they know enough
> about the subject matter to clearly know what they're talking about,
> they're much more likely to be taken seriously.
>

Yup - but it's not just the subject matter, it's also some of the
history/culture/etc. I *always* recommend that newcomers read the Tao (
https://www.ietf.org/about/participate/tao/). It's much much less scary to
participate if you have at least some vague idea how the system works. Even
"silly" things like dress code (doesn't really apply any more), what the
dots mean, what a blue sheet is, etc. Knowing some of this stuff makes
people feel more like insiders, instead of wondering why people keep
humming, or shouting "Mike!!!"

> limited to newcomers to IETF.

Indeed. As with any group, we have our own "culture" and clique - we have
tried to make it easier for people to come in (see the Tao, Scott Bradner's
Newcomer videos, Edu team, Mentors, etc). We've done more than some other
groups I can think of, but it can still be intimidating.

W

---

From: Mary B <[email-masked]>
Date: Fri, 16 Apr 2021 12:20:37 -0500

I was going to respond to Jim, but I think Victor's response is accurate
and I go so far as to say that I don't  think the terminology is in any way
a barrier to participation in IETF.  And, it's the last solution I would
put in a list when it comes to diversity.   I will acknowledge, it seems to
be the right thing to do politically at this time.

The problem in IETF is not these terms, but rather it's our culture and how
we interact as humans.  Many of us don't have what might be a culturally
acceptable way of interacting with other humans (and I'd go so far as to
say that some folks are not aware that they fall into that category).  Most
of us are very blunt, sometimes to the point that many would consider us
rude.  Some humans are fine with (and some actually appreciate) that we say
what we think. And, I think it's something that's extremely important in
doing things right and getting work done.   Being nice and not telling
someone that we don't think their proposal is going to fly is not a good
thing.

At the same time, people that come from cultures or environments where this
isn't how you ever interact with other humans will often not be comfortable
here or want to pursue their work here.   I've participated in many of the
newcomer activities and I told one newcomer that was a woman that she would
have to push back on folks that wanted to interrupt her before she finished
her presentation and react and treat people in a way that would disappoint
her parents. And, I speak from experience where I wish I'd done that - the
SIP WG meeting in Vienna is a great example of this (I'm still traumatized
by that incident).    So, again, we get into cultural issues.   My mother
would be appalled at how I interact with people in IETF meetings (as she
has been in other situations).  My father has resigned himself and his
basic view is that I inherited his intellect, but not his tact.  I'm just
thankful my mother wasn't Southern or she would have made me go to
cotillion. And, for folks that don't know what cotillion is, the purpose of
a cotillion is to teach respectful manners to young people so they can go
out and thrive in society (it includes manners, interacting with the
opposite sex in social situations, etc.).  I will confess that I sent my
sons because I knew I wasn't qualified to teach them myself.   And, in the
spirit of being blunt, there's clearly a whole lot of other IETFers in that
category, some of whom we appoint to leadership.  We are a group of very
smart people, but not a group of very polite people - you only have to
watch the behavior during snack breaks (around the cookies in particular)
to see this.

And, I will highlight that I'm the only woman responding on this thread and
it's not unusual for us to have threads where there are no responses from
any women.  Now, I could share why I think that is, but I know there will
be responses that tell me how wrong I am and that it isn't harder or more
hostile for women to work in this environment...and so it goes.

That all said, in one sense IETF is a microcosm of the industry and while
some companies have significant initiatives to address the diversity
issue,  it's still a significant issue that I think is only magnified in
IETF.

Regards,
Mary.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 16 Apr 2021 17:40:51 +0000

> > And WGs might also become more productive.

I'm not really replying to this directly, but more to the thought it made me have.
What if we have a "WG mentor(s)" in each WG? This could be chairs, but doesn't have to be. It's something I see some chairs do, but far from all.
One role would be "if you want to post something to this WG but don't feel comfortable, feel free to reach out to this person and ask". Then this person could provide some private feedback and maybe any history that the post would be coming up against. The WG mentor could also help set the tone of the initial response to a new person. If a new person posts something without contacting the mentor first and immediately gets laid into, the mentor could reach out and provide some private constructive feedback and encouragement.

Anyway, it's just a thought about something that could be experimented with and doesn't require money or massive change. Y'all have a great weekend.
Barbara

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 16 Apr 2021 14:44:09 -0700

> honestly might help motivate some.  Maybe.

I'd like to point out that it is not always true.  I had some reviews over the years that were not acknowledged in the final version of the RFC and I must say that spending hours on a substantial review without the only reward you could ever get for it is not a great feeling, especially as a newcomer.  Let's just say that the authors of these RFCs are not going out of my do-not-review list anytime soon.

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 17 Apr 2021 10:09:19 +1200

Warren, and everybody,

The material at
https://www.ietf.org/about/participate/get-started/
is only as good as we make it. If you think it could be improved, don't say it here, send concrete suggestions to the appropriate place (now [email-masked], I think).

   Brian

On 17-Apr-21 03:47, Warren Kumari wrote:
> 
> 
> On Thu, Apr 15, 2021 at 8:54 PM Keith Moore <[email-masked] <mailto:[email-masked]>> wrote:
> 
>>>     I've found that newcomers are much more likely to be taken favorably if they're well-prepared.
>>
>>     Well, the nature of a newcomer is that they **won't** be well prepared. It's sort of the nature of the beast. 
> 
>     Disagree.   They won't know everything, of course, but if they know enough about the subject matter to clearly know what they're talking about,  they're much more likely to be taken seriously.
> 
> 
> Yup - but it's not just the subject matter, it's also some of the history/culture/etc. I *always* recommend that newcomers read the Tao (https://www.ietf.org/about/participate/tao/). It's much much less scary to participate if you have at least some vague idea how the system works. Even "silly" things like dress code (doesn't really apply any more), what the dots mean, what a blue sheet is, etc. Knowing some of this stuff makes people feel more like insiders, instead of wondering why people keep humming, or shouting "Mike!!!"
> 
>     And the problem of participants not being well-prepared isn't at all limited to newcomers to IETF.
> 
> 
> Indeed. As with any group, we have our own "culture" and clique - we have tried to make it easier for people to come in (see the Tao, Scott Bradner's Newcomer videos, Edu team, Mentors, etc). We've done more than some other groups I can think of, but it can still be intimidating.
> 
> W
> 
>  
> 
>     Keith
> 
> 
> 
> 
> 
> --

---

From: John C Klensin <[email-masked]>
Date: Fri, 16 Apr 2021 23:03:28 -0400

Ole,

I think you have captured something important but that Randy's
additional comments expose an additional part of the problem.

First, you are absolutely right.   I have seen people who come
to meetings (or watch mailing list) and just do so to observe
and learn what is going on snarled at, but it has been very,
very rare.  Two pieces of advice I give newcomers, advise that I
think is applicable to those who come with a particular topic
focus and those who just come to learn, are to not interrupt a
WG meeting (or equivalent) with suggestions, or even questions,
until they are watched enough to be confident they understand
what is going on and, if they figure out that they don't
understand something, to ask outside an active meeting/
discussion session.   In that regard, one of the most important
and useful features of our various one-on-one "help and guide
the newcomer" efforts, no matter the details of how they have
been organized or titled, has been that they provide a mechanism
for pointing people with questions to someone who would be
likely to be able to answer them and do so patiently.

>From that perspective, much of the "snarling" (or worse) that is
directed against newcomers or others is the result of
unfortunate behavior on the part of those people.  Standing up
(physically or virtually in a busy WG session or on an already
busy mailing list and taking up time advocating an idea that
(almost?) everyone else in the room believes to be seriously
wrong, already examined and rejected (with the person making the
suggestion not really saying anything new), or just in violation
of conventional wisdom is likely to produce a bit of "snarling"
... and worse on the second or third attempt.  Randy is right --
other professional communities, especially in the physical
sciences, can be even more abusive in those contexts than we
often are.  It is not hard to imagine what would happen to
someone who stood up in a contemporary meeting of chemists and
said that they have a brand-new theory to explain why things get
heavier when they burn and this "oxygen" theory is nuts and a
dead end, or what would happen in a meeting of planetary
astronomers (or students in the upper grades of elementary
school) if someone stood and pointed out that it was obvious
that the sun rotates around the earth and moreover that the
earth itself is obviously flat.  Should they, and we, treat such
input with more sympathy and willingness to educate --at least
up to the point where it becomes clear that the new people is
absolutely not interested in being educated-- absolutely.  But
inappropriate or excessive reactions to someone asking questions
or proposing a radical idea is still different from treating
every newcomer as a hopeless, ignorant, fool until proven
otherwise (or making a habit of snarling).  And we should also
probably remember that neither Priestley nor Copernicus were
treated very well when they first proposed their idea be a bit
less sure of ourselves and the reasonableness of our reactions.  

But Randy's other point is, IMO, important too.  Suppose we
could adopt a rule that forbade snarling at people until after
they had participated in the IETF for a few years and magically
changed the culture so that everyone observed it, at the same
time declaring open season on people with longer participation
records or at least a couple of RFCs behind them.  Whether
because of what Randy describes as having a shred of empathy or
because of the sense that they are likely to be treated
obnoxiously and aggressively about the time they were ready to
make significant contributions, people would still go away after
watching others be mistreated, abused, or dismissed.  

It really is time we clean up our acts.  And, for better or
worse, I think that insensitive choices of vocabulary are, while
important, a very small portion of the problem.

    john

--On Thursday, April 15, 2021 22:12 -0700 Ole Jacobsen
<olejacobsen=[email-masked]> wrote:

> necessarily looking to get directly involved with a working
> group from Day One and therefore need to do a lot of homework
> and preparation. I know we keep telling the world that the
> IETF is "not a conference" and that "people come here to
> work," but I see no harm in simply exploring what the IETF is
> all about and then perhaps getting involved in a particular
> effort after some time, after having attended a few meetings,
> and most of all after having made friends and even discovered
> who to avoid! :-)
> 
> Speaking as a Professional IETF Lurker with exactly 100
> meetings under my belt, I may not be your typical attendee,
> but I am surely not the only person who participates in the
> IETF mostly to "learn what is going on" and perhaps get
> involved in some projects or protocols from time to time, and
> above all keep in touch with colleagues from all over the
> world/industry. I have written exactly two RFCs and that was a
> very long time ago, but some of you may remember other
> activities that I have contributed to over the years.
> 
> culture and abusive behavior and not due to their lack of
> preparation. or coaching.
>

---

From: S Moonesamy <[email-masked]>
Date: Sat, 17 Apr 2021 04:03:35 -0700

Hi Nico,
>But we _care_ so *so* much!

Your point, from what I understood, is that people which care about 
participants from economically disadvantaged countries would not have 
been quiet on hearing that the program which was set up to provide 
financial support to those participants was terminated.  John Levine 
pointed out that "The people would come to a meeting but then 
wouldn't write I-Ds or continue to engage with the IETF".  There was 
a discussion about the program in 2013 [1].  In general, it doesn't 
take seven years to figure out that a program is mismanaged.

I haven't seen any complaint about the termination of the sponsorship 
program; it could be different in the region where Fernando is 
located.  The important question is whether broad participation is in 
the interest of an organization which promotes itself as a a large 
open international community concerned with the evolution of the 
Internet architecture and the smooth operation of the Internet.  It 
would be difficult to influence the operational side without broad 
participation.  There is also a perception of regulatory capture when 
there is overrepresentation of a few companies in the standards 
development process.

Regards,
S. Moonesamy

1. http://r.elandsys.com/r/50988

---

From: Michael Thomas <[email-masked]>
Date: Sat, 17 Apr 2021 08:07:18 -0700

> watching others be mistreated, abused, or dismissed.

I don't know how you enforce such a thing because who knows whether 
somebody is new to IETF or just new to a particular working group? 
Frankly there ought not be such a distinction, as it is intimately 
related to the "security researcher" problem discussed previously. The 
problem is that too often working groups become fiefdoms and accrue 
self-coronated manner lords while the chairs sit idly by, or worse 
enable them. It is extremely off putting for chairs to shut down 
questions as off topic or members jumping down your throat for questions 
that cannot reasonably be answered any other way. Who needs that kind of 
grief? Especially when you're not getting paid to take it.

Mike

---

From: Larry Masinter <[email-masked]>
Date: Sat, 17 Apr 2021 09:00:55 -0700

Let me suggest that "New-comers" provide an essential resource to aid the IETF in assuring one of it's core values -- that the standards it produces can be read, understood, and implemented interoperably and securely by others now and in the future -- and not just by the members of a small insider  design and authoring group.

It is (or should be) the responsibility of the working group chair to manage the conversation in an IETF open meeting to manage the group, invite newcomers to ask questions and insure they get sincere and thoughtful responses.

---

From: John C Klensin <[email-masked]>
Date: Sat, 17 Apr 2021 13:28:03 -0400

(IESG copied because of the last paragraph)

--On Saturday, April 17, 2021 08:07 -0700 Michael Thomas
<[email-masked]> wrote:

>> they had participated in the IETF for a few years and
>> magically changed the culture so that everyone observed it,
>> at the same time declaring open season on people with longer
>> participation records or at least a couple of RFCs behind
>> them.  Whether because of what Randy describes as having a
>> shred of empathy or because of the sense that they are likely
>> to be treated obnoxiously and aggressively about the time
>> they were ready to make significant contributions, people
>> would still go away after watching others be mistreated,
>> abused, or dismissed.
> 
> I don't know how you enforce such a thing because who knows
> whether somebody is new to IETF or just new to a particular
> working group? Frankly there ought not be such a distinction,
> as it is intimately related to the "security researcher"
> problem discussed previously.

Mike,

Sorry... I obviously wasn't clear.  I was trying to pose a
hypothetical and extreme scenario precisely to point out that it
would not work, not advocating it.  That was why I said "suppose
we could" and "magically".   In the real world, not only could
such a thing not be enforced, but we would need, IMO, to be
collectively insane to try it.

> The problem is that too often
> working groups become fiefdoms and accrue self-coronated
> manner lords while the chairs sit idly by, or worse enable
> them. It is extremely off putting for chairs to shut down
> questions as off topic or members jumping down your throat for
> questions that cannot reasonably be answered any other way.

Indeed, that is at least a key part of the problem -- and a
problem that I believe Andrew, myself, Randy, and probably Brian
were trying to address from our different perspectives.  It is
the part of this problem that I think has gotten worse in the
last decade or so.  It is one that the anti-harassment
procedures and guidelines for conduct developed during that
period either do not address or have proven inadequate to
prevent or remedy.  I suggest that guidelines for improved
terminology will not help either.  People can jump down the
throats of others (or snarl at them) for departing from
homogeneous opinion or the preference of leadership in a WG (or
even in other contexts) without violating any specific rules
(even though it is fairly clear from RFC 7154 that it is bad
behavior) with impunity.

> Who needs that kind of grief? Especially when you're not
> getting paid to take it.

Exactly.

I don't see any way to stop that behavior -- and stop it from
driving people away from those WGs at least and probably the
IETF more generally -- unless:

(1) The IESG, perhaps borrowing ideas for other SDOs, will not
tolerate (i.e., charter or allow to continue) WGs whose
participation represents only a narrow range of interests.

(2) The IESG and community will not tolerate WGs (or other
groups) in which shutting down dissent or questions that differ
from the opinions of WG leadership (including de facto
leadership by those you describe as manor lords) is a regular
practice.

(3) The community has effective ways to push back on individuals
who exhibit that sort of shutting down or snarling behavior
regularly, whether it is confined to one WG or not. 

Of course a WG should not need to tolerate someone who raises
the same questions or proposals repeatedly after they have been
fairly considered and rejected, but that is disruptive behavior
and we have many years of mostly-successful experience in
dealing with it. 

Independent of the impact on feelings and participation, the
behavior you describe damages the credibility of the IETF and
its work if a cabal, especially one with shared commercial
interests, can take over (or initiate) a WG, push documents into
and through IETF Last Call, and then successfully claim IETF
consensus and standards status for the results.

And none of the above would likely be meaningful or effective
unless there is also a mechanism for reporting problems and
having them considered that does not put the reporter at risk
for further abuse.  In that regard, the recent IESG statement
about Last Calls may be a step backward. If someone feels a need
to make a Last Call comment identifying ways in which claimed
consensus (in a WG, on a mailing list, etc.) is invalid because
those who disagreed were silenced or driven away, it should be
possible to make that comment to the IESG with the same degree
of anonymity associated with the Ombudsteam process.  More
generally, someone should be able to make such a report to an AD
or the whole IESG at any time and have it taken seriously
without disclosing the identity of the reporter.  At least for
Last Calls, that seems to be precluded by the new process
description.

    john

---

From: Larry Masinter <[email-masked]>
Date: Sat, 17 Apr 2021 14:24:42 -0700

You can't eliminate bad behavior by making more rules. By the time you get
to reportable problems (be it smearing or down-throat-jumping) things have
gotten way over the line.

What I remember from the HTTP-WG (which had lots of newcomers) was to set up
discussion with a short presentation on an issue, and to call on people with
hands up sweeping the room from left to right. No mike hogging, ask everyone
to start with their name and affiliation.
(I suppose in a virtual meeting you could let people speak in alphabetical
order.) Make sure questions or issues are understood  and answered.

Some amount of reinforcement that newcomer's misunderstandings are often
failings of the work documents to adequately explain their design.

---

From: Michael Thomas <[email-masked]>
Date: Sat, 17 Apr 2021 15:03:05 -0700

> (even though it is fairly clear from RFC 7154 that it is bad

Part of the failing is that passive aggressive behavior is tolerated in 
my experience. But outright hostility is certainly tolerated way too 
much too. Just because you aren't couching something as an ad hominem 
doesn't mean that you aren't being aggressive. Part of the problem is 
passive working group chairs and that AD's don't scale to deal with 
that. Indeed, if you're an AD about the last thing you want on your 
plate is wg chairs behaving badly I would think. Essentially you're 
talking about taking the time to get the back story for somebody who can 
only keep loose tabs on the tech, let alone how the wg is being run and 
its day to day operation.

> leadership by those you describe as manor lords) is a regular
Dang it, I knew my spelling looked suspect for manor :)
> regularly, whether it is confined to one WG or not.
It often becomes just a war of attrition until you ask why you're doing 
this. For a newbie that question gets asked a lot sooner rather than later.
> and we have many years of mostly-successful experience in
Right, I'm not talking about religitation on an individual basis. But it 
can be really hard from the outside to understand why various decisions 
were made and frankly I don't know of any other way to do that than just 
ask. Do we record hums and/or working group consensus calls and what 
they represent? Even that would go some way to help get up to speed. The 
document is the distillation of what the protocol is, but the back story 
of *why* it is the way it is is often just as important.
> consensus and standards status for the results.
What change was that?
> Last Calls, that seems to be precluded by the new process
This of course has the same AD scaling problem as above. Real Supreme 
Courts spend considerable time and effort with themselves and their 
staff to scale up, and that's their day job. AD have no such staff and 
working group squabbles are hopefully not a significant portion of their 
day job.

Mike

---

From: Michael Richardson <[email-masked]>
Date: Sat, 17 Apr 2021 20:02:33 -0400

Michael Thomas <[email-masked]> wrote:
    > that you aren't being aggressive. Part of the problem is passive working
    > group chairs and that AD's don't scale to deal with that. Indeed, if you're
    > an AD about the last thing you want on your plate is wg chairs behaving badly
    > I would think.

I think that ADs have hard enough time just getting any WG chairs.
Getting rid of poorly performing ones is probably terribly difficult.

Having fewer WGs would help for many things, including scheduling.

But, given the tendacy to having more WGs, with extremely narrow focus, means
that we need a lot more good WG chairs than we have.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Michael Thomas <[email-masked]>
Date: Sat, 17 Apr 2021 17:22:24 -0700

> that we need a lot more good WG chairs than we have.

I agree. I don't envy AD's even a little bit. It's thankless. That is a 
structural problem.

Mike

---

From: Keith Moore <[email-masked]>
Date: Sat, 17 Apr 2021 21:46:20 -0400

On 4/16/21 11:03 PM, John C Klensin wrote:

> It really is time we clean up our acts.

While I do think that we could possibly "clean up our acts" somewhat, I 
suspect that we will always need some way of pushing back on Bad Ideas 
and maybe even pushing back on participants who persistently promote Bad 
Ideas.   And that, to a newcomer, such pushing back will be seen as 
"snarling" or perhaps even worse, no matter how politely the pushing 
back is done.

We can't have an open discussion, one in which anyone is free to speak, 
without having Bad Ideas contributed.   Nor can we have an open 
discussion without the possibility of genuine conflict between 
legitimate interests (leaving aside the question of what is 
"legitimate"), and also the possibility of misunderstanding.  So there 
will always be a need for some form of pushback either against bad ideas 
or as part of the path toward consensus and/or compromise.

I suspect that such pushback will always be considered rude by 
newcomers, people who lack the context to understand the nature of the 
conflict, no matter what form it takes:  Whether it's a terse "-1" 
message, or a longer polite phrase like "I do not believe that this idea 
is viable", or if Bad Ideas and their contributors are widely ignored 
(but others may still reply thus amplifying the Bad Idea), or if we 
continue to let people express such pushback in their own words.

Any of us who has been around for very long has seen tremendous amounts 
of expensive time [*] has been wasted trying to deal with Bad Ideas - 
ideas that have repeatedly been considered and rejected in the past, 
ideas that are hopelessly naive or uninformed by reality, ideas for 
which the hazards are obvious to experienced participants but perhaps 
not to every participant.

([*] Especially time in f2f meetings which can easily represent hundreds 
of thousands of dollars in meeting and travel expense on the part of 
participants or their sponsors, and also wasting the time of extremely 
talented and knowledgeable people who were hoping to get useful work done.)

***

And sometimes, it should be admitted, the "Bad Ideas" aren't inherently 
Bad, but are being rejected for other reasons.   Maybe an idea sounds 
too much like an idea that has been rejected as Bad, and the difference 
is too subtle for people to notice.   Maybe the community is simply not 
ready to consider the idea.   Maybe some people do not like the person 
proposing the idea, and wishes to discourage that person.  Or maybe 
those people are so prejudiced against that person that they can't let 
themselves evaluate the idea on its merits.  Maybe the idea has 
potential, but threatens the interests of too many influential 
participants.   Or maybe an idea which was formerly rejected as Bad has 
been improved, but people once got so tired of discussing it that 
they're not willing to invest the effort (and fight the cognitive 
dissonance) required to fairly consider it again.

Conditions do change over time, and ideas once considered unworkable may 
become more acceptable and/or feasible as a result.   I remember when 
the general belief was that the web was too large to be effectively 
indexed by a search engine because CPUs and link speeds were too slow. 
I remember when it was considered infeasible to deploy a new transport 
protocol because of all of the different platforms that would have to 
change - there are fewer widely-used platforms now.   I remember when 
the idea of provider-independent IPv6 addresses for non-providers was 
heresy.

And sometimes an idea is inherently Bad, and no amount of persistence or 
effort will fix it.

But I also realize that sometimes the pushback against an idea is really 
not that important.   Sometimes it might be displaced discomfort about 
something else.   Sometimes we argue over trivial ideas and expressions 
that aren't likely to have any significant effect.   Maybe if we only 
had rude-seeming arguments about the ideas that seem to be really 
important, the overall perceived level of rudeness would go down.   But 
there will still be some ideas that are important enough that candor is 
more important than playing nice.

***

Every open discussion forum needs a way to push back on Bad Ideas.   And 
every discussion forum (that wishes to be technically honest) needs a 
way to reconsider formerly rejected ideas.   How we do each of these is 
hugely important.   Either we waste immense amounts of time endlessly 
discussing Bad Ideas, or we find a way to push back on them.   And 
either we find a way to reconsider formerly rejected ideas, or we paint 
ourselves into corners of technical irrelevance.

Perhaps we can define a better way of giving pushback than snarling.   
But I'm pretty sure that we could also do worse than letting people 
express their dislike for ideas in their own words.    I'd be especially 
wary of defining some standard "polite" way of rejecting Bad Ideas that 
doesn't let people express themselves.   We need some flexibility in how 
we give pushback, so that some people can open up doors at least a 
little bit, even if other people want to slam them shut.

Maybe it would help to have some concrete suggestions for non-snarling 
ways of pushing back on Bad Ideas.   As in "if you can't find better 
language to use, try one of these boilerplate alternatives".

Keith

p.s. I've definitely been the target of "snarling" and worse, including 
overt personal attacks. Unpleasant though it was, I tried to just accept 
it as a sign that the community wasn't ready to consider the idea at 
that time.  I do think we can and should treat one another better than 
that.  But even if we choose better ways of pushing back, I'm not sure 
how obvious the difference will be to newcomers, who may still think 
we're being rude.

---

From: "Bron Gondwana" <[email-masked]>
Date: Sun, 18 Apr 2021 16:11:07 +1000

Not sure if deliberate misunderstanding or not - but I believe this is about my comments since I was the main proponent of "a lack of consensus in the NY Times comment section supports a hypothesis of a lack of consensus in wider US society".

And none of your long comments here address that, they instead conflate it with IETF consensus (which I never claimed that the NY Times comment section has any bearing on).

I would claim there isn't rough consensus on whether particular technical-English terms should be retired in the US population, let alone in the rest of the world.  I doubt there's even rough consensus within the English-speaking technical world, most of whom are just keeping their heads down and trying to do their jobs.

So I believe your source of frustration is a misunderstanding of what I wrote.  I guess at the furthest analysis that is my fault for being unclear, and I apologise that I wasn't able to make my point sufficiently.

Regards,

Bron.

P.S. Your example shows that it's all about how you phrase the question - what's the burden of proof here - that the sidebar design was good, or that it was bad.  Flip the logic and you also don't have consensus that it's a good idea to have the navigation on the sidebar.  Consensus would be all 6 finding it easy to use.  33% disagreeing is not consensus by any definition of the word, even the IETF Tao would say "you need to understand and address their objection" or something to that effect.

---

From: "Bron Gondwana" <[email-masked]>
Date: Sun, 18 Apr 2021 16:13:52 +1000

Sorry, I shouldn't cast aspersions here - just very frustrated at my comment about "there's clearly not consensus even amongst NYT readers" being so misinterpreted.

Bron.

---

From: "[email-masked]" <[email-masked]>
Date: Sun, 18 Apr 2021 12:13:49 +0000 (UTC)

On 18 Apr 2021, at 11:47, Keith Moore <[email-masked]> wrote:
> wary of defining some standard "polite" way of rejecting Bad Ideas
> that doesn't let people express themselves.  We need some flexibility
> in how we give pushback, so that some people can open up doors at least
> a little bit, even if other people want to slam them shut.
> 

That is a truly excellent suggestion.

Your idea would be more clearly expressed in an internet-draft, which we
look forward to seeing in due course. As far as we can tell, your basic
idea is sound. We look forward to seeing it progress in a different
workgroup.

We need to define these alternatives in a BRUSH-OFF BOILERPLATE (BROFF)
workgroup, which we can form by holding a BROFF BOF. The output of that
WG can be an informational RFC making advisory recommendations on how to
effectively handle and respond to bad, poorly thought out, unwelcome,
ill-advised, or ahead-of-their-time ideas.

Of course, BROFF will be presumed to be working on RFC editing markup, so
we'll immediately need to decide a better name at the BROFF BOF; say,
Idea Acknowledgement and Action (IDEATION)?

The informational RFC will specify sample response boilerplates, which
will be something generated using a simple tool based along the lines
of these skeleton choose-your-own-acknowledgement checkboxes in an
outline decision-tree format, below.

This is very much an early draft laying out the basic idea with some
filler, not set in stone, and would need considerable revision during
the BOF and until eventual WG acceptance.

INSTRUCTIONS TO DESIGNATED FIRST RESPONDERS:
   tick boxes that are relevant, and assemble your reply from that.

Dear [INSERT NAME HERE].

thankyou for your suggested idea in [INSERT WORKGROUP HERE].

[] Your idea would be
   [] better
   [] more clearly
   [] more fully
   expressed in
   [] an
   [] a different
   internet draft,
   [] which we look forward to seeing in due course.
   [] which would be suitable for another workgroup.
   [] from other authors.

[] As far as we can tell, your basic idea
   [] which has been said before
      [] many times
         [] by others
         [] by you
   
   [] is sound
      [] but has been evaluated and rejected as not viable
         [] at this time
         [] each and every time
      for [REASONS].
   [] sounds as if it could have been sound, but [REASONS].
   [] needs sounding boards outside this WG. We suggest [ANOTHER SELECTED WORKGROUP].

   [] is unlikely to be progressed, because
      [] it is not within the scope of this workgroup
         [] but it is in scope for [ANOTHER SELECTED WORKGROUP].
      [] while it is in the scope of this workgroup, it is not in its charter.
      [] it is in the scope and charter of this workgroup, but alongside already established work, which is
         [] taking all our time and effort.
         [] sucking all the air out of the room.
         [] supported and invested in by almost everyone else.
      [] [REASONS]

      [] that problem just can't be fixed.
         [] Everyone else has already tried.
      [] it's a new transport protocol. Space for those is exhausted.
          [] There's the QUIC and the dead, so this must already be dead.
          [] and its congestion control would need work.
      [] it requires a 'flag day' changing everything on the Internet.
      [] it requires a 'flag day' changing the known laws of physics.
      [] it requires a 'flag day' changing capitalism.
      [] it, without explanation,
         [] invokes and relies on the availability and use of
            [] blockchain
            [] NFTs
            [] 'the cloud'
            [] quantum entanglement
            [] the 'quantum blockchain cloud'
            [] IPv6.
         [] uses unfamiliar terminology.
            [] including 'quantum blockchain cloud'.
         [] uses familiar terminology, but not in a way that that terminology is used.
         [] invents an entirely new language for networking.

     [] it increments the version number of an existing protocol without justification.
     [] it decrements the version number of an existing protocol without justification.
     [] it does not consider the end-to-end principle.
     [] it relies on the end-to-end-principle, which fell out of favor over a decade ago.
     [] it does not consider the RESTful architecture.
     [] it relies on the RESTful architecture, which fell out of fashion a decade ago.
     [] it expects multicast use to work.
     [] it expects IPv6 use to work.
     [] it raises important security concerns, which are
        [] obvious
        [] non-obvious
           [] but require too much explanation
        [] sadly not interesting enough to describe in detail.
     [] it expects us to work for, rather than with, you.

[] With much more added explanatory detail, your idea
   [] may meet with a better reception.
   [] may not meet with any improved reception.
   [] will have much more added explanatory detail.

We thank you for taking the time to present your idea to us and to make a contribution.

Your efforts and enthusiasm have
   [] unfortunately 
not gone unnoticed.

We look forward to
   [] more considered
   [] better documented
   [] more aligned-with-reality-as-we-see-it
   [] more politically acceptable
   [] improved
future ideas from you
   [] and to seeing those ideas progress in [ANOTHER SELECTED WORKGROUP].

---

From: Keith Moore <[email-masked]>
Date: Sun, 18 Apr 2021 09:11:48 -0400

On 4/18/21 8:13 AM, [email-masked] wrote:

<<prototype of "polite" form letter>>

Yeah, I'd much rather be snarled at than get one of these.

Keith

---

From: Ofer Inbar <[email-masked]>
Date: Sun, 18 Apr 2021 12:16:26 -0400

> Not sure if deliberate misunderstanding or not - but I believe this is about my comments since I was the main proponent of "a lack of consensus in the NY Times comment section supports a hypothesis…

It was not you specifically, it was the discussion with many
participants, with several either expressing or assuming the
idea that "no consensus in the US population" necessarily means
that TERM should just give up and not look into this at all.

My point is only partly that NY Times commenters tells us very
little about "the US population".  My bigger point is that this
idea of concensus in the US population, whatever we can or cannot
determine about it from NY Times comments, is not relevant to
the matter of whether TERM should do the work we've been told
they're going to do.
  -- Cos

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 19 Apr 2021 20:37:22 +0900

> that TERM should just give up and not look into this at all.

That is not very precise, because you misunderstand which party
has responsibility for proof.

As TERM is trying to restrict very basic human right of freedom
of speech in an international organization of IETF, it can be
authorized only when there is very smooth consensus that some
terminology is definitely not acceptable not only in US but
internationally.

Moreover, it is responsibility of those who are arguing for TERM
to prove that there is such very smooth international consensus.

However, from comments on NYT article, it is obvious that, even
in US, there is no such consensus, not even roughly.

As such, TERM, attempting to restrict freedom of speech
internationally without any valid reasoning, is hopeless.

TERM could be authorized only when there is a valid proof that
there is a very smooth international consensus for it, which
is totally lacking.

						Masataka Ohta

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 19 Apr 2021 21:03:12 +0900

Vasilenko Eduard wrote:

> The diversity of humans (for the matter that I have touched below)
> are very big even if one takes a very small and uniform part of the
> population. IETF covering the whole world - diversity is in the full
> range possible (100%). It does not help on average (or better median
> - for the biggest crowd) - the motivation is distorted.

So true.

For example, as is stated in:

	https://www.ietf.org/about/administration/policies-procedures/code-of-conduct/

	5. Nondiscrimination
	IETF LLC recognizes the right of all persons—including Board
	Directors, employees, contractors and volunteers—to equal
	opportunity. No Covered Individual shall discriminate against
	or treat any person with whom they deal unequally because of
	race, gender, gender identity and expression, sexual
	orientation, disability, physical appearance, body size, age,
	marital status, religion, ethnicity, national origin, ancestry
	or any other status protected by applicable laws.

all the IETF participants are required to respect marital status
between not only same sex but also a man and a or four nine years
old women, as long as such marriage is a status "protected by
applicable laws".

That is the inclusiveness required for international organizations.

						Masataka Ohta

PS

My wife was not 9 but far above 20 years old, when I married her.

---

From: Keith Moore <[email-masked]>
Date: Mon, 19 Apr 2021 08:44:19 -0400

> in US, there is no such consensus, not even roughly. 

I don't think any conclusion about consensus within the US can be drawn 
from the NYT article comments.   The sample is too small and not 
representative of the US population.

Keith

---

From: Victor Kuarsingh <[email-masked]>
Date: Mon, 19 Apr 2021 10:16:55 -0400

> representative of the US population.

Yes, I would agree. Also, I suspect the IETF's view of consensus is
different than what the general population may think it is.   Our approach
to consensus makes sense when determining how to move forward and get
things done with respect to technology, however for this topic (terminology
as it applies to humanity) is far more than a technical topic.

regards,

Victor K

---

From: Leif Johansson <[email-masked]>
Date: Mon, 19 Apr 2021 16:25:11 +0200

> While I do think that we could possibly "clean up our acts" somewhat, I suspect that we will always need some way of pushing back on Bad Ideas and maybe even pushing back on participants who
> persistently promote Bad Ideas.   And that, to a newcomer, such pushing back will be seen as "snarling" or perhaps even worse, no matter how politely the pushing back is done.

Let me contribute a short anecdote.

Years ago I spent some time doing math (never graduated for my sins).

The math department got a slow but steady stream of mail-in "solutions"
to the squaring of the circle.

Anyone with a smattering of higher math knows why this is impossible. For
everyone else claiming you can square the circle is like standing up in
rtgwg and proposing bgp5 should be based on blockchain - or RIP, I don't
know which would be worse.

These mail-in attempts were given to grad students as excercises and *every*
*single* *one* got a polite and detailed answer identifying the problem. They
also got a reference to galois theory of course. Politely.

My point?

It was to politely point out to you that you are wrong.

	Cheers Leif

---

From: Masataka Ohta <[email-masked]>
Date: Mon, 19 Apr 2021 23:31:18 +0900

Keith Moore wrote:

> from the NYT article comments.

Then, you mean any conclusion about consensus within the Internet
community can be drawn from the IETF list where there is no
membership.

 > The sample is too small and not

"too small"?

You lack expertise in statistics.

In this case of so obvious lack of support for TERM, sample size
of 100 is enough as the proof regardless of US population, even
when there is some bias to choose representatives.

Anyway, as your point is that it is impossible to prove existence of
consensus for or against TERM, it is enough to deny TERM, trying
to restrict basic human right of freedom of speach with no
proven reason, totally.

							Masataka Ohta

---

From: Keith Moore <[email-masked]>
Date: Mon, 19 Apr 2021 11:02:40 -0400

On 4/19/21 10:25 AM, Leif Johansson wrote:

> These mail-in attempts were given to grad students as excercises and*every*

So now we have tasks to assign to newcomers to IETF, as an initiation :)

Keith

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 19 Apr 2021 08:10:22 -0700

> So now we have tasks to assign to newcomers to IETF, as an initiation :)

That's doable as part of a mentorship.

---

From: Keith Moore <[email-masked]>
Date: Mon, 19 Apr 2021 11:14:27 -0400

> That's doable as part of a mentorship.

That way, they can learn to snarl like the rest of us :)

Keith

---

From: Leif Johansson <[email-masked]>
Date: Mon, 19 Apr 2021 17:14:53 +0200

> That's doable as part of a mentorship.

Thats right.

---

From: Leif Johansson <[email-masked]>
Date: Mon, 19 Apr 2021 17:16:59 +0200

> That way, they can learn to snarl like the rest of us :)

Or we assign tasks to old-timers so they can learn not to.

---

From: Keith Moore <[email-masked]>
Date: Mon, 19 Apr 2021 11:18:18 -0400

> You lack expertise in statistics.
That is undoubtedly true.   And yet, the sample of NYT comments is still 
far too small to represent the US population.
> when there is some bias to choose representatives.

I wasn't addressing TERM.   But I think it's fair to say that several 
IETF participants regard TERM as problematic at least.

Keith

---

From: Keith Moore <[email-masked]>
Date: Mon, 19 Apr 2021 11:24:28 -0400

> Or we assign tasks to old-timers so they can learn not to.

In other words, they can spend all of their time politely explaining in 
detail why proposals are Bad Ideas, instead of getting useful work done.

Old-timers snarl, at least in part, because they've been through all of 
it before, and they would rather work on trying to improve potentially 
promising ideas than defeating Bad Ideas.   Snarling is one version of 
conservation of effort.

Like I said, we could probably improve on how we do it.   But 
fundamentally, being able to reject Bad Ideas without spending a lot of 
effort doing so is a necessary skill.

Keith

---

From: Leif Johansson <[email-masked]>
Date: Mon, 19 Apr 2021 17:51:18 +0200

Skickat från min iPhone

> 19 apr. 2021 kl. 17:25 skrev Keith Moore <[email-masked]>:
> 
> In other words, they can spend all of their time politely explaining in detail why proposals are Bad Ideas, instead of getting useful work done.

Point to where the useful work will be done if we don’t stop this.

---

From: Dave Cridland <[email-masked]>
Date: Mon, 19 Apr 2021 17:35:50 +0100

> detail why proposals are Bad Ideas, instead of getting useful work done.
Radical thought: What if explaining in detail why a proposal is a Bad Idea
*is* useful work?

What if it might bring new people in to provide new insight? That strikes
me as very useful work indeed.

Dave.

---

From: Christian Huitema <[email-masked]>
Date: Mon, 19 Apr 2021 09:38:02 -0700

On 4/19/2021 8:51 AM, Leif Johansson wrote
> Point to where the useful work will be done if we don’t stop this.

I think that Leif has a point. Treating new comers politely may take a 
bit more time in the short term than just telling them to go away with 
their bad ideas, but welcoming more participants in the IETF will 
definitely get more work done in the long term.

-- Christian Huitema

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 19 Apr 2021 16:45:59 +0000

I really hesitated to say this, but in my experience, most of the snarlers are old men who have not made notable contributions to any draft in some time.

---

From: Keith Moore <[email-masked]>
Date: Mon, 19 Apr 2021 12:57:22 -0400

On 4/19/21 12:35 PM, Dave Cridland wrote:

>
> Radical thought: What if explaining in detail why a proposal is a Bad 
> Idea *is* useful work?
>
> What if it might bring new people in to provide new insight? That 
> strikes me as very useful work indeed.

Under some conditions, it certainly can be useful work.   That's why, 
for example, refuting proofs of how to square circles might have made a 
good exercise for math graduate students, who are basically indentured 
servants anyway so they're not free to resist, and maybe could use a 
better grounding in the math that underlies such arguments.

But there's a limit to how much of this is useful, and when writing the 
Nth explanation for why (for example) assigning IP addresses 
geographically isn't as good an idea as it might initially seem, the 
point of diminishing returns is probably around N=1.

I also suspect there are better ways to generate new insights than to 
endlessly try to refute Bad Ideas.   For instance, try to approach a 
problem from a completely different angle than has been proposed before.

Keith

---

From: Keith Moore <[email-masked]>
Date: Mon, 19 Apr 2021 13:07:10 -0400

> I really hesitated to say this, but in my experience, most of the snarlers are old men who have not made notable contributions to any draft in some time.

Absent some more precise definition, "snarling" is subjective. And there 
are other ways to contribute without making "notable" contributions of 
text to any specific draft: general comments in a WG discussion that 
shape the problem space or influence how a draft is scoped, private 
comments to a document author, Last Call comments, etc.

***

I get the impression that many people have a theory that IETF's problem 
is that it is populated with too many Bad People, and the way to fix 
IETF is to discourage or silence those Bad People.

I believe the IETF needs many different kinds of people, including 
Annoying People, because it seems like many important issues never get 
looked at without some Annoying People to call attention to those 
problems.   Which is not to say that everyone who is annoying is helpful 
in that way, but that filtering out Annoying People - people who say 
things that make people uncomfortable - would make it harder for those 
issues to be examined and addressed.

Keith

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 19 Apr 2021 17:10:05 +0000

I agree with all of what you wrote.

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 19 Apr 2021 10:30:51 -0700

Hi -

On 2021-04-19 9:35 AM, Dave Cridland wrote:
...
> strikes me as very useful work indeed.

Agree.  But that requires careful listening to their ideas, as well
as a willingness to examine dogma.

Too often, the ideas aren't actually bad, but rather are at odds with
some relatively arbitrary choice a WG has made in the past, and that
decision has since ossified into an article of faith.  Consciously or
unconsciously, there seems to be reluctance to admit that an
original choice might in any way have been arbitrary or unconsidered,
much less admit that it may have with time proven to be suboptimal,
even as protocols are pressed to handle situations well outside their
original design parameters.  Perhaps it's just human nature to be
unwilling to admit that one's beautiful baby has developed
into an ugly juvenile delinquent, as much as we might love that
delinquent and in any case be stuck with them.

This is where diplomacy comes in: there's a big difference between
admitting that an idea might be a good one, but has come at the wrong
time, and just snarling "Bad Idea" or doing the "bzzzt, thank you for
playing" that I remember ADs and WG chairs using to squelch discussion.

Randy

---

From: Keith Moore <[email-masked]>
Date: Mon, 19 Apr 2021 13:42:13 -0400

> as a willingness to examine dogma.
And the amount of careful listening required is often roughly the same 
for a Bad Idea versus a promising idea.   Wrapping your head around 
someone else's idea is hard work, especially when you have to re-examine 
deeply held assumptions to do so.   Also the difference between a really 
Bad Idea and a more promising idea might be subtle, as in: if you make 
this slight change, it would be a much better idea.   So you not only 
need to examine the presumably bad idea but also some amount of 
variation around that idea.

> delinquent and in any case be stuck with them.
Yes.
> playing" that I remember ADs and WG chairs using to squelch discussion.

Yes.

I wish I knew of a way to quickly filter or refute truly bad ideas in 
order to leave more time/energy for the better ideas. And assuming it's 
possible, a way to teach that skill to everyone in IETF.

Keith

---

From: Clint Chaplin <[email-masked]>
Date: Mon, 19 Apr 2021 10:57:09 -0700

In a different context, the observation was made that in order to get good
art, you have to tolerate and/or support bad art.

-- 
Clint Chaplin
Senior Principal Standards Engineer
Samsung Research America

---

From: Michael Thomas <[email-masked]>
Date: Mon, 19 Apr 2021 11:05:17 -0700

On 4/19/21 10:42 AM, Keith Moore wrote:
> someone else's idea is hard work, especially when you have to 
> re-examine deeply held assumptions to do so.   Also the difference 
> between a really Bad Idea and a more promising idea might be subtle, 
> as in: if you make this slight change, it would be a much better 
> idea.   So you not only need to examine the presumably bad idea but 
> also some amount of variation around that idea.
>
The real issue if you ask me is whether a new and better idea overcomes 
the energy barrier to matter. With something old and established that 
barrier is extremely high. For Quic, for example, we've had 20+ years of 
an 8 packet startup handshake before that energy barrier was overcome to 
get to 5 packets, and who knows how many years it will be to get it back 
to 3 if ever even though it's perfectly possible to fix. ObMe: I haven't 
joined the Quic mailing list mainly because I'm not sure I want to 
endure yet another snarling match from entrenched powers that be. Maybe 
I will, but it's a fairly typical outcome in my experience that that is 
what will happen.

Mike

---

From: Keith Moore <[email-masked]>
Date: Mon, 19 Apr 2021 15:46:32 -0400

> Point to where the useful work will be done if we don’t stop this.

I don't want to either dismiss your concern (which I share) or sound 
flippant, but I also wonder where the useful work will be done if we DO 
stop this.

I wonder if there's actually no good solution - no way to be open to 
participation by everyone without having some way of filtering ideas 
that sometimes seems rude.   We may be faced with a dilemma between 
seeming rude in a way that discourages many newcomers, versus so much 
time refuting Bad Ideas in detail that we can't accomplish much that's 
useful, and also discourages participation from both newcomers and 
experienced people.   I've certainly seen signs of both.

But I haven't yet reached the conclusion that there's no good solution, 
because I think there are still things to look at.

Things that I'm wondering are:

- What is "snarling" anyway, and are we all talking about the same 
thing?   Is snarling any kind of unpleasant feedback, or what?

- Is the problem really the language we use to discourage (presumably) 
Bad Ideas, or is it that we discourage them at all? Even if we improve 
our language for discouraging Bad Ideas (which IMO is worth trying), 
will we still be discouraging newcomers? Maybe not as much?   Are there 
occurrences of snarling which aren't about discouraging (presumably) Bad 
Ideas?

- Is it possible for us to get better at distinguishing between Bad 
Ideas and promising ideas?

- Assuming that some of what people are "snarling" about is in part 
displaced frustration from something else about IETF, is there anything 
we can do about that?

- What does it take to (re)create an IETF in which we're mostly happy 
about getting to do really useful work with really talented people?

Keith

---

From: Leif Johansson <[email-masked]>
Date: Mon, 19 Apr 2021 22:09:03 +0200

On 2021-04-19 21:46, Keith Moore wrote:
> I don't want to either dismiss your concern (which I share) or sound flippant, but I also wonder where the useful work will be done if we DO stop this.

I appreciate your attempt to keep sticking to your point and trying to be serious
about it but... I just don't buy the IETF as the group of brilliant but tortured
souls who have "snarl" at each other to make themselves heard over the din of "Bad
Ideas".

Where is this apocalyptic horde of Bad Ideas that is sucking up all of our precious
resources? The IETF meetings are growing smaller. Clearly we have figured out how
to turn people away at the door.

What problem are you trying to solve Keith?

	Cheers Leif

---

From: Michael Thomas <[email-masked]>
Date: Mon, 19 Apr 2021 13:19:06 -0700

> souls who have "snarl" at each other to make themselves heard over the din of "Bad

What's funny is that several run ins I had that wg chairs shut down just 
went back to their default mode of nothing getting done. In that time, 
they have about a hundred open issues and they were still on issue #1 
which wasn't particularly exciting or important and had been going on 
sporadically the entire time I was there which was a couple months. For 
all I know, they're still stuck on it.

Mike

---

From: Ofer Inbar <[email-masked]>
Date: Mon, 19 Apr 2021 16:32:34 -0400

On Mon, Apr 19, 2021 at 08:37:22PM +0900,
> of speech in an international organization of IETF, it can be

This claim is ridiculous on its face.  TERM is supposed to study
whether to make recommendations about terminology, and if so, what
recommendations to make.  If they end up making specific
recommendations that somehow affect someone's freedom of speech,
please point those out and explain at that time.

> in US, there is no such consensus, not even roughly.

As I already addressed, NYT commenters are not even slightly
representation of "the US population".  And it is also not
relevant at this stage.

I supposed based on your premise that TERM is somehow restricting your
freedom of speech, it could be relevant, so at least I see why you're
talking about a lack of US consensus.  However, even in that context,
I don't see why you would ignore the fact that NYT commenters are a
tiny and *systematically un-representative* sample so you can't
conclude anything about some consensus of the US population, even if
it were a consensus on a matter that were relevant to this discussion
... which, again, it's not.

Keith Moore <[email-masked]> wrote:
> I don't think any conclusion about consensus within the US can be
> drawn from the NYT article comments.   The sample is too small and
> not representative of the US population.

Yes, as I stated in the very message Masataka Ohta is replying to here.
"Not representative" is key to that particular point.  He chose to
focus on your saying "too small", and in fact we don't know whether
the commenter sample is too small for a well designed poll, but we
also can't know whether people are using sock puppets so we don't
know the real sample size anyway.  The fact that it's systematically
different from the US population AND also probably very small, means
that it can't be used to draw any conclusions about the larger population.

> as it applies to humanity) is far more than a technical topic.

Yes, as I addressed at length in the very message Masataka Ohta is
replying to here.  The supposed consensus or lack thereof of the US
population, is both not relevant to IETF process, and is about a
different matter than the WG consensus would be about, so it's doubly
irrelevant.

You also bring up that this is not a technical matter, and that may
mean it should be handled differently.  I think we had a separate long
thread about that (with people suggesting this is a matter for the
IAB, for example).  I'm not weighing in on that discussion, just
saying that it's a separate point and would be best dealt with
separately from this thread.

But the subthread here about supposed lack of consensus in the US
population is off target for several reasons, and should be rejected.

1: NY Times comments do not indicate anything about the US population.

2: The US population is not the same population the IETF cares about.

3: Consensus on whether a specific term is an individual problem for
someone, is utterly irrelevant to whether TERM should be chartered,
even if we were talking about the intended population and even if
we did know something about that population's state of consensus.

4: Objections to particular recommendations or points that the WG
seeks to adopt cannot be made in some purely vague hypothetical sense
without any reference to a specific thing the WG is discussing.
  -- Cos

---

From: Randy Presuhn <[email-masked]>
Date: Mon, 19 Apr 2021 13:42:58 -0700

Hi -

I hate to post twice in one day, but...

On 2021-04-19 12:46 PM, Keith Moore wrote:
...
> thing?   Is snarling any kind of unpleasant feedback, or what?

Ancient examples that came to *my* mind when the word first came up in
this discussion:

    - in discussion of features to be considered in developing version 2
      of a protocol, WG chairs and even ADs squelching discussing of
      certain ideas with "bzzzt, thank you for playing."  (With the
      clear implication they really just wished the participant would
      go away.)

    - declarations by leadership that certain technology paths were
      not to be discussed, not even in a BOF (with recognition by
      many participants that those paths would be problematic for
      the business interests of some of those leaders)

    - snide remarks about the technology choices made by other
      organizations, and "guilt by association" when any attempt
      is made to leverage "outside" technology or models

...

Usually the "snarling" I've witnessed was from folks who seemed to think
their power/position/status was threatened.  It often looked like they
were defending a technically questionable position with what amounted to
an appeal to authority.  But for some folks it seems to become a habit:
even when there is a strong technical footing for their argument, they 
resort to the snide "insider" comment as the quickest way to move the
discussion along, rather than making the strong technical argument
they could have made, or admitting that the proposal might make sense
if we were designing things tabula rasa, but would be problematic in
the current ecosystem.

Randy

---

From: Keith Moore <[email-masked]>
Date: Mon, 19 Apr 2021 17:00:02 -0400

> souls who have "snarl" at each other to make themselves heard over the din of "Bad

Well, again, I'm not even sure we're all talking about the same thing 
when we use the word "snarling".   And while I'm pretty sure that we 
need a way to push back on Bad Ideas, I'm not sure that what people are 
calling "snarling" is only or even mostly about discouraging Bad 
Ideas.   Maybe, for example, some of it is about "baggage" - old 
resentments for hard-fought battles lost, perceived insults, or even 
genuinely bad behavior.

> resources?
One doesn't have to look very far to find some, just follow ietf@ or any 
of several mailing lists.   In theory at least, the situation would be 
worse if we didn't try to discourage them.
> The IETF meetings are growing smaller. Clearly we have figured out how

With respect, it doesn't follow from just that information.  I'm sure we 
have surveys which have shown that some people have stopped attending 
because of what they perceived as rudeness, but there may be many more 
reasons than that.

What is IETF doing these days that's exciting, that helps make the 
Internet generally better in a way that's obvious to most participants, 
that gives participants a sense of purpose and makes them proud to work 
with IETF?   I don't think it's the null set, but it's certainly not 
like it was 30 years ago when there was a general sense of excitement 
about making this wonderful resource available to the world.

In conversations with IETFers I often get a sense of futility, as in 
"sure we could theoretically improve X, but we'd have to deal with these 
technical constraints and/or these people and/or these Big Companies".   
There's a lot more inertia around many kinds of Internet development 
than there used to be.   It's probably not IETF's fault, so much as a 
symptom of success.   But it has changed the landscape and how we feel 
about our work.

And yet, conditions have changed enough that the constraints around 
deployment of new features in some applications protocols and some 
layers of the stack may be less than they once were. Understanding where 
we can make a positive difference may be as important as understanding 
what limitations there are.

Keith

---

From: Michael Thomas <[email-masked]>
Date: Mon, 19 Apr 2021 14:14:11 -0700

On 4/19/21 2:00 PM, Keith Moore wrote:
>>>>> In other words, they can spend all of their time politely 
>>>>> explaining in detail why proposals are Bad Ideas, instead of 
>>>>> getting useful work done.
>>> flippant, but I also wonder where the useful work will be done if we 
>>> DO stop this.
> need a way to push back on Bad Ideas, I'm not sure that what people 
> are calling "snarling" is only or even mostly about discouraging Bad 
Since I was the one who introduced "snarling" to the conversation 
(sheesh, do I get a gold star or what?), what I was referring to was 
coming with, say, security concerns and in my case the document author 
quite literally snarled at me, or as best you can tell over email. I 
feel somewhat vindicated since they ended up writing an entire 
informational RFC on what I pointed out as being a no-no, but nobody 
cares in the real world and the vulnerability is still there out in the 
wild to be exploited. In that particular case there was a *huge* amount 
of incentive to sweep it under the rug, and that's exactly what happened.

Mike

---

From: Richard Shockey <[email-masked]>
Date: Mon, 19 Apr 2021 17:34:48 -0400

richard<at>shockey.us

Skype-Linkedin-Facebook –Twitter  rshockey101

PSTN +1 703-593-2683

On 4/19/21, 11:51 AM, "ietf on behalf of Leif Johansson" <[email-masked] on behalf of [email-masked]> wrote:

    Skickat från min iPhone

RS> GitHub.  The paradigm has shifted. It's no longer "rough consensus and running code." Its just running code.  Look at WEBRTC as a example.

---

From: Keith Moore <[email-masked]>
Date: Mon, 19 Apr 2021 18:22:29 -0400

> RS> GitHub.  The paradigm has shifted. It's no longer "rough consensus and running code." Its just running code.  Look at WEBRTC as a example.

Though at least at one time, the emphasis wasn't merely on "running 
code" so much as on "specifications that permit multiple running code 
implementations to interoperate".

These days there's less variation between platforms, so often it's at 
least possible for different implementations of some applications to 
share the same code base.   And with automatic software update, 
applications can be upgraded to support new protocol features without 
needing to get agreement on a protocol specification.  Rather than get 
rough consensus on the change, whoever controls the repository 
effectively wins.   (Though forking does happen sometimes.)

Webrtc is certainly an example of something, but people might have 
different opinions about whether it's a Good Thing.   At least the last 
time I looked, it was extremely complex and difficult to implement from 
a specification.  So it tends to be tied to these bloated 
privacy-violating codes called web browsers that have a huge attack 
surface and require very significant resources.

But I do think it's an example of how the paradigm has shifted, at least 
for some kinds of applications.    How can IETF respond constructively 
to that shift?    Somehow doing everything the github way doesn't seem 
like adding value.  But there's even more demand than ever to be nimble, 
to make huge changes quickly and without much time for review.   And yet 
in some areas, particularly security, and probably also other 
operational considerations, the need for careful design and 
implementation are greater than ever.   Could we restructure our 
processes to change the emphasis in our reviews to make sure we're 
adding value in these neglected areas?   Would it make sense to make 
running code part of our official work product, produced concurrently 
with the specification and reviewed for consistency with the 
specification?   Could we make greater use of protocol specification 
languages to reduce the difference between specification and running code?

Some of these things are already happening, of course, but could/should 
we make them a more explicit part of our process?

Keith

---

From: Larry Masinter <[email-masked]>
Date: Mon, 19 Apr 2021 15:35:06 -0700

The alternative to "snarling" is having at least one person per working group who takes seriously the requirement that RFCs and working group decisions be understandable by newcomers. Perhaps the WG chair or someone appointed by AD or chair. 
--
https://LarryMasinter.net https://interlisp.org

---

From: Richard Shockey <[email-masked]>
Date: Mon, 19 Apr 2021 18:57:02 -0400

In Line..

On 4/19/21, 5:00 PM, "ietf on behalf of Keith Moore" <[email-masked] on behalf of [email-masked]> wrote:

RS> IMHO its already gone too far.  This whole thread is case in point. 

    > to turn people away at the door.

RS> That’s easy ... the process has become way too complicated. The IETF has become what it always despised the ITU-T.   I would never take new work into the IETF and I was a WG chair for almost 10 years (RFC 6116 ENUM) .   Work on improving or fixing problems in Real Time Communications protocols in ART has stalled. Look at the DISPATCH list for instance. Other than WEBRTC the last useful thing ART did was STIR and even with that we had to re-form as a SDO outside the IETF with the ATIS/SIP Forum NNI TF to get the operational standards ready.  Snarling is definitely allowed there and encouraged in our TF.  

We backtracked Rich Call Data only after we had the documentation ready if for no other reasons to make sure it had enough eyeballs on it.  The savings in time and effort was enormous.  Our TF meets every single month.  

RS> Its not rudeness and IMHO rudeness has its place.  There is a whole lot of stupid out there. I've seen serious proposals about using Hyperledger for TN to URI translation. 

I cannot empathize enough the issues with  STIR/SHAKEN protocols is regulatory.  I spend a unique amount of time explaining S/S to an alphabet soup of national regulators. I could go on and on about that.  BTW based on my conversations most of us are well served by our national regulators and if ever offered to serve on a National or State Technical Advisory Committee do so. For those of you in the US write your Governor.  BTW the FCC has openings for CSRIC. You can self-nominate.  

https://www.fcc.gov/document/fcc-intends-re-establish-csric-and-solicits-membership-nominations

 It’s a very pleasant a rewarding experience.  I'm currently on the FCC NANC. 

BTW the surest way to get a protocol adopted is have it mandated by the relevant legislature which is what we did with S/S and the US TRACED Act.  You want BGP security ...mandate it.  

https://www.congress.gov/bill/116th-congress/senate-bill/151

RS>  +1 Keith 

RS> Well there are certainly constraints and "those people" namely the <fill in the blank> Mafia around certain protocols and certainly companies if you have to deal with routing protocols.  The largest single problem the IETF has now is what I refer to as the 'Persistence of Protocol'  Once something get imbedded in the network it is nearly impossible to extract or modify.  Professionally I've spent 30 years trying to kill off Time Division Multiplexing and Signaling System 7 in the Phone networks and it's still there.  I literally have to argue with regulators. "If you want real Calling Line Authentication S/S" Tell THEM to shut it F* off. Pick a date.  In the US we did that with Digital Television and made the US Treasury 40B richer when the spectrum was sold off. 
  
    than there used to be.   

RS> Keith its not  lack of inertia. Its Entropy.

https://en.wikipedia.org/wiki/Second_law_of_thermodynamics

It's probably not IETF's fault, so much as a 
    symptom of success.   But it has changed the landscape and how we feel 
    about our work.

    Keith

RS> There are issues ISOC might be helpful in working with the general IETF community on some of these issues but I know they are extremely careful treading on areas that look like lobbying.  Realistically the IETF is not unlike any major SDO dealing with "essential" networks. The electric power people certainly are well organized. IEEE etc. EPRI.  IMHO we are being way way to idealistic about what we do. 

— 
Richard Shockey
Shockey Consulting LLC
Chairman of the Board SIP Forum
www.shockey.us
www.sipforum.org
richard<at>shockey.us
Skype-Linkedin-Facebook –Twitter  rshockey101

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 20 Apr 2021 14:58:54 +1200

On 20-Apr-21 10:22, Keith Moore wrote:
> effectively wins.   

And if you're the least bit concerned about anti-trust laws, you would
want to be well away from that control point. That's a fairly strong
argument for why you need open standards as well as open source.

(Though forking does happen sometimes.)
> surface and require very significant resources.

And it's no coincidence that WebRTC led to the largest and probably
trickiest set of interdependent RFCs in the history of the Internet.
 
> adding value in these neglected areas?

I thought we already did that by instituting the area review teams.
It might be time to review whether that's working properly.

> Would it make sense to make 
> specification?

Again I think anti-trust would be a factor, although we'd need legal
advice on that. Also possible liability concerns, ditto. However,
I am disappointed by the low uptake of BCP205/RFC7942. We need to
do better.

> Could we make greater use of protocol specification 

In theory we could, but it's far from easy. Take CBOR-based protocols for
a start. Yes, you can use CDDL for a formal specification of the message
formats, and you can in theory verify that the messages conform; you could
presumably write a CDDL-driven message parser. But none of that models
the protocol's state machine. That would be a whole new level of formalism.

People are trying, however: https://doi.org/10.1145/3341302.3342087

   Brian

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 20 Apr 2021 01:25:42 -0400

> People are trying, however: https://doi.org/10.1145/3341302.3342087

I use formal-ized tools for much of my work. But I haven't written a proof
since I finished my doctorate. The problem I found is the aspects of the
system that can be reasoned about tend to not be the parts that are
important for reliability of the system. I prefer to spend the time
simplifying the system and removing what is unnecessary than limiting
myself to what can be proved.

There turns out to be a particular hazard with proofs of crypto protocols
as protocols with a proof of correctness tend to be brittle as the
constraints of proof hacking prevent the defense in depth type approaches
needed today.

I almost always write a tool to parse and serialize even apparently simple
messages because experience tells me that is necessary. I don't find the
same is true for protocol state machines even though I have dozens of
domain specific languages for state machines as well.

This morning, I modelled the state machine of RUD using CSP. But it doesn't
really help very much because the important issues are packets being lost,
packets arriving out of order and timing. Sure, there are timed versions of
CSP but how do I get from CSP to the Tasks model of C# or anything in
Java-land?

---

From: Leif Johansson <[email-masked]>
Date: Tue, 20 Apr 2021 08:27:08 +0200

> RS> GitHub.  The paradigm has shifted. It's no longer "rough consensus and running code." Its just running code.  Look at WEBRTC as a example. 

Thats exactly my point.

I really should have said "Point to where the useful work will be done in the IETF..."

---

From: Lloyd W <[email-masked]>
Date: Tue, 20 Apr 2021 16:36:01 +1000

> On 20 Apr 2021, at 12:59, Brian E Carpenter <[email-masked]> wrote:
> 
>> Rather than get 
> want to be well away from that control point.

Microsoft, famed for antitrust, controls GitHub.

> That's a fairly strong

https://en.wikipedia.org/wiki/Embrace,_extend,_and_extinguish

Lloyd Wood
[email-masked]

---

From: Dave Cridland <[email-masked]>
Date: Tue, 20 Apr 2021 07:51:49 +0100

On Mon, 19 Apr 2021, 17:57 Keith Moore, <[email-masked]> wrote:

> Under some conditions, it certainly can be useful work.   That's why, for
> example, refuting proofs of how to square circles might have made a good
> exercise for math graduate students, who are basically indentured servants
> anyway so they're not free to resist, and maybe could use a better
> grounding in the math that underlies such arguments.
>
> Nth explanation for why (for example) assigning IP addresses geographically
> isn't as good an idea as it might initially seem, the point of diminishing
> returns is probably around N=1.
>
> Okay, I can go along with this. But presumably someone wrote this up
originally, so should we be curating these answers, maybe as drafts, so we
can say, "You should look at this and see if you've anything new here",
rather than "Not again, go away you idiot".

I mean, I can take a stab at why geographic ip address assignments aren't
perfect, but I have no idea what a routing expert might write on the
subject. I'm quite intrigued now.

> problem from a completely different angle than has been proposed before.
Sure, but the thing about newcomers is that they don't know what has been
proposed before, and it's not easy to find out. I certainly wouldn't have
known that a serious attempt to use geographic ip had been made before.

And if you want new approaches, then new people is almost certainly a
requirement.

---

From: "Bron Gondwana" <[email-masked]>
Date: Tue, 20 Apr 2021 20:25:12 +1000

> Or we assign tasks to old-timers so they can learn not to.

A little late to the party but there's no better place to hang this comment.

History is littered with companies and clubs which decided that the right choice was to alienate their existing membership/customer base in order to attract a mythical new market of "grass is always greener" proportions.

Sometimes they're right, and they succeed wildly.  They were indeed stuck in a local maxima and pivoting was the right choice.  Far more often, they fizzed out.  To the point that there's plenty of advice in the business world to try to keep your existing customers satisfied as you evolve.

I think one of the key questions underlying trepidation with plans to reorganise the IETF culture along different philosophical lines are rooted in this question: is there a better maxima we can reach without dying on the way?  Will this pool dry up if we stay here (just to flip the analogy landscape here and make the "maxima" a pool instead)?

In this analogy, I'm considering people who show up and contribute to the IETF as "customers" - we pay in our time and our meeting attendance and our emotional energy to engage in debate.  We receive enough value in terms of something meaningful to us that we continue to attend - many IETFers remaining with the IETF as they change jobs, or even participating on their own recognizance.  That's a serious commitment, and it's held the organisation through meetings stretching back more than 30 years.

Some would say that this conversation has already turned away good participants.  Probably.  The more time we spend introspecting on this, the more damage it will cause.  More than any particular outcome would.  Even the most extreme outcomes of "we commit to do nothing in this area for the next 10 years" and "we have a language police who inspect every draft and censor every microagression" are not worse than killing ourselves through reflexive infighting.

It's this recognition that the current state is worse than any of the likely outcomes which led me to write a draft in the first place.

But if we drive away a bunch of people who currently contribute, or demotivate them sufficiently that they put in minimal effort, then we'd sure better have a happy diverse bunch of folks waiting in the wings with the same level of energy and same level of value received that they would stick with the IETF through changing jobs and of their own volition as volunteers afterwards, or we'll find the new pool even less nourishing than our current one.

Regards,

Bron.

---

From: Lloyd W <[email-masked]>
Date: Tue, 20 Apr 2021 20:57:50 +1000

> On 20 Apr 2021, at 20:26, Bron Gondwana <[email-masked]> wrote:
> 

maxima is plural, so I'm not sure how many different cultural dimensions or axes you're considering maximums on. Or how many minimums you're plumbing the depths of.

Will it be:
'go woke or go broke'
or
'go woke and go broke'?

Lloyd Wood
[email-masked]

'affirmative agreement with application activity' is an AAAA slogan.

---

From: Keith Moore <[email-masked]>
Date: Tue, 20 Apr 2021 07:29:24 -0400

> Microsoft, famed for antitrust, controls GitHub.

I did say "and similar tools".   Though I realize there's a lot of 
investment in the github interface, there are alternatives that IETF 
could use if it decided to more fully embrace this way of working.

Keith

---

From: "John Levine" <[email-masked]>
Date: 20 Apr 2021 12:08:59 -0400

>Microsoft, famed for antitrust, controls GitHub.

It was obvious at the time that MS bought Github defensively, to ensure that Facebook
or someone else didn't buy it instead.  There were more MS employees contributing to
open source projects on Githunb than any other employer and I think there still are.

There are certainly reasons to worry about depending on an unpaid third party but
MS subverting Github is rather low on my list of concerns.

R's,
John

---

From: Nick Hilliard <[email-masked]>
Date: Tue, 20 Apr 2021 17:38:03 +0100

> MS subverting Github is rather low on my list of concerns.

in addition to which, any claim of GH capture risk can be averted with a 
surprisingly low overhead "git clone" operation.

Nick

---

From: Keith Moore <[email-masked]>
Date: Tue, 20 Apr 2021 12:54:45 -0400

On 4/20/21 12:38 PM, Nick Hilliard wrote:

> in addition to which, any claim of GH capture risk can be averted with 
> a surprisingly low overhead "git clone" operation. 

The overhead isn't in the "git clone", it's in retraining everyone to 
use a different site with different enhancements to vanilla git.

Keith

---

From: Eliot Lear <[email-masked]>
Date: Tue, 20 Apr 2021 18:56:36 +0200

Hi,

> On 20 Apr 2021, at 18:08, John Levine <[email-masked]> wrote:
> 

We have to decide what business we’re in.  If we are in the tooling business and want to compete with Microsoft, then we should be concerned.  But as a standards organization, I don’t think we are.  I think we are in the business of doing open standards.  And it’s not as if Microsoft forces people to use Word and Excel on Github, or even provides a comfortable experience on GH for those apps.

Eliot

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 20 Apr 2021 17:00:20 +0000

It's retraning some members of the community, in exchange for reducing friction on a much larger potential community.

---

From: Larry Masinter <[email-masked]>
Date: Tue, 20 Apr 2021 10:32:28 -0700

Git/github could use some adaption to make it work better for IETF.
I sent in some suggestions back in January. Does anyone think GitHub is
perfect for IETF use already?

-----Original Message-----
From: Larry Masinter <[email-masked]> On Behalf Of Larry Masinter
Sent: Wednesday, January 6, 2021 10:51 AM
To: [email-masked]
Subject: RE: Old directions in social media.

I'd like to see the IETF LLC fund some development of enterprise github.ietf.org to make it work better.
Just off the top ...
An enterprise license so it could be customized.
Fix the default GFM so it could easily be used to produce xml2rfcv3 With custom diff appropriate.
Default actions for building PDF, HTML, text views Tie in with DataTracker and appropriate authentication....
Integrate with email and wg "decisions"
Fix the bugs in GitHub "discussions" <-> Issues Integration with meeting tools (agendas, minutes) Default "Teams" & roles appropriate for WG work rather than software development Tutorials & written guides for using Git for IETF work  Regular summaries and insights appropriate for document production Some way to subscribe to summaries of actions and topics without watching every action on the repo (maybe a 'significant change' flag that the PR has and must be approved)

---

From: Fred Baker <[email-masked]>
Date: Tue, 20 Apr 2021 10:49:06 -0700

> On Apr 20, 2021, at 10:33 AM, Larry Masinter <[email-masked]> wrote:
> 
> Does anyone think GitHub is perfect for IETF use already?

I do not. I’m not sure that a process or tool exists that can be described in those terms, including our present processes and tools.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 20 Apr 2021 15:54:44 -0400

On Tue, Apr 20, 2021 at 12:57 PM Eliot Lear <lear=[email-masked]>
wrote:

> We have to decide what business we’re in.  If we are in the tooling
> business and want to compete with Microsoft, then we should be concerned.
> But as a standards organization, I don’t think we are.  I think we are in
> the business of doing open standards.  And it’s not as if Microsoft forces
> people to use Word and Excel on Github, or even provides a comfortable
> experience on GH for those apps.
>
> Eliot
>

Arriving at the Washington National airport with over an hour and a half
before my US Air Shuttle took off and three people in line ahead of me, I
thought I was fine. I missed the flight.

The problem was that US Air had made the mistake of thinking they were in
the airline business and they were actually in the information business.
And their SABRE flight check in system hadn't been changed since it was
state of the art in the 1950s. The fact that it took a clerk 15 minutes to
book a single passenger onto a flight was one of the main reasons the
airline went bust. But that didn't stop the CEO singing the praises of his
utterly obsolete information infrastructure. Its not just computer types
can get wedged on legacy systems 30 years after their sell by date has
passed.

Modern businesses are all in the information business and their business is
their IT systems and business processes at least as much as it is people
and plant.

My point is that IETF is in the information business and the community
building business and in a very real sense we are the set of tools we use.
In the past that was nroff, mailing lists and three in-person meetings a
year. And that model is no longer sustainable.

I really have no problem with Microsoft being the technology provider, they
have contributed a great deal to IETF over the years. But I do have a
problem with trying to use a tool designed to support one application for a
very different application. Fortunately, code is malleable, cloneable and
changeable. There are multiple options:

1) Use Github as-is

2) Partner with Microsoft (or similarly placed competitor) to design a new
collaboration infrastructure. IETF gets the tools it needs, partner gets a
framework for a collaboration infrastructure building product it can sell
to a much wider audience - modern business is process.

3) A group of IETF-ers take VC money to build system (2) above and then
sell the result back to Microsoft or similarly placed competitor as exit
strategy.

Of course, the fact that the large business process these days is to
outsource innovation to angel funded startups, the most likely one is:

4) A group of IETF-ers take VC money from Microsoft and/or similarly placed
competitors to build system (2) above and then sell the result back to
Microsoft or similarly placed competitor as exit strategy.

I know someone with an interesting technology that allows such a
collaboration infrastructure to be entirely end-to-end encrypted so the
cloud provider hosting the IT systems has no visibility into the business
they are supporting. An essential step if the operators are going to
mitigate liability.

---

From: Jay Daley <[email-masked]>
Date: Wed, 21 Apr 2021 07:57:26 +1200

> On 20/04/2021, at 10:25 PM, Bron Gondwana <[email-masked]> wrote:
> 
> I think one of the key questions underlying trepidation with plans to reorganise the IETF culture along different philosophical lines

How on earth do you get to the position where you believe this is happening?  From my perspective all I see a bunch of people discussing the narrow question of how to avoid an adverse reaction to newcomers who make a suggestion that has been discussed ad nauseam before.  The only way I can see how this could be characterised as "reorganising the IETF culture along different philosophical lines" is if you believe the snarling at newcomers is a fundamental expression of an agreed philosophical basis for IETF culture - neither of which I think is even remotely true.

> are rooted in this question: is there a better maxima we can reach without dying on the way?  Will this pool dry up if we stay here (just to flip the analogy landscape here and make the "maxima" a pool instead)?

> Some would say that this conversation has already turned away good participants.  Probably.  The more time we spend introspecting on this, the more damage it will cause.  More than any particular o…

Again, I don’t see how you got here.  It reads to me as if you believe there are good participants who take from this conversation that their snarling days are coming to an end and so are choosing to get out early. 

> But if we drive away a bunch of people who currently contribute, or demotivate them sufficiently that they put in minimal effort, then we'd sure better have a happy diverse bunch of folks waiting i…

Other than my reading above I have no idea at all how you think avoiding snarling can drive people away or demotivate them, when the whole point of this conversation so far is how to bring newcomers up to speed quickly enough that they don’t get an adverse reaction to something they say that then puts them off.

Please explain for the benefit of one very confused onlooker.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Wed, 21 Apr 2021 09:18:50 +1200

> On 21/04/2021, at 5:32 AM, Larry Masinter <[email-masked]> wrote:
> 

RFC 8875 sets out a plan for how GitHub repositories should be managed and gives the Secretariat and Tools Team various tasks and responsibilities.  As it stands there are two issues with this.  One is the high administrative burden of multiple organisations and repositories.  The second is the limited access to features provided by the free tier, such as the Audit API, which are useful for tools integrations.

As of last week we have an enterprise license for GitHub, which gives the following features:

- access to the Audit API that let’s us pull records of everything for archiving
- allows the creation of unlimited organisations and public repositories under this account.  We can assign whoever we want to manage those without them requiring a license while the Secretariat remains an owner for when an admin change is needed.
- existing organisations can be included under this account if they choose to move to the account
- we are also investigating how it can be used to provide central licensing terms, which will be https://trustee.ietf.org/license-for-open-source-repositories.html <https://trustee.ietf.org/license-for-open-source-repositories.html> to comply with RFC 8875

This basically provides the features the Secretariat and Tools Team need to deliver RFC 8875.  It is also quite cheap as we can use the minimum 10 user license pack, with a not-for-profit discount, provided that we don’t do anything with private repositories, which would change the licensing dramatically.  

> An enterprise license so it could be customized.

Your specific suggestions below should be raised for discussion on tools-discuss.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Lloyd W <[email-masked]>
Date: Wed, 21 Apr 2021 10:22:20 +1000

I argue that the IETF is in publishing.

Which is why the RFC Editor is so important, and should not be overlooked.

Lloyd Wood
[email-masked]

> On 21 Apr 2021, at 02:57, Eliot Lear <[email-masked]> wrote:
>

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 21 Apr 2021 11:41:03 +1000

> How on earth do you get to the position where you believe this is happening?  From my perspective all I see a bunch of people discussing the narrow question of how to avoid an adverse reaction to n…

No, you're right - looking at this context the "snarling it's been considered already" topic is the wrong place for this comment.  The larger "is kindness the key virtue" question is the deeper thing, and I was reminded of it yesterday by a prompt to go back and look at:

https://www.fast.ai/2020/10/28/code-of-conduct/

Which is a great primer on the way in which well meaning codes of behaviour can be weaponised against somebody stating a technical belief that happens to annoy an observer.

> Again, I don’t see how you got here.  It reads to me as if you believe there are good participants who take from this conversation that their snarling days are coming to an end and so are choosing…

I believe there are good participants who will get out if they see a trust-and-safety secret court established which can judge them as having snarled, and tar and feather them as happened to Jeremy in that blog post above, with no recourse and no fair hearing.

> Please explain for the benefit of one very confused onlooker.

I expect I'm conflating "let's all be better, please don't snarl" with "snarling is now banned".  Nobody wants to be a snarler - and we've all done it, either directly or in a passive-aggressive way.  It's amazing how much snarl can be hidden being plausibly deniable politeness, and that's the other big concern with "you must be polite" - it just gives cover to those who are better skilled at hiding nastiness in nice language

For the avoidance of doubt, I'm not accusing you of anything like that in this email.  For real.  I think I wasn't clear about what I meant in my email, and re-reading it I can see why you are/were confused about what I mean!

We had an induction for my kids' school a couple of years ago, and the principal talked to us about bullying, and about how bullies often know the rules the best - they are intimately familiar with the rules and able to weaponise them against others, poking and needling at the other person until they break and lash out back, at which point the bully proudly shouts "look, the other person aggressed me" and points to the chapter and verse of the rule that was broken.  And looking back at the bully's actions leading up, they were all within the letter of the rules, while quite clearly also goading on their victim to impale themselves.

So yeah... that's my concern.  I think it's great for each of us to reflect on our own snarling and talk about good ways to avoid it and to look at how we can guide newcomers more quickly to the already assessed technical landscape and the underlying reasons why particular attractive-looking ideas have been dismissed, while still being open to the idea that we might have been wrong in that dismissal.  No concern there.

But "assign tasks to old-timers" - in the re-educate all the old bad people who need showing that they're wrong sense?  That's how you drive people out - by their involvement no longer worthwhile to them.  We'd want to be really sure there's newer, better people waiting to take their place before embarking down that route!  That's where I was getting at with the "disuade existing customer base in favour of chasing a theoretical new customer base" analogy.

Cheers,

Bron.

---

From: Jay Daley <[email-masked]>
Date: Wed, 21 Apr 2021 15:07:54 +1200

> On 21/04/2021, at 1:41 PM, Bron Gondwana <[email-masked]> wrote:
> 
>> On 20/04/2021, at 10:25 PM, Bron Gondwana <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
> No, you're right - looking at this context the "snarling it's been considered already" topic is the wrong place for this comment. 

Thanks, that partly explains things.

> The larger "is kindness the key virtue" question is the deeper thing, and I was reminded of it yesterday by a prompt to go back and look at:
> 
> https://www.fast.ai/2020/10/28/code-of-conduct/ <https://www.fast.ai/2020/10/28/code-of-conduct/>
> 

I don’t recall seeing anyone suggesting that.

> For the avoidance of doubt, I'm not accusing you of anything like that in this email.  For real.  I think I wasn't clear about what I meant in my email, and re-reading it I can see why you are/were…

Don’t worry I didn’t think you were accusing me.  My reading of the posts though is quite different from yours - I saw a lot of positive suggestions on how to avoid snarling by doing new things that made it easier for newcomers to get up to speed, with little focus on simply banning snarling.

> We had an induction for my kids' school a couple of years ago, and the principal talked to us about bullying, and about how bullies often know the rules the best - they are intimately familiar with…

That’s behaviour I’ve observed too but I struggle to see the relevance here - are you suggesting that by the community trying to manage down bad behaviour all it is doing is creating opportunity for clever bullies to exploit the rules?

> So yeah... that's my concern.  I think it's great for each of us to reflect on our own snarling and talk about good ways to avoid it and to look at how we can guide newcomers more quickly to the al…

Great.

> But "assign tasks to old-timers" - in the re-educate all the old bad people who need showing that they're wrong sense?  That's how you drive people out - by their involvement no longer worthwhile t…

Again, I read that quite differently.  To me this was someone suggesting that old-timers are the best choice for documenting all the "discussed ad nauseum" ideas, which newcomers can then read to avoid falling into the trap.  Sounds like a useful section for the new wiki being planned [1].

Jay

[1]  https://mailarchive.ietf.org/arch/msg/tools-discuss/OKPzIqdz79FAdrKcx9SNDGysUww/

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Bron Gondwana" <[email-masked]>
Date: Wed, 21 Apr 2021 13:49:06 +1000

> I don’t recall seeing anyone suggesting that.

Nope, but it's a persistent end-state .  The particular good thing which Jeremy called out was:

Some of these issues are discussed in an excellent presentation <https://files.frameshiftconsulting.com/codeofconducttraining.pdf> from Valerie Aurora, who explains that “a code of conduct should contain” “behaviors which many people think are acceptable but are unacceptable in your community”, and that “If you want to list good behaviors or describe the community ideal of behavior, do it in a separate document”, and in particular “Do not require politeness or other forms of ‘proper’ behavior”.

> That’s behaviour I’ve observed too but I struggle to see the relevance here - are you suggesting that by the community trying to manage down bad behaviour all it is doing is creating opportunity fo…

If the community starts enforcing "proper behaviour", then yes - that's where there's an opportunity for bullies to say "X snarled at me, CoC them".  And it's really hard to tell who's the bully in the general case - often both parties have some "instigating" blame to be apportioned.

> Again, I read that quite differently.  To me this was someone suggesting that old-timers are the best choice for documenting all the "discussed ad nauseum" ideas, which newcomers can then read to a…

I found a good one over in one of the other threads, which is very not much IETF specific, and is the assumption "company X is big so they can implement my idea / test my idea easily".  For sure, documenting both "discussed ad nauseum" and "fallacies about how the standards work" (hello protocol police) is useful.

In the degenerate case, once you remove the politeness angle, what's left of snarling is "outright dismissal of input without showing cause"... which is still tricky because when the Nth person shows up proposing that we drop all other work to implement IPv100-over-QBITS, it becomes a DoS to be required to fully educate them to their satisfaction.  In the anti-spam email world it got to the point where somebody built a template for rejecting ideas:

https://craphound.com/spamsolutions.txt

And sometimes a list like that is necessary to allow you to quickly dismiss distractions and get back to work!

Bron.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Wed, 21 Apr 2021 00:27:48 -0400

> me as very useful work indeed.

That depends on the feedback and if it is actually feedback. I almost
invariably give too much explanation. And the fact something failed 20
years ago isn't always dispositive, but it is important context.

What I noticed some people do is to tell people something is bad without
making any further argument or they will claim certain authorities have
written that something is just a terrible idea. When someone tries that on
me, I invariably contact said authority for their opinion, unless of course
I discussed the issue with them directly before making the proposal.

Thing is, it's not just newcomers who have difficulty with the way IETF
carries on.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 21 Apr 2021 16:59:23 +1200

On 21-Apr-21 15:07, Jay Daley wrote:
...
> Again, I read that quite differently.  To me this was someone suggesting that old-timers are the best choice for documenting all the "discussed ad nauseum" ideas, which newcomers can then read to a…

I think so, but it needs to be curated in a somewhat Wikipedian style to ensure that it isn't just a list of pet peeves. IMHO it certainly should not be old timers only. As evidence I submit RFC6294, where most of the spadework was done by a grad student.

   Brian

---

From: Martin J. Dürst <[email-masked]>
Date: Wed, 21 Apr 2021 15:32:10 +0900

> I do not. I’m not sure that a process or tool exists that can be described in those terms, including our present processes and tools.

I know some very productive open source contributors who do not think 
GitHub is perfect for source code development.

I wouldn't expect GitHub to be perfect for IETF use, which has usage 
patterns quite a bit different from source code development.

Also, users are individuals with different work habits and preferences. 
It is very rare that a single tool fits all users perfectly, even for 
the same range of work. That definitely also applies to our present 
process and tools.

The greatest feature in GitHub is pull requests, allowing to provide 
suggestions for changes to text in an *actionable* form. When I worked 
on specs at the W3C or for the IETF, I often wished I had such a tool.

The main drawbacks are GitHub's chattiness (it's not possible to close 
an issue with a comment in one go), and the lack of context that forces 
one to go back to GitHub often. These could be improved upon, but I 
guess especially the second is something they wouldn't want to do; once 
you have your users, you don't want to let them go.

Regards,    Martin.

---

From: Nick Hilliard <[email-masked]>
Date: Wed, 21 Apr 2021 15:29:34 +0100

Martin J. Dürst wrote on 21/04/2021 07:32:
>> I do not. I’m not sure that a process or tool exists that can be 
>> described in those terms, including our present processes and tools.
> 

tools don't need to be perfect to be usable, and the IETF has always 
encoded the principle that insisting on perfection is an obstacle to 
progress.

The discussion on tools needs to centre not on whether GH or any other 
tool is perfect, but whether they suit a reasonable number of people for 
a reasonable number of things.  So long as people aren't forced down any 
particular alley - and in the case of GH, they are clearly not - then 
there isn't a particular problem with opening up access to a specific 
tool or other.  There is nothing which suits everyone.

Nick