Subject: Re: Proposal: an "important-news" IETF announcement list

From: tom petch <[email-masked]>
Date: Fri, 1 Oct 2021 09:35:03 +0100

On 30/09/2021 21:01, Brian E Carpenter wrote:
> On 01-Oct-21 07:05, Michael Richardson wrote:
>> Brian E Carpenter <[email-masked]> wrote:
>> > On 30-Sep-21 04:07, Michael Richardson wrote:
>> >>
>> >> Barry Leiba <[email-masked]> wrote:
>> >> > I think that 2, 5, 7, 8, 9, and 10 should be in a weekly summary, one
>> >> > single message per week.
>> >>
>> >> Mailman has a digest mode.  Would that suffice?
>>
 >> > No, because from observation, most people who reply to a digest don't
>> > change the Subject to a useful string. This would be disastrous for
>> > Last Call workflows in particular.
>>
>> The categories proposed that would be on a list that would be digestable
>> would be (based upon what Barry wrote):
>>
>>>>>> 2.  Announcements of new and updated WG charters & WG closures = 44
>>>>>> 5.  Announcements of new RFCs = 275
>>>>>> 7.  Announcements of document actions = 175
>>>>>> 8.  Announcements of IESG conflict-review results = 14
>>>>>> 9.  Last call announcements for I-Ds = 174 (+ 4 for other actions)
>>>>>> 10. Interim WG meeting announcements = 256
>>
>> So, we'd need to not include Last Call Announcements in that list.
>> Then would it work for you?
>
> Not if it ever leads me to receive a message with a subject like
>
> Re: document-actions Digest, Vol 52, Issue 41
>
> That one would take many times longer before I could hit delete than
>
> Re: Document Action: 'Boring Stuff' to Informational RFC (draft-ietf-boring-stuff-10.txt)

Spot on. Digests are dire, uninformative header, hard to find the real 
content in, unsuitable Reply to.

By contrast, I think that Last Call announcements get it almost right. 
The Subject line tells me whether or not I am interested, I only need 
the body for the date (which I would like to be more prominent).

I suggested earlier that while Last Call should each have a separate 
e-mail on some list, yet a weekly summary would cut by a factor of three 
the traffic on whatever is the new list. I did not mean digest! rather a 
customised e-mail taking the subject line of each Last Call announcement 
and putting it on a separate line in the body

e.g.

Last Call: <draft-ietf-regext-rfc7484bis-04.txt> (Finding the 
Authoritative Registration Data (RDAP) Service) to Internet Standard

Last Call: <draft-ietf-tsvwg-rfc4960-bis-15.txt> (Stream Control 
Transmission Protocol) to Proposed Standard

Last Call: <draft-ietf-netconf-notification-capabilities-17.txt> (YANG 
Modules describing Capabilities for Systems and Datastore Update 
Notifications) to Proposed Standard

or, less expansive,

Last Calls week ending ....

<draft-ietf-regext-rfc7484bis-04.txt> to IS

<draft-ietf-tsvwg-rfc4960-bis-15.txt> to PS

<draft-ietf-netconf-notification-capabilities-17.txt> to PS

PS: Proposed Standard
IS: Internet Standard

Tom Petch

>
>> A thing that I like about the digest option is that the archives (and IMAP)
>> would have the individual messages.
>
> But in my experience people reply directly to the digest.
>
> The bottom line is that people's workflows and email habits vary widely,
> so there is no one-size-fits-all solution.
>
>     Brian

---

From: John C Klensin <[email-masked]>
Date: Fri, 01 Oct 2021 07:39:59 -0400

--On Friday, October 1, 2021 09:35 +0100 tom petch
<[email-masked]> wrote:

>>> >> > I think that 2, 5, 7, 8, 9, and 10 should be in a
>>> >> > weekly summary, one single message per week.
>>> >> 
>>> > change the Subject to a useful string. This would be
>>> > disastrous for Last Call workflows in particular.
>>> 
>>> The categories proposed that would be on a list that would
>>> be digestable would be (based upon what Barry wrote):
>>> 
>>>>>>> 2.  Announcements of new and updated WG charters & WG
>>>>>>> closures = 44 5.  Announcements of new RFCs = 275
>>>>>>> 9.  Last call announcements for I-Ds = 174 (+ 4 for
>>>>>>> other actions) 10. Interim WG meeting announcements = 256
>>> 
>>> So, we'd need to not include Last Call Announcements in that
>>> list. Then would it work for you?
>> 
> Spot on. Digests are dire, uninformative header, hard to find
> the real content in, unsuitable Reply to.
> 
> By contrast, I think that Last Call announcements get it
> almost right. The Subject line tells me whether or not I am
> interested, I only need the body for the date (which I would
> like to be more prominent).
> 
> I suggested earlier that while Last Call should each have a
> separate e-mail on some list, yet a weekly summary would cut
> by a factor of three the traffic on whatever is the new list.
> I did not mean digest! rather a customised e-mail taking the
> subject line of each Last Call announcement and putting it on
> a separate line in the body
> 
> e.g.
> 
> Last Call: <draft-ietf-tsvwg-rfc4960-bis-15.txt> (Stream
> Control Transmission Protocol) to Proposed Standard
> 
> Last Call:
> <draft-ietf-netconf-notification-capabilities-17.txt> (YANG
> Modules describing Capabilities for Systems and Datastore
> Update Notifications) to Proposed Standard
> 
> or, less expansive,
> 

Yes.  And then including the expiration dates would be even more
important.  I note that you have "week ending" but I'd suggest
two sections: 
  New announcements 
  Previously announced

Any resemblance between that and the "New items" and "Returning
items" breakdown on the IESG agendas -- and the fact that the
first three lines of each item identify file name, proposed
status, title, and relevant Area--  reinforce the value of such
a summary.  Like you, I'd add Last Call expiration dates (not
needed on the IESG agenda because documents don't show up there
until they are close to or past those dates).

best,
   john

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 1 Oct 2021 10:09:07 -0500

Top-posting to say that this conversation seems headed in the right
direction.

IIRC, the thing we were trying to accomplish with the Last-Call mailing
list, was to make it easier for People Who Care to follow the entire Last
Call thread for a specific draft, without having to dig through all of the
posts on the IETF discussion list.

If a summary of what's entering Last Call, and what's in Last Call, was
available, that would make it easier for People Who Care to see that it's
time to provide last call comments for specific drafts in specific threads,
and that would also be appreciated.

Best,

Spencer

---

From: Michael Richardson <[email-masked]>
Date: Fri, 01 Oct 2021 11:31:15 -0400

tom petch <[email-masked]> wrote:
    > I suggested earlier that while Last Call should each have a separate e-mail
    > on some list, yet a weekly summary would cut by a factor of three the traffic
    > on whatever is the new list. I did not mean digest! rather a customised
    > e-mail taking the subject line of each Last Call announcement and putting it
    > on a separate line in the body

Hmm. But, can we use digest format?  Many of us have digest burst actions in
our MUAs, which means that we could do the burst, and then followup properly.
(Yes, many people born after 1985 won't know about that)

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Robert Sparks <[email-masked]>
Date: Fri, 1 Oct 2021 10:32:48 -0500

Related but apart from discussion of what summaries might be sent by email -

There is a feed for last call documents at 
https://datatracker.ietf.org/feed/last-call, and a page at 
https://datatracker.ietf.org/doc/in-last-call.

There are several feeds, fwiw. At one point there was a menu for them, 
but pressure to declutter the menus some time back took that away. There 
should at least be a summary page somewhere.

RjS

On 10/1/21 10:09 AM, Spencer Dawkins at IETF wrote:
> IIRC, the thing we were trying to accomplish with the Last-Call 
> mailing list, was to make it easier for People Who Care to follow the 
> entire Last Call thread for a specific draft, without having to dig 
> through all of the posts on the IETF discussion list.
>
> If a summary of what's entering Last Call, and what's in Last Call, 
> was available, that would make it easier for People Who Care to see 
> that it's time to provide last call comments for specific drafts in 
> specific threads, and that would also be appreciated.
>
> Best,
>
> Spencer
>
> On Fri, Oct 1, 2021 at 6:40 AM John C Klensin <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>
>
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>     >>> Brian E Carpenter <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >>> >> Barry Leiba <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >  >> > No, because from observation, most people who reply to a
>     > digest don't

---

From: Michael Richardson <[email-masked]>
Date: Fri, 01 Oct 2021 12:36:52 -0400

> https://datatracker.ietf.org/doc/in-last-call.

Could we update the footer for those lists to say;
  "Want this as an Atom feed? Use ..."

---

From: John C Klensin <[email-masked]>
Date: Fri, 01 Oct 2021 14:01:19 -0400

--On Friday, October 1, 2021 10:32 -0500 Robert Sparks
<[email-masked]> wrote:

> There are several feeds, fwiw. At one point there was a menu
> for them, but pressure to declutter the menus some time back
> took that away. There should at least be a summary page
> somewhere.

Robert,

Thanks.

Noting that a page the IETF participants don't know about or
don't know how to find is of limited utility, your paragraph
above exactly, if indirectly, summarizes part of the problem.
I've just looked at 
   https://www.ietf.org
   https://www.ietf.org/standards/process/
and even
   https://www.ietf.org/links/ 
(which only active participants who have been paying attention
know how to find).

And, if any of them contain the links you provided or even hints
that they exist, I'm not looking hard enough.  While, again, I
don't think that page is a substitute for well-considered Last
Call announcements (at least to the relevant WG, maybe Area, and
a weekly summary as others have discussed), it suggests that we
should be looking more broadly than tweaking or subdividing
mailing lists.  

Some particular suggestions that I assume should be
straightforward if others agree:

(1) Add https://datatracker.ietf.org/doc/in-last-call to the
"links" page under "IESG", "Internet-Drafts" or both.

(2) Add a line to the bottom of the template for Last Call
announcements that says something like "A listing of open IETF
Last Calls is available at
https://datatracker.ietf.org/doc/in-last-call

Really a different topic, but I also think the "links" page
should be more obviously available from the www.ietf.org home
page and wonder whether the Last Calls should be identified
there too.  However, I've lost track of who the audience for
that page is supposed to be and wonder if any evaluation is
underway for whether that redesign is serving its intended
purpose. 

best,
   john

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 2 Oct 2021 09:27:27 +1300

> underway for whether that redesign is serving its intended

I believe I am to blame for the existence of that page, which
largely speaking does what the old IETF sidebar did.
(For the nostalgic, see https://www6.ietf.org/)

fwiw, I agree that it should be more obvious and cover more
ground.

    Brian