Subject: Re: [Gendispatch] Last Call: <draft-eggert-bcp45bis-06.txt> (IETF Discussion List Charter) to Best Current Practice

From: Lloyd W <[email-masked]>
Date: Wed, 20 Oct 2021 20:25:27 +1100

A sergeant-at-arms (SAA) "is an officer appointed by a deliberative
   body (...) to keep order during its meetings" [SAA-WIKIPEDIA].  SAAs
   for the IETF discussion list are appointed by the IETF Chair and are
   empowered to restrict posting by a person, or of a thread, when the
   content is inappropriate and represents a pattern of abuse

there's an inherent contradiction in that little quoted snippet, which remains unexplained in the text of this draft despite being raised previously on gendispatch.

In many bodies, the body itself appoints the SAAs, and that Wikipedia page says as much, at least until someone edits it to say otherwise.

Here, in a draft being written by the IETF Chair, the very next sentence says that the SAAs are not appointed by the deliberative body itself - which is to say, the mailing list contributors - but by the Chair. Who, by the way, is the person writing this draft describing the Chair's powers. Yes, the Chair is the person doing the necessary work of writing this update draft, but, just maybe, hear me out, since it describes powers of the Chair, the Chair really shouldn't have been tasked with doing it in the first place?

This cascading cognitive dissonance remains a bad look, and the draft should at least attempt to explain these points somehow -  historical practice, under further review, we didn't realise how much the SAAs were at the behest of the chairs, the SAAs actually have very little independence, this is just how it is, the SAAs are not appointed by the list, but by the chair who is writing this draft which tightens and tidies and documents previous practice, we can't trust the list to even stay on topic and keep to an undefined level of 'professionalism', so have it appoint its own SAAs? Ha, you must be joking, IETF LLC has a reputation to protect.

I don't know what the explanation will be, but there needs to be one. Just saying 'well, the wikipedia page is not a dictionary and is not normative' would not be enough - and if referencing wikipedia you'd need to give a date/revision, anyway, just as we do for drafts, because wikipedia is eternally drafted.

(we reject kings etc. and the chair unfortunately looks here very much like a king issuing executive fiat. but we also reject voting, so we'd have to... hum between candidates?)

The draft can't skip around this, but imo does have to explicitly address and explain these points in its text, and thus shed some light on the underlying philosophy of list governance which must underpin and support the reasoning given.  Somehow. 

How the draft chooses to do this will imo say a lot about the IETF.

I encourage IETF mailing list contributors to look closely at this draft.

Lloyd Wood
[email-masked]

> On 20 Oct 2021, at 02:53, The IESG <[email-masked]> wrote:
> 
> 
> The IESG has received a request from an individual submitter to consider the
> following document: - 'IETF Discussion List Charter'
>  <draft-eggert-bcp45bis-06.txt> as Best Current Practice
> 
> The IESG plans to make a decision in the next few weeks, and solicits final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2021-11-23. Exceptionally, comments may
> be sent to [email-masked] instead. In either case, please retain the beginning
> of the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>   The Internet Engineering Task Force (IETF) discussion mailing list
>   furthers the development and specification of Internet technology
>   through the general discussion of topics for which no dedicated
>   mailing lists exists.  As this is the most general IETF mailing list,
>   considerable latitude is allowed, but there are posts and topics that
>   are unsuitable for this mailing list.
> 
>   This document obsoletes RFC3005.
> 
> 
> 
> 
> The file can be obtained via
> https://datatracker.ietf.org/doc/draft-eggert-bcp45bis/
> 
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> 
> 
> 
> 
> 
> -- 
> Gendispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gendispatch

---

From: Lars Eggert <[email-masked]>
Date: Wed, 20 Oct 2021 15:36:33 +0300

Hi Lloyd,

thank you for your feedback.

On 2021-10-20, at 12:25, Lloyd W <lloyd.wood=[email-masked]> wrote:
> Here, in a draft being written by the IETF Chair, the very next sentence says that the SAAs are not appointed by the deliberative body itself - which is to say, the mailing list contributors - but by the Chair.

First, I added the link to that Wikipedia page (which was not in the original BCP45), because I received feedback from IETF participants outside of the US/UK geos that the term "sergeant at arms" was unfamiliar. I'd be happy to point to a better definition.

Second, I think we're reading the Wikipedia text differently. I read "appointed by a deliberative body" pretty broadly, including appointments by an elected committee or chair of the body in question.

> Who, by the way, is the person writing this draft describing the Chair's powers. Yes, the Chair is the person doing the necessary work of writing this update draft, but, just maybe, hear me out, since it describes powers of the Chair, the Chair really shouldn't have been tasked with doing it in the first place?

BCP45bis does not grant the IETF chair any additional powers. In fact, it removes some.

I repeatedly asked if the community felt that someone else should hold the pen for this, and most feedback I received seemed to indicate that it was OK for me to do this, given the minor nature of the changes. I'll leave it up to my sponsoring AD to decide if this is a change we should (now) do anyhow.

> This cascading cognitive dissonance remains a bad look, and the draft should at least attempt to explain these points somehow -  historical practice, under further review, we didn't realise how muc…

I'm sorry this minor update is giving you cascading cognitive dissonance.

You raised two points in this email: (1) that in your opinion the Wikipedia page for SAA is not fully aligned with our SAA selection, and (2) that the IETF chair is authoring this minor update. I hope I gave additional context on both points above.

> I don't know what the explanation will be, but there needs to be one. Just saying 'well, the wikipedia page is not a dictionary and is not normative' would not be enough - and if referencing wikipe…

The Wikipedia page is an informative reference already. I don't think it's common practice to call out in the text that a reference is informative, but I can of course do so if that ends up being the consensus. I will add a retrieval date to the reference, or alternatively cite an archive.org snapshot of the page.

> How the draft chooses to do this will imo say a lot about the IETF.

Again, I hope I gave you additional context above. I remain unconvinced that the document itself needs text to capture some of this context, however.

> I encourage IETF mailing list contributors to look closely at this draft.

Seconded.

Thanks,
Lars

---

From: Barry Leiba <[email-masked]>
Date: Wed, 20 Oct 2021 09:13:39 -0400

> I encourage IETF mailing list contributors to look closely at this draft.

I have looked at it closely, and I do NOT share the concerns raised
here.  I think the draft is a reasonable update to BCP 45, that it
clarifies the charter for the IETF list and the SAA team's role, and
that anything more than this would need a fresh effort by the
community to make a more significant update -- which I don't think is
needed.

I think there is no contradiction between the use of Wikipedia to
explain the general role of Sergeants at Arms and the role the SAAs
have with respect to the IETF list.  Wikipedia discusses some
mechanisms for appointment and use of SAAs, but those are not the only
mechanisms.  It's not wrong, and neither is it exhaustive.

The only way we have, at this point, to make community appointments is
through the NomCom, and I think it would be a bad approach to add SAA
positions to the NomCom's slate.

The draft makes it clear that the purpose of the SAA team is to allow
the IETF Chair to appoint people to handle this role, and then to step
back and *not* be a king, to *not* have a day-to-day role in
monitoring and managing the IETF list.  That is as it should be.

I find nothing at all wrong with the IETF Chair being the editor of
this draft: Lars has fairly edited it based on input, and its contents
reflect not Lars's thoughts, but rough consensus of the community so
far.  That not everyone is happy with everything it says shows that we
have *rough consensus*, not unanimity... it does not say that the IETF
Chair has done anything inappropriate here.

This is ready to be published and to update BCP 45.

Barry

---

From: "Bron Gondwana" <[email-masked]>
Date: Thu, 21 Oct 2021 01:34:11 +1100

> positions to the NomCom's slate.

I definitely agree with this.  While there are some advantages to having the NomCom appoint everything, the SAA role isn't one of the things that needs it - likewise we don't have the NomCom appoint all working group chairs, instead we have the ADs appoint them as part of their responsibilities.

I do understand Lloyd's issue as well - he had a particularly messy run-in with the SAA in a circumstance where the SAA was being used to shut down a very uncomfortable discussion about a publication which was seen to be claiming a consensus which had not been established.

If the SAA was the final arbiter of what's acceptable in the IETF, then I'd agree that we need a more rigorous way to appoint them - but, they aren't.  The escalation point for a problem with the SAA is the IETF chair, and if you ALSO have a problem with the chair, then there's a dispute resolution or recall processes.  So the SAA isn't the final arbiter, so I'm quite happy for the SAAs to continue to be appointed by the chair.

Cheers,

Bron.

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 20 Oct 2021 15:17:06 +0000

> This is ready to be published and to update BCP 45.

+1
I find the definition of SAA at "https://www.wordnik.com/words/sergeant%20at%20arms"
to be more consistent with IETF usage but don't object to the Wikipedia page being used
to help people understand the origins of the term. Understanding the origins of the term is
a reasonable use of an informative reference. I do not agree with suggestions that "if IETF
wants to use this term and point to the Wikipedia page to help people understand the
term's origins, then IETF must define the role exactly as described on the Wikipedia page".
I also would not agree with a suggestion that "because IETF's definition of the SAA role
does not precisely match the Wikipedia description of the term's origins, IETF must use
a different name for the role".
Neither suggestion makes sense to me.
I also think the proposed updates are fine and don't think it's a problem for Lars to have
written them.
Barbara

> > there's an inherent contradiction in that little quoted snippet, which remains
> unexplained in the text of this draft despite being raised previously on
> gendispatch.
> >
> > In many bodies, the body itself appoints the SAAs, and that Wikipedia page
> says as much, at least until someone edits it to say otherwise.
> >
> > Here, in a draft being written by the IETF Chair, the very next sentence says
> that the SAAs are not appointed by the deliberative body itself - which is to say,
> the mailing list contributors - but by the Chair. Who, by the way, is the person
> writing this draft describing the Chair's powers. Yes, the Chair is the person
> doing the necessary work of writing this update draft, but, just maybe, hear me
> out, since it describes powers of the Chair, the Chair really shouldn't have been
> tasked with doing it in the first place?
> >
> > This cascading cognitive dissonance remains a bad look, and the draft should
> at least attempt to explain these points somehow -  historical practice, under
> further review, we didn't realise how much the SAAs were at the behest of the
> chairs, the SAAs actually have very little independence, this is just how it is, the
> SAAs are not appointed by the list, but by the chair who is writing this draft
> which tightens and tidies and documents previous practice, we can't trust the list
> to even stay on topic and keep to an undefined level of 'professionalism', so
> have it appoint its own SAAs? Ha, you must be joking, IETF LLC has a reputation
> to protect.
> >
> > I don't know what the explanation will be, but there needs to be one. Just
> saying 'well, the wikipedia page is not a dictionary and is not normative' would
> not be enough - and if referencing wikipedia you'd need to give a date/revision,
> anyway, just as we do for drafts, because wikipedia is eternally drafted.
> >
> > (we reject kings etc. and the chair unfortunately looks here very much like a
> king issuing executive fiat. but we also reject voting, so we'd have to... hum
> between candidates?)
> >
> > The draft can't skip around this, but imo does have to explicitly address and
> explain these points in its text, and thus shed some light on the underlying
> philosophy of list governance which must underpin and support the reasoning
> given.  Somehow.
> >
> > https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-eggert-
> bcp45bis/__;!!BhdT!0qhHLkRLBCzfz2_B0zYKcT-
> 87lxnEs7p5XEnW4bhmTHp_R8vdc6fchEhGrNTRw$
> >
> >
> >
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/gendispatc
> h__;!!BhdT!0qhHLkRLBCzfz2_B0zYKcT-
> 87lxnEs7p5XEnW4bhmTHp_R8vdc6fchGfidxfJA$
> >
> > --
> > Gendispatch mailing list
> > [email-masked]
> >
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/gendispatc
> h__;!!BhdT!0qhHLkRLBCzfz2_B0zYKcT-
> 87lxnEs7p5XEnW4bhmTHp_R8vdc6fchGfidxfJA$

---

From: S Moonesamy <[email-masked]>
Date: Sat, 30 Oct 2021 04:39:41 -0700

Hi Keith,
At 03:53 PM 20-10-2021, Keith Moore wrote:
>The aggregate effect of such efforts is to make IETF more like an 
>echo chamber, in which everyone is expected to "know their place" - 
>i.e. know to not express views that might conflict with the views of 
>those in power, or otherwise know the unwritten "rules".   This is, 
>after all, often what is expected of "professionals" in their 
>workplaces, which is yet another reason why "professional" is a poor 
>criterion for describing which behavior is appropriate or not in 
>IETF discussions.

I read comments about the word "professional" in a RFC over the 
years.  Here is another comment [1] (translated with Yandex):

   "Unfortunately, this RFC feels obliged to add that it is necessary to behave
    in a professional manner as if amateurs were avinee brutes and that it is
    only in the context of work that one can be civilized."

The sentence with that word was the "IETF Consensus" when the RFC was 
approved for publication.  The "know their place" was removed during 
the revision of the document.  There isn't anything in the RFC which 
prohibits a participant from expressing his/her disagreement with an 
Area Director's decision.

One of the points which you raised is about "a system in which people 
are placed in a series of levels with different importance or 
status".  The RFC does not establish a system with different levels 
of importance or status.

The underlying value for some participants is most likely related to 
https://www.uscourts.gov/about-federal-courts/educational-resources/about-educational-outreach/activity-resources/what-does 
A participant residing in another country might not have the 
background information to understand those participants.  It takes 
many years to understand all that.

Regards,
S. Moonesamy

1. http://r.elandsys.com/r/86822

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sat, 30 Oct 2021 05:34:44 -0700

As far as I am concerned there is only one correct context in which the word "professional" should be used at the IETF, which is to qualify the documents we produce.

On 10/30/21 04:39, S Moonesamy wrote:
>> The aggregate effect of such efforts is to make IETF more like an echo chamber, in which everyone is expected to "know their place" - i.e. know to not express views that might conflict with the views of those in power, or otherwise know the unwritten "rules".   This is, after all, often what is expected of "professionals" in their workplaces, which is yet another reason why "professional" is a poor criterion for describing which behavior is appropriate or not in IETF discussions.
> 
> I read comments about the word "professional" in a RFC over the years.  Here is another comment [1] (translated with Yandex):
> 
> The sentence with that word was the "IETF Consensus" when the RFC was approved for publication.  The "know their place" was removed during the revision of the document.  There isn't anything in the RFC which prohibits a participant from expressing his/her disagreement with an Area Director's decision.
> 
> One of the points which you raised is about "a system in which people are placed in a series of levels with different importance or status".  The RFC does not establish a system with different levels of importance or status.
> 
> The underlying value for some participants is most likely related to https://www.uscourts.gov/about-federal-courts/educational-resources/about-educational-outreach/activity-resources/what-does A participant residing in another country might not have the background information to understand those participants.  It takes many years to understand all that.
> 
> Regards,
> S. Moonesamy
> 

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: Keith Moore <[email-masked]>
Date: Sat, 30 Oct 2021 18:31:07 -0400

On 10/30/21 7:39 AM, S Moonesamy wrote:
>> criterion for describing which behavior is appropriate or not in IETF 
>> discussions.
>
> status".  The RFC does not establish a system with different levels of 
> importance or status.

For me a lot of the problem is that the word "professional" has many 
different meanings, and is therefore ambiguous.

One interpretation of "professional behavior" seems to be norms of a 
corporate workplace.  But corporate workplaces have many restraints on 
speech and behavior which aren't appropriate for IETF.   For example, 
publicly criticizing your employer, or its leadership, or its policies, 
or its products, can get you fired. But IETF should be open to public 
criticism, even by (perhaps especially by) its participants.

Another interpretation of "professional" refers to a group of persons 
who are all make their living in the same trade.   It can even carry 
with it the assumption that "professionals" are privileged somehow.  
(There's a joke: "Why don't sharks eat lawyers?"  "Professional 
courtesy.")   But IETF is open to participation by everyone, and its 
participants should treat each other as peers, regardless of how they 
earn their living or even whether they are employed.

It's hard to escape the impression that some of those insisting on 
"professional behavior" are looking for a way to exclude those who they 
deem not qualified, so as to get out of the way of the Big Corporations 
who want IETF to do what they want it to do.

Anyway, if "unprofessional behavior" is not defined, those in power can 
use any deviation from "normal" as an excuse to sanction participants.

But I also realize that maybe this doesn't matter much, as the scope of 
this document is limited to the IETF list which is of decreasing 
relevance anyway.   The IETF list used to serve as the primary forum of 
the community, its center, and also its conscience.   This draft along 
with several other IMO extremely harmful measures that have been taken 
in recent years (including the creation of gendispatch) narrows the 
scope of the IETF list so much that it effectively destroys most of the 
utility that the IETF list used to have, and with it the organization's 
core values.

I don't know why people think that the solution to traffic overload is 
to keep siloing discussions ad infinitum, and I would argue that one of 
IETF's core problems has long been the over-fragmentation of discussions.

Or maybe the fragmentation of the IETF list was part of a deliberate 
effort to subvert the IETF into being a forum that only serves the 
Internet industry, rather than one trying to serve the broader Internet 
community?

> many years to understand all that.

These rules don't really apply to discussions like the IETF list, even 
in the United States.   Governments within the US are forbidden from 
penalizing most kinds of speech.   But those restrictions on government 
don't prevent the moderation of discussions hosted by non-governmental 
organizations such as IETF, or for that matter discussions on social 
media sites.

But it may well be true that US citizens and longtime US residents, 
accustomed to having few government prohibitions on speech, are somewhat 
more outspoken than those from elsewhere.

Keith

---

From: Lloyd W <[email-masked]>
Date: Sun, 31 Oct 2021 11:00:56 +1100

> On 30 Oct 2021, at 22:42, S Moonesamy <[email-masked]> wrote:
> 
> as if amateurs were avinee brutes

a better translation of that phrase is "drunken bullies". (Google Translate has an edge over Yandex, btw.)

But really, if we're not working to advance the corporate interests of our employers, why are we even here?

L.

The name's Wood. Lloyd Wood. I'll have a vodka martini. shaken, not stirred.

---

From: Lloyd W <[email-masked]>
Date: Sun, 31 Oct 2021 11:23:09 +1100

> On 31 Oct 2021, at 09:32, Keith Moore <[email-masked]> wrote:
> It's hard to escape the impression that some of those insisting on "professional behavior" are looking for a way to exclude those who they deem not qualified, so as to get out of the way of the Big Corporations who want IETF to do what they want it to do.

Absolutely. That's why I threw together

http://lloydwood.users.sourceforge.net/Personal/L.Wood/publications/internet-drafts/README.html

in my defence, because every so often I get asked to justify my worth and existence to some random corporate apparatchik of some random company who has decided that he (and it's always a he. women just don't do that whole  'you must justify your right to exist to me' thing) dislikes my participation in an IETF mailing list.

And what justifies their participation in the IETF? Why, their employer!

L.

it's really all a bit "show me your papers".

---

From: Keith Moore <[email-masked]>
Date: Sat, 30 Oct 2021 20:34:07 -0400

> <http://lloydwood.users.sourceforge.net/Personal/L.Wood/publications/internet-drafts/README.html>
>
> in my defence, because every so often I get asked to justify my worth 
> and existence to some random corporate apparatchik of some random 
> company who has decided that he (and it's always a he. women just 
> don't do that whole  'you must justify your right to exist to me' 
> thing) dislikes my participation in an IETF mailing list.

And that's why it's important to reinforce the idea that IETF 
participants are NOT representatives of their employers, but at most 
"sponsored" by them (or in many cases they pay their own way), and IETF 
participants are expected to use their own best technical judgment about 
what's good for the Internet as a whole.

Keith

---

From: Sander Steffann <[email-masked]>
Date: Sun, 31 Oct 2021 02:51:54 +0200

Hi,

> And that's why it's important to reinforce the idea that IETF participants are NOT representatives of their employers, but at most "sponsored" by them (or in many cases they pay their own way), and IETF participants are expected to use their own best technical judgment about what's good for the Internet as a whole.

If we can get back to this, I'm in!

Unfortunately the IETF has indeed become the IVTF (https://archive.psg.com/051000.sigcomm-ivtf.pdf)

Cheers,
Sander

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 31 Oct 2021 16:38:23 +1300

s/Unprofessional commentary/Uncivil commentary/

Merriam-Webster Online says:

Definition of uncivil

1 : not civilized : barbarous
2 : lacking in courtesy : ill-mannered, impolite uncivil remarks
3 : not conducive to civic harmony and welfare

Regards
    Brian Carpenter
    Thinking of the IETF standards process: https://xkcd.com/2530/

---

From: S Moonesamy <[email-masked]>
Date: Sun, 31 Oct 2021 01:37:51 -0700

Hi Keith,
>different meanings, and is therefore ambiguous.

As a point of information, the text was added in December 2013 based 
on feedback.  I verified whether the change was in accordance with 
the "process" documents.

>corporate workplace.  But corporate workplaces have many restraints 
>on speech and behavior which aren't appropriate for IETF.   For 
>example, publicly criticizing your employer, or its leadership, or 
>its policies, or its products, can get you fired. But IETF should be 
>open to public criticism, even by (perhaps especially by) its participants.
>
>Another interpretation of "professional" refers to a group of 
>persons who are all make their living in the same trade.   It can 
>even carry with it the assumption that "professionals" are 
>privileged somehow.  (There's a joke: "Why don't sharks eat 
>lawyers?"  "Professional courtesy.")   But IETF is open to 
>participation by everyone, and its participants should treat each 
>other as peers, regardless of how they earn their living or even 
>whether they are employed.
>
>"professional behavior" are looking for a way to exclude those who 
>they deem not qualified, so as to get out of the way of the Big 
>Corporations who want IETF to do what they want it to do.
>
>Anyway, if "unprofessional behavior" is not defined, those in power 
>can use any deviation from "normal" as an excuse to sanction participants.

The professional courtesy is not a one-way street.  There was a time 
when the views of those who were not regular attendees were ignored 
during Last-Calls and the Area Directors called it "consensus".  To 
be fair, there were some Area Directors who did not follow to that practice.

>But I also realize that maybe this doesn't matter much, as the scope 
>of this document is limited to the IETF list which is of decreasing 
>relevance anyway.   The IETF list used to serve as the primary forum 
>of the community, its center, and also its conscience.   This draft 
>along with several other IMO extremely harmful measures that have 
>been taken in recent years (including the creation of gendispatch) 
>narrows the scope of the IETF list so much that it effectively 
>destroys most of the utility that the IETF list used to have, and 
>with it the organization's core values.

The IETF mailing list is no longer the marketplace of the IETF.  It 
weakens the IETF.

The shared values is bound to change with newer participants.  There 
are also changes outside the IETF which influence those values.

>I don't know why people think that the solution to traffic overload 
>is to keep siloing discussions ad infinitum, and I would argue that 
>one of IETF's core problems has long been the over-fragmentation of 
>discussions.

It is probably easier to solve an issue by having a narrow scope.  I 
assume that some of the mailing list subscribers know the story of 
the three blind men and an elephant.  It explains what can happen 
when by having a narrow scope.

>Internet industry, rather than one trying to serve the broader 
>Internet community?

It is better, in my opinion, to focus on whether the IETF is serving 
the broader community instead of whether there was a deliberate 
effort (or not) to serve the industry only.

>These rules don't really apply to discussions like the IETF list, 
>even in the United States.   Governments within the US are forbidden 
>from penalizing most kinds of speech.   But those restrictions on 
>government don't prevent the moderation of discussions hosted by 
>non-governmental organizations such as IETF, or for that matter 
>discussions on social media sites.
>
>accustomed to having few government prohibitions on speech, are 
>somewhat more outspoken than those from elsewhere.

Some participants may not be understand why there are debates about 
"free speech" in a place where people are expected to discuss 
technical documents.

The purpose of this exchange was to understand what the concern was.

Regards,
S. Moonesamy

---

From: Keith Moore <[email-masked]>
Date: Sun, 31 Oct 2021 05:09:19 -0400

On 10/31/21 4:37 AM, S Moonesamy wrote:

> on feedback.  I verified whether the change was in accordance with the 
> "process" documents.
>
The text is old, but the problems with the old text became more evident 
relatively recently.
> The IETF mailing list is no longer the marketplace of the IETF.  It 

I respectfully disagree that the ietf list weakens the IETF.   I think 
the IETF is much weaker now, much less able to address the real needs of 
the Internet community.

> are also changes outside the IETF which influence those values.

I agree with this much.   But we have now become so fragmented that it's 
hard for us to discover new shared values or evolve the old ones.   I 
used to call this the Tower of Babel effect, but it's much worse now 
than it was when I first saw it happening in the late 1990s.

Instead a poor substitute for values are imposed from above or by 
external forces, neither of which serves the Internet user community.

How can we move IETF forward so that it can actually become more 
inclusive rather than less, better able to consider diverse inputs than 
it is now?   I'm pretty sure that efforts to marginalize "different" 
participants won't serve this purpose.

Keith

---

From: Lloyd W <[email-masked]>
Date: Sun, 31 Oct 2021 21:07:31 +1100

> On 31 Oct 2021, at 20:10, Keith Moore <[email-masked]> wrote:
> 
>   But we have now become so fragmented that it's hard for us to discover new shared values or evolve the old ones.   I used to call this the Tower of Babel effect, but it's much worse now than it was when I first saw it happening in the late 1990s

You have an open git issue on a document, you can work on and resolve it without having to interact with anyone who might decrease your productivity.

Get with the program.

L.

---

From: Keith Moore <[email-masked]>
Date: Sun, 31 Oct 2021 06:12:41 -0400

Sent from my iPhone

> On Oct 31, 2021, at 6:07 AM, Lloyd W <[email-masked]> wrote:
> 
> 

I don’t understand what you are trying to say.

---

From: Lloyd W <[email-masked]>
Date: Sun, 31 Oct 2021 21:25:43 +1100

> On 31 Oct 2021, at 21:12, Keith Moore <[email-masked]> wrote:
> 

it's an observation on where any IETF list discussion is headed, reinforcing your comment. For example: 

"I think there's a problem in the design described by this document..."

"well, if you have a real issue open a git issue on the document repository. we're not going to discuss technical document issues on this list."

...alluded to in a couple of git-related drafts I wrote.

it's not just siloed in mailing lists, but discussion is now fragmented across document repositories and issue trackers.

that system has no use for generalists or for cross-pollination of ideas.

L.

---

From: Keith Moore <[email-masked]>
Date: Sun, 31 Oct 2021 11:08:07 -0400

> 3 : not conducive to civic harmony and welfare

This seems like a potential improvement to me.   I don't think it has as 
much baggage as [un]professional has.  Offhand, I can't think of a kind 
of constructive input that cannot be expressed in a civil manner.   I 
wonder how well it translates to various languages and cultures?

Keith

---

From: Miles Fidelman <[email-masked]>
Date: Sun, 31 Oct 2021 11:18:31 -0400

Re. "professional behavior"

I've always interpreted that as denoting actually being knowledgeable 
about that which you speak, exercising a measure of judgement & 
restraint, and adhering to a code of professional ethics & decorum.

It's what we expect of our doctors, lawyers, and... ENGINEERS.  It is an 
ENGINEERING Task Force, after all.  And I would hope that most of us 
here are actually engineers, with some reasonable level of engineering 
knowledge, experience, and professionalism.

Miles Fidelman

-- 
In theory, there is no difference between theory and practice.
In practice, there is.  .... Yogi Berra

Theory is when you know everything but nothing works.
Practice is when everything works but no one knows why.
In our lab, theory and practice are combined:
nothing works and no one knows why.  ... unknown

---

From: S Moonesamy <[email-masked]>
Date: Sun, 31 Oct 2021 09:53:32 -0700

Hi Keith,
At 02:09 AM 31-10-2021, Keith Moore wrote:
>I respectfully disagree that the ietf list weakens the IETF.   I 
>think the IETF is much weaker now, much less able to address the 
>real needs of the Internet community.

What I meant was that not having the venue weakens the IETF.

>I agree with this much.   But we have now become so fragmented that 
>it's hard for us to discover new shared values or evolve the old 
>ones.   I used to call this the Tower of Babel effect, but it's much 
>worse now than it was when I first saw it happening in the late 1990s.
>
>inclusive rather than less, better able to consider diverse inputs 
>than it is now?   I'm pretty sure that efforts to marginalize 
>"different" participants won't serve this purpose.

The following is an IESG task from 2019:

        [removed] to work on some mechanism to obtain wider or private
        feedback from people who are disenfranchised; anonymous flagging
        of offensive emails to inform  leadership; more opportunities for
        private feedback.

There wasn't any action on that (from what I remember).

The issues which you mentioned require a lot of effort to resolve, if 
that is even possible.  The persons doing that would need to get 
community buy-in.

Regards,
S. Moonesamy

---

From: Keith Moore <[email-masked]>
Date: Sun, 31 Oct 2021 13:45:23 -0400

On 10/31/21 11:18 AM, Miles Fidelman wrote:

> It's what we expect of our doctors, lawyers, and... ENGINEERS.  It is 
> an ENGINEERING Task Force, after all.  And I would hope that most of 
> us here are actually engineers, with some reasonable level of 
> engineering knowledge, experience, and professionalism. 

Lately I've been asking myself how I would define "professional" in an 
IETF context.  What I've come up with so far is (no particular order):

1. Be competent and well-prepared.
2. Let people with appointed roles do their jobs.  It's okay to publicly 
and respectfully object when you believe they've not done their jobs 
properly, and there are various remedies like appeals that can also be 
used.   But it's not ok to try to prevent them from doing their jobs.
3. Follow the Guidelines For Conduct.
4. Treat fellow participants as equals in technical discussions (while 
respecting any appointed roles they have in IETF), regardless of their 
day jobs (or lack thereof) or who they work for.
5. Whatever you’re working on, try to help build consensus or craft or 
find a compromise that can attract broad support.  Again you’re free to 
withhold support or to point out problems with a proposal, you’re free 
to offer alternative proposals, and/or to appeal formal decisions, but 
not to obstruct discussion. State/log your objections and move on (But 
you should have a reasonable expectation that such objections will not 
be forgotten and be reviewed again at last call time).

As for ethics, I'm reminded that when I earned an engineering degree I 
was encouraged to take a solemn oath to always act with regard for 
public safety.   In the Internet context I might argue that there's a 
duty to act with regard for the security and privacy needs of the public.

Keith

---

From: S Moonesamy <[email-masked]>
Date: Sun, 31 Oct 2021 10:48:39 -0700

Hi Lloyd,
>Translate has an edge over Yandex, btw.)

Yes (about the translation service).

>of our employers, why are we even here?

It is a balance of interests.  The standards development activity 
should not be dominated by a small group of persons (or companies).

People are here for different reasons.  I found the cross-pollination 
interesting.  It was also useful to know which specifications to avoid.

Regards,
S. Moonesamy

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 1 Nov 2021 08:34:10 +1300

Keith,

I repeat my suggestion that s/unprofessional/uncivil/ would fix the document under discussion.

Apart from that, I think your points are valid. I'd like to point to ISOC's take on this:
https://www.internetsociety.org/become-a-member/code-of-conduct-jan-2003/
which was based on similar documents for traditional engineering institutions.

[Disclaimer: I originally drafted the ISOC document.]

Regards
    Brian

---

From: Keith Moore <[email-masked]>
Date: Sun, 31 Oct 2021 17:12:23 -0400

> document under discussion. 

Perhaps it would.   And all other things being equal, a simpler fix is 
attractive.  But I don't know why others seem to insist on "professional".

Keith

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 31 Oct 2021 21:17:11 +0000

Hiya,

> I repeat my suggestion that s/unprofessional/uncivil/ would fix the document under discussion. 

I definitely prefer civil.

Cheers,
S.

---

From: David Farmer <[email-masked]>
Date: Sun, 31 Oct 2021 17:03:32 -0500

> attractive.  But I don't know why others seem to insist on "professional".

In the context of the document under discussion, I think “uncivil” is what
is needed and might translate better to other languages and societies.

In my opinion, “professional” includes technical and ethical context that
are unnecessary for particular usage. That is, any kind of “uncivil commentary,
regardless of the general subject” is inappropriate on the IETF mailing
list.

Nevertheless, of course IETF participants should act in a
professional manner, but that isn’t the issue for that bullet.

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: Andrew Campling <[email-masked]>
Date: Sun, 31 Oct 2021 22:19:07 +0000

On 10/31/21 17:45, Keith Moore <[email-masked]> wrote:

> Lately I've been asking myself how I would define "professional" in an IETF context.  What I've come up with so far is (no particular order):
> 
> 2. Let people with appointed roles do their jobs.  It's okay to publicly and respectfully object when you believe they've not done their jobs properly, and there are various remedies like appeals that can also be used.   But it's not ok to try to prevent them from doing their jobs.
> 4. Treat fellow participants as equals in technical discussions (while respecting any appointed roles they have in IETF), regardless of their day jobs (or lack thereof) or who they work for.
> 5. Whatever you’re working on, try to help build consensus or craft or find a compromise that can attract broad support.  Again you’re free to withhold support or to point out problems with a proposal, you’re free to offer alternative proposals, and/or to appeal formal decisions, but not to obstruct discussion. State/log your objections and move on (But you should have a reasonable expectation that such objections will not be forgotten and be reviewed again at last call time).

These points seem like a helpful way to expand on "civil", using that as a better option than "professional" - you could add "be kind" as a sixth point.

> As for ethics, I'm reminded that when I earned an engineering degree I was encouraged to take a solemn oath to always act with regard for public safety.   In the Internet context I might argue that there's a duty to act with regard for the security and privacy needs of the public.

A reference to RFC 8890, the Internet is for End Users, never goes amiss, especially with its comments about multistakeholder engagement etc.  IMHO end users seem to be absent from many (most?) discussions; their needs and the impact on them of any proposals ought to be a required section in Internet Drafts and given as much attention as, for example, security considerations.

Andrew

---

From: Keith Moore <[email-masked]>
Date: Sun, 31 Oct 2021 19:00:15 -0400

+1

---

From: Jay Daley <[email-masked]>
Date: Mon, 1 Nov 2021 12:25:05 +1300

> On 31/10/2021, at 11:31 AM, Keith Moore <[email-masked]> wrote:
> 

While I understand the allure of conspiracy theories, it is far more straightforward and far more accurate to assume that those insisting on "professional behaviour" are simply looking to exclude "unprofessional behaviour" wherever that is found, with no ulterior motive.

> Anyway, if "unprofessional behavior" is not defined, those in power can use any deviation from "normal" as an excuse to sanction participants.

And the same lack of definition allows those not in power to claim that they were not behaving unprofessionally and any sanctions against them were therefore an abuse of power.

FWIW I like the list you posted in an attempt to define professional, though I personally would add a lot more to it.

Jay
> 
> 
> But I also realize that maybe this doesn't matter much, as the scope of this document is limited to the IETF list which is of decreasing relevance anyway.   The IETF list used to serve as the primary forum of the community, its center, and also its conscience.   This draft along with several other IMO extremely harmful measures that have been taken in recent years (including the creation of gendispatch) narrows the scope of the IETF list so much that it effectively destroys most of the utility that the IETF list used to have, and with it the organization's core values.
> 
> I don't know why people think that the solution to traffic overload is to keep siloing discussions ad infinitum, and I would argue that one of IETF's core problems has long been the over-fragmentation of discussions.
> 
> Or maybe the fragmentation of the IETF list was part of a deliberate effort to subvert the IETF into being a forum that only serves the Internet industry, rather than one trying to serve the broader Internet community?
> 
>> 
>> The underlying value for some participants is most likely related to https://www.uscourts.gov/about-federal-courts/educational-resources/about-educational-outreach/activity-resources/what-does <https://www.uscourts.gov/about-federal-courts/educational-resources/about-educational-outreach/activity-resources/what-does> A participant residing in another country might not have the background information to understand those participants.  It takes many years to understand all that.
> 
> These rules don't really apply to discussions like the IETF list, even in the United States.   Governments within the US are forbidden from penalizing most kinds of speech.   But those restrictions on government don't prevent the moderation of discussions hosted by non-governmental organizations such as IETF, or for that matter discussions on social media sites.
> 
> But it may well be true that US citizens and longtime US residents, accustomed to having few government prohibitions on speech, are somewhat more outspoken than those from elsewhere.
> 
> Keith

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Stephen Farrell <[email-masked]>
Date: Sun, 31 Oct 2021 23:34:45 +0000

Hiya,

On 31/10/2021 23:25, Jay Daley wrote:
> 
>> On 31/10/2021, at 11:31 AM, Keith Moore<[email-masked]>
>> wrote:
>> 

> While I understand the allure of conspiracy theories, it is far more
> straightforward and far more accurate to assume that those insisting
> on "professional behaviour" are simply looking to exclude
> "unprofessional behaviour" wherever that is found, with no ulterior
> motive.

I don't think there's any necessity here to impugn someone as
finding conspiracy theories alluring.

These things change over time and in different locales. At
this time, ISTM there are some corporate HR regimes that are
both a vast improvement over what was seen a decade or two
ago, and yet at the same time, can be validly criticised as
being hugely hypocritical. My impression is that Keith is
more making the point that "professional" in such a context
is problematic. (A point with which I agree btw.)

Cheers,
S.