Subject: Re: draft-ietf-krb-wg-anon-03 review

From: "Shawn M. Emery" <[email-masked]>
Date: Tue, 24 Jul 2007 22:28:49 -0600

My concerns were addressed in 04.  So I think the only thing left out 
was the ret_flags check suggestion that I had made, but that was really 
just a nit.

Shawn.
--
Shawn M Emery wrote:

 > Here is my review of draft-ietf-krb-wg-anon-03:
 >
 > 3. Definitions
 > The name-type field is incorrectly specified for principals, this 
should be
 > KRB_NT_WELLKNOWN, not KRB_NT_RESRVED.
 >
 > 4. Protocol Description
 > The segment starting with "and this rule MUST..." should be a 
separate sentence and reworded for
 > readability purposes.
 >
 > For this concept:
 > "A server accepting an anonymous service ticket may assume that 
subsequent requests using the
 > same ticket originate from the same client."
 >
 > could be a bad assumption, since you would be dependent on other 
information, such as a time
 > stamp.  When spread across multiple machines and users this could be 
a larger assumption than
 > normal.
 >
 > You should mention that applications can detect if anonymity is 
supported by the mechanism by
 > checking the GSS-API's ret_flags.
 >
 > Shawn.
 > --

---

From: Larry Zhu <[email-masked]>
Date: Wed, 25 Jul 2007 08:45:31 -0700

> was the ret_flags check suggestion that I had made, but that was
really 

Section 5 has the following text:

  A GSS-API initiator MUST carefully check the resulting context
   attributes from the initial call to GSS_Init_Sec_Context() when
  requesting anonymity

in my opinion it is sufficiently explicit here. I can explicitly list
the flag 
if another revision is needed. Thanks,

--larry

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Shawn M. Emery
Sent: Tuesday, July 24, 2007 9:29 PM
To: [email-masked]
Subject: Re: draft-ietf-krb-wg-anon-03 review

Shawn.
--

should be
a larger assumption than