Subject: VPLS MAC Withdrawal Optimization draft

From: "LASSERRE, Marc \(Marc\)" <[email-masked]>
Date: Thu, 27 Mar 2008 13:53:07 +0100

In the last l2vpn WG session in Philadelphia, we presented an update of
http://tools.ietf.org/html/draft-pdutta-l2vpn-vpls-ldp-mac-opt-03

This draft describes an optional VPLS MAC flush extension by adding a
PE-ID TLV. This TLV defines which MAC addresses need to be flushed: All
MACs that have been learned from the specified PE need to be flushed.

This mechanism is independent of specific hardware capabilities (e.g.
hardware assisted learning) or specific L2 protocols used by CEs (which
could be different at ingress and egress points).  It can be used with
existing H-VPLS implementations/deployments and is orthogonal to various
MAC scaling mechanisms.  

The benefits are that such a mechanism minimizes the overhead of
topology changes (e.g. in terms of flooding vs unicasting, FIB
maintenance).

We would like to request feedback from the WG about the acceptance of
this draft as a WG document.

Pranjal & Marc

---

From: Olen Stokes <[email-masked]>
Date: Thu, 27 Mar 2008 06:02:35 -0700

I strongly support this draft becoming a WG document.

Olen

From: [email-masked] [mailto:[email-masked]] On Behalf Of LASSERRE, Marc (Marc)
Sent: Thursday, March 27, 2008 8:53 AM
To: [email-masked]
Subject: VPLS MAC Withdrawal Optimization draft

In the last l2vpn WG session in Philadelphia, we presented an update of http://tools.ietf.org/html/draft-pdutta-l2vpn-vpls-ldp-mac-opt-03

This draft describes an optional VPLS MAC flush extension by adding a PE-ID TLV. This TLV defines which MAC addresses need to be flushed: All MACs that have been learned from the specified PE need to be flushed.

This mechanism is independent of specific hardware capabilities (e.g. hardware assisted learning) or specific L2 protocols used by CEs (which could be different at ingress and egress points).  It can be used with existing H-VPLS implementations/deployments and is orthogonal to various MAC scaling mechanisms.

The benefits are that such a mechanism minimizes the overhead of topology changes (e.g. in terms of flooding vs unicasting, FIB maintenance).

We would like to request feedback from the WG about the acceptance of this draft as a WG document.

Pranjal & Marc

---

From: "BOCCI Matthew" <[email-masked]>
Date: Thu, 27 Mar 2008 14:05:50 +0100

I support this.
 
Matthew

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of LASSERRE Marc
	Sent: 27 March 2008 12:53
	To: [email-masked]
	Subject: VPLS MAC Withdrawal Optimization draft

	In the last l2vpn WG session in Philadelphia, we presented an
update of
http://tools.ietf.org/html/draft-pdutta-l2vpn-vpls-ldp-mac-opt-03

	This draft describes an optional VPLS MAC flush extension by
adding a PE-ID TLV. This TLV defines which MAC addresses need to be
flushed: All MACs that have been learned from the specified PE need to
be flushed.

	This mechanism is independent of specific hardware capabilities
(e.g. hardware assisted learning) or specific L2 protocols used by CEs
(which could be different at ingress and egress points).  It can be used
with existing H-VPLS implementations/deployments and is orthogonal to
various MAC scaling mechanisms.  

	We would like to request feedback from the WG about the
acceptance of this draft as a WG document.

	Pranjal & Marc

---

From: "PAPADIMITRIOU Dimitri" <[email-masked]>
Date: Thu, 27 Mar 2008 15:31:51 +0100

I support making this i-d a WG document.

thanks,
-d.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of LASSERRE Marc
> Sent: Thursday, March 27, 2008 1:53 PM
> To: [email-masked]
> adding a PE-ID TLV. This TLV defines which MAC addresses need 
> to be flushed: All MACs that have been learned from the 
> specified PE need to be flushed.
> 
>  
> 
> This mechanism is independent of specific hardware 
> capabilities (e.g. hardware assisted learning) or specific L2 
> protocols used by CEs (which could be different at ingress 
> and egress points).  It can be used with existing H-VPLS 
> implementations/deployments and is orthogonal to various MAC 
> scaling mechanisms.  
> 
>  
> 
> The benefits are that such a mechanism minimizes the overhead 
> of topology changes (e.g. in terms of flooding vs unicasting, 
> FIB maintenance).
> 
>  
>

---

From: "Mallette, Edwin" <[email-masked]>
Date: Thu, 27 Mar 2008 10:37:30 -0400

I support this work.

Pranjal & Marc

________________________________
CONFIDENTIALITY NOTICE: This e-mail may contain information that is privileged, confidential or otherwise protected from disclosure. If you are not the intended recipient of this e-mail, please notify the sender immediately by return e-mail, purge it and do not disseminate or copy it.

---

From: "Dutta, Pranjal K \(Pranjal\)" <[email-masked]>
Date: Thu, 27 Mar 2008 20:20:44 +0530

Support for WG status.
 
Thanks,
Pranjal

From: [email-masked] [mailto:[email-masked]] On Behalf
Of LASSERRE, Marc (Marc)
Sent: Thursday, March 27, 2008 5:53 AM
To: [email-masked]
Subject: VPLS MAC Withdrawal Optimization draft

Pranjal & Marc

---

From: Prashant Desai <[email-masked]>
Date: Thu, 27 Mar 2008 10:51:07 -0400

support

Pranjal & Marc

---

From: "BALUS Florin" <[email-masked]>
Date: Thu, 27 Mar 2008 12:22:52 -0500

Strongly support this draft to become Working Group draft.

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of LASSERRE, Marc (Marc)
	Sent: Thursday, March 27, 2008 5:53 AM
	To: [email-masked]
	Subject: VPLS MAC Withdrawal Optimization draft

	Pranjal & Marc

---

From: <[email-masked]>
Date: Thu, 27 Mar 2008 17:33:03 +0100

Hi,
I support the draft becoming a WG doc
-Fred  

De : [email-masked] [mailto:[email-masked]] De la part de LASSERRE, Marc (Marc)
Envoyé : jeudi 27 mars 2008 13:53
À : [email-masked]
Objet : VPLS MAC Withdrawal Optimization draft

Pranjal & Marc

---

From: <[email-masked]>
Date: Fri, 28 Mar 2008 11:35:39 +0100

Hi,
-fred

Pranjal & Marc

---

From: "HEMIGE Venu" <[email-masked]>
Date: Sun, 30 Mar 2008 00:33:36 -0500

Support the draft.

	Pranjal & Marc