Subject: RE: AW: AW: [Nsis-imp] Call for GIMPS testing at 62nd IETF

From: "Hancock, Robert" <[email-masked]>
Date: Thu, 10 Feb 2005 12:01:57 -0000

hi,

we would be interested in exchanging packets at
#62. (of course, we will have to decide whether
it's against the -04 version or the -05 version,
which doesn't quite exist yet. the former is
more likely.)

as an aside, we also developed our own state
machines to accompany the implementation (and
also to help me think about the spec.) while
we tried to follow the style/notation of the
Fu documents, the actual structure we have
ended up with is quite different. we'll try to
publish the state machine results before 
minneapolis, although whether they will make it
into any I-D is less clear.

robert h. 

> -----Original Message-----
> From: Martin Stiemerling [mailto:[email-masked]] 
> Sent: 09 February 2005 19:49
> To: Tschofenig Hannes; [email-masked]
> Subject: Re: AW: AW: [Nsis-imp] Call for GIMPS testing at 62nd IETF
> 
> 
> 
> 
> --On Mittwoch, 9. Februar 2005 19:55 Uhr +0100 Tschofenig Hannes 
> <[email-masked]> wrote:
> 
> | hi martin,
> |
> | interesting view. when we worked on eap and eap methods 
> | implementations the existence of state machine helped us a lot to 
> | produce interoperable code in a very short amount of time.
> |
> | i think that this would be helpful for nsis as well if we work on a 
> | state maschine which allows people to interoperable implement nsis 
> | quickly.
> 
> True, but it is helpful to start developing your own state 
> machine first. This covers up ambiguities in the spec better, 
> since you can compare how people interpret the same text in 
> different ways and so refine the text plus eliminate the ambiguities.
> 
>   Martin
> 
> 
> 
> 
> _______________________________________________
> NSIS-imp mailing list
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/nsis-imp
> 

_______________________________________________
NSIS-imp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis-imp

---

From: Martin Stiemerling <[email-masked]>
Date: Mon, 14 Feb 2005 14:53:23 +0100

Hi Robert,

--On Donnerstag, 10. Februar 2005 12:01 Uhr +0000 "Hancock, Robert" 
<[email-masked]> wrote:

| hi,
|
| we would be interested in exchanging packets at
|# 62. (of course, we will have to decide whether
| it's against the -04 version or the -05 version,
| which doesn't quite exist yet. the former is
| more likely.)

I think it is better to take -04 version for the testing.

|
| as an aside, we also developed our own state
| machines to accompany the implementation (and
| also to help me think about the spec.) while
| we tried to follow the style/notation of the
| Fu documents, the actual structure we have
| ended up with is quite different. we'll try to

That is what have expected (and my reasoning in my
emails).  When two people read the draft they are
most likely to draw two different state machines.

  Martin

| publish the state machine results before
| minneapolis, although whether they will make it
| into any I-D is less clear.
|
| robert h.
|
|
|
|> -----Original Message-----
|> From: Martin Stiemerling [mailto:[email-masked]]
|> Sent: 09 February 2005 19:49
|> To: Tschofenig Hannes; [email-masked]
|> Subject: Re: AW: AW: [Nsis-imp] Call for GIMPS testing at 62nd IETF
|>
|>
|>
|>
|> --On Mittwoch, 9. Februar 2005 19:55 Uhr +0100 Tschofenig Hannes
|> <[email-masked]> wrote:
|>
|> | hi martin,
|> |
|> | interesting view. when we worked on eap and eap methods
|> | implementations the existence of state machine helped us a lot to
|> | produce interoperable code in a very short amount of time.
|> |
|> | i think that this would be helpful for nsis as well if we work on a
|> | state maschine which allows people to interoperable implement nsis
|> | quickly.
|>
|> True, but it is helpful to start developing your own state
|> machine first. This covers up ambiguities in the spec better,
|> since you can compare how people interpret the same text in
|> different ways and so refine the text plus eliminate the ambiguities.
|>
|>   Martin
|>
|>
|>
|>
|> _______________________________________________
|> NSIS-imp mailing list
|> [email-masked]
|> https://www1.ietf.org/mailman/listinfo/nsis-imp
|>
|
| --
|
| Visit our website at www.roke.co.uk
|
| Roke Manor Research Ltd, Roke Manor, Romsey, Hampshire SO51 0ZN, UK.
|
| The information contained in this e-mail and any attachments is
| proprietary to Roke Manor Research Ltd and must not be passed to any
| third party without permission. This communication is for information
| only and shall not create or change any contractual relationship.
|