Subject: AW: AW: [Nsis-imp] Call for GIMPS testing at 62nd IETF

From: Tschofenig Hannes <[email-masked]>
Date: Wed, 9 Feb 2005 19:55:32 +0100

hi martin, 

interesting view. when we worked on eap and eap methods implementations the
existence of state machine helped us a lot to produce interoperable code in
a very short amount of time. 

i think that this would be helpful for nsis as well if we work on a state
maschine which allows people to interoperable implement nsis quickly. 

ciao
hannes

> -----Ursprüngliche Nachricht-----
> Von: Martin Stiemerling [mailto:[email-masked]] 
> Gesendet: Mittwoch, 9. Februar 2005 19:37
> An: Tschofenig Hannes; [email-masked]
> Betreff: Re: AW: [Nsis-imp] Call for GIMPS testing at 62nd IETF
> 
> 
> 
> 
> --On Dienstag, 8. Februar 2005 16:48 Uhr +0100 Tschofenig Hannes 
> <[email-masked]> wrote:
> 
> | hi martin,
> |
> | since you are working on the gimps implementation i would 
> like to know
> | whether you have looked at the gimps state maschine document?
> 
> Not yet and I probably won't do.  Our implementation (and thus state
> machines too) should be independent.  That's good for several reasons:
> 
> - Total different people with different mindset implementing the
>   same thing, giving a better chance to prove the specification
> - Implementation independence, needed to get a standard document
> 
>   Martin
> 
> 
> |
> | ciao
> | hannes
> |
> |
> |> -----Ursprüngliche Nachricht-----
> |> Von: Martin Stiemerling [mailto:[email-masked]]
> |> Gesendet: Dienstag, 8. Februar 2005 16:19
> |> An: [email-masked]
> |> Betreff: [Nsis-imp] Call for GIMPS testing at 62nd IETF
> |>
> |>
> |> Dear NSIS Implementors,
> |>
> |> I'm currently working on a GIMPS implementation and I'm probably
> |> ready to send some GIMPS packets out of my implementations
> |> at the next IETF in Minneapolis.  Anybody interested in
> |> doing a little bit of testing?
> |>
> |> With best regards,
> |>
> |>     Martin Stiemerling
> |>
> |> NEC Europe Ltd. -- Network Laboratories [email-masked]
> |> PGP Key at:        http://www.stiemerling.org/stiemerling_nec.gpg
> |> WWW: http://www.netlab.nec.de
> |>
> |> _______________________________________________
> |> NSIS-imp mailing list
> |> [email-masked]
> |> https://www1.ietf.org/mailman/listinfo/nsis-imp
> |>
> 
> 

_______________________________________________
NSIS-imp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis-imp

---

From: Martin Stiemerling <[email-masked]>
Date: Wed, 09 Feb 2005 20:48:50 +0100

--On Mittwoch, 9. Februar 2005 19:55 Uhr +0100 Tschofenig Hannes 
<[email-masked]> wrote:

| hi martin,
|
| interesting view. when we worked on eap and eap methods implementations
| the existence of state machine helped us a lot to produce interoperable
| code in a very short amount of time.
|
| i think that this would be helpful for nsis as well if we work on a state
| maschine which allows people to interoperable implement nsis quickly.

True, but it is helpful to start developing your own state machine first.
This covers up ambiguities in the spec better, since you can compare
how people interpret the same text in different ways and so refine
the text plus eliminate the ambiguities.

  Martin