Subject: [regext] FW: New Version Notification for draft-gould-regext-rdap-redacted-00.txt

From: "Gould, James" <[email-masked]>
Date: Mon, 12 Jul 2021 11:02:44 +0000

The "Redacted Fields in the Registration Data Access Protocol (RDAP) Response" draft-gould-regext-rdap-redacted has been published.  The goal of the draft is to describe an RDAP extension for explicitly identifying redacted RDAP response fields, using JSONPath as the default expression language.  Any review and feedback is welcome.

Thanks,

-- 
 
JG

James Gould
Fellow Engineer
[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com <http://verisigninc.com/>

On 7/12/21, 6:47 AM, "[email-masked]" <[email-masked]> wrote:

    A new version of I-D, draft-gould-regext-rdap-redacted-00.txt
    has been successfully submitted by James Gould and posted to the
    IETF repository.

    Name:		draft-gould-regext-rdap-redacted
    Revision:	00
    Title:		Redacted Fields in the Registration Data Access Protocol (RDAP) Response
    Document date:	2021-07-12
    Group:		Individual Submission
    Pages:		24
    URL:            https://www.ietf.org/archive/id/draft-gould-regext-rdap-redacted-00.txt
    Status:         https://datatracker.ietf.org/doc/draft-gould-regext-rdap-redacted
    Html:           https://www.ietf.org/archive/id/draft-gould-regext-rdap-redacted-00.html
    Htmlized:       https://datatracker.ietf.org/doc/html/draft-gould-regext-rdap-redacted

    Abstract:
       This document describes an RDAP extension for explicitly identifying
       redacted RDAP response fields, using JSONPath as the default
       expression language.

    The IETF Secretariat

---

From: Marc Blanchet <[email-masked]>
Date: Mon, 12 Jul 2021 07:15:27 -0400

Just read it. Goooood. We need it. (Specially with my hat of RDAP client app). 

Some early comments:
- would be good to include specific text about jscontact, so when we switch to it, this document does not need rev.
- I really would like to have an IANA registry for the « reason » property. Because this would be potentially displayed to the user, and to avoid having all variations of the same reason in different words. A registry of reserved words would also facilitate translation in multiple languages.

Really would like this document to move forward. As RDAP client implementor, I would like to implement it. If some servers are already implementing it, please contact me directly so we can do some interop testing.

Marc.

> Le 12 juill. 2021 à 07:02, Gould, James <jgould=[email-masked]> a écrit :
> 
> _______________________________________________
> regext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/regext