Subject: Re: [regext] New Version Notification for draft-gould-regext-rdap-redacted-00.txt

From: "Gould, James" <[email-masked]>
Date: Mon, 12 Jul 2021 11:26:19 +0000

Marc,

Thank you for the quick review and feedback.  Below are responses to your early comments:

    - would be good to include specific text about jscontact, so when we switch to it, this document does not need rev.

Agreed, that was thought about while drafting, but we initially left it out.  I'm confident that the extension will work with JSContact, but some text would help for clarity.  

    - I really would like to have an IANA registry for the « reason » property. Because this would be potentially displayed to the user, and to avoid having all variations of the same reason in different words. A registry of reserved words would also facilitate translation in multiple languages.

We had a desire to stay away from needing to setup an IANA registry for redaction.  I view the reason property as not a good candidate for an IANA registry, since it's meant to be a human readable informational value that includes normative language not to be used as a client processing dependency.  This is a good discussion item.  

Thanks, 

-- 
 
JG

James Gould
Fellow Engineer
[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com <http://verisigninc.com/>

On 7/12/21, 7:15 AM, "Marc Blanchet" <[email-masked]> wrote:

    Just read it. Goooood. We need it. (Specially with my hat of RDAP client app). 

    Some early comments:
    - would be good to include specific text about jscontact, so when we switch to it, this document does not need rev.
    - I really would like to have an IANA registry for the « reason » property. Because this would be potentially displayed to the user, and to avoid having all variations of the same reason in different words. A registry of reserved words would also facilitate translation in multiple languages.

    Really would like this document to move forward. As RDAP client implementor, I would like to implement it. If some servers are already implementing it, please contact me directly so we can do some interop testing.

    Marc.

    > Le 12 juill. 2021 à 07:02, Gould, James <jgould=[email-masked]> a écrit :
    > 
    > The "Redacted Fields in the Registration Data Access Protocol (RDAP) Response" draft-gould-regext-rdap-redacted has been published.  The goal of the draft is to describe an RDAP extension for explicitly identifying redacted RDAP response fields, using JSONPath as the default expression language.  Any review and feedback is welcome.
    > 
    > Thanks,
    > 
    > -- 
    > 
    > JG
    > 
    > 
    > 
    > James Gould
    > Fellow Engineer
    > [email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>
    > 
    > 703-948-3271
    > 12061 Bluemont Way
    > Reston, VA 20190
    > 
    > Verisign.com <http://secure-web.cisco.com/1mjljSszRHMWBBWiVRrUMrhOUeWm_mQQZEornOV0IrqHX9vEnx-RCoWBk3Zda8WqCNRU2NgrG-u3RKtOxjaTIW2NQLrnU8qmJM0TdYVjnXN4tq91ifewAp8_CuiyCLw6D7pv86v_tMUzLbq-kK-UEKMjw1YjiruuDEgLNYp1REtcP41bcKqFQ78Vfk0NDCZffn1KMxVw3qsSCX0lghUob_fR3sL9B3rSsac77K29Rvaq_6-YuWGw8mpL_8Gsf5msC/http%3A%2F%2Fverisigninc.com%2F>
    > 
    > On 7/12/21, 6:47 AM, "[email-masked]" <[email-masked]> wrote:
    > 
    >    A new version of I-D, draft-gould-regext-rdap-redacted-00.txt
    >    has been successfully submitted by James Gould and posted to the
    >    IETF repository.
    > 
    >    Name:		draft-gould-regext-rdap-redacted
    >    Revision:	00
    >    Title:		Redacted Fields in the Registration Data Access Protocol (RDAP) Response
    >    Document date:	2021-07-12
    >    Group:		Individual Submission
    >    Pages:		24
    >    URL:            https://secure-web.cisco.com/1K328CySVpeAdQz8KNkRu7ncZhdPUaP8fTNul1LMbiFUNsZqIiaoBcPF_OjIj35fkwT9gDpIgI0UtjP0gvmatvP7d36VCx0jJYMqBEmzxelQ-PIg05Xfql3NqrTwSL4Q0rFMFYnngRChk0aHwtRt906uYqS23NjDteP_jrqxZQGqLQKBOv5Vgb43XRE8Ihgi27Ri4OozGV8C0GXEqGrZ7b95LpT-V-dDS3cIXEQUtIo-eTKJ-ZWGQKtVrYCNA9LBg/https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-gould-regext-rdap-redacted-00.txt
    >    Status:         https://secure-web.cisco.com/1XGKSPZDnB5CHFRYeBm5qN0ACnFvTe1ZG2O2llFvSrZi7q2nOKGpyNnv6E_m3_MO7ccF7VFbViZPAwR4-AhBS-dsgLlgR1UWs2nad61Rru2hB4B4t9trR3YvtBbMbIodX7jHHjrS9fI-dpAMLzEEana8BOyRiZ39Ri-bvZ5UE_IFT9l3WqspNfRqWS9oSUFqY-vVM_ewYcTLOwSxMvY7FXlWt6BqjHa2qdBNgIIZeu7bRKJ5BQ06B4AIe9y0IyRKd/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-gould-regext-rdap-redacted
    >    Html:           https://secure-web.cisco.com/1B_5eD2QiPrj83T06F7L4QtU3TiyBUmvF_j2dCXin9B7g8aMHESwA458zvkfsNCSZ3H37ObhlCl4HDgTiq7FCk0m7tAWuFQNAMEz0gzbNML-5hfGMJS-SZMuc6OuAnS8mkBUX_yXOBGkWsB1aiFk9UNolX6_o5zxWepxXz9nn-00BrxxTi1kyaRTiPZNpjLbdBMA2T4pNfhbpIfvRnlq-ewNw77MmMocKIy0Out4Cqwdx_6T6yGu-QwVjoPehH4Pt/https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-gould-regext-rdap-redacted-00.html
    >    Htmlized:       https://secure-web.cisco.com/1p7JRanlgcayeNYcfSxig8HPTMLyO10UtuXnj8prHHxr5LSwZTK_a-LVs8jabLArSP8K_rmlxZ1UXoHYVMmGFjCculzG_bqoCTMIdWMI3hZ2nNAgnlOeQ9Py-vf3Jw_R533LAJqInMLvnEvhSaQlcJWdR7ttfJNgVhe04-dcLQt5GX8eCG-_W4P8LLeD1v8jcEH0CxWlSoiZ1Mfo-4sI5sOAnym_uiUApuKbmHO5njJY85ABtWiPCmHlxlVZghFOL/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-gould-regext-rdap-redacted
    > 
    > 
    >    Abstract:
    >       This document describes an RDAP extension for explicitly identifying
    >       redacted RDAP response fields, using JSONPath as the default
    >       expression language.
    > 
    > 
    > 
    > 
    >    The IETF Secretariat
    > 
    > 
    > 
    > _______________________________________________
    > regext mailing list
    > [email-masked]
    > https://secure-web.cisco.com/16CgORZ2fFT66iHVzi7kyPw6Mv9G4kbF2Mgjac7T3eRZU23t5cU1UejDzEN_N3uECtWwJmmdzTr2tME-2vLucgYzZURc3yY1pPZhyd2OA6EY1f6pWeTEY0LdnOjA4EUtLZsfr7Smu9GrMZbxiX5T10srKCMu0VsIZMNNswinhqo37gohlXQnOq_S3LmiXJlIt3gFaIYPid2NMKMibEzU_dtV-3t1v4BgghjRXsqsJQlv9cZq6k-Txw_wXVf2ekDS0/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext

---

From: Marc Blanchet <[email-masked]>
Date: Mon, 12 Jul 2021 07:41:02 -0400

> Le 12 juill. 2021 à 07:26, Gould, James <[email-masked]> a écrit :
> 
> 
> We had a desire to stay away from needing to setup an IANA registry for redaction.  I view the reason property as not a good candidate for an IANA registry, since it's meant to be a human readable informational value

Fine but that does not preclude the use of an IANA registry with reserved text. We already have that: https://www.iana.org/assignments/rdap-json-values/rdap-json-values.xhtml <https://www.iana.org/assignments/rdap-json-values/rdap-json-values.xhtml>.   We can even reuse the same registry and add some rows. Client processing, with reserved words, can act upon: displaying nice icons instead of long words for example. It can also be internationalized.  If it is human readable, then that means the server has to send all the languages translations. Not great.   I’m sure that we can standardized those reason values to less than a dozen.

Marc.

> that includes normative language not to be used as a client processing dependency.  This is a good discussion item.  
> 
> Thanks, 
> 
> -- 
> 
> JG
> 
> 
> 
> James Gould
> Fellow Engineer

---

From: Mario Loffredo <[email-masked]>
Date: Wed, 14 Jul 2021 09:57:45 +0200

Hi all,

> Agreed, that was thought about while drafting, but we initially left it out.  I'm confident that the extension will work with JSContact, but some text would help for clarity.

I guess it will work even better than with jCard! JSContact is more 
object-oriented than jCard and the json path expressions are simpler 
since maps are mostly used to represent collections (e.g.

"$.entities[?(@.roles[0]=='registrant')].jscard.phones.voice.phone" 
instead of 
"$.entities[?(@.roles[0]=='registrant')].vcardArray[1][?(@[1].type=='voice')]")

Here in the following a first feedback from my side about the document:

- if, as it seems, the "name" property is unique in the "redacted" 
array, I would prefer to define "redacted" as a map where the "name" 
value is the map key. In theory, every RDAP information can be redacted 
but, in practice, the number of RDAP properties usually redacted is 
limited. If the possible "name" values were standardized, il would be 
easier for RDAP clients implementers to check and pick a property inside 
the collection of redacted properties.

- another possible pre-defined value for "pathLang" might be 
"jsonpointer" as an alternative syntax to indentify a value within a 
JSON doc.

- it seems to me that the document assumes that the role used to 
identify the redacted entity within the array of entities should be in 
the first position of "roles" array. Maybe such assumption should be 
added somewhere in the document.

- there is a typo in the json path expression of  "Registrant Street"

Best,

Mario

-- 
Dr. Mario Loffredo
Technological Unit “Digital Innovation”
Institute of Informatics and Telematics (IIT)
National Research Council (CNR)
via G. Moruzzi 1, I-56124 PISA, Italy
Phone: +39.0503153497
Web: http://www.iit.cnr.it/mario.loffredo

---

From: "Gould, James" <[email-masked]>
Date: Wed, 14 Jul 2021 13:26:11 +0000

Marc,

Precedence has been set in JSON Values Registry of RFC 9083 with the “notice and remark type” to support an enumerated set of notices and remarks with the use of the “type” field.  If a similar approach was taken for the reason in draft-gould-regext-rdap-redacted, the reason member would need to be restructured in a similar fashion to the “notices” and “remarks” in RFC 9083.  Meaning make it a JSON object with a optional “description” member and an optional “type” member, where the “type” member will match the registered type in the JSON Values Registry.  We would then need to add a new JSON Values Registry type for redaction reasons to enable the registration of them.  I recommend adding the JSON Values Registry type “redaction reason” for this purpose.  The optional “reason” member would then look like the following:

# Reason with an unregistered description
"reason" :
{

   “description” : “Client request”

}

# Reason with only a registered type
“reason” :
{

   “type” : “Client request"

}

# Reason with both a registered type and a description
“reason” :
{

   “type” : “Client request"

   “description” : “Client requested to have the field redacted”

}

Does this look consistent with the approach taken in RFC 9083 and address your feedback?

Thanks,

--

JG

James Gould
Fellow Engineer
[email-masked]<applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://verisigninc.com/>

From: Marc Blanchet <[email-masked]>
Date: Monday, July 12, 2021 at 7:41 AM
To: James Gould <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [EXTERNAL] Re: [regext] New Version Notification for draft-gould-regext-rdap-redacted-00.txt

Le 12 juill. 2021 à 07:26, Gould, James <[email-masked]<mailto:[email-masked]>> a écrit :

Fine but that does not preclude the use of an IANA registry with reserved text. We already have that: https://www.iana.org/assignments/rdap-json-values/rdap-json-values.xhtml<https://secure-web.cisco.com/1CpBTBaAbWXShtu3I3CgJpJu24mEs9ljN-JZFzuDsQTI3FxgaWMmOrd_t3tvEV72gkQmb5znPpgnRyT4kmZRJDIqFHqcz9Bbyvg57xwiJfZd-N4xqddAw5eLmk_K28myevtwarkxyyRc3Nrd_Hv17G7Ps-CwKFwcGPyigFJVrP1aZw9RCvarhO-h-GExrL1MsE7pkowpYOR3h_QrlwfnEBqhicohhvS7BpAyyBnWL6VIuEMdEN5HFDNJ_DAAljli3/https%3A%2F%2Fwww.iana.org%2Fassignments%2Frdap-json-values%2Frdap-json-values.xhtml>.   We can even reuse the same registry and add some rows. Client processing, with reserved words, can act upon: displaying nice icons instead of long words for example. It can also be internationalized.  If it is human readable, then that means the server has to send all the languages translations. Not great.   I’m sure that we can standardized those reason values to less than a dozen.

Marc.

Thanks,

--

JG

James Gould
Fellow Engineer
[email-masked]<mailto:[email-masked]> <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://Verisign.com> <http://verisigninc.com/<http://secure-web.cisco.com/1beQfCbdiRGkXWoDIwEZqB-syrWkxKlPLmKXZ5TyPLcyHJefT1L0kWFy55Ogjue3I0e6sl1LZnrl57ZdbPW70plJDkV1TrXSRiOVelUFiAdeskppvN7dLYDFaa0F4fRnqlN0gf6aXzFlIMbtj7PYNnyai6PheZ2iizECnbbRgkFOPor0IF9oPIALohtLm2Ur5hdrKFF3RqLFts6IzaW8svDPPDK_pHe6KQjPjK63W-Cx_D5Xb_GShrkpr4QQRNZyb/http%3A%2F%2Fverisigninc.com%2F>>

On 7/12/21, 7:15 AM, "Marc Blanchet" <[email-masked]<mailto:[email-masked]>> wrote:

   Some early comments:

   Marc.

Le 12 juill. 2021 à 07:02, Gould, James <jgould=[email-masked]<mailto:jgould=[email-masked]>> a écrit :

Thanks,

--

JG

James Gould
Fellow Engineer
[email-masked]<mailto:[email-masked]> <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>

703-948-3271
12061 Bluemont Way
Reston, VA 20190

Verisign.com<http://Verisign.com> <http://secure-web.cisco.com/1mjljSszRHMWBBWiVRrUMrhOUeWm_mQQZEornOV0IrqHX9vEnx-RCoWBk3Zda8WqCNRU2NgrG-u3RKtOxjaTIW2NQLrnU8qmJM0TdYVjnXN4tq91ifewAp8_CuiyCLw6D7pv86v_tMUzLbq-kK-UEKMjw1YjiruuDEgLNYp1REtcP41bcKqFQ78Vfk0NDCZffn1KMxVw3qsSCX0lghUob_fR3sL9B3rSsac77K29Rvaq_6-YuWGw8mpL_8Gsf5msC/http%3A%2F%2Fverisigninc.com%2F>

On 7/12/21, 6:47 AM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

  Abstract:

  The IETF Secretariat

_______________________________________________
regext mailing list
[email-masked]<mailto:[email-masked]>
https://secure-web.cisco.com/16CgORZ2fFT66iHVzi7kyPw6Mv9G4kbF2Mgjac7T3eRZU23t5cU1UejDzEN_N3uECtWwJmmdzTr2tME-2vLucgYzZURc3yY1pPZhyd2OA6EY1f6pWeTEY0LdnOjA4EUtLZsfr7Smu9GrMZbxiX5T10srKCMu0VsIZMNNswinhqo37gohlXQnOq_S3LmiXJlIt3gFaIYPid2NMKMibEzU_dtV-3t1v4BgghjRXsqsJQlv9cZq6k-Txw_wXVf2ekDS0/https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fregext

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 14 Jul 2021 11:05:54 -0400

> Le 14 juill. 2021 à 09:26, Gould, James <[email-masked]> a écrit :
> 
> Marc,
>  

Fine by me! Much better to me.

Marc.

>> Le 12 juill. 2021 à 07:26, Gould, James <[email-masked] <mailto:[email-masked]>> a écrit :
>>  
>> 
> Fine but that does not preclude the use of an IANA registry with reserved text. We already have that: https://www.iana.org/assignments/rdap-json-values/rdap-json-values.xhtml <https://secure-web.cisco.com/1CpBTBaAbWXShtu3I3CgJpJu24mEs9ljN-JZFzuDsQTI3FxgaWMmOrd_t3tvEV72gkQmb5znPpgnRyT4kmZRJDIqFHqcz9Bbyvg57xwiJfZd-N4xqddAw5eLmk_K28myevtwarkxyyRc3Nrd_Hv17G7Ps-CwKFwcGPyigFJVrP1aZw9RCvarhO-h-GExrL1MsE7pkowpYOR3h_QrlwfnEBqhicohhvS7BpAyyBnWL6VIuEMdEN5HFDNJ_DAAljli3/https%3A%2F%2Fwww.iana.org%2Fassignments%2Frdap-json-values%2Frdap-json-values.xhtml>.   We can even reuse the same registry and add some rows. Client processing, with reserved words, can act upon: displaying nice icons instead of long words for example. It can also be internationalized.  If it is human readable, then that means the server has to send all the languages translations. Not great.   I’m sure that we can standardized those reason values to less than a dozen.
>  
> Marc.
>  
>> [email-masked] <mailto:[email-masked]> <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>>
>> 
>> 703-948-3271
>> 12061 Bluemont Way
>> Reston, VA 20190
>> 
>> Verisign.com <http://verisign.com/> <http://verisigninc.com/ <http://secure-web.cisco.com/1beQfCbdiRGkXWoDIwEZqB-syrWkxKlPLmKXZ5TyPLcyHJefT1L0kWFy55Ogjue3I0e6sl1LZnrl57ZdbPW70plJDkV1TrXSRiOVelUFiAdeskppvN7dLYDFaa0F4fRnqlN0gf6aXzFlIMbtj7PYNnyai6PheZ2iizECnbbRgkFOPor0IF9oPIALohtLm2Ur5hdrKFF3RqLFts6IzaW8svDPPDK_pHe6KQjPjK63W-Cx_D5Xb_GShrkpr4QQRNZyb/http%3A%2F%2Fverisigninc.com%2F>>
>> 
>> On 7/12/21, 7:15 AM, "Marc Blanchet" <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>>> Le 12 juill. 2021 à 07:02, Gould, James <jgould=[email-masked] <mailto:jgould=[email-masked]>> a écrit :
>>> 
>>> [email-masked] <mailto:[email-masked]> <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked] <applewebdata://13890C55-AAE8-4BF3-A6CE-B4BA42740803/[email-masked]>>
>>> 
>>> 703-948-3271
>>> 12061 Bluemont Way
>>> Reston, VA 20190
>>> 
>>> Verisign.com <http://verisign.com/> <http://secure-web.cisco.com/1mjljSszRHMWBBWiVRrUMrhOUeWm_mQQZEornOV0IrqHX9vEnx-RCoWBk3Zda8WqCNRU2NgrG-u3RKtOxjaTIW2NQLrnU8qmJM0TdYVjnXN4tq91ifewAp8_CuiyCLw6D7pv86v_tMUzLbq-kK-UEKMjw1YjiruuDEgLNYp1REtcP41bcKqFQ78Vfk0NDCZffn1KMxVw3qsSCX0lghUob_fR3sL9B3rSsac77K29Rvaq_6-YuWGw8mpL_8Gsf5msC/http%3A%2F%2Fverisigninc.com%2F <http://secure-web.cisco.com/1mjljSszRHMWBBWiVRrUMrhOUeWm_mQQZEornOV0IrqHX9vEnx-RCoWBk3Zda8WqCNRU2NgrG-u3RKtOxjaTIW2NQLrnU8qmJM0TdYVjnXN4tq91ifewAp8_CuiyCLw6D7pv86v_tMUzLbq-kK-UEKMjw1YjiruuDEgLNYp1REtcP41bcKqFQ78Vfk0NDCZffn1KMxVw3qsSCX0lghUob_fR3sL9B3rSsac77K29Rvaq_6-YuWGw8mpL_8Gsf5msC/http%3A%2F%2Fverisigninc.com%2F>>
>>> 
>>> On 7/12/21, 6:47 AM, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>>   URL:            https://secure-web.cisco.com/1K328CySVpeAdQz8KNkRu7ncZhdPUaP8fTNul1LMbiFUNsZqIiaoBcPF_OjIj35fkwT9gDpIgI0UtjP0gvmatvP7d36VCx0jJYMqBEmzxelQ-PIg05Xfql3NqrTwSL4Q0rFMFYnngRChk0aHwtRt906uYqS23NjDteP_jrqxZQGqLQKBOv5Vgb43XRE8Ihgi27Ri4OozGV8C0GXEqGrZ7b95LpT-V-dDS3cIXEQUtIo-eTKJ-ZWGQKtVrYCNA9LBg/https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-gould-regext-rdap-redacted-00.txt <https://secure-web.cisco.com/1K328CySVpeAdQz8KNkRu7ncZhdPUaP8fTNul1LMbiFUNsZqIiaoBcPF_OjIj35fkwT9gDpIgI0UtjP0gvmatvP7d36VCx0jJYMqBEmzxelQ-PIg05Xfql3NqrTwSL4Q0rFMFYnngRChk0aHwtRt906uYqS23NjDteP_jrqxZQGqLQKBOv5Vgb43XRE8Ihgi27Ri4OozGV8C0GXEqGrZ7b95LpT-V-dDS3cIXEQUtIo-eTKJ-ZWGQKtVrYCNA9LBg/https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-gould-regext-rdap-redacted-00.txt>
>>>   Status:         https://secure-web.cisco.com/1XGKSPZDnB5CHFRYeBm5qN0ACnFvTe1ZG2O2llFvSrZi7q2nOKGpyNnv6E_m3_MO7ccF7VFbViZPAwR4-AhBS-dsgLlgR1UWs2nad61Rru2hB4B4t9trR3YvtBbMbIodX7jHHjrS9fI-dpAMLzEEana8BOyRiZ39Ri-bvZ5UE_IFT9l3WqspNfRqWS9oSUFqY-vVM_ewYcTLOwSxMvY7FXlWt6BqjHa2qdBNgIIZeu7bRKJ5BQ06B4AIe9y0IyRKd/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-gould-regext-rdap-redacted <https://secure-web.cisco.com/1XGKSPZDnB5CHFRYeBm5qN0ACnFvTe1ZG2O2llFvSrZi7q2nOKGpyNnv6E_m3_MO7ccF7VFbViZPAwR4-AhBS-dsgLlgR1UWs2nad61Rru2hB4B4t9trR3YvtBbMbIodX7jHHjrS9fI-dpAMLzEEana8BOyRiZ39Ri-bvZ5UE_IFT9l3WqspNfRqWS9oSUFqY-vVM_ewYcTLOwSxMvY7FXlWt6BqjHa2qdBNgIIZeu7bRKJ5BQ06B4AIe9y0IyRKd/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-gould-regext-rdap-redacted>
>>>   Html:           https://secure-web.cisco.com/1B_5eD2QiPrj83T06F7L4QtU3TiyBUmvF_j2dCXin9B7g8aMHESwA458zvkfsNCSZ3H37ObhlCl4HDgTiq7FCk0m7tAWuFQNAMEz0gzbNML-5hfGMJS-SZMuc6OuAnS8mkBUX_yXOBGkWsB1aiFk9UNolX6_o5zxWepxXz9nn-00BrxxTi1kyaRTiPZNpjLbdBMA2T4pNfhbpIfvRnlq-ewNw77MmMocKIy0Out4Cqwdx_6T6yGu-QwVjoPehH4Pt/https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-gould-regext-rdap-redacted-00.html <https://secure-web.cisco.com/1B_5eD2QiPrj83T06F7L4QtU3TiyBUmvF_j2dCXin9B7g8aMHESwA458zvkfsNCSZ3H37ObhlCl4HDgTiq7FCk0m7tAWuFQNAMEz0gzbNML-5hfGMJS-SZMuc6OuAnS8mkBUX_yXOBGkWsB1aiFk9UNolX6_o5zxWepxXz9nn-00BrxxTi1kyaRTiPZNpjLbdBMA2T4pNfhbpIfvRnlq-ewNw77MmMocKIy0Out4Cqwdx_6T6yGu-QwVjoPehH4Pt/https%3A%2F%2Fwww.ietf.org%2Farchive%2Fid%2Fdraft-gould-regext-rdap-redacted-00.html>
>>>   Htmlized:       https://secure-web.cisco.com/1p7JRanlgcayeNYcfSxig8HPTMLyO10UtuXnj8prHHxr5LSwZTK_a-LVs8jabLArSP8K_rmlxZ1UXoHYVMmGFjCculzG_bqoCTMIdWMI3hZ2nNAgnlOeQ9Py-vf3Jw_R533LAJqInMLvnEvhSaQlcJWdR7ttfJNgVhe04-dcLQt5GX8eCG-_W4P8LLeD1v8jcEH0CxWlSoiZ1Mfo-4sI5sOAnym_uiUApuKbmHO5njJY85ABtWiPCmHlxlVZghFOL/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-gould-regext-rdap-redacted <https://secure-web.cisco.com/1p7JRanlgcayeNYcfSxig8HPTMLyO10UtuXnj8prHHxr5LSwZTK_a-LVs8jabLArSP8K_rmlxZ1UXoHYVMmGFjCculzG_bqoCTMIdWMI3hZ2nNAgnlOeQ9Py-vf3Jw_R533LAJqInMLvnEvhSaQlcJWdR7ttfJNgVhe04-dcLQt5GX8eCG-_W4P8LLeD1v8jcEH0CxWlSoiZ1Mfo-4sI5sOAnym_uiUApuKbmHO5njJY85ABtWiPCmHlxlVZghFOL/https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fhtml%2Fdraft-gould-regext-rdap-redacted>
>>> 
>>> 
>>>   Abstract:
>>> [email-masked] <mailto:[email-masked]>