Subject: [rbridge] draft-eastlake-trill-00

From: "Jeff Pickering" <[email-masked]>
Date: Thu, 17 Jun 2010 13:02:58 -0700

In the text:

2.5 TRILL Neighbor TLV

   The TRILL Neighbor TLV is used in TRILL-Hellos (see Section 4.1<http://tools.ietf.org/html/draft-eastlake-isis-trill-00#section-4.1>

   below) in place of the IS Neighbor TLV, as specified in Section<http://tools.ietf.org/html/draft-eastlake-isis-trill-00#section->

   4.4.2.1<http://tools.ietf.org/html/draft-eastlake-isis-trill-00#section-> of [RFCtrill<http://tools.ietf.org/html/draft-eastlake-isis-trill-00#ref-RFCtrill>].  This TLV can occur zero, one, or multiple

   times in a TRILL-Hello.  The structure of the TRILL Neighbor TLV is

   as follows:

   +-+-+-+-+-+-+-+-+

   | Type = TNeigh |                  (1 byte)

   +-+-+-+-+-+-+-+-+

   |   Length      |                  (1 byte)

   +-+-+-+-+-+-+-+-+

   |S|L|  RESV     |                  (1 byte)

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                Neighbor RECORDS (1)                           |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                   .................                           |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                Neighbor RECORDS (N)                           |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   The list of neighbors MUST be ordered by MAC address, considering

   each 6-byte MAC address to be an unsigned integer, starting with the

   smallest.  The information present for each neighbor is as follows:

   +-+-+-+-+-+-+-+-+

   |F|  RESV       |                (1 bytes)

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |       MTU                   |  (2 bytes)

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+...+-+-+-+-+-+-+

   |   MAC Address                                       | (6 bytes)

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+...+-+-+-+-+-+-+

   o  Type: TLV Type, set to TRILL-Neighbor TLV 145 [TBD].

   o  Length: 2 + 9*n, where n is the number of neighbor records.

Should length be 1+9*n or is the RESV field 2 bytes?

Jeff
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 17 Jun 2010 19:25:55 -0400

Hi Jeff,

That's draft-eastlake-isis-trill-00 but otherwise, you are completely
correct. The RESV area used to fill two bytes (minus the S and L bits). When
it was reduced to one byte, the length expression was not adjusted.

Thanks,
Donald

On Thu, Jun 17, 2010 at 4:02 PM, Jeff Pickering <[email-masked]>wrote:

>  In the text:
>
>
>
>
>
> 2.5 TRILL Neighbor TLV
>
>
>
>    The TRILL Neighbor TLV is used in TRILL-Hellos (see Section 4.1 <http://tools.ietf.org/html/draft-eastlake-isis-trill-00#section-4.1>
>
>    below) in place of the IS Neighbor TLV, as specified in Section <http://tools.ietf.org/html/draft-eastlake-isis-trill-00#section->
>
>    4.4.2.1 <http://tools.ietf.org/html/draft-eastlake-isis-trill-00#section-> of [RFCtrill <http://tools.ietf.org/html/draft-eastlake-isis-trill-00#ref-RFCtrill>].  This TLV can occur zero, one, or multiple
>

Jeff